Sun-One Platform JMS (client-side jar?)

Does anyone know if there is a JMS client-side jar file for
the Sun-One Platform Edition?

On Solaris they live in /usr/share/lib
they are:
jms.jar
and
imq.jar

Similar Messages

  • Client Side Jar

    Hi folks,
    in the days of the good old 5.1 release there where rumors and promises
    about a as-thin-as-possible-jar-file for client side usage containing
    just the classes a swing client would need. I did not find this magic
    jar in 6.0 and 6.1. Is there being worked on? Is there a list of
    packages I can safely remove from the giant weblogic.jar in order to cut
    it to a WebStart-with-dialup compatible size of let's say 2-5mb? Please
    don't point me to verbose2zip, I won't spend weeks on finding every
    possible way through WebLogic code ... :-)
    Thanks for any insight!
    Daniel

    That's an easy one ;-). Include the original MANIFEST.MF in the
    generated jar.
    Daniel
    -----Original Message-----
    From: Nick Minnutello
    [mailto:[email protected]]
    Posted At: Friday, August 31, 2001 3:04 AM
    Posted To: misc
    Conversation: Client Side Jar
    Subject: Re: Client Side Jar
    Please let me know how you get on.
    You can email me if you like.
    We too are deploying our apps via JWS, and a 25MB jar will
    drive the users
    nuts, let alone us when we want to access the server in Hong Kong..!
    I had problems with the verboseToZip - I could never get my
    client to start
    up. Is there some other fancy footwork you have to do apart from
    the -verbose and the verboseToZip?
    Do you need to exercise every code path in order to create
    this file? Once
    you have done a JNDI lookip, a few RMI calls, caught an
    exception or two,
    what else is there ? (I guess that you are using JMS and
    FileT3 which makes
    it more complicated). However, for straight RMI, is there
    that big a risk?
    I got a stack trace of:
    Any clues anyone?
    (I understand that a thin-client jar is on its way soon)
    --------stack trace-------------------
    java.lang.InternalError: error initializing kernel
    at weblogic.kernel.Kernel.ensureInitialized(Kernel.java:85)
    at
    weblogic.jndi.WLInitialContextFactoryDelegate.<init>(WLInitial
    ContextFactory
    Delegate.java:161)
    at java.lang.Class.newInstance0(Native Method)
    at java.lang.Class.newInstance(Unknown Source)
    at
    weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInit
    ialContextFact
    ory.java:119)
    at javax.naming.spi.NamingManager.getInitialContext(Unknown Source)
    at javax.naming.InitialContext.getDefaultInitCtx(Unknown Source)
    at javax.naming.InitialContext.init(Unknown Source)
    at javax.naming.InitialContext.<init>(Unknown Source)
    at
    com.bnpparibas.eqd.stingray.mantaray.servercontext.AbstractSer
    verContext.<in
    it>(AbstractServerContext.java:65)
    at
    com.bnpparibas.eqd.stingray.mantaray.servercontext.WebLogicCon
    text.<init>(We
    bLogicContext.java:35)
    at
    com.bnpparibas.eqd.stingray.mantaray.servercontext.ServerConte
    xtFactory.crea
    te(ServerContextFactory.java:34)
    at
    com.bnpparibas.eqd.stingray.mantaray.beans.ViewFactory.getCurr
    encies(ViewFac
    tory.java:247)
    at
    com.bnpparibas.eqd.stingray.mantaray.beans.ViewFactory.createT
    ree(ViewFactor
    y.java:206)
    at
    com.bnpparibas.eqd.stingray.mantaray.beans.ViewFactory.<init>(
    ViewFactory.ja
    va:61)
    at
    com.bnpparibas.eqd.stingray.mantaray.MantaViewManager.initaliz
    e(MantaViewMan
    ager.java:24)
    at
    com.bnpparibas.eqd.stingray.mantaray.MantaMainFrame.initialise
    (MantaMainFram
    e.java:114)
    at
    com.bnpparibas.eqd.stingray.mantaray.MantaMainFrame.<init>(Man
    taMainFrame.ja
    va:56)
    at
    com.bnpparibas.eqd.stingray.mantaray.MantaMainFrame.getInstanc
    e(MantaMainFra
    me.java:63)
    at com.bnpparibas.eqd.stingray.mantaray.Manta.main(Manta.java:61)
    at java.lang.reflect.Method.invoke(Native Method)
    at com.sun.javaws.Launcher.executeApplication(Launcher.java:701)
    at com.sun.javaws.Launcher.executeMainClass(Launcher.java:663)
    at com.sun.javaws.Launcher.continueLaunch(Launcher.java:546)
    at com.sun.javaws.Launcher.handleApplicationDesc(Launcher.java:334)
    at com.sun.javaws.Launcher.handleLaunchFile(Launcher.java:151)
    at com.sun.javaws.Launcher.<init>(Launcher.java:113)
    at com.sun.javaws.Main.main(Main.java:153)
    "Daniel Hoppe" <[email protected]> wrote in message
    news:[email protected]...
    Thanks for the tip. Actually I have a fat swing-gui client which uses
    quite a lot of features, T3 File Systems, EJB Calls, JMS etc.. I'm
    afraid the Web Services client jar won't help me here.
    I need to distribute it via WebStart, that's why the whole weblogic.jar
    is just not acceptable. I used to use java -verbose and verboseToZip,
    but that's a quite dangerous strategy, I can never be sure that I really
    covered every codepath. I guess I will open a case and see if that
    helps. Maybe I can at least get a change request for a future version...
    Daniel
    -----Original Message-----
    From: Dimitri Rakitine [mailto:[email protected]]
    Posted At: Monday, August 27, 2001 10:09 PM
    Posted To: misc
    Conversation: Client Side Jar
    Subject: Re: Client Side Jar
    6.1 does create small client jar if you use web services :
    http://e-docs.bea.com/wls/docs61/webServices/client.html#1036653
    Daniel Hoppe <[email protected]> wrote:
    Hi folks,
    in the days of the good old 5.1 release there where rumorsand promises
    about a as-thin-as-possible-jar-file for client side usagecontaining
    just the classes a swing client would need. I did not findthis magic
    jar in 6.0 and 6.1. Is there being worked on? Is there a list of
    packages I can safely remove from the giant weblogic.jar inorder to cut
    it to a WebStart-with-dialup compatible size of let's say2-5mb? Please
    don't point me to verbose2zip, I won't spend weeks on
    finding every
    possible way through WebLogic code ... :-)
    Thanks for any insight!
    Daniel--
    Dimitri

  • Problem starting Sun One Application - JMS Exception

    Hello,
    I'm having some trouble trying to start SunONE JMS sever via the Sun ONE application server v7 running on RedHat Linux 7.3.
    When I start the app server via the asadmin tool I receive the following exception,
    [root@sc-test1 config]# asadmin start-appserv
    Instance domain1:admin-server started
    Could not start the instance: domain1:server1
    server failed to start: abnormal subprocess termination
    Could not start one or more instances in the domain : domain1
    Could not start one or more domains
    The following exception is outputted to the server log,
    19/Sep/2003:15:47:14] INFO ( 2135): CORE1116: Sun ONE Application Server 7.0.0_00
    [19/Sep/2003:15:47:15] INFO ( 2137): CORE3016: daemon is running as super-user
    [19/Sep/2003:15:47:17] INFO ( 2137): CORE5076: Using [Java HotSpot(TM) Server VM, Version 1.4.1] from [Sun Microsystems Inc.]
    [19/Sep/2003:15:47:54] INFO ( 2137): JMS5035: Timed out after 30000 milliseconds while trying to verify if the JMS service startup succeeded.
    [19/Sep/2003:15:47:54] INFO ( 2137): JMS5036: More details may be available in the log file for the JMS service broker instance domain1_server1. Please refer to the JMS provider documentation for the exact location of this log file.
    [19/Sep/2003:15:47:54] SEVERE ( 2137): JMS5024: JMS service startup failed.
    [19/Sep/2003:15:47:54] SEVERE ( 2137): CORE5071: An error occurred during initialization
    com.sun.appserv.server.ServerLifecycleException: [C4003]: Error occurred on connection creation. - caught java.net.ConnectException
    at com.iplanet.ias.jms.JmsProviderLifecycle.onInitialization(JmsProviderLifecycle.java:247)
    at com.iplanet.ias.server.ApplicationServer.onInitialization(ApplicationServer.java:206)
    at com.iplanet.ias.server.J2EERunner.confPreInit(J2EERunner.java:114)
    Caused by: com.sun.appserv.server.ServerLifecycleException: [C4003]: Error occurred on connection creation. - caught java.net.ConnectException
    at com.iplanet.ias.jms.JmsProviderLifecycle.onInitialization(JmsProviderLifecycle.java:231)
    ... 2 more
    Caused by: javax.jms.JMSException: [C4003]: Error occurred on connection creation. - caught java.net.ConnectException
    at com.sun.messaging.jmq.jmsclient.ExceptionHandler.getJMSException(ExceptionHandler.java:183)
    at com.sun.messaging.jmq.jmsclient.ExceptionHandler.handleException(ExceptionHandler.java:136)
    at com.sun.messaging.jmq.jmsclient.PortMapperClient.readBrokerPorts(PortMapperClient.java:145)
    at com.sun.messaging.jmq.jmsclient.PortMapperClient.init(PortMapperClient.java:86)
    at com.sun.messaging.jmq.jmsclient.PortMapperClient.<init>(PortMapperClient.java:47)
    at com.sun.messaging.jmq.jmsclient.protocol.tcp.TCPConnectionHandler.<init>(TCPConnectionHandler.java:46)
    at com.sun.messaging.jmq.jmsclient.protocol.tcp.TCPStreamHandler.openConnection(TCPStreamHandler.java:101)
    at com.sun.messaging.jmq.jmsclient.ProtocolHandler.init(ProtocolHandler.java:501)
    at com.sun.messaging.jmq.jmsclient.ProtocolHandler.<init>(ProtocolHandler.java:930)
    at com.sun.messaging.jmq.jmsclient.ConnectionImpl.openConnection(ConnectionImpl.java:1482)
    at com.sun.messaging.jmq.jmsclient.ConnectionImpl.init(ConnectionImpl.java:403)
    at com.sun.messaging.jmq.jmsclient.ConnectionImpl.<init>(ConnectionImpl.java:234)
    at com.sun.messaging.jmq.jmsclient.UnifiedConnectionImpl.<init>(UnifiedConnectionImpl.java:33)
    at com.sun.messaging.jmq.jmsclient.QueueConnectionImpl.<init>(QueueConnectionImpl.java:32)
    at com.sun.messaging.ConnectionFactory.createQueueConnection(ConnectionFactory.java:72)
    at com.sun.messaging.jmq.admin.jmsspi.JMSAdminImpl.pingProvider(JMSAdminImpl.java:733)
    at com.iplanet.ias.jms.JmsProviderLifecycle.waitForJmsProvider(JmsProviderLifecycle.java:284)
    at com.iplanet.ias.jms.JmsProviderLifecycle.onInitialization(JmsProviderLifecycle.java:224)
    ... 2 more
    [19/Sep/2003:15:47:54] SEVERE ( 2137): CORE3186: Failed to set configuration
    I can confirm that the default JMS port (7676) is not be used elsewhere / by another process on the server and that netfilter/iptables are not active/running.
    I have also tried different/alternative ports for the JMS server however it still fails to startup.
    Any help much appreciated.
    Thanks and Regards,
    Rachel Gilmer

    I have encountered similar problem when running Sun Application server 7 in Fedora Core 2.
    It seems that problem was due to improper shutdown of my system.
    Following was what I did to resolve the problem:
    Look for the JMS installation directory (installed & created together with the application server). Mine is in /var/opt/imq. In the dir,
    look for directory instances/domain1_server1 (if your server is running in domain1 server1). Look for a file called lock. Remove the lock file (rename if you are not sure).
    After that I was able to successfully start the server.

  • Client side weblogic.management jar

    Hi,
    Could you help me with the following issue?
    I am writing a simple mgmt application that uses Weblogic's JMX APIs remotely
    via JNDI/RMI either from another VM on the same or another box (no firewall issues).
    All is fine except that the weblogic.management interfaces, stubs, and skeletons
    are all part of the huge weblogic.jar.
    Do you know where I can find a client side classes for weblogic.management? I
    noticed that the Weblogic 8.1 distribution comes with client side jars for other
    APIS (e.g. JMS, Web services, EJB etc.) but cannot find one for JMX.
    Thanks a lot for any insight on this,
    Piotr

    Hi Piotr,
    I do not believe there is a client side jar for wl management. This is
    being considered for our next release.
    Thanks,
    -satya
    Piotr Krychniak wrote:
    Hi,
    Could you help me with the following issue?
    I am writing a simple mgmt application that uses Weblogic's JMX APIs remotely
    via JNDI/RMI either from another VM on the same or another box (no firewall issues).
    All is fine except that the weblogic.management interfaces, stubs, and skeletons
    are all part of the huge weblogic.jar.
    Do you know where I can find a client side classes for weblogic.management? I
    noticed that the Weblogic 8.1 distribution comes with client side jars for other
    APIS (e.g. JMS, Web services, EJB etc.) but cannot find one for JMX.
    Thanks a lot for any insight on this,
    Piotr

  • Does Sun ONE AS has built-in SOAP engine

    Hi,
    This is Shankar from Chennai (India).
    Out company provide solution on Sun ONE platform to all our clients. I have installed Apache SOAP on Sun ONE AS and implemented a smalll web service application.
    I would like to know whether Sun ONE AS comes with a built-int SOAP engine? Do we need to depend on Apache SOAP?
    Thanks in Adavance,
    Shankar Shamugam

    Yes, Sun ONE Application Server 7 includes a built in SOAP runtime. Supporting both RPC and messaging styles. See the sample applications under <install_dir>/samples/webservices/.
    You do not need to use Apache SOAP on top of the app server in order to support SOAP. (However, one can run most any of the 3rd party SOAP implementations on top of the Sun ONE Application Server 7 web container).
    The integrated SOAP implementation in Sun ONE Application Server supports the JAX-RPC and JAXM API standards for web services.
    Thanks,
    Chris

  • Sun One deploy from 9.0.3

    Is there a way to deploy from jdev to a sun one server using an admin jar and appserver connection? other than copying over the war/ear file, I mean ...

    There is no built-in one click deployment to Sunone from 9.0.3
    You might be able to use the external tools option to invoke some script that will take the needed files and deploy them.

  • JMS Exception at Client Side

    Hi All
    We have application consisting of applets
    a) We have signed the Application JAR (CA ) and put in the below attributes in the manifest file
    Codebase: <<CodebasePath>>
    Application-Library-Allowable-Codebase: <<CodebasePath>>
    permissions: all-permissions
    b) We use the wlclient.jar and wljmsclient.jar as well. For these JARS we have added the below attribute in the manifest file
    Permissions: all-permissions
    c) We are getting exceptions at the client side while launching the application ( JRE is 1.6.0_51)
    Exception in initJMS()>>>>>>>>>>>>>>>
    javax.naming.NamingException: Unhandled exception in lookup [Root exception is org.omg.CORBA.NO_PERMISSION:   vmcid: 0x0  minor code: 0  completed: No]
      at weblogic.corba.j2ee.naming.Utils.wrapNamingException(Utils.java:83)
      at weblogic.corba.j2ee.naming.ContextImpl.lookup(ContextImpl.java:232)
      at weblogic.corba.j2ee.naming.ContextImpl.lookup(ContextImpl.java:168)
      at javax.naming.InitialContext.lookup(Unknown Source)
      at com.orbitreasury.moneymarket.presentation.util.MessagingServiceFactory.initJMS(MessagingServiceFactory.java:142)
      at com.orbitreasury.moneymarket.presentation.util.MessagingServiceFactory.<init>(MessagingServiceFactory.java:102)
      at com.orbitreasury.moneymarket.presentation.util.MessagingServiceFactory.getInstance(MessagingServiceFactory.java:94)
      at com.orbitreasury.moneymarket.presentation.applet.FrontOfficeDesk.init(FrontOfficeDesk.java:328)
      at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
      at java.lang.Thread.run(Unknown Source)
    Caused by: org.omg.CORBA.NO_PERMISSION:   vmcid: 0x0  minor code: 0  completed: No
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
      at java.lang.reflect.Constructor.newInstance(Unknown Source)
      at java.lang.Class.newInstance0(Unknown Source)
      at java.lang.Class.newInstance(Unknown Source)
      at com.sun.corba.se.impl.protocol.giopmsgheaders.MessageBase.getSystemException(Unknown Source)
      at com.sun.corba.se.impl.protocol.giopmsgheaders.ReplyMessage_1_2.getSystemException(Unknown Source)
      at com.sun.corba.se.impl.protocol.CorbaMessageMediatorImpl.getSystemExceptionReply(Unknown Source)
      at com.sun.corba.se.impl.protocol.CorbaClientRequestDispatcherImpl.processResponse(Unknown Source)
      at com.sun.corba.se.impl.protocol.CorbaClientRequestDispatcherImpl.marshalingComplete(Unknown Source)
      at com.sun.corba.se.impl.protocol.CorbaClientDelegateImpl.invoke(Unknown Source)
      at org.omg.CORBA.portable.ObjectImpl._invoke(Unknown Source)
      at weblogic.corba.cos.naming._NamingContextAnyStub.resolve_any(_NamingContextAnyStub.java:80)
      at weblogic.corba.j2ee.naming.ContextImpl.lookup(ContextImpl.java:208)

    Hi Amitava,
    This error may happen when creating foreign JMS server and user credentials (principal name) is not provided. As a result, Weblogic is unable to create the required JNDI name.
    To rectify the error you can provide principal name in the JMS Configuration and restart Weblogic. See the following for sample configuration required:
    <foreign-server name="ForeignServer">
    <sub-deployment-name>subDep</sub-deployment-name>
    <foreign-destination name="ForeignDestination">
    <local-jndi-name>localQueue</local-jndi-name>
    <remote-jndi-name>remoteQueue</remote-jndi-name>
    </foreign-destination>
    <foreign-connection-factory name="ForeignConnectionFactory-0">
    <local-jndi-name>localJNDI</local-jndi-name>
    <remote-jndi-name>remoteJNDI</remote-jndi-name>
    </foreign-connection-factory>
    <connection-url>t3://localhost:7010</connection-url>
    <jndi-properties-credential-encrypted>{3DES}yK0ERotSucIGRVFORfS4Kw==</jndi-properties-credential-encrypted>
    <jndi-property>
    <key>java.naming.security.principal</key>
    <value>weblogic</value>
    </jndi-property>
    </foreign-server>
    Refer to documentation below for more details:
    http://download.oracle.com/docs/cd/E12840_01/wls/docs103/jms_admin/advance_config.html#wp1075917
    Hope it helps.
    Thanks,
    Cris

  • Getting Sun ONE Initial Context from standalone client

    Hi,
    I'm having problems connecting to Sun One's JNDI from a standalone client ... I've seen other topics raised with similar problems but with no real answers.
    I can connect to what i think is a different JNDI resource with:
    Hashtable env = new Hashtable();
    env.put(javax.naming.Context.INITIAL_CONTEXT_FACTORY,           "com.sun.jndi.cosnaming.CNCtxFactory");
    env.put("java.naming.provider.url", "iiop://localhost:3700");
    jndiContext = new InitialContext(env);
    But this JNDI does not hold my JMS resources (connection factories, queues, etc) ??? Am i connecting to the wrong port??
    I've tried to look at the documentation but with no success.
    Any ideas?
    cheers,
    Chico.

    Where did you get port 58058 from?
    When trying to run:
    java -Dorg.omg.CORBA.ORBInitialHost=localhost -Dorg.omg.CORBA.ORBInitialPort=58058 SimpleJNDITest
    I got this exception:
    Exception in thread "main" javax.naming.CommunicationException: Cannot connect to ORB.
    Root exception is org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
    This is my JNDI Test source:
    import javax.jms.*;
    import javax.naming.*;
    import java.util.*;
    import org.omg.CORBA.ORB;
    public class SimpleJNDITest {
    public static void main(String[] args) throws Exception {
              SimpleJNDITest t = new SimpleJNDITest();
              t.runTest();
         public void runTest() throws Exception {
              //Invoking -> java -Dorg.omg.CORBA.ORBInitialHost=localhost -Dorg.omg.CORBA.ORBInitialPort=58058 SimpleJNDITest
              // Results in the exception
              // Exception in thread "main" javax.naming.CommunicationException: Cannot connect to ORB.
              // Root exception is org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code: 201 completed: No
              Context jndiContext = new InitialContext();
    // -----> Alternative 1
              // This gets the JNDI Context, but the JNDI context does not hold JMS resources
              Hashtable env = new Hashtable();
         env.put(javax.naming.Context.INITIAL_CONTEXT_FACTORY, "com.sun.jndi.cosnaming.CNCtxFactory");
         env.put("java.naming.provider.url", "iiop://localhost:3700");
              Context jndiContext = new InitialContext(env);
    // -----> Alternative 2
              // This gets the JNDI Context, but the JNDI context does not hold JMS resources
              String[] orbArgs = {"-ORBInitialPort", "3700", "-ORBInitialHost", "localhost"};
              ORB orb = ORB.init(orbArgs, null);
              Hashtable env = new Hashtable();
         env.put(javax.naming.Context.INITIAL_CONTEXT_FACTORY, "com.sun.jndi.cosnaming.CNCtxFactory");
              env.put("java.naming.corba.orb", orb );
              Context jndiContext = new InitialContext(env);
    // -----> Alternative 3
              /* This gets the following exception:
              Exception in thread "main" javax.naming.CommunicationException: Cannot connect to ORB.
              Root exception is org.omg.CORBA.COMM_FAILURE: vmcid: SUN minor code:     201 completed: No
              String[] orbArgs = {"-ORBInitialPort", "58058", "-ORBInitialHost", "localhost"};
              ORB orb = ORB.init(orbArgs, null);
              Hashtable env = new Hashtable();
         env.put(javax.naming.Context.INITIAL_CONTEXT_FACTORY, "com.sun.jndi.cosnaming.CNCtxFactory");
              env.put("java.naming.corba.orb", orb );
              Context jndiContext = new InitialContext(env);
              StringBuffer sb = new StringBuffer();
              list(jndiContext, sb);
              System.out.println(sb.toString());
         public void list(Context ctx,StringBuffer sb) {
              try {
                   NamingEnumeration enum = ctx.listBindings("");
                   while (enum.hasMore()) {
                        Binding binding = (Binding)enum.next();
                        Object obj = (Object)binding.getObject();
                        if (obj instanceof Context) {
                             sb.append("---> ");
                             sb.append(binding.getName());
                             sb.append(".");
                             list((Context)obj,sb);
                        } else {
                             sb.append(binding.getName()); sb.append("\n");
              } catch (NamingException e) {
                   System.out.println(e);
    Cheers,
    Chico

  • Sun ONE Message Queue and JMS

    Is Sun ONE Message Queue software a reference implementation or a
    product?

    Sun ONE Message Queue is a product. It is a production implementation of the JMS
    specification. Sun ONE Message Queue software performs the function of a message
    broker, essentially serving as a common denominator enabling the exchange of
    information between applications. A number of competing products perform this same
    function, but Sun ONE Message Queue software adds the availability of JMS APIs to
    promote an open, industry-standard interface to messaging middleware, thus
    promoting the platform interoperability of Java while also enabling developers of
    business applications to write to only a single interface. In and of itself, this does not
    make Sun ONE Message Queue software unique since other MOM products also
    conform to the JMS specification. However, the combination of JMS with high
    performance, low cost, ease of use, and Sun's world class distribution and support
    channels makes Sun ONE Message Queue software a highly competitive product.

  • Stub j2ee.jar to jms-client.jar?

    I'd like to be able to run a JMS client w/ only those j2ee.jar classes relevant to a JMS client. The j2ee.jar file is about 8 MB and contains everything under the sun. It would be nice to have a JMS client jar file under 500 KB that contains only those classes relevant to a JMS client.
    Has anyone tried to create a jms-client.jar from the j2ee.jar that contains only the necessary classes to run a JMS client?
    thanks

    I was able to create a 1.1 MB jar file that can run my JMS client.
    First I ran my JMSClient with the -verbose:gc option against the j2ee.jar. With a simple java app I parsed the loaded classes list, copied all these classes to a temp dir and then created the jar file.

  • Creating JAR of an ejb from sun one studio 5.0

    I�ve got the following error when I�m trying to generate the jar of and ejb from sun one studio 5.0. What�s the problem?
    org/w3c/dom/Document.java [0:0] No file named org/w3c/dom/Document.java exists on disk in src.zip.
    Therefore it may not be compiled with an external compiler.
    You may need to check it out from version control or save some changes to it.
    com/ssos/ejb/information/EJBModule_InformationEJB.ejbmodule [0:0] Problem compiling class: "org/w3c/dom/Document" reason: Compile failed
    Called From: com/iplanet/services/util/XMLParser
    Called From: com/iplanet/services/ldap/DSConfigMgr
    Called From: com/iplanet/services/util/I18n
    Called From: com/iplanet/sso/SSOTokenManager
    Called From: com/iplanet/am/sdk/AMCommonUtils
    Called From: com/iplanet/am/sdk/AMException
    Called From: com/iplanet/dpro/session/service/SessionService
    Called From: com/iplanet/services/naming/WebtopNaming
    Called From: com/iplanet/dpro/session/SessionID
    Called From: com/iplanet/dpro/session/Session
    Called From: com/iplanet/am/util/Locale
    Called From: com/iplanet/sso/SSOException
    Called From: com/iplanet/sso/SSOToken
    Called From: com/ssos/ejb/information/LocalInformationEJB
    Errors compiling EJBModule_InformationEJB.

    Hep, we have the same problem. I am still trying to figure out why. I have some idea about the reason but I am testing my founding. It seems to me that the problem shows up when I add my database driver in Runtime/Databases/drivers tree (IBM DB2 driver: db2jcc.jar)
    Like I am saying I am still checking the connection. When I am convinced that indeed that is the problem, I will then try to find out why and what to do to make my life easier.
    clogon

  • Which clients are using my Sun One server for authentication?

    We use Sun One ver. 5.2 .
    Our LDAP clients use it for authentication.
    How can I list which clients recently used the Sun One server to authenticate?
    The reason I need that is because I want to upgrade the Sun One server and I want to notify the clients that I'm about to do it.
    Thanks.

    https://www.redhat.com/archives/fedora-directory-users/2005-September/msg00010.html
    Useful script to extract LDAP based user posixGroup memberships information
    ===
    Assuming you are using posixGroup objectclass and memberUid attribute to
    store your membership information, you may find my shell script useful
    and handy.
    It works on Solaris LDAP Client with "ldapaddent" and "ldaplist"
    commands, and works against FDS, SUN DS or OpenLDAP.
    ===
    Gary

  • ACE in one-arm model. VIP on Client Side, servers in other vlan

    Hello All
    i have a LAN whit many servers,but only 2 need to be balanced. So i think in one-arm model, due to the higth trafic that not be pass trought ACE.
    i have a vlan 900 where is the client side and the VIP also. (10.0.9.64/26)
    the servers are in vlan 503 (10.12.3.0/24)
    it mi first design with ONE-arm but i thinks something is missing, because doesn't work.
    the configuration is the next:
    MSFC:
    svclc module 1 vlan-group 1,2,
    svclc vlan-group 1 503,900-902
    svclc vlan-group 2 511
    interface Vlan503
    description OSS_&_Otros
    ip address 10.12.3.253 255.255.255.0
    standby 10 ip 10.12.3.254
    standby 10 priority 150
    standby 10 preempt delay minimum 305
    interface Vlan900
    description MSF_<->_ACE
    ip address 10.0.9.126 255.255.255.192
    end
    access-list 101 permit ip 10.12.3.0 0.0.0.255 10.0.9.64 0.0.0.63
    access-list 101 deny ip any any
    route-map From_Server_OSS_to_ACE permit 10
    match ip address 101
    set ip next-hop 10.0.9.125
    ACE_1/admin#
    ip route 0.0.0.0 0.0.0.0 10.0.9.126
    context OSS
    allocate-interface vlan 511
    allocate-interface vlan 900
    allocate-interface vlan 902
    member Max20
    ACE_1/OSS# sh run
    Generating configuration....
    access-list EVERYONE line 10 extended permit ip any any
    access-list EVERYONE line 20 extended permit icmp any any
    rserver host OSS_FES_1
    description OSS_Front_End_Server_1
    ip address 10.12.3.140
    inservice
    rserver host OSS_FES_2
    description OSS_Front_End_Server_2
    ip address 10.12.3.150
    inservice
    serverfarm host SERVER_farm_OSS
    rserver OSS_FES_1
    inservice
    rserver OSS_FES_2
    inservice
    class-map match-all VIP-OSS
    2 match virtual-address 10.0.9.66 any
    policy-map type loadbalance first-match OSS-LB-POLICY
    class class-default
    serverfarm SERVER_farm_OSS
    policy-map multi-match OSS-POLICY-MAP
    class VIP-OSS
    loadbalance vip inservice
    loadbalance policy OSS-LB-POLICY
    loadbalance vip icmp-reply
    interface vlan 900
    description Clients-side
    ip address 10.0.9.125 255.255.255.192
    access-group input EVERYONE
    access-group output EVERYONE
    service-policy input OSS-POLICY-MAP
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.0.9.126
    maybe a i need to allocate the vlan 503 in OSS Context, any advice?
    Thanks in advace,
    Gianni From Chile

    Since you server are not behind the ACE in either bridge or routed mode add the follwoing to your config and use nat to get the traffic back to the ace.
    This is how one-armed mode works.
    ACE_1/OSS# sh run
    Generating configuration....
    access-list EVERYONE line 10 extended permit ip any any
    access-list EVERYONE line 20 extended permit icmp any any
    rserver host OSS_FES_1
    description OSS_Front_End_Server_1
    ip address 10.12.3.140
    inservice
    rserver host OSS_FES_2
    description OSS_Front_End_Server_2
    ip address 10.12.3.150
    inservice
    serverfarm host SERVER_farm_OSS
    rserver OSS_FES_1
    inservice
    rserver OSS_FES_2
    inservice
    class-map match-all VIP-OSS
    2 match virtual-address 10.0.9.66 any
    policy-map type loadbalance first-match OSS-LB-POLICY
    class class-default
    serverfarm SERVER_farm_OSS
    policy-map multi-match OSS-POLICY-MAP
    class VIP-OSS
    loadbalance vip inservice
    loadbalance policy OSS-LB-POLICY
    loadbalance vip icmp-reply
    nat dynamic 10 vlan 900
    interface vlan 900
    description Clients-side
    ip address 10.0.9.125 255.255.255.192
    nat-pool 10 0.9.126 10 0.9.126 netmask 255.255.255.192 pat
    access-group input EVERYONE
    access-group output EVERYONE
    service-policy input OSS-POLICY-MAP
    no shutdown

  • Where is "Sun ONE Application Server Developer's Guide to Clients"

    Hi All,
    "Sun ONE Application Server 7 Developer's Guide " refers
    "Sun ONE Application Server Developer's Guide to Clients" many times. But I can not find it. Where is it?
    Thanks.

    I would also like to know where to find the "Developer's Guide to J2EE Features and Services" ?
    Kind regards, Johann

  • Copy one list items new list using client side object model

    Hi,
    I have a requirement like i need to copy one list information to new list with createdby and modified by fields.I need to use client side object model code.Can u please send me the code sample.
    Regards,
    Praveen

    Hi,
    According to your post, my understanding is that you want to copy one list items new list using client side object model.
    You can use console application.
    Here is a similar thread for your reference:
    https://social.technet.microsoft.com/Forums/sharepoint/en-US/28a43891-7505-4d34-b513-fdd66773c2a3/copy-list-item-to-another-list-using-client-object-model-in-console-application?forum=sharepointdevelopmentprevious
    Best Regards,
    Linda Li
    Linda Li
    TechNet Community Support

Maybe you are looking for