Trouble with dynamically filling fields

I have a large form that contains over 50 pages. The first page is a flowable user input form.
There are several fields which are common with other fields in the various underlying hidden pages. When a user selects an account type from a dropdown list, the appropriate account opening checklist appears as page 2.
The user then selects various checkboxes which then makes the appropriate additional pages visible. Thes additional pages contain fields that should autopopulate based on the data entered in page 1 input form.
The fields that are globally bound are fine. The problem is fields where I need to script to autopopulate. For example, there is a ACH authorization distribution section with 2 checkboxes (one for Checking one for Savings) and one Account number field. The page for ACH data, shows the ABA and Bank Name fine since those are globally bound, but the account number is 2 separate fields that I need to script in order to fill in but it is not working correctly.
I think it is the event I have used but I'm not sure which event is best to place the script in. I started in the initialize event of that page but that doesnt work. If I click the checking/savings checkbox again after the ach page is visible, the field populates.
How do I get the field to be prefilled as soon as it becomes visible?
I am very new to scripting and LC. Any suggestions would be greatly appreciated!

If you are new to scripting I might suggest using the Action Builder. It is a set of prebuilt actions that do not require scripting. If you are using Windows go to the toolbar at the top, go to Tools and select Action Builder. From there you set a condition and a result. From the condition select what field is going to hold the value you want to be copied and select "is not empty" from the first drop down box. Then in the result section select "set value of field" and then select the field that you want the data copied to. In the result section you will then select from the drop down box what you want the value to be and you select "to the value of field" and select your 1st field. This will mirror 2 fields or even multiple fields from 1 box without global binding. What is nice about the Action Builder is if you go to the Script box at the top you can see Livecycle will populate the actual code on the correct show event. This way you can start to see how the code works and build from there.

Similar Messages

  • Trouble with PDF fonts - fields only

    We're having trouble with our PDFs once the data is merged into the PDF template. All of the merged data appears cut in half in the form fields so only the top half of the letters are shown; the rest of the document is fine. We think this could be due to a font issue, but loading different fonts haven't seemed to make any difference. Could this be caused by anything besides the fonts?
    Thanks!
    KH

    Klye
    Pdf is designed for presenting information graphically to reduce the file size. This reduction is achieved by making it an uneditable - something that comes in handy if you don't want people to alter your content.
    You can (using a pdf writter) create pdf forms where information can be added in to a text field or box. However if you want to edit the content from a pdf file then you could select the text and copy and paste it in to a document like Pages or Word and then re-export when you're finished.
    But I'm affraid you can't edit pdf as such - this is the case on Macs and PCs. If you need to edit documents on different platforms then you'll need to find a common editor. There's Office for Mac (student teacher versions) or you could try OpenOffice Org - it's free, works on both Macs and PCs, and will convert most Word documents provided there's not too many tables or a complex layout format.
    Hope this helps
    Stu

  • Printing - With Dynamic Text Fields

    Hello,
    i wonder if anyone can help me........i know there are a lot
    of posts already on how to print out dynamic text but all of them
    seem to be using scrolling text fields.
    However my problem isn't even as complex as this but i still
    can't work it out.
    At the moment i have a form of text boxes which the user
    inputs text.............from here there is a print
    button.........in order to compile all of the answers together i
    have created a movie clip.........with the layout of the printed
    page on it, and placed this on the main timeline. Inside this movie
    clip to be printed i have dynamic text fields...which link to the
    text fields which the users inputted data in, therefore both sets
    of text fields contain the same data, when you change one the other
    should change.
    I have set up a very simple printJob command to print out the
    movie clip named print_mc and it prints the page even the outline
    of the text boxes but it doesn't print out the content which
    appears on the screen. my code is attached below.......please if
    anyone could help i would be very grateful :)
    print_btn.onRelease = function() {
    _global.aOneVar =oneAPone.text;
    _global.aTwoVar =oneAPtwo.text;
    print_mc.gotoAndStop("2");
    var myPrintJob:PrintJob = new PrintJob();
    var result:Boolean = myPrintJob.start();
    if (result) {
    myPrintJob.addPage("print_mc", null, {printAsBitmap:false},
    2);
    myPrintJob.send();
    delete myPrintJob;
    } else {
    thanks

    erictomlinson,
    > So, if I turn off the xml/css and use htmlText to create
    > content for the text field, the text uses the embedded
    > font and is anti-aliased.
    I'm with ya. Presumably, then there's a font symbol in your
    Library,
    right? And its Linkage identifier is "arial_font"?
    > If I keep the xml/css but comment out embedFonts, then
    > the content works but is not anti-aliased.
    That's because your CSS calls for Franklin Gothic Book,
    which hasn't
    been imported into your Library as a font symbol (at least,
    you haven't said
    it has).
    > I need both of these to work at the same time.
    Give Franklin Gothic Book a Linkage identifier, and use that
    name in
    your CSS.
    David Stiller
    Adobe Community Expert
    Dev blog,
    http://www.quip.net/blog/
    "Luck is the residue of good design."

  • Unable to get the data from a website with dynamically filled textboxes when accessing through myWb.Document.GetElementById("num1").InnerText;

    Hi Team,
    I am learning on webbrowser control and during the learning phase i have the following issue:-
    My webbrowser [mywb in this case] is successfully navigating and displaying the website content in webbrowser control. However; that site has three textboxes with dynamically allocated text from asp script
    code behind; I have tried to display these textboxes values by providing the correct id of these textboxes in my visual studio 2013 code; but I am not receiving any data except null. Can you help me on this as early as possible.
    asp code written to dynamically assign the data to textbox:-
    <%
    myvar=Request.form("some")
    Response.write("<input type=text id=num1 value=" + myvar+ ">")
    %>
    The code written in VS 2013 to access the textbox  by its id when the DocumentCompleted event is triggered:-
    string mystr ="";
    mystr = myWb.Document.GetElementById("num1").InnerText;
    MessageBox.Show(mystr);
    Thank You in Advance.
    Regards, Subhash Konduru

    Hello,
    Thank you for your post.
    I am afraid that the issue is out of support range of VS General Question forum which mainly discusses
    the usage of Visual Studio IDE such as WPF & SL designer, Visual Studio Guidance Automation Toolkit, Developer Documentation and Help System
    and Visual Studio Editor.
    Because the issue is related to website, I suggest that you can consult your issue on ASP.NET forum:
    http://forums.asp.net/
     for better solution and support.
    Best regards,
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Trouble with Visible/Invisible Fields on PDF Form

    I created a fillable, calculating pdf form in Adobe Acrobat Pro 9, but ran into some issues, so I'm taking a stab at LiveCycle that I've never used before today.  By reviewing sample template forms, I'm able to pick up the tricks of the trade, but I'm struggling with one particular field.  I got it to calculate and the amount shows in the subtotal, but I don't know why I can't get the field itself to show the amount calculated.
    FS1 is a numeric field where a customer puts square footage.
    Based on the square footage a calculation occurs.  Here is the statement:
    topmostSubform.Page1.Total[1]::calculate - (FormCalc, client)
         Total[1] = 208.75
    elseif (FS1 > 3600) then
         Total[1] = 154.30
    elseif (FS1 > 2000) then
         Total[1] - 136.15
    elseif (FS1 > 0) then
         Total[1] = 99.85
    endif
    When I put in 5000 in the FS1 field, 154.30 is added to the subtotal, but no amount shows in Total[1] field.
    Working with properties in Adobe Acrobat Pro 9 was easy, LiveCycle takes a little more getting used to, so any help is appreciated.
    Thank you.
    if (FS1 > 7200) then    

    You may have just pasted your code in a funny way but I noticed your 'if' statement is underneath the rest of your message. Assuming it is in the correct place and you change "Total[1] - 136.15" to "Total[1] = 136.15" it should work. Also just to let you know that in formcalc you can use the "$" to reference the field you are in (so you could use $ instead of Total[1] in your formula).

  • HELP: Trouble with partial filled arrays

    For HW, I have to write a deleteRepeats static method for an array of characters that deletes any character previously listed and returns the new array size. The example the problem gives is:
    char a[10];
    a[0]='a';
    a[1]='b';
    a[2]='a';
    a[3]='c';
    int size = 4;
    size = deleteRepeats(a, size);
    The problem then says after the code is executed, a[0] should be 'a', a[1] should be 'b', a[2] should be 'c' and size is 3. I read the section in my book on partially filled arrays, but I still can't get this method to work properly. Here is my code:
    public static int deleteRepeats(char[] a, int size) {
    size=a.length;
    for(int i=0; i<size; i++) {
    for(int j=1; i+j<size; j++) {
    if(a==a[i+j]) {
    a[i+j]=a[(i+j)+1];
    size--;
    return size;
    With that code, when I put in the test array [aabcd], it returns 3, when it should be 4 and it changes the array to [abccd]. I'm sure there's numerous problems with my code. Any help is greatly appreciated.

    Please post code in code tags.
    First, I have no idea why they make you work with partially-filled arrays. It seems like the worst idea in the world. You should use ArrayLists for this kind of thing.
    Why do you do "size=a.length;" at the beginning of the method? You lose the size information.
    And I don't see how the algorithm does what you want. When you "delete" an element from your list of numbers in the array, you need to shift all later elements backwards to fill the gap.

  • Trouble with mapping CMR field using Sun One Studio

    I am having trouble adding a cmr between 2 entity beans. It is a simple one to one relationship, navigatable in only one direction. In the database I have a foreign key defined between the two tables that store the data for the beans.
    I add the relation by selecting the 2 beans and define it as one directional, one to one , with the name "bb". I then map the relationship field via the properties/As Sun One tab. I use the foreign key defined in the database. All seems to be well.
    Using Sun One AppServer 7 and Studio 4
    Upon deploying the application I receive:
    CMP Mapping Error in bean Sites:: Warning: The field bb is not mapped.
    Set the column mapping for the field.

    The CMR/CMP mappings is very instable.
    Sunone Studio 5 has a lot of bugs when mapping CMP/CMR but i never saw this one, try to upgrade.
    Please vote for this bug. It's killing me!!!!!!!!!!!!!!!
    http://developer.java.sun.com/developer/bugParade/bugs/4932495.html

  • I created a pdf with some filled fields.  The person I e-mailed it to said it was blank.

    I open a PDF, use form wizard to detect and create fields, end form wizard, fill in some of the fields, save doc, and e-mail it.  Recipient says PDF fields are all blank.  Does anyone know what I'm doing wrong?
    Using Acrobat 9 Pro.

    If you are sending a quote and they do not need to deal with the form itself, after you complete the form just flatten it so that the form fields go away and are embedded as part of the PDF. Then save to another name (assume you already do that). Then you are simply sending a PDF to them, not a form. The form is simply being used by you to create a quote. This may be your best solution and makes it independent of viewer.
    OK, I really don't know how to flatten the form directly, but a simple alternative is to print the completed form to a new PDF. I am sure that others may be able to tell you how to flatten the form in a more direct manner. In any case, if you can get the end result into a simple PDF format and not a form, then your customers should not have a problem reading it. Bill
    PS - In another post, George indicated you can use a JavaScript to flatten the form
    // Flatten this document
    flattenPages();
    I have been successful running a javascript as a batch, but don't know how to run it from the Acrobat window on the current file. It was a heck of a lot more straight forward in older versions of Acrobat where there was an obvious run button. But then I may just be missing something obvious that the manual does not discuss.

  • Having trouble with Dynamic-to-static

    Having an issue with traffic passing over a dynamic-to-static VPN.  Phase 1 and Phase 2 both complete.  sh cry ips sa on the ASA shows 0 #pkts encaps.  From the 861 it shows 0 #pkts decaps
    I know its a lot to look at but hopefully someone will see something obvious that I messed up. 
    The second tunnel is working.  It is coming from a CradlePoint MBR1400 so I am unable to apply the config from that.
    ciscoasa# sh crypto isakmp sa
       Active SA: 2
        Rekey SA: 0 (A tunnel will report 1 Active and 1 Rekey SA during rekey)
    Total IKE SA: 2
    1   IKE Peer: 107.46.57.189
        Type    : L2L             Role    : responder
        Rekey   : no              State   : MM_ACTIVE
    2   IKE Peer: xxx.xxx.xxx.xxx
        Type    : L2L             Role    : responder
        Rekey   : no              State   : MM_ACTIVE
    ciscoasa# sh crypto ipsec sa
    interface: outside
        Crypto map tag: SYSTEM_DEFAULT_CRYPTO_MAP, seq num: 65535, local addr:
          local ident (addr/mask/prot/port): (10.10.0.0/255.255.0.0/0/0)
          remote ident (addr/mask/prot/port): (192.168.101.0/255.255.255.0/0/0)
          current_peer: 107.46.57.189
          #pkts encaps: 3166, #pkts encrypt: 3166, #pkts digest: 3166
          #pkts decaps: 2828, #pkts decrypt: 2828, #pkts verify: 2828
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 3166, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: xxx.xxx.xxx.98, remote crypto endpt.: 107.46.57.189
          path mtu 1500, ipsec overhead 74, media mtu 1500
          current outbound spi: 0D67A97D
          current inbound spi : B59B6F50
        inbound esp sas:
          spi: 0xB59B6F50 (3046862672)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 5472256, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 3020
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0xFFFFFFFF 0xFFF7FFFF
        outbound esp sas:
          spi: 0x0D67A97D (224897405)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel, }
             slot: 0, conn_id: 5472256, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (sec): 3020
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
        Crypto map tag: SYSTEM_DEFAULT_CRYPTO_MAP, seq num: 65535, local addr: xxx.xxx.xxx.98
          local ident (addr/mask/prot/port): (10.10.0.0/255.255.0.0/0/0)
          remote ident (addr/mask/prot/port): (10.10.10.0/255.255.255.0/0/0)
          current_peer: xxx.xxx.xxx.xxx
         #pkts encaps: 0, #pkts encrypt: 0, #pkts digest: 0
          #pkts decaps: 1041, #pkts decrypt: 1044, #pkts verify: 1044
          #pkts compressed: 0, #pkts decompressed: 0
          #pkts not compressed: 0, #pkts comp failed: 0, #pkts decomp failed: 0
          #pre-frag successes: 0, #pre-frag failures: 0, #fragments created: 0
          #PMTUs sent: 0, #PMTUs rcvd: 0, #decapsulated frgs needing reassembly: 0
          #send errors: 0, #recv errors: 0
          local crypto endpt.: xxx.xxx.xxx.xxx/4500, remote crypto endpt.: xxx.xxx.xxx.xxx/2944
          path mtu 1500, ipsec overhead 82, media mtu 1500
          current outbound spi: 9613FEAC
          current inbound spi : 186C9E40
        inbound esp sas:
          spi: 0x186C9E40 (409771584)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel,  NAT-T-Encaps, }
             slot: 0, conn_id: 5476352, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (kB/sec): (3914991/3199)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0xFFFFFFFF 0xFFFFFFFF
        outbound esp sas:
          spi: 0x9613FEAC (2517892780)
             transform: esp-aes esp-sha-hmac no compression
             in use settings ={L2L, Tunnel,  NAT-T-Encaps, }
             slot: 0, conn_id: 5476352, crypto-map: SYSTEM_DEFAULT_CRYPTO_MAP
             sa timing: remaining key lifetime (kB/sec): (3915000/3198)
             IV size: 16 bytes
             replay detection support: Y
             Anti replay bitmap:
              0x00000000 0x00000001
    REMOTE Config  Cisco 861
    Current configuration : 3112 bytes
    ! Last configuration change at 13:07:07 UTC Mon Jan 2 2006 by jwright
    ! NVRAM config last updated at 12:10:49 UTC Mon Jan 2 2006 by jwright
    version 15.0
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service sequence-numbers
    hostname Corvid
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    logging console critical
    no aaa new-model
    memory-size iomem 10
    crypto pki trustpoint TP-self-signed-3769564853
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3769564853
    revocation-check none
    rsakeypair TP-self-signed-3769564853
    crypto pki certificate chain TP-self-signed-3769564853
    certificate self-signed 02
    ip source-route
    ip dhcp excluded-address 10.10.10.1
    ip dhcp pool ccp-pool
       import all
       network 10.10.10.0 255.255.255.248
       default-router 10.10.10.1
       lease 0 2
    ip cef
    no ip bootp server
    no ip domain lookup
    ip domain name yourdomain.com
    license udi pid CISCO861-K9 sn
    username xxxxx privilege 15 secret 5 $1$SI.
    username xxxxx privilege 15 secret 5 $1$y1
    ip tcp synwait-time 10
    crypto isakmp policy 1
    encr 3des
    hash md5
    authentication pre-share
    group 2
    crypto isakmp key ************ address xxx.xxx.xxx.xxx
    crypto ipsec transform-set RTPSET esp-aes esp-sha-hmac
    crypto map RTP 1 ipsec-isakmp
    set peer xxx.xxx.xxx.xxx
    set transform-set RTPSET
    match address 100
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    interface FastEthernet3
    interface FastEthernet4
    ip address dhcp
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    crypto map RTP
    interface Vlan1
    description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
    ip address 10.10.10.1 255.255.255.248
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1452
    ip forward-protocol nd
    ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip nat inside source route-map nonat interface FastEthernet4 overload
    ip route 0.0.0.0 0.0.0.0 dhcp
    logging trap debugging
    access-list 23 permit 10.10.10.0 0.0.0.7
    access-list 24 permit 192.168.0.0 0.0.0.255
    access-list 100 permit ip 10.10.10.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 100 deny   ip 10.10.10.0 0.0.0.255 any
    access-list 120 deny   ip 10.10.10.0 0.0.0.255 10.10.0.0 0.0.255.255
    access-list 120 permit ip 10.10.10.0 0.0.0.255 any
    no cdp run
    route-map nonat permit 10
    match ip address 120
    control-plane
    line con 0
    logging synchronous
    login local
    no modem enable
    line aux 0
    line vty 0 4
    access-class 23 in
    privilege level 15
    login local
    transport input telnet ssh
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end
    ASA5510
    ciscoasa# sh run
    : Saved
    ASA Version 8.2(1)11
    hostname ciscoasa
    domain-name pme.local
    enable password xxx encrypted
    passwd xxx encrypted
    names
    interface Ethernet0/0
    nameif backup
    security-level 1
    ip address xxx.xxx.xxx.xxx 255.255.255.248
    interface Ethernet0/1
    nameif inside
    security-level 100
    ip address 10.10.1.1 255.255.0.0
    interface Ethernet0/2
    shutdown
    nameif outside2
    security-level 0
    no ip address
    interface Ethernet0/3
    nameif outside
    security-level 0
    ip address xxx.xxx.xxx.xxx 255.255.255.224
    interface Management0/0
    nameif management
    security-level 100
    ip address 172.17.0.199 255.255.255.0
    management-only
    banner motd       **************************** NOTICE ******************************
    banner motd       *    Unauthorized access to this network device is FORBIDDEN!    *
    banner motd       *  All connection attempts and sessions are logged and AUDITED!  *
    banner motd       ******************************************************************
    banner motd       **************************** NOTICE ******************************
    banner motd       *    Unauthorized access to this network device is FORBIDDEN!    *
    banner motd       *  All connection attempts and sessions are logged and AUDITED!  *
    banner motd       ******************************************************************
    boot system disk0:/asa821-11-k8.bin
    ftp mode passive
    clock timezone EST -5
    clock summer-time EDT recurring
    dns domain-lookup inside
    dns domain-lookup outside2
    dns domain-lookup outside
    dns domain-lookup management
    dns server-group DefaultDNS
    name-server HOMESTEAD-INT
    name-server SEBRING-INT
    domain-name pme.local
    object-group service SQLTEST udp
    description SQLTEST for VES
    port-object eq 1434
    object-group service SQLTEST_TCP tcp
    description SQLTEST For VES
    port-object eq 1433
    object-group service DM_INLINE_TCP_1 tcp
    port-object eq ftp
    port-object eq ftp-data
    access-list nonat extended permit ip any 10.10.11.0 255.255.255.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.10.11.0 255.255.255.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 192.168.101.0 255.255.255.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.10.10.0 255.255.255.248
    access-list outside_access_in extended permit tcp any host DAYTONA-EXT-BAK eq smtp
    access-list outside_access_in extended permit tcp any host DAYTONA-EXT-BAK eq https
    access-list outside_access_in extended permit tcp any host DAYTONA-EXT-BAK eq www
    access-list outside_access_in extended permit tcp any host SonomaBullsEye eq https inactive
    access-list outside_access_in extended permit tcp any host AUTHENTICA-EXT-BAK eq www
    access-list outside_access_in extended permit tcp any host AUTHENTICA-EXT-BAK eq https
    access-list outside_access_in extended permit udp any host xxx.xxx.xxx.xxx eq 1434
    access-list outside_access_in extended permit tcp any host xxx.xxx.xxx.xxx eq 1433 inactive
    access-list outside_access_in extended permit tcp any host FILETRANSFER-EXT-BAK eq www
    access-list outside_access_in extended permit tcp any host FILETRANSFER-EXT-BAK eq https
    access-list outside_access_in remark HTTP for TeamWeb
    access-list outside_access_in extended permit tcp any host ALEXSYS-EXT-BAK eq www
    access-list outside_access_in remark HTTPS for TeamWeb
    access-list outside_access_in extended permit tcp any host ALEXSYS-EXT-BAK eq https
    access-list outside_access_in extended deny icmp any any
    access-list Split_Tunnel_List standard permit 10.10.0.0 255.255.0.0
    access-list outside_access_in_1 extended permit tcp any host DAYTONA-EXT-OUT eq smtp
    access-list outside_access_in_1 extended permit tcp any host DAYTONA-EXT-OUT eq https
    access-list outside_access_in_1 extended permit tcp any host DAYTONA-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host Sonoma eq https inactive
    access-list outside_access_in_1 extended permit tcp any host PMEUPDATE-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host FILETRANSFER-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host FILETRANSFER-EXT-OUT eq ssh inactive
    access-list outside_access_in_1 extended permit tcp any host FILETRANSFER-EXT-OUT eq https
    access-list outside_access_in_1 remark FTPS
    access-list outside_access_in_1 extended permit tcp any host FTP-EXT-OUT object-group DM_INLINE_TCP_1
    access-list outside_access_in_1 extended permit tcp any host FTP-EXT-OUT range 60200 60400
    access-list outside_access_in_1 extended permit tcp any host AUTHENTICA-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host AUTHENTICA-EXT-OUT eq https
    access-list outside_access_in_1 extended permit tcp any host OSCODA-EXT-OUT object-group SQLTEST_TCP inactive
    access-list outside_access_in_1 extended permit udp any host OSCODA-EXT-OUT object-group SQLTEST inactive
    access-list outside_access_in_1 extended permit tcp any host ALEXSYS123-EXT-OUT eq www
    access-list outside_access_in_1 extended permit tcp any host ALEXSYS123-EXT-OUT eq https
    access-list outside_access_in_1 extended deny icmp any any
    access-list inside_access_out extended permit ip any any log
    pager lines 24
    logging enable
    logging timestamp
    logging trap notifications
    logging asdm notifications
    logging from-address [email protected]
    logging recipient-address [email protected] level errors
    logging host inside 10.10.2.12
    logging permit-hostdown
    no logging message 302015
    no logging message 302014
    no logging message 302013
    no logging message 302012
    no logging message 302017
    no logging message 302016
    mtu backup 1500
    mtu inside 1500
    mtu outside2 1500
    mtu outside 1500
    mtu management 1500
    ip local pool IPSECVPN2 10.10.11.76-10.10.11.100
    ip local pool SSLVPN 10.10.11.101-10.10.11.200 mask 255.255.0.0
    ip local pool IPSECVPN 10.10.11.25-10.10.11.75
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-623.bin
    no asdm history enable
    arp timeout 14400
    global (backup) 1 xxx.xxx.xxx.xxx
    global (outside) 1 xxx.xxx.xxx.xxx netmask 255.255.255.224
    nat (inside) 0 access-list nonat
    nat (inside) 1 10.10.0.0 255.255.0.0
    static (inside,outside) DAYTONA-EXT-OUT DAYTONA-INT netmask 255.255.255.255
    static (inside,outside) AUTHENTICA-EXT-OUT AUTHENTICA-INT netmask 255.255.255.255
    static (inside,outside) ALEXSYS123-EXT-OUT MIDOHIO-INT netmask 255.255.255.255
    static (inside,outside) PMEUPDATE-EXT-OUT PMEUPDATE-INT netmask 255.255.255.255
    static (inside,outside) FILETRANSFER-EXT-OUT FILETRANSFER-INT netmask 255.255.255.255
    static (inside,outside) FTP-EXT-OUT FTP-INT netmask 255.255.255.255
    static (inside,backup) FILETRANSFER-EXT-BAK FILETRANSFER-INT netmask 255.255.255.255
    static (inside,backup) DAYTONA-EXT-BAK DAYTONA-INT netmask 255.255.255.255
    static (inside,backup) AUTHENTICA-EXT-BAK AUTHENTICA-INT netmask 255.255.255.255
    static (inside,backup) ALEXSYS-EXT-BAK MIDOHIO-INT netmask 255.255.255.255
    access-group outside_access_in in interface backup
    access-group inside_access_out in interface inside
    access-group outside_access_in_1 in interface outside
    route outside 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 1 track 1
    route backup 0.0.0.0 0.0.0.0 xxx.xxx.xxx.xxx 254
    route backup 62.109.192.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    route backup 64.68.96.0 255.255.224.0 xxx.xxx.xxx.xxx 1
    route backup 66.114.160.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    route backup 66.163.32.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    route backup 209.197.192.0 255.255.224.0 xxx.xxx.xxx.xxx 1
    route backup 210.4.192.0 255.255.240.0 xxx.xxx.xxx.xxx 1
    timeout xlate 3:00:00
    timeout conn 24:00:00 half-closed 0:05:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    webvpn
      http-proxy enable
    aaa-server PMERADIUS protocol radius
    aaa-server PMERADIUS (inside) host HOMESTEAD-INT
    key ******
    radius-common-pw ******
    aaa authentication ssh console LOCAL
    http server enable
    http 10.10.0.0 255.255.0.0 inside
    http 172.17.0.0 255.255.255.0 management
    http redirect backup 80
    http redirect outside 80
    snmp-server location Server Room
    snmp-server contact Jay
    snmp-server community *****
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    sla monitor 100
    type echo protocol ipIcmpEcho xxx.xxx.xxx.xxx interface outside
    timeout 3000
    frequency 10
    sla monitor schedule 100 life forever start-time now
    crypto ipsec transform-set PM1 esp-3des esp-md5-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set TRANS_ESP_3DES_SHA mode transport
    crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map dyn1 1 set pfs group1
    crypto dynamic-map dyn1 1 set transform-set PM1
    crypto dynamic-map dyn1 1 set security-association lifetime seconds 28800
    crypto dynamic-map dyn1 1 set security-association lifetime kilobytes 4608000
    crypto dynamic-map dyn1 1 set reverse-route
    crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map cryptomap1 1 ipsec-isakmp dynamic dyn1
    crypto map cryptomap1 interface backup
    crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
    crypto map outside_map interface outside
    crypto ca trustpoint xxx.xxx.xxx.xxx
    enrollment terminal
    fqdn xxx.xxx.xxx.xxx
    subject-name CN= xxx.xxx.xxx.xxx, O=xxxx, C=US, St=MI, L=xxxx
    keypair xxx.xxx.xxx.xxx
    crl configure
    crypto ca certificate chain xxx.xxx.xxx.xxx
    certificate 041200616c79f4
        30820577 3082045f a0030201 02020704 1200616c 79f4300d 06092a86 4886f70d
      quit
    crypto isakmp identity address
    crypto isakmp enable backup
    crypto isakmp enable outside
    crypto isakmp policy 1
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 5
    lifetime 86400
    crypto isakmp policy 50
    authentication pre-share
    encryption aes-256
    hash md5
    group 5
    lifetime 86400
    crypto isakmp nat-traversal 33
    track 1 rtr 100 reachability
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 15
    ssh version 2
    console timeout 0
    management-access inside
    threat-detection basic-threat
    threat-detection statistics port
    threat-detection statistics protocol
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 64.22.86.210 source backup prefer
    ssl trust-point vpn.prattmiller.com outside
    ssl trust-point vpn.prattmiller.com backup
    ssl trust-point vpn.prattmiller.com outside2
    webvpn
    enable backup
    enable outside2
    enable outside
    svc image disk0:/anyconnect-win-2.5.3055-k9.pkg 2
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 3
    svc profiles AllowRemoteUsers disk0:/AnyConnectProfile.xml
    svc enable
    internal-password enable
    group-policy DefaultRAGroup internal
    group-policy DefaultRAGroup attributes
    dns-server value 10.10.2.1
    vpn-tunnel-protocol IPSec l2tp-ipsec
    default-domain none
    group-policy DfltGrpPolicy attributes
    dns-server value 10.10.2.1 10.10.2.62
    vpn-idle-timeout 600
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value Split_Tunnel_List
    default-domain value pme.local
    webvpn
      url-list value Book1
      svc profiles value AllowRemoteUsers
      svc ask enable default webvpn timeout 10
    group-policy AnyConnect internal
    group-policy AnyConnect attributes
    vpn-tunnel-protocol webvpn
    webvpn
      svc ask enable default webvpn timeout 15
    username xxxx password RrjDgdg5BBLrGPnn encrypted privilege 15
    username xxxx password qDxllXruMJHEVZji encrypted privilege 15
    username xxxx password dGOqWbOOjP0FVxtl encrypted privilege 15
    tunnel-group DefaultL2LGroup ipsec-attributes
    pre-shared-key *
    tunnel-group DefaultRAGroup general-attributes
    default-group-policy DefaultRAGroup
    tunnel-group DefaultRAGroup ipsec-attributes
    pre-shared-key *
    tunnel-group DefaultRAGroup ppp-attributes
    authentication ms-chap-v2
    tunnel-group DefaultWEBVPNGroup general-attributes
    address-pool (backup) IPSECVPN2
    address-pool (outside2) IPSECVPN2
    address-pool (outside) SSLVPN
    address-pool SSLVPN
    authentication-server-group PMERADIUS
    tunnel-group pm_ipsec type remote-access
    tunnel-group pm_ipsec general-attributes
    address-pool IPSECVPN2
    tunnel-group pm_ipsec ipsec-attributes
    pre-shared-key *
    tunnel-group prattmiller type remote-access
    tunnel-group prattmiller general-attributes
    address-pool IPSECVPN
    tunnel-group prattmiller ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 1024
    policy-map global_policy
    class inspection_default
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect pptp
    class class-default
    service-policy global_policy global
    smtp-server 10.10.2.6
    prompt hostname context
    Cryptochecksum:8316029502f6698d4015f5e1b3d40a08
    : end
    [code] TEST   [/code]

    My question about this is the other Dynamic VPN that is working has no static route.
    I added:
    route outside 10.10.10.0 255.255.255.248 xxx.xxx.xxx.xxx (where xxx.xxx.xxx.xxx is the IP of the non working remote IKE Peer)
    This had no effect.
    Looking at the two tunnels.  The working tunnel is using IKE IPSEC and the nonworking tunnel is using IKE IPsecOverNatT.  What have I entered that tells the VPN to use IPsecOverNatT?

  • I'm having trouble with a Text Field and a Time Format

    I have created a form.
    There are many text fields for clients to fill out.
    One Field have been formatted to enter a time. Ex. 6:00pm.
    This works great unless it's a 12:00am time then the field reads 00:00am
    I would rather it read 12:00 am.
    How can I do this?

    Maybe you should put the time format in 24hour instead.

  • Trouble with Dynamic Calc Scenario

    We have built a dynamic Calc scenario in our first 11.1.2 Planning environment that works fine in web forms; Forecast vs Prior Forecast Version. However, when we created our second environment the dyanmic scenario is now causing errors with the web forms. I am getting the generic Data form is invalid, check log for details.
    I have isolated the problem to this one scenario. We have three other dynamic scenarios on the form and they work fine.
    The formula on the scenario below which is not working does reference another dynamic scenario (Prior Forecast Version, which is working).
    Forecast vs Prior Forecast (Scenario not working)
    "Forecast" - "Prior Forecast Version";
    Prior Forecast Version works fine and here is that formula:
    if (@ISMBR("Final"))
    "Forecast"->&FcstPF;
    elseif (@ISMBR("Final_Jul"))
    "Budget"->"Final";
    else
    @PRIOR("Forecast", 1, @RELATIVE("Version", 0));
    endif;
    The Prior Forecast Version is before the Forecast vs Prior Forecast in the outline.
    I have checked the formulas and settings on each one and they are the same in both environments. We used LCM to build the second environment.
    Any suggestions on where to look next?
    I am not finding anything in the planning logs that seems to help, do I need to turn on auditing first to get information from the planning logs when you get the generic Check Planning Log for Details message?
    Thanks.

    I haven't check the essbase log but will do so. I thought I checked the correct planning log, but looking at the path I was using, I might have been looking for the log in the wrong place. I was using the path from the troubleshooting guide but it was the diagnostic logs and maybe that is only the correct one when we have auditing turned on.
    Help on the path to the correct planning log would be great. I was looking in middleware/user_projects/epmsystem1/diagnostics/logs
    Thanks.

  • HELP troubles with dynamically generated URLs

    I'm trying to integrate a new shopping cart, but DW CS4 can't follow the dynamic links in the template pages. They render fine in Live View. I can follow the CSS in the CSS Styles panel, but of course, it's not editable. Related files are far from complete and if I try to click on one, I get an error that the file can't be found.
    The templates all contain dynamically generated URLs such as:
    <?php include("${__TPL_DIR__}pages/templates/part.header.tpl.html"); ?>
    The .ini files used have site root relative references.
    Any ideas? Or am I stuck limping along?

    Thanks David,
    I found a few articles in the Developer Center that were helpful in understanding what I was looking at. The articles on creating Drupal and Wordpress themes explained how the pages are created dynamically, as well as how to use DW to modify and create themes. Though the specifics are different than what I am looking at, the concepts are similar. They also confirmed that attaching the relevant CSS files as design time style sheets was a practical workaround in the absence of an add-on to help DW understand the site structure. I was hoping that I had just not done something correctly, but I can live with a workaround, knowing that an "easier" way isn't just waiting for me to learn something about DW.
    Don

  • Trouble with Dynamic TextField and Virtual Keyboard

    I'm working on a flashlite 3.1 touchscreen device running a flash app that I've written. At certain times, I need to be able to enter text, so I created an onscreen keyboard that updates a dynamic textfield.
    If I use a dynamic textfield, a caret doesn't appear, and you can tell where you are entering text. Using some of the text metric info, I've been able to *draw* a caret at the proper position for single line textfields. However, when I try and handle multiline textfields (with wordwrap on), I can seem to figure out what line the *caret* would be or how to breakdown what text is on each line. Has anybody had any success with this? Obviously, hard newlines could be parsed, but the wordwrap is giving me grief.
    In addition, for the Selection class to work, the textfield must have focus. In flashlite, this results in a yellow box around the input, which looks horrible. Is there a way to disable the yellow box?
    Regards,
    Bill

    It is simple, and should be, but I can't say whether you are implementing something incorrectly or if CS5 has some added complexity (or bug) at play.  If we go back to your initial posting, and my initial response, then that should be the end of the story.
    I don't own CS5, but I'd hate to think they made something else difficult to deal with like they seemingly did with timeline tweening in CS4 (which I also did not buy into).  I believe they invented some new form of textfield in CS5, but it'd be sad if they invented some new property to deal with for assigning text to it.
    The only thing I can imagine at this point where it might be something you did involves a couple of factors being at play... 1)  you are using the library name of the movieclip, not the instance name, and 2) your Publish Settings are set for AS2 (so that no error is generated... AS2 is not generous with them like AS3).

  • Please help with dynamic form field names in cfloop

    Hi,
    I need to create a form with day, date, month, year and time for 12 months
    Instead of coding them 12 times, I create day,date,month,year and time fileds in my form 1 time and then I use cfloop from="1" to="12" index="i" to loop these form fields 12 times.
    I gave each form field name such as: <input type="text" name="ScheduleDate_# i #" value=" "> this way each of those field will be named differently such as:
    ScheduleDate_1, ScheduleDate_2,ScheduleDate_3, ScheduleTime_1,ScheduleTime_2, etc
    I'm facing problem when this form is submitted, I think the error has something to do with the pound sign (##) when it comes to updating the back end
    I use MS SQL
    It doesn like this:
    <CFLOOP From="1" To="12" index="k">
    <CFIF Len(Trim(Form.MeetYear_#k#)) NEQ 0 AND Len(Trim(Form.MeetTime_#k#)) NEQ 0>
    <cfquery name="CreateSchedule" datasource="#DSN#">
    UPDATE TableSchedule 
    SET SchedDay = <cfqueryparam cfsqltype="cf_sql_varchar" value="#form.SchedDay_#k##">,SchedMonth =
    <cfqueryparam cfsqltype="cf_sql_varchar" value="#form.SchedMonth_#k##">,SchedDate =
    <cfqueryparam cfsqltype="cf_sql_varchar" value="#form.SchedDate_#k##">,SchedYear =
    <cfqueryparam cfsqltype="cf_sql_varchar" value="#form.SchedYear_#k##">,SchedTime =
    <cfqueryparam cfsqltype="cf_sql_varchar" value="#form.SchedTime_#k##">
    Where SchedId = <cfqueryparam cfsqltype="cf_sql_numeric" value="#k#">  
    </cfquery>
    </CFIF>
    </CFLOOP>
    Can anyone help please?

    You can't nest hash marks. Do this instead:
    SET SchedDay = <cfqueryparam cfsqltype="cf_sql_varchar" value="#form["SchedDay_" & k]#">
    Dave Watts, CTO, Fig Leaf Software
    http://www.figleaf.com/
    http://training.figleaf.com/

  • Trouble with JTextArea & JPassword field

    What I want to do, is have a simple text box, where a user can put text, and store this text in a String field.
    For the password, I just want to let the user have a password field, have it come up as '****' and again store the password in a String field.
    Right now, to do this I have:
    for the text area:
    JTextArea textArea = new JTextArea ("Hello ",8,40);
    getContentPane().add(textArea);
    textArea.setLineWrap(true);
    comment = textArea.paramString();
    but I get the 2 errors:
    paramString() has protected access in javax.swing.JPasswordField
    password = pass.paramString();
    and
    cannot resolve symbol
    symbol : method getContentPane ()
    For the password one, I have:
    String password;
    JPasswordField pass = new JPasswordField("Please enter your password: ");
    pass.setEchoChar('*');
    password = pass.paramString();
    and I get the error:
    paramString() has protected access in javax.swing.JTextArea
         comment = textArea.paramString();
    Could someone help me as to how I get around these errors or another suggestion as to what I could use?
    Thank you very much,
    nickeeboo.

    I have no idea why you're trying to mess with paramString(). A friendly word of advice: don't. Please take some time to look up the protected keyword (in relation to fields) and I think the reason for your errors will dawn on you.
    There are far simpler ways of doing what you want, as you will see.
    To get the text from a JTextArea, use
    textArea.getText()To get the password from a JPasswordField, use
    password.getPassword()

Maybe you are looking for

  • Urgent!  Adobe killed drag/dropping workflow in CC.  Help restore it!

    I posted this first FR at the end of another thread, here.  Due to the importance of this issue, IMO, I'm giving this FR a new thread, plus adding as second version of the same FR. My stance is simple.  Every change Adobe makes to Premiere Pro should

  • Color Correction wanishes

    Hi. I have a strange problem with my latest project regarding color correction changes. All of a sudden i can not make perminant changes in the color section, I use to but not any more. The old changes are in place, but if I make some new ones, the c

  • Error when executing external workflow process

    OWB 9.2 with server on Windows NT. I can successfully execute a mapping workflow process from the deployment manager, but I get an error when executing a simple external process: command: move parameters: ?c:\\data\\owbtest\\src.txt?c:\\data\\owbtest

  • Blank screen on phone

    I recharged my phone this morning and it was working ok. Now the screen has gone totally blank and I get an error messasge when trying to connect to iTunes. What is the problem?

  • NavigationTarget parameter handling

    Hello Gurus, I've implemented IF_RS_BBS_BADI_HANDLER for jumping to URL. Now, when I call jump from BEx Analyzer (Excel/Web) it works fine. But when I display query within portal, jump's not working - it seems that portal clasifies link as internal a