Upgrading from 1.4 to 6 - some code doesn't compile.

Hi all, I've just upgraded from version 1.4 to 6. I tried compiling a few classes and I'm getting errors (it previously compiled fine under 1.4).
Any idea how I can get the errors below fixed?
I've checked the version 6 api and it doesn't contain the servlet classes that I require:
import javax.servlet.http.*;
import javax.servlet.*;
import javax.servlet.jsp.*;
import javax.servlet.jsp.tagext.*;
Here's a few errors:
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:11: package javax.servlet.http does not exist
import javax.servlet.http.*;
^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:12: package javax.servlet does not exist
import javax.servlet.*;
^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:13: package javax.servlet.jsp does not exist
import javax.servlet.jsp.*;
^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:14: package javax.servlet.jsp.tagext does not exist
import javax.servlet.jsp.tagext.*;
^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:18: cannot find symbol
symbol: class BodyTagSupport
public class HtmlCalendar extends BodyTagSupport{
^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:31: cannot find symbol
symbol : class JspTagException
location: class com.javacomponents.HtmlCalendar
     public int doStartTag() throws JspTagException{
     ^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:36: cannot find symbol
symbol : class JspTagException
location: class com.javacomponents.HtmlCalendar
     public int doEndTag() throws JspTagException{
     ^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:33: cannot find symbol
symbol : variable EVAL_BODY_TAG
location: class com.javacomponents.HtmlCalendar
          return EVAL_BODY_TAG;
          ^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:38: cannot find symbol
symbol : class JspWriter
location: class com.javacomponents.HtmlCalendar
          JspWriter out = pageContext.getOut();
          ^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:38: cannot find symbol
symbol : variable pageContext
location: class com.javacomponents.HtmlCalendar
          JspWriter out = pageContext.getOut();
          ^
C:\Program Files\Apache Software Foundation\Tomcat 5.0\webapps\calendar\WEB-INF\classes\com\javacomponents\HtmlCalendar.java:97: cannot find symbol
symbol : class DateCorrection
location: class com.javacomponents.HtmlCalendar
                         DateCorrection dc = new DateCorrection();
Cheers in advance,
MM

Can you please show me exactly what I need? I've tried downloading a couple of things:
Java EE SDK 5 Update 2 No JDK
and
Java EE 5 SDK Update 2 (with JDK)
Both times I got an application server installed and I couldn't use Tomcat.
I thought this would be easy to sort out. What exactly do i need to do?
Cheers again,
MM

Similar Messages

  • Hi,  I've just purchased and installed an upgrade from Lightroom 4 to 5.  It doesn't seem to handle raw files authored with a new Nikon D750 camera.  I spoke to the sales rep about this and he gave me a link to the 8.6 DNG converter page with instructions

    Hi,  I've just purchased and installed an upgrade from Lightroom 4 to 5.  It doesn't seem to handle raw files authored with a new Nikon D750 camera.  I spoke to the sales rep about this and he gave me a link to the 8.6 DNG converter page with instructions to download.  8.6 only works with Mac OS 10.7-10.9, according to the page.  I'm running Yosemite, Mac 10.10.  Please can you tell me my options?  Lightroom 4 worked beautifully with my older cameras' raw files so I would like to continue using the application.  What should I do?  How soon will Lightroom 5 be able to deal with raw files from a D750.  Many thanks, Adam.

    Until the next version of Lightroom is released, you need to use the DNG Converter version 8.7RC to convert your RAW photos to DNG and then import the DNGs into Lightroom.

  • After upgrading from ITunes6 on ITunes 7 my videos doesn´t work

    after upgrading from ITunes6 on ITunes 7 my videos doesn´t work. there are no error messages, popups or ballons. songs are no problem, only the videos?!
    Can somebody help me?
    Thanks
    Cross

    hmmmm. let's try checking to see if they will still play in your current version of QuickTime.
    in itunes, right-click on one of the videos that is causing the grief, and select "Show in Windows Explorer".
    right click the icon of the file in the Explorer window that comes up and select "Open With ...", and try to open it with your QuickTime player. does it play there or do you get funny business with that too?

  • Upgrade from ColdFusion6 to Cold Fusion8 -- Required Code Changes

    Hi ,
    We recently upgraded to CF8 from CF6. SOem of the functionalities are not working as expected.
    For Eg: if we click on the button it shoudl tak eus  to other page ,but after upgrade its staying in the same page.
    I suspect <cfform> tag method attribute. we are using method attribute with "Get" method. Not sure how to fix the issue.
    Can any body help on that how can we find what are the required chanegs we need to make in the code so that it will compatiable with CF8?
    Is there any way to run the whole code and see required changes? I know the code analyzer it is just fid the syntax errors. i feel that it didn't help me much.
    Regards
    sudha.

    As a thumb rule, if a HTML form is meant to make any "changes" to any data, backend, etc., you should always use the POST method. Only in cases where the form post simply fetches a page without altering anything anywhere, GET can be justified.
    When using GET, form values may get transported into the URL scope.
    Debug the URL and FORM scope for the variables which dictate the action that happens.
    Another thing to check, if you still have problems when using POST instead of GET:
    What is the exact target page you're posting to, _with_ url parameters? Does it have url parameters?
    In addition, does the form have hidden fields which could have the same parameters?
    It's a typical mistake to accidentally have a page "page.cfm?area=3&action=get", having also a hidden input "get" with some other value, and posting the page to itself with all current url parameters. The url value of "action" may override the one coming from the form.
    I faintly remember the behaviour of ColdFusion changing at some point, when this happens.
    -Fernis - fernis.net - ColdFusion Developer For Hire

  • Just upgraded from Mountain Lion and now some programmes do not work. How to go back to Mountain Lion

    Just upgraded to Yosemite from Moutain Lion. Want to go back as it refuses to run some programmes

    Yosemite/ OS X Mavericks: Revert to a previous OS X version

  • Upgrading from Panther to Tiger -- Need some hand holding

    Hello all,
    So I'm a newbie to upgrading operating systems on the Mac but need to upgrade to Tiger in order to install Final Cut Studio 5 so I can use my new HD camera. I will upgrade to Leopard when it comes out, but I need to be able to edit my videocamera's footage now.
    So...I've read so many horror stories I wanted to post about my system and some of my most used applications and see if anyone sees any potential problems, as far as compatibility OR not working once the upgrade is complete..
    I have a 1.8 Dual G5, 2 gigs RAM, running Panther 10.3.9
    I use these applications FREQUENTLY and want to make sure they still work after doing a simple upgrade:
    Adobe Creative Suite (not 2, but the one before that)
    Dreamweaver 8
    Final Cut HD 4.5 (will I be able to open old projects with the new FCP 5, otherwise I won't need this afterwards)
    DVD Studio Pro 3 (will I be able to open old projects with the new DVD Studio Pro 4 otherwise I won't need this afterwards)
    iLife '06 (this won't be overwritten, correct?)
    iWork
    Quickbooks (that came with my original system...will it stay too?)
    Microsoft Office X for Mac (using Entourage as my mail program)
    Virtual PC for Mac
    Classic OS 9 (I've read I should remove this before I upgrade? I never use it)
    I think that's the important stuff. Some people tell me they've upgraded with no problems but I guess I read these boards too much to be that confident.
    I've backed up my Docs, iTunes, iPhoto...anything else in my Library or something else you recommend I backup?
    Do I choose Archive and Install for a Simple Upgrade or will it just say "Simple Upgrade" and not prompt me further?
    Sorry if these are dumb questions...I'm just nervous I will have a big paperweight on my desk after this and I have mucho work to do right now!
    Thanks everyone!
    Mare

    Here are some suggestions:
    Important: Please read before installing
    1. If you have a third-party FireWire hard drive connected, disconnect it before installing this update. Reconnect it and turn it back on after installation is complete and you've restarted.
    2. You may experience unexpected results if you have installed third-party system software modifications, or if you have modified the operating system through other means. (This does not apply to normal application software installation.)
    3. The installation process should not be interrupted. If a power outage or other interruption occurs during installation, use the standalone installer (see below) from Apple Downloads to update.
    System Update Procedure
    A. Repair hard drive and permissions.
    Repairing the Hard Drive and Permissions
    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger.) After DU loads select your OS X volume from the list on the left, click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now shutdown the computer for a couple of minutes and then restart normally.
    If DU reports errors it cannot fix, then you will need Disk Warrior (4.0 for Tiger) and/or TechTool Pro (4.5.2 for Tiger) to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X. Note that Disk Warrior will not work on Intel Macs.
    B. Clone your existing system to an external Firewire drive.
    How to Clone Using Restore Option of Disk Utility
    1. Open Disk Utility from the Utilities folder.
    2. Select the startup or source volume from the left side list.
    3. Click on the Restore tab in the DU main window.
    4. Drag the startup or source volume to the Source entry field.
    5. Select the backup or destination volume from the leftside list and drag it to the Destination entry field.
    6. Check the box to Erase Destination. Skip this step if you've already formatted the drive.
    7. Double-check you got it right, then click on the Restore button.
    C. Consult the Tiger Installation Checklist.
    You have three upgrade options. If you use the Upgrade installation option be sure you have repaired the hard drive and permissions first and made your backup. If you choose the Archive and Install option then you only need to repair the hard drive.
    Neither of the above options will erase the disk. Some of your software may not work with Tiger. You will need to upgrade those programs. It would be best to do the upgrades to your software before upgrading to Tiger.
    You don't have to remove your OS 9 installation for Classic. However, if you don't use it you can recover the disk space by deleting it from the drive. The OS 9 folders are located at the root directory of the hard drive and are:
    +System Folder+ (Note this is NOT the System folder.)
    +Applications (Mac OS 9)+
    Documentation
    Be sure Classic is not activated (System Preferences.) Simply open the System Folder and drag the System file into the Trash. Restart the computer. After the computer restarts empty the Trash then drag the three OS 9 folders to the Trash and empty.

  • Upgrade from DW8 to CS4. need some advise/info

    Since 1 year I`m using DW8 (Studio 8) as I started making websites with this program. (it is far much interesting as the progam I had before).
    This year I learned about PHP and databases and dynamic websites.
    I`m thinking of getting CS4.
    Now I have some questions for which I hope you can give me some info or advise :
    1) Can I only upgrade the DW8 out of Studio 8 upto CS4?
    2) Is there much difference between them.   Are the buttons or option to be found somewhere else or are they still in the same place?
    3) Can I still use my old page of DW8 in CS4?   Or do I need to convert or rebuild them?
    4) Any common bugs in CS4.  I do ask this one as I`m not that technical to overcome some bugs that seems easy to pro`s.
    Thanks in advance
    Kind regards
    martine

    No, that's not correct. "Upgrade" refers only to the price you pay. Regardless of which version you buy, the Studio 8 software remains on your computer, and can still be used.
    However, as I said before, you cannot run Dreamweaver 8 and Dreamweaver CS4 at the same time on a Windows computer. If, for some reason, you want to use Dreamweaver 8, you must close Dreamweaver CS4. After you have finished working with Dreamweaver 8, close it, and then you can relaunch Dreamweaver CS4.
    David,
    You are confusing me.
    With `full` version I mean : the higher price.
    With `upgrade` I mean the cheaper price.
    From the earlier messages I understood that an `upgrade` (thus the cheaper price) of 1 piece of Studio 8 is not possbile.
    So to have DW8  (out of Studio 8) changed into DW CS4 I have the following option :
    - I purchase the full (thus higher price) version of Dreamweaver CS4.   Then I can install CS4 and still all programs of Studio 8 can be used.
    or
    - I purchase an `upgrade` (thus the cheaper price) from Studio 8 to CS4 Web Standard.  Here we go from one suite to another and all programs are updated/upgraded.
    Hope I`m out of the confusion now.
    Martine    

  • HP Pavilion dv6 Windows 10 upgrade from Windows 7 Home Prem; Error code 0xC1900101

    Have been trying to upgrade to Windows 10 (from Windows 7 Home Prem 64 bit). However, the upgrade fails showing an error code 0xC1900101. Tried uninstalling MCafee Antivirus and upgrading, but that fails too. Also, checked and installed all 'other' available system updates and tried. But no luck.During the installation process, the failure occurs when the system has finished copying and is in the process of installing drivers (that is, after the second restart). I have noticed that the 'installing drivers' process was also almost 90% complete. Once the second restart process begins, the system hangs and processor keeps running (and so does the cooling fan, at its highest speed). Earlier, had heating problems which used to hibernate my system during this process, but have fixed that now. And I get this new error message (in the subject above).Guess, the issue occurs when the system is trying to install drivers or when it is trying to upgrade its configuration. Need help!

    I dunno if this is related but I had an error as well during the upgrade on an HP DV5. You can find more information on the error if you analyze the dump file (.dmp) found in the Windows.BT folder right after the upgrade fails. You can use a utility like BlueScreenView. In my case, the upgrade crashed at around 75% of the total process (when configuring settings). Analyzing the dump file showed that the error was caused by a driver named 000.fcl, related to Cyberlink and their DVD player. Turns out this is used in the HP QuickPlay feature. After removing HP Quick Play, the upgrade proceeded as normal. Hope it helps anyone with a similar problem !

  • Upgrading from W 8.1 to 10, Key doesn't work

    This laptop was purchased with Windows 8.1 pre-installed. The Windows 10 software is on my C drive and I tried installing it. The window asks for the Key. I've run the CMD wmic path softwarelicensingservice get OA3xOriginalProductKey. It gives me a Key but the installation program says the key doesn't work. Some sites say all updates must be installed. Done!Some sites say ignore the key and proceed. I can't as the software is very snooty - the OK cell is grayed out. Any suggestions? As an aside, I can't believe all the fluff on the Internet about installing W10. BTW, I installed W10 on an old ASUS Eee PC without any problem.

    Hello, Thank you for posting in the HP Support Forum. Please, refer to this thread:  http://h30434.www3.hp.com/t5/Notebook-Operating-Systems-and-Software/problem-with-activation-after-upgrade-to-windows-10/td-p/5172044  

  • Missing Snippet Descriptions (upgraded from RH7 to RH9)

    Hi all,
    I've pretty much successfully upgraded my RH7 project to RH9. I only noticed two problems, one of which is the subject of this thread - the descriptions for each of my snippets isn't displaying. It looks to me like this problem has something to do with the way descriptions were previously stored (in a title tag for RH7 and lower versions?) versus the way the descriptions are now stored (in a meta tag, i think, for RH8 and higher versions?).
    I took a look at the hts file for one of my snippets that was upgraded from RH7 to RH9. The code looks like this (I've bolded the snippet description):
    <?xml version="1.0" encoding="utf-8" ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta name="generator" content="Adobe RoboHelp 9" />
    <title>Use this text above the table that explains Action menu items.</title>
    </head>
    <body>
    <p style="margin-top: 2pt; margin-bottom: 2pt;">Select an action from the
    menu and click Go. </p>
    <p style="margin-top: 2pt; margin-bottom: 2pt;">&#160;</p>
    <p style="margin-top: 2pt; margin-bottom: 2pt;"><span class="NoteTitle">Note:</span>
    The Action menu may change depending on the content, the content's status,
    your permissions and what you have already accessed. Therefore, the options
    explained below may not all be available at the same time.</p>
    </body>
    </html>
    THEN, I created a brand new snippet in RH9. The code looks like this:
    <?xml version="1.0" encoding="utf-8"?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta name="topic-comment" content="this is a new test snippet" />
    <title>New Snippet</title>
    <meta name="generator" content="Adobe RoboHelp 9" />
    </head>
    <body>
    <p>This is placeholder text for your snippet. To add content to the body,
    replace this text. </p>
    <p>&#160;</p>
    <p>For information about applying snippets to topics, press <b>F1</b>.</p>
    </body>
    </html>
    Notice how the description for the brand new snippet starts with "<meta name" but for the snippet that was created in RH7 (and then automatically upgraded by RH9), the description for the snippet starts with "<title>".
    I have 101 (exact count) snippet files and would hate to have to go into each one and modify this line of code myself, so my question is this:  Does anybody know a good, faster way to 'upgrade' all of my hts (snippet) files to follow the new RH9 format?
    Here are two things I've tried:
    1. Using TextPad, I manually made the change in the .hts file. Result: The description still does not display in the Description column in the Snippets pod (on the left in the screenshot below), but it DOES display in the Snippet Properties window (on the right in the screenshot below).
    2. Copying the description from TextPad, then opening the Properties window for the snippet and pasting the description into the Description field, and saving the snippet. This WORKS...but I'll have to do it 100 more times to fix all my snippets, AND the Title tag still ends up being incorrect.   Although things LOOK correct in the Properties window (i.e., the Name field indicates the correct name for the snippet, and the Description field now contains the correct description), here's the resulting code:
    <meta name="topic-comment" content="Use this text as the explanation for the Add To Cart Action menu option." />
    <title>Use this text as the explanation for the Add To Cart Action menu option.</title>
    So, the meta and title tags end up having the same values! The title tag should say "Add To Cart" - I don't know how it's possible that it doesn't contain this text as the value for the title tag. Thus, it seems like in order to get the descriptions in there correctly, I have to do a copy, then paste into the Properties window in RH9, but to correct the Title tags I have to open the .hts files in a text editor (i.e., *outside* of RH9) and enter the correct title text for each snippet. Is this really going to be this time-consuming to fix?

    Let's try again.
    First forget thinking in INCLUDE mode. Everything will be included unless you exclude it.
    Example.
    Topic 1 has tag A applied to the topic
    Topic 2 has tag B applied to the topic
    Topic 3 has tag A applied to some of the content (let's say to the word Redrabbit) but not the topic itself.
    Topic 4 has the tag A applied to the word Redrabbit and tag B to the word Greenrabbit but no tag on the topic itself.
    This is how it should work.
    Topic
    Topic tag
    Text tagged
    Expression Not A
    Expression Not B
    Expression Not A and Not B
    Header 6
    1
    A
    Topic will be excluded
    Topic be in output
    Topic will be excluded
    2
    B
    Topic be in output
    Topic will be excluded
    Topic will be excluded
    3
    None
    Redrabbit is tagged A
    Topic will be in output but the word Redrabbit will be excluded
    Whole topic will be in output including the word Redrabbit.
    Topic will be in the output but the words Redrabbit and Greenrabbit will be excluded.
    4
    None
    Redrabbit is tagged A and Greenrabbit is tagged B
    Topic will be in output but the word Redrabbit will be excluded
    Topic will be in the output but the word Greenrabbit will be excluded.
    Topic will be in the output but the words Redrabbit and Greenrabbit will be excluded.
    Below is the expression dialog.
    Here I have selected from Available Tags and put them in Exclude.
    Click Advanced and you will see how RH writes the expression.
    Written like that, does it now work for you?
    See www.grainge.org for RoboHelp and Authoring tips

  • Upgrade from RH8 to RH10 formatting

    We upgraded from RH8 to RH10 and some of the topics are not formatted. (1484 topics) There is alot of extra spacing inbetween bullets and alpha numbering.
    For example:
    Enter a Business    Name, if applicable. This field is not required if you    are not establishing a business account and when you provide a    first and last name. The value entered is displayed on the customer's    invoice and is limited to 30 alphanumeric characters.
    What do I need to eliminate in the HTML code? And is there a way to programatically remove all the extra spaces?
    Thank-you,
    Michelle

    I think your problem is because you are generating to a network drive. You should generate to a local drive and publish to a network drive.
    I changed your start page in the project you sent to index.htm as I don't like having a start page with the same name as a topic and generated to a local drive.
    Works fine. Correct formatting.
    Also I would avoid spaces in a CSS file name.
    See www.grainge.org for RoboHelp and Authoring tips
    @petergrainge

  • Upgrading from PIX to ASA 5512X

    Hi everyone,
    We are in the middle of upgrading from two PIX's to some new ASA5512X's. To give you some background on the situation we are upgrading these since the PIXs are fairly old. We had one extra that we had to use since one PIX has failed already. The guy that implemented the PIXs orginally was learning how to do so as he went so there is alot of needless config in the PIX, atleast from what I can tell. Another guy that works with me has done some configuration on the new ASAs and has done the majority of it so far. Today we went to install the new ASAs and switch everything over hoping it would work, but that didn't happen. It seems that there is something wrong with our NAT and ACLs somewhere along the lines. The way our network is laid out is that we have two school campus with a site-to-site VPN one is 172.17.0.0/16 and the other is 172.18.0.0/16. We also have a remote-access VPN on both ASA's. When we connected the new ASAs up and brought up the interfaces, nothing on the inside could ping the internet nor the other side. The VPN showed active on the ASA's and each ASA could ping the others outside interface, but that was it. I have posted the configs below. If anyone could help out I would GREATLY appreciate it! Thank you in advance!
    ASA1:
    : Saved
    : Written by enable_15 at 04:26:18.240 CDT Tue Mar 12 2013
    ASA Version 8.6(1)2
    hostname dallasroadASA
    enable password **** encrypted
    passwd **** encrypted
    names
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address 70.x.x.x 255.255.255.0
    interface GigabitEthernet0/1
    nameif inside
    security-level 100
    ip address 172.18.1.1 255.255.255.0
    interface GigabitEthernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/4
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/5
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    ftp mode passive
    clock timezone CST -6
    clock summer-time CDT recurring
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 172.18.2.21
    name-server 172.18.2.20
    object network WS_VLAN2
    subnet 172.17.2.0 255.255.255.0
    object network WS_VLAN3
    subnet 172.17.3.0 255.255.255.0
    object network WS_VLAN4
    subnet 172.17.4.0 255.255.255.0
    object network WS_VLAN5
    subnet 172.17.5.0 255.255.255.0
    object network WS_VLAN6
    subnet 172.17.6.0 255.255.255.0
    object network WS_VLAN7
    subnet 172.17.7.0 255.255.255.0
    object network WS_VLAN8
    subnet 172.17.8.0 255.255.255.0
    object network WS_VLAN9
    subnet 172.17.9.0 255.255.255.0
    object network WS_VLAN10
    subnet 172.17.10.0 255.255.255.0
    object network WS_VLAN11
    subnet 172.17.11.0 255.255.255.0
    object network WS_VLAN12
    subnet 172.17.12.0 255.255.255.0
    object network WS_VLAN13
    subnet 172.17.13.0 255.255.255.0
    object network WS_VLAN14
    subnet 172.17.14.0 255.255.255.0
    object network WS_VLAN15
    subnet 172.17.15.0 255.255.255.0
    object network WS_VLAN16
    subnet 172.17.16.0 255.255.255.0
    object network DR_VLAN2
    subnet 172.18.2.0 255.255.255.0
    object network DR_VLAN3
    subnet 172.18.3.0 255.255.255.0
    object network DR_VLAN4
    subnet 172.18.4.0 255.255.255.0
    object network DR_VLAN5
    subnet 172.18.5.0 255.255.255.0
    object network DR_VLAN6
    subnet 172.18.6.0 255.255.255.0
    object network DR_VLAN7
    subnet 172.18.7.0 255.255.255.0
    object network DR_VLAN8
    subnet 172.18.8.0 255.255.255.0
    object network DR_VLAN9
    subnet 172.18.9.0 255.255.255.0
    object network DR_VLAN10
    subnet 172.18.10.0 255.255.255.0
    object network DR_CORE_SW
    host 172.18.2.1
    object network dallasdns02_internal
    host 172.18.2.21
    object network faithdallas03_internal
    host 172.18.2.20
    object network dns_external
    host 70.x.x.x
    object network WorthStreet
    subnet 172.17.0.0 255.255.0.0
    object network DallasRoad
    subnet 172.18.0.0 255.255.0.0
    object-group network DALLAS_VLANS
    network-object object DR_VLAN10
    network-object object DR_VLAN2
    network-object object DR_VLAN3
    network-object object DR_VLAN4
    network-object object DR_VLAN5
    network-object object DR_VLAN6
    network-object object DR_VLAN7
    network-object object DR_VLAN8
    network-object object DR_VLAN9
    object-group network WORTH_VLANS
    network-object object WS_VLAN10
    network-object object WS_VLAN11
    network-object object WS_VLAN12
    network-object object WS_VLAN13
    network-object object WS_VLAN14
    network-object object WS_VLAN15
    network-object object WS_VLAN16
    network-object object WS_VLAN2
    network-object object WS_VLAN3
    network-object object WS_VLAN4
    network-object object WS_VLAN5
    network-object object WS_VLAN6
    network-object object WS_VLAN7
    network-object object WS_VLAN8
    network-object object WS_VLAN9
    object-group network dallasitnetwork
    network-object host 172.18.2.20
    network-object host 172.18.2.40
    object-group protocol tcpudp
    protocol-object udp
    protocol-object tcp
    object-group network dallasroaddns
    network-object host 172.18.2.20
    network-object host 172.18.2.21
    object-group service tcpservices tcp
    port-object eq ftp
    port-object eq ftp-data
    port-object eq www
    port-object eq ssh
    object-group network remotevpnnetwork
    network-object 172.18.50.0 255.255.255.0
    access-list L2LAccesslist extended permit ip 172.18.0.0 255.255.0.0 172.17.0.0 255.255.0.0
    access-list NONAT extended permit ip any 172.18.50.0 255.255.255.0
    access-list inside_inbound_access extended permit ip 172.18.0.0 255.255.0.0 172.17.0.0 255.255.0.0
    access-list inside_inbound_access extended permit ip object-group dallasitnetwork any
    access-list inside_inbound_access extended permit object-group tcpudp object-group dallasroaddns any eq domain
    access-list inside_inbound_access extended permit ip host 172.18.4.10 any
    access-list inside_inbound_access extended deny object-group tcpudp any any eq domain
    access-list inside_inbound_access extended deny tcp any any eq smtp
    access-list inside_inbound_access extended permit ip any any
    access-list outside_inbound_access extended permit tcp any host 70.x.x.x object-group tcpservices
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool vpnaddresspool 172.18.50.0-172.18.50.255
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static dallasdns02_internal dns_external
    nat (inside,outside) source static faithdallas03_internal dns_external
    nat (inside,outside) source dynamic any interface
    nat (any,outside) source static remotevpnnetwork remotevpnnetwork destination static remotevpnnetwork remotevpnnetwork description NONAT for remote vpn users
    nat (inside,outside) source static DallasRoad DallasRoad destination static WorthStreet WorthStreet
    access-group outside_inbound_access in interface outside
    access-group inside_inbound_access in interface inside
    route outside 0.0.0.0 0.0.0.0 70.x.x.x 1
    route inside 172.18.0.0 255.255.0.0 172.18.1.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    ldap attribute-map CISCOMAP
      map-name  VPNALLOW IETF-Radius-Class
      map-value VPNALLOW FALSE NOACESS
      map-value VPNALLOW TRUE ALLOWACCESS
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server LDAP protocol ldap
    aaa-server LDAP (inside) host 172.17.2.28
    server-port 389
    ldap-base-dn DC=campus,DC=fcschool,DC=org
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password ****
    ldap-login-dn CN=fcsadmin,CN=Users,DC=campus,DC=fcschool,DC=org
    server-type microsoft
    ldap-attribute-map CISCOMAP
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 172.17.11.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set myset esp-aes-256 esp-sha-hmac
    crypto map outside_map 10 match address L2LAccesslist
    crypto map outside_map 10 set peer 71.x.x.x
    crypto map outside_map 10 set ikev1 transform-set myset
    crypto map outside_map 10 set reverse-route
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    crypto ikev1 policy 1
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 65535
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    telnet timeout 5
    ssh 172.18.0.0 255.255.0.0 inside
    ssh 172.17.0.0 255.255.0.0 inside
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    group-policy NOACCESS internal
    group-policy NOACCESS attributes
    vpn-simultaneous-logins 0
    vpn-tunnel-protocol ikev1
    group-policy DfltGrpPolicy attributes
    dns-server value 172.18.2.20
    vpn-tunnel-protocol ikev1 l2tp-ipsec ssl-clientless
    password-storage enable
    group-policy DallasRoad internal
    group-policy DallasRoad attributes
    dns-server value 172.18.2.20 172.18.2.21
    password-storage enable
    default-domain value campus.fcschool.org
    group-policy ALLOWACCESS internal
    group-policy ALLOWACCESS attributes
    banner value Now connected to the FCS Network
    vpn-tunnel-protocol ikev1
    username iwerkadmin password i6vIlW5ctGaR0l7n encrypted privilege 15
    tunnel-group remoteaccessvpn type remote-access
    tunnel-group remoteaccessvpn general-attributes
    address-pool vpnaddresspool
    authentication-server-group LDAP
    tunnel-group 71.x.x.x type ipsec-l2l
    tunnel-group 71.x.x.x ipsec-attributes
    ikev1 pre-shared-key ****
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect ip-options
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:fd69fbd7a2cb0a6a125308dd85302198
    : end
    ASA2:
    : Saved
    : Written by enable_15 at 09:27:47.579 UTC Tue Mar 12 2013
    ASA Version 8.6(1)2
    hostname worthstreetASA
    enable password **** encrypted
    passwd **** encrypted
    names
    interface GigabitEthernet0/0
    nameif outside
    security-level 0
    ip address 71.x.x.x 255.255.255.0
    interface GigabitEthernet0/1
    nameif inside
    security-level 100
    ip address 172.17.1.1 255.255.255.0
    interface GigabitEthernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/4
    shutdown
    no nameif
    no security-level
    no ip address
    interface GigabitEthernet0/5
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    boot system disk0:/asa861-2-smp-k8.bin
    ftp mode passive
    dns domain-lookup inside
    dns server-group DefaultDNS
    name-server 172.17.2.23
    name-server 172.17.2.28
    object network mail_external
    host 71.x.x.x
    object network mail_internal
    host 172.17.2.57
    object network faweb_external
    host 71.x.x.x
    object network netclassroom_external
    host 71.x.x.x
    object network blackbaud_external
    host 71.x.x.x
    object network netclassroom_internal
    host 172.17.2.41
    object network nagios
    host 208.x.x.x
    object network DallasRoad_ASA
    host 70.x.x.x
    object network WS_VLAN2
    subnet 172.17.2.0 255.255.255.0
    object network WS_VLAN3
    subnet 172.17.3.0 255.255.255.0
    object network WS_VLAN4
    subnet 172.17.4.0 255.255.255.0
    object network WS_VLAN5
    subnet 172.17.5.0 255.255.255.0
    object network WS_VLAN6
    subnet 172.17.6.0 255.255.255.0
    object network WS_VLAN7
    subnet 172.17.7.0 255.255.255.0
    object network WS_VLAN8
    subnet 172.17.8.0 255.255.255.0
    object network WS_VLAN9
    subnet 172.17.9.0 255.255.255.0
    object network WS_VLAN10
    subnet 172.17.10.0 255.255.255.0
    object network WS_VLAN11
    subnet 172.17.11.0 255.255.255.0
    object network WS_VLAN12
    subnet 172.17.12.0 255.255.255.0
    object network WS_VLAN13
    subnet 172.17.13.0 255.255.255.0
    object network WS_VLAN14
    subnet 172.17.14.0 255.255.255.0
    object network WS_VLAN15
    subnet 172.17.15.0 255.255.255.0
    object network WS_VLAN16
    subnet 172.17.16.0 255.255.255.0
    object network DR_VLAN2
    subnet 172.18.2.0 255.255.255.0
    object network DR_VLAN3
    subnet 172.18.3.0 255.255.255.0
    object network DR_VLAN4
    subnet 172.18.4.0 255.255.255.0
    object network DR_VLAN5
    subnet 172.18.5.0 255.255.255.0
    object network DR_VLAN6
    subnet 172.18.6.0 255.255.255.0
    object network DR_VLAN7
    subnet 172.18.7.0 255.255.255.0
    object network DR_VLAN8
    subnet 172.18.8.0 255.255.255.0
    object network DR_VLAN9
    subnet 172.18.9.0 255.255.255.0
    object network DR_VLAN10
    subnet 172.18.10.0 255.255.255.0
    object network WS_CORE_SW
    host 172.17.2.1
    object network blackbaud_internal
    host 172.17.2.26
    object network spiceworks_internal
    host 172.17.2.15
    object network faweb_internal
    host 172.17.2.31
    object network spiceworks_external
    host 71.x.x.x
    object network WorthStreet
    subnet 172.17.0.0 255.255.0.0
    object network DallasRoad
    subnet 172.18.0.0 255.255.0.0
    object network remotevpnnetwork
    subnet 172.17.50.0 255.255.255.0
    object-group icmp-type echo_svc_group
    icmp-object echo
    icmp-object echo-reply
    object-group service mail.fcshool.org_svc_group
    service-object icmp
    service-object icmp echo
    service-object icmp echo-reply
    service-object tcp destination eq www
    service-object tcp destination eq https
    service-object tcp destination eq imap4
    service-object tcp destination eq pop3
    service-object tcp destination eq smtp
    object-group service nagios_svc_group tcp
    port-object eq 12489
    object-group service http_s_svc_group tcp
    port-object eq www
    port-object eq https
    object-group network DALLAS_VLANS
    network-object object DR_VLAN10
    network-object object DR_VLAN2
    network-object object DR_VLAN3
    network-object object DR_VLAN4
    network-object object DR_VLAN5
    network-object object DR_VLAN6
    network-object object DR_VLAN7
    network-object object DR_VLAN8
    network-object object DR_VLAN9
    object-group network WORTH_VLANS
    network-object object WS_VLAN10
    network-object object WS_VLAN11
    network-object object WS_VLAN12
    network-object object WS_VLAN13
    network-object object WS_VLAN14
    network-object object WS_VLAN15
    network-object object WS_VLAN16
    network-object object WS_VLAN2
    network-object object WS_VLAN3
    network-object object WS_VLAN4
    network-object object WS_VLAN5
    network-object object WS_VLAN6
    network-object object WS_VLAN7
    network-object object WS_VLAN8
    network-object object WS_VLAN9
    object-group network MailServers
    network-object host 172.17.2.57
    network-object host 172.17.2.58
    network-object host 172.17.2.17
    object-group protocol DM_INLINE_PROTOCOL
    protocol-object ip
    protocol-object udp
    protocol-object tcp
    object-group network DNS_Servers
    network-object host 172.17.2.23
    network-object host 172.17.2.28
    object-group protocol TCPUDP
    protocol-object udp
    protocol-object tcp
    access-list outside_access_in extended permit object-group mail.fcshool.org_svc_group any object mail_internal
    access-list outside_access_in extended permit tcp object nagios object mail_internal object-group nagios_svc_group
    access-list outside_access_in extended permit tcp any object faweb_external object-group http_s_svc_group
    access-list outside_access_in extended permit tcp any object netclassroom_external object-group http_s_svc_group
    access-list outside_access_in extended permit tcp any object blackbaud_external eq https
    access-list outside_access_in extended permit tcp any object spiceworks_external object-group http_s_svc_group
    access-list L2LAccesslist extended permit ip 172.17.0.0 255.255.0.0 172.18.0.0 255.255.0.0
    access-list inside_inbound extended permit object-group TCPUDP object-group DNS_Servers any eq domain
    access-list inside_access_in extended permit object-group DM_INLINE_PROTOCOL host 172.17.15.10 any inactive
    access-list inside_access_in extended permit tcp object-group MailServers any eq smtp
    access-list inside_access_in extended permit tcp host 172.17.14.10 any eq smtp
    access-list inside_access_in extended deny object-group TCPUDP any any eq domain
    access-list inside_access_in extended deny tcp any any eq smtp
    access-list inside_access_in extended permit ip any any
    access-list vpn_access extended permit ip any any
    pager lines 24
    logging asdm informational
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool vpnaddresspool 172.17.50.1-172.17.50.255
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-66114.bin
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static mail_internal mail_external
    nat (inside,outside) source static netclassroom_internal netclassroom_external
    nat (inside,outside) source static faweb_internal faweb_external
    nat (inside,outside) source static spiceworks_internal interface
    nat (inside,outside) source static blackbaud_internal blackbaud_external
    nat (inside,outside) source dynamic any interface
    nat (inside,outside) source static WorthStreet WorthStreet destination static DallasRoad DallasRoad
    nat (any,outside) source static remotevpnnetwork remotevpnnetwork destination static remotevpnnetwork remotevpnnetwork description NONAT for remote vpn users
    access-group outside_access_in in interface outside
    access-group inside_access_in in interface inside
    route outside 0.0.0.0 0.0.0.0 71.x.x.x 1
    route inside 172.17.0.0 255.255.0.0 172.17.2.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    ldap attribute-map CISCOMAP
      map-name  VPNALLOW IETF-Radius-Class
      map-value VPNALLOW FALSE NOACESS
      map-value VPNALLOW TRUE ALLOWACCESS
    dynamic-access-policy-record DfltAccessPolicy
    network-acl vpn_access
    aaa-server LDAP protocol ldap
    aaa-server LDAP (inside) host 172.17.2.28
    ldap-base-dn DC=campus,DC=fcschool,DC=org
    ldap-scope subtree
    ldap-naming-attribute sAMAccountName
    ldap-login-password Iw@FCS730w
    ldap-login-dn CN=VPN Admin,CN=Users,DC=campus,DC=fcschool,DC=org
    server-type microsoft
    ldap-attribute-map CISCOMAP
    user-identity default-domain LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    http 172.17.0.0 255.255.0.0 inside
    http 172.18.0.0 255.255.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set myset esp-aes-256 esp-sha-hmac
    crypto map outside_map 10 match address L2LAccesslist
    crypto map outside_map 10 set peer 70.x.x.x
    crypto map outside_map 10 set ikev1 transform-set myset
    crypto map outside_map 10 set reverse-route
    crypto map outside_map interface outside
    crypto ikev1 enable outside
    crypto ikev1 policy 1
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 65535
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    telnet 172.17.0.0 255.255.0.0 inside
    telnet 172.18.0.0 255.255.0.0 inside
    telnet 192.168.1.0 255.255.255.0 inside
    telnet timeout 5
    ssh 172.17.0.0 255.255.0.0 inside
    ssh 172.18.0.0 255.255.0.0 inside
    ssh 192.168.1.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    management-access management
    dhcpd address 192.168.1.2-192.168.1.254 management
    dhcpd enable management
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ssl encryption aes256-sha1 aes128-sha1 3des-sha1
    webvpn
    group-policy NOACCESS internal
    group-policy NOACCESS attributes
    vpn-simultaneous-logins 0
    vpn-tunnel-protocol ikev1
    group-policy ALLOWACCESS internal
    group-policy ALLOWACCESS attributes
    banner value Now connected to the FCS Network
    vpn-tunnel-protocol ikev1
    username iwerkadmin password i6vIlW5ctGaR0l7n encrypted privilege 15
    tunnel-group 70.x.x.x type ipsec-l2l
    tunnel-group 70.x.x.x ipsec-attributes
    ikev1 pre-shared-key FC$vpnn3tw0rk
    tunnel-group remoteaccessvpn type remote-access
    tunnel-group remoteaccessvpn general-attributes
    address-pool vpnaddresspool
    authentication-server-group LDAP
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny 
      inspect sunrpc
      inspect xdmcp
      inspect sip 
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:b599ba0f719f39b213e7f01fe55588ac
    : end

    Hi Derrick,
    I just did the same for a customer; replaced 2 PIX515s failover cluster with 5512X. The NAT change is major with ASAs version 8.3 and later...
    here's what you need: a manual NAT rule called twice NAT (policy NAT or NONAT is the old terminology) for the VPNs to work. also add the no-proxy-arp keyword:
    nat (inside,outside) source static INSIDE_NETWORKS INSIDE_NETWORKS VPN_NETWORKS VPN_NETWORKS no-proxy-arp
    nat (inside,outside) source static INSIDE_NETWORKS INSIDE_NETWORKS RA_VPN_NETWORKS RA_VPN_NETWORKS no-proxy-arp
    then the dynamic PAT for internet access (after the twice NATs for VPN); could be a manual NAT like you did, or preferred an object NAT.
    you did:
    nat (inside,outside) source dynamic any interface
    would also work with object nat:
    object network INSIDE_NETWORKS
    subnet ...
    nat (inside,outside) dynamic interface
    Same on the other side (except the networks are reversed since the inside network is now what the other side refers to as vpn network and vice versa)
    If you don't put the no-proxy-arp, your NAT configuration will cause network issues.
    also to be able to pass pings through ASA, add the following:
    policy-map global_policy
    class inspection_default
      inspect icmp
    The asa will do some basic inspection of the ICMP protocol with that config ex. it will make sure there is 1 echo-reply for each echo-request...
    hope that helps,
    Patrick

  • Upgrade from JDK 1.2.2 to JDK 1.4.2. Any code changes required?

    Hi,
    We are in the processes of upgrading the JDK versions on servers to JDK 1.4.2 to support other software upgrades.
    The JDK versions on each of the servers are at different versions. On one of the servers, the version of JDK is currently at JDK 1.2.2_10. Can somebody please advise me if there would be any code changes required to support this upgrade (such as some methods being depreciated)?
    We are also evaluating if we need to upgrade to JDK 1.4.5. In such a case, would there be any code changes required to upgrade from JDK 1.4.1_x to JDK 1.4.5. I assume there wouldn't be any changes for this minor upgrade but just want to confirm.
    I would really appreciate an early reply.
    Thanks in advance.
    Regards,
    Vamshi

    "1.4.5" - you meant "1.5" ? :)
    About deprecations -- you will be warned by the compiler. E.g. "assert", "enum" are keywords and cannot be used as method names.
    The rest depends on your application. The more complex it is, the more differences can be encountered. You certainly need to run a test cycle for it with the new platform.
    From my experience, I can list some issues that I have read about or have experienced myself:
    1) serialization: the algorithm used to calculate the serialVersionUID had some changes between Java versions, due to compiler-added extra methods.
    If you don't have serialized instances, or your serialVersionUID is specified explicitly, you are safe.
    2) class loading order can be different in different platforms
    Once ago I have seen a paper from BEA Systems highlighting some open topics that can arise when migrating between different vendor's JVMs. Probably, it is the one:
    http://edocs.bea.com/jrockit/geninfo/devapps/codeprac.html
    In my friend's case, there was some class-initialization logic, that behaved differently when class loading order changed.
    3) Swing applications can sometimes behave slightly different.
    E.g., I observed some changes in focus handling, although minor ones. Fixed with several lines of code.
    4) Some libraries can depend on particular J2SE version. E.g. J2EE ones.
    E.g. I was not able to run J2EE 1.4 thick client application with JRE 1.5. The j2ee library used by the app either had some dependencies on sun.* classes, or on some protocols (not sure, I don't remember it well).
    5) Regression bugs are sometimes encountered. I.e. something that worked, does not work now.
    Summary: You need testing.

  • ABAP Code Changes During Upgrade from 4.7C to ECC6

    Hi all,
    I'm in process of collecting information for our next upgrade.
    We are on 4.7C and are planning to upgrade to ECC6. We wanted to know what changes shall be required on ABAP side during this upgrade. e.g. certain ABAP commands which are obselete, few tables , few fucntional modules being obselete.
    Any specific functional areas/transcation codes being obselete which in turn would make Uer Exit redudant etc.....
    Could somebody please help me out with some info regarding this upgrade? Some links or any hint you can give would help me a lot. (Whether technical or functional..all very welcome!).
    Thanks in advance
    Moderator message: topic too broad to be answered in a forum thread, many people had to go through this, please search for available information/documentation.
    Edited by: Thomas Zloch on Jun 14, 2011 9:31 AM

    Hi ,
    I too got an error of this type .
    The resolution is as follows :
    login as user SAP<SID> in the oracle database .
    SQL> drop tabel <tablename>;
    Restart the upgrade from PARMVNT_SHD phase.
    Regards
    Ratnajit

  • IMAQ Upgrade seems to have broken some code

    We recently upgraded from the IMAQ 4.0 to 4.5, and some pieces of labview code we wrote have broken. When i boot it up, it gives me warnings like the ones at the bottom. I figure the simplest fix is just to download the old .dll files and overwrite them somehow...does anybody have any ideas on how to do this?
    imgBufferElement.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    imgClose.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    imgCreateBufList.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    imgSessionAttribute.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    imgSessionLineTrigSource2.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    imgSessionTriggerConfigure2.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    imgSetRoi.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".
    SessionLookUp.vi
        - The shared library expected to be at "imaq.dll" was loaded from "C:\WINDOWS\system32\imaq.dll".

    gswang wrote:
    Oops, sorry, actually. I'm not sure what version it used to be, but it currently is 4.1. Is there a way to determine what we upgraded from?
    No and those errors are no errors but warnings and as such in fact a bit overreacting. What it says is that a Call Library Node trying to load imaq.dll (which without path means to load it from the one of the Windows standard search paths where the system directory is also part of) has been redirected to load said DLL from the system directory. A rather strange message in fact as those are virtually the same for a properly configured Windows system. Bascially you can ignore this specific warning completely as it informs you of something that Windows will do anyhow, unless you start to copy and move DLLs that were originally installed in the system directory.
    What LabVIEW version is that?
    Rolf Kalbermatter
    Message Edited by rolfk on 08-11-2009 09:00 AM
    Rolf Kalbermatter
    CIT Engineering Netherlands
    a division of Test & Measurement Solutions

Maybe you are looking for

  • Development and Test on same machine

    Hi, In my current setup I have a development application, a test application and a production application. The dev. and test is on the same machine, with different APP ID's. Dev is 102, and test is 110 At first there was no problems with this. But no

  • How can I capture and re-present Oracle contraint/check/DML errors?

    Hi, New to APEX, I have a Designer/Web-PLSQL background. In Designer I can define the messages that I want the user to see when check, constraint, etc. errors are generated by the application interaction with the database server (done through table A

  • PCH Logical Database - Set stucture conditions

    Hi All, Can anyone tell me what is the use or how to use the Set structure conditions in PCH logical database. Best regards, Aravind

  • I-tunes folder doesn't appear

    I am trying to move files from old computer to the new one, and the problem is that when I get to the step where I open the i-pod in my browser, there IS no i-tunes folder. Calendars are there, and notes are there, and contacts... But no i-tunes. Wha

  • Address Panel in iCal empty but typing in characters yields search results

    I upgraded our 10.5 iCal Server to a Snow Leopard server about 6 weeks ago. At that time I also began upgrading users to 10.6 from 10.5. The address panel of iCal functioned properly with 10.5 clients before and after the server upgrade. However the