Virtual Interface generation bug with NetWeaver ?

I use the Web Service generation wizard to generate a virtual interface which exposes methods in an EJB. As one of the parameters I pass a simple java bean, lets say:
public class StatusCode
    private String name;
    private boolean buggy;
    public String getName() {...}
    public void setName(String newName){...}
    public boolean isBuggy() {...}
    public void setBuggy(boolean trueOrFalse){...}
When I look at the virtual interface generated, especially at the Types tab, my boolean attribute is not included.
If I change the getter to "getBuggy()", the attribute is included in the VI. The only problem is that the typical Java Bean framework, say from sun or ibm, always map 'boolean' getters to 'isSomething()' and not 'getSomething()'.
Is this a bug with NW? Is there a fix or workaround for this ?
My version of NW:
Version: 2.0.7
Build id: 200407270250
Thanks in advance,
Mark
(If this is not the right forum, could someone suggest where I can post this question?)

Hi.  As of Netweaver 2004s,  the virtual interface piece has be absorbed into the creation of the web service definition, so there is no need to create it as well.   When you are getting the 403,  how are you trying to run this, using the Web Service Homepage?  If so, you will need to configure what j2e engine that you want to use to use.  You can do this in WSADMIN under the Administration settings.   Check that this is set.  YOu must know the URL of your j2e engine.
Regards,
Rich Heilman

Similar Messages

  • Virtual Interface generation bug in NetWeaver ?

    I use the Web Service generation wizard to generate a virtual interface which exposes methods in an EJB. As one of the parameters I pass a simple java bean, lets say:
    public class StatusCode
    private String name;
    private boolean buggy;
    public String getName() {...}
    public void setName(String newName){...}
    public boolean isBuggy() {...}
    public void setBuggy(boolean trueOrFalse){...}
    When I look at the virtual interface generated, especially at the Types tab, my boolean attribute is not included.
    If I change the getter to "getBuggy()", the attribute is included in the VI. The only problem is that the typical Java Bean framework, say from sun or ibm, always map 'boolean' getters to 'isSomething()' and not 'getSomething()'.
    Is this a bug with NW? Is there a fix or workaround for this ?
    My version of NW:
    Version: 2.0.7
    Build id: 200407270250
    Thanks in advance,
    Mark
    I posted this question also in the NW development forum, but so far no replies.

    I try to login by use:
    username : Administrator
    password : <master password> (at least 1 number)
    I try to login many times but it always fails.
    (I am very sure about my password since i also try to reinstall many times - 10th. both J2EE 1.4 and Java EE 5)
    Ivaylo Ivanov, do you sure that you test with this new edition. (Not the previous edition)
    I see the other persons get the result like me:
    Telnet Administration
    SAP J2EE Engine v7.100
    User name: Administrator
    Password:
    The user account is either expired, or not valid yet.
    Login failed. Reason: The user account is either expired, or not valid yet.
    Connection to host lost.
    if my login is not correct, it will tell the other messags.
    Telnet Administration
    SAP J2EE Engine v7.100
    User name: f
    Password:
    Cannot authenticate the user.
    Login failed. Reason: Cannot authenticate the user.

  • UCS P81E Virtual Interface Card

    Hi all,
    This is a newbie question.
    1. Is the UCS P81E Virtual Interface Card compatible with Cisco Catalyst 3750-X and 3560-X Series Switches 10GE Network Module (C3KX-NM-10G)?
    2. Does VIC require a DCE switch such as the Nexus 5000?
    3. Does VIC require a FCoE switch such as the Nexus 5000?
    4. Is there any other requirement?
    TIA
    Joseph

    for server uplink to the LAN Nexus is not a must
    FCoE if used you need a device support it like nexus if you not using it then you do not need
    if want to use multiple gourp links/etherchanne you could use LACP with the Cisco switch
    other requriments is make sure you allow the vlans created in you VM enviroment to be paased over the trunk link in the switch port
    HTH
    if helpful Rate

  • Getaddrinfo() fails with 32 virtual interfaces?

    Hi all, this is regarding Solaris 9 on Sparc.
    We have code that fails when calling getaddrinfo() when the user has configured a large number of virtual Ethernet interfaces (multi-homing). If you have only a couple of network interfaces configured, the call works fine, but if you have a lot of virtual interfaces, 20+, the call fails.
    Any ideas what we might be doing wrong, or if there is an update to fix this? On another system, that is running the latest patches for Solaris 9, a call to t_kconnect fails with a EPROTO error when there are 20 virtual interfaces, but succeeds when there are fewer interfaces configured (like just the three physical interfaces).
    Thanks!
    Mark

    Thanks for reporting this - it is a new manifestation of a known bug (#6184000), however I don't have a date for a correction yet.
    Blaise

  • ABAP web service/ Virtual Interface

    Hi all,
    I'm trying to create a webservice for a ZRFC,when using the wizard in SE37>utilites>more utilities>create web service> from function module ,it's creating only the Webservice ,not prompting for a "virtual interface" .Same thing happens in se80,in create,under enterprise services node,i'm getting options only for web service and proxy object. Is there some thing missing.when excuting the webservice created from WSADMIN i'm getting 403 error ,page not found.
    how do i create virtual interface ??.
    we have version ECC 6.0,with software component SAP_BASIS 700 and java stack acitivated.How do i know what SAP Netweaver version we have ??.
    any help !
    Thanks
    Bvan

    Hi.  As of Netweaver 2004s,  the virtual interface piece has be absorbed into the creation of the web service definition, so there is no need to create it as well.   When you are getting the 403,  how are you trying to run this, using the Web Service Homepage?  If so, you will need to configure what j2e engine that you want to use to use.  You can do this in WSADMIN under the Administration settings.   Check that this is set.  YOu must know the URL of your j2e engine.
    Regards,
    Rich Heilman

  • INS-40925 - One or more nodes have interfaces not configured with a subnet that is common across all cluster nodes.

    Hi All,
    I am facing the below error while installing Oracle RAC in Silent Mode.
    SEVERE: There are no common subnets represented by network interfaces across all cluster nodes.
    SEVERE: [FATAL] [INS-40925] One or more nodes have interfaces not configured with a subnet that is common across all cluster nodes.
       CAUSE: Not all nodes have network interfaces that are configured on subnets that are common to all nodes in the cluster.
       ACTION: Ensure all cluster nodes have a public interface defined with the same subnet accessible by all nodes in the cluster.
    My /etc/hosts is given below.
    127.0.0.1        localhost    localhost.localdomain
    #Public
    192.168.1.101      rac1        rac1.localdomain
    192.168.1.102    rac2        rac2.localdomain
    #Private
    192.168.2.101    rac1-priv    rac1-priv.localdomain
    192.168.2.102    rac2-priv    rac2-priv.localdomain
    #Virtual
    192.168.1.103      rac1-vip    rac1-vip.localdomain
    192.168.1.104    rac2-vip    rac2-vip.localdomain
    #SCAN
    192.168.1.105    rac-scan    rac-scan.localdomain
    Could you please help me to get rid of the error INS-40925....Any Idea...???

    Hi Ramesh,
    Please find the result of ifconfig -a from both nodes RAC1 & RAC2.
    ifconfig -a in RAC1
    [oracle@rac1 Desktop]$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 08:00:27:17:7A:D5
              inet addr:192.168.1.101  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::a00:27ff:fe17:7ad5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:102 errors:0 dropped:0 overruns:0 frame:0
              TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:25472 (24.8 KiB)  TX bytes:3322 (3.2 KiB)
              Interrupt:19 Base address:0xd020
    eth1      Link encap:Ethernet  HWaddr 08:00:27:C0:AC:DB
              inet addr:192.168.2.101  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::a00:27ff:fec0:acdb/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:4 errors:0 dropped:0 overruns:0 frame:0
              TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:240 (240.0 b)  TX bytes:816 (816.0 b)
              Interrupt:16 Base address:0xd240
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:56 errors:0 dropped:0 overruns:0 frame:0
              TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:6394 (6.2 KiB)  TX bytes:6394 (6.2 KiB)
    virbr0    Link encap:Ethernet  HWaddr 52:54:00:CC:BD:FB
              inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    virbr0-nic Link encap:Ethernet  HWaddr 52:54:00:CC:BD:FB
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:500
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    ifconfig -a in RAC2
    [oracle@rac2 Desktop]$ ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 08:00:27:C9:38:82
              inet addr:192.168.1.102  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::a00:27ff:fec9:3882/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:122 errors:0 dropped:0 overruns:0 frame:0
              TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:32617 (31.8 KiB)  TX bytes:5157 (5.0 KiB)
              Interrupt:19 Base address:0xd020
    eth1      Link encap:Ethernet  HWaddr 08:00:27:90:B5:A0
              inet addr:192.168.2.102  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::a00:27ff:fe90:b5a0/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:4 errors:0 dropped:0 overruns:0 frame:0
              TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:240 (240.0 b)  TX bytes:746 (746.0 b)
              Interrupt:16 Base address:0xd240
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:56 errors:0 dropped:0 overruns:0 frame:0
              TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:6390 (6.2 KiB)  TX bytes:6390 (6.2 KiB)
    virbr0    Link encap:Ethernet  HWaddr 52:54:00:CC:BD:FB
              inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
    virbr0-nic Link encap:Ethernet  HWaddr 52:54:00:CC:BD:FB
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:500
              RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

  • Is it a bug in NetWeaver CE 7.1 SP3 server? Any hint to resolve this?

    Hi Experts,
    I have installed NetWeaver CE 7.1 SP3 server.
    Using Developer Studio's Deploy view I have deployed successfully my J2EE application as ear file.
    My ear file contains one web application as war file. This web application uses custom tag. and .tld file is saved under /WEB-INF directory.
    When I try to access my application I am getting below runtime exception.
    Is it a bug in NetWeaver CE 7.1 SP3 server? Any hint to resolve this?
    Thanks in advance.
    Fairoz
    #1.5 #C000C0A8057F001D00000000000007BC00A0D8EAF9E2ACD4#1199941553035#com.sap.engine.services.servlets_jsp.client.RequestInfoServer#sap.com/earapp#com.sap.engine.services.servlets_jsp.client.RequestInfoServer#Guest#79####b64a0e61bf3911dc8067001a4b582aa7#HTTP Worker [3]##0#0#Error##Plain###Runtime error in processing of the JSP file [E:
    usr
    sap
    CE1
    J00
    j2ee
    cluster
    apps
    sap.com
    earapp
    servlet_jsp
    sums
    root
    jsp
    pcm
    CFMLogin.jsp]. The error is: com.sap.engine.services.servlets_jsp.jspparser_api.exception.JspParseException: Cannot parse custom tag with short name [message].
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.xmlsyntax.CustomJspTag.action(CustomJspTag.java:125)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:974)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:213)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:69)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.GenerateJavaFile.generateJavaFile(GenerateJavaFile.java:72)
         at com.sap.engine.services.servlets_jsp.server.jsp.JSPProcessor.parse(JSPProcessor.java:259)
         at com.sap.engine.services.servlets_jsp.server.jsp.JSPProcessor.generateJavaFile(JSPProcessor.java:190)
         at com.sap.engine.services.servlets_jsp.server.jsp.JSPProcessor.parse(JSPProcessor.java:123)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.getClassName(JSPChecker.java:313)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.compileAndGetClassName(JSPChecker.java:245)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.processJSPRequest(JSPChecker.java:112)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JspParser.generateJspClass(JspParser.java:121)
         at com.sap.engine.services.servlets_jsp.server.servlet.JSPServlet.service(JSPServlet.java:194)
         at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
         at com.sap.engine.services.servlets_jsp.server.Invokable.invoke(Invokable.java:66)
         at com.sap.engine.services.servlets_jsp.server.runtime.RequestDispatcherImpl.doWork(RequestDispatcherImpl.java:246)
         at com.sap.engine.services.servlets_jsp.server.runtime.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:334)
         at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:408)
         at com.sun.faces.application.ViewHandlerImpl.executePageToBuildView(ViewHandlerImpl.java:439)
         at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:114)
         at org.ajax4jsf.framework.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:101)
         at org.ajax4jsf.framework.ajax.AjaxViewHandler.renderView(AjaxViewHandler.java:222)
         at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:106)
         at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:251)
         at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:144)
         at javax.faces.webapp.FacesServlet.service(FacesServlet.java:245)
         at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.runServlet(FilterChainImpl.java:163)
         at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.doFilter(FilterChainImpl.java:82)
         at org.ajax4jsf.framework.ajax.xmlfilter.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:75)
         at org.ajax4jsf.framework.ajax.xmlfilter.BaseFilter.doFilter(BaseFilter.java:213)
         at com.sap.engine.services.servlets_jsp.server.runtime.FilterChainImpl.doFilter(FilterChainImpl.java:74)
         at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.runServlet(HttpHandlerImpl.java:425)
         at com.sap.engine.services.servlets_jsp.server.HttpHandlerImpl.handleRequest(HttpHandlerImpl.java:289)
         at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:387)
         at com.sap.engine.services.httpserver.server.RequestAnalizer.startServlet(RequestAnalizer.java:376)
         at com.sap.engine.services.servlets_jsp.filters.ServletSelector.process(ServletSelector.java:85)
         at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:71)
         at com.sap.engine.services.servlets_jsp.filters.ApplicationSelector.process(ApplicationSelector.java:160)
         at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:71)
         at com.sap.engine.services.httpserver.filters.WebContainerInvoker.process(WebContainerInvoker.java:67)
         at com.sap.engine.services.httpserver.chain.HostFilter.process(HostFilter.java:9)
         at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:71)
         at com.sap.engine.services.httpserver.filters.ResponseLogWriter.process(ResponseLogWriter.java:60)
         at com.sap.engine.services.httpserver.chain.HostFilter.process(HostFilter.java:9)
         at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:71)
         at com.sap.engine.services.httpserver.filters.DefineHostFilter.process(DefineHostFilter.java:27)
         at com.sap.engine.services.httpserver.chain.ServerFilter.process(ServerFilter.java:12)
         at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:71)
         at com.sap.engine.services.httpserver.filters.MonitoringFilter.process(MonitoringFilter.java:29)
         at com.sap.engine.services.httpserver.chain.ServerFilter.process(ServerFilter.java:12)
         at com.sap.engine.services.httpserver.chain.AbstractChain.process(AbstractChain.java:71)
         at com.sap.engine.services.httpserver.server.Processor.chainedRequest(Processor.java:309)
         at com.sap.engine.services.httpserver.server.Processor$FCAProcessorThread.run(Processor.java:222)
         at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)
         at java.security.AccessController.doPrivileged(Native Method)
         at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:152)
         at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:247)
    Caused by: com.sap.engine.services.servlets_jsp.jspparser_api.exception.JspParseException: Cannot initialize TagBeginGenerator.
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.taglib.TagBeginGenerator.init(TagBeginGenerator.java:184)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.xmlsyntax.CustomJspTag.action(CustomJspTag.java:121)
         ... 79 more
    Caused by: java.lang.VerifyError: Cannot inherit from final class
         at java.lang.ClassLoader.defineClass1(Native Method)
         at java.lang.ClassLoader.defineClass(ClassLoader.java:654)
         at com.sap.engine.boot.loader.ResourceMultiParentClassLoader.loadClassLocal(ResourceMultiParentClassLoader.java:198)
         at com.sap.engine.boot.loader.MultiParentClassLoader.findClassInLoaderGraph(MultiParentClassLoader.java:302)
         at com.sap.engine.boot.loader.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:256)
         at com.sap.engine.boot.loader.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:228)
         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:353)
         at java.lang.ClassLoader.defineClass1(Native Method)
         at java.lang.ClassLoader.defineClass(ClassLoader.java:654)
         at com.sap.engine.boot.loader.ResourceMultiParentClassLoader.loadClassLocal(ResourceMultiParentClassLoader.java:198)
         at com.sap.engine.boot.loader.MultiParentClassLoader.findClassInLoaderGraph(MultiParentClassLoader.java:302)
         at com.sap.engine.boot.loader.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:256)
         at com.sap.engine.boot.loader.MultiParentClassLoader.loadClass(MultiParentClassLoader.java:228)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.taglib.TagBeginGenerator.init(TagBeginGenerator.java:178)
         ... 80 more

    Hello,
    I am facing similar kind of issue.
    Can any body help me?
    Thanks in advance.
    Caused by: com.sap.engine.services.servlets_jsp.jspparser_api.exception.JspParseException: Cannot parse custom tag with short name [out].
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.xmlsyntax.CustomJspTag.action(CustomJspTag.java:183)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspIncludeDirective.action(JspIncludeDirective.java:51)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.customTagAction(JspElement.java:994)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.JspElement.action(JspElement.java:228)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:59)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.ElementCollection.action(ElementCollection.java:69)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.GenerateJavaFile.generateJavaFile(GenerateJavaFile.java:72)
         at com.sap.engine.services.servlets_jsp.server.jsp.JSPProcessor.parse(JSPProcessor.java:270)
         at com.sap.engine.services.servlets_jsp.server.jsp.JSPProcessor.generateJavaFile(JSPProcessor.java:194)
         at com.sap.engine.services.servlets_jsp.server.jsp.JSPProcessor.parse(JSPProcessor.java:126)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.getClassName(JSPChecker.java:319)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.compileAndGetClassName(JSPChecker.java:248)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.getClassNameForProduction(JSPChecker.java:178)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JSPChecker.processJSPRequest(JSPChecker.java:109)
         at com.sap.engine.services.servlets_jsp.jspparser_api.JspParser.generateJspClass(JspParser.java:154)
         at com.sap.engine.services.servlets_jsp.server.servlet.JSPServlet.service(JSPServlet.java:193)
         ... 47 more
    Caused by: com.sap.engine.services.servlets_jsp.jspparser_api.exception.JspParseException: Attribute [value] of [<c:out>] can accept only static values.
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.taglib.TagBeginGenerator.calculateAttributeValue(TagBeginGenerator.java:476)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.taglib.TagBeginGenerator.generateSetters(TagBeginGenerator.java:394)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.taglib.TagBeginGenerator.generateServiceMethodStatements(TagBeginGenerator.java:562)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.taglib.TagBeginGenerator.generate(TagBeginGenerator.java:678)
         at com.sap.engine.services.servlets_jsp.jspparser_api.jspparser.syntax.xmlsyntax.CustomJspTag.action(CustomJspTag.java:181)
         ... 64 more
    Regrads,
    Sankalp

  • Code generation bug in C++ 5.0

    The enclosed test program generates incorrect code
    with C++ 5.0 when -g is not used.
    The problem showed up in our production code
    and concerns any reference counted smart pointer
    implementation.
    The test program is specifically written to demonstrate
    the problem and diagnose a reference miscount.
    With any optimization at all (without -g, and/or with
    any level of -O including no -O) it generates
    incorrect results. With -g the results are correct.
    gcc compiles this correctly with any optimizations
    selected.
    // main.cc
    // test program to demonstrate code generation bug in
    // Sun WorkShop Compilers C++ 5.0
    // bug exhibited as of 27th April 2001
    // relevant patches applied:
    // 107289-05 Packages: SPROcc
    // 107390-12 Packages: SPROtl7x, SPROsclx, SPROtll7x, SPROcplx, SPROlgcx
    // 107311-12 Packages: SPROscl, SPROtll7, SPROtlbn7, SPROcpl, SPROgc, SPROlgc
    // 107357-11 Packages: SPROlang
    // correct behaviour with CC -g:
    // CC -g main.cc -o main; ./main
    // incorrect behaviour with CC (no -g):
    // CC main.cc -o main; ./main
    #include <stdio.h>
    class O {
    public:
    inline O() : m_refCount(0) { };
    inline void ref() { m_refCount++; }
    inline void deref() { m_refCount--; }
    inline int refCount() { return(m_refCount); }
    private:
    int m_refCount;
    class R {
    public:
    inline R() : m_object(0) { };
    inline R(const R &r) : m_object(r.m_object) { if (m_object) m_object->ref(); }
    inline R(O *o) : m_object(o) { if (o) o->ref(); };
    inline ~R() { if (m_object) m_object->deref(); }
    inline R &operator =(const R &r) {
    if (this == &r) return(*this);
    O *o = m_object;
    if (m_object = r.m_object) m_object->ref();
    if (o) o->deref();
    return(*this);
    inline R &operator =(O *n) {
    if (m_object == n) return(*this);
    O *o = m_object;
    if (m_object = n) n->ref();
    if (o) o->deref();
    return(*this);
    inline operator O *() const { return(m_object); }
    inline O *operator ->() const { return(m_object); }
    private:
    O *m_object;
    class B {
    public:
    inline B(const R &r) : m_ref(r) { };
    inline const R &ref() { return(m_ref); }
    private:
    R m_ref;
    R buggy(int notnull, B &b)
    return(notnull ? b.ref() : 0); // BUG HERE
    int main()
    O o;
    R r(&o);
    B b(r);
    int i;
    for (i = 0; i < 20; i++) {
    R s;
    s = buggy(!0, b);
    printf("refCount: %d (should be 2)\n", o.refCount());

    How do I file a bug report for this and get
    a bug ID assigned?

  • Virtual Interface IP address

    Hi,
    In all Cisco documentation 1.1.1.1 is always specified as Virtual Interface IP address.
    Here is my concern. When wireless client gets an IP address (through DHCP), 1.1.1.1 is entered as DHCP server which means that at 50% lease time client will attempt DHCP Request to 1.1.1.1
    1.1.1.1 is not routable on the wired network, but controller makes sure that it is accessible on the wireless network.
    The problem is if you have both wired and wireless connected, default gateway through wired connection wil have less cost, so client will attempt to send traffic to 1.1.1.1 using wired interface and will obviously fail.
    At 83.5% of lease time client will attempt full DHCP process starting from Discovery and I guess this is when the IP on wireless NIC will be renewed, cause those Discovery messages are to 0.0.0.0....
    Is my understanding correct?
    Thanks!
    David

    Hi,
    With both wired and wireless active at the same time (when laptop is docked for example)DHCP Request to 1.1.1.1 will fail cause it will be sent using wired interface and not wireless (default route metric in the host's routing table). This will cause this DHCP Request to fail at 50% lease time.
    Next step is DHCP Discover at 83.5% of lease time. Destination IP will be 255.255.255.255 and it will be generated specifically on wireless interface, since this in the interface that needs to renew the IP.
    This is exactly my question. Will this Discover to 255.255.255.255 go through wireless interface, cause this is the interface that needs IP addresses renewed. If so, I assume it will succeed and client's IP address will be renewed.
    A bit worse than renewing at 50% lease time as a normal DHCP process, but better than loosing the IP at all when 100% lease time hits. 83.5% is somewhere in between...
    Comments?
    Can you also advise how do you disable DHCP Relay function on the controller? Do you need to remove DHCP IP addresses in WLAN configs?
    Another question is about needing WLAN for Management interface. Is it needed for any reason? WLANs are always documented to be bound to Dynamic Interfaces and not Management, however Management interface does appear in the drop down menu under WLAN configuration. Thoughts?
    Thanks!
    David

  • Transaction code to create virtual interface.

    I want to create a web service from a RFC. For that first, virtual interface needs to be created which will be linked to the RFC. Can u please tell me what is the transaction code to create a virtual interface.

    Thankx for ur reply.
    Now I have created the Web service. To do this I have done the followings-
    1. created one RFC enabled Function Module.
    2. Created one virtual interface
    3. Created Web service defination.
    4. Released Web service from the wsconfig transaction.
    Then from The transaction wsadmin I have opened the browser by clicking Web Service > Web Service Homepage (from menu)
    After logging in it , shows the web service and RFC with in it. Now after clicking the Test link from the browser it asks for the parameter of the RFC. But After populating the parameters and clicking send button. it gives NullpointerException.
    exact err message  is --
    An error has occurred. Maybe the request is not accepted by the server:
    java.lang.NullPointerException

  • Migrate PPPoE/Virtual-Interface from 7206VXR to ASR 1002

    Good Day,
    I have been attempting to migrate services from an existing 7206VXR to a recently purchased ASR1002 and could use some help.
    My mistake in assuming that the config would be similar to 7206VXR, but there are changes - mainly VRF and cisco-avpair attributes that need added to radius.
    Our lab test, with the below ASR config will allow the user to authenticate successfully but does not assign IP address.
    User Status
    User is online
    Last Connection
    2012-09-21 10:27:47
    Online Time
    1 hours, 4 minutes, 15 seconds
    Server (NAS)
    206.251.40.52 (MAC: )
    User Workstation
    (MAC: )
    User Upload
    6.5 Kb
    User Download
    6.51 Kb
    ID
    HotSpot
    Username
    IP Address
    Start Time
    Stop Time
    Total Time
    Upload (Bytes)
    Download (Bytes)
    Termination
    NAS IP Address
    7837056
    [email protected]
    2012-09-21 10:27:47
    1 hours, 4 minutes, 15 seconds
    6.5 Kb
    6.51 Kb
    206.251.40.52
    I have also tried assigning a static IP to the CPE, however the CPE cannot see 199.200.107.1.
    No doubt the problem is something simple I appreciate any help or suggestions.
    Radius Reply Attributes
    Cisco-AVPair += ip:vrf-id=CV_VRF
    Cisco-AVPair += ip:ip-unnumbered=Loopback 111 (generates unsupported sub-interface errors when used)
    7206VXR Config-
    aaa new-model
    aaa authentication login default group radius
    aaa authentication login con none
    aaa authentication login vty line local
    aaa authentication login localauth local
    aaa authentication ppp default if-needed group radius
    aaa authorization network default group radius
    aaa authorization network noauth none
    aaa accounting update periodic 5
    aaa accounting network default
    action-type start-stop
    group radius
    aaa accounting system default
    action-type start-stop
    group radius
    bba-group pppoe 156
    virtual-template 156
    sessions per-vc limit 65000
    sessions per-mac limit 65000
    sessions per-vlan limit 65000
    interface Loopback0
    ip address 10.1.1.3 255.255.255.255
    ip ospf network point-to-point
    interface GigabitEthernet0/1
    no ip address
    no ip redirects
    duplex full
    speed 1000
    media-type rj45
    no negotiation auto
    no cdp enable
    interface GigabitEthernet0/1.20
    description ROUTER GATEWAY
    encapsulation dot1Q 20
    ip address 206.251.40.51 255.255.255.248
    no cdp enable
    interface GigabitEthernet0/2
    no ip address
    no ip redirects
    duplex full
    speed 1000
    media-type rj45
    no negotiation auto
    no cdp enable
    interface GigabitEthernet0/2.156
    encapsulation dot1Q 156
    ip address 199.30.185.1 255.255.255.0 secondary
    ip address 199.30.186.1 255.255.255.0 secondary
    ip address 199.30.187.1 255.255.255.0 secondary
    ip address 199.30.184.1 255.255.255.0
    pppoe enable group 156
    no cdp enable
    interface Virtual-Template156
    ip unnumbered GigabitEthernet0/2.156
    no ip redirects
    no ip route-cache cef
    peer default ip address pool IP_POOL156
    ppp mtu adaptive
    ppp authentication pap
    ip local pool IP_POOL156 199.30.184.2 199.30.184.254
    ip local pool IP_POOL156 199.30.185.2 199.30.185.254
    ip local pool IP_POOL156 199.30.186.2 199.30.186.254
    ip local pool IP_POOL156 199.30.187.2 199.30.187.254
    no ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip route 199.30.184.0 255.255.252.0 Null0 200
    ip prefix-list AS19045 seq 10 permit 199.30.184.0/22
    ip radius source-interface GigabitEthernet0/1.20
    radius-server host x.x.x.x auth-port 1812 acct-port 1813
    radius-server retransmit 1
    radius-server timeout 60
    radius-server key ********
    radius-server vsa send accounting
    radius-server vsa send authentication
    ASR 1002 Config (attempt)
    aaa new-model
    aaa group server radius AAA_CV_VRF
    server 208.98.188.6 auth-port 1812 acct-port 1813
    aaa authentication login default group AAA_CV_VRF
    aaa authentication login con none
    aaa authentication login vty line local
    aaa authentication login localauth local
    aaa authentication ppp default if-needed group AAA_CV_VRF
    aaa authorization network default group AAA_CV_VRF
    aaa authorization network noauth none
    aaa accounting update newinfo periodic 60
    aaa accounting network default start-stop group AAA_CV_VRF
    aaa accounting connection default start-stop group AAA_CV_VRF
    aaa accounting system default
    action-type start-stop
    group AAA_CV_VRF
    aaa accounting resource default start-stop group AAA_CV_VRF
    aaa session-id common
    aaa policy interface-config allow-subinterface
    clock timezone MST -7 0
    clock summer-time MST recurring
    no ip source-route
    ip vrf CV_VRF
    rd 1:1
    virtual-profile if-needed
    multilink bundle-name authenticated
    bba-group pppoe 111
    description TEST
    virtual-template 111
    sessions per-vc limit 65000
    sessions per-mac limit 65000
    sessions per-vlan limit 65000
    sessions auto cleanup
    interface Loopback0
    ip address 10.1.1.4 255.255.255.255
    ip ospf network point-to-point
    interface Loopback111
    description TEST
    ip vrf forwarding CV_VRF
    ip address 199.200.107.1 255.255.255.0
    interface GigabitEthernet0/0/2
    no ip address
    no ip redirects
    no negotiation auto
    interface GigabitEthernet0/0/2.20
    description ROUTER GATEWAY
    encapsulation dot1Q 20
    ip address 206.251.40.52 255.255.255.248
    interface GigabitEthernet0/0/3
    no ip address
    no ip redirects
    no negotiation auto
    interface GigabitEthernet0/0/3.111
    encapsulation dot1Q 111
    ip vrf forwarding CV_VRF
    no ip proxy-arp
    pppoe enable group 111
    interface Virtual-Template111
    ip unnumbered GigabitEthernet0/0/3.111
    no ip redirects
    no ip route-cache cef
    peer default ip address pool IP_POOL111
    ppp mtu adaptive
    ppp authentication pap
    router ospf 19045
    router-id 10.1.1.4
    network 10.1.1.4 0.0.0.0 area 0.0.0.0
    network 199.200.107.0 0.0.0.255 area 0.0.0.0
    network 206.251.40.48 0.0.0.7 area 0.0.0.0
    router bgp 19045
    bgp log-neighbor-changes
    network 199.200.104.0 mask 255.255.252.0
    network 206.251.40.0 mask 255.255.248.0
    neighbor 10.1.1.1 remote-as 19045
    neighbor 10.1.1.1 description IBGP_PEER_ASR
    neighbor 10.1.1.1 update-source Loopback0
    neighbor 10.1.1.1 next-hop-self
    ip local pool IP_POOL111 199.200.107.2 199.200.107.254
    no ip forward-protocol nd
    no ip http server
    no ip http secure-server
    ip route 0.0.0.0 0.0.0.0 206.251.40.49
    ip route 199.200.104.0 255.255.252.0 Null0 200
    ip prefix-list AS19045 seq 10 permit 199.200.104.0/22
    ip radius source-interface GigabitEthernet0/0/2.20
    radius-server host x.x.x.x auth-port 1812 acct-port 1813 key ********
    radius-server retransmit 1
    radius-server timeout 60
    radius-server vsa send accounting
    radius-server vsa send authentication
    Debug Info
    *Sep 20 22:03:26.677: [910]PPPoE 1911: AAA get dynamic attrs
    *Sep 20 22:03:26.678: [910]PPPoE 1911: O PADT  R:6468.0cf7.8546 L:f866.f287.7c83 Gi0/0/3.111
    *Sep 20 22:03:26.678: [910]PPPoE 1911: Destroying  R:6468.0cf7.8546 L:f866.f287.7c83 111 Gi0/0/3.111
    *Sep 20 22:03:26.678: PPPoE: Returning Vaccess Virtual-Access3
    *Sep 20 22:03:26.679: [910]PPPoE 1911: AAA get dynamic attrs
    *Sep 20 22:03:26.679: [910]PPPoE 1911: AAA account stopped
    *Sep 20 22:03:26.679: RADIUS/ENCODE(00000791):Orig. component type = PPPoE
    *Sep 20 22:03:26.679: RADIUS(00000791): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:26.679: RADIUS(00000791): Config NAS IPv6: ::
    *Sep 20 22:03:26.679: RADIUS(00000791): sending
    *Sep 20 22:03:26.682: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 20 22:03:26.682: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
    *Sep 20 22:03:26.683: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:26.683: RADIUS(00000791): Sending a IPv4 Radius Packet
    *Sep 20 22:03:26.683: RADIUS(00000791): Send Accounting-Request to 208.98.188.6:1813 id 1646/71,len 379
    *Sep 20 22:03:26.683: RADIUS:  authenticator A6 50 A4 C3 2A 30 AB DA - 59 BF E8 75 8A 91 AA 9B
    *Sep 20 22:03:26.683: RADIUS:  Acct-Session-Id     [44]  10  "00000D51"
    *Sep 20 22:03:26.683: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  53 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   47  "ppp-disconnect-cause=Lower Layer disconnected"
    *Sep 20 22:03:26.683: RADIUS:  User-Name           [1]   19  "[email protected]"
    *Sep 20 22:03:26.683: RADIUS:  Acct-Authentic      [45]  6   RADIUS                    [1]
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  32 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   26  "connect-progress=Call Up"
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  31 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   25  "nas-tx-speed=1000000000"
    *Sep 20 22:03:26.683: RADIUS:  Vendor, Cisco       [26]  31 
    *Sep 20 22:03:26.683: RADIUS:   Cisco AVpair       [1]   25  "nas-rx-speed=1000000000"
    *Sep 20 22:03:26.683: RADIUS:  Acct-Session-Time   [46]  6   615                      
    *Sep 20 22:03:26.683: RADIUS:  Acct-Input-Octets   [42]  6   1040                     
    *Sep 20 22:03:26.683: RADIUS:  Acct-Output-Octets  [43]  6   1066                     
    *Sep 20 22:03:26.683: RADIUS:  Acct-Input-Packets  [47]  6   78                       
    *Sep 20 22:03:26.684: RADIUS:  Acct-Output-Packets [48]  6   79                       
    *Sep 20 22:03:26.684: RADIUS:  Acct-Terminate-Cause[49]  6   admin-reset               [6]
    *Sep 20 22:03:26.684: RADIUS:  Vendor, Cisco       [26]  39 
    *Sep 20 22:03:26.684: RADIUS:   Cisco AVpair       [1]   33  "disc-cause-ext=Local Admin Disc"
    *Sep 20 22:03:26.684: RADIUS:  Acct-Status-Type    [40]  6   Stop                      [2]
    *Sep 20 22:03:26.684: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:26.684: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:26.684: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:26.684: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:26.684: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:26.684: RADIUS:  Connect-Info        [77]  8   "CV_VRF"
    *Sep 20 22:03:26.684: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    *Sep 20 22:03:26.684: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:26.684: RADIUS:  Acct-Delay-Time     [41]  6   0                        
    *Sep 20 22:03:26.684: RADIUS(00000791): Started 60 sec timeout
    *Sep 20 22:03:26.686: [910]PPPoE 1911: Segment (SSS class): UNBOUND
    *Sep 20 22:03:26.686: [910]PPPoE 1911: Vi3 Block vaccess from being freed.
    *Sep 20 22:03:26.687: [910]PPPoE 1911: Segment (SSS class): UNPROVISION
    *Sep 20 22:03:26.687: [910]PPPoE 1911: failed to remove session from switching hash table.
    *Sep 20 22:03:26.694: PPPoE 1911: I PADT  R:6468.0cf7.8546 L:f866.f287.7c83 111 Gi0/0/3.111
    *Sep 20 22:03:26.758: RADIUS: Received from id 1646/71 208.98.188.6:1813, Accounting-response, len 20
    *Sep 20 22:03:26.758: RADIUS:  authenticator E3 A2 A1 EE B0 3F 43 1C - 03 B6 84 A8 20 0D B8 90
    *Sep 20 22:03:32.713: PPPoE 0: I PADI  R:6468.0cf7.8546 L:ffff.ffff.ffff 111 Gi0/0/3.111
    *Sep 20 22:03:32.713:  Service tag: NULL Tag
    *Sep 20 22:03:32.713: PPPoE 0: O PADO, R:f866.f287.7c83 L:6468.0cf7.8546 111 Gi0/0/3.111
    *Sep 20 22:03:32.713:  Service tag: NULL Tag
    *Sep 20 22:03:32.722: PPPoE 0: I PADR  R:6468.0cf7.8546 L:f866.f287.7c83 111 Gi0/0/3.111
    *Sep 20 22:03:32.722:  Service tag: NULL Tag
    *Sep 20 22:03:32.722: PPPoE : encap string prepared
    *Sep 20 22:03:32.722: [911]PPPoE 1912: Access IE handle allocated
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA get retrieved attrs
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA get nas port details
    *Sep 20 22:03:32.722: [911]PPPoE 1912: Error adjusting nas port format did
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA get dynamic attrs
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA unique ID 792 allocated
    *Sep 20 22:03:32.722: [911]PPPoE 1912: AAA method list  set
    *Sep 20 22:03:32.722: [911]PPPoE 1912: Service request sent to SSS
    *Sep 20 22:03:32.723: [911]PPPoE 1912: Created, Service: None R:f866.f287.7c83 L:6468.0cf7.8546 111 Gi0/0/3.111
    *Sep 20 22:03:32.723: [911]PPPoE 1912: State NAS_PORT_POLICY_INQUIRY    Event SSS MORE KEYS
    *Sep 20 22:03:32.724: [911]PPPoE 1912: data path set to PPP
    *Sep 20 22:03:32.724: [911]PPPoE 1912: Segment (SSS class): PROVISION
    *Sep 20 22:03:32.724: [911]PPPoE 1912: State PROVISION_PPP    Event SSM PROVISIONED
    *Sep 20 22:03:32.724: [911]PPPoE 1912: O PADS  R:6468.0cf7.8546 L:f866.f287.7c83 Gi0/0/3.111
    *Sep 20 22:03:32.724: [911]PPPoE 1912 <Gi0/0/3.111:111>: Unable to add line attributes from ANCP
    *Sep 20 22:03:32.724: [911]PPPoE 1912: Unable to Add ANCP Line attributes to the PPPoE Authen attributes
    *Sep 20 22:03:33.845: RADIUS/ENCODE(00000792):Orig. component type = PPPoE
    *Sep 20 22:03:33.845: RADIUS: DSL line rate attributes successfully added
    *Sep 20 22:03:33.845: RADIUS(00000792): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:33.845: RADIUS(00000792): Config NAS IPv6: ::
    *Sep 20 22:03:33.845: RADIUS/ENCODE(00000792): acct_session_id: 3411
    *Sep 20 22:03:33.845: RADIUS(00000792): sending
    *Sep 20 22:03:33.845: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:33.845: RADIUS(00000792): Sending a IPv4 Radius Packet
    *Sep 20 22:03:33.845: RADIUS(00000792): Send Access-Request to 208.98.188.6:1812 id 1645/56,len 124
    *Sep 20 22:03:33.846: RADIUS:  authenticator 3E 87 16 F9 FF 1A F8 74 - D6 7F 38 C3 F0 98 6E 6F
    *Sep 20 22:03:33.846: RADIUS:  User-Name           [1]   10  "dcdi.net"
    *Sep 20 22:03:33.846: RADIUS:  User-Password       [2]   18  *
    *Sep 20 22:03:33.846: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:33.846: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:33.846: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:33.846: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:33.846: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:33.846: RADIUS:  Service-Type        [6]   6   Outbound                  [5]
    *Sep 20 22:03:33.846: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:33.846: RADIUS(00000792): Started 60 sec timeout
    *Sep 20 22:03:34.868: RADIUS: Received from id 1645/56 208.98.188.6:1812, Access-Reject, len 20
    *Sep 20 22:03:34.868: RADIUS:  authenticator 02 CF 53 0A 6A 62 E5 DB - 2E 96 99 E4 09 D8 2E B1
    *Sep 20 22:03:34.868: RADIUS(00000792): Received from id 1645/56
    *Sep 20 22:03:34.869: RADIUS/ENCODE(00000792):Orig. component type = PPPoE
    *Sep 20 22:03:34.869: RADIUS: DSL line rate attributes successfully added
    *Sep 20 22:03:34.869: RADIUS(00000792): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:34.869: RADIUS(00000792): Config NAS IPv6: ::
    *Sep 20 22:03:34.869: RADIUS/ENCODE(00000792): acct_session_id: 3411
    *Sep 20 22:03:34.869: RADIUS(00000792): sending
    *Sep 20 22:03:34.870: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:34.870: RADIUS(00000792): Sending a IPv4 Radius Packet
    *Sep 20 22:03:34.870: RADIUS(00000792): Send Access-Request to 208.98.188.6:1812 id 1645/57,len 139
    *Sep 20 22:03:34.870: RADIUS:  authenticator 8D 12 A1 E3 30 52 B0 F5 - 1C CD 8F 60 49 E9 F4 26
    *Sep 20 22:03:34.870: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    *Sep 20 22:03:34.870: RADIUS:  User-Name           [1]   19  "[email protected]"
    *Sep 20 22:03:34.870: RADIUS:  User-Password       [2]   18  *
    *Sep 20 22:03:34.870: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:34.870: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:34.870: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:34.870: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:34.870: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:34.870: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    *Sep 20 22:03:34.870: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:34.870: RADIUS(00000792): Started 60 sec timeout
    *Sep 20 22:03:34.894: RADIUS: Received from id 1645/57 208.98.188.6:1812, Access-Accept, len 44
    *Sep 20 22:03:34.894: RADIUS:  authenticator AC 92 A9 7C 1F CB 46 6B - F6 68 03 D8 AF 0B F0 F5
    *Sep 20 22:03:34.894: RADIUS:  Vendor, Cisco       [26]  24 
    *Sep 20 22:03:34.894: RADIUS:   Cisco AVpair       [1]   18  "ip:vrf-id=CV_VRF"
    *Sep 20 22:03:34.894: RADIUS(00000792): Received from id 1645/57
    *Sep 20 22:03:34.902: [911]PPPoE 1912: State LCP_NEGOTIATION    Event SSS CONNECT LOCAL
    *Sep 20 22:03:34.904: [911]PPPoE 1912: Segment (SSS class): UPDATED
    *Sep 20 22:03:34.904: [911]PPPoE 1912: Segment (SSS class): BOUND
    *Sep 20 22:03:34.904: [911]PPPoE 1912: data path set to Virtual Acess
    *Sep 20 22:03:34.905: [911]PPPoE 1912: State LCP_NEGOTIATION    Event SSM UPDATED
    *Sep 20 22:03:34.905: [911]PPPoE 1912: AAA get dynamic attrs
    *Sep 20 22:03:34.906: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
    *Sep 20 22:03:34.907: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
    *Sep 20 22:03:34.907: RADIUS/ENCODE(00000792):Orig. component type = PPPoE
    *Sep 20 22:03:34.907: RADIUS(00000792): Config NAS IP: 0.0.0.0
    *Sep 20 22:03:34.907: RADIUS(00000792): Config NAS IPv6: ::
    *Sep 20 22:03:34.907: RADIUS(00000792): sending
    *Sep 20 22:03:34.907: [911]PPPoE 1912: State PTA_BINDING    Event STATIC BIND RESPONSE
    *Sep 20 22:03:34.907: [911]PPPoE 1912: Connected PTA
    *Sep 20 22:03:34.908: RADIUS/ENCODE: Best Local IP-Address 206.251.40.52 for Radius-Server 208.98.188.6
    *Sep 20 22:03:34.913: RADIUS(00000792): Sending a IPv4 Radius Packet
    *Sep 20 22:03:34.913: RADIUS(00000792): Send Accounting-Request to 208.98.188.6:1813 id 1646/72,len 189
    *Sep 20 22:03:34.913: RADIUS:  authenticator 5B 19 2B 31 5B 6C E7 46 - 5D 69 8D 66 99 13 2E F0
    *Sep 20 22:03:34.913: RADIUS:  Acct-Session-Id     [44]  10  "00000D53"
    *Sep 20 22:03:34.913: RADIUS:  Framed-Protocol     [7]   6   PPP                       [1]
    *Sep 20 22:03:34.913: RADIUS:  User-Name           [1]   19  "[email protected]"
    *Sep 20 22:03:34.913: RADIUS:  Vendor, Cisco       [26]  32 
    *Sep 20 22:03:34.913: RADIUS:   Cisco AVpair       [1]   26  "connect-progress=Call Up"
    *Sep 20 22:03:34.913: RADIUS:  Acct-Authentic      [45]  6   RADIUS                    [1]
    *Sep 20 22:03:34.913: RADIUS:  Acct-Status-Type    [40]  6   Start                     [1]
    *Sep 20 22:03:34.913: RADIUS:  NAS-Port-Type       [61]  6   Virtual                   [5]
    *Sep 20 22:03:34.913: RADIUS:  NAS-Port            [5]   6   0                        
    *Sep 20 22:03:34.913: RADIUS:  NAS-Port-Id         [87]  11  "0/0/3/111"
    *Sep 20 22:03:34.913: RADIUS:  Vendor, Cisco       [26]  41 
    *Sep 20 22:03:34.913: RADIUS:   Cisco AVpair       [1]   35  "client-mac-address=6468.0cf7.8546"
    *Sep 20 22:03:34.913: RADIUS:  Connect-Info        [77]  8   "CV_VRF"
    *Sep 20 22:03:34.913: RADIUS:  Service-Type        [6]   6   Framed                    [2]
    *Sep 20 22:03:34.913: RADIUS:  NAS-IP-Address      [4]   6   206.251.40.52            
    *Sep 20 22:03:34.914: RADIUS:  Acct-Delay-Time     [41]  6   0                        
    *Sep 20 22:03:34.914: RADIUS(00000792): Started 60 sec timeout
    *Sep 20 22:03:34.994: RADIUS: Received from id 1646/72 208.98.188.6:1813, Accounting-response, len 20
    *Sep 20 22:03:34.994: RADIUS:  authenticator 8E E3 AD 24 76 EA C2 53 - AD 0F DD 57 AC 0D F3 BAsho debug
    coreASR1002#sho debugging
    General OS:
      AAA subscriber profile cli debugging is on
    PPPoE:
      PPPoE protocol events debugging is on
      PPPoE protocol errors debugging is on
    Radius protocol debugging is on
    Radius packet protocol debugging is on

    Good Day Manuel,
    "...client is not getting IP address even though the sessions seems to be up. Is this correct?" Correct.
    What I am seeing and suspecting is the problem has to do with 'ip:ip-unnumbered=interface'.
    Trying with the ip:ip-unnumbered=Loopback111 or GigabitEthernet0/0/3.111 (for testing) debugging reports "Session creation failed due to full virtual-access interfaces not being supported...", as soon as the attribute is removed in radius the client authenticates but does not get an IP address. I would rather not use Loopback if possible.
    GE0/0/3.111 is basically the client egress and GE0/0/2.20 is the ingress/router gateway
    Also seeing this debug message, "...Unable to add line attributes from ANCP ... Unable to Add ANCP Line attributes to the PPPoE Authen attributes" which may or may not relate to ip-unnumbered attribute.
    I hope the information isn't too much or confusing, sure appreciate the help.
    debugging with ip:vrf-id=CV_VRF w/o ip:ip-unnumbered
    *Sep 26 17:04:57.395: Vi3 PPP DISC: Lower Layer disconnected
    *Sep 26 17:04:57.396: Vi3 PPP: Sending Acct Event[Down] id[5FB]
    *Sep 26 17:04:57.396: PPP: NET STOP send to AAA.
    *Sep 26 17:04:57.396: Vi3 LCP: O TERMREQ [Open] id 4 len 4
    *Sep 26 17:04:57.396: Vi3 LCP: Event[CLOSE] State[Open to Closing]
    *Sep 26 17:04:57.396: Vi3 PPP: Phase is TERMINATING
    *Sep 26 17:04:57.397: Vi3 PPP: Block vaccess from being freed [0x10]
    *Sep 26 17:04:57.398: Vi3 LCP: Event[DOWN] State[Closing to Initial]
    *Sep 26 17:04:57.399: Vi3 PPP: Unlocked by [0x10] Still Locked by [0x0]
    *Sep 26 17:04:57.399: Vi3 PPP: Free previously blocked vaccess
    *Sep 26 17:04:57.399: Vi3 PPP: Phase is DOWN
    *Sep 26 17:04:57.400: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 26 17:04:57.401: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
    *Sep 26 17:05:03.440: PPP: Alloc Context [38E95CFC]
    *Sep 26 17:05:03.440: ppp514 PPP: Phase is ESTABLISHING
    *Sep 26 17:05:03.440: ppp514 PPP: Using vpn set call direction
    *Sep 26 17:05:03.440: ppp514 PPP: Treating connection as a callin
    *Sep 26 17:05:03.440: ppp514 PPP: Session handle[1D0005EB] Session id[514]
    *Sep 26 17:05:03.440: ppp514 LCP: Event[OPEN] State[Initial to Starting]
    *Sep 26 17:05:03.441: ppp514 PPP LCP: Enter passive mode, state[Stopped]
    *Sep 26 17:05:04.522: ppp514 LCP: I CONFREQ [Stopped] id 180 len 10
    *Sep 26 17:05:04.522: ppp514 LCP:    MagicNumber 0x0669ECAE (0x05060669ECAE)
    *Sep 26 17:05:04.522: ppp514 LCP: O CONFREQ [Stopped] id 1 len 18
    *Sep 26 17:05:04.522: ppp514 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:05:04.522: ppp514 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:05:04.522: ppp514 LCP:    MagicNumber 0x6ABFFB9F (0x05066ABFFB9F)
    *Sep 26 17:05:04.522: ppp514 LCP: O CONFACK [Stopped] id 180 len 10
    *Sep 26 17:05:04.522: ppp514 LCP:    MagicNumber 0x0669ECAE (0x05060669ECAE)
    *Sep 26 17:05:04.522: ppp514 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]
    *Sep 26 17:05:04.525: ppp514 LCP: I CONFACK [ACKsent] id 1 len 18
    *Sep 26 17:05:04.526: ppp514 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:05:04.526: ppp514 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:05:04.526: ppp514 LCP:    MagicNumber 0x6ABFFB9F (0x05066ABFFB9F)
    *Sep 26 17:05:04.526: ppp514 LCP: Event[Receive ConfAck] State[ACKsent to Open]
    *Sep 26 17:05:04.528: ppp514 PPP: Queue PAP code[1] id[15]
    *Sep 26 17:05:04.529: ppp514 PPP: Phase is AUTHENTICATING, by this end
    *Sep 26 17:05:04.529: ppp514 PAP: Redirect packet to ppp514
    *Sep 26 17:05:04.529: ppp514 PAP: I AUTH-REQ id 15 len 31 from "[email protected]"
    *Sep 26 17:05:04.529: ppp514 PAP: Authenticating peer [email protected]
    *Sep 26 17:05:04.529: ppp514 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:05:04.529: ppp514 LCP: State is Open
    *Sep 26 17:05:05.553: ppp514 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Sep 26 17:05:05.553: ppp514 PPP: Sent PAP LOGIN Request
    *Sep 26 17:05:05.584: ppp514 PPP: Received LOGIN Response PASS
    *Sep 26 17:05:05.584: ppp514 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:05:05.594: Vi3 PPP: Phase is AUTHENTICATING, Authenticated User
    *Sep 26 17:05:05.594: Vi3 PAP: O AUTH-ACK id 15 len 5
    *Sep 26 17:05:05.595: Vi3 PPP: Phase is UP
    *Sep 26 17:05:05.595: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
    *Sep 26 17:05:05.596: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
    *Sep 26 17:05:05.606: Vi3 IPCP: I CONFREQ [UNKNOWN] id 44 len 22
    *Sep 26 17:05:05.606: Vi3 IPCP:    Address 0.0.0.0 (0x030600000000)
    *Sep 26 17:05:05.606: Vi3 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
    *Sep 26 17:05:05.606: Vi3 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
    *Sep 26 17:05:05.606: Vi3 LCP: O PROTREJ [Open] id 2 len 28 protocol IPCP
    *Sep 26 17:05:05.606: Vi3 LCP: (0x012C0018030600000000810600000000)
    *Sep 26 17:05:05.606: Vi3 LCP: (0x830600000000)
    *Sep 26 17:05:05.607: Vi3 IPV6CP: I CONFREQ [UNKNOWN] id 26 len 14
    *Sep 26 17:05:05.607: Vi3 IPV6CP:    Interface-Id 5421:6C1B:5DCE:401A (0x010A54216C1B5DCE401A)
    *Sep 26 17:05:05.607: Vi3 LCP: O PROTREJ [Open] id 3 len 20 protocol IPV6CP (0x011A0010010A54216C1B5DCE401A) debugging w/o ip:vrf-id=CV_VRF w/o ip:ip-unnumbered
    *Sep 26 17:13:12.424: Vi3 PPP DISC: Lower Layer disconnected
    *Sep 26 17:13:12.424: Vi3 PPP: Sending Acct Event[Down] id[5FE]
    *Sep 26 17:13:12.425: PPP: NET STOP send to AAA.
    *Sep 26 17:13:12.425: Vi3 LCP: O TERMREQ [Open] id 4 len 4
    *Sep 26 17:13:12.425: Vi3 LCP: Event[CLOSE] State[Open to Closing]
    *Sep 26 17:13:12.425: Vi3 PPP: Phase is TERMINATING
    *Sep 26 17:13:12.426: Vi3 PPP: Block vaccess from being freed [0x10]
    *Sep 26 17:13:12.426: Vi3 LCP: Event[DOWN] State[Closing to Initial]
    *Sep 26 17:13:12.428: Vi3 PPP: Unlocked by [0x10] Still Locked by [0x0]
    *Sep 26 17:13:12.428: Vi3 PPP: Free previously blocked vaccess
    *Sep 26 17:13:12.428: Vi3 PPP: Phase is DOWN
    *Sep 26 17:13:12.429: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 26 17:13:12.430: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down
    *Sep 26 17:13:18.485: PPP: Alloc Context [38E95CFC]
    *Sep 26 17:13:18.485: ppp515 PPP: Phase is ESTABLISHING
    *Sep 26 17:13:18.486: ppp515 PPP: Using vpn set call direction
    *Sep 26 17:13:18.486: ppp515 PPP: Treating connection as a callin
    *Sep 26 17:13:18.486: ppp515 PPP: Session handle[AC0005EC] Session id[515]
    *Sep 26 17:13:18.486: ppp515 LCP: Event[OPEN] State[Initial to Starting]
    *Sep 26 17:13:18.486: ppp515 PPP LCP: Enter passive mode, state[Stopped]
    *Sep 26 17:13:19.572: ppp515 LCP: I CONFREQ [Stopped] id 181 len 10
    *Sep 26 17:13:19.572: ppp515 LCP:    MagicNumber 0x171E542B (0x0506171E542B)
    *Sep 26 17:13:19.572: ppp515 LCP: O CONFREQ [Stopped] id 1 len 18
    *Sep 26 17:13:19.572: ppp515 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:13:19.572: ppp515 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:13:19.572: ppp515 LCP:    MagicNumber 0x6AC78AB2 (0x05066AC78AB2)
    *Sep 26 17:13:19.572: ppp515 LCP: O CONFACK [Stopped] id 181 len 10
    *Sep 26 17:13:19.572: ppp515 LCP:    MagicNumber 0x171E542B (0x0506171E542B)
    *Sep 26 17:13:19.572: ppp515 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]
    *Sep 26 17:13:19.576: ppp515 LCP: I CONFACK [ACKsent] id 1 len 18
    *Sep 26 17:13:19.576: ppp515 LCP:    MRU 1492 (0x010405D4)
    *Sep 26 17:13:19.576: ppp515 LCP:    AuthProto PAP (0x0304C023)
    *Sep 26 17:13:19.576: ppp515 LCP:    MagicNumber 0x6AC78AB2 (0x05066AC78AB2)
    *Sep 26 17:13:19.576: ppp515 LCP: Event[Receive ConfAck] State[ACKsent to Open]
    *Sep 26 17:13:19.579: ppp515 PPP: Queue PAP code[1] id[16]
    *Sep 26 17:13:19.601: ppp515 PPP: Phase is AUTHENTICATING, by this end
    *Sep 26 17:13:19.601: ppp515 PAP: Redirect packet to ppp515
    *Sep 26 17:13:19.601: ppp515 PAP: I AUTH-REQ id 16 len 31 from "[email protected]"
    *Sep 26 17:13:19.601: ppp515 PAP: Authenticating peer [email protected]
    *Sep 26 17:13:19.601: ppp515 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:13:19.601: ppp515 LCP: State is Open
    *Sep 26 17:13:20.625: ppp515 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Sep 26 17:13:20.625: ppp515 PPP: Sent PAP LOGIN Request
    *Sep 26 17:13:20.650: ppp515 PPP: Received LOGIN Response PASS
    *Sep 26 17:13:20.650: ppp515 PPP: Phase is FORWARDING, Attempting Forward
    *Sep 26 17:13:20.657: Vi3 PPP: Phase is AUTHENTICATING, Authenticated User
    *Sep 26 17:13:20.657: Vi3 PAP: O AUTH-ACK id 16 len 5
    *Sep 26 17:13:20.658: Vi3 PPP: Phase is UP
    *Sep 26 17:13:20.658: Vi3 IPCP: Protocol configured, start CP. state[Initial]
    *Sep 26 17:13:20.658: Vi3 IPCP: Event[OPEN] State[Initial to Starting]
    *Sep 26 17:13:20.658: Vi3 IPCP: O CONFREQ [Starting] id 1 len 10
    *Sep 26 17:13:20.658: Vi3 IPCP:    Address 199.200.107.1 (0x0306C7C86B01)
    *Sep 26 17:13:20.658: Vi3 IPCP: Event[UP] State[Starting to REQsent]
    *Sep 26 17:13:20.658: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to up
    *Sep 26 17:13:20.660: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to up
    *Sep 26 17:13:20.666: Vi3 IPCP: I CONFREQ [REQsent] id 45 len 22
    *Sep 26 17:13:20.666: Vi3 IPCP:    Address 0.0.0.0 (0x030600000000)
    *Sep 26 17:13:20.666: Vi3 IPCP:    PrimaryDNS 0.0.0.0 (0x810600000000)
    *Sep 26 17:13:20.666: Vi3 IPCP:    SecondaryDNS 0.0.0.0 (0x830600000000)
    *Sep 26 17:13:20.666: Vi3 IPCP AUTHOR: Start.  Her address 0.0.0.0, we want 0.0.0.0
    *Sep 26 17:13:20.666: Vi3 IPCP AUTHOR: Done.  Her address 0.0.0.0, we want 0.0.0.0
    *Sep 26 17:13:20.666: Vi3 IPCP: Pool returned 199.200.107.20
    *Sep 26 17:13:20.667: Vi3 IPCP: O CONFNAK [REQsent] id 45 len 22
    *Sep 26 17:13:20.667: Vi3 IPCP:    Address 199.200.107.20 (0x0306C7C86B14)
    *Sep 26 17:13:20.667: Vi3 IPCP:    PrimaryDNS 208.98.188.81 (0x8106D062BC51)
    *Sep 26 17:13:20.667: Vi3 IPCP:    SecondaryDNS 8.8.8.8 (0x830608080808)
    *Sep 26 17:13:20.667: Vi3 IPCP: Event[Receive ConfReq-] State[REQsent to REQsent]
    *Sep 26 17:13:20.667: Vi3 IPV6CP: I CONFREQ [UNKNOWN] id 27 len 14
    *Sep 26 17:13:20.667: Vi3 IPV6CP:    Interface-Id 096D:2933:E6FE:523D (0x010A096D2933E6FE523D)
    *Sep 26 17:13:20.667: Vi3 LCP: O PROTREJ [Open] id 2 len 20 protocol IPV6CP (0x011B0010010A096D2933E6FE523D)
    *Sep 26 17:13:20.668: Vi3 IPCP: I CONFACK [REQsent] id 1 len 10
    *Sep 26 17:13:20.668: Vi3 IPCP:    Address 199.200.107.1 (0x0306C7C86B01)
    *Sep 26 17:13:20.668: Vi3 IPCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
    *Sep 26 17:13:20.672: Vi3 IPCP: I CONFREQ [ACKrcvd] id 46 len 22
    *Sep 26 17:13:20.672: Vi3 IPCP:    Address 199.200.107.20 (0x0306C7C86B14)
    *Sep 26 17:13:20.672: Vi3 IPCP:    PrimaryDNS 208.98.188.81 (0x8106D062BC51)
    *Sep 26 17:13:20.672: Vi3 IPCP:    SecondaryDNS 8.8.8.8 (0x830608080808)
    *Sep 26 17:13:20.672: Vi3 IPCP: O CONFACK [ACKrcvd] id 46 len 22
    *Sep 26 17:13:20.672: Vi3 IPCP:    Address 199.200.107.20 (0x0306C7C86B14)
    *Sep 26 17:13:20.672: Vi3 IPCP:    PrimaryDNS 208.98.188.81 (0x8106D062BC51)
    *Sep 26 17:13:20.672: Vi3 IPCP:    SecondaryDNS 8.8.8.8 (0x830608080808)
    *Sep 26 17:13:20.672: Vi3 IPCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
    *Sep 26 17:13:20.689: Vi3 IPCP: State is Open
    *Sep 26 17:13:20.691: %FMANRP_ESS-4-FULLVAI: Session creation failed due to Full Virtual-Access Interfaces not being supported. Check that all applied Virtual-Template and RADIUS features support Virtual-Access sub-interfaces. swidb= 0x41F07370, ifnum= 22
    *Sep 26 17:13:20.691: Vi3 Added to neighbor route AVL tree: topoid 0, address 199.200.107.20
    *Sep 26 17:13:20.691: Vi3 IPCP: Install route to 199.200.107.20
    *Sep 26 17:13:20.693: Vi3 PPP DISC: Lower Layer disconnected
    *Sep 26 17:13:20.693: Vi3 PPP: Sending Acct Event[Down] id[5FF]
    *Sep 26 17:13:20.693: PPP: NET STOP send to AAA.
    *Sep 26 17:13:20.694: Vi3 IPCP: Event[DOWN] State[Open to Starting]
    *Sep 26 17:13:20.694: Vi3 IPCP: Event[CLOSE] State[Starting to Initial]
    *Sep 26 17:13:20.694: Vi3 LCP: O TERMREQ [Open] id 3 len 4
    *Sep 26 17:13:20.694: Vi3 LCP: Event[CLOSE] State[Open to Closing]
    *Sep 26 17:13:20.694: Vi3 PPP: Phase is TERMINATING
    *Sep 26 17:13:20.695: Vi3 PPP: Block vaccess from being freed [0x10]
    *Sep 26 17:13:20.695: Vi3 Deleted neighbor route from AVL tree: topoid 0, address 199.200.107.20
    *Sep 26 17:13:20.695: Vi3 IPCP: Remove route to 199.200.107.20
    *Sep 26 17:13:20.696: Vi3 LCP: Event[DOWN] State[Closing to Initial]
    *Sep 26 17:13:20.696: Vi3 PPP: Unlocked by [0x10] Still Locked by [0x0]
    *Sep 26 17:13:20.696: Vi3 PPP: Free previously blocked vaccess
    *Sep 26 17:13:20.696: Vi3 PPP: Phase is DOWN
    *Sep 26 17:13:20.696: %LINK-3-UPDOWN: Interface Virtual-Access3, changed state to down
    *Sep 26 17:13:20.698: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access3, changed state to down

  • WLAN Controller learning IP/MAC on wrong virtual interface

    Hello
    I believe since I upgraded my WiSM to 7.0.250.0 is it learning a MAC address on the wrong virtual interface.
    The setup:
    - a Linux server with 2 virtual interfaces, both use the same MAC address, one is the gateway of VLAN 116 and one is the gateway of VLAN 240
    - a WiSM with several virtual interfaces, including one in 116 and one in 240
    Here the arp table with the problem:
        MAC Address        IP Address     Port   VLAN   Type
    00:50:56:BD:32:92   172.16.240.9     29     240    Host
    00:1E:4A:FA:87:8B   172.16.102.12    29     0      Permanent
    00:1E:4A:FA:50:0B   172.16.102.13    29     0      Permanent
    00:1E:4A:FA:81:2B   172.16.102.14    29     0      Permanent
    00:50:56:BD:32:92   172.16.116.9     29     240    Host
    00:1D:E0:31:55:23   172.16.116.185   29     116    Client
    58:94:6B:68:50:E8   172.16.118.201   29     116    Client
    1C:B0:94:B7:38:08   172.16.118.234   29     116    Client
    And here after I made a PING from the controller to the listed ip address:
        MAC Address        IP Address     Port   VLAN   Type
    00:50:56:BD:32:92   172.16.240.9     29     240    Host
    00:1E:4A:FA:87:8B   172.16.102.12    29     0      Permanent
    00:1E:4A:FA:50:0B   172.16.102.13    29     0      Permanent
    00:1E:4A:FA:81:2B   172.16.102.14    29     0      Permanent
    00:50:56:BD:32:92   172.16.116.9     29     116    Host
    00:1D:E0:31:55:23   172.16.116.185   29     116    Client
    38:E7:D8:D3:7C:FA   172.16.118.92    29     116    Client
    58:94:6B:68:50:E8   172.16.118.201   29     116    Client
    1C:B0:94:B7:38:08   172.16.118.234   29     116    Client
    18:AF:61:12:E9:FB   192.168.1.59     29     117    Client
    Has anybody else the same problem?
    The host 172.16.116.9 is also the configured DHCP server on VLAN 116.
    Is there a way to statically configure this IP address on that VLAN? Because it causes every few days a service outage on that VLAN (which is bound to an SSID).

    Yup, I'd say still valid. Seeing as it is the gateway, if it had different mac addresses per interface, it might still work.
    No, clients in the same subnet can communicate, but it is not recommended to 'bridge' wired and wireless with a WLC. The WLC doesn't like to bridge the communication by default, though there are work arounds.
     I might also say that as it uses the same MAC address for both virtual interfaces L2 is going to be messed up as each time there were an ARP the entry would change.
    Take a look and see if you can manually change the mac for one of the interfaces and test again.
    HTH,
    Steve

  • Errors in Virtual interface after editing application service

    Hi all,
    I have an external service in CAF which connects to the backend to an RFC.
    This external service is being used by an application service.
    I recently added an extra import parameter to the RFC in the backend. So in CAF I deleted my old external service and imported the
    RFC again with the correct import parameters.
    In the Application Service I added an extra import parameter to the input node of the corresponding operations in which the external service is being used. And I inserted a line of code to fill in the correct value in the import parameter.
    After doing this and saving the CAF project a lot of errors are being generated in the ejbmodule of the caf project. (in the Virtual Interface files <servicename>.videf)
    Errors like:
    Type com.spe.portal.foa_serv.appsrv.datatypes.AddressDS of field addressDS0 in type com.spe.portal.foa_serv.appsrv.datatypes.BPartnerLightDS_R has been exchanged by type com.spe.portal.foa_serv.appsrv.datatypes.AddressDS_R
    These errors even occur in the VIs of the services that I didn't change.
    Can somebody tell me what the Virtual interface is for and why they are throwing these errors,
    Thanks
    Kr
    Wouter

    Hi Wouter,
    A virtual interface ia actuallly a xml-file with a description of all the operations and fields of de webservice.
    To solve your problems: go to the navigator view, select the <CAFname>EJB project, navigate to the <servicename> folder under the ejbModule folder.
    Open the wsdef file with the WSD editor and push the button Edit VI....
    Remove the operations under <servicename>Bean and add them again using the buttons below the pane.
    Save and rebuild your work and everything should be ok.
    Hope this helps.
    Regards,
    Alain

  • CSS- traffic orignating from real server + Virtual interface

    Hi all,
    I am designing a solution at the moment, in which I shall have 2 servers behind a pair of CSS & their default gateway will be the Virtual Interface ip address of CSS.
    Is there any problem forseen in traffic getting initiated from the server to any other subnet in the network and the return traffic to the server.
    Servers shall connect to a pair of 3750 being used as L2 in stack .
    The Stacked 3750's shall be placed below the CSS pair & the CSS pair shall further connects to a single 6509 upstream....
    Each 3750-L2 connects single port to each CSS
    (3750-L2-1 to CSS1 &
    3750-L2-2 to CSS 2)
    Both CSS connect to the SINGLE 6509 on diff blades. for better redundency.
    The CSS shall not be connected to each other directly.
    Both 3750-L2 connect to each other as well
    IIS-1---L2_Sw1---CSS1---6509---Othr_Subent
    IIS-1---L2_Sw2---CSS2---6509---Othr_Subent
    Note: I shall have VIP/Virtual Interface config on my CSS's.
    Appreciate validation and recomendations on this design.
    Many Thanks,
    gagan

    Hi Gilles,
    Many thanks for the confirmation.
    Request verification on the below as well~
    1. With the above scenario; I do not require any group (NAT) configuration, either for my servers initiating traffic for going out or for clients hitting the VIP to reach servers. The client & server shall be in diff VLAN?s of course.
    2. With VIP & Virtual Interface configuration & couple of server VLAN's below on server side, I should be able to use both the gigabit interfaces on the 11503 to connect up and down stream as TRUNK. I mean to ask Virtual intf. & VIP has no problems working on the same TRUNK interface?
    3. I understand that Fate sharing and critical service helps full failover (client & server side).
    As an upstream router or L3 switch fails or the upstream connecting gigabit interface on CSS fails, the failover happens.
    Will the same be applicable to downstream L2 switch & CSS interface failure? If any of these on the downstream fails will the CSS failover to the standby unit.
    I think this above should work, just need confirmation coz I have not done this before.
    Thanks a lot again,
    Gagan

  • Why virtual interfaces added to ManagementOS not visible to Cluster service?

    Hello All, 
    I"m starting this new thread since the one before is answered by our friend Udo. My problem in short is following. Diagram will be enough to explain what I'm trying to achieve. I've setup this lab to learn Hyper-V clustering with 2 nodes. It is Hyper-V
    server 2012. Both nodes have 3x physical NIcs, 1 in each node is dedicated to managing the Node. Rest of the two are used to create a NIC team. Atop of that NIC team, a virtual switch is created with -AllowManagementOS
    $False. Next I created and added following virtual interfaces to host partition, and plugged them into virtual switch created atop of teamed interface. These virtual interfaces should serve the purpose of various networks available. 
    For SAN i'm running a Linux VM which has iSCSI target server and clustering service has no problem with that. All tests pass ok.
    The problem is......when those virtual interfaces added to hosts; do not appear as available networks
    to cluster service; instead it only shows the management NIC as the available network to leverage. 
    This is making it difficult to understand how to setup a cluster of 2x Hyper-V Server nodes. Can someone help please?
    Regards,
    Shahzad.

    Shahzad,
    I've read this thread a couple of times and I don't think I'm clear on the exact question you're asking.
    When the clustering service goes out to look for "Networks", what it does is scan the IP addresses on each node. Every time it finds an IP in a unique subnet, that subnet is listed as a network. It can't see virtual switches and doesn't care about
    virtual vs. teamed vs. physical adapters or anything like that. It's just looking at IP addresses. This is why I'm confused when you say, "it won't show virtual interfaces available as networks". "Networks" in this context are IP subnets.
    I'm not aware of any context where a singular interface would be treated like a network.
    If you've got virtual adapters attached to the management operating system
    and have assigned IPs to them, the cluster should have discovered those networks. If you have multiple adapters on the same node using IPs in the same subnet, that network will only appear once and the cluster service will only use
    one adapter from that subnet on that node. The one it picked will be visible on the "Network Connections" tab at the bottom of Failover Cluster Manager when you're on the Networks section.
    Eric Siron Altaro Hyper-V Blog
    I am an independent blog contributor, not an Altaro employee. I am solely responsible for the content of my posts.
    "Every relationship you have is in worse shape than you think."
    Hello Eric and friends, 
    Eric, much appreciated about your interest about the issue and yes I agree with you when you said... "When the clustering service goes out to look for "Networks",
    what it does is scan the IP addresses on each node. Every time it finds an IP in a unique subnet, that subnet is listed as a network. It can't see virtual switches and doesn't care about virtual vs. teamed vs. physical adapters or anything like that. It's
    just looking at IP addresses. This is why I'm confused when you say, "it won't show virtual interfaces available as networks". "Networks" in this context are IP subnets. I'm not aware of any context where a singular interface would be treated
    like a network."
    By networks I meant to say subnets. Let me explain what I've configured so far:
    Node 1 & Node 2 installed with 3x NICs. All 3 NICs/node plugged into same switch. 
    Node1:  131.107.0.50/24
    Node2:  131.107l.0.150/24
    A Core Domain controller VM running on Node 1:   131.107.0.200/24 
    A JUMPBOX (WS 2012 R2 Std.) VM running on Node 1: 131.107.0.100/24
    A Linux SAN VM running on Node 2: 10.1.1.100/8 
    I planed to configured following networks:
    (1) Cluster traffic:  10.0.0.50/24     (IP given to virtual interface for Cluster traffic in Node1)
         Cluster traffic:  10.0.0.150/24   (IP given to virtual interface for Cluster traffic in Node2)
    (2) SAN traffic:      10.1.1.50/8      (IP given to virtual interfce for SAN traffic in Node1)  
         SAN traffic:      10.1.1.150/8    (IP given to virtual interfce for SAN traffic in Node2)
    Note: Cluster service has no problem accessing the SAN VM (10.1.1.100) over this network, it validates SAN settings and comes back OK. This is an indication that virtual interface is
    working fine. 
    (3) Migration traffic:   172.168.0.50/8     (IP given to virtual interfce for
    Migration traffic in Node1) 
         Migration traffic:   172.168.0.150/8    (IP given to virtual interfce for
    Migration  traffic in Node2)
    All these networks (virtual interfaces) are made available through two virtual switches which are configured EXACTLY identical on both Node1/Node2.
    Now after finishing the cluster validation steps (which comes all OK), when create cluster wizard starts, it only shows one network; i.e. network of physical Layer 2 switch i.e. 131.107.0.0/24.
    I wonder why it won't show IPs of other networks (10.0.0.0/8, 10.1.1.0/8 and  172.168.0.0/8)
    Regards,
    Shahzad

Maybe you are looking for

  • How do I generate a report (Active Vendors -- Vendor Code)?

    Dear SAP Friends, May I ask how do I generate a report showing all active vendors with their corresponing vendor code in SAP? Thank you very much in advance, Albert

  • Dbms_metadata.get_ddl returns unusable create index statement

    Hello everybody, I'm trying to write a procdeure that automatically deletes all duplicate record and rebuild all table indexes after an sqlldr load with direct path. In short the procdeure indentifies the indexes, read them using dbms_metadata.get_dd

  • Ibooks no opening pdfs

    After I installed the itunes update and synced my ipad I have not been able to open pdf or books on my ipad.  When I open ibooks on my ipad the pdfs and books are their but when you click on them to open they won't open.  Any ideas?  I've tried updat

  • Dropped Signal...I'm Going to Go Crazy

    Hello, I have the Airport Extreme 802.11 base station and it's worked well for two years. About two weeks ago, I started losing the signal and having network timeout connections. I talked with the ISP (Virgin Media) and the signal is coming into the

  • Latest update makes firefox so slow it's unusable

    after yet another ff crash, I forced an update to the latest release today. THAT was a mistake. Before, ff was simply unstable. Now it's so slow it's unusable. It's like running Windows 8 on an IBM XT. Given that I'm running Win7 on an Intel i7 3770