Virtual IP and physical IP

Hi All,
What is the difference between virtual IP and physical IP. Can some one tell me what is the use of virual IP. I think physical IP means listening port of the web-logic server. Is it possible to deploy any application on virual IP.
Thanks,
Venkat.

What is the difference between virtual IP and physical IP?
IP – the abbreviation means Internet Protocol.
Physical IP – Network Port is used to bring a system under network and rest of the world communicates with system through this port in reference of an Address. This is called Internet Protocol Address (IP Address). The address which is bind with Physical Network Port (RJ45) is known as Physical IP Address of that system.
Virtual IP – With the help of inbuilt OS utility we can create/configure virtual network port and assign IP address to it. This is called Virtual IP.
Use of Virtual IP – Suppose you have two physical network ports (Two network card). Now you have configured one virtual network IP/port and assigne it to a program. When Rest of the world access your program, the packet passes through any of the physical network port and reach to the virtual IP/Port associated with the program. If any one of two Network card damages, your program will not suffer.
Extensive use of VIP is found in Web server Virtual hosting.
Is it possible to deploy any application on virtual IP? – Configure VIP in your system and assign the same to a Managed Server. Deploy application on that managed server. Your application will run on VIP.
From OS point of view VIP is something like adding a Network Card virtually and assign an address to it. But, to run an application on VIP, the best way is to configure Virtual Host.

Similar Messages

  • HSRP : routers respond with virtual mac AND physical mac to ARP requests

    Hello.
    I've noticed a very strange behaviour on my two Cisco's 2621 with HSRP configured.
    But first, this is a simplified schema of my current network.
    1. Summary
    - IOS version : 12.2(37)
    - File image : c2600-ik9o3s-mz.122-37.bin
    - R1 is the active router.
    - Both have tagged virtual interfaces : f0/0.10 & f0/0.60
    - NAT functionnality is enabled.
         - f0/0.10 is configured as outside.
         - f0/0.60 is configured as inside.
    2. Configuration samples
    R1
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.0.254 255.255.255.0
    ip nat outside
    service-policy output parent_out_internet
    no ip mroute-cache
    standby 10 ip 192.168.0.2
    standby 10 priority 120
    standby 10 preempt
    interface FastEthernet0/0.60
    encapsulation dot1Q 60
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    no ip mroute-cache
    no cdp enable
    standby 60 ip 192.168.1.1
    standby 60 priority 120
    standby 60 preempt
    ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
    ip nat inside source list internet pool ovrld overload
    R2
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.0.253 255.255.255.0
    ip nat outside
    service-policy output parent_out_internet
    no ip mroute-cache
    standby 10 ip 192.168.0.2
    standby 10 preempt
    interface FastEthernet0/0.60
    encapsulation dot1Q 60
    ip address 192.168.1.253 255.255.255.0
    ip nat inside
    no ip mroute-cache
    no cdp enable
    standby 60 ip 192.168.1.1
    standby 60 preempt
    ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
    ip nat inside source list internet pool ovrld overload
    3. Events.
    - When HSRP first runs or when there is a topology change, the active router sends correct ARP gratuitous reply packets (with the virtual MAC address)
    - ARP table is filled in on the Internet router.
    - When the ARP entry in the table expires it asks for the virtual IP mac address (192.168.0.2).
    - R1 responds with the virtual MAC address ---- BUT ---- R2 also responds with its physical mac address !
    - So packets are sent to the wrong router (R2) which can't route any packets because the NAT table is not up to date. I don't even have NAT command to synhronize NAT sessions between routers. But anyway, it should not solve my issue.
    It occurs only on the NAT (outside) interface. On the other virtual interfaces it behaves as expected.
    I don't have any explanations to this behaviour.
    For the moment, I have to keep R2 offline and bring it back online in case of failure.
    I tried several workarounds but I can neither filter ARP packets (no such function) on my router nor on my switch (too restrictive).
    If I forgot any information please ask me.
    Any help would be very much appreciated.

    Hello.
    I've noticed a very strange behaviour on my two Cisco's 2621 with HSRP configured.
    But first, this is a simplified schema of my current network.
    1. Summary
    - IOS version : 12.2(37)
    - File image : c2600-ik9o3s-mz.122-37.bin
    - R1 is the active router.
    - Both have tagged virtual interfaces : f0/0.10 & f0/0.60
    - NAT functionnality is enabled.
         - f0/0.10 is configured as outside.
         - f0/0.60 is configured as inside.
    2. Configuration samples
    R1
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.0.254 255.255.255.0
    ip nat outside
    service-policy output parent_out_internet
    no ip mroute-cache
    standby 10 ip 192.168.0.2
    standby 10 priority 120
    standby 10 preempt
    interface FastEthernet0/0.60
    encapsulation dot1Q 60
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    no ip mroute-cache
    no cdp enable
    standby 60 ip 192.168.1.1
    standby 60 priority 120
    standby 60 preempt
    ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
    ip nat inside source list internet pool ovrld overload
    R2
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 192.168.0.253 255.255.255.0
    ip nat outside
    service-policy output parent_out_internet
    no ip mroute-cache
    standby 10 ip 192.168.0.2
    standby 10 preempt
    interface FastEthernet0/0.60
    encapsulation dot1Q 60
    ip address 192.168.1.253 255.255.255.0
    ip nat inside
    no ip mroute-cache
    no cdp enable
    standby 60 ip 192.168.1.1
    standby 60 preempt
    ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
    ip nat inside source list internet pool ovrld overload
    3. Events.
    - When HSRP first runs or when there is a topology change, the active router sends correct ARP gratuitous reply packets (with the virtual MAC address)
    - ARP table is filled in on the Internet router.
    - When the ARP entry in the table expires it asks for the virtual IP mac address (192.168.0.2).
    - R1 responds with the virtual MAC address ---- BUT ---- R2 also responds with its physical mac address !
    - So packets are sent to the wrong router (R2) which can't route any packets because the NAT table is not up to date. I don't even have NAT command to synhronize NAT sessions between routers. But anyway, it should not solve my issue.
    It occurs only on the NAT (outside) interface. On the other virtual interfaces it behaves as expected.
    I don't have any explanations to this behaviour.
    For the moment, I have to keep R2 offline and bring it back online in case of failure.
    I tried several workarounds but I can neither filter ARP packets (no such function) on my router nor on my switch (too restrictive).
    If I forgot any information please ask me.
    Any help would be very much appreciated.

  • V2P Virtual Machine to physical Server migration on IBM x3650 M4 and switch from BIOS to UEFI Boot environment

    Hi there,
    just wanted to share my experience with a manual P2V Migration. The VM became to ressource hungry and it was decided to move it off an ESX 5 Cluster to a dedicated physical Machine.
    V2P Virtual Machine to physical Server IBM x3650 M4 and switch from BIOS to UEFI Boot environment
    Task:
    V2P Migrate a VMware virtual machine to a IBM x3650 M4 with a ServeRAID 5110e RAID Controller or any other LSI RAID Controller without 3rd Party tools.
    This should also work with other RAID Controllers or Servers but be sure to pick the right drivers then.
    Extra Task:
    The VM's boot environment/virtual BIOS is BIOS, not UEFI (as per default VMware Setting). The physical Server is running in UEFI mode.
    The Challenge:
    After restore the Server won't boot or get into a BSOD (7B), because the RAID drivers are missing.
    After restore the VM won't boot because the boot environment has changed from BIOS to UEFI
    Preparations:
    An existing physical Server of the same type and with the same RAID controller and same OS would be nice for troubleshooting and checking the registry.
    An existing DHCP server will make networking things easier.
    Connect the new physical server x3650 M4 to power and network
        create a virtual drive that has at least the size of the existing VM plus the size of the full backup (.vhd). Should be about twice the size of the original vmdk.
    Get a USB Flash stick (I used a 8GB modell so no problem with larger sticks)
    Download and extract LSI MegaRAID Driver on that USB media (I used 6.705.05.00-MR_Windows_Driver directly from LSI website)
    Download and extract INTEL Network Adapter Driver on that USB media (I used 12.11.97.0 of e1r62x64.inf from 19.5 driver release from 2014.09.26 directly from LSI website)
    Step by Step:
    if you have an other physical Server of the same type and same Controller and same OS:
    1.    open regedit and export everything related to SCSIAdapter and megasas2 to .reg files or skip this step and use my files below
        some of this (sub)keys may not be accesible - you will then first take ownership and/or modify permissions to read them
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\PCI\VEN_1000&DEV_005B&SUBSYS_04121014&REV_05
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\megasas2
        this one is more complicated:
        HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase (only relevant are those devices where the service name is megasas2 - export the whole subkey and get the filtering done with tools like notepad++)
        Make a copy of the following files/folders:
        c:\programdata\LSI\
        c:\windows\inf\megasas2.INF
        c:\windows\inf\megasas2.PNF
        c:\windows\system32\drivers\megasas2.SYS
    on the existing VM:
    1.    create a full backup (image) with the built-in Windows Backup Utility and save it in an accessible network location (you will need this one, if anything goes wrong or you want to come back to this point.
        Alternatively you could create a VMware snapshot.
    2.    import the .reg files you created earlier or import my files below.
        Attention: This will make the VM unbootable!
        But it is required to prepare the VM for the new RAID controller when it will be restored on the physical server.
        Do NOT reboot now as this will make the VM unbootable!
    4.    Copy the LSI folder and the megasas2.INF/PNF/SYS files to the appropriate destination folders on the VM.
    3.    again create a full backup (image) with the built-in Windows Backup Utility and save it in an other accessible network location but not where you safed the first backup.
        This will be the "golden" backup if you want, where the RAID controller is prepares. We will rebuild the new machine with this second backup.
    4.    Optional: you could use the Backuputility now to restore the Systemstate of the first backup and reboot or restore the VMware snapshot.
        This will undo the changes we made to the VM.
    on the new physical server:
    1.    boot the physical server from Windows Server 2008 R2 SP1 DVD
    2.    when it is ready to install, press shift+F10 to get command prompt and do not click to install Server 2008
    3.    check driveletter of the USB stick with diskpart list vol (was C: at my Server, so don't wonder about that letter)
    3.    load drivers for ServeRAID SAS controller (this is mandatory to see the volume in diskpart)
        drvload c:\srv_2008_x64\megasas2.inf
    4.    load drivers for INTEL I350 Gigabit NIC's (you will need this to access the backup that is on the network)
        drvload c:\PRO1000\NDIS62\e1r62x64.inf
    5.    wpeinit (will start network. wait ~15 sec to let it start and get IP address)
        check if you have IP connectivity an address with ipconfig, if not, use an other NIC driver and repeat steps 4+5
    6.    create the EFI and BCD
        diskpart
        list disk
        select disk x (where x is the number of the disk to convert)
        clean
        convert gpt
        create partition EFI size=128
        format fs=fat32 quick label=EFI
        assign letter=i or any other free drive letter
        create partition MSR size=128
    6.1    Copy EFI bootloader to EFI partition
        i: (where i is the letter of your EFI partition)
        mkdir EFI\Boot
        mkdir EFI\Microsoft\Boot
        copy x:\Windows\Boot\EFI\bootmgfw.efi i:\EFI\Microsoft\Boot (where x ist the default letter of the current Windows PE environment)
        copy x:\Windows\Boot\EFI\bootmgfw.efi i:\EFI\Boot\bootx64.efi (note that the file will be renamed to bootx64.efi)
    7.    create the new partitions
        diskpart
        create partition primary size=100000 (edit the size to your needs. this will later become the system drive of your server)
        format fs=ntfs quick label=Windows
        assign letter=Y or any other free drive letter
        create partition primary size=990000 (this will temporarily store your backup and we need it for the restore process)
        format fs=ntfs quick label=Backup
        assign letter=B or any other free drive letter
        exit
    8.    map network drive and copy the backup .vhd  to the local disk
        net use L: \\networklocation\where\you\saved\the\backup (enter the credentials when asked)
            copy the .vhd file that contains the OS of your VM to the local Backup Partition B. The relevant vhd file is usually the largest file in that fileset.
            Note that the names are very similarly - be sure to get the correct file!
        copy "L:\WindowsImageBackup\VMNAME\Backup 2015-02-03 123456\00e767c6-xxxx-xxxx-xxxxxxxxxxxx.vhd" B:\
            give it time, this is slow and will take some minutes/hours and you will not see any progress! Look at the disk-LED's to see if anything is still happening
    9.    mount the .vhd and copy it's contents to the new system partition
            Note that you can only mount a locally stored .vhd. You cannot mount a .vhd in a network location.
        diskpart
        select vdisk file=B:\00e767c6-xxxx-xxxx-xxxxxxxxxxxx.vhd
        attach vdisk
        select vol 5 (where 5 is the number of the mounted vdisk)
        assign letter=Z or any other free drive letter
        exit
    10. Restore the files from the image
        z: (where z is the letter of your mounted .vhd)
        xcopy * Y:\ /e /c /h /k /o /b /q /y (where Y: is the letter of your new partition with the label "Windows")
            several "Access denied" messages appear, ignore them. Those are SystemVolumeInformation folders.
    11.    Create Boot Configuration Data (BCD)
        bootrec /RebuildBcd
            this will try to repair the missing BCD on the second of the two small partitions we created earlier in and should normally work, otherwise you'll have to create BCD manually (search google for that procedure)
            Note that it may find more than one Windows installation and ask which sould be added to the boot list. Be sure to select only the one that is in the correct Volume (Y:\)
        that's it - exit the DOS command box and close the "Install Windows" Window, after a prompt it will reboot.
        Select "Start Windows Normally", if Windows Error Recovery appears.    
    12. Preparing Windows
        When Windows boots for the first time, DO NOT reboot if you are asked, it won't come back at this stage!
        Install Intel chipset drivers for the Server (I used "intc_dd_inteldp_9.4.0.1026_windows_32-64.exe" from IBM website)
        Open Device Manager, uninstall the "RAID-Controller" with the exclamation mark. You cannot install the correct driver for this Device at this point, it will bring you the error: "Cannot create a stable subkey under a volatile
    parent key"
        Once again, DO NOT reboot!
        In Device Manager select Action>Add Legacy Hardware
        click Next
        select Hardware manually
        select Storage Controller as Type
        LSI should be listed, select "LSI MegaRAID SAS 9281-8E"
        click Next, ignore the error "Code 10" Message.
        Click Done.
        Rightclick the LSI MegaRAID SAS 9281-8E device with the exclamation mark in Device Manager
        select Update driver
        select Browse my computer for driver software
        select let me pick from a list of device drivers on my computer
        select "Have Disk"
        browse to the folder where the extracted RAID driver 6.705.05.00-MR_Windows_Driver is located (e.g. USB Flash stick E:\6.705.05.00-MR_Windows_Driver\srv_2008_x64)
        then unselect "Show Compatible Hardware"
        on the right side, scroll up and select "IBM ServeRAID M5110e SAS/SSATA Controller"
        ignore the Update Driver Warning and click Yes
        click Next, ignore the error "Code 10" Message.
        ignore the exclamation mark on "IBM ServeRAID M5110e SAS/SSATA Controller" in Device Manager but be sure that there is only this controller and no other RAID-Controller or LSI SAS Controller listed under "Other Devices"
    or "Storage Controllers"
        NOW you are safe to reboot
        After reboot you will find two "IBM ServeRAID M5110e SAS/SSATA Controller" in Device Manager
        Rightclick and uninstall the one with the exclamation mark. Do not tick the checkbox to remove the driver as well!
    You're done!! (hopefully)

    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase]
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C31115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C38015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C41115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C48015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C51115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C58015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C61115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C68015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C71115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C78015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C81115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C88015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C91115D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_C98015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_D20219E5]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0060&SUBSYS_D20319E5]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0071&SUBSYS_00721137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00011BD4]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00721137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00731137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_008F1137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00B01137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00B11137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00B61137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00B71137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00C21137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_00C31137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_03B11014]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_040015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_040D1014]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_10541000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_11771734]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_14581002]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_1F201462]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_30351054]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_350C8086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_350D8086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_822910F1]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_843B1043]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_84711043]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92211000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92401000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92408086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92411000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92418086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92421000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92431000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92441000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92A01000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0073&SUBSYS_92A11000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0078&SUBSYS_92501000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0078&SUBSYS_92511000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0078&SUBSYS_92701000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_00011BAA]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_00021BD4]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_00791137]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_02001AE3]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_03B21014]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_03B31014]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_03C71014]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_070015D9]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_11761734]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_11B31734]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_30361054]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_350B8086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_84731043]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_84801043]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_8985152D]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92551000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92561000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92568086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92601000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92608086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92611000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92618086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92621000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92631000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92641000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92648086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92671000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92678086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92681000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92688086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92751000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92758086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92761000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92768086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92771000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92801000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92808086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92811000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92821000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92828086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92841000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92881000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92891000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92901000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_92908086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_D20819E5]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0079&SUBSYS_D20919E5]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0409&SUBSYS_10091000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10011000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10018086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10021000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10031000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10038086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10041000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10081000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10088086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_100C1000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_100D1000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10811734]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_10a31734]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_20041000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_20051000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_30161054]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_34908086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_35008086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_35018086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_35048086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_35078086]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0411&SUBSYS_82871033]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CriticalDeviceDatabase\PCI#VEN_1000&DEV_0413&SUBSYS_10051000]
    "ClassGUID"="{4D36E97B-E325-11CE-BFC1-08002BE10318}"
    "Service"="megasas2"
    "DriverPackageId"="megasas2.inf_amd64_neutral_8eb95ad00f4c26d7"

  • Kernel, virtual and physical memory

    Hi,
    I would like to get a clarification of the uses of the terms kernel, virtual and physical memory. Functions like kmem_alloc provide non-paged 'kernel' memory, but is this a pointer to a physical memory address, or is it similar to a virtual address that gets mapped by the memory management when it is referenced like virtual memory?
    Is there a way to determine a mapping between a virtual address and a physical address? (like vtophys in bsd or virt_to_phys/virt_to_bus in linux) ?
    Is all memory that is normally used within a driver (e.g. messages through a STREAM or DMA areas) 'kernel' memory, and is this a direct physical memory address (as asked above)?
    Many thanks
    S.

    Hi,
    Most kernel code and device drivers will only use virtual addresses. Yes, it is right!
    But I want to access a specific physical address.
    Because the bus bridge chip with PCI bus-master access a specific physical address directly.
    My system configuration is below:
    Platform: IA32
    Address map:
    0x00000000 - 0x000FFFFF: Main Memory, VGA Frame Buffer, Boot ROM
    0x00100000 - 0x0FFFFFFF : Main Memory(DIMM) - 255MB*
    0x10000000 - 0xFEBFFFFF: PCI bus memory space
    0xFEC00000 - 0xFFF7FFFF: Not Used
    0xFFFF8000 - 0xFFFFFFFF: Boot ROM
    *My system has 128MB DIMM on board.
    The bus bridge chip access a physical address at 0x06000000.
    I tested whether it would be set up correctly by using Linux as follow:
    1) Memory size is specified to 96MB compulsorily.
    init: Linux mem=96M
    2) Access to Physical address space via virtual address in kernel space.
    init_module(){
    va = iormap(0x06000000, size);
    *va = value;
    value = *(va+n);
    3) work good.
    I tried on Solaris by the same way.
    But I cannot find working.
    1) Memory size is specified to 96MB compulsorily.
    In /etc/system:
    set physmem=23723 <- Page size is 4K in my system. lower than 96MB.
    2) Access to Physical address space via virtual address in kernel space.
    xxx_attach(){
    ddi_regs_map_setup();
    ddi_putX(value);
    value = ddi_getX();
    driver.conf
    name="xxx" class="sysbus" reg=0,0x06000000, size;
    And I tried access by using /dev/mem.
    This also went wrong.
    dose anyone have good idea?
    Toru OHATA

  • What Virtual Characterstic and How to Create it.

    Hi Experts,
    My Requirment is to calculacte age based on DOB at run time.
    One expert in this forum gave me an idea and required code how to achieve it.
    Could you please specifie me on how to
    1) Create Virtual Characterstic
    And he asked me to in SMOD .....how can i do it...please explain me in a bit detail
    Thanks

    Hi,
    Virtual key figures: Will not be stored in the cube. Will be computed at run time when he query is executed. The are virtual in nature and not physical. When you view the cube's contents in listcube, you will not see it there. This is not the same as calc key figures. example: to store sales in your cube and this has o be allocated to all the group companies with a business logic, in this scenario you can code the logic in an exit and derive these virtual key figures. Another example is, when you report on no of days outstanding of your debtors. This will vary depending on when you the run the report. So, a exit can be coded to compute this run time. This is classical example of virtual key figure.
    Virtual characteristics: Same as above. Here you will derive the characteristics while report is run.
    Depending on the requirements, you must decide when to code for a virtual kf or cha and when to store them in the cube physically.
    Virtual characteristics and Key figures are useful if you want to dynamically pouplate data from the fact table to the field.
    Virtual key figures are key figures within an InfoProvider that are not filled with data. Instead the key figure value is determined at runtime of the query using custom ABAP coding
    Check "how to" doc for virtual characteristic/key figure details.
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/biw/g-i/how%20to%20use%20variable%20time%20references%20in%20currency%20conversion
    Virtual key figures and charecteristcs are populated at query execution time.
    These virtual objects should be included in the modelling level itself,so that it can be used in the query while using exit in that.
    check this step by step doc:
    https://websmp106.sap-ag.de/~sapdownload/011000358700009299362001E/HOWTOIDENTIFYCOMPRESULTS.DOC
    Regards,

  • Virtual server and Firewall

    Hi all,
    Sorry if this is a too basic question. I'm trying to understand how our system works as I'm not the one that set it up in the first place. The Firewall crashed today and needed rebooted. When connected to the the server it says "Kernel-Power" and
    ID 41 so to me it sounds like the server shut down unexpectedly but I'm not sure. When the Firewall was rebooted everything was working fine again. So I have several questions that I'm thinking of. How can I figure out what really happened? Did the server
    shut down or was it just the firewall? Is it possible that the server (or client computers) sent information through the firewall, the firewall's cache got fully loaded and couldn't give a response and because the server didn't get a response it rebooted and
    the firewall crashed? Sounds unlikely, doesn't it. I maybe should say that when the firewall was down, as I said, I could access the server through RDC but the firewall was completely inaccessible so I had to press the physical power button to restart the
    Firewall. And the last week the network overall has been going very slow (which I tried to resolve yesterday by rebooting the routers that we have and that seemed to work).
    Thankful for any ideas!

    Hi Nitman,
    You are welcome to post the feedback here when using microsoft products .
    "is it possible to setup Windows Server 2008 in a way that it runs on a virtual machine but physically on three different machines? "
    If you want to enable hyper-v role in server 2008 (you can enable hyper-v role directly in 2008R2 and later ), please refer to the article below :
    http://technet.microsoft.com/en-us/magazine/dd744752.aspx
    The prerequisites for hyper-v :
    http://technet.microsoft.com/en-us/library/cc731898.aspx
    Hyper-v getting started guide :
    http://technet.microsoft.com/en-us/library/cc732470(v=WS.10).aspx
    Best Regards
    Elton Ji
    We
    are trying to better understand customer views on social support experience, so your participation in this
    interview project would be greatly appreciated if you have time.
    Thanks for helping make community forums a great place.

  • Virtual PC and Citrix web access

    Hello!
    I have a PowerBook G4 running OS X Tiger. For work, I have to access my company's Citrix web site when I am not in the office physically so I can use some mainframe based applications. I'd prefer not to buy an additional PC laptop just for the web Citrix access.
    I researched on the web and found that Virtual PC 7.0 for Windows XP Professional seems to be the solution, but I didn't find anything about using Virtual PC to access a web site that has the Citrix (I think it uses Metaframe) portal to launch company email, office apps, and mainframe access.
    I have not purchase Virtual PC 7.0 yet - I am in my research stage where I'd like to know "what I am getting into". Requesting Citrix server IP address for a direct sign-on is not an option for me even if I use Virtual PC 7.0. Does anyone either have experience with similar Citrix access situations via Web or can anyone point me to some other resources website that may help me?
    Thanks!
    Angela

    Hi Angela!
    A Citrix client for Mac OS X is also available. Using this may be easier than trying to install and configure Virtual PC and then installing and configuring the Citrix client for Windows.
    Your Citrix support folks should be able to tell you what settings you need to connect and log in but they may only support you as far as Windows. You'd need to use the admin guide (found at the same link above) to configure your Mac client.
    Hope this helps! bill
    1 GHz Powerbook G4   Mac OS X (10.4.6)  

  • Virtual chars and keyfigures

    HI All,
    I have created a BADI for virtual characteristics and key figures according to a business requirement but the biggest problem is the query performance. Its taking around 15 to 20 minutes to refresh a query. I have used internal tables and field symbols in the BADI but I do not know what is causing this problem.
    Could anybody suggest me? How to improve the query performance? Do I need to do any changes in the code? or anything that can be done in query level? Or taking off virtual characteristics and key figures or do physical design instead of virtual characteristics and key figures? I have done all level of query performance tuning but still same problem.
    have done all kinds of analysis but still I could not find the solution.
    I know this is defiantly something to be done with virtual characteristics and Keyfigures.
    Is there anything new that I can do tuning for code?
    Points will be assigned.
    Thanks,
    Martin.

    dear all,
    I implemented badi for virtual key figures , i am unable to stop at compute method.
    could any one of you suggest me why it is not stoping at compute method while executing quesry even though i kept break points.
    regards,
    Nerusu

  • Virtual char and keyfig

    HI
    wt is the ue of virtual chars an keyfiures.. how r they created.... how r they different from normal keyfig..... explain .. plzzzzzzz
    <removed>
    Regards
    Rekha

    Hi Rekha,
    Virtual key figures: Will not be stored in the cube. Will be computed at run time when he query is executed. The are virtual in nature and not physical. When you view the cube's contents in listcube, you will not see it there. This is not the same as calc key figures. example: to store sales in your cube and this has o be allocated to all the group companies with a business logic, in this scenario you can code the logic in an exit and derive these virtual key figures. Another example is, when you report on no of days outstanding of your debtors. This will vary depending on when you the run the report. So, a exit can be coded to compute this run time. This is classical example of virtual key figure.
    Virtual characteristics: Same as above. Here you will derive the characteristics while report is run.
    Depending on the requirements, you must decide when to code for a virtual kf or cha and when to store them in the cube physically.
    Virtual characteristics and Key figures are useful if you want to dynamically pouplate data from the fact table to the field.
    Virtual key figures are key figures within an InfoProvider that are not filled with data. Instead the key figure value is determined at runtime of the query using custom ABAP coding
    Check "how to" doc for virtual characteristic/key figure details.
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/biw/g-i/how%20to%20use%20variable%20time%20references%20in%20currency%20conversion
    Virtual key figures and charecteristcs are populated at query execution time.
    These virtual objects should be included in the modelling level itself,so that it can be used in the query while using exit in that.
    check this step by step doc:
    https://websmp106.sap-ag.de/~sapdownload/011000358700009299362001E/HOWTOIDENTIFYCOMPRESULTS.DOC
    <removed>
    Regards,
    Ravikanth

  • Global virtual channels and DAQmx AI inputs

    I would like to see and example linking global virtual channels and input configuration for DAQmx AI inputs.  The DAQmx input requires physical channels and not global virtual channels.

    Hello rlbrehm,
    If you are using a global virtual channel then you have alredy set up the input configuration, as shown here:
    So you simply need to set up timing and read, as shown here and in the attached VI:
    Message Edited by Dr. Doiron on 08-06-2009 02:55 PM
    With warm regards,
    David D.
    Attachments:
    Global Virtual Channel.vi ‏9 KB
    Input Config.jpg ‏176 KB
    VI.jpg ‏78 KB

  • How does OpenSPARC translate Virtual Address to Physical Address or Vice V

    The i386 page address system has three levels: dir, page, offset. The 32 bits virtual address consists of dir, page, offset. When the process releases a virtual address to read a memory content, the MMU of i386 will translate the virtual address to physical address as follows:1,Based on the value of CR3 register and dir of virtual address, MMU returns the base address of page.2, Based on the the base address of page and value of page of virtual address, MMU returns the base address of physical page.3, Based on the base address of physical page and value of offset of virtual address, MMU returns physical memory address. 4, Read the content of physical memory address.
    However, when I read the source code of the bw_r_tlb of OpenSPARC�s MMU, I am puzzled. I am not clear how is the page address system of OpenSPARC implement.
    Will you offer me some hints about it ? And are there any documents about it?
    Thanks a lot!

    It would be good to add the definition of Hypervisor in the wikipedia.
    Thanks
    [email protected] wrote:
    > I have downloaded the source code of linux-2.6.17.9 version. In the arch directory of linux-2.6.17.9, I
    find the Hypervisor API (such as sun4v_intr_setstate, sun4v_intr_gettarget) has been
    integrated with Linux kernel. In other words, it is implemented in Linux kernel. All the time, I think
    Hypervisor API is an independent layer which provides an easy way to switch among all kinds of OS. But now,
    I find it is a part of Linux. If so, what a role does Hypervisor API take? Why do we name it Hypervisor API
    rather than a part of Linux? It do puzzle me, am I wrong?
    The Hypervisor API ("application programming interface") is fully described in the UltraSPARC T1 Hypervisor API Specification, which is downloadable from page http://opensparc-t1.sunsource.net/index.html .
    As a brief digression ... the term "Hypervisor API" has always seemed a bit oxymoronic to me -- given the historic equivalency of "application" to "nonprivileged". After all, isn't it more of an "SPI" (supervisor programming interface) because it services privileged supervisor (operating system) software, not nonprivileged (application) software? But if you think of a guest OS as an "application" (in the general sense of the word) supported by the Hypervisor, then "Hypervisor API" makes some sense.
    Now, regarding Hypervisor API and Linux. If you read the UltraSPARC T1 Hypervisor API Specification, you'll find that Hypervisor API calls are defined (appropriately enough) in terms of native SPARC assembly language. I haven't looked at the Linux source code, but I'd bet a considerable sum of money that the Linux sun4v_intr_gettarget() function is a C-language wrapper around a SPARC assemly-language routine that sets up arguments, performs a trap to the Hypervisor intr_gettarget function, and returns the result(s) to the caller.
    In any case, all actual Hypervisor code is fully implemented in the Hypervisor, not in Linux or Solaris or FreeBSD or Wind River Linux or any other OS running on top of the Hypervisor. Each OS may implement some "wrapper" code around Hypervisor calls, but no actual Hypervisor functionality actually resides in a guest OS. In fact, it can't reside in a guest OS because it must run in hyperprivileged mode and guest operating systems run in "merely" Privileged mode.
    To unsubscribe, e-mail: [email protected]
    For additional commands, e-mail: [email protected]
    Shrenik Mehta               Tel: 408-774-8580
    Sr. Director, Frontend Technologies & OpenSPARC Program
    System Group               Fax: 408-774-8154
    Sun Microsystems          http://www.opensparc.net
    NOTICE: This email message is for the sole use of the intended
    recipient(s) and may contain confidential and privileged
    information. Any unauthorized review, use, disclosure or
    distribution is prohibited. If you are not the intended
    recipient, please contact the sender by reply email and destroy
    all copies of the original message.
    To unsubscribe, e-mail: [email protected]
    For additional commands, e-mail: [email protected]

  • Find out virtual nic to physical nic mapping

    any command in hyper-v / scvmm to find out virtual nic to physical nic mapping. In vmware we can get the same by esxtop N view shows VMname and the physical NIC used, simlarly any in hyper-v

    I think that in a device driver you can use hat_getkpfnum(9F) to get the physical page number from a virtual address.
    In crash(1m) the vtop command will translate a virtual to a physical address.
    I would have thought you could also just use the virtual address against /dev/kmem, as opposed to using a physical address against /dev/mem?
    Hope that helps.
    Ralph
    SUN DTS

  • Virtual address to physical address

    Hi,
    How do i convert kernel virtual address to physical address.... do we have
    any DDI function for this.?.. i am writing a driver for a pci card... my
    card needs the physical address of the memory location so that it can dump
    data to this location..
    OS: SOlaris 7 on intel pc..
    gurus any idea how to do this stuff???....
    TIA
    azad

    The recommended way to do this is by using the ddi_dma* functions. I would suggest reading the entire "Writing Device Drivers", but pay particular attention to the chapters on DMA and the section in the chapter on character drivers that deals with DMA.

  • Working set, virtual bytes and private bytes

    Hello everyone,
    I am using Windows Server 2003 Performance Counter tool to monitor the memory consumed by my process.
    The interested terms are working set, virtual bytes and private bytes. My questions are,
    1. If I want to watch the real physical memory consumed by current process, which one should I monitor?
    2. If I want to watch the physical memory + swap file consumed by current process, which one should I monitor?
    3. Any more clear description of what these terms mean? I read the help from Performance Counter tool, but still confused
    which one(s) identifies the real used physical memory, and which one(s) identifies the real used physical memory + page swap file, and which one(s) identifies the required memory (may not be really allocated either in physical memory or in swap page file).
    If there are any related learning resource about the concepts, it is appreciated if you could recommend some. :-)
    thanks in advance,
    George

    And for further benefit:
    "Virtual bytes" is the total size of the not-free virtual address space of the process. It includes private committed, mapped, physically mapped (AWE), and even reserved address spaces. 
    "Private committed" is the portion of "virtual bytes" that is private to the process (as opposed to "mapped", which may be shared between processes; this is used by default for code). This normally includes program globals,
    the stacks (hence locals), heaps, thread-local storage, etc. 
    Each process's "private committed" memory is that process's contribution to the system-wide counter called "commit charge". There are also contributions to commit charge that aren't part of any one process, such as the paged pool. 
    The backing store for "private committed" v.m. is the page file, if you have one; if you have (foolishly in my opinion) deleted your page file, then all private committed v.m., along with things like the paged pool that would normally be backed
    by the page file, has to stay in RAM at all times... no matter how long ago it's been referenced (which is why I think running without a page file is foolish). 
    The "commit limit" is the size of RAM that the OS can use (this will exclude RAM used for things like video buffers) plus the total of the current size(s) of your pagefile(s). Windows will not allow allocations of private committed address space
    (e.g. VirtualAlloc calls with the COMMIT option) that would take the commit charge above the limit. If a program tries it, Windows will try to expand the page file (hence increasing the commit limit). If this doesn't succeed (maybe because page file expansion
    is disabled, maybe because there's no free disk space to do it) then the attempt to allocate committed address space fails (e.g. the VirtualAlloc call returns with a NULL result, indicating no memory was allocated). 
    The "Working set" is not quite "the subset of virtual pages that are resident in physical memory", unless by "resident" you mean "the valid bit is set in the page table entry", meaning that no page fault will occur
    when they're referenced. But this ignores the pages on the modified and standby page lists. Pages lost from a working set go to one of these lists; if the modified list, they are written to the page file and then moved to the standby list. From there they
    may be used for other things, such as to satisfy another process's  need for pages, or (in  Vista and later) for SuperFetch. But until that happens, they still contains the data from the process they came from and are still associated with that process
    and with that processes' virtual pages. Referring to the virtual page for which the physical page is on the standby or modified list will result in a "soft" page fault that is resolved without disk I/O. Much slower than referring to a page that's
    in the working set - but much faster than having to go to disk for it. 
    So the most precise definition of "working set" is "the subset of virtual pages that can be referenced without incurring a page fault." 

  • Virtual Directories and ColfFusion

    This is really hot but I need to know what happens when
    ColdFusion accessed a Virtual Directory. Does any one have a
    architect of this for ColdFusion?
    This is REALLY HOT and I need this ASAP. I have the following
    but I need to add the VD part.
    Jim

    > ColdFusion accessed a Virtual Directory
    I'm guessing you mean Virtual Directories in IIS?
    I don't think CF is the one actually accessing these
    directories? I think IIS
    simply has a map from the virtual to the physical, and it's
    the physical that IIS
    passes to CF?
    Meaning, CF is unaware of the Virtual Directory? This is not
    to say that .cfm
    files located in Virtual Directories do not get processed by
    CF.
    Good luck!

Maybe you are looking for

  • Apple TV (1st Gen) not being recognized in iTunes 10.5

    I recently updated iTunes to 10.5 and my Apple TV (1st Gen) will not longer show up in iTunes; thus I am not able to syn or stream any content from my iTunes library.  I am not even able to reconnect/pair my Apple TV with my iTunes. I have also been

  • How to upgrade OS on an External Drive?

    I have downloaded Lion to my iMac. All seems well. Glad I had a Track Pad, The lion was well hidden. I keep TT Pro and DW on an external drive on which I installed a Mac OS as a "carrier" some years back. I have updated/upgraded it as new OSs came al

  • Biometric device is not showing up in the control panel

    hello,  i'm using elitebook 8440p. earlier i was using win 8, my biometric device was runnig fine. But when i begant use win 7, it started showing unavailable in the control panel. So I reinstalled it, now it is not showing up in the control panel to

  • Preset file location; I've got a mess

    I've got a set of Preset folders in my C:\Users\Bob\AppData\Roaming\Adobe\Lightroom directory (Windows 7 64 bit); Lightroom.exe is in a nearby folder.  I have another set of Preset folders with the same names in my F:\Lightroom\Lightroom Settings dri

  • Both can connect to test sites but not videochat with each other

    I am using a 2GHz PPC iMac on 10.4.6 with external iSight. I can see the Apple ad from one of the test sites. My wife is using a G4 PowerBook running the latest Panther OS with external iSight. She is in a hotel but can also see the Apple ad from the