HSRP : routers respond with virtual mac AND physical mac to ARP requests

Hello.
I've noticed a very strange behaviour on my two Cisco's 2621 with HSRP configured.
But first, this is a simplified schema of my current network.
1. Summary
- IOS version : 12.2(37)
- File image : c2600-ik9o3s-mz.122-37.bin
- R1 is the active router.
- Both have tagged virtual interfaces : f0/0.10 & f0/0.60
- NAT functionnality is enabled.
     - f0/0.10 is configured as outside.
     - f0/0.60 is configured as inside.
2. Configuration samples
R1
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.0.254 255.255.255.0
ip nat outside
service-policy output parent_out_internet
no ip mroute-cache
standby 10 ip 192.168.0.2
standby 10 priority 120
standby 10 preempt
interface FastEthernet0/0.60
encapsulation dot1Q 60
ip address 192.168.1.254 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
standby 60 ip 192.168.1.1
standby 60 priority 120
standby 60 preempt
ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
ip nat inside source list internet pool ovrld overload
R2
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.0.253 255.255.255.0
ip nat outside
service-policy output parent_out_internet
no ip mroute-cache
standby 10 ip 192.168.0.2
standby 10 preempt
interface FastEthernet0/0.60
encapsulation dot1Q 60
ip address 192.168.1.253 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
standby 60 ip 192.168.1.1
standby 60 preempt
ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
ip nat inside source list internet pool ovrld overload
3. Events.
- When HSRP first runs or when there is a topology change, the active router sends correct ARP gratuitous reply packets (with the virtual MAC address)
- ARP table is filled in on the Internet router.
- When the ARP entry in the table expires it asks for the virtual IP mac address (192.168.0.2).
- R1 responds with the virtual MAC address ---- BUT ---- R2 also responds with its physical mac address !
- So packets are sent to the wrong router (R2) which can't route any packets because the NAT table is not up to date. I don't even have NAT command to synhronize NAT sessions between routers. But anyway, it should not solve my issue.
It occurs only on the NAT (outside) interface. On the other virtual interfaces it behaves as expected.
I don't have any explanations to this behaviour.
For the moment, I have to keep R2 offline and bring it back online in case of failure.
I tried several workarounds but I can neither filter ARP packets (no such function) on my router nor on my switch (too restrictive).
If I forgot any information please ask me.
Any help would be very much appreciated.

Hello.
I've noticed a very strange behaviour on my two Cisco's 2621 with HSRP configured.
But first, this is a simplified schema of my current network.
1. Summary
- IOS version : 12.2(37)
- File image : c2600-ik9o3s-mz.122-37.bin
- R1 is the active router.
- Both have tagged virtual interfaces : f0/0.10 & f0/0.60
- NAT functionnality is enabled.
     - f0/0.10 is configured as outside.
     - f0/0.60 is configured as inside.
2. Configuration samples
R1
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.0.254 255.255.255.0
ip nat outside
service-policy output parent_out_internet
no ip mroute-cache
standby 10 ip 192.168.0.2
standby 10 priority 120
standby 10 preempt
interface FastEthernet0/0.60
encapsulation dot1Q 60
ip address 192.168.1.254 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
standby 60 ip 192.168.1.1
standby 60 priority 120
standby 60 preempt
ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
ip nat inside source list internet pool ovrld overload
R2
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.0.253 255.255.255.0
ip nat outside
service-policy output parent_out_internet
no ip mroute-cache
standby 10 ip 192.168.0.2
standby 10 preempt
interface FastEthernet0/0.60
encapsulation dot1Q 60
ip address 192.168.1.253 255.255.255.0
ip nat inside
no ip mroute-cache
no cdp enable
standby 60 ip 192.168.1.1
standby 60 preempt
ip nat pool ovrld 192.168.0.2 192.168.0.2 prefix-length 24
ip nat inside source list internet pool ovrld overload
3. Events.
- When HSRP first runs or when there is a topology change, the active router sends correct ARP gratuitous reply packets (with the virtual MAC address)
- ARP table is filled in on the Internet router.
- When the ARP entry in the table expires it asks for the virtual IP mac address (192.168.0.2).
- R1 responds with the virtual MAC address ---- BUT ---- R2 also responds with its physical mac address !
- So packets are sent to the wrong router (R2) which can't route any packets because the NAT table is not up to date. I don't even have NAT command to synhronize NAT sessions between routers. But anyway, it should not solve my issue.
It occurs only on the NAT (outside) interface. On the other virtual interfaces it behaves as expected.
I don't have any explanations to this behaviour.
For the moment, I have to keep R2 offline and bring it back online in case of failure.
I tried several workarounds but I can neither filter ARP packets (no such function) on my router nor on my switch (too restrictive).
If I forgot any information please ask me.
Any help would be very much appreciated.

Similar Messages

  • Virtual IP and physical IP

    Hi All,
    What is the difference between virtual IP and physical IP. Can some one tell me what is the use of virual IP. I think physical IP means listening port of the web-logic server. Is it possible to deploy any application on virual IP.
    Thanks,
    Venkat.

    What is the difference between virtual IP and physical IP?
    IP – the abbreviation means Internet Protocol.
    Physical IP – Network Port is used to bring a system under network and rest of the world communicates with system through this port in reference of an Address. This is called Internet Protocol Address (IP Address). The address which is bind with Physical Network Port (RJ45) is known as Physical IP Address of that system.
    Virtual IP – With the help of inbuilt OS utility we can create/configure virtual network port and assign IP address to it. This is called Virtual IP.
    Use of Virtual IP – Suppose you have two physical network ports (Two network card). Now you have configured one virtual network IP/port and assigne it to a program. When Rest of the world access your program, the packet passes through any of the physical network port and reach to the virtual IP/Port associated with the program. If any one of two Network card damages, your program will not suffer.
    Extensive use of VIP is found in Web server Virtual hosting.
    Is it possible to deploy any application on virtual IP? – Configure VIP in your system and assign the same to a Managed Server. Deploy application on that managed server. Your application will run on VIP.
    From OS point of view VIP is something like adding a Network Card virtually and assign an address to it. But, to run an application on VIP, the best way is to configure Virtual Host.

  • My MacBook not responding with all browsers and some applications!!!

    Hi !!!
    First sorry my english...
    My apple not respond i i need force to quiet... (Safari, firefox, chrome, some applications like players)
    I a few days my mac don't works like before i try to use chrome safari fireworks and is always the same in youtube or any website with flash content, and some applications too the same problem not respond, i was unistall and reinstall a lot o softwares i use clean app to remove the app complete and reinstall but don't works ... What i do? whatis this? My mac is all updated i use all lastest versions ... I don't understand why... Somebody can help me...
    Thank you for all news...
    bye!

    Hi,
    Click once on the hard drive icon. Then hold down the  key and tap i (  + i ).
    Capacity XX
    Available XX
    Used XX
    Post back with your values of XX.
    Regards.
    Ian.

  • Problem with Virtual PC and Network Connection - VPC gets disconnected

    Hi,
    I've been having a few problems with a virtual computer and its network connection.  I've set up a few computers the same way over the years and they all work fine except this one.  We use the Virtual PC and XP mode to access our data from an older
    program.  The databases are on a server, which are accessed as a mapped drive.  Every once in a while (with no particular pattern, sometimes it doesn't happen all day, sometimes it happens every 5 mins), the VPC gets disconnected from the network,
    my program returns a file read error and then everything is frozen.  When I try to ipconfig/release and renew, it releases correctly then it won't renew.  I need to shut down the VPC from the Win7 task manager and even so, it doesn't shut it down,
    even when I try to kill the vpc process.  The only way it'll come back up is if I restart the computer.  The network connection on the Win7 computer doesn't do that.
    Is there anything I can do to fix this ?
    Thanks,
    Melanie

    Hi,
    Does it become more stable now, actually, I'm afraid that this issue is not related with the drive letter or name. Since you're using bridge mode, the I would suggest you use NAT as a test, it is the default network configuration, which allows the VM
    to leverage the external TCP/IP network connected to the host. This is very useful if you regularly move the host computer between different network configurations. NAT is the preferred networking option when there is a shortage of IP addresses, a need to
    ensure the VM’s IP address is not targetable from an external network, or a need for connecting using WWAN.
    Yolanda Zhu
    TechNet Community Support

  • OMacbook calendar gets the message "the server responded with an error" and is now not syncing. Any idea?

    I haven't done anything to my Macbook (I don't think) but out of the blue when adding entries to my calendar,  I now get the message "the server responded with an error". Consequently it will not sync with the Cloud. I have an iMac which DOES sync with both iPad and the iPhone.
    Anyone any idea?
    ALan

    Sorry, no help there. Ical does not stay open long enough to do anything with. All it does is crash and apologise and say it will notify Apple.
    Guess I will just delete it altogether and use google calendar.

  • Slim, a problem with virtual consoles and a question about reboot

    hi, just installed slim but now when I switch to the virtual consoles my session on X starts firing keyboard events on the consoles I have there, how can I fix that?
    I'm using xmonad, my terminal is sakura and I'm starting slim from /etc/inittab and xmonad from ~/.xinitrc
    also, it seems slim uses special usernames to halt and reboot however those ask me for the root password, is there a way to avoid that?
    thanks all.
    Last edited by Samus_ (2008-11-23 18:19:49)

    Samus_ wrote:hi, just installed slim but now when I switch to the virtual consoles my session on X starts firing keyboard events on the consoles I have there, how can I fix that?
    this http://developer.berlios.de/bugs/?func= … up_id=2663 might be related.  out of curiosity, why are you starting slim from /etc/inittab and not as a daemon in /etc/rc.conf?
    Samus_ wrote:also, it seems slim uses special usernames to halt and reboot however those ask me for the root password, is there a way to avoid that?
    the flippant answer is, "yes, fix slim."  but so as not to be a jerk, 'man slim' turns up this:
    The 'halt' and 'reboot' commands need the root password, this may change in future releases.
    so i was about to say, "no."  then i decided to hit google with 'slim "special usernames" password'.   unfortunately, your post here is the fourth result, so no love there.
    *but* there's this:
    http://developer.berlios.de/bugs/?func= … up_id=2663
    and this:
    http://developer.berlios.de/patch/?func … up_id=2663
    and the abs.
    so if you really want it, read the wiki page on the abs, add the patch to the pkgbuild, makepkg, and pacman -U.  if you don't want pacman to replace your patched version when there's an update, add slim to the IgnorePkg line in /etc/pacman.conf.  you'll have to re-makepkg and re-pacman -U whenever there's an update, but it ain't that hard.
    if it works, i might like a copy of yr pkgbuild.  hth!

  • Is there a problem with Virtual PC and OS 10.4.4?

    After installing OS 10.4.4 (which gave me my first EVER Mac system crash!) I found that when running Virtual PC (6.1) I had to re-install Windows XP. I didn't need the CD; everything was still on the hard drive, but I had to re-register it. Has this affected anyone else?
    Of course, I don't actually KNOW that it was caused by 10.4.4; it may have been a coincidence. But it's never happened before.
    Everything runs fine so far after the reinstallation.

    After installing OS 10.4.4 (which gave me my first EVER Mac system crash!) I found that when running Virtual PC (6.1) I had to re-install Windows XP. I didn't need the CD; everything was still on the hard drive, but I had to re-register it. Has this affected anyone else?
    Of course, I don't actually KNOW that it was caused by 10.4.4; it may have been a coincidence. But it's never happened before.
    Everything runs fine so far after the reinstallation.

  • I have tried to upgrade my iPod touch , and cant even remember to which iOS  , and it didnt respond with the upgrade and does the loading logo until the battery life is gone. I tried restarting it doesnt work. NEED HELP

    I have upgraded my iPod touch and it didnt respond to the upgrade. Cant remember which iOS i was upgrading but when i try to switch it on the apple logo comes up but than it just goes to the loading logo until the battery life is gone. I have tried restarting it , that doesnt work. I need help i am lost without my ipod please help. Any ideas besides restarting it ?

    Try:                           
    - iOS: Not responding or does not turn on
    - Also try DFU mode after try recovery mode
    How to put iPod touch / iPhone into DFU mode « Karthik's scribblings
    - If not successful and you can't fully turn the iOS device fully off, let the battery fully drain. After charging for an least an hour try the above again.
    - Try another cable
    - Try on another computer                            
    - If still not successful that usually indicates a hardware problem and an appointment at the Genius Bar of an Apple store is in order.
    Apple Retail Store - Genius Bar                                     

  • Problems with Remote Desktop and Back to My Mac

    It's impressive how quickly Apple removed my post because of its tone. I hope they respond with equal speed and verve to my concerns.
    I need to get Remote Desktop operational. Can someone walk me through the process of getting Remote Desktop to "see" my home computer? The current online video tutorial for Remote Desktop is outdated and no longer resembles the current UI for setting up Remote Desktop.
    What about Back to My Mac? Can I get help with that, too? I figure if I can get at least RD or BTMM running properly I'll be able to do what I want to do.

    The subject of connecting ARD via the Internet has been covered here many times already (search the forum for "Internet"), but take a look at this web page:
    http://www.starkpr.com/ard.htm
    It should help, though you may have to refer to your router's documentation for specifics on opening and forward ports in that particular unit.
    "Back to my Mac" is a different feature of Mac OS X and has it's own forum:
    http://discussions.apple.com/forum.jspa?forumID=1247

  • MY calendar screen on my MacBook Pro is locked up will not let me close. "The server responded with an error" I have tried force quit, and shutting of the computer.

    My MacBook Pro 15in mid 2010 4gb 1067, 2.4gighertz i5, os 10.9.5 has locked up the calendar screen displays "The server responded with an error" and will not let me exit the msg or the screen I can use the rest of the computer.  I have turned of the computer, force quit and other things.  I tried to send a Calendar by email

    I tried your suggestion but it did not work (hold shift down when re-launching calendar). Here is the message I keep getting. Help - this endless loop prohibits me from accessing any calendar functions.
    The server responded with error.
    Access to account “Google” is not permitted.
    The server responded:
    “403”
    to operation CalDAVAccountRefreshQueueableOperation.

  • Virtual chars and keyfigures

    HI All,
    I have created a BADI for virtual characteristics and key figures according to a business requirement but the biggest problem is the query performance. Its taking around 15 to 20 minutes to refresh a query. I have used internal tables and field symbols in the BADI but I do not know what is causing this problem.
    Could anybody suggest me? How to improve the query performance? Do I need to do any changes in the code? or anything that can be done in query level? Or taking off virtual characteristics and key figures or do physical design instead of virtual characteristics and key figures? I have done all level of query performance tuning but still same problem.
    have done all kinds of analysis but still I could not find the solution.
    I know this is defiantly something to be done with virtual characteristics and Keyfigures.
    Is there anything new that I can do tuning for code?
    Points will be assigned.
    Thanks,
    Martin.

    dear all,
    I implemented badi for virtual key figures , i am unable to stop at compute method.
    could any one of you suggest me why it is not stoping at compute method while executing quesry even though i kept break points.
    regards,
    Nerusu

  • Inventory management and physical inventory data transfer

    hi all,
    can anyone plz povide me with inventory management and physical inventory data transfer tutorial or link.
    points are guarented.
    rgds

    The information behind the blue-button for MI34, MI38 (as you mentioned) does not have enough detail. It's basically one-page. Is there another instructional source available?  How is the logical file MMIM_PHYSICAL_INVENTORY_DOCUMENTS tied to the physical, can you clarify? Not sure how to determine where the sequential file being processed needs to be located. Thanks!

  • Ical server responds with an error

    I have a MacBook Pro and I have an Ical error "server responds with an error" and cannot make it stop popping up

    Sorry, no help there. Ical does not stay open long enough to do anything with. All it does is crash and apologise and say it will notify Apple.
    Guess I will just delete it altogether and use google calendar.

  • I can't quit iCal on my imac. I keep getting  "the server responded with an error"

    I can't quit iCal on my imac. I keep getting  "the server responded with an error" and I  need to change my password but I can't even quit it to do it.

    Can you do a Force Quit?  Right click on it in the dock, then press the option/alt key, and Force Quit should come up in the sub menu.

  • Creating external drive with mac/Virtual PC and ex-wintel drive!!

    OK, I hope I can make this as clear as possible to get some assistance, as it's not too clear in my head!!
    I'm a long-ish time mac user, my girlfriend not. Her wintel machine has recently hit some problems (looks like fried motherboard) and it's a grand opportunity for her to get going with a mac. She has a lot of word docs/pdfs etc on the HD from the wintel machine (PhD reseracher). If I put that (20GB seagate) drive in a USB/firewire enclosure will I be able to access the relevant files (using virtual pc-do I need to use that?) to connect and get them onto a mac????
    Any help much, much, much appreciated!
    Best

    Easing reluctant PC users into our much better way of life is a technically easy endeaver. The largest obstacle, however, is the PC user, themselves. It's unnerving for them to see this wildly different user interface and think that their PDFs, Docs, email, bookmarks and more can move to the mac just like they can.
    If you're talking about taking the Hard Drive out of your girlfriend's PC because the rest of the PC's hardware is funky, I understand that (although buying a fresh HD down the line would be good, since the old one has seen significant non-OSX wear and tear). But if the PC boots fine but merely is sluggish and crippled, you can have her NEW MAC(!!!) network to the PC for the great file migration. Just her knowing that the files are the same and came from a computer she is familiar with could help turn the trauma into the eye-opening experience she deserves.
    I'm close to certain that OSX will be able to connect to and read the file structure of an external Firewire device without Virtual PC.
    Good luck and have fun.
    Brandon

Maybe you are looking for

  • Can't create ODBC connection in Windows Server 2012R2

    I just finished installing the instant client & odbc connection on Windows Server 2008R2. I then attempted to perform the same installation on a new Windows Server 2012R2 instance and encountered the following issue. After extracting the contents of

  • Help please! CC Desktop fails to install -- Adobe cleaner has errors...

    Migod, this CC business is more trouble than it is worth. My latest problem is that I cannot update CC Desktop. I followed the steps outlined in another post, to wit: I downloaded and ran the cleaner tool. It completed, but with errors. I tried to re

  • Is there any API to insert/update RA_TERRITORIES table

    Hi I have to create diff territory combinations for new customer creation. Is there any API for inserting records to RA_TERRITORIES table. I did n,t find any thing related to this. Thanks&Regards RS

  • ODI 10.1.3.5.0 Documentation

    Hi Experts, Could you please share where can i find documentation for ODI 10.1.3.5 I am looking for Release Notes ,New Features etc. Cheers, Andy

  • RFC sender adapter question

    Hi Experts, if we take RFC as sender adapter for communication. from PI aspect, the trigger mechanism is pull or push? in sender RFC configuration, we need to specify Application Server (Gateway), Application Server Service (Gateway), Program ID, App