VoIP good priority

Hello,
I'm looking for good solution to priority VoIP packages in routers.
We have about 10 Cisco routers, and sometimes when someone downloading files
from internet connection over VoIP telephone is slow/disconnent. Is this
solution is good to priority packages:
access-list 100 permit ip any 'IP_VOIP_SERVER'
access-list 100 permit ip 'IP_VOIP_SERVER' any
class-map test_speed
match access-group 100
policy-map test
class test_speed
set ip precedence 5
class class-default
set ip precedence 0
interface Ethernet0/0
service-policy input test
Maybe there is a better solution ? Those packages are only marked with
higher prioryty, is this part of config I should write on all my routers'???
Thanks
Pawel R.

Your packets are marked with ipp 5, but you're not really putting it in the priority queue. Class class-default has already been set at dscp 0, so there's no need to specifiy it there.
You can try something like this:
class-map match all VoIP
match ip dscp ef
class-map match-any Call-Signaling
match ip dscp cs3
policy-map test_speed
class VoIP
priority 512 **VoIP packets are placed in the priority queue( or you can use " priority percent" of T1 bandwidth if you like)
class Call-Signaling
bandwith percent 5
class class-default
fair-queue
random-detect dscp-based
Then apply the test_speed policy to the serial int, outbound (service-policy output test_speed)
Take a look at the document link from the Brandon. It contains very good explanation and examples that you can follow to create the optimum QoS for your enviroment.
HTH,
hieu

Similar Messages

  • Nokia e72 voip calls priority

    for use internet calls in my e72 i install sip voip 3.x settings...
    now i can make an internet calls...but when i search a contact writing direct on a keyboard  the preferred od is internet calls in voip.....
    were i can change this  ?????
    FaaBruno
    Solved!
    Go to Solution.

    You are right the call priority option is not where it is supposed to be on this phone, so my proposed solution above does not work but somehow I cannot edit in my post above it so here is my new solution now that I've been using the phone for a few days:
    Go to "Internet Settings" (the new Icon appearing in Control Panel after you install VoIP settings 3.x)
    Don't go to Advanced VoIP Settings in that menu, just scroll down until you find the choice corresponding to the VoIP service you're using in the list ("Gizmo VoIP settings" for example), open it
    "Default Service" should be the first choice there: set it to NO
    Although my VoIP service is always on (SIP profile settings) when I'm indoors with a WLAN at hand the phone it still uses GSM as default call service to place a call.
    Unlike with previous versions, using VoIP as default service is just not an option if you intend to use the phone outdoors : it asks for too many confirmations and ends up not making the call at all, driving you crazy if you're in a hurry !! Most professionals for whom this phone is intended are...
    As a VoIP provider I have to say I'm pleased with the flexibility/reliability/stability and more importantly the quality of this SIP client, but I just wish Nokia would make it easier for the rest of the users out there with a configurating tool for example: getting it to work right is a headache when you have so many settings (and the fact that the VoIP settings 3.x is not installed on the phone by default is ... puzzling to say the least).

  • Bandwidth for VoIP H323 signaling channels

    Hallo
    I have a VoIp application between two LANs connected by FR WAN.
    I use two cisco1751 routers as gateway.
    I would use LLQ and other QoS features on cisco gateway to prioritise VoIP streams.
    access-list 100 permit udp host 192.168.1.1 host 192.168.2.2 range 16384 32767
    access-list 101 permit tcp host 192.168.1.1 host 192.168.2.2 eq 1720
    class-map voip-media
    match access-group 100
    exit
    class-map voip-signaling
    match access-group 101
    exit
    policy-map qos-voip
    class voip-media
    priority 12 (* number of VoIP channels)
    class voip-signaling
    bandwidth XXX
    class class-default
    fair-queue
    Using g.729a codec and vad.....I would reserve 12kbps for each VoIp media channel (RTP) in the strict priority queue.
    How many bandwith must I give to VoIP signaling (RTCP, H225) for each voIp channel ?
    thankyou

    Tejas:
    I have a similar problem, I have voice over IP running over frame relay between a 7500 & a 3600 router. Doing DTS on the 7500 side. Everything works fine but when I try to use rtp compression to save some bandwith..it seems like "even though the command for rtp header-compresion are accepted on the interface configuration" Compression is actually not happening. Monitoring through EMCOM..sindle takes about 32K..i am suspecting that due to DTS on 7500 side..I am missing something....
    Is there any good url ..you can suggest me....As far as enabling rtp header compression is concerned it is very straight forward...the requirement is that ditsributed CEF be enabled globally & interface level which I am already doing...
    regards

  • Need help - Catalyst 3550 on CCM4.1 Voip

    Guys.
    We had a Catalyst 3550 switch fail last week, and the guy who really knows this system has left the company.
    The switch has a non-free molecules error, which i believe is terminal.
    I've sourced a replacement switch and need help configuring it.
    I copied the running config from it's sister switch (there are only 2 switches on this ccm), however, the sister switch is a 3560.
    I changed the I.P address and switch name before uploading it to the 3550 on the off chance it might just work.
    Show run on the 3550 shows that it might be configured, but when i connected it, it took the gateway down.
    I'm really up the creek at the moment unless i can get someone to either look at it, find an old config or get this guy back in for a few hours.
    Any advice would be greatly received.
    Looking at show run, i see two refernces to VLAN's
    interface Vlan1
     ip address 170.205.238.3 255.255.255.0
    interface Vlan10
     ip address 10.10.0.254 255.255.255.0
    ip classless
    ip route 0.0.0.0 0.0.0.0 170.205.238.1
    no ip http server
    The I.P address 170.205.238.1 is alien to me.. i don't know what this is. However, what i do know is that i never changed this. This IP address is the same in the 3560.
    Could this cause an issue ?. I'm not aware of anything on a 170.X.X.X subnet, this could have been some legacy from the previous owners of the building.
    The first 3 ports in the switch are connected to the publisher, subscriber and gateway router.
    Does it matter which port is connected to which component. ?
    I believe that i can't be too far away from configuring this, but without any help, i'm a bit stuck.
    LEE-SW-CC_VOIP-01#show run
    Building configuration...
    Current configuration : 6147 bytes
    version 12.1
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname LEE-SW-CC_VOIP-01
    enable secret 5 $1$2BRP$UtiYkRMAsp7roykkfRDo3/
    username cisco privilege 15 secret 5 $1$mh3w$w8H5ygAfDUOBdiE2UftB8.
    ip subnet-zero
    ip routing
    vtp domain LEE
    vtp mode transparent
    mls qos map cos-dscp 0 8 16 26 32 46 48 56
    mls qos
    no file verify auto
    spanning-tree mode pvst
    spanning-tree extend system-id
    vlan 10
    interface FastEthernet0/1
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/2
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/3
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/4
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/5
     switchport access vlan 10
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/6
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/7
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/8
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/9
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/10
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/11
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/12
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/13
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/14
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/15
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/16
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/17
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/18
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/19
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/20
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/21
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/22
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/23
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface FastEthernet0/24
     switchport mode access
     switchport voice vlan 10
     no ip address
     mls qos trust device cisco-phone
     mls qos trust cos
     auto qos voip cisco-phone
     spanning-tree portfast
    interface GigabitEthernet0/1
     switchport trunk encapsulation dot1q
     switchport mode trunk
     no ip address
     mls qos trust cos
     udld port aggressive
     auto qos voip trust
    interface GigabitEthernet0/2
     switchport trunk encapsulation dot1q
     switchport mode trunk
     no ip address
     mls qos trust cos
     udld port aggressive
     auto qos voip trust
     priority-queue out
    interface Vlan1
     ip address 170.205.238.3 255.255.255.0
    interface Vlan10
     ip address 10.10.0.254 255.255.255.0
    ip classless
    ip route 0.0.0.0 0.0.0.0 170.205.238.1
    no ip http server
    logging trap debugging
    line con 0
     exec-timeout 0 0
     privilege level 15
     login local
    line vty 0 4
     privilege level 15
     login local
     length 0
    line vty 5 15
     privilege level 15
     login local
     length 0
    end
    LEE-SW-CC_VOIP-01#

    Always wanting to learn more, I re-instated the test config and ran those commands.
    LEE-SW-CC_VOIP-01#show cdp neighbor
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                      S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
    Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
    LEE-SW-CC_VOIP-01#show ip int brief
    Interface                  IP-Address      OK? Method Status                Prot
    ocol
    Vlan1                      170.205.238.2   YES NVRAM  up                    down
    Vlan10                     10.10.0.254     YES NVRAM  up                    down
    FastEthernet0/1            unassigned      YES unset  down                  down
    FastEthernet0/2            unassigned      YES unset  down                  down
    FastEthernet0/3            unassigned      YES unset  down                  down
    FastEthernet0/4            unassigned      YES unset  down                  down
    FastEthernet0/5            unassigned      YES unset  down                  down
    FastEthernet0/6            unassigned      YES unset  down                  down
    FastEthernet0/7            unassigned      YES unset  down                  down
    FastEthernet0/8            unassigned      YES unset  down                  down
    FastEthernet0/9            unassigned      YES unset  down                  down
    FastEthernet0/10           unassigned      YES unset  down                  down
    FastEthernet0/11           unassigned      YES unset  down                  down
    FastEthernet0/12           unassigned      YES unset  down                  down
    FastEthernet0/13           unassigned      YES unset  down                  down
    FastEthernet0/14           unassigned      YES unset  down                  down
    FastEthernet0/15           unassigned      YES unset  down                  down
    FastEthernet0/16           unassigned      YES unset  down                  down
    FastEthernet0/17           unassigned      YES unset  down                  down
    FastEthernet0/18           unassigned      YES unset  down                  down
    FastEthernet0/19           unassigned      YES unset  down                  down
    FastEthernet0/20           unassigned      YES unset  down                  down
    FastEthernet0/21           unassigned      YES unset  down                  down
    FastEthernet0/22           unassigned      YES unset  down                  down
    FastEthernet0/23           unassigned      YES unset  down                  down
    FastEthernet0/24           unassigned      YES unset  down                  down
    GigabitEthernet0/1         unassigned      YES unset  down                  down
    GigabitEthernet0/2         unassigned      YES unset  down                  down
    LEE-SW-CC_VOIP-01#

  • Voice traffic- bandwidth

    Hi Experts..
    Pls help me in setting up QoS for my company. I have MPLS circuit for my all company locations. Main locations has 60mb MPLS circuit and branch locations has 20mb each. I have CME in my main location to which VOIP phones are registered. Since past few days i have been observing bandwith choke of my main location, due to this calling through VOIP phones from main locations to hub locations are getting drop intermediately.
    I am looking to prioritize voice traffic so that other traffic could not make impact on voip calls. I want to assign 10mb bandwith to voice traffic and rest bandwith for others traffic.
    Pls help me good way to configure this.

    Disclaimer
    The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.
    Liability Disclaimer
    In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.
    Posting
    policy-map sample
    class voip-bearer
    priority percent 33
    class voip-signaling
    bandwidth remaining 10 percent
    class class-default
    bandwidth remaining 90 percent
    fair-queue
    For above, you need to classify traffic and mark to agree with MPLS QoS support.  Percentages might also be changed to agree with MPLS QoS.
    Apply above as an out policy on MPLS egress port.

  • Implemention QOS for Voice

    Hi,
    We have a 2Mbps LL 1:4
    we are using CSICO ATA for Voice.
    we are using cisco 2620 router .
    Here are my questions.
    1.Kindly check My config and say whether this QOS config will work for prioritising the Voice.
    class-map match-all VOIP-RTP
    match ip dscp ef
    policy-map VOICE-QOS
    class VOIP-RTP
    priority 1024
    interface Serial0/0
    description ### STPI-GATEWAY-VASHI ###
    bandwidth 2048
    ip address 213.11.12.115 255.255.255.252
    ip access-group 103 in
    ip access-group 103 out
    service-policy output VOICE-QOS
    shutdown
    2.How can i filter the HTTP,TELNET,SSH,RDP,FTP traffic.
    Kindly help me.
    Thanks
    Ranga

    A more scalable config (that you dont have to redo too much) might include bandwidth guarantees for other classes of traffic as well...
    Also, I like to go with the qos design guide recommendation and set aside a queue for voice signalling... like the following...
    i also dont "match ip dscp ef" but rather just look for rtp audio... dont always have a marking switch/phone system behind your router... sometimes its a whitebox phone system sending rtp packets, and a dumb switch... I also go with a nested policy, which shapes all to the speed of the link, then decides which traffic will follow the rules of the child policy to leave the single queue ;)
    class-map match-any manage
    match protocol dhcp
    match protocol dns
    match protocol kerberos
    match protocol ldap
    match protocol snmp
    match protocol syslog
    class-map match-any bulk
    match protocol exchange
    match protocol ftp
    match protocol pop3
    match protocol smtp
    class-map match-any voicesignal
    match protocol h323
    match protocol rtcp
    class-map match-any transactional
    match protocol citrix
    match protocol pcanywhere
    match protocol secure-telnet
    match protocol sqlnet
    match protocol sqlserver
    match protocol ssh
    match protocol telnet
    match protocol tsrvrdp
    class-map match-any video
    match protocol rtp video
    match protocol cuseeme
    match protocol netshow
    match protocol rtsp
    match protocol streamwork
    match protocol vdolive
    class-map match-any voicebearer
    match protocol rtp audio
    policy-map Pol-S0/0/0.1-child
    class voicebearer
    set dscp ef
    priority percent 25
    class transactional
    bandwidth percent 25
    class voicesignal
    bandwidth percent 5
    class manage
    bandwidth percent 5
    policy-map Pol-S0/0/0.1-parent
    class class-default
    shape average 1444000
    service-policy Pol-0/0/0.1-child
    int s0/0/0.1
    service-policy output Pol-S0/0/0.1-parent
    (yes not all my classes are used in my policy; they are for future use... nice to have them in there now though, as they can always be allocated some bandwidth later on, at the expense of what is carved out now...)
    Tschuss,
    Joe

  • Making sure Qos is working?

    Hi All,
    This question has probably been asked a million times but I cannot find a solid answer. We had our routers setup by an external company and I'm not sure if they completely finished the Qos settings on the routers. How do I check?
    I am new to QoS so bear with me.
    Our setup can be seen in the diagram attached.
    The user switches are running AutoQos on each port
    interface GigabitEthernet6/0/46
    description ### CISCO VOICE & DATA PORT ###
    switchport access vlan 5
    switchport mode access
    switchport voice vlan 10
    srr-queue bandwidth share 10 10 60 20
    queue-set 2 <-- Not sure why this is set on some switches and not on others
    priority-queue out
    mls qos trust device cisco-phone
    mls qos trust cos
    auto qos voip cisco-phone
    spanning-tree portfast
    service-policy input AutoQoS-Police-CiscoPhone
    There is a global QoS config set automatically by AutoQos template.
    The Etherchannel-Trunk ports from the user switches to the Core switches and vice versa have the following commands set
    mls qos trust dscp
    priority-queue out
    Q1: What Qos settings need to be added to the core switch? I have no phones are attached to it.
    Currently we have the following global Qos values set
    mls qos
    mls qos map cos-dscp 0 8 16 24 32 46 48 56
    Q2: What Qos settings need to be added to the router subinterface ports and global configs.
    mls qos is not set globally but there are a bunch of policy-maps and class-maps?
    Subinterface ports
    interface GigabitEthernet0/0.10
    description ### VOICE VLAN INTERFACE ###
    encapsulation dot1Q 10
    ip address 192.168.10.254 255.255.255.0
    Interface 0/1 to Private network (class-maps and policy maps)
    class-map match-all AllTraffic
    match any
    class-map match-any JTAPI
    match access-group 110
    class-map match-any voip-sig
    match access-group name voip-signal
    match ip dscp af31
    match ip dscp cs3
    class-map match-any voip-rtp
    match ip rtp 16384 16383
    match ip dscp ef
    policy-map llq-voip
    class voip-rtp
      priority 256
    class voip-sig
      bandwidth 16
    class JTAPI
      set dscp cs3
      bandwidth 20
    class class-default
      fair-queue
      random-detect dscp-based
    policy-map shape-wan
    class AllTraffic
      shape average 50000000
      service-policy llq-voip
    policy-map mark-all
    class voip-rtp
      set dscp ef
    class voip-sig
      set dscp cs3
    class class-default
      set dscp default
    ip access-list extended voip-signal
    permit tcp any any eq 1720
    permit tcp any eq 1720 any
    permit tcp any any eq 2000
    permit tcp any eq 2000 any
    permit tcp any any range 11000 11999
    permit tcp any range 11000 11999 any
    permit tcp any any eq 2748
    permit tcp any eq 2748 any
    permit tcp any any eq 8404
    permit tcp any eq 8404 any
    permit tcp any any eq 42027
    permit tcp any eq 42027 any
    permit tcp any any range 59000 59025
    permit tcp any range 59000 59025 any
    interface GigabitEthernet0/1
    description ### Private Network ###
    ip address 192.168.255.2 255.255.255.252
    duplex full
    speed 100
    service-policy input mark-all
    service-policy output shape-wan
    Still looking into what all these values mean.
    Regards

    show policy-map interface GigabitEthernet6/0/46 (This is off the Melbourne 3750G-USER01 switch)
    GigabitEthernet6/0/46
      Service-policy input: AUTOQOS-SRND4-CISCOPHONE-POLICY
        Class-map: AUTOQOS_VOIP_DATA_CLASS (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp ef (46)
        Class-map: AUTOQOS_VOIP_SIGNAL_CLASS (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: ip dscp cs3 (24)
        Class-map: AUTOQOS_DEFAULT_CLASS (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group name AUTOQOS-ACL-DEFAULT
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
            0 packets, 0 bytes
            5 minute rate 0 bps
    show policy-map int GigabitEthernet0/1 (Off the Melbourne 2800 Router )
    GigabitEthernet0/1
      Service-policy input: mark-all
        Class-map: voip-rtp (match-any)
          422882260 packets, 73717373837 bytes
          5 minute offered rate 117000 bps, drop rate 0 bps
          Match: ip rtp 16384 16383
            422145770 packets, 73561857794 bytes
            5 minute rate 114000 bps
          Match: ip dscp ef (46)
            736511 packets, 155520147 bytes
            5 minute rate 2000 bps
          QoS Set
            dscp ef
              Packets marked 422882281
        Class-map: voip-sig (match-any)
          400358097 packets, 44842004330 bytes
          5 minute offered rate 31000 bps, drop rate 0 bps
          Match: access-group name voip-signal
            396250102 packets, 44527028287 bytes
            5 minute rate 31000 bps
          Match: ip dscp af31 (26)
            2787234 packets, 234418763 bytes
            5 minute rate 0 bps
          Match: ip dscp cs3 (24)
            1320764 packets, 80557256 bytes
            5 minute rate 0 bps
          QoS Set
            dscp cs3
              Packets marked 400358262
        Class-map: class-default (match-any)
          18847301096 packets, 13836330525020 bytes
          5 minute offered rate 16131000 bps, drop rate 0 bps
          Match: any
          QoS Set
            dscp default
              Packets marked 18847294088
      Service-policy output: shape-wan
        Class-map: AllTraffic (match-all)
          18031038728 packets, 11420761193505 bytes
          5 minute offered rate 12704000 bps, drop rate 0 bps
          Match: any
          Traffic Shaping
               Target/Average   Byte   Sustain   Excess    Interval  Increment
                 Rate           Limit  bits/int  bits/int  (ms)      (bytes)
             50000000/50000000  312500 1250000   1250000   25        156250
            Adapt  Queue     Packets   Bytes     Packets   Bytes     Shaping
            Active Depth                         Delayed   Delayed   Active
            -      0         850797478 4183363168 170360913 3101776193 no
          Service-policy : llq-voip
            Class-map: voip-rtp (match-any)
              341581698 packets, 27282557780 bytes
              5 minute offered rate 56000 bps, drop rate 0 bps
              Match: ip rtp 16384 16383
                341574850 packets, 27281749554 bytes
                5 minute rate 56000 bps
              Match: ip dscp ef (46)
                6851 packets, 808418 bytes
                5 minute rate 0 bps
              Queueing
                Strict Priority
                Output Queue: Conversation 264
                Bandwidth 256 (kbps) Burst 6400 (Bytes)
                (pkts matched/bytes matched) 2940781/225999928
                (total drops/bytes drops) 537/661802
            Class-map: voip-sig (match-any)
              247531259 packets, 23679757170 bytes
              5 minute offered rate 82000 bps, drop rate 0 bps
              Match: access-group name voip-signal
                247480960 packets, 23672100642 bytes
                5 minute rate 82000 bps
              Match: ip dscp af31 (26)
                49905 packets, 7602622 bytes
                5 minute rate 0 bps
              Match: ip dscp cs3 (24)
                401 packets, 54278 bytes
                5 minute rate 0 bps
              Queueing
                Output Queue: Conversation 265
                Bandwidth 16 (kbps) Max Threshold 64 (packets)
                (pkts matched/bytes matched) 779747/105298466
            (depth/total drops/no-buffer drops) 0/765/0
            Class-map: JTAPI (match-any)
              0 packets, 0 bytes
              5 minute offered rate 0 bps, drop rate 0 bps
              Match: access-group 110
                0 packets, 0 bytes
                5 minute rate 0 bps
              QoS Set
                dscp cs3
                  Packets marked 0
              Queueing
                Output Queue: Conversation 266
                Bandwidth 20 (kbps) Max Threshold 64 (packets)
                (pkts matched/bytes matched) 0/0
            (depth/total drops/no-buffer drops) 0/0/0
            Class-map: class-default (match-any)
              17441925990 packets, 11369798942000 bytes
              5 minute offered rate 12554000 bps, drop rate 0 bps
              Match: any
              Queueing
                Flow Based Fair Queueing
                Maximum Number of Hashed Queues 256
            (total queued/total drops/no-buffer drops) 0/380841/0
                 exponential weight: 9
       dscp    Transmitted      Random drop      Tail drop    Minimum Maximum  Mark
               pkts/bytes       pkts/bytes       pkts/bytes    thresh  thresh  prob
       af11       0/0               0/0              0/0           32      40  1/10
       af12       0/0               0/0              0/0           28      40  1/10
       af13       0/0               0/0              0/0           24      40  1/10
       af21       0/0               0/0              0/0           32      40  1/10
       af22       0/0               0/0              0/0           28      40  1/10
       af23       0/0               0/0              0/0           24      40  1/10
       af31       0/0               0/0              0/0           32      40  1/10
       af32       0/0               0/0              0/0           28      40  1/10
       af33       0/0               0/0              0/0           24      40  1/10
       af41       0/0               0/0              0/0           32      40  1/10
       af42       0/0               0/0              0/0           28      40  1/10
       af43       0/0               0/0              0/0           24      40  1/10
        cs1 13779821/19479353285      2/2948           0/0           22      40  1/10
        cs2       0/0               0/0              0/0           24      40  1/10
        cs3       0/0               0/0              0/0           26      40  1/10
        cs4       0/0               0/0              0/0           28      40  1/10
        cs5       0/0               0/0              0/0           30      40  1/10
        cs6 1460106/221012238       0/0              0/0           32      40  1/10
        cs7       0/0               0/0              0/0           34      40  1/10
         ef       0/0               0/0              0/0           36      40  1/10
       rsvp       0/0               0/0              0/0           36      40  1/10
    default 246455719/11349551197230 257261/380315020 123578/179057908   20      40  1/10
        Class-map: class-default (match-any)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
    Hope this helps?
    Do I need any class-maps policy-maps set on the Melbourne 3750X-CORE and 3750X switches.
    * I am looking at basic Qos rules Voip packets take priority ... leave all other data packets untouched.
    Thanks for having a look. Cheers

  • Need help with configuring QoS

    Hello,
    We are in the process of implementing MPLS for our WAN links so that we can run VoIP between 9 locations in the USA and I have lots of questions regarding how to configure QoS.
    We have a dedicated E1 connection to our headquarters in Germany. This location houses all of our SAP servers.
    In each location in the US, we will be using Avaya IP telephones and media gateways for voice communications. We also have some Polycom units in the field for video confererncing.
    How would I begin to configure QoS for these network connections.
    I was planning on using IP precedence or DSCP for marking the traffic and prioritizing as follows.
    Highest Priority: Voice and video
    2nd Highest: SAP and Oracle traffic
    Default priority: Lotus notes, www access
    Here are some questions that I have:
    1- For voice/video, which DSCP values or IP precedence values do I use?
    2- How do I assign voice/video to the LLQ queue?
    3- For SAP, what is the best way to mark the SAP traffic? From my understanding, SAP uses a variety of ports.
    4- For SAP and Oracle, should I use the CBWFQ queus? Is that preferable over other queues for this traffic?
    5- Should I make another classification of traffic for things like signaling for Voice and TFTP/FTP?
    6- If so for #5, what IP precedence/DSCP value(s) should I use and which queuing mechanism should I use?
    Thanks for the help in advance. At this point, you can probably tell that I am a newbie to QoS.
    Pete

    I can answer a few since i have a ton of avaya ip phones deployed.
    1)personally i leave both bearer and signaling in same queue at 46 (Diffserv) and 5 (COS) Video would be 40/4.
    2)sample config:
    class-map match-all voip-fr
    match ip dscp 46 (all traffic that have DSCP 46)
    class-map match-all vovid-fr
    match ip dscp 40(all traffic that have DSCP 40)
    policy-map llq
    class voip-fr
    priority 100 (Reserve 100Kbps priority bw for DSCP 46)
    class vovid-fr
    bandwidth 300 (Reserve 300Kbps non-priority bw for DSCP 40)
    class class-default
    fair-queue
    Serial Interface 0/0
    service-policy output llq (Apply policy map to voice and signaling
    traffic)
    5) nope. leave tftp and data in the default queue
    Also, since you are deploying Avaya IPT make sure you look at this document. great document i used.
    http://support.avaya.com/elmodocs2/comm_mgr/r3_1/pdfs/245600_4_2.pdf

  • QoS on engine 0 LC

    Hi,
    We applied "tx-cos" command (MDRR) on our GSR's Engine 0 DS3 Line Card. I would like to know the command which will show the statistics output of this command (similar to the one when we apply policy map command).. Is there any specific command to view the statistics?
    thanks in advance

    Someone will have to correct me if I am wrong but CBWFQ is not supported on Virtual interfaces like Dialers, - basically it tries to apply hardware queueing on a virtual interface. You can use nested policy-maps though. Here is an example of what I had to do for a connection that the provider had given me where 6 megs where for internet and 14 megs were for MPLS connection and in order to apply QoS to a sub-interface I used nested policy map but it will be the same concept for Dialers I believe.
    class-map match-any VoIP-Control
    match ip dscp cs3
    match ip dscp af31
    class-map match-any VoIP-RTP
    match ip dscp ef
    policy-map WAN-EDGE
    class VoIP-RTP
    priority 768
    class VoIP-Control
    bandwidth percent 5
    class class-default
    fair-queue
    policy-map MPLS-14Meg
    class class-default
    shape average 14000000
    service-policy WAN-EDGE
    policy-map Internet-6Meg
    class class-default
    shape average 6000000
    interface Serial1/0
    description WAN/MPLS
    bandwidth 20000
    interface Serial1/0.1 point-to-point
    bandwidth 14000
    service-policy output MPLS-14Meg
    interface Serial1/0.2 point-to-point
    bandwidth 6000
    service-policy output Internet-6Meg

  • UC320w Call drop off after 15:04

    Hi All,
    So we have had this VoIP setup now for about 5/6 months, and recently we have started to use BT meet me conferencing service, on every call to them the line drops after 15 minutes and 4 seconds.
    We do not have this issue on any other call.
    Have spoken to our sip provider they can’t ID any issues and have also spoken to the BT Meet me team and they have no idea.
    Our UC320 and spa504G phones are isolated to our data network but both go through a Meraki MX60 for usage monitoring, Voip has priority.

    Hi James,
    I would suggest opening a support call with Cisco Small Business Support.  The support team can obtain syslog messages of the BT Meet me call and determine what side is disconnecting the call at the 15min 4 sec time frame.  Then it can be determined if the BT Meet me service is dropping the call or not.
    Regards,
    Randy

  • Announcing DataGuard My Oracle Support Community

    The My Oracle Support Community which covers all support related questions on High Availability -> DataGuard is available under: https://communities.oracle.com/portal/server.pt/community/high_availability_data_guard/302
    Have you ever visited the Community to exchange, learn, share and get answers to your support related questions? This My Oracle Support Community is a vibrant forum for Oracle customers, partners and employees to share knowledge, discover best practices and ask questions. We encourage you to use these communities for all your support related topics.
    Generally with over 427,000 members and 227 communities dedicated to product and industry-specific topics, the My Oracle Support Community encompasses a huge range of technologies, applications, and business processes—including 30 focused communities for Oracle Database, 6 for Enterprise Manager, 4 for Engineered Systems etc.
    Join a community of peers with real-world experience using Oracle products, and Oracle support engineers who moderate and contribute to discussions, for unparalleled access to deep and practical expertise. With My Oracle Support Community, you’ll get faster, real-time access to information about Oracle technologies to help you improve your operational efficiency and reduce downtime.
    An existing support contract is required for this service.
    If you have not used the My Oracle Support Communities before, please watch this brief (2 minute) video to help you quickly understand the benefits available to you.
    http://bcove.me/rvjqwdn5
    Regards,
    Carmelo Amoroso
    (Snr Manager High Availability Produts for Global Customer Support)

    to use MyOracleSupport Communities you need to be part of an organization that gives you access to the the Support with a CSI - That is correct!Got it.
    On the other side, working on this other Community will give you the opportunity to integrate the threads with all the contents available from Oracle Support.Even its good point, where we can look up into different communities.
    By the way, I would like to clarify that the Community I'm advertising here is NOT replacing this OTN forum.
    As you said, I just wanted to take the chance to advertise it in the interest of every customer who can access it.
    Hope this helps.Thank you, But you know? still i like to give some good priority to OTN, why because. People who are learning and trying to explore their knowledge and who do not have CSI, where they can contact? they are really helpless. & Support community people all have CSI activiated they can raise SR any time.
    Of course you are not asking to leave OTN, its just one of my point why i prefer OTN. but for sure will see threads from Community as well.

  • Snow and setting priority for voip voice packets?

    I have an engine Voice Box 2 connected to my dual ethernet base station, for voip phone calls using a 1500kbps broadband connection. It all works fine, except sometimes the voice quality of phone calls isn't good - drop-outs occur. Engin support tells me there is a way to configure an airport BS to give priority to voice packet data over other internet data data, and this will improve the voice quality.
    Is this possible with a snow BS, and if so how do I do it?

    OK, Duane and anyone else. My question has been answered via telephone from Apple Australia, on Thursday 22 Feb 2007 at local time 9.01 pm. The answer is: There is no way that any version of an Airport BS can be set to prioritize voip voice packets over other internet packets of data.
    Apple Supporters in other countries may disagree (not a surprise). I've been a Mac user since the first 1984 64K Mac, and I've not been too impressed with Apple phone service during the last 20+ years, so if another Apple tech elsewhere comes up with a different answer I would not be at all surprised.
    So, first premise is my voip provider gave me incorrect info. Second one is maybe someone else gave them the incorrect info. One guess and no prizes as to whom this may have been.
    Bigger surprise is that Apple seems oblivious to how popular voip phone is going to be in the immediate future, and that Mac users are likely to receive inferior quality voice quality and have no way to improve this by tweaking their Airports.

  • Is QoS tools shape good for VoIP?

    Hi,
    I have MPLS VPN scenario. For MPLS VPN at PE router connecting to hub, I've configured below QoS:
    class-map match-any P1
    match ip dscp ef
    class-map match-any P3
    match ip dscp default
    class-map match-any P2
    match ip dscp af31
    policy-map QoS
    class P1
    priority percent 35
    class P2
    bandwidth percent 40
    random-detect
    class P3
    bandwidth percent 25
    random-detect
    Since on the egree PE towords the internet, I'm using subinterface thus, the configuration is:
    policy-map cust-qos
    class class-default
    shape average 256000
    service-policy output QoS
    interface FastEthernet1/0.8
    encapsulation dot1q 8
    ip address ...
    service-policy output cust-qos
    Since the internet access is 256K, I've configured shape average 256000.
    My problem is that, during high congestion at internet access, I noticed that on cust-hub my VoIP SIP is having problem to ring to another VoIP SIP within the same hub. Is it because of the shape command ?
    thanks in advanced

    Hi Maher,
    shape average 256000 is to much. The point is, that you have OSI layer2 overhead and layer2 keepalives and such. Lower it to f.e. 240000. You might need to "play" a little with the parameter, as the overhaed depends on average packet size.
    Also make sure, that your SIP traffic is marked with af31. Just as a note: Cisco changed from marking voip signaling with af31 to cs3. Take a sniffer and check that proper markings are in place for voip signaling. Or just try
    class-map match-any P2
    match ip dscp af31 cs3
    Hope this helps! Please rate all posts.
    Regards, Martin

  • How to  make a good voip server +applet ?

    Here is my applet wich I made http://84.244.8.225/test.html
    It works a bit
    Here the code:
    http://84.244.8.225/javamic4.txt
    Any ideas/suggestions to make it better...
    (for example how to make a good server (windows) ?)
    Thx!
    Edited by: FrederikPot on Sep 24, 2007 3:01 PM
    Edited by: FrederikPot on Sep 24, 2007 3:03 PM
    Edited by: FrederikPot on Sep 24, 2007 3:07 PM

    Hello Thanks for your replys and sorry for being so fussy about this.
    I have now seen that one of the options for exporting from Premiere 6.5 is Adobe MPEG encoder. So Do you guys think it would be a good idea to do it with that, Or Would it be better AVI or DV AVI compressor from Premiere before making the DVD?
    I have the Nero Vision 4.9.6.6  But I may be able to look for another one if you think it is better...
    Thanks a lot for your advises...

  • ASA5505 - Qos / Priority / Traffic Shaping - VOIP/SIP

    I have a client using a VOIP service to a third party provider (RingCentral). They are connected via Cable ISP (6mb) to the Internet and now experiencing performance issues with their VOIP service. They indicated that the call can be heard but that there is jitter and choppines in the call and they have to place a regular landline call. Their provider recoomended using QOS to help improve. I did not see anything straight forward on the ASDM interface to do this and figure it may require command line to accomplish.
    They have Cisco IP 303 and 5252G2 phones which connect through an ASA5505 7.2(4) to their provider for service. Apparently the voip app uses the following ports:
    UDP
    5060-5090
    8000-8200
    16384-16482
    What would be the best solution to improve performance or perhaps traffic shape / priortize traffic to help. I assume this may be happening if there are heavy downloads or activity happening on the network. The ASA5505 is on 7.2(4). I'd appreciate if someone could provide some coded examples for the above info.
    Much appreciated!

    Hi Vito,
    You can prioritize your voice traffic over data traffic, refer to this doc for prioritization:
    http://www.cisco.com/en/US/products/hw/vpndevc/ps2030/products_tech_note09186a008084de0c.shtml#Pqu
    Hope that helps
    Thanks,
    Varun

Maybe you are looking for