What is the wrong in this PL/SQL  block

Hi a...
Can you please tell what is the wrong in this pl/sql block.
declare
TYPE TYP_NT_NUM IS TABLE OF NUMBER ;
v_tab TYP_NT_NUM := TYP_NT_NUM();
TYPE uname is VARRAY(30) of varchar2(100) ;
usr uname := uname ( 'u1','u2','u3','u4' );
TYPE pwd is VARRAY(30) of varchar2(100) ;
psw pwd := pwd('p1','p2','p3','p4');
x number(10):=0;
Cursor fcid IS Select distinct FC_ID From FCMASTER ;
Begin
Open fcid ;
--for ii in usr.first .. usr.last loop
     Loop
          Fetch fcid Into x ;
          Exit When fcid%NOTFOUND ;
          v_tab(fcid%ROWCOUNT) := x ;
     End loop ;
     For iii IN v_tab.FIRST .. v_tab.LAST Loop
          dbms_output.put_line(v_tab(iii).FC_ID) ;
          End loop ;
End loop; End of outer loop
End;
The error is
Error
[row:28,col:36] ORA-06550: line 28, column 36:
PLS-00487: Invalid reference to variable 'NUMBER'
ORA-06550: line 28, column 4:
PL/SQL: Statement ignored
Thanks in advance,
Pal

v_tab(iii).FC_ID
declare
  type typ_nt_num is table of number;
  v_tab typ_nt_num;
begin
  select distinct object_id bulk collect into v_tab from all_objects where rownum <= 10;
  for i in 1 .. v_tab.count loop
    dbms_output.put_line(v_tab(i)) ;
  end loop ;
end;
/

Similar Messages

  • What is wrong with this PL/SQL block

    declare
    v_count integer := 0;
    begin
    -- execute immediate 'select count(1) into v_count from ' || 'abc' || '.table1';
    execute immediate 'select count(1) into v_count from abc.table1';
    dbms_output.put_line('v_count: ' || v_count);
    end;
    When i execute the above pl/sql block, I get the following error:
    ORA-00905: missing keyword
    ORA-06512: at line 6
    What am I doing wrong?
    When I use SELECT COUNT(1) INTO v_count FROM abc.table1; ( instead of the dynamic sql ), it works.
    I realize I don't need to use execute immediate for SELECT, but I need to do the dynamic SQL because the table1 will be under multiple schemas.
    Would appreciate an explanation for the above error, and/or alternate solution(s) for dynamic sql.
    Thanks

    DECLARE
      v_count INTEGER := 0;
    BEGIN
      -- execute immediate 'select count(1) into v_count from ' || 'abc' || '.table1';
      EXECUTE IMMEDIATE 'select count(1)  from abc.table1' into v_count;
      dbms_output.put_line('v_count: ' || v_count);
    END;TEST
    DECLARE
      v_count INTEGER := 0;
    BEGIN
      -- execute immediate 'select count(1) into v_count from ' || 'abc' || '.table1';
      EXECUTE IMMEDIATE 'select count(1) from dual ' into v_count;
      dbms_output.put_line('v_count: ' || v_count);
    END;
    v_count: 1
    PL/SQL procedure successfully completed.HTH
    SS

  • What is the wrong in this utl_file

    declare
         f utl_file.file_type;
         --v_str varchar2(32000);
         TYPE TAB_COL IS TABLE OF VARCHAR2(30);
         V_TAB_COL TAB_COL;
         FILE_NAME VARCHAR2(32000);
         V_LEN NUMBER;
         V_TOT_SIZE VARCHAR2(32000);
         V_TOT_SIZE1 VARCHAR2(32000);
         V_TOT_SIZE2 VARCHAR2(32000);
    SQL_STR VARCHAR2(32000);
         lv_loop_counter NUMBER;
    begin
    select COLUMN_NAME BULK COLLECT INTO V_TAB_COL FROM ALL_TAB_COLUMNS WHERE
         TABLE_NAME='CN_SMSC' AND OWNER='TEST';
         FOR I IN V_TAB_COL.FIRST..V_TAB_COL.LAST
    LOOP
              FILE_NAME:=FILE_NAME||','||V_TAB_COL(I);
    --DBMS_OUTPUT.PUT_LINE(FILE_NAME);
    /*lv_loop_counter := 1;
    WHILE (lv_loop_counter < LENGTH(FILE_NAME ))
    LOOP
    DBMS_OUTPUT.PUT_LINE(SUBSTR(FILE_NAME ,lv_loop_counter,255));
    -- DBMS_OUTPUT.PUT_LINE(FILE_NAME);
    lv_loop_counter:= lv_loop_counter + 255;
    END LOOP; */
    END LOOP;
         SELECT LENGTH(FILE_NAME) INTO V_LEN FROM DUAL;
         SELECT SUBSTR(FILE_NAME,2,V_LEN) INTO V_TOT_SIZE FROM DUAL;
         SELECT REPLACE(V_TOT_SIZE,',',',S.') INTO V_TOT_SIZE1 FROM DUAL;
         V_TOT_SIZE2:='S.'||V_TOT_SIZE1;
    SQL_STR:=' DECLARE      f utl_file.file_type; BEGIN
    f := utl_file.fopen('||'''E:\NETWORK_ELEMENT_ID_KEY'''||','||'''A.txt'''||','||'''W'''||');
    for s in (select '||V_TOT_SIZE ||' from cn_smsc)
    loop
    --V_TOT_SIZE2 holds list of column name like s.col_name1,s.col_name2
    utl_file.put_line(f, '||V_TOT_SIZE2 ||' );
    end loop;
         utl_file.fclose(f);
    END;';
    lv_loop_counter := 1;
    WHILE (lv_loop_counter < LENGTH(SQL_STR ))
    LOOP
    DBMS_OUTPUT.PUT_LINE(SUBSTR(SQL_STR ,lv_loop_counter,255));
    lv_loop_counter:= lv_loop_counter + 255;
    END LOOP;
    -- DBMS_OUTPUT.PUT_LINE(SQL_STR);
    EXECUTE IMMEDIATE SQL_STR;
    end;
    it return :
    ORA-06550: line 6, column 9:
    PLS-00306: wrong number or types of arguments in call to 'PUT_LINE'
    ORA-06550: line 6, column 9:
    PL/SQL: Statement ignored
    ORA-06512: at line 57
    n.b: i want to make it dynamic

    You call utl_file.put_line with a list of fields as separate parameters, that is obviously wrong. Consider to have a look on your generated sql (uncomment dbms_output call at the bottom of your block) and compare with utl_file package specification .
    Best regards
    Maxim

  • What is the wrong in this code

    *& Report  ZTESTTEST
    REPORT  ztesttest LINE-SIZE 256.
    TYPE-POOLS: slis.
    FIELD-SYMBOLS: <dyn_table> TYPE STANDARD TABLE ,
                   <dyn_wa>,
                   <dyn_field>.
    FIELD-SYMBOLS: <dyn_table1> TYPE STANDARD TABLE ,
                   <dyn_wa1>,
                   <dyn_field1>.
    DATA: alv_fldcat TYPE slis_t_fieldcat_alv,
          it_fldcat TYPE lvc_t_fcat.
    TYPE-POOLS : abap.
    DATA : it_details TYPE abap_compdescr_tab,
           wa_details TYPE abap_compdescr.
    DATA :itab TYPE abap_component_tab.
    *       CLASS cl_my_structure  DEFENITION
    CLASS cl_my_structure DEFINITION.
      PUBLIC  SECTION.
        METHODS: x.
      PROTECTED SECTION.
      PRIVATE SECTION.
    ENDCLASS.                    "cl_my_structure  DEFENITION
    *       CLASS cl_my_structure IMPLEMENTATION
    CLASS cl_my_structure IMPLEMENTATION.
      METHOD x.
        WRITE 'HI'.
      ENDMETHOD.                    "x
    ENDCLASS.                    "cl_my_structure IMPLEMENTATION
    DATA : ref_descr TYPE REF TO cl_abap_structdescr.
    DATA: new_table TYPE REF TO data,
          new_line  TYPE REF TO data,
          wa_it_fldcat TYPE lvc_s_fcat.
    SELECTION-SCREEN BEGIN OF BLOCK b1 WITH FRAME TITLE text .
    PARAMETERS: p_table(30) TYPE c DEFAULT 'T001'.
    SELECTION-SCREEN END OF BLOCK b1.
    * Get the structure of the table.
    ref_descr ?= cl_abap_typedescr=>describe_by_name( p_table ).

    That depends on what you want it to do.  Do you want it to write "Hi"?  If so...
    report  ztesttest line-size 256.
    *type-pools: slis.
    *field-symbols: <dyn_table> type standard table ,
    *               <dyn_wa>,
    *               <dyn_field>.
    *field-symbols: <dyn_table1> type standard table ,
    *               <dyn_wa1>,
    *               <dyn_field1>.
    *data: alv_fldcat type slis_t_fieldcat_alv,
    *      it_fldcat type lvc_t_fcat.
    *type-pools : abap.
    *data : it_details type abap_compdescr_tab,
    *       wa_details type abap_compdescr.
    *data :itab type abap_component_tab.
    *       CLASS cl_my_structure  DEFENITION
    class cl_my_structure definition.
      public  section.
        methods: x.
      protected section.
      private section.
    endclass.                    "cl_my_structure  DEFENITION
    *       CLASS cl_my_structure IMPLEMENTATION
    class cl_my_structure implementation.
      method x.
        write 'HI'.
      endmethod.                    "x
    endclass.                    "cl_my_structure IMPLEMENTATION
    *data : ref_descr type ref to cl_abap_structdescr.
    *data: new_table type ref to data,
    *      new_line  type ref to data,
    *      wa_it_fldcat type lvc_s_fcat.
    data: o_ref type ref to cl_my_structure.
    selection-screen begin of block b1 with frame title text .
    parameters: p_table(30) type c default 'T001'.
    selection-screen end of block b1.
    start-of-selection.    "<--  YES, YOU NEED THIS.
    create object o_ref .
    call method o_ref->x.
    * Get the structure of the table.
    *ref_descr ?= cl_abap_typedescr=>describe_by_name( p_table ).
    Regards,
    RIch Heilman

  • What is the wrong with this small code of groupitems

    var msg =""
    if(app.documents.length > 0)
    var pgItems = app.activeDocument.pageItems;
    tot_obj=pgItems.length ;
    if( pgItems.length > 0 )
      var GroupItem =app.activeDocument.groupItems;
      total_Group = GroupItem.length;
       for(var a = 0;a<total_Group;a++)
        GroupItem[a].hidden=true;

    Use this code :
    app.activeDocument.groupItems[a].hidden=true;

  • What is the wrong with my select query

    HI All,
    TYPES: BEGIN OF t_equi,
             equnr          TYPE equi-equnr,
             aedat          TYPE equi-aedat,
             matnr          TYPE equi-matnr,
             sernr          TYPE equi-sernr,
             kunde          TYPE equi-kunde,
             zzreg_date     TYPE equi-zzreg_date,
             zzin_indic     TYPE equi-zzin_indic,
             zzinvoice_num  TYPE equi-zzinvoice_num,
             zzinvoice_date TYPE equi-zzinvoice_date,
             kund1          TYPE equz-kund1,
          END OF t_equi,
    DATA: it_equi        TYPE TABLE OF t_equi,
      SELECT equnr
             aedat
             matnr
             sernr
             kunde          "Ship to
             zzreg_date
             zzin_indic
             zzinvoice_num
             zzinvoice_date
             kund1            "Sold to
             INTO TABLE it_equi
             FROM equi AS a
             INNER JOIN equz AS b
             ON a~equnr = b~equnr
             WHERE a~equnr      IN s_equnr AND
    *               aedat GE gv_rdate AND
                   a~matnr      IN s_matnr AND
                   a~sernr      IN s_sernr AND
                   a~kunde      IN r_shpbr_kunde AND
                   a~zzin_indic IN s_indic  AND
                   b~datbi      EQ c_datbi  AND 
                   b~kund1     IN r_sldbr_kund1 .
    what is the wrong with this select query.. ?
    its giving me error  "The column name "EQUNR" is unclear ."
    Thanks

    Hi ,
    write  tablename or alias in select also
    SELECT a~equnr and check.
    Regards

  • What does the PopUp "Prevent this page from creating additional dialogs" really mean and if I check the Box, how do I undo this if this was the Wrong Thing To Do?

    What does the PopUp "Prevent this page from creating additional dialogs" really mean and if I check the Box, how do I undo this if this was the Wrong Thing To Do?
    Details
    Constantly, while using Firefox (Beta v 11.0), and/or ESPECIALLY, when I have my eMail @ Mail.com open, I get this PopUp stating: "For security reasons, restarting mail.com Mail is possible only via the mail.com Mail Service. Please close this window and restart mail.com Mail" BUT Then there is a CHECKBOX: "Prevent this page from creating additional dialogs."
    I have no idea if Checking this Box is a Good Idea or if it will Screw-Up my mail.com Mail Service...
    Anyone have an answer or explanation of the Use of this Little Check-Box?
    BJ Orden [email protected]

    You do not get any pop-up windows on that website if you tick that box.
    That setting is stored in the cache and you should see pop-ups again if you reload the page and bypass the cache.
    Reload web page(s) and bypass the cache.
    *Press and hold Shift and left-click the Reload button.
    *Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
    *Press "Cmd + Shift + R" (MAC)

  • What is going wrong with this config ??

    Hello guys,
    I am busting my head to find out what is going wrong with this config and cant figure it out since i am not an advanced cisco technician.
    Problem is that i cant access the 94.70.142.127 server that is supposed to be in a DMZ zone.
    I know it is a bit chaotic but would really appreciate any help since i am running on a deadline.
    I am building the config step by step and although it seems to be working access to the server all of the sudden is denied.
    No idea if its a NAT issue a firewall issue or a security audit issue.
    There are 3 vlans.
    Vlan 1 is the inside network.
    Vlan 2 is the DMZ server
    Vlan 3 is the Management Network.
    thanks in advance
    Building configuration...
    Current configuration : 11796 bytes
    ! Last configuration change at 11:28:33 PCTime Fri Jan 4 2013 by admin
    ! NVRAM config last updated at 11:27:51 PCTime Fri Jan 4 2013 by admin
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime
    service password-encryption
    service sequence-numbers
    hostname R1
    boot-start-marker
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 8
    logging message-counter syslog
    logging buffered 4096 informational
    enable secret 5 $1$oT7y$BwhdEjMJfAaTQI3dzDVwP.
    no aaa new-model
    memory-size iomem 10
    clock timezone PCTime 2
    clock summer-time PCTime date Mar 30 2003 3:00 Oct 26 2003 4:00
    crypto pki trustpoint TP-self-signed-2567543707
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-2567543707
    revocation-check none
    rsakeypair TP-self-signed-2567543707
    crypto pki certificate chain TP-self-signed-2567543707
    certificate self-signed 01
      30820244 308201AD A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 32353637 35343337 3037301E 170D3133 30313032 30383431
      35335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 35363735
      34333730 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100ABA4 B7FFF4F1 9FBE79D8 2CEBCA68 A14BE3AB DBF770C2 EB35A954 B271AE3E
      F8485837 F2E8566B 66E5EF6B BCFCDFA3 8F6F91F3 FD8E3015 879A67F5 85DD95F5
      C26875C0 2202CA6C CE95888F 545AB4F6 6F708A0E C65E78D1 60967480 5589F5EE
      80505E46 8767CE2C 37C994FE AB555AF0 BA4C4679 63FF7641 34FFF6EF 3EC38006
      46B90203 010001A3 6C306A30 0F060355 1D130101 FF040530 030101FF 30170603
      551D1104 10300E82 0C52312E 646F636E 65742E67 72301F06 03551D23 04183016
      8014F0DE 85318FB3 70C36B4A FEB4B0CA 446025F0 329C301D 0603551D 0E041604
      14F0DE85 318FB370 C36B4AFE B4B0CA44 6025F032 9C300D06 092A8648 86F70D01
      01040500 03818100 5D76D5F4 5FB659C3 1E5B3777 420E1703 CD019889 AE79390D
      A2AA4D26 AD9913B4 B3292277 97ACACDD D7093465 78279B4D 5FAC0A21 EFBF3B74
      6A25BC5B ACFB648F 08F92678 00BB495C 037DEAF7 C5910944 3D2C0643 EA19E9BD
      0AFE5423 AADBB3C2 B2C94296 DABE0D3D 6438F7A8 32B0A92B 3E8E0D26 635070A3
      ACF87E49 65A9E468
          quit
    no ip source-route
    ip cef
    no ip bootp server
    ip domain name docnet.gr
    ip name-server 195.170.0.1
    no ipv6 cef
    username admin privilege 15 view root secret 5 $1$Lny5$et1FhWOpIKOOYRUtN89H10
    archive
    log config
      hidekeys
    ip tcp synwait-time 10
    ip ssh version 2
    class-map type inspect match-any WebService
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls-sdm-pol-NATOutsideToInside-1-1
    match class-map WebService
    match access-group name WebServer
    class-map type inspect match-all ccp-cls-sdm-pol-NATOutsideToInside-1-1
    match access-group name Spoofing
    class-map type inspect match-any CCP-Voice-permit
    match protocol h323
    match protocol skinny
    match protocol sip
    class-map type inspect match-any tcp-udp
    match protocol http
    match protocol https
    match protocol dns
    match protocol icmp
    class-map type inspect match-all ccp-cls--3
    match access-group name mng-out
    match class-map tcp-udp
    class-map type inspect match-all ccp-cls--2
    match access-group name mng-self
    class-map type inspect match-all ccp-cls--4
    match access-group name mng-out-drop
    class-map type inspect match-any ccp-cls-insp-traffic
    match protocol cuseeme
    match protocol dns
    match protocol ftp
    match protocol h323
    match protocol https
    match protocol icmp
    match protocol imap
    match protocol pop3
    match protocol netshow
    match protocol shell
    match protocol realmedia
    match protocol rtsp
    match protocol smtp extended
    match protocol sql-net
    match protocol streamworks
    match protocol tftp
    match protocol vdolive
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-insp-traffic
    match class-map ccp-cls-insp-traffic
    class-map type inspect match-any http-https-DMZ
    match protocol http
    match protocol https
    class-map type inspect match-all sdm-cls--2
    match class-map http-https-DMZ
    match access-group name web_server
    class-map type inspect match-any MySQLService
    match protocol mysql
    class-map type inspect match-all sdm-cls--1
    match class-map MySQLService
    match access-group name DMZtoMySQL
    class-map type inspect match-any ccp-cls-icmp-access
    match protocol icmp
    match protocol tcp
    match protocol udp
    class-map type inspect match-all ccp-icmp-access
    match class-map ccp-cls-icmp-access
    class-map type inspect match-all ccp-invalid-src
    match access-group 100
    class-map type inspect match-all sdm-nat-https-1
    match access-group 102
    match protocol https
    class-map type inspect match-all ccp-protocol-http
    match protocol http
    policy-map type inspect ccp-permit-icmpreply
    class type inspect ccp-icmp-access
      inspect
    class class-default
      pass
    policy-map type inspect sdm-pol-NATOutsideToInside-1
    class type inspect ccp-cls-sdm-pol-NATOutsideToInside-1-1
      drop
    class type inspect sdm-cls-sdm-pol-NATOutsideToInside-1-1
      inspect
    class type inspect sdm-nat-https-1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-inspect
    class type inspect ccp-invalid-src
      drop log
    class type inspect ccp-protocol-http
      inspect
    class type inspect ccp-insp-traffic
      inspect
    class type inspect CCP-Voice-permit
      inspect
    class class-default
      drop
    policy-map type inspect ccp-permit
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--1
    class type inspect sdm-cls--1
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--1
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--3
    class type inspect ccp-cls--3
      inspect
    class class-default
      drop
    policy-map type inspect sdm-policy-sdm-cls--2
    class type inspect sdm-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--2
    class type inspect ccp-cls--2
      inspect
    class class-default
      drop
    policy-map type inspect ccp-policy-ccp-cls--5
    class class-default
      drop
    zone security out-zone
    zone security in-zone
    zone security dmz-zone
    zone security mng
    zone-pair security ccp-zp-self-out source self destination out-zone
    service-policy type inspect ccp-permit-icmpreply
    zone-pair security sdm-zp-NATOutsideToInside-1 source out-zone destination in-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security ccp-zp-in-out source in-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security ccp-zp-out-self source out-zone destination self
    service-policy type inspect ccp-permit
    zone-pair security zp-dmz-to-outside source dmz-zone destination out-zone
    service-policy type inspect ccp-inspect
    zone-pair security zp-outside-to-dmz source out-zone destination dmz-zone
    service-policy type inspect sdm-pol-NATOutsideToInside-1
    zone-pair security sdm-zp-dmz-zone-in-zone source dmz-zone destination in-zone
    service-policy type inspect sdm-policy-sdm-cls--1
    zone-pair security sdm-zp-in-zone-dmz-zone source in-zone destination dmz-zone
    service-policy type inspect sdm-policy-sdm-cls--2
    zone-pair security sdm-zp-dmz-zone-self source dmz-zone destination self
    service-policy type inspect ccp-policy-ccp-cls--1
    zone-pair security sdm-zp-mng-self source mng destination self
    service-policy type inspect ccp-policy-ccp-cls--2
    zone-pair security sdm-zp-mng-out-zone source mng destination out-zone
    service-policy type inspect ccp-policy-ccp-cls--3
    zone-pair security sdm-zp-out-zone-mng source out-zone destination mng
    service-policy type inspect ccp-policy-ccp-cls--5
    interface Null0
    no ip unreachables
    interface BRI0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    encapsulation hdlc
    shutdown
    isdn termination multidrop
    interface ATM0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    no atm ilmi-keepalive
    interface ATM0.1 point-to-point
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    pvc 8/35
      pppoe-client dial-pool-number 1
    interface FastEthernet0
    interface FastEthernet1
    interface FastEthernet2
    switchport access vlan 3
    spanning-tree portfast
    interface FastEthernet3
    switchport access vlan 2
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security in-zone
    ip tcp adjust-mss 1412
    interface Vlan2
    description $FW_INSIDE$
    ip address 192.168.1.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security dmz-zone
    interface Vlan3
    description $FW_INSIDE$
    ip address 10.0.10.1 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip nat inside
    ip virtual-reassembly
    zone-member security mng
    interface Dialer0
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1452
    ip flow ingress
    ip nat outside
    ip virtual-reassembly max-reassemblies 64
    zone-member security out-zone
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 7 0918425001505245
    ppp pap sent-username [email protected] password 7 13511B4B1359417D
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip route 10.0.10.0 255.255.255.0 Vlan3
    no ip http server
    ip http secure-server
    ip nat inside source list 1 interface Dialer0 overload
    ip nat inside source static 192.168.0.101 94.70.142.113
    ip nat inside source static 192.168.1.102 94.70.142.127
    ip access-list extended DMZtoMySQL
    remark CCP_ACL Category=128
    permit ip host 192.168.1.102 host 192.168.0.101
    ip access-list extended Spoofing
    remark CCP_ACL Category=128
    permit ip 10.0.0.0 0.255.255.255 any
    permit ip 192.168.0.0 0.0.255.255 any
    permit ip 172.16.0.0 0.15.255.255 any
    ip access-list extended VTY_incoming
    remark CCP_ACL Category=1
    permit ip host 10.0.10.2 any
    ip access-list extended WebServer
    remark CCP_ACL Category=128
    permit ip any host 192.168.1.102
    ip access-list extended mng-out
    remark CCP_ACL Category=128
    permit ip 10.0.10.0 0.0.0.255 any
    ip access-list extended mng-out-drop
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended mng-self
    remark CCP_ACL Category=128
    permit ip any any
    ip access-list extended web_server
    remark CCP_ACL Category=128
    permit ip 192.168.0.0 0.0.0.255 host 192.168.1.102
    logging 10.0.10.2
    access-list 1 remark INSIDE_IF=Vlan1
    access-list 1 remark CCP_ACL Category=2
    access-list 1 remark VLan 1 Access
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 1 remark VLan 3 Access
    access-list 1 permit 10.0.10.0 0.0.0.255
    access-list 1 remark Vlan 2 Access
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 100 remark CCP_ACL Category=128
    access-list 100 permit ip host 255.255.255.255 any
    access-list 100 permit ip 127.0.0.0 0.255.255.255 any
    access-list 102 remark CCP_ACL Category=0
    access-list 102 permit ip any host 192.168.0.101
    dialer-list 1 protocol ip permit
    no cdp run
    control-plane
    banner login ^CWARNING!!!This is a highly monitored private system. Access is prohibited!!^C
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class VTY_incoming in
    password 7 12292504011C5C162E
    login local
    transport input ssh
    scheduler max-task-time 5000
    ntp authentication-key 1 md5 10603D29214711255F106B2677 7
    ntp authenticate
    ntp trusted-key 1
    ntp master 2
    end

    Hello karolos,
    Here is the thing.
    You said you are trying to access 94.70.142.113 and that is a server on the DMZ but based in your configuration that is not true
    ip nat inside source static 192.168.0.101 94.70.142.113
    So 192.168.0.101 is on Vlan 1 witch is the in-zone
    interface Vlan1
    description $FW_INSIDE$
    ip address 192.168.0.1 255.255.255.0
    security in-zone
    If you got confused with  the security zone that the host is assigned to then just add the following and it should work
    ip access-list extended WebServer
    permit ip any host 192.168.0.101
    Regards

  • What is the diffrence between package javax.sql and java.sql

    Is javax designed for J2EE?
    And when to use package javax?

    Hi,
    What is the diffrence between package javax.sql and java.sql?The JDBC 2.0 & above API is comprised of two packages:
    1.The java.sql package and
    2.The javax.sql package.
    java.sql provides features mostly related to client
    side database functionalities where as the javax.sql
    package, which adds server-side capabilities.
    You automatically get both packages when you download the JavaTM 2 Platform, Standard Edition, Version 1.4 (J2SETM) or the JavaTM 2, Platform Enterprise Edition, Version 1.3 (J2EETM).
    For further information on this please visit our website at http://java.sun.com/j2se/1.3/docs/guide/jdbc/index.html
    Hope this helps.
    Good Luck.
    Gayam.Srinivasa Reddy
    Developer Technical Support
    Sun Micro Systems
    http://www.sun.com/developers/support/

  • What is the wrong in code while creating a container

    Hello all,
    what is the wrong in code while creating container.
    *& Report  ZTEST_TREE4
    REPORT  ztest_tree4.
    *       CLASS lcl_application DEFINITION
    CLASS lcl_application DEFINITION CREATE PRIVATE.
      PUBLIC SECTION.
        CLASS-METHODS: run_application.
        METHODS constructor.
      PRIVATE SECTION.
        CLASS-DATA: s_container TYPE REF TO cl_gui_simple_container.
        DATA: container TYPE REF TO cl_gui_simple_container.
    ENDCLASS.                    "lcl_application DEFINITION
    *       CLASS lcl_implementation DEFINITION
    CLASS lcl_application IMPLEMENTATION.
      METHOD run_application.
        IF lcl_application=>s_container IS INITIAL.
          CREATE OBJECT lcl_application=>s_container.
        ENDIF.
      ENDMETHOD.                    "run_application
      METHOD constructor.
        CREATE OBJECT container.
      ENDMETHOD.                    "constructor
    ENDCLASS.                    "lcl_implementation DEFINITION
    *&      Module  STATUS_0100  OUTPUT
    *       text
    MODULE status_0100 OUTPUT.
      CALL METHOD lcl_application=>run_application.
      SET PF-STATUS 'CO_100'.
      SET TITLEBAR 'CO_100'.
    ENDMODULE.                 " STATUS_0100  OUTPUT
    *&      Module  USER_COMMAND_0100  INPUT
    *       text
    MODULE user_command_0100 INPUT.
    ENDMODULE.                 " USER_COMMAND_0100  INPUT
    *&      Module  exit  INPUT
    *       text
    MODULE exit INPUT.
      LEAVE PROGRAM.
    ENDMODULE.                 " exit  INPUT
    START-OF-SELECTION.
      CALL SCREEN 100.
    regards,
    Lisa.
    Edited by: Lisa Roy on Mar 6, 2008 10:15 AM
    Edited by: Lisa Roy on Mar 6, 2008 10:29 AM

    Hi Lisa,
    a container must be placed in a respective screen area. Also the module calls must be implemented in your screen input and output sections. Finally you have to place something (a GUI control) in your container.
    I do not see anything like this in your program. So I don't know what you are asking about. Do you get any error message?
    Regards,
    Clemens

  • TS1702 I use iphone5, I see an app update on the app store. but when App store and click on the update tab, it doesn't show me which application to update.. just give me a blank page.!!!! what is the solution for this.!!!!

    I use iphone5, I see an app update on the app store. but when App store and click on the update tab, it doesn't show me which application to update.. just gives me a blank page.!!!! I wouldn't able to know what app has to be updated, untill and unless i get check for each every app on the app store installed on my iphone... what is the solution for this.!!!! can any1 one help me out.!!!!

    Cc2528 wrote:
    The iTunes Store on my iPad is set up with all my music already. And at the very bottom it shows my apple Id username. The only place it shows the previous owners id is in the App Store...
    You can probably change the ID in the "iTunes and App stores" settings on the iPad....click on the wrong account ID , select sign out, then log in with your own ID, I have not done this but I think it works.....
    but I would be more inclined to to the factory reset and start afresh.

  • What's the error in this package

    dear all,
    can you plz tell me what's the erro in this package plz
    SQL> CREATE OR REPLACE PACKAGE discounts
      2  IS
      3  g_id NUMBER := 7839;
      4  discount_rate NUMBER := 0.00;
      5  PROCEDURE display_price (p_price NUMBER);
      6  END discounts;
      7  /
    Package created.
    SQL>
    SQL>
    SQL> CREATE OR REPLACE PACKAGE BODY discounts
      2  IS
      3  PROCEDURE display_price (p_price NUMBER)
      4  IS
      5  BEGIN
      6  DBMS_OUTPUT.PUT_LINE ( 'Discounted '
      7  ||TO_CHAR(p_price*NVL(discount_rate, 1)));
      8  END ;
      9  discount_rate:= 0.10;
    10  END ;
    11  /
    Warning: Package Body created with compilation errors.
    SQL>
    SQL> show errors;
    Errors for PACKAGE BODY DISCOUNTS:
    LINE/COL ERROR
    9/1      PLS-00103: Encountered the symbol "DISCOUNT_RATE" when expecting
             one of the following:
             begin end function package pragma procedure form
             The symbol "begin" was substituted for "DISCOUNT_RATE" to
             continue.
    SQL>

    if you want declare a private variable you need to declare at package body and remove from the package specification
    something like this
    @10g> CREATE OR REPLACE PACKAGE discounts
      2    IS
      3   g_id NUMBER := 7839;
      4    PROCEDURE display_price (p_price NUMBER);
      5    END discounts;
      6  /
    Package created.
    @10g> 
    @10g> CREATE OR REPLACE PACKAGE BODY discounts
      2    IS
      3    discount_rate NUMBER := 0.10; /* Private declaration */
      4  
      5    PROCEDURE display_price (p_price NUMBER)
      6    IS
      7    BEGIN
      8    DBMS_OUTPUT.PUT_LINE ( 'Discounted '
      9    ||TO_CHAR(p_price*NVL(discount_rate, 1)));
    10    END ;
    11  END ;
    12  /
    Package body created.You can't assign values to variables out of procedure unless you declare and assign a initial value.
    Edited by: dask99 on Oct 26, 2009 8:23 AM

  • What is the problem with this Stored Procedure

    Hi ,
    What is the problem with this Stored Procedure ?Why is it giving errors ??
    CREATE or replace  PROCEDURE getEmpName
    *(EMP_FIRST OUT VARCHAR2(255))*
    BEGIN
    SELECT ename INTO EMP_FIRST
    FROM Emp
    WHERE EMPNO = 7369;
    END ;
    */*

    You don't specify precision in procedure arguments.
    (EMP_FIRST OUT VARCHAR2(255))should be
    (EMP_FIRST OUT VARCHAR2)Since you asked what's wrong with it, I could add that it needs formatting and the inconsistent use of upper and lower case is not helping readability.

  • What is the problem with native dynamic sql when counting rows in all table

    what is the problem with native dynamic sql when counting rows in all table?Giving an error "table or view does not exist". Thanks.
    DECLARE
    v_sql_string varchar2(1000);
    v_no_of_rows number;
    BEGIN
    for i in ( select table_name from all_tables )
    loop
    v_sql_string := ' select count(1) from ' || i.table_name;
    dbms_output.put_line( v_sql_string );
    --execute immediate v_sql_string into v_no_of_rows;
    end loop;
    END;

    Usually your problem can be described with 'Who cares'. I mean, for what reason do you do this? I doubt that there's a business need to get 100 % accurate answers for this. Normally such things are used to get a picture about the growth of data.
    Personally I would prefer to have up-to-date statistics for all tables and just query the number of rows from there. Sufficient for me in < 99 % of all cases.
    Just my $ .02...

  • What is the use of this form?

    Hi all,
    What is the use of this form in include RV61B901?
    How does this code send any information to the program calling it? Is Sy-subrc global so that main program will know the reuslts?
    Code:
    FORM KOBED_901.
      DATA : l_anzpk LIKE likp-anzpk.
      SELECT SINGLE anzpk FROM likp
                          INTO l_anzpk
                          WHERE vbeln = komkbv2-vbeln.
      IF l_anzpk NE 0.
        sy-subrc = 4.
        exit.
      ENDIF.
      sy-subrc = 0.
    ENDFORM.
    Thanks,
    Charles.

    Hello,
    This form sets the value of sy-subrc(which is global) based
    on the value of l_anzpk.
    Regards
    Greg Kern

Maybe you are looking for