Why cannot execute DB operation at client side with dynamic proxy?

I want to execute a DB operation at client side with dynamic proxy. that is bypass EJBs to execute DB operation. And there is a data source in weblogic server, and I get an EJB instance using dynamic proxy, get connection using this instance, then invoke executeQuery method. But it is failed, and throw exception when execute "conn.setAutoCommit(false)" as below:
<Caused by: weblogic.rmi.extensions.RemoteRuntimeException: Unexpected Exception - with nested exception:
[java.rmi.UnmarshalException: Could not unmarshal method ID; nested exception is:
java.rmi.UnmarshalException: Method not found: 'newArrayDataResultSet(Loracle.sql.ARRAY;JILjava.util.Map;)']
at weblogic.jdbc.rmi.internal.ConnectionImpl_weblogic_jdbc_wrapper_PoolConnection_oracle_jdbc_driver_OracleConnection_813_WLStub.setAutoCommit(Unknown Source)
at weblogic.jdbc.rmi.SerialConnection_weblogic_jdbc_rmi_internal_ConnectionImpl_weblogic_jdbc_wrapper_PoolConnection_oracle_jdbc_driver_OracleConnection_813_WLStub.setAutoCommit(Unknown Source)>
but it is no exception and run well using EJB, who can tell me why? if it is a weblogic limitation? and my version of WLS is 8.1 sp3

Hi,
Do you create the connection object on the server and pass it over to the client, we do not allow passing the connection object over the wire.

Similar Messages

  • Hello. I don't live in the U.S. and I'd like to buy a new mini IPad retina. But I see it is offered with four mobile operators. Does that mean I cannot use another operator, in my country, with it?

    Hello. I don't live in the U.S. and I'd like to buy a new mini IPad retina. But I see it is offered with four mobile operators. Does that mean I cannot use another operator, in my country, with it?

    Hello. I don't live in the U.S. and I'd like to buy a new mini IPad retina. But I see it is offered with four mobile operators. Does that mean I cannot use another operator, in my country, with it?

  • Why cannot any longer do "slow motion" gesture with 2 fingers of videos in iPhoto 9.2

    why cannot any longer do "slow motion" gesture with 2 fingers of videos in iPhoto 9.2 under lion ??? anyone knows why ? bug or feature...

    why cannot any longer do "slow motion" gesture with 2 fingers of videos in iPhoto 9.2 under lion ??? anyone knows why ? bug or feature...

  • What kind of hardware is required on client side with OWB 10gR2?

    Hi,
    What kind of hardware are you using, on client side, with OWb 10gr2?
    Currently I'm using a PC having a Pentium 4 1.7Ghz with 1.5 GB Ram but it's extreamly slow.

    Hi
    For Windows, ensure that the machine has a minimum of 850 MB disk space, 768 MB available memory, and 1GB of page file size, TMP, or swap space.
    For Linux, ensure that the machine has a minimum of 1100 MB disk space, 768 MB available memory, and 1GB of page file size, TMP, or swap space.
    Are you running an anti-virus? If so, try stopping it and run OWB. This is due to the anti-virus action and OWB being a java based tool...
    Regards,
    Marcos

  • Merging randomly-named XML data file on client-side with pdf designed in Livecycle 7.0 (and addition

    Okay, as a heads up I work for a financial institution and we are converting our legacy "jetforms" to pdf format. I have in my staff for the project, 2 code developers and myself- a form designer. We have currently spent 2 months in trial and error attempting to resolve this problem, please let us know anything you can have. All client-side (internal) machines are running Windows XP and Adobe Reader 7.0.7
    The software we use as a financial institution allows our users to export a customer's data file onto their machine which is then renamed to include the member's account number and first and last name for our staff to determine which data file they need more accurately. In legacy jetforms, we have developed a program that pushes the data from the customers file that they select, into the jetform that they want to open and the matching fields in the data file fill in the fields of the jetform. Clean and simple.
    Now, i have hit nothing but frustration when attempting to perform the same process with pdfs using a form designed in livecycle designer 7. First, i see no obvious command for opening a pdf and importing a data file using a command line, like pdfmerge or something of the sort in which an xml data file can be specified and a pdf can be specified. I saw something like it using an fdf format and attempted to do this but apparently reader cannot import the data into the pdf that was designed adobe livecycle 7. All i have been seeing is database connections and using javascript inside the form to populate fields based on these database connections, etc. etc. or doing a manual file>import data>etc. which we don't want to have our staff do. We do not have reader extensions enabled, simply because i cannot get an adobe representative to call me and discuss pricing nor see any estimated pricing chart around. I don't know if reader extensions are necessary for this or not but i'm becoming very very frustrated with it.
    We don't want a complex server-side data connection binding with dynamic input. No, we just want it where our developers can say "if this data file is selected, and this pdf form is selected run this command" which would be a simple pdfmerge type solution. Is this possible or do i need to stay with jetforms until our software the billion dollar financial institution uses does form building inside its own application? I don't want to fight about who is better, what version to use, etc. I just want the straight up honest truth. If you need to know the pricing that the reader extensions would have to go by, assume there will be 500 client computers that will need to use it.

    From your post it sounds like you are Central Pro (a product for which I am by no means an expert), but you say you want to upgrade to a newer product from your "legacy" one. Is there a reason for this? Have your requirements change so that it no longer fits them? Central is still in the current Adobe roster and as far as I know there is no plans to get rid of it any time soon, so if it does everything you want I don't see why you would want to change.
    There is no product in the LiveCycle suite that merges xml data into a form from the command line. LiveCycle (with the exception of Designer) is a suite of server products, so the closest you would come is LiveCycle Forms (merge the xml and create a fillable PDF) or LiveCycle Print (merge the xml and print the form).
    Hope this helps somewhat.
    Chris
    Adobe Enterprise Developer Support

  • User form: to execute some operation at server side for a command click

    jurajsiska Apr 11, 2006 7:56 AM
    I'm creating a customer user form. I want to do some thing at server side when a command is clicked, but don't want to save any modified value until user clicks "Save" button. There is property for command display class, named "command", but it just gives you opportunity to execute some pre-defined command, Save, Recalcuate, or Cance. How can I achieve this by customizing the event handler for command click?

    I just figured out a way myself. Create a hidden field in your user form, use the java script to set hidden field to some value for the "onclick" property of BUTTON, and to check this hidden value in the properties command of BUTTON to know if it's coming from click or refres/recalculate. Of course you need to reset the hidden value in the expression of command property.
    Hope it's helpful for somebody having the same situation,

  • How to execute jsp script  at client side

    i have a web page developed in jsp. i need to capture the client machines ip address and MAC address. i got ip address. how to get MAC address who are all accessing that page

    Yeah, there's no javascript that'll do it either. I saw a bunch of posts from php guys trying to do the same thing. It's just not part of TCP/IP. There are apps that will give you the MAC based on an IP in a local network. That's all I've seen available.

  • Printing client side with Applet!!!

    Hi,
    Does anyone can help me with my applet. It must get the current page and print it in landscape out over at the user side (local printer).
    Here some sample of my source to help....
    // JavaScript part
    function print(){
    var myURL = document.location.href;
    alert(myURL);
    testApplet.print(myURL);
    // Applet part
    public class MyClass extends Applet implements Pageable, Printable {
    // .... some source ...
    public void print(String myURL) throws IOException, PrinterException {
    PrinterJob job = PrinterJob.getPrinterJob();
    PageFormat landscape = job.defaultPage();
    Paper sheet = new Paper();
    sheet.setImageableArea(0,0,landscape.getImageableWidth()+ (landscape.getImageableX()*2),landscape.getImageableHeight()+(landscape.getImageableY()*2));
    landscape.setPaper(sheet);
    landscape.setOrientation(PageFormat.LANDSCAPE);
    JTextPane txt = new JTextPane();
    txt.setPage(myURL);
    // this method initialise the parameters for the printing
    initialise(txt.getText(), landscape);
    job.setPageable(this);
    job.print(); ///// THE PROBLEM IS HERE
    java.awt.print.PrinterException: No print service found.
    at sun.print.RasterPrinterJob.print(Unknown Source)
    at sun.print.RasterPrinterJob.print(Unknown Source)
    at PageableText.test1(PageableText.java:151)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at sun.plugin.com.MethodDispatcher.invoke(Unknown Source)
    at sun.plugin.com.DispatchImpl.invoke(Unknown Source)
    I have printers define and they worked well. Also, I have use the same code but without the Applet (calliing it from the main and with a static url) and it work perfectly. I'm pretty sure it's the Applet who's causing trouble.
    Anyone has any idea or sample to help me?
    Thanks

    It has to do with the JS call to the print method. I got around it by calling my printData() method in a separate thread...
    try something like this:
    ============================
    public void jsPrintData()
    if ( isPrinting )
    return;
    isPrinting = true;
    Thread runner = new Thread()
    public void run()
    printData();
    runner.start();

  • Why cannot iTunes sync movies from iPhoto taken with iPhone

    I take little movies with iPhone. (5Mb)
    iPhoto copies then to the Mac with the Photos.
    Movie plays in iPhoto.
    In iTunes I say Sync event and tick include videos on. The movies are not copied back to the iPhone.
    Checked in iPhoto, event says 18 items (17 are photos one is the movie MOV04391.MPG)
    In iTunes > Photos tab. the event only shows 17 items.
    Thanks in anticipation...

    Try launching iPhoto while holding Option, to create an alternate iPhoto library that you can test with. You can always switch back to the original iPhoto library launching iPhoto while holding Option again.
    If it works in the new test library, you'll probably want to switch back to the main library and then rebuild it by holding down the Command and Option keys when launching iPhoto.
    Also, when you email photos from the iPhone you should see an option to email as actual size, along with the compressed options.
    WTH.

  • Limiting bandwidth on client side with Camera.setQuality() inconsistent?

    After successful bandwidthCheck() limiting bandwidth to setQuality(75000, 100)
    leads to the desired result of publishing the stream with max bitrate of 75000 byte/s.
    On other locations the same setting results in publishing the stream with max bitrate of 
    approx. 13107 byte/s. If I change bandwidth to setQuality(400000, 100) i am reaching the desired
    bandwidth limit of 75000 byte/s.
    Stream is published with h264Settings.setProfileLevel(H264Profile.MAIN, H264Level.LEVEL_5_1).
    Any clues?
    These behaviour only occurs with outStream.videoStreamSettings = h264Settings;
    If videoStreamSettings is not set to h264Settings all things are doing well as expected.

    Here's a link that explains what BBSM is all about:
    http://www.cisco.com/en/US/partner/products/sw/netmgtsw/ps533/index.html

  • ACE30 - PING to VIP and Client side SVI not working

    Hi Guys,
    Having setup the ACE30 based on the configuration guides, I've been able to get basic load balancing working, probes, stickness etc.  However in testing connectivty, I've noticed that from the real server on the backend I cannot seem to PING:
    1. The VIP for the web service that the server is a part of
    2. The Client side SVI
    I'd like this to work to ensure full connectivity.
    I've applied ACLs to the Client side SVI (on the ACE) to allow this in both directions, and also removed any ACLs attached to the client side SVI on the MSFC where the subnet is actually homed.  However I just cannot seem to PING the Client side SVI on the ACE, or the VIP.  Trying to understand if this is normal behavior.
    Have inserted my config below for completeness.
    ACE30 Config
    login timeout 60
    hostname ACE1
    boot system image:c6ace-t1k9-mz.A90_6_3_5.bin
    boot system image:c6ace-t1k9-mz.A4_1_0.bin
    resource-class RC_1
      limit-resource all minimum 10.00 maximum unlimited
    access-list all line 8 extended permit ip any any
    access-list v6-any line 8 extended permit ip anyv6 anyv6
    class-map type management match-any REMOTE_ACCESS
      description Remote access traffic match
      2 match protocol telnet any
      3 match protocol ssh any
      4 match protocol icmp any
      5 match protocol https any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
      class REMOTE_ACCESS
        permit
    interface vlan 768
      description Management connectivity
      ip address 10.20.40.72 255.255.255.0
      service-policy input REMOTE_MGMT_ALLOW_POLICY
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.20.40.254
    context VC_1
      allocate-interface vlan 11
      allocate-interface vlan 186
      member RC_1
    username admin password 5 $1$STizNv5q$i96.Qrt4C4SfHkbLyVT74.  role Admin domain default-domain
    username www password 5 $1$ZAn8bOtv$xmmNlH8akF6iYfXdQCKMo1  role Admin domain default-domain
    ssh key rsa1 1024 force
    ! VC_1
    ACE1/VC_1# sh run
    probe http HTTP_PROBE1
      interval 15
      passdetect interval 60
      expect status 200 200
      open 1
    rserver host RS_MONASH_WEB1
      description Test Monash Web Server 1
      ip address 10.194.27.177
      inservice
    serverfarm host SF_MONASH_WEB
      probe HTTP_PROBE1
      rserver RS_MONASH_WEB1 80
        inservice
    sticky ip-netmask 255.255.255.255 address source STICKY_MONASH_WEB
      timeout 3600
      serverfarm SF_MONASH_WEB
    class-map type management match-any REMOTE_ACCESS
      description Remote access traffic match
      2 match protocol ssh any
      3 match protocol telnet any
      4 match protocol icmp any
      5 match protocol https any
    class-map match-all VS_MONASH_WEB
      2 match virtual-address 10.194.11.1 tcp eq www
    access-list ALLOW_TRAFFIC_TOWARDS_ACE extended permit ip any any
    access-list ALLOW_TRAFFIC_TOWARDS_ACE extended permit icmp any any
    policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
      class REMOTE_ACCESS
        permit
    policy-map type loadbalance first-match PM_MONASH_WEB_LB
      class class-default
        sticky-serverfarm STICKY_MONASH_WEB
    policy-map multi-match PM_MULTI_MATCH_CLIENT_VIP
      class VS_MONASH_WEB
        loadbalance vip inservice
        loadbalance policy PM_MONASH_WEB_LB
    service-policy input REMOTE_MGMT_ALLOW_POLICY
    interface vlan 11
      description Client connectivity on Vlan 11
      ip address 10.194.11.250 255.255.255.0
      access-group input ALLOW_TRAFFIC_TOWARDS_ACE
      access-group out ALLOW_TRAFFIC_TOWARDS_ACE       ! not sure if this is required as well?
      service-policy input PM_MULTI_MATCH_CLIENT_VIP
      no shutdown
    interface vlan 186
      description CSM www monash
      ip address 10.194.27.189 255.255.255.240
      access-group input ALLOW_TRAFFIC_TOWARDS_ACE    ! not sure if this is required?
      access-group out ALLOW_TRAFFIC_TOWARDS_ACE      ! not sure if this is required?
      ip dhcp relay server 130.194.15.17
      ip dhcp relay server 130.194.15.1
      ip dhcp relay enable
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.194.11.254
    6500s
    ! test-clay1-gw - ACE connects to this 6500
    svclc multiple-vlan-interfaces
    svclc module 2 vlan-group 2
    svclc vlan-group 2  11,171-499,768
    ! test-clay0-gw - Where Client side subnet, VLAN11 is homed
    interface Vlan11
    description Testlab server subnet
    ip address 10.194.11.253 255.255.255.0
    no shut
    ip route 10.194.27.176 255.255.255.240 10.194.11.250
    thanks
    Sheldon

    To ping your VIP of the webserver, you should apple the service-policy input command on VLAN 186 too. Currently the VIP only listens on VLAN 11. For the SVI i think that was forbidden by security reason, but i cant remember anymore. Maybe you just need to put the management policy on the interface VLAN 186. If it dont work, then my first guess was right

  • Cannot execute RSA1

    Hi everyone,
    I have an URGENT issue, cannot execute RSA1.
    Already modify WE20 with the missing entry (BWDCLNT700, LS) but in table RSBASIDOC I dont see it.
    When I execute RSA1 display the same error and delete from WE20 the new entry.
    Please help me to solve this!!!
    <b>Entry in inbound table already exists
    Message no. E0412
    Diagnosis
    Inbound parameters already exist in the partner profile under the following key:
    /BWDCLNT700/LS//RSSEND////
    This relates to the key fields in table EDP21:
    SNDPRN Partner number
    SNDPRT Partner type
    SNDPFC Partner function
    MESTYP Message type
    MESCOD Message code
    MESFCT Message function
    TEST Test indicator
    Procedure
    Please check the EDI partner profile.</b>

    Hello All,
    HERE THE RELEVENT ANSWER:
    I found solution for this error.
    1. Go to WE20 and check whether Partner profile T90CLNT090 exist in LS type,if not just add Parnter profile with same and save.
    Partner profile Name: T90CLNT090
    TYPE: LS
    Give:
    Ty: US
    User: User Name
    Lang: EN
    and Save.
    2. Again re-click on Partner Profile: T90CLNT090
    you will see ,there will be some entries in Inbound & out Bound Tabs.
    Delete the following from outbound:
    1.RSRQST
    Delete the following from inbound.
    1.RSINFO
    2.RSSEND
    and save your partner profile.
    3. now execute - RSA1, it will ask to active Workbench. Just activate it . it will work now.... Cheers.
    Regards,
    K.Ramesh
    Note: Please give some points ,if it solves your problem.

  • Webservice without client side interface

    Is there a way to call a webservice from the client side with out having any jar or interface used in the client side?
    Can you recommend me some good links on this?
    Thanks

    The most flexible client invocation method is DII (Dynamic Invocation Interface). With this approach your client needs just the standard JAX-RPC JARs from the JWSDP, but it doesn't need any runtime classes generated by WSDL to Java mapping tools.
    The following link has some DII examples as well as comparisons with the other types of client invocations:
    http://www-128.ibm.com/developerworks/webservices/library/ws-javaclient/

  • Chart Control printing at the client side

    Hi,
    I have multiple chart controls (in VS2010) on an aspx page, which also show their relevant detaild data in a table on the same page. I could not found yet an appropriate solution for printing such a page with chart control and other data.
    In fact I was able to print the chart alone at the client side, but only by sending it directly to the printer, this method is unable to show print preview dialog to the client.
    Then i started thinking in another direction, and came with the idea to export my desired controls into a pdf file which then can be shown in the browser (which resolves browser independance), for that i used nReco (the dll which comes with dot net) pdf converter
    which can convert the whole html page into the pdf file (by passing the url of the page) and then opens/saves in the browser to print.
    But when i pass it (to one of the the funtion in nreco) a container means a div or a panel control which holds the chart control and other normal controls then it gives me the error that unable to convert to pdf.
    Tis may be due to the relative path of the chart control image.
    I am stuck in this situtation, My original requirement is to show the the print preview to the user at client side with all printing options. It would be very convenient if the desired control can be exprted to pdf.
    And I don't want to use any ohter third party control (for print preview at client side) which needs to be installed on the client machine.
    Thanks.
    Code Sample:
    using NReco.PdfGenerator;
    on Load
    Chart1.Series[0].Points.DataBind(datatbl.Rows, "ColHeading", "colName", string.Empty);
    On Print
    HtmlToPdfConverter nRecohtmltoPdfObj = new HtmlToPdfConverter();
    nRecohtmltoPdfObj.Orientation = PageOrientation.Portrait;
    StringBuilder sb = new StringBuilder();
    StringWriter tw = new StringWriter(sb);
    HtmlTextWriter hw = new HtmlTextWriter(tw);
    ChartPanel1.RenderControl(hw);
    string temp =
     "<html><head><style>td,th{line-height:20px;} tr { page-break-inside: avoid }</style><script>function subst() {var vars={};var x=document.location.search.substring(1).split('&');for(var i in x) {var z=x[i].split('=',2);vars[z[0]]
    = unescape(z[1]);}" +
                "var x=['frompage','topage','page','webpage','section','subsection','subsubsection'];for(var i in x) {var y = document.getElementsByClassName(x[i]);" +
                "for(var j=0; j<y.length; ++j) y[j].textContent = vars[x[i]];}}</script></head><body onload=\"subst()\">"
     + sb.ToString() 
     + "</body></html>";
    nRecohtmltoPdfObj.GeneratePdf(temp);
    Please suggest a batter way out.

    Is this question hard to answer? or I am going to the wrong direction since I am new about Java EE/EJB.
    Can anyone give me some answer?

  • How to implement a persistent HTTP connection on client side...

    Sorry for the inconvenience everyone, but I could really use some help here since I am a total newbie to Java programming
    I am trying to implement a persistent HTTP connection on the client side with request pipelining. The way I understand it is that client requests will be sent to the server, which will reply to them back to back, and then the client will read them accordingly. But when I read the server responses, I get only the reply for the first request, and nothing further, when I actually expect it to give me as many responses as the number of requests I ussued. Here is a sample code illustrating what I am trying to do.
    ====================
    import java.io.*;
    import java.net.*;
    import java.util.*;
    public class HttpClient {
    public static String host = "www.somehost.com";
    public static int port = 80;
    public static String pathname = "/download.asp";
    public static String protocol = "http";
    public static ArrayList list;
    public static void main(String[] args) {
    Parser parser = new Parser();
    list = parser.getIDs();
    try {
    Socket socket = new Socket(host, port);
    InputStream from_server = socket.getInputStream();
    PrintWriter to_server = new PrintWriter(socket.getOutputStream());
    OutputStream to_file;
    to_file = new FileOutputStream("HTTP_response.txt", true);
    for(int i = 0; i < 3; i++)
    String s = (String)parser.getIDs().get(i);
    String filename = "/download.asp?id=" + s;
    to_server.print("GET " + filename + "\n\n");
    to_server.flush(); // Send it right now!
    //This response gives only  only the response to the first
    //request,....
    byte[] buffer = new byte[4096];
    int bytes_read;
    while((bytes_read = from_server.read(buffer)) != -1)
    to_file.write(buffer, 0, bytes_read);
    to_file.close();
    socket.close();
    catch (Exception e) {
    System.err.println(e);
    System.err.println("Usage: java HttpClient <URL> [<filename>]");
    }

    There are many things wrong with your code. Learn the HTTP protocol and you'll know what I mean.
    Here's a hint - you'r missing headers in your code.
    Some servers do not support keep-alive connections, nor do you request a keep-alive connection.
    Connection: keep-alive
    Use that header field and see what happends. Also, in your while-loop, you actually close the output file and the socket. Don't you think it may be hard for the server to respond to a client that closed the connection on it?
    1. You don't know HTTP
    2. You don't seem to know Java
    3. You don't seem to understand basic programming logic

Maybe you are looking for

  • One keyboard for ibook and pc laptop?

    Would really appreciate any advice on how to operate a PC laptop (Samsung) and an Apple Mac iBook using one keyboard and mouse.  Would a bluetooth keyboard/mouse be enough or does an iBook require different accessories to a PC Laptop?

  • Issue setting up 1-Step CC payment in iRec and iPayment 11.5.10.2

    I am experiencing some 'crazy' inconsistent errors in iReceivables and iPayments. Currently running version 11.5.10.2. We currently have 'two-step' credit card processing setup for our iReceivables and iStore implimentation. I am attempting to switch

  • Titles work in iMovie but not after I export them

    Everything seems to be working normally in my iMovie project but when I export the video, some of the titles are no longer readable (they seem too transparent). When I view the project is full screen mode - it works but once I finalize it and export

  • WikiServerUI error message

    Is anyone getting this error message when connecting to the XServe Wiki/Blog? The error started after updating to Mac OS X Server 10.6.5. The versions of the server and UI don't match. Try clicking Reload; if that doesn't work, please make sure both

  • Portal export while users logged in application

    Hi, We are using Oracle Application Server Portal 10g (904) for our corporate applications. I am preparing to migrate our production system into a new database server (as the current Database server is too old). I have created a transport set – but b