Why is this RSS Feed not working?

Here is the code I used on the RSS Parser file. Yet when I
open the flash viewer no changes have been made from the original
example I pulled this from. Sorry, the code is listed twice. The
second version is when I used "attach code" and I can't seem to
delete the original cut & paste.
Mind you, I'm just getting through the latter stages of a
beginner Flash course, so if possible, please keep explanations
relatively understandable to a newbie. :)
package com.example.programmingas3.rssViewer {
import flash.net.URLRequest;
import flash.net.URLLoader;
import flash.events.*;
* RSSParser includes methods for
* converting RSS XML data into HTML text.
public class RSSParser extends EventDispatcher {
* The text to use as the title of the application
public var sampleTitle:String = "Raw Story: Breaking News";
* The text to use as the description of the application
public var sampleDescription:String = "Bringing you the news
the supposed liberal media won't";
* The URL of the source RSS data. Alternate URLs are listed
as comments.
* Note that in order to use RSS data from a network address,
the source server
* needs to impliment a cross-domain policy file. For
details, see the "Flash Player
* Security" chapter in the Programming ActionScript 3.0
book.
public var url:String = "
http://feeds.feedburner.com/rawstory/gKpz"
//"./RSSData/ak.rss"
http://feeds.feedburner.com/rawstory/gKpz"
* The XML object containing the source RSS data
public var rssXML:XML;
* The string that will contain the converted HTML version of
the RSS topic data.
public var rssOutput:String;
* The title of the RSS feed.
public var rssTitle:String;
* Used to load RSS data.
private var myLoader:URLLoader;
* An event used to signal that the HTML version of the RSS
data has been written.
private var dataWritten:Event;
* Initiates loading of the RSS data.
public function RSSParser() {
var rssXMLURL:URLRequest = new URLRequest(url);
myLoader = new URLLoader(rssXMLURL);
myLoader.addEventListener("complete", xmlLoaded);
* Invoked when the RSS data is loaded. This method parses
through the
* XML data by looping through each item element in the XML,
extracting
* the title description and link elements in the item
element.
* The buildHTML() method returns HTML in the form of an
XMLList
* object, which is converted to the rssOutput string.
* The channel.title property of the rssXML is used as the
* title for the RSS feed. When the method is complete, it
dispatches
* a dataWritten event, which notifies the host application
of the
* completion.
public function xmlLoaded(evtObj:Event):void {
rssXML = XML(myLoader.data);
var outXML:XMLList = new XMLList();
/* The source RSS data may or may not use a namespace to
define
* its content.
if (rssXML.namespace("") != undefined) {
default xml namespace = rssXML.namespace("");
for each (var item:XML in rssXML..item) {
var itemTitle:String = item.title.toString();
var itemDescription:String = item.description.toString();
var itemLink:String = item.link.toString();
outXML += buildItemHTML(itemTitle,
itemDescription,
itemLink);
XML.prettyPrinting = false;
rssOutput = outXML.toXMLString();
trace(rssOutput);
rssTitle = rssXML.channel.title.toString();
dataWritten = new Event("dataWritten", true);
dispatchEvent(dataWritten);
* Builds an XMLList object that represents a segment of HTML
code,
* based on the three string parameters that define the
title, description,
* and link information from an RSS item.
* The return text is of the following form:
* <p>itemDescription<br/><a
href="link"><font
color="#008000">More...</font></a></p>
private function buildItemHTML(itemTitle:String,
itemDescription:String,
itemLink:String):XMLList {
default xml namespace = new Namespace();
var body:XMLList = new XMLList();
body += new XML("<b>" + itemTitle + "</b>");
var p:XML = new XML("<p>" + itemDescription +
"</p>");
var link:XML = <a></a>;
link.@href = itemLink; // <link
href="itemLinkString"></link>
link.font.@color = "#008000"; // <font
color="#008000"></font></a>
// 0x008000 = green
link.font = "More...";
p.appendChild(<br/>);
p.appendChild(link);
body += p;
return body;

Please when you have a question post the feed URL, not its contents. For reference, your feed is at
http://gamersscope.emachine08.com/podcast.rss
You have failed to close the category tag, which renders the feed unreadable. You need to add a line as here:
<itunes:category text="Games &amp; Hobbies">
<itunes:category text="Video Games"/>
</itunes:category>
<itunes:owner>
Though it doesn't affect the validity of the feed, your link tag:
<link>http://gamersscope.emachine08.com</link>
leads to a server directory, not a page.

Similar Messages

  • I already update my os to ios7 but the panorama wallpaper is not working, i try to use before the ios7 beta, the panorama is working. Why in this ios7 is not working. Could anyone help me????? Thanks

    I already update my os to ios7 but the panorama wallpaper is not working, i try to use before the ios7 beta, the panorama is working. Why in this ios7 is not working. Could anyone help me????? Thanks

    That's odd.
    Try this: Unplug your Time Capsule and your router. On your MBP, click the Wi-Fi icon and select "Open Network Preferences".
    Click the lock icon to authenticate, then click the "gear" and select "set service order". Wherever AirPort (or Wi-Fi - I forget what Snow Leopard calls it) appears, drag it elsewhere in the list. Click OK, then Apply, then power up your router and TC.
    If that doesn't result in any change, repeat the above but try making the service(s) you do not need "inactive".
    The purpose of this is to reset or at least change your Network Preferences, which somehow got confused upon upgrading to SL.

  • RSS feeds not working in Mail

    Hello Everyone,
    My RSS feeds stopped working on April 12th. Two of them have given me feeds today but nothing from yesterday or the day before or the day before that. Very strange. I've tried quitting Mail, restarting my computer, control clicking on the individual feeds and folders and clicking update all feeds and the specific feeds. Any other tips?
    Thank you very much!

    Not sure if this counts as 'fixing' the problem; but here's what I did:
    * Moved ~Library/Mail to someplace else (I picked my desktop)
    * Open mail.
    * Watch as .Mac pulls in the configuration that was synced to .Mac.
    * Wait to download new mail (IMAP headers)
    I did have to manually copy the mail rules .plist, but other than that, things seem to be working as I want them to.
    Somehow, RSS started working.

  • Help Please, RSS Feed Not Working! :(

    Hello there,
    I'm having a hard time getting my RSS feed to work correctly with subscribers and am at my wits end. I cannot seem to wrap my head around it.
    I (ideally) wanted to get both MP3 and M4A file formats working to please both crowds or subscribers. So the iTunes subscribers can subscribe to the M4As and the other listners can subscribe to the MP3s.
    Anyway, I deleted and recreated the feed on feedburner here, but it's still not resolving. I've deleted the feed countless times, reinstalled iTunes, and tried it on 4 different computers, and even had other people
    Any ideas why iTunes will not resolve the feed? If you look at the main page the files play correctly and without issue via the flash player.
    www.playedpodcast.com/feed
    Thanks in advanced guys!

    Fixed!

  • RSS feeds not working.

    So somehow my rss feeds stopped working. This happens for all my rss feeds (about 9) except for 2. Also one web isn't working for me either it's just stuck at the 3rd of october update... When I use a proxy the web page does work so I'm guessing the problem is there. I should clarify that I do have other mac's and pc's in the house and they are working fine, so I don't think this is a problem by my ISP. Any suggestions?? Thanks

    Might give a try with Applejack...
    http://www.versiontracker.com/dyn/moreinfo/macosx/19596
    After installing, reboot holding down CMD+s, then when the DOS like prompt shows, type in...
    applejack AUTO
    Then let it do all 5 of it's things.
    At least it'll eliminate some questions if it doesn't fix it.
    The 5 things it does are...
    Correct any Disk problems.
    Repair Permissions.
    Clear out Cache Files.
    Repair/check several plist files.
    Dump the VM files for a fresh start.
    As long as you don't have a USB connection in tandem with a UPS, which can cause problems.

  • RSS feed not working correctly

    I have several RSS feeds and have for a while. All of a sudden, one feed (NYT Travel) started coming into my InBox as well as into its RSS box. If I delete the article from INBox, it's deleted from the RSS box. Same in reverse. However, I can't move them from InBox to RSS box and they're clogging my InBox. Other feeds are working fine. Can anyone help? Thanks.

    I had the same problem. I didn't knowingly do anything. In the past when that happens the whole thing moves up to the inbox & I can click on the down arrow that shows up next to it. Not the case this time.
    To fix it do this:
    Right click on the RSS feed in the left column. There is a popup menu that gives you the option to "View in inbox" which probably got turned on, uncheck it.

  • RSS feed not working properly.

    Site is http://www.shatteredthought.com
    The site redirects to a subdomain http://www.shatteredthought.freeservers.com
    When I went to publish to a folder, I did stated the path should be http://www.shatteredthought.freeservers.com and not the correct domain, but the RSS feeds are not working still.
    Has anyone experienced this?
    They had worked before, I have tried republishing the page twice with the same result.
    Tried as well under domain, http://www.shatteredthought.com as well as subdomain with same result. Feed failed to load. It was working prior to this. I looked at the XML code and it all appears fine to me.
    Any help would be appreciated

    Issue was resolved and narrowed down to web hosting company

  • RSS Feed not working in chrome browser for anonymous users but working fine in IE

    HI All,
    We are having public facing site for anonymous users. We have created links for OOTB RSS feed for lists and libraries. The link is working fine in IE, but for chrome it is asking for credentials. We are using publishing site. Any idea or pointers is much
    appreciated. We are in testing phase and this issue sticking us.
    Rohit Pasrija

    Hi,
    According to your description, my understanding is that you want anonymous user access RSS feed link without asking for credentials.
    I suggest you can check if you have deactived the “Limited-access user permission lockdown mode” feature in the site settings-> site collection features
    In my environment ,after disabling the feature, then the rss feed link will be accessed without credentials for anonymous users in Chrome.
    Thanks
    Best Regards
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact
    [email protected]
    Jerry Guo
    TechNet Community Support

  • RSS feed not working in iweb

    Hi
    Any idea why RSS player displays "the RSS feed source can't be reached, try again later", is it becasue the source RSS contains pictures?
    Would this cause compatibility issues in iweb?
    Thanks for your help
    Lawrence

    Hi,
    According to your description, my understanding is that you want anonymous user access RSS feed link without asking for credentials.
    I suggest you can check if you have deactived the “Limited-access user permission lockdown mode” feature in the site settings-> site collection features
    In my environment ,after disabling the feature, then the rss feed link will be accessed without credentials for anonymous users in Chrome.
    Thanks
    Best Regards
    Forum Support
    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact
    [email protected]
    Jerry Guo
    TechNet Community Support

  • Iweb rss feed not working

    I published my website (www.nigelreblochon.com) to a folder, then uploaded (using cyberduck) to my webhost. For it to work properly there, I had to remove all items from the folder iWeb created for my site (lets call the folder nigel). The site works fine except for the fact that the podcast feed no longer works because the files needed are no longer in the "nigel" folder. What to do, I would give up the rss feed if there is no other solution. Any help would be apreciated.

    well, i didi that. only problem is the index.html
    that was sent with the iweb folder was for my .mac
    site instead of the nigel site (since iweb always
    publishes EVERYTHING! instead of just something.)
    If you have multiple sites inside iWeb, then to have the index.html refer to the nigel site, just make sure that the nigel site is at the top of the list in the site organizer when you publish to your local drive.
    am
    i right in assuming that setting up a new user
    "nigel" and working on iweb from there would rectify
    my problem.?
    Yes, as long as nigel is at the top of the list of your sites (or the only site of course) inside iWeb when you publish. You could make it the only site by putting a copy of your Domain file in the appropriate place in the new account and opening iweb and deleting the other sites.

  • Why does this NAT configuration not work ?

    interface FastEthernet0/0
    description To Cable Modem
    ip address dhcp
    ip nat outside
    interface FastEthernet0/1
    description To LAN
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    ip nat pool ovrld 72.186.194.72 72.186.194.72 netmask 255.255.192.0
    ip nat inside source list NATOUT pool ovrld overload
    ip access-list standard NATOUT
    permit 192.168.1.0 0.0.0.255 log
    Show ip nat translations shows no translations.
    The Stats
    Dynamic mappings:
    -- Inside Source
    [Id: 3] access-list NATOUT pool ovrld refcount 0
    pool ovrld: netmask 255.255.192.0
            start 72.186.194.72 end 72.186.194.72
            type generic, total addresses 1, allocated 0 (0%), misses 0
    Queued Packets: 0
    I can get one device to translate with a static but the dynamic does not work.

    Hey Rolf. I used the commands like you said but it will not translate anything unless the entry is static.
    ip nat inside source static 192.168.1.2 72.186.*.72      is what im using to get my main node translated while i figure out this problem. The configuration worked fine until I upgraded IOS from 12.3 to 12.4.  Thats when it quit translating. My config follows. Keep in ming that when i tried your commands I removed the static entry for 192.168.1.2
    Building configuration...
    [OK]
    HEADEND(config)#do sh run
    Building configuration...
    Current configuration : 3267 bytes
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname HEADEND
    boot-start-marker
    boot-end-marker
    enable secret 5 $1$vk5M$eGiHBbhKZrvPdNz0aXhve1
    no aaa new-model
    memory-size iomem 15
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1 192.168.1.100
    ip dhcp excluded-address 192.168.1.254
    ip dhcp excluded-address 192.168.1.250 192.168.1.254
    ip dhcp pool DEESPOOL
       network 192.168.1.0 255.255.255.0
       dns-server 65.32.5.111 65.32.5.112
       domain-name dbtech.netpros.com
       default-router 192.168.1.254
    crypto pki trustpoint TP-self-signed-3843280569
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-3843280569
    revocation-check none
    rsakeypair TP-self-signed-3843280569
    crypto pki certificate chain TP-self-signed-3843280569
    certificate self-signed 01
      3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 33383433 32383035 3639301E 170D3032 30333031 30333331
      30305A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38343332
      38303536 3930819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100BD0F 1F06509B 67D1C1F4 C9AEFA31 89A8C059 4B17CDE8 95F23275 CFB9AC41
      D784F703 C25B630D A0461FB1 114B3608 B3387518 8F552DD7 41796488 F0C79FC0
      103A2C3F FFE388FE 7970D921 C5F754D1 68A15518 F30F91CC 26884284 5C8C3275
      B06A584D 96D2D5CB 92068B40 C05C8A4E 80E9CCE0 2DE5883F 9EF405BB 89252921
      B03D0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
      551D1104 1B301982 17484541 44454E44 2E74616D 70616261 792E7272 2E636F6D
      301F0603 551D2304 18301680 14E92E8B 5F671437 6F383CCD 42AD6AE8 4CC47730
      F9301D06 03551D0E 04160414 E92E8B5F 6714376F 383CCD42 AD6AE84C C47730F9
      300D0609 2A864886 F70D0101 04050003 81810055 7BE1410C C73F83F3 26B30B9A
      569ED607 9FDCB6CD 46125795 0A8137EF 930C195B 19E79813 B6DF9B2D 6809F4A2
      A5F0BDB0 03DF87D2 81643EC7 5D619E65 132B1C12 61FB212B DAEB02A2 56E63559
      D931DF1F A3817AAF F21D8EE0 D0741B96 DBF52051 78964876 5AB7E319 5A051455
      4EA9186D 1E9ABC81 00573284 564D6BE7 486681
      quit
    username derek privilege 15 secret 5 $1$rBZD$NqY/hkTEpcZV4rYqwtKAD.
    interface FastEthernet0/0
    description To Cable Modem
    ip address dhcp
    ip nat outside
    duplex auto
    speed auto
    interface FastEthernet0/1
    description To LAN
    ip address 192.168.1.254 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    ip nat inside source list NATOUT interface FastEthernet0/0 overload
    ip access-list standard NATOUT
    permit 192.168.1.0 0.0.0.255 log
    control-plane
    line con 0
    line aux 0
    This is very odd it is like dynamic NAT is just broken.

  • Why is this FMS query not working for me?

    There is already a FMS query that works in Delivery Pane. The FMS field there is a user defined field called U_NWR_Bin, rom table DLN1. This works fine and it is alpha numeric 10 characters. This FMS is defined in Marketing Documents rows.
    I created another user defined field called U_Bin in table PKL1 for picklist row level. This user defined field shows up in FMS in PickList Pane.
    I created a query - SELECT $[DLN1.U_NWR_Bin].
    I then assigned above query through Shift F2 to Picklist Pane field U_Bin.
    The above query is not executed on clicking the lens it gives the error - Internal error -1004 occured message 131-183.
    What am I doing wrong? Please help. Thanks.

    Hi,
    FMS query can only access the current form. $[DLN1.U_NWR_Bin\] is not valid for PickList Pane.
    Thanks,
    Gordon

  • Why does this email address not work

    Hi
    i have posted the question a couple of times in a different format, but have not received an answer....
    Why wont the ipad email system allow the following format address:
           [email protected]
    It works in outlook, but not on the iPad.
    I get the message invalid address or password.
    I am hoping that someone knows how to make it work...
    Cheers

    I think the format is yourdomain.com.test-google-a.com. Your example is missing the .com part of your domain. So your example should look like [email protected] where mydomain = name.com
    See http://www.google.com/support/a/bin/answer.py?answer=56835

  • Why is this new version not working on Youtube?

    I clicked a video and then the screen is loading but it didn't start to play the clip, it showed a word "Upgrade" instead. So I clicked on it and it led me to this Adobe Flash player downloading page. I have finished installing the software as it told me to, but the videos are still not playing like they used to be and they kept show the "Upgrade" word as if I have never done the installation of this software! It is quite bugging me since I can no longer use Youtube to watch anything! If you know the way to fix this problem please tell me, I will be very appreciated.
    Thankyou~!

    Thankyou so much for your reply!
    My operating system is Windows XP, I think it is a pretty old version because I bought this computer around December,2006. My web browser is Internet Explore 8.0 I suppose, since I just upgraded it a month ago~
    Here is my screenshot. It appears like this after the loading:

  • RSS feeds not working? (on N8)

    I got a couple feeds on my N8 (bbbc, cnn, engadget....) anyways since yesterday they wont update, i checked online some people said this has something to do with installing fring (which i did install last night), so is this relevant at all? and if so how do i fix it? (i need fring as well)
    If you found this post or any other psot helpful please press the green kudus star

    Same problem here.
    Only update if I reboot the phone, going in there on the browser and manually updating them will give me an "Unknown error".
    Seems to have happened after an over the air update of Social Networking on the phone.
    N8 User.

Maybe you are looking for