Help With Multiple Schemas In Multiple Environments

Dear Oracle Forum:
We have a bit of controversy around the office and I was hoping we could get some expert input to get us on the right track.
For the purposes of this discussion, we have two machines, development and production. Currently, on each machine, we have one database with multiple schemas, say, one for sales data and another for inventory. The sales data has maybe 200 tables and the inventory has another 50. About 12 times a year, once a month, we have a release and move code from dev to prod. The database is accessed by several hundred Pro*C and Pro*Cobol programs for online transaction processing.
The problem comes up when we need to have multiple development environments. If I need to work on something for May that requires the customer address field to be 50 characters and somebody else is working on something for July that requires the customer address field to be 100 characters, we can’t both function in the same schema. We have a method of configuring running programs to attach to a given schema/database. Currently, everything connects to the same place. We were told that we should not have the programs running as the owners of the schemas for some reason so we set up additional users. The SALES schema is accessed with the connect string: SALES_USER/[email protected]. (I don’t know where we got dot world from but that is not the current discussion.)
One of the guys said that we should have 12 copies of the database running, which is kind of painful to think about in my opinion. Oracle is not a lightweight product and there are any number of ancillary processes that would have to be duplicated 12 times.
My recommendation is that we have 12 schemas each for sales and inventory with 12 users each to access them. We would have something like JAN_SALES_USER, FEB_SALES_USER, etc. Each user would have synonyms set up for each of the tables it is interested in. When my program connects as MAY_SALES_USER, I could select from the customer table and I would get my 50 character address field. When the other user connects as JUL_SALES_USER, he would get his 100 character address field. Both of us would not know anything different.
Another idea that came up is to have a logon trigger that would set the current schema for that user to the appropriate base schema. When JUL_SALES_USER logs in, the current schema would be set to JUL_SALES, etc. This would simplify things by allowing us to avoid having something like 2400 synonyms to maintain (which could be automated without too much difficulty) but it would complicate things by requiring a trigger.
There are probably other ways to go about this we have not considered as yet. Any input you can give will be appreciated.
Regards,
/Bob Bryan

Hans Forbrich wrote:
I'd rather see you with 12 schemas than with 12 databases. Unless you have lots of CPUs to spare ... and lots of cash to pay for those extra CPU licenses.
Then again, I'd take it one step further and ask to investigate the base design. There should be little reason to change the schema based on time. Indeed, from what little I know of your app, I'd have to ask whether adding a 'date' column and appropriate views or properly coded SQL statements might simplify things. Interesting. If we were to have one big Customer table with views for each month, how would we handle the case where the May people have to see 50 character address and July have to see a 100 character address field. I guess we could have MAY_ADDRESS VARCHAR2(50) and JULY_ADDRESS VARCHAR2(100) and take care to make sure that people connecting as May can only see the May columns, etc. This is simpler than multiple schemas?
I may have overly simplified things in my effort to get something down that would not require too much explanation. The big thing is that multiple people are doing development and they have to be independent of each other. If we were to drop a column for July, the May people will have trouble compiling if we don’t keep things separate. It is not a case of making the data available. The data in development is something we cook up to allow us to test. The other part is the code we compile now will be released to production one of these times. In production, there is only a need for one database.
We are moving from another database product where multiple databases are effectively different sets of files. We have lots of disk space so multiple databases were no problem. Oracle is such a powerful product; I can’t believe there is not some way to set up something similar.

Similar Messages

  • I have a "Contact" organization issue I need help with.  I organize multiple customers under their account affiliation. I place the people with their contact info under each account name by their dept/role in the notes section of their account. I am l

    I have a "Contact" organization issue I need help with.  I organize multiple customers under their account affiliation. I place the people with their contact info under each account name by their dept/role in the notes section of their account. I am looking to be able to directly dial / email from this info in yet notes section located within a contact. On Blackberry, the notes area entered in a contact can connect directly but on the iPhone those numbers/emails are inactive. I am trying to avoid having to create each of these individuals as a separate contact and keep them under their account affiliation. It is easier to find them.  This does not seem like that complicated of a request and hoping someone can tell me how or share an app that will enable the "notes" within a contact be "active". Hope this makes sense.

    I seem to recall that this question has been asked before and I'm pretty sure that the answer is that you can't do what you want to do with the native contact app. However, there are lots of contact apps out there that pull from the built app's data but have other features. Perhaps one of them would meet your needs.

  • Help with POST data if  multiple selections are chosen

    I've created a form with a menu (list) that includes all 50
    states. I'm using the POST option, along with PHP, to process the
    form data, which will be emailed to me. The list-menu looks like
    this:
    http://askdave.info/help/states_menu.gif
    and I have "Allow Multiple Selections" checked in the Property
    Inspector.
    If the user chooses multiple states, I want
    EACH of those states to be listed in the email that I
    receive. Right now, if I check multiple states, I only get
    the very last state that's selected. For example, here's the
    email I get after I check 5 different states.
    http://askdave.info/help/formdata.gif
    Problem--> In this email, only one state is listed
    (Hawaii) even though I selected 5 different states. How do I get
    the form data to list ALL states that are checked?
    Here is what I have:
    <form name="form1" method="post" action="process.php">
    <input type="hidden" name="required"
    value="name,phone,email,states,capital" />
    And then for the menu that lists the states, I have:
    <label>
    <select name="states" size="7" multiple id="states">
    <option>All States</option>
    <option>Alabama</option>
    <option>Alaska</option>
    <option>Arizona</option>
    <option>Arkansas</option>
    and so on...
    What am I missing? How do I get the PHP script to send
    multiple values, if multiple values are chosen? (I'm new to PHP, so
    go easy on me. I can post my code, if necessary.) Is this a PHP
    issue, or do I need to add something to the HTML form?

    Hi,
    >>
    I think DynaForm stands for Dynamic Form
    >>
    this makes some sense ;-) I was just wondering because there
    is a pre-made script called DynaForm
    here, but
    it has a different "logistics" than yours.
    However, both "DynaForm" versions are pretty basic, as they
    just deal with non-multiple values - form fields like single line
    input fields, texareas and non-multiple select´s. Your script
    e.g. just loops through all existing form fields using the
    "foreach" method:
    //Pulls form fields & values.
    foreach ($this->post as $field => $value) { // looping
    through all form fields
    if ( $field == 'required' ) continue;
    $this->_addLine($field, $value); // here´s where the
    field´s name/value consolidation happens
    ...and simply consolidates a field´s "value" with its
    associated "name". The problem is : this method just works for
    fields having just 1 value -- but any "multiple value" form fields
    (e.g. your "states" select or checkbox groups which can pass
    multiple values as well) actually require a separate "foreach"
    treatment within the script, and this hasn´t been incorporated
    here.
    That said, I suggest using an other pre-made solution like
    PHP
    Form Mail script that´s capable to handle your multiple
    values - scenario innately.

  • Help with rounding to nearest multiples of n-1 !!

    i need help writing part of a program;
    start with int n, then round ***up*** to the nearest multiple of n-1; then round **this** value up to the nearest multiple of n-2. (the final step is to round up to the nearest multiple of 2)
    eg
    if n=10;
    9 -> 18
    8->24
    7->28
    6->30
    2->34.
    Please help me with this, i'm really not sure where to begin !

    it's a program to do with the approximation of pi;
    so far i have;
    public double pi (int n) {
    double f; (this is the final value of the nearest
    multiple of 2)
    then from here i'm really not sure how to go about
    it..... in other words i haven't gotten very far.Okay. I'm currious as to how this helps in the approximation of PI. Would you mind posting that?
    I'll give you a few hints. The mod operator "%" tells you the distance a number is from the multiple of n immediately bellow a positive number.
    The Math.IEEERemainder function tells you the distance a number is from the nearest multiple of n (whether above or below).
    I'll leave it to you to figure out how to find the nearest multiple ABOVE the number, and how to use that to round the number. It's actually not all that hard.
    - Adam

  • Help with a query.. (multiplication / division)

    Hi All, i have this data example
    CREATE TABLE "TB_CONVERSION_UNIDAD_TMP"
      ("ID_PRODUCTO"    NUMBER,
        "FLG_OPERADOR"   CHAR(1 BYTE) NOT NULL ENABLE,
        "NUM_FACTOR"     NUMBER(10,6) NOT NULL ENABLE);
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'M','0,0001');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'D','1');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'M','1');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'M','2');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('79','M','1');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('17','M','100');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('16','M','10');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('16','M','1');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('78','D','48');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('18','D','100');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'M','1');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'M','11');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values (null,'M','1111');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('126','D','1111,19');
    Insert into TB_CONVERSION_UNIDAD_TMP (ID_PRODUCTO,FLG_OPERADOR,NUM_FACTOR) values ('40','D','2');
    COMMIT;
    /I want get the num_factor columns where's the condition i send is id_producto then validate if the column FLG_OPERADOR is 'M' or 'D' for the multiplication or division with the another parameter i send (val).
    so far i got this:
    set serveroutput on;
    DECLARE
    intFactor number(8,2);
    intID_Producto NUMBER(10):=126;
    strFlg_Operador CHAR(1);
    Cant number(8,2);
    Val number(8,2):=100;
    BEGIN
    select num_factor into intFactor from TB_CONVERSION_UNIDAD_TMP where id_producto=intid_producto and rownum=1;
    select flg_operador into strFlg_Operador from TB_CONVERSION_UNIDAD_TMP where id_producto=intid_producto and rownum=1;
    if (strFlg_operador='M') then
        Cant:=Val*intFactor;
    else
        Cant:=Val/intFactor;
    end if;
    dbms_output.put_line('Factor :' || to_char(intFactor) || ' Operador ' || strFlg_Operador || ' Total : ' || to_char(Cant));
    END;Thanks for the help.

    Wrong forum!
    This is the sql developer forum and is not for sql or pl/sql questions.
    Please mark this question ANSWERED and if the below doesn't answer your question repost the question in the sql and pl/sql forum.
    >
    I want get the num_factor columns where's the condition i send is id_producto then validate if the column FLG_OPERADOR is 'M' or 'D' for the multiplication or division with the another parameter i send (val).
    >
    You've got a good start. Now you just need to BULK COLLECT the data and loop thru it. By the way you don't need two separate queries.
    set serveroutput on;
    DECLARE
    intFactor number(8,2);
    intID_Producto NUMBER(10):=126;
    strFlg_Operador CHAR(1);
    Cant number(8,2);
    Val number(8,2):=100;
    type tbl_factor is table of number(8,2);
    type tbl_flg is table of char(1);
    t_factor tbl_factor;
    t_flg tbl_flg;
    intID1 NUMBER(10):=40;
    BEGIN
    select num_factor into intFactor from TB_CONVERSION_UNIDAD_TMP where id_producto=intid_producto and rownum=1;
    select flg_operador into strFlg_Operador from TB_CONVERSION_UNIDAD_TMP where id_producto=intid_producto and rownum=1;
    if (strFlg_operador='M') then
        Cant:=Val*intFactor;
    else
        Cant:=Val/intFactor;
    end if;
    dbms_output.put_line('Factor :' || to_char(intFactor) || ' Operador ' || strFlg_Operador || ' Total : ' || to_char(Cant));
    select num_factor, flg_operador bulk collect into t_factor, t_flg
    from TB_CONVERSION_UNIDAD_TMP where id_producto=intid1;
    for i in 1..t_factor.count loop
       if (t_flg(i)='M') then
           Cant:=Val*t_factor(i);
       else
           Cant:=Val/t_factor(i);
       end if;
      dbms_output.put_line('Factor :' || to_char(t_factor(i)) ||
      ' Operador ' || t_flg(i) || ' Total : ' || to_char(Cant));
    end loop;
    END;
    /

  • Help with Contacts - IDs and Multiple Accounts

    Hello
    I am involved in the process of migrating accounts and contacts into ByDesign, but have come across a couple of questions that I can't seem to find an answer to anywhere!
    Firstly, is it possible to specify the 'Contact ID' reference range. I have found how to set the Account ID for suppliers and customers, and also how to set the Employee ID for employees within Fine Tuning, but cannot seem to find the same feature for the Contact ID. Is it possible to set this field up to have a certain amount of digits, and between certain values when automated?
    My other question regards having contacts linked to more than one account. I understand it is possible to have a contact linked to multiple accounts, but how? Is it possible from the Migration Templates? Is it a simple case of using the same Contact ID and information, but differing Account IDs on the 'Contacts' tab of the Template?
    Any help is much appreciated.
    Thanks
    Andrew

    You should not be using some other user's icloud account on your devices.  That's not how icloud is designed, because if you edit/delete data on the device that ties to the other user's icloud account, then those changes will automatically sync to their devices - something I don't think you two want happenning.
    If you want to keep your work data separate from personal data, then depending on what databases you want to use, like contacts or calendars, you could use a single icloud account and define groups in contacts, for exampe, some for work and some for personal.  Same thing with calendars, define different calenders for each environment.  Some databases like email may be problematic, however, I would think that work emails involve a non-icloud email account, so you could use the icloud email for personal use.
    The other approach is to define and use two icloud accounts and for each device, decide which account to use.  Having one device that uses both work and personal data would be a problem.

  • Help With split tunneling and multiple subnets behind asa

    Hello All,
    our vpn clients can no longer access internet while connected to vpn.
    I was hoping I could get an answer on here for an issue we are having. let me explain this with as little words as possible.
    here was old network layout:
    ASA
    192.168.1.1   ---->  the rest of the internal subnet (was only subnet in network)
    now
    ASA                              3560
    192.168.254.1/24 ----->192.168.254.2/24-->192.168.1.1/24
                                                                   192.168.2.1/24
    so what we did was route from 3560 to asa  so we would be able to have multiple subnets since our asa has base license.
    Our vpn with easy connect worked with our split tunneling before and now we made the change above and it no longer works. Can someone help me out as to why it no longer works and what changed need to be made to make it work.
    Thank you.
    ciscoasa# sh run
    : Saved
    ASA Version 8.2(2)
    hostname ciscoasa
    enable password 1N7bTm05RXLnBcUc encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.254.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address x.x.x.x 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    ftp mode passive
    clock timezone est -5
    same-security-traffic permit intra-interface
    access-list NoNat extended permit ip any 172.16.5.0 255.255.255.0
    access-list SplitTunnel standard permit 192.168.1.0 255.255.255.0
    access-list SplitTunnel standard permit 192.168.2.0 255.255.255.0
    access-list SplitTunnel standard permit 192.168.254.0 255.255.255.0
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool VPNPool 172.16.5.1-172.16.5.254 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list NoNat
    nat (inside) 1 0.0.0.0 0.0.0.0
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    route inside 192.168.1.0 255.255.255.0 192.168.254.2 1
    route inside 192.168.2.0 255.255.255.0 192.168.254.2 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    http server enable
    http 192.168.1.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set TransformSet1 esp-3des esp-md5-hmac
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    crypto dynamic-map DynamicMap1 1 set transform-set TransformSet1
    crypto map MainMap 999 ipsec-isakmp dynamic DynamicMap1
    crypto map MainMap interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    ntp server 64.90.182.55 source outside
    webvpn
    enable outside
    svc image disk0:/anyconnect-dart-win-2.5.0217-k9.pkg 1
    svc enable
    tunnel-group-list enable
    group-policy RenotreUsers internal
    group-policy RemoteUsers internal
    group-policy RemoteUsers attributes
    vpn-tunnel-protocol svc webvpn
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value SplitTunnel
    tunnel-group RemoteUsers type remote-access
    tunnel-group RemoteUsers general-attributes
    address-pool VPNPool
    default-group-policy RemoteUsers
    tunnel-group RemoteUsers webvpn-attributes
    group-alias Southeast-Security-VPN enable
    tunnel-group RemoteUsers ipsec-attributes
    pre-shared-key *****

    I think it could be your NAT statement. You should try an avoid using any unless you tunnel everything. Try making this change
    no access-list NoNat extended permit ip any 172.16.5.0 255.255.255.0
    object-group network INTERNAL_NETWORKS
    description Internal Networks
    network-object 192.168.1.0 255.255.255.0
    network-object 192.168.2.0 255.255.255.0
    network-object 192.168.254.0 255.255.255.0
    access-list NoNat extended permit ip object-group INTERNAL_NETWORKS 172.16.5.0 255.255.255.0
    You may have to re-add your NAT0
    nat (inside) 0 access-list NoNat

  • Help with sending emails to multiple users.

    Currently we have a process to send mail to muliple users by looping through the list of users and sending each individual an email
    <Action id='1' name='sendEmail' application='com.waveset.provision.WorkflowServices'>
    <Argument name='op' value='notify'/>
    <Argument name='template' value='$(template)'/>
    <Argument name='toUser' value='$(tuser)'/>
    <Argument name='catch' value='notificationException'/>
    </Action>
    The variable tuser contains a single email address.
    Is there any way to setup tuser to contain multiple email addresses?
    I have tried passing a list and a string separated by colons (ex: <s>[email protected]; [email protected]</s>) and neither one works.
    Question 2
    Is it a bad idea to try and send email to up to 50000 users at once using IDM? Besides the fact that I would need to search for specific users and get their email addresses based on their capabilities.

    Hi,
    For sending emails to multiple users, use to instead of toUser. Put the names in comma seperated values
    <Action id='0' application='com.waveset.provision.WorkflowServices'>
    <Argument name='op' value='notify'/>
    <Argument name='template' value='$(template)'/>
    <Argument name='to' value='$(to)'/>
    <Argument name='cc' value='$(cc)'/>
    <Argument name='catch' value='notificationException'/>
    </Action>
    You can use IDM to send emails.
    it will be a good idea to break down the email that you are sending into groups/batches. If possible, you can send email to DL s
    Else, you can segregate the users based on roles and send emails. This will reduce the load. Hope it helps
    Regards
    Arjun
    Edited by: arjun.sengupta on Dec 4, 2012 3:26 AM

  • Need help with Adobe documents - emailing multiple PDFs

    Can anyone out there help an old man? I'm new to all things Adobe but the only thing I can't seem to master is sending multiple PDFs in a single email, from Adobe documents. What am I missing here?

    Hi Craig,
    You can either Create a pdf portfolio of those files and send a single file to the user or you can select all the files you want to send at once while uploading and then send them in one go.
    Please revert back if you still face challenges in sending multiple pdf files at once.
    Regards,
    Rahul

  • Help with header field on multiple pages

    I am trying to print three multiple page documents.  The first document in the dat file has data in a header comment field.  The last two documents in the dat file do not have data for the header comment field. On the form I have defined this comment field as global.  When I print the documents the first document comment is being printed on the last two documents that should not have comments.
    If I remove the global condition for the comment field, then the comment is only printed on the first page of the first multiple page document.  Is it possible to print the comment on each page of the first multiple page document and not print the comment on the documents that should not have a comment?  Thanks for any help.

    Got it. Thank you. I'm having one other problem though. I
    keep getting this bizare message every time i save or try to use
    the template:
    The is an error at line 41 column 7 (absolute position 2486)
    of "~pathandfilename.dwt": Nested editable regions
    The only thing at line 41 is the <body> tag. I took all
    the formating out to try to trim this out... any thoughts about
    this one.
    Thanks G

  • Need help with displaying content on multiple pages

    Hi I'm kind of a dreamweaver newbie and i'm a little in over
    my head. I'm trying to design a web site with the same content
    appearing on multiple pages. Here's the current site...
    http://home.comcast.net/~gascec/cecnh20/index.html
    I'm trying to establish the top bar and side bars of links
    and the logo on each page from one point so i don't have to change
    forty pages if i update a link.
    I know there's a way to do this and i thought it was using a
    CSS page but i can't figure it out and i'm running out of time.
    Help

    Got it. Thank you. I'm having one other problem though. I
    keep getting this bizare message every time i save or try to use
    the template:
    The is an error at line 41 column 7 (absolute position 2486)
    of "~pathandfilename.dwt": Nested editable regions
    The only thing at line 41 is the <body> tag. I took all
    the formating out to try to trim this out... any thoughts about
    this one.
    Thanks G

  • Help with running iWeb on multiple computers and find the current site

    I have two Macs and MobileMe. I have usually run iWeb on the laptop and have my website on it. I thought I saved the site in MobileMe. When I go to the desktop and open iWeb it opens up an old version of my site. I search for Domain and none of the options are the current site. On my laptop (the current iWeb version) I opened MobileMe's iDisk and tried a couple of the "Domains" that live on it and none of them are the current version. Now, I can't even get my laptop to open the one I had opened a few moments ago beacuse I can't find the newest domain. So, where is my current domain/ I can't find it.
    I do have a folder on iDisk called "Sites" that contains the HTML files and folders of my current site but I can't seem to get this to open in iWeb. But, this folder does contain the current version but none of the Domain files I have opened refer to these I guess.
    What should I do?
    Guy
    PS I am running the latest iWeb on both computers

    Welcome to the Apple Discussions. As you know for both of you to edit and update the web site both of you must be using the same version of iWeb and working on the same Domain.sites2 file.
    See MacWorld's online article Managing an iWeb site from multiple Macs. However, there are a couple of caveats: 1 - only one can be editing and uploading at a time; 2 - allow plenty of time for Dropbox to update all copies of the domain file.
    What I would do is when you plan on editing the site copy the domain file that's in your Dropbox as a backup. Do you editing and publish. If something goes wrong you'll have the good domain file that was copied just before you started editing. If the site is small and, thus, the domain file the updating will be better insured. Keep both computers online much of the time so the updates will go thru as soon as they are made.
    OT

  • Help with sql query for multiple years

    Hello,
    I am new to SQL and am trying to perform a query that includes multiple years from 2005 to 2011.
    I was trying to enter the following query but received a message that said "Operand should contain 1 column(s)"
    SELECT * FROM `auto_2` WHERE `year` LIKE (2005, 2006, 2007, 2008, 2009, 2010, 2011);
    What am I doing wrong here? Please advise...
    Thanks

    Hi and welcome to the forum,
    You cannot use LIKE here, that is for pattern matching.
    You need either IN operator, or less known =ANY.
    Regards
    Peter

  • Help with jfree regarding plotting multiple lines in a line graph

    hi,
    i have
    < time>
    < volume>
    i have sucessfully used this data to plot a line graph(1 line)
    now i have
    <time> <time2>
    <volume> <volume2>
    how do i put this values into a single line graph? that means, i will have a line graphs with 2 lines.
    Help appreciated. Thanks Alot

    any help? still need help. thanks

  • Need help with Replace Metadata then multiple Save script

    I am attempting to create a javascript to run on a folder of PSDs. I need it to:
    1. Replace image Metadata with an existing Metadata Template called "UsageTerms".
    2. Play an existing Action "Prep_PrintRes". (The action sharpens and converts to 8-bit)
    3. Append "_PrintRes" to the filename. (ie OriginalPSDName_PrintRes.jpg)
    4. Save the file as a 12 Quality JPEG to specific folder on my hard drive, "D:/Transfer".
    5. Play an existing Action "Prep_Magazine" (The action resizes, sharpens, and converts to CMYK)
    6. Append "_Magazine" to the filename. (ie OriginalPSDName_Magazine.jpg)
    7. Save the file as a 10 Quality JPEG WITH NO EMBEDDED PROFILE to "D:/Transfer".
    8. Play an existing Action "Prep_Screen". (The action sizes, sharpens, and converts to sRGB)
    9. Append "_ScreenRes" to the filename (ie OriginalPSDName_ScreenRes.jpg)
    10. Save the file as an 8 Quality JPEG to "D:/Transfer"
    If anyone is available to help me get started with this I would greatly appreciate it. I can do a minimal amount of Visual Basic but Javascript is alien to me. Thanks so much!

    Try the following as the custom calculate script:
    // Sum the field values, as numbers
    var sum = +getField("LaborCost").value;
    sum += +getField("MaterialCost").value;
    sum += +getField("EquipmentCost").value;
    // Set this field value
    event.value = sum > 0 ? sum : 0;
    For the other one, change the last line to:
    event.value = sum < 0 ? sum : 0;

Maybe you are looking for

  • Defaulting the Payment card details

    Hello, I have created the payment card details in the customer master [Payment transaction-payment cards]. Now when i am creating the sales order via VA01, the card data is not defaulted to the sales order. what configuration have i missed for the sa

  • Resolving block corruption issue

    Hi All, In one of our database a block in a datafile gotcorrupted, but I am not getting any object related to the corrupted. ESPSSTOR@ci418erx [home/oracle] $ dbv file=/oradata/ESPSSTOR/data03.dbf blocksize=8192 Page 697507 is influx - most likely me

  • Handfree curves in Graphs?

    Hi, Is there anyway that i could instill a handfree curves in Query Graph as a trend tracer just by combining the edges of the columns? Raj

  • NO SOLN FOUND: ERROR IN MOUSE NAVIGATION.....PLS HELP!!

    HI all! Migration from Froms 4.5 > 5.0 I have a problem. in one of the canvases, the user is not able to enter the mouse in any of the fileds of the second block. but however, the user can go to that field using the tab key! WHEN THE USER ENTERS THE

  • Smart Sharpen Incredibly Slow 16-bit mode, Vista 64

    I recently switched to a VISTA 64 machine, Quad, with 6 GB ram. I export 16-bit files from LR. Now the Smart Sharpen routine is horrendously slow - taking upwards of 5 or more minutes to sharpen a 5700x4300px image. If I change the mode down to 8-bit