ACE: How to implement multiple services on a pair of servers

We plan to loadbalance two mail servers which offer several services like http, imap and pop3. Those services are independent from each other.
Our idea is to use an own serverfarm for each service, something like that :
probe http http-probe
probe imap imap-probe
probe pop3 pop3-probe
serverfarm host http-farm
predictor leastconns
probe http-probe
rserver server1
inservice
rserver server2
inservice
serverfarm host imap-farm
predictor leastconns
probe imap-probe
rserver server1
inservice
rserver server2
inservice
serverfarm host pop3-farm
predictor leastconns
probe pop3-probe
rserver server1
inservice
rserver server2
inservice
Is that approach meaningful at all ?
Can we use a common vip for all serverfarms or do we have to assign a unique vip for each farm ?
How do we distinguish between the different requests ?
Has somebody a sample configuration for that ?
Thank you very much in advance.

If the 3 services run on the same port, using different serverfarm does not make sense just because the problem would be different.
If they run on different ports, then you have the distinction that you need to split the config.
Gilles.

Similar Messages

  • How to implement multiple Value Helps within the same Application ??

    Dear Experts,
    I want to implement multiple value helps in the same view.For that I have declared exporting parameters of type 'wdy_key_value_table.' within the component controller for each of the value helps.While I do activate and test the application I get the following error :
    The following error text was processed in the system HE6 : A row with the same key already exists.
    The error occurred on the application server hsdnt24s11_HE6_00 and in the work process 4 .
    The termination type was: RABAX_STATE
    The ABAP call stack was:
    Method: VALUESET_BSART of program /1BCWDY/9VSHJWRNR0EZPKFT3ZKC==CP
    Method: IF_PO_VIEW1~VALUESET_BSART of program /1BCWDY/9VSHJWRNR0EZPKFT3ZKC==CP
    Method: WDDOINIT of program /1BCWDY/9VSHJWRNR0EZPKFT3ZKC==CP
    Method: IF_WDR_VIEW_DELEGATE~WD_DO_INIT of program /1BCWDY/9VSHJWRNR0EZPKFT3ZKC==CP
    Method: DO_INIT of program CL_WDR_DELEGATING_VIEW========CP
    Method: INIT_CONTROLLER of program CL_WDR_CONTROLLER=============CP
    Method: INIT_CONTROLLER of program CL_WDR_VIEW===================CP
    Method: INIT of program CL_WDR_CONTROLLER=============CP
    Method: GET_VIEW of program CL_WDR_VIEW_MANAGER===========CP
    Method: BIND_ROOT of program CL_WDR_VIEW_MANAGER===========CP
    I dont know how to implement multiple value helps.Need your help on this.
    Regards,
    Mamai.

    Hi
    Hint is : A row with the same key already exists it means , It is assigning the same value/Key to row and you are calling it at WDDOINIT  so it giving error at the time of initialization .
    Better way to do the coding at some event in view OR if not possible than just execute the first value help in wddoinit later clear all the value before gettig the other Value help. Code it at WdDoModify View to get its run time behaviour.
    BR
    Satish Kumar

  • How to implement sheduling services in Ep

    Hi all,
    I would like to know how to implement scheduling services in ep in the sense .. running jobs in portal .
    Any pointers to this would be of great help.
    Thanks& Regards,
    Uma,

    Hi Uma,
    If you have not already done so, try the following weblog by Prakash.
    <b>Did you know you can schedule jobs in portal using KM's Scheduler Task?>
    Hope this helps you
    Ranjith

  • Oracle BI Enterprise Edition - How to implement "Scheduling Services"

    hi,
    Currently doing some analysis of OBIEE for project specification doc.
    Please help me for the below need.
    1. How to implement "Scheduling Services" in OBIEE , terms of;
    a.Integration with 3rd party schedulers
    b.Job management
    c.Job scheduling
    d.Notifications
    reg,kannan
    Edited by: user4810433 on Nov 13, 2008 8:59 PM

    hi,
    try this below links
    http://www.oracle.com/technology/obe/obe_bi/bi_ee_1013/delivers/delivers.htm
    http://oraclebizint.wordpress.com/2007/09/13/oracle-bi-ee-10133-configuring-delivers-ibots/
    Regards
    Naresh
    Edited by: Naresh Meda on Nov 13, 2008 9:03 PM

  • How to implement Multiple Roadmap step with in a roadMap

    Hi,
    I am trying to implement Multiple roadmap step with in a roadMap.Can any one help me on this how to do it.
    As of now i have added Multiple roadmap step element with in my Road map navigation and assign a data source which contains single attribute steps. I am stuck here open question like
    1) How i map the view accordingly with the steps that are dynamically created
    2) Weather i have to create dynamic plugs? to handle it
    Can any one help me out or if you have any sample implementation please guide me through that link.
    Thanks in advance.
    Regards,
    Karthikeyan R

    Hi,
    1. In the View add a RoadMapUI element.
    2. Right click->Insert Steps (as many as required)
    3. Set the design property of the Roadmap step as standard / selected (Highlighted if set to "Selected")
    This is for a static approach i.e if there are 3 views, then in all the three views u repeat the procedure above and set the property as Selected for the required step.
    For dynamic selection of roadmap, bind the design property to context attribute of type WDRoadMapDesign and set the property thru code.
    Hope this helps you.
    Regards,
    Poojith MV

  • How to implement singleton service if i m using only jar and war component

    hello,
    in my application i m using only jar and war component .
    as i m not using EAR for deployment so i dont have weblogic-application.xml file.
    so in this case how i implement weblogic singleton service .and how to call active method

    From the documentation:
    After you have created a singleton service class using the SingletonService interface, you must define it as a singleton service within WebLogic Server. This singleton service object contains the following information:
    The path to the class to load as the singleton service.
    The preferred server and other candidate servers for the singleton service.
    The following excerpt from the cluster element of config.xml shows how a singleton service is defined:
    <singleton-service>
    <name>SingletonTestServiceName</name>
    <user-preferred-server>myManaged1</user-preferred-server>
    <class-name>mycompany.myprogram.subpackage.SingletonTestServiceImpl</class-name>
    <cluster>myCluster</cluster>
    </singleton-service>
    Note that the config.xml is located in the <domain-home>/config directory

  • ACE 4710 multiple services running on load balanced Servers

    Our Exchange 2010 hub servers run multiple services/ports:  smtp, www, pop3,135, 143, https, 993, 995, 6001,6002,6003,60200,60201,8400, and 8402
    what is the best way of balancing these servers so that if only one of the services failed on a server, it would switch only the failed service to remaining servers.
    At present I only use an smtp probe, so as log as that sevrice is running the server is marked good. It seems to me the setup could get quite complicated so any responses welcome.

    Jorge,
    Please see config below
    logging enable
    logging buffered 5
    logging monitor 5
    access-list ALL line 10 extended permit ip any any
    access-list ALL line 18 extended permit icmp any any
    ip domain-name simplot.com.au
    ip name-server 172.16.7.210
    ip name-server 172.16.5.228
    probe icmp icmp
    interval 7
    faildetect 2
    passdetect interval 30
    passdetect count 2
    receive 5
    probe tcp tcp25
    port 25
    interval 20
    passdetect interval 60
    passdetect count 2
    open 1
    rserver host chihub73
    description hub73
    ip address 172.16.6.196
    inservice
    rserver host chihub74
    description hub74
    ip address 172.16.6.197
    inservice
    serverfarm host Exchange
    description DSI servers
    failaction purge
    probe tcp25
    fail-on-all
    rserver chihub73
    inservice
    rserver chihub74
    inservice
    sticky ip-netmask 255.255.255.255 address source Sticky
    serverfarm Exchange
    class-map type management match-any EXCH
    201 match protocol snmp any
    202 match protocol https any
    203 match protocol telnet any
    204 match protocol icmp any
    class-map match-any EXCH_vip
    2 match virtual-address 172.16.93.2 tcp eq smtp
    3 match virtual-address 172.16.93.2 tcp eq www
    4 match virtual-address 172.16.93.2 tcp eq pop3
    5 match virtual-address 172.16.93.2 tcp eq 135
    6 match virtual-address 172.16.93.2 tcp eq 143
    7 match virtual-address 172.16.93.2 tcp eq https
    8 match virtual-address 172.16.93.2 tcp eq 993
    9 match virtual-address 172.16.93.2 tcp eq 995
    10 match virtual-address 172.16.93.2 tcp eq 6001
    11 match virtual-address 172.16.93.2 tcp eq 6002
    12 match virtual-address 172.16.93.2 tcp eq 6003
    13 match virtual-address 172.16.93.2 tcp eq 60200
    14 match virtual-address 172.16.93.2 tcp eq 60201
    15 match virtual-address 172.16.93.2 tcp eq 8400
    16 match virtual-address 172.16.93.2 tcp eq 8402
    policy-map type management first-match EXCHANGE
    class EXCH
    permit
    policy-map type loadbalance first-match ldap-slb
    class class-default
    sticky-serverfarm Sticky
    policy-map multi-match multi-vips
    class EXCH_vip
    loadbalance vip inservice
    loadbalance policy ldap-slb
    loadbalance vip icmp-reply
    nat dynamic 6 vlan 93
    interface vlan 93
    description client server vlan
    ip address 172.16.93.4 255.255.255.0
    peer ip address 172.16.93.1 255.255.255.0
    access-group input ALL
    nat-pool 6 172.16.93.8 172.16.93.20 netmask 255.255.255.0 pat
    service-policy input EXCHANGE
    service-policy input multi-vips
    no shutdown
    ip route 0.0.0.0 0.0.0.0 172.16.93.254
    snmp-server contact "Comms team"
    snmp-server location "Chifley park CR"
    snmp-server community OVSimplot group Network-Monitor
    snmp-server trap-source vlan 93

  • How to implement web service client timeout

    I'm trying to implement a web service client using JAX-RPC specification and the client is generated by clientgen utility. We are using weblogic8.1(sp5).
    How do I control the connection timeout and data transmission timeout? I have tried:
    BindingInfo.setTimeout() method and stub._setProperty("weblogic.webservice.rpc.timeoutsecs", "1" /* secs */);
    and they don't seem to be working...
    I have searched the web service documentation and didn't found any mentioning on this. Can someone shred some light on this?
    Thanks.
    Ren
    null

    Hi,
    I had a problem too for setting the timeout of a webservice client. but i didn't find any thing on this.
    But there is a work around for this see if it suits you but for this you have to use Apache AXIS webservice api to generate the client in that Api you have the Stub.timeOut() function to over come this problem
    Cheers !!
    Vivek:-)

  • How to implement a service that runs once a day?

    Hi all,
    is there a service or so available that waits for example 24 hours and runs every day for example at 9:00 am?
    I know there is the Wait service with the scheduleWait operation, but I can only specify days, hours or minutes. So I can not use this service to specify a time when to run. How is this possible?
    Thanks in advance!
    Paul

    Design your process somewhat similar to the above model.
    Invoke your process (only one time) at 9 AM.
    This is the simplest solutions. The other way is to write a custom DSC.
    Nith

  • How to implement multiple files upload

    RichFaces has a cool component for uploading multiple files with flash. But we use ADF and we need to deploy it on a 10G server. With multiple upload I mean that it should be possible to press a browse button and in the file dialog select multiple files instead of the standard one file.
    Do you know any open source flash fileupload applications and do you have an example of how to integrate it with ADF?

    I have done that but rather then using a single <af:inputFile> to upload a file i have used multiple of the same and set their rendered property as true when user clicks on add another attachments. The trick to call a java method from the doDML method of entity object and writing your custom logic their. Also you need to used Partial Submit =true on the Submit button of the creation page so that page does not get submited and you do not loose the Uploaded File Objects when you press commit button.
    How to call method from doDML
    make your backing bean scope as session
    protected void doDML(int operation, TransactionEvent e) {
    if(operation==1){
    FacesContext ctx = FacesContext.getCurrentInstance();
    Class c[]=new Class[3];
    String s="rohit";
    oracle.jbo.domain.Number n=new oracle.jbo.domain.Number();
    c[0]=s.getClass();
    c[1]=s.getClass();
    c[2]=s.getClass();
    MethodBinding vb = ctx.getApplication().createMethodBinding("#{AddIwoAttachment.insert}",c);
    Object para[]=new Object[3];
    para[0] = getIwoNo();
    para[1]= getProjectNo().toString();
    para[2]= getRemarks();
    vb.invoke(ctx,para);
    // AddIwoAttachment o=(AddIwoAttachment)vb.getValue(ctx.getCurrentInstance());
    // System.out.println(o.fileName1);
    else{
    super.doDML(operation, e);
    Where MethodBinding vb = ctx.getApplication().createMethodBinding("#{AddIwoAttachment.insert}",c); creates the methodBinding to the same object whick backs the af:inputFile ActionListener and mehtodBinding .invoke calls the method and para is used to supply other attribute values.
    Hope this helps.
    Regards
    Rohit

  • How to implement multiple queues in one circular buffer?

    Spoiler (Highlight to read)
    Recently I have successfully shared data of 2D array among different vis in a project, using circular buffer.
    However, there is only one circular buffer allowed in one project for one data type.
    I want different vis, running and getting data from circular buffer in different speed, all getting data as a queue from circular buffer. Like the circular buffer's read continuous mode.
    The problem is that after a vi reads in continuous mode, the read data is deleted from the circular buffer. Then other vis can not use them any more and can not keep track where they should begin to read again.
    So if it is possible that there are multiple pointers or queues in circular buffer to keep track the progress of different vis, and data only update when it gets input from DAQ but not deleted when read?   

    LawrenceChong wrote:
    Spoiler (Highlight to read)
    Recently I have successfully shared data of 2D array among different vis in a project, using circular buffer.
    However, there is only one circular buffer allowed in one project for one data type.
    I want different vis, running and getting data from circular buffer in different speed, all getting data as a queue from circular buffer. Like the circular buffer's read continuous mode.
    The problem is that after a vi reads in continuous mode, the read data is deleted from the circular buffer. Then other vis can not use them any more and can not keep track where they should begin to read again.
    So if it is possible that there are multiple pointers or queues in circular buffer to keep track the progress of different vis, and data only update when it gets input from DAQ but not deleted when read?   
    THe last time I wrote a multi-subscriber cirular buffer was in LV 6. Since then I have found that polymorphic queues perform much better so I now use multiple queues. One queue for each subscriber of the data. The subscribers are then responsible for maintaining their own histories.
    So just use multiple queues.
    Ben
    Ben Rayner
    I am currently active on.. MainStream Preppers
    Rayner's Ridge is under construction

  • Bapi_po_create1 ,No account assignment exist for service line 0000000000'. for po limits,how to create multiple service items in service po

    hi,
    Hello all, please help!! I used function BAPI_PO_CREATE1 to create PO with limit item but function returned message error '518 No account assignment exist for service line 0000000000'. Can anyone give me an idea to slove this problem?
    i am passing po header, po headerx, po item , po itemx, po account, po accountx, po limits, po services, po service values, to bapi. if i comment package number in po limits structure , po was creating but limits data not updating in po., if i pass package number i am getting above error.
    Thanks In Advance,
    regards

    hi Dinesh,
    am also having same error for bap po create1 . did it get resolved for you? please help its urgently needed for me here

  • How to implement multiple (not redundant) 2100 series controllers?

    We are using H-REAP and have the 2125 WAC  at a central location. The APs are given the controller address in DHCP option 43.
    The question is this.  When I reach the point that I have more APs than one controller allows I want to add another controller. Do I have to manage which APs connect to each controller or can I give both controller addresses in the option 43 so the APs can figure it out and use whichever controller has room for them at the time?

    Hi,
    You could give in both WLC ip addresses in DHCP option 43 and APs should join fine.
    Once AP joins, you could actually set high availability and for few APs WLC1 can be made primary and for few APs WLC1 can be made secondary.
    Links :-
    step 5 : http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a00808714fe.shtml#p3
    High availability : http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008064a294.shtml#c4
    Regards,
    Madhuri

  • SSL: how to use Multiple Private key/Certificate pair for authentication.

    Hi all,
    i am implementing SSL in java using X509 Certificate/private key combination.
    i have two set of private key/certificate pair.
    one is factory default and another is generated at run time.
    my problem is to try ssl connection with both pairs on same tcp/ip connection.
    e.g. on server side: first try ssl connection with factory default certificate, if it fails try connecting with generated certificate on same tcp/ip connection.
    on client side: if generated certificate(this certificate was generated at server side) is present first perform server authentication using this certificate otherwise authenticate server with factory default certificate.
    can someone please help and let me know how do i need to configure both ends(client and server) for achieving the same.
    Thanks In Advance
    Saurabh Ahuja

    Client code does not contain any default truststore and needs a certificate for authentication.Of course it does. OpenSSL has a way of doing that: some kind of equivalent for the truststore. None of the stuff you've posted here about generating certificates at runtime has any bearing on that problem.
    It's like this. The idea of PKI with SSL is as follows:
    - the server has a private key and a signed certificate. Preferably it's signed by a CA that the client already trusts, otherwise if it's self-signed it has to be exported from the server's keystore and imported into the truststores of all the clients.
    - the client has a truststore that trusts the server, one way or the other, see above.
    - the server's private key is private to it. Nobody else has it. Nobody else can ever get it. If it ever leaks, the server is compromised, and server authentication via that private key now means absolutely nothing. You have lost security.
    - the server sends its cert to the client along with a digital signature signed by its private key.
    - the client (a) decides whether it trusts the cert, via its truststore, and (b) verifies the digital signature, which establishes that the server owns the certificate.
    At this point the server is authenticated to the client and the SSL connection is open. It can now be used as an ordinary socket connection.
    If you want client authentication too, you need all the above in reverse as well, i.e. reading server for client and client for server throughout. Note particularly that each client must have its own private key. Otherwise the private key isn't private, so signing something with it doesn't establish ownership, so client authentication isn't valid.
    You need to understand all this stuff and relate it to the apparently broken security design of your application. Generating a private key and a certificate at runtime is complete nonsense within the context of PKI and SSL. It proves nothing, establishes nothing, authenticates nothing; it just wastes time.

  • [Forum FAQ] How to use multiple field terminators in BULK INSERT or BCP command line

    Introduction
    Some people want to know if we can have multiple field terminators in BULK INSERT or BCP commands, and how to implement multiple field terminators in BULK INSERT or BCP commands.
    Solution
    For character data fields, optional terminating characters allow you to mark the end of each field in a data file with a field terminator, as well as the end of each row with a row terminator. If a terminator character occurs within the data, it is interpreted
    as a terminator, not as data, and the data after that character is interpreted and belongs to the next field or record. I have done a test, if you use BULK INSERT or BCP commands and set the multiple field terminators, you can refer to the following command.
    In Windows command line,
    bcp <Databasename.schema.tablename> out “<path>” –c –t –r –T
    For example, you can export data from the Department table with bcp command and use the comma and colon (,:) as one field terminator.
    bcp AdventureWorks.HumanResources.Department out C:\myDepartment.txt -c -t ,: -r \n –T
    The txt file as follows:
    However, if you want to bcp by using multiple field terminators the same as the following command, which will still use the last terminator defined by default.
    bcp AdventureWorks.HumanResources.Department in C:\myDepartment.txt -c -t , -r \n -t: –T
    The txt file as follows:
    When multiple field terminators means multiple fields, you use the below comma separated format,
    column1,,column2,,,column3
    In this occasion, you only separate 3 fields (column1, column2 and column3). In fact, after testing, there will be 6 fields here. That is the significance of a field terminator (comma in this case).
    Meanwhile, using BULK INSERT to import the data of the data file into the SQL table, if you specify terminator for BULK import, you can only set multiple characters as one terminator in the BULK INSERT statement.
    USE <testdatabase>;
    GO
    BULK INSERT <your table> FROM ‘<Path>’
     WITH (
    DATAFILETYPE = ' char/native/ widechar /widenative',
     FIELDTERMINATOR = ' field_terminator',
    For example, using BULK INSERT to import the data of C:\myDepartment.txt data file into the DepartmentTest table, the field terminator (,:) must be declared in the statement.
    In SQL Server Management Studio Query Editor:
    BULK INSERT AdventureWorks.HumanResources.DepartmentTest FROM ‘C:\myDepartment.txt’
     WITH (
    DATAFILETYPE = ‘char',
    FIELDTERMINATOR = ‘,:’,
    The new table contains like as follows:  
    We could not declare multiple field terminators (, and :) in the Query statement,  as the following format, a duplicate error will occur.
    In SQL Server Management Studio Query Editor:
    BULK INSERT AdventureWorks.HumanResources.DepartmentTest FROM ‘C:\myDepartment.txt’
     WITH (
    DATAFILETYPE = ‘char',
    FIELDTERMINATOR = ‘,’,
    FIELDTERMINATOR = ‘:’
    However, if you want to use a data file with fewer or more fields, we can implement via setting extra field length to 0 for fewer fields or omitting or skipping more fields during the bulk copy procedure.  
    More Information
    For more information about filed terminators, you can review the following article.
    http://technet.microsoft.com/en-us/library/aa196735(v=sql.80).aspx
    http://social.technet.microsoft.com/Forums/en-US/d2fa4b1e-3bd4-4379-bc30-389202a99ae2/multiple-field-terminators-in-bulk-insert-or-bcp?forum=sqlgetsta
    http://technet.microsoft.com/en-us/library/ms191485.aspx
    http://technet.microsoft.com/en-us/library/aa173858(v=sql.80).aspx
    http://technet.microsoft.com/en-us/library/aa173842(v=sql.80).aspx
    Applies to
    SQL Server 2012
    SQL Server 2008R2
    SQL Server 2005
    SQL Server 2000
    Please click to vote if the post helps you. This can be beneficial to other community members reading the thread.

    Thanks,
    Is this a supported scenario, or does it use unsupported features?
    For example, can we call exec [ReportServer].dbo.AddEvent @EventType='TimedSubscription', @EventData='b64ce7ec-d598-45cd-bbc2-ea202e0c129d'
    in a supported way?
    Thanks! Josh

Maybe you are looking for

  • Microsoft Office 2013 is not working on Windows 8

    I downloaded Microsoft office 2 days ago.  Since then Window 8.1 update has basically attempted to ruin my life.  Since I attempted to download the update (which will not download properly no matter how many times I try) Microsoft office will not ope

  • Possible to use old macbook (mini dvi port) with 24 in LED display?

    Is there a combo of adaptors that will allow me to use my older macbook (mini-DVI port) with the new apple LED screens- i.e. adaptors allowing mini-DVI to mini displayport connector that comes with monitor?

  • Time Capsule and windows 7

    Just installed a new time capsule. I have a MacBook and my wife has a pc. I am able to get on fine. I downloaded airport utility for windows 7 from Apple support for her, but when I open network preferences I can only get on the guest site from the p

  • PO PDF Error - File does not Begin with '%PDF-'

    Hi, I am working on Implementing PO PDF with XML data and RTF Template. I have created a new template in XML Publisher and followed the following set up steps Setup / Organizations / Purchasing Options / Control TAB / set 'PO Output Format' = 'PDF' s

  • Best Approach for Reporting on SAP HANA Views

    Hi, Kindly provide information w.r.t the best approach for the reporting on HANA views for the architecture displayed below: We are on a lookout for information mainly around the following points: There are two reporting options which are known to us