ACE source IP based predictor

Hi
I know that if we use source IP based predictors, the ACE would use a hash of the source IP to load balance the traffic. Is there is capability to make this process deterministic. In other words, I have tthree client subnets accessing the web servers on the same VIP. I want the traffic from subnet 1 to go to server 1 and traffic from subnets 2 and 3 to be loadbalanced to the rest of the servers
any idea on how to get this done ?

HI Dinuka,
Session persistence (stickiness) based on client source IP address or HTTP cookies are recommended to be configured on the Cisco ACE for this flow.
IP Address Stickiness
You can use the source IP address, the destination IP address, or both to uniquely identify individual clients and their requests for stickiness purposes based on their IP netmask. However, if an enterprise or a service provider uses a megaproxy to establish client connections to the Internet, the source IP address no longer is a reliable indicator of the true source of the request. In this case, you can use cookies or one of the other sticky methods to ensure session persistence.
Here can be the sample configuration:
resource-class websrv
limit-resource all minimum 0.00 maximum unlimited
limit-resource sticky minimum 20.00 maximum equal-to-min
rserver host webserver1
ip address 10.10.10.1
inservice
rserver host webserver2
ip address 10.10.10.2
inservice
rserver host webserver3
ip address 10.10.10.3
inservice
serverfarm host werbsrv1only
probe websrv
rserver webserver1 1000
inservice
serverfarm host werbsrv123
probe websrv
rserver webserver1 1000
inservice
rserver webserver2 1000
inservice
rserver webserver3 1000
inservice
ACE receives requests to the VIP on port 80 and translates them to port 1000 using the server farm configuration shown above.
The link to the websrv home page is http://websrv:1000/index.html. A probe to this link is configured on ACE as follows:
probe http websrv
port 1000
interval 2
faildetect 2
passdetect interval 2
request method get url /index.html
expect status 200 200
Session persistence can be established by tying the session to an IP address, that uniquely identifies the client.
Create a sticky-group
sticky ip-netmask 255.255.255.255 address source Client_subnet_1
timeout 10
serverfarm werbsrv1only
Change the server farm to the sticky-group:
policy-map type loadbalance first-match basic-slb
class class-default
sticky-serverfarm werbsrv1only
sticky ip-netmask 255.255.255.255 address source Client_subnet_2
timeout 10
serverfarm werbsrv123
sticky ip-netmask 255.255.255.255 address source Client_subnet_3
timeout 10
serverfarm werbsrv123
Here you can find the details in the below url :
http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/sticky.html#wp1004411
I have also attached a jpeg for your reference.
Hope you will get the idea how to use the sticky based on IP address.
http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/sticky.html#wp1004411
Here you can find sample config of similar type:
http://www.cisco.com/en/US/prod/collateral/modules/ps2706/ps6906/prod_white_paper0900aecd804edab0.html
Thanks and regards,
Sachin Garg
Senior Specialist Security
HCL Comnet Ltd.
http://www.hclcomnet.co.in
A-10, Sector 3, Noida- 201301
INDIA
Mob: +91-9911757733
Email: [email protected]

Similar Messages

  • Switch to "Source Code-Based" mode in class builder

    hi,
    while doing the tutorial
    http://help.sap.com/saphelp_nwpi71/helpdata/en/67/6b5bbb681e4f10b44bc2d6c4167b02/content.htm
    i came across the step,
    ... Switch to Source Code-Based mode , in the class builder,
    but in my workbench it is not available.
    i searched on sdn, and saw the link
    [Settings of the Class Builder|http://help.sap.com/saphelp_nwpi71/helpdata/en/67/6b5bbb681e4f10b44bc2d6c4167b02/content.htm]
    it shows there must be an option for
    Source Code-Based Class Builder  -  If you choose this option, the system opens the Source Code-Based Class Builder by default.
    but in my system, i can see all other options in the Utilities->Settings-Classbuider page, except the option of Source Code-Based Class Builder
    could this be related to my permissions or our version of sap system.
    madhu_1980

    [ABAP documentation indicates it is available as of 7.0 ehp 2|http://help.sap.com/abapdocu_70/en/ABENNEWS-710-TOOLS.htm#!ABAP_MODIFICATION_2@2@]

  • ACE load balance based on Source IP Address

    Hi Cisco  Support,
    I have question  related to Cisco ACE behavior in term to taking a decision based on source  address
    I currently have two  servers sits behind ACE part of one server farm, these servers are load balanced  via one VIP on ACE module and every things looks fine.
    Now service  owners want to replace these old servers with new hardware hence before the  migration we need to make sure these new servers are working as required standard hence  need to create a testing scenario for new servers along with old server. The problem is that number of third party partners are accessing existing servers by hitting VIP on ace and we  can't engage all our partner to participate in this test therefore decided to  engage only one partner to carry our test with us.
    For that reason can  we some how configure the ACE so when packet arrive on ACE from one test partner  mentioned above, ACE send only that partner's traffic based on it's source address  (define via class/policy map on ACE if possible) towards new servers in the existing server  farm and not to the old server in the same server farm.
    Thanks for your  support

    Hi,
    Just to put some config sample that might help you to get this done.
    First create the new rservers and include them under a new serverfarm (New-APP)/
    serverfarm host Webfarm
      rserver SVR1
        inservice
      rserver SVR2
        inservice
    serverfarm host New-APP
      rserver New-1
        inservice
      rserver New-2
        inservice
    - Same VIP already working.
    class-map match-all VIP-HTTP
      2 match virtual-address 10.10.10.10 tcp eq www
    - Create a new class that will include your partner's IP(s).
    class-map type http loadbalance match-any 3rd-Party
      2 match source-address 200.200.200.1 255.255.255.255 
      3 match source-address 200.200.200.10 255.255.255.255 
    Modify your current first-match policy to put the new class on top so that all the traffic matched by the statement above (IP) will be redirected to the new farm with the new APP, any other traffic that does not match the "rule" will be sent to the old serverfam with the old app.
    policy-map type loadbalance first-match L7-SLB
      class 3rd-Party
        serverfarm New-APP
      class class-default
        serverfarm Webfarm
    Since you already have LB working then this is it, nothing needs to be added under the multi-match policy nor interface.
    HTH
    Pablo

  • Problem creating a 'used sources' list based on EXIF data in InDesign CS5

    Hello everyone,
    I recently started to use InDesign CS5 to work on school projects. These projects regularly require us to have a list of sources, not only for citations and referenced work, but also for images. As I sometimes make quite long documents, keeping track of what image is where, and where I got it from, gets tedious.
    I had the idea of generating a caption based on EXIF data, which I'd move to the pasteboard, and group it with the image. The text in the caption has a seperate, numbered paragraph style. On one of the last pages, I generate a table of contents, which the numbered paragraph style selected. I chose to display it using another paragraph style, without page numbers.
    What I want to have as the end result is:
    Table of contents
    1. <Title>. <Author> (<Creation Date>). Retrieved <Date Placed> through <Description>
    The captions display correctly, as shown above in the body of the table of contents. The table of contents itself however, shows only the numbering in front of it, and not the variables.
    I already tried converting the live captions to static captions, but that doesn't work. Does anyone have an idea how to solve this?

    Hello everyone,
    I recently started to use InDesign CS5 to work on school projects. These projects regularly require us to have a list of sources, not only for citations and referenced work, but also for images. As I sometimes make quite long documents, keeping track of what image is where, and where I got it from, gets tedious.
    I had the idea of generating a caption based on EXIF data, which I'd move to the pasteboard, and group it with the image. The text in the caption has a seperate, numbered paragraph style. On one of the last pages, I generate a table of contents, which the numbered paragraph style selected. I chose to display it using another paragraph style, without page numbers.
    What I want to have as the end result is:
    Table of contents
    1. <Title>. <Author> (<Creation Date>). Retrieved <Date Placed> through <Description>
    The captions display correctly, as shown above in the body of the table of contents. The table of contents itself however, shows only the numbering in front of it, and not the variables.
    I already tried converting the live captions to static captions, but that doesn't work. Does anyone have an idea how to solve this?

  • Changed source address based on destination IP

    Hello,
    Suppose I had the following configuration in an IOS router
    interface <interface type/number>
     ip address 1.1.1.3 255.255.255.0 secondary
     ip address 1.1.1.2 255.255.255.0
    ip route 0.0.0.0 0.0.0.0 1.1.1.1
    access-list standard INTERNET_BOUND_ACL
     permit <lan subnet-id> <lan wildcard>
    ip nat inside source list INTERNET_BOUND_ACL interface <interface type/number> overload
    I need to change the source inside global IP address based on the destination outside global IP address.
    Example: I need our source IP to be 1.1.1.3 when I ping 8.8.8.8
    How would i accomplish this?

    Hi,
    You would need to use two NAT pools and two different ACLs to separate your internal clients depending on the destination they want to communicate with, and to subsequently NAT them using a selected NAT pool. For example:
    ip access-list extended NAT_2
      permit ip <LAN Network> <Wildcard> <DestinationX> <WildcardX>
    ip access-list extended NAT_3
      permit ip <LAN Network> <Wildcard> <DestinationY> <WildcardY>
    ip nat pool NATPOOL_2 1.1.1.2 1.1.1.2 netmask 255.255.255.0
    ip nat pool NATPOOL_3 1.1.1.3 1.1.1.3 netmask 255.255.255.0
    ip nat inside source list NAT_2 pool NATPOOL_2 overload
    ip nat inside source list NAT_3 pool NATPOOL_3 overload
    Exactly one of the ACLs should actually contain an entry saying
    permit ip <LAN Network> <Wildcard> any
    to make sure that the internal network gets translated to some of the two public addresses even if itt does not communicate with any specific destination IP.
    Do you believe this could be a workable solution for you?
    Best regards,
    Peter

  • ACE load balancing based on URL

    I am trying to send traffic to one server or another based on the URL. I want traffic to foo.com/selfserv to direct to server A and traffic to foo.com/webui to direct to server B. I found URL inspection etc but I am not sure how to apply it the scenario as I do not want the ACE to inspect all inbound HTTP requests.

    The ACE performs regular expression matching against the received packet data from a particular connection based on the HTTP URL string. To configure a class map to make Layer 7 SLB decisions based on the URL name and, optionally, the HTTP method, use the match http url command in class-map HTTP load balance configuration mode.
    The ACE performs regular expression matching against the received packet data from a particular connection based on the RTSP URL string. You can configure a class map to make Layer 7 SLB decisions based on the URL name and optionally, the RTSP method, by using the match rtsp url command in class-map RTSP load balance configuration mode.
    Configuring Traffic Policies for Server Load Balancing:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/classlb.html

  • I want to update source code based

    Hi Guru ,
    My requirement is like - i want to replance all name space (/ABC) to (/XYZ) in All table , Program .
    Please suggest which is better way for that.
    Example.
    /PAYMETRC/PM30  to /XYXMETRC/PM30 like Remane .
    Same thingsh should be replace in source code like in source code - table is USING /PAYTABLEPARAM TO /XYZTABLEPRAM.
    Same in Structre - Data Field , Data Element and Domain,,.. etc.
    Please suggest what is best way for taht can we do it programatically and Manul.
    Thanks
    Durgesh

    Hi Soumya,
    Its not standard code . Its all Z programe more than 2000 and using only z table . in this i want replace all table name , data element , domain to customer name space based on custom requirement .
    eq. Z table is using in ZPROGRAM  LIKE  ZBAAPARAM table to change customer name space ZABCPARAM and same in data element and domain with having custom declaration.
    That is only one simple example .
    As i know here by two way i can do --
    1. Manual
    2. Programatically.
    BY using manual is lot of time takan - more than 100000 object need to convert Z name to some othe z custom name space.
    Programatically it can fit or i dont know .
    Can any suggest me about this requirement.
    Regards
    Durgesh

  • Open source role based framework

    We have an application which is using :-
    1) spring framework/j2ee code at the backend
    2) while the front end is comprised of Adobe flex and action script. The app is web based.
    A need of the application at the moment is for a role based authorization framework, based on which a decision can be made as to which widgets/tabs/screens should be visible to the user and which should be hidden from him.
    Wanted to know
    1) if somebody was willing to share some of his experiences on a similar project.
    2) found and existing framework open source or otherwise helpful.
    3) would recommend one architecture over the other
    4) or anything else he would think might be beneficial to know.
    Thanks

    Most app servers have some built in container managed security (for example Tomcat Realms) which may or may not meet your requirements.

  • ACE 4710 Redirection based on incoming Spanish Language

    I have a customer that wants to redirect incoming traffic to a different url or host based on the end users language. Spanish in particular. What is the best way to accomplish this task with the least amount of issues.
    Stan

    If you capture a sniffer trace of any HTTP traffic, you will see that every request contains a line like this :
    "Accept-Language: de"
    So, in this example the request contains information that the browser accept German (DE).
    If you sniff a request from a spanish browser, you should see a similar line with the "SP" letters.
    Then with ACE, you can match those requests with a class-map like below :
    AceC6k2/Admin(config)# class-map type http load Spanish
    AceC6k2/Admin(config-cmap-http-lb)# match http heade Accept-Language header-value sp
    AceC6k2/Admin(config-cmap-http-lb)#
    Then inside your policy-map you can use this class-map to differentiate spanish request from the others.
    policy-map type
    AceC6k2/Admin(config)# policy-map type loadbalance http first-match Web
    AceC6k2/Admin(config-pmap-lb)#
    AceC6k2/Admin(config-pmap-lb)# class-map Spanish
    <.....do something here for spanish browsers .....>
    AceC6k2/Admin(config-pmap-lb)# class class-default
    <..... do something here for the other browsers ......>
    gilles.

  • ACE / CSM: how does predictor staticload work?

    Hello,
    I tested to implement the new ACE feature "staticload" .
    It seems to be that the connections are not distributed according to my settings.
    Does anyone have an idea how this feature works?
    Our SW versions are:
    ===================
    core1#show module 9
    Mod Ports Card Type Model Serial No.
    9 4 SLB Application Processor Complex WS-X6066-SLB-APC SAD101803W7
    Mod MAC addresses Hw Fw Sw Status
    9 0017.0ee1.bddc to 0017.0ee1.bde3 1.9 4.3(1) Ok
    Mod Online Diag Status
    9 Pass
    ===================
    ===================
    core1#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) s72033_rp Software (s72033_rp-ADVIPSERVICESK9_WAN-M), Version 12.2(18)SXF12, RELEASE SOFTWARE (fc2)
    ===================
    If you need further information feel free to contact me.
    Best Regards,
    Thorsten

    Thorsten,
    sorry to say this, but if you do not understand the description, this probably means you don't need this feature.
    It was developped for one customer with a very specific requirement.
    the Load MUST be updated on the CSM by a script running on the server.
    The CSM will send ALL traffic to the server with the lowest load.
    If you do not update the load via a script, you end up with all traffic going to one server.
    Very few people have scripts running on the server updating the csm config.
    If you want to have some servers handling more traffic than others, you need to configure weight.
    This is describe here :
    http://www.cisco.com/en/US/docs/interfaces_modules/services_modules/csm/4.1.x/4.1.1/command/reference/m_r.html#wp1057123
    This works with predictor roundrobin or leastconn.
    Gilles.

  • ACE Source NAT

    Hi Team,
    I have ACE implemented in the routed mode.We have 2 servers and 2 users in the same vlan.
    2 of the servers are getting loadbalanced.Now the other 2(users) which are not getting load balanced want to access the severs using in VIP for the load balanced servers.
    Now the issue is all the servers are having the same subnet, How should i proceed in this can i have the sample configuration regarding this.

    Hi,
    configuration example that may be helpful for u.
    class-map match-all SNAT
    2 match source-address 10.10.10.0 255.255.255.0
    policy-map multi-match L4
    class HTTP-SFARM
    loadbalance vip inservice
    loadbalance policy WEB-PM
    loadbalance vip icmp-reply
    class SNAT
    nat dynamic 100 vlan 31
    interface vlan 31(Server Vlan)
    ip address 10.10.10.2 255.255.255.0
    alias 10.10.10.1 255.255.255.0
    peer ip address 10.10.10.4 255.255.255.0
    mac-sticky enable
    access-group input 1
    nat-pool 100 1.1.1.100 1.1.1.100 netmask 255.255.255.255 pat
    service-policy input L4
    no shutdown
    ACE1/SP1# sh xlate
    TCP PAT from vlan31:10.10.10.10/1149 to vlan31:1.1.1.100/1025
    Regards,
    Rajesh

  • Sourcing Strategy based on Quantity Price Breaks and Risk

    The customer would like to optimize the supply chain cost by considering the quantity based price breaks at Raw Material Level and model the risk to source strategically with suppliers at SKU# Level and optimize the cost across the supply chain Network from Raw Material to FG
    Does SNO support modeling price breaks along with Risk associated by SKU# into cosideration to source raw material strategically?
    The FG cost is based on which Supplier the raw material is sourced from as the downstream processes depend on the raw material source.
    I do see similar capability listed on Llamasoft website w.r.t Strategic Sourcing. I would like to know if this capability is supported by SNO? If so how is it modeled in SNO?
    http://www.llamasoft.com/Solutions/StrategicSourcing.aspx

    Hi,
    Net order value is known ie we give value for the characteristicex: RS.100000 or 1 crore etc, but  effective price is unknown how can we mention that a charactristic value? I dont understand
    Regards

  • Rejecting a source file based on validation

    Hi,
    I hav an xls file as source.
    I want to check, whether one of its field matches the specified validation criteria.say "p_num>6" where p_num is a column name in d xls file.
    If the condition is not satisfied,then i dont want to process the file instead i want to jus reject the file and capture the error message.
    Can any1 help me rgarding this especially how to stop the processing of the file.
    Moreover, i also want to know, that by using procedures can i query xls files???
    Thanks in advance.

    Hi,
    Simply,
    Create a constraint in the target table with the condition and error message you want.
    Thanks,
    Guru

  • Changing region source SQL based on condition

    I have a reports region which displays the results from some SQL. Depending on the value of a page variable I need to run a different bit of SQL to get my results. At the moment I'm using 5 different regions and displaying the appropriate one and hiding the others, depending on the value of the page variable.
    It's a bit messy and I'm looking for a better way to do it. Is it possible to use a single region and change the SQL used as the region source after checking my page variable? e.g. something like this for the region source:
    IF :report_type = 1 THEN
    SELECT col1, col2, col3 from table1;
    ELSEIF :report_type = 2 THEN
    SELECT col1, col2, col3 from table2;
    ELSEIF :report_type = 2 THEN
    SELECT col1, col2, col3 from table3;
    END IF;..or something similar?
    Or is there an even easier way of doing this?

    Hello,
    Actually, as long as you're willing to live with some limitations, you can indeed do that with an interactive report.
    A while ago, I blogged about using pipelined functions with respective to generic charting -
    http://jes.blogs.shellprompt.net/2006/05/25/generic-charting-in-application-express/
    Using the same technique you can create a pipelined function which returns each of your different resultsets.
    The key limitation is of course that you need to return the same columns each time (in your example you are always returning 3 columns, it is just the table name that changes, so perhaps it might still be an acceptable solution to you).
    John.
    Blog: http://jes.blogs.shellprompt.net
    Work: http://www.apex-evangelists.com
    Author of Pro Application Express: http://tinyurl.com/3gu7cd
    REWARDS: Please remember to mark helpful or correct posts on the forum, not just for my answers but for everyone!

  • Open source projects based on Oracle technology

    Hello:
    Here's a project for the open source page at
    Open Source Projects for Oracle:
    http://www.oracle.com/technology/tech/opensource/projects.html
    The open source (GPL) ValueObjects Framework for ADF is available for download. It is a JDeveloper 10g 10.1.2 extension for building SOAP-compliant DTOs over ADF Business Components.
    http://www.sourceforge.net/projects/valueobjects
    Quick intro at http://valueobjects.sf.net
    Screenshots at http://valueobjects.sourceforge.net/screenshots/screenshots.html
    Thanks,
    - Zak
    [email protected]

    Hi,
    Jim is right.
    There is no way of converting/upgrading a VI to the newer version of LabVIEW without its block diagram. Below are a couple of KBs that discuss this issue:
    How Do I Recover My Block Diagram If I Saved My VI with Options and Selected Remove Diagrams?
    What Does it Mean When I Receive the Message "LabVIEW load error code 11"?
    Feroz

Maybe you are looking for