Addons on Static IP

Hello to all,
I am Working with SAP 2007 B PL 11,on server every Add-on working Properly But on the client system(Connected to SAP B1 using Static IP ) add-on is not working.It is showing add on 's on client system,started the add on,it is started successfuly but not showing any of the forms (Addon Forms) on client.
why not showing  any from on the client ?It is working fine on server system.
how to solve this
Regards,
Neetu

Hi Neetu,
Check the following thread
Client Pc's Issue
Forms are not opening
*Close the thread if issue solved.
Regards
Jambulingam.P

Similar Messages

  • What the best way to create User defined table with ADDON purpose

    Hi folks, how are you ?
    I´m beginner in development to business one, and I m studying to develop ISV addons.
    But, during my exercises and analisys, I learned that have two ways to create tables and fields in business one. One way is throght by wizard in business one using Tools Menu > Configuration Tools > User Defined Tables >
    Obs: I ´m using Business One Patch Level 9.
    Other way, is create the tables and fields using DI API
    But, my question is. When I develop one addon, or one UDO form that uses one set of user defined tables or used defined fields that where created by the first way (by wizard in B1), how I deploy this in other business one installation ? The package process will ensure the creation of this tables in another enviroment or I must implement the creation of user defined tables using DI API so that this code is called during the installation?
    If in cases of addon develop I must use DI API to create user defined tables, How can I use my classes with this responsibility in package process ?
    Thanks my friends.

    Hi Renan,
    You just need to put your logic in to the startup of your application, after you've established your connection to the UI API and DI API. All this will be triggered in the constructor of your main class.
    namespace MyNamespace
    public class MyAddon
      bool runAddon = true;
      bool initialised = false;
      const string ADDON_NAME = "My Addon";
      public static void Main()
            MyAddon addOn = new MyAddon();
            if(runAddon)
                  System.Windows.Forms.Application.Run();
            else
             Application.Exit();
      public MyAddon()
            // Connect to SBO session for UI
            if(!SetApplication()) runAddon = false;
      private bool SetApplication()
            // Code goes in here to establish UI API and DI API connections
            // See SDK samples for examples
            // You should also define and filter the UI API events your addon will trap at this stage and create any menus
            // Call your routine to check if the required UDFs/UDTs exist on this company
            initialised = CheckInitialisation();
            if (!initialised)
               //  AddOn not yet intialised on this company so prompt the user to run the intialisation process
              int iResponse = app.MessageBox("The " + ADDON_NAME + " addon will now create all required fields and tables."
                                             + System.Environment.NewLine + System.Environment.NewLine
                                             + "WARNING: It is strongly recommended that all other users are logged out of this company "
                                             + "before running this process. Are you sure you wish to continue?", 2, "Yes", "No", "");
              if (iResponse == 1) initialised = InitialiseAddOn(); // Call your routine to create the objects
            return true;
    Kind Regards,
    Owen

  • A split screen feature would hold part of the web page static and allow scrolling through the rest, can it be done?

    I would like to be able to hold one part of a web page static while scrolling further down, most usually when following an onscreen tutorial on fixing something with 8.1, (pretty much an everyday occurrence).
    This feature would be similar to that in Office programs like excel.
    Is this feasible or must I open the same web page in different windows?

    See if this still works.
    https://addons.mozilla.org/en-US/firefox/addon/split-pannel/

  • Split screen static

    ijust picked up a new imca 27" to replace my powerbook pro. i have always used a lg monitor on the left side at 270 degrees for design. i was told i needed a new adapter for vga to mini display for the thunderbolt connection. its works but only some time. half the time it has a zig zag pattern of static on the screen. any ideas?

    See if this still works.
    https://addons.mozilla.org/en-US/firefox/addon/split-pannel/

  • Firefox 4.o seems to hang when loading some websites while waiting for an application called static-cdn.mozilla....

    the application seems to be : static-cdn.addons.mozilla.net

    From the menu bar, select
     ▹ System Preferences... ▹ Network ▹ Advanced... ▹ DNS
    Under DNS Servers you should have one or more numerical addresses, such as “192.168.1.1” or “10.0.0.1”. What are those addresses?

  • Excel addons for excel

    Im trying to find an addon for microsoft office 2010 (for mac) that lets me use portuguese version of formulas. Bu that i mean be able to write formulas in portuguese instead of having to use english ones. Can u please help me? Thanks a lot .
    I`m aware that there is an addon for Pc version that lets u use english formulas in a Portuguese Excel Version. Since there is only an english version for Mac, im wondering if there is the opposite. Thanks a lot .

    Hello Rafa,
    Are you trying to import data via VBA / DI API?
    I had tried such things as well some time back - and some things worked well, but others surprisingly didn't, but that may just be due to some specifics I didn't know...
    ...do you have the same version of Excel / VBA on both systems?
    ...and then there could (and will?) still be some coponents (DLLs) different between the 2 systems... - maybe check at least the statically linked DLLs with Depends.exe (I hope you have MS Visual Studio or so?)?
    HTH,
    Frank

  • Shutting down existing copies of an addon

    Hi all, how do I make sure that only one copy per user of my addon is running at a time? I have noticed that sometimes if user incorrectly exits SAP B1, the copy of the addon remains in the system. When SAP B1 restarted, another copy kicks in.
    Ideally would be to check upon addon start for existing copies of the addon for the particular user and to kill them.
    Thanks a lot for your contribution.

    thanks a lot
    this is how I shut down my addon. Do I need anything else?
         private static void myApplicationHandler(BoAppEventTypes pVal)
                   switch (pVal)
                        case BoAppEventTypes.aet_ShutDown:
                        System.Windows.Forms.Application.Exit();
                        break;

  • Install AddOn problem

    Hello all,
    I have a problem with install my addon to SAP2004. I create setup program for my addon, than i make .ard file for this addon and registred Addon in SAP SBO. When start the SAP begin the installation process. This process is ending by error "Install is time out". The setup dont start. I used time for installation 300 second. The wizard for setup didnt start. Why not?

    Hey Vit,
    First of all you will need to use some kind of installer that will allow you to execute your own custom code blocks as you must tell Business one that your installer has been successful.
    Here is some of the code that I used:
    First of all when your add on installer is called it gets two parameters from Business one. The first one is the install dir and the second os the location of the addonreg dll. You need to use these variables in your code.
    installDir = Environment.GetCommandLineArgs().GetValue(1).ToString();
    dllLocale = Environment.GetCommandLineArgs().GetValue(2).ToString();
    You need your C# application to talk to the business one registration dll. These are the three main functions you will need to call.
    [DllImport("AddOnInstallAPI.dll")]
    static extern int EndInstall();
    [DllImport("AddOnInstallAPI.dll")]
    static extern int RestartNeeded();
    [DllImport("AddOnInstallAPI.dll")]
    static extern int SetAddOnFolder(string srrPath);
    This is the code I use to tell Business one my addon has been installed:
    public bool RegisterAddOnWithBusinessOne()
        //set curr directory to SBO dll path
        Environment.CurrentDirectory = dllLocation;
        //override the default install Dir
        if (SetAddOnFolder(installLocation) != 0)
              return false;
        else
         //tell SBO the install has ended properly
         if (EndInstall() != 0)
              return false;
    return true;
    Please let me know if you have any questions or if this helps.

  • Version 29: Address bar is filled with static Firefox icons. Unable to type URL in address bar.

    I've never seen this before and cannot find a solution in support or in a general Google search.
    We have a user who has an address bar filed with static Firefox icons (there is a screen shot if there is any way to provide that). If the user clicks on them, they go nowhere (they shouldn't be there anyway, right?). This user is unable to type anything into the address bar, either. Not certain if there was an auto-update to version 29 overnight or not, but Firefox was uninstalled a fresh version of 29 installed - the reasoning being it might have been an installation issue. The issue still remains. This user is not having the same issue with Chrome. Have not tried reproducing it with any other browser on that machine. Have not heard any complaints from other users in the office using version 29.
    Is there some setting that is being overlooked with version 29? Is it a bug? Should we try installing version 28 and see if it's a versioning issue or perhaps something else? Trying to eliminate possible issues and move onto the next set of solutions.
    Thanks,

    Note that you can find an RSS feed icon in the Customize palette (3-bar Firefox menu button).
    * RSS Icon in url bar: https://addons.mozilla.org/firefox/addon/rss-icon-in-url-bar/

  • How to get my Addon to work with the license key?

    Hi,
    Can someone tell me how to get the Addon to work with the license key?
    I've follow the steps as stated in this thread:
    [Re: SBO 2005 A - How do I get a Connection string from SAP B1.|Re: SBO 2005 A - How do I get a Connection string from SAP B1.]
    1) i've registered a BASIS key and get a 'BASISXXXXXX" string
    2) then i paste my BASIS key in "Solution" of Add-On Indentifier Generator and generate the  Add-On Indentifier Code
    3) then i paste the string to my source code
    which is the "XXX" of the sample code in that thread.
    static string AddonIdentifierString="XXX";
    int lRetCode=0;
    int errCode=0;
    string errMsg= string.Empty;
    string connectionStr ="";
    link = new SAPbouiCOM.SboGuiApiClass();
    connectionStr =Environment.GetCommandLineArgs().GetValue(1).ToString();
    link.AddonIdentifier=AddonIdentifierString;
    link.Connect(connectionStr);
    oApp = link.GetApplication(-1);
    vCompany = new SAPbobsCOM.CompanyClass();
    string cookie = vCompany.GetContextCookie();
    string conStr = oApp.Company.GetConnectionContext(cookie);
    vCompany.SetSboLoginContext(conStr);
    lRetCode = vCompany.Connect();
    4) then i add my add-on using manager role at Add-on admin
    5) then i can see my add-on there. it not suppose to be there since i've not installed any of my add-on license for my own add-on.
    what steps did i miss? Can someone please advise? Thanks
    ps : i'm coding in VB

    Hi,
    i think you have to change the license file attributing the number of licensing for your addon, then download it from https://websmp202.sap-ag.de/smb and then install it on SAP License manager, then I think you should give the license for your addon for individual users (example manager)
    I hope it helps.
    Best regards

  • AddOn Permissions

    If I have a class called "Controller" and a class called "AddOn", how do I call one of AddOn's methods from the Controller class safely?
    The point is that the AddOn class could have been written by anyone, so I need to make sure that when I call addOn.doSomething() that the addon can't delete all of the system's files or download and run a virus...
    Thanks

    Well, to call one of AddOn's methods from your Controller class, you'd have to instantiate the AddOn and then call its method.
    What makes you think the AddOn coder couldn't fill up his constructor with malicious code? Methods aren't the only way someone with malign intent can play with your system.
    ... Unless, of course, AddOn's methods are static- in which case you wouldn't need to instantiate it, you'd just need to call AddOn.method().
    How are you accessing AddOn's methods? If someone else codes AddOn, and you code Controller, how do you even know what AddOns methods are? Does AddOn inherit any sort of interface? Does it extend an abstract class?
    Perhaps there's a way for you to 'check' code via coding a super abstract class for AddOn with a method that validates AddOn's doSomething method.
    Perhaps you can somehow deny AddOn access to the file system?
    What a fun problem, though. :) Best of luck.

  • Problem with Threads and a static variable

    I have a problem with the code below. I am yet to make sure that I understand the problem. Correct me if I am wrong please.
    Code functionality:
    A timer calls SetState every second. It sets the state and sets boolean variable "changed" to true. Then notifies a main process thread to check if the state changed to send a message.
    The problem as far I understand is:
    Assume the timer Thread calls SetState twice before the main process Thread runs. As a result, "changed" is set to true twice. However, since the main process is blocked twice during the two calls to SetState, when it runs it would have the two SetState timer threads blocked on its synchronized body. It will pass the first one, send the message and set "changed" to false since it was true. Now, it will pass the second thread, but here is the problem, "changed" is already set to false. As a result, it won't send the message even though it is supposed to.
    Would you please let me know if my understanding is correct? If so, what would you propose to resolve the problem? Should I call wait some other or should I notify in a different way?
    Thanks,
    B.D.
    Code:
    private static volatile boolean bChanged = false;
    private static Thread objMainProcess;
       protected static void Init(){
            objMainProcess = new Thread() {
                public void run() {
                    while( objMainProcess == Thread.currentThread() ) {
                       GetState();
            objMainProcess.setDaemon( true );
            objMainProcess.start();
        public static void initStatusTimer(){
            if(objTimer == null)
                 objTimer = new javax.swing.Timer( 1000, new java.awt.event.ActionListener(){
                    public void actionPerformed( java.awt.event.ActionEvent evt){
                              SetState();
        private static void SetState(){
            if( objMainProcess == null ) return;
            synchronized( objMainProcess ) {
                bChanged = true;
                try{
                    objMainProcess.notify();
                }catch( IllegalMonitorStateException e ) {}
        private static boolean GetState() {
            if( objMainProcess == null ) return false;
            synchronized( objMainProcess ) {
                if( bChanged) {
                    SendMessage();
                    bChanged = false;
                    return true;
                try {
                    objMainProcess.wait();
                }catch( InterruptedException e ) {}
                return false;
        }

    Thanks DrClap for your reply. Everything you said is right. It is not easy to make them alternate since SetState() could be called from different places where the state could be anything else but a status message. Like a GREETING message for example. It is a handshaking message but not a status message.
    Again as you said, There is a reason I can't call sendMessage() inside setState().
    The only way I was able to do it is by having a counter of the number of notifies that have been called. Every time notify() is called a counter is incremented. Now instead of just checking if "changed" flag is true, I also check if notify counter is greater than zero. If both true, I send the message. If "changed" flag is false, I check again if the notify counter is greater than zero, I send the message. This way it works, but it is kind of a patch than a good design fix. I am yet to find a good solution.
    Thanks,
    B.D.

  • Adobe cloud tries to load addon which I have deleted in Extension manager

    when Adobe Cloud starts it tries to load an application (Edge FX lite) that I have deleted in Adobe Extension Manager cc. I get the error message ' unable to install the addon EdgeFX lite  error 603. How do I stop this?
    Also in Adobe Exchange in 'My Stuff'  there are showing addons which I have removed in Adobe extension Manager cc which I would like to be removed from this listing as I will never use them, but if I right click to uninstall I fail to get rid of them.

    Apologies, without making the assumption that you are signed in
    1) Go to https://creative.adobe.com/addons/
    2) In the top right hand corner select sign in and enter your Adobe ID and password
    3) Once logged in, on the center of the screen at the left hand side, select the link 'All your purchases and shared items'
    4) You will then be taken to a page that is the equivalent of your My Stuff panel.
    5) You can then install individual add-ons/extensions.
    Kind regards,
    Lea

  • Can I use same IP to static to internal server from external dedicated ip?

    M question is would it cause my problems if I had the outside interface external ip mapped to vlan2 with the same ip address as I am trying to create static route to my server? Or is this OK? Keep in mind these are imaginary ips.
    I was trying to use this command but it was not letting me:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    Here is the front end of my config
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.333 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1

    Since you are using the outside interface ip address in your static PAT, you should use the keyword "interface" as follows:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255

  • Crystal Report Addon Error

    Hi All,
    I have successfully installed Crystal Report Addon Version 2.0.0.7 on B1 (Patch 0) . I have already installed Dot Net framework 3.5 on my machine and I use to design Crystal Reports in VS.Net 2005 Crystal Reporting tool .
    The proble is that everything works fine but as I click on the button 'preview and print ' it flashes an error "Could not load file or assembly CrystalDecisions.Windows.Reports Version 12.0.2008......"
    Iam not able to understand exactly what is lacking ? Do I require to install Crystal Report 2008 also . I do only have Crystal Report 10 (shipped with VS .NET 2005)
    If yes then please help me how to proceed to crack this problem...
    Thanks in advance.

    Hi Pooja,
    Yes, you need to install  Crystal Reports 2008 Runtime. Alternatively you can install Crystal Reports 2008 or Crystal Reports 2008 for B1.
    Regards,
    Vítor Vieira

Maybe you are looking for