Binding issue between POJO properties and JavaFX components

Currently, what I want to do is use bidirectionnal binding between POJO properties and JavaFX components.
For example, if the property is a String, a Textfield will be generated and binded with it.
My POJOs are generated by JAXB.
To do that, I proceeded as followed :
In order to make the binding works I changed the default generation of JAXB
I created a factory which takes a class instance at input and return a Map containing the POJO properties as key and the JavaFX components as value
I displayed this map in a JFXPanel
Here is a sample of the factory  :
public static Map<Field, Node> createComponents(Object obj) throws NoSuchMethodException
           Map<Field, Node> map = new LinkedHashMap<Field, Node>();
           for (final Field field : obj.getClass().getDeclaredFields())
               @SuppressWarnings("rawtypes")
               Class fieldType = field.getType();
               if (fieldType.equals(boolean.class) || (fieldType.equals(Boolean.class))) //Boolean
                   map.put(field, createBool(obj, field));
               else if (fieldType.equals(int.class) || (fieldType.equals(Integer.class))) //Integer
                  map.put(field, createInt(obj, field));
               else if (fieldType.equals(BigInteger.class)) //BigInteger
                  map.put(field, createBigInt(obj, field));
               else if (fieldType.equals(long.class) || fieldType.equals(Long.class)) //Long
                  map.put(field, createLong(obj, field));
               else if (fieldType.equals(String.class)) //String
                  map.put(field, createString(obj, field));
           return map;  
public static Node createBool(Object obj, final Field field) throws NoSuchMethodException
   System.out.println(field.getType().getSimpleName() + " spotted");
   JavaBeanBooleanProperty boolProperty = JavaBeanBooleanPropertyBuilder.create().bean(obj).name(field.getName()).build();
  boolProperty.addListener(new ChangeListener<Boolean>() {
   @Override
   public void changed(ObservableValue<? extends Boolean> arg0, Boolean arg1, Boolean arg2)
  prettyPrinter(field, arg1, arg2);
   CheckBox cb = new CheckBox();
  cb.setText(" : " + field.getName());
  cb.selectedProperty().bindBidirectional(boolProperty);
   return cb;}
So, the problem I have is : Sometimes the binding will work and sometimes it won't. For example, the binding is working unless I changed the declaration property order in the POJO, or unless I resized the panel where components are displayed.
Does anybody have an idea of what I am doing wrong ?
Thanks,
Bastien

You may like to look at the PropertySheet from ControlsFX.
Not sure if it does what you want, but the concept appears similar.

Similar Messages

  • Routing issue between Cisco Nexus and Cisco 4510 R+E Chassis

    We have configured Cisco Nexus 7K9 as core and Cisco 4510 R+E as access switches for Server connectivity.
    We are experiencing problem in terms of ARP learning and Ping issues between Cisco Nexus and end hosts.

    Hi,
    So you have N7k acting as L3 with servers connected to 4510?.
    Do you see the MAC associated with failing ARP in 4510?. Is it happening with all or few servers?. Just to verify if it is connectivity issue between N7k and 4510, you can configure an SVI on 4510 and assign address from same raneg (server/core range) and perform a ping.
    This will help narrow down if issue is between server to 4510 or 4510 to N7k.
    Thanks,
    Nagendra

  • Score Issues between Captivate 4 and 5

    Hi Everyone,
    We are noticing an issue between Captivate 4 and 5 and we can't seem to figure out what is going on, this issue is with Captivate modules that have no quiz and the completion status is based only on a % of slide views.  We publish as SCORM with complete/incomplete and report percent.
    With these types of modules created in Captivate 4, the LMS would record a completion and a N/A score.  Now, for those created in Captivate 5, the LMS receives a 0% score and the completion.  Our end users are really confused as to why they see a 0%.  Any ideas on what may be causing this?  The LMS is Taleo Learn, formerly Learn.com's LearnCenter.
    Any assitance would be greatly appreciated.
    Thanks,
    Connor

    If you can't download any old versions by logging into your account then clearly these have been discontinued.  Your best bet is ask somebody to lend you their CD/DVD which you can copy for your safe keeping.
    Old products are always discontinued and that is why you should always buy them on a CD/DVD so that they can installed whenever you have a new system or you have a system crash.
    Good luck.

  • Difference between Java applet and JavaFX

    Hello, all!
    I am studying javaFX in general. As far as I understand there is no main difference between java applet and javafx, except javafx has different syntax and library simple to use. Is it right?

    Basically, yes. But as you point out, it is supposed to be faster to develop in JavaFX...
    For example, Processing allows to export to applet, and is strong on doing graphics, but to see if user has clicked on a circle, you have to check the mouse coordinates against the circle coordinates, or create your own Circle class: it is at a much lower level.
    Likewise, you can use gaming frameworks like Slick2D or PulpCore, but they might be lacking on GUI (but perhaps faster). Or use Apache's Pivot, strong on GUI, but perhaps lacking a bit on graphics and animation.
    It depends on your needs, if you prefer to stick to Java, etc.

  • User synchronization issue between Active Directory and Solution manager.

    Requirement:
    Synchronize the users between Active directory and solution manager system.
    <u>What we did:</u>
    1.     Created RFC connection (LDAP_RFC) for LDAP connector.
    2.     Created new LDAP connector that utilize the RFC (LDAP_RFC).
    3.     Created new logical LDAP Server(CUA).Here we have to maintain the connection
    details to the physical directory.
    4.     We maintained the communication user that is used by the LDAP connector to bind the LDAP Directory Server.
    5.     In transaction LDAPMAP specific SAP data fields, we mapped to the desired
    directory attributes.
    6.     Testing from LDAP transaction working fine. We are able to see the attributes and
    values       from Active directory.
    <b><u>Issue:</u></b>
    When executed the program RSLDAPSYNC_USER for user synchronization from t-code se38 with below selection .
    LDAP Server = CUA (created earlier)
    LDAP Connector = LDAP_RFC (RFC connection created created ealier)
    In the tab: (Object that exist both in the directory and in the Database:)
    Selected: Compare Time Stamp.
    In the tab: (Objects the only exist in the Directory.)
    Selected : Create in Database.
    In the tab(Objects that only Exist in the Database:
    Selected: Ignore Object.
    Result from the report shows that connection to LDAP server is fine and ‘0’(zero) objects in Directory.
    The program does not create any new user in the Solution Manager system.
    Any help on this issue greatly appreciated.
    Thanks & Regards,
    Harish

    where did you see this error ? is there anymore details.
    i think the account you are using for Sync does not have Replicate Directory Changes permission in AD. follow below article and give Replicate directory changes permission.
    http://technet.microsoft.com/en-us/library/hh296982(v=office.15).aspx
    Thanks, Noddy

  • Issues between power, usb and airport?

    Well, after having my new MacBook Pro for only a couple of weeks, I've come to the conclusion that there are some pretty weird issues between the power manager, usb bus and airport (and from what I've read here, are pretty widespread issues). First, every time I charge the battery, my Logitech MX laser mouse stutters and jumps all over the screen (trackpad works smoothly though). If I turn off airport, the mouse works smoothly again. When the battery is done charging, the mouse will work smoothly again. Second, every now and then (when the mouse isn't connected) the trackpad will start to stutter and jump all over the screen. When this happens, I've noticed that the graphics card is running slowly as well (expose stutters). Both of these issues can then be remedied by one of two actions, either plug something into a usb port, or turn off airport. I am also suffering from the missing first letter issue, which also seems to go away by disabling airport... So, since disabling airport most of the time is not an option, anyone care to take a guess as to how long it will take Apple to come up with a fix to these issues?

    TM does not backup to a networked drive in the same way as a directly connected drive. A networked drive requires the creation of a .sparsebundle disc image file that holds the actual backed up files. So when you shift from direct to networked connection TM actually makes a different backup. This is unrelated to the actual type of port connection. So there's really nothing you can do to have TM use one backup for each type of connection used in your situation.

  • 2008r2 RDS Copy / Paste issue between remote app and client

    I am running a 2008r2 Remote App server with Win7/XP(sp3) clients.  All devices are up to date on current service packs and patches.  I can open RDWeb applications and paste between other RDWeb applications, but cannot paste from RDWeb to local
    applications.  I can also paste between various locally running applications, but not from a local application to an RDWeb application.  Each machine is maintaining it's own paste buffer, but not exchanging between the server and local machine.
    I have tried using different applications on both local and remote app, with the same results (Word, excel, notepad).
    I have verified the client and server settings are set to allow printer and clipboard resources, and have verified that there are no GPO's applied to either the server or client.
    I have tried to include as much relative information as I can, please feel free to ask any questions and I will do my best to get back to you as quickly as possible.
    Any help resolving this is most appreciated!
    Sean

    Hi Sean,
    I wish most of the posters would be as detailed as you are. Good troubleshooting! :)
    Two things to try:
    1) when you connect DIRECTLY to the server via MSTSC and set a checkbox in the OPTIONS/Local Resources - to share Clipboard - do you then get the Copy paste working?
    IF SO
    2) Then please make sure that the Published applications - RemoteApp - have an additional line (Custom RDP settings) in properties (you miht need to recreate the RemoteApp's
    redirectclipboard:i:1
     then it should work.
    Virtualization Conference “PubForum 2011 Dublin”,
    The Bible of Remote Desktop Services! , Microsoft Virtualization Solutions Day Dublin!

  • VPD date issue between 10.1 and 10.2 databases

    I have uncovered an issue today with VPD against date fields. The issue came up at a client site on a 10.2 database. When I got back to the hotel and tried this on my own database, which is 10.1, I got no issue and everything worked ok.
    Therefore, I am asking if anyone is able to try out the following for me on different Oracle databases and platforms and let me know whether it worked for you or not. I'd like to compile a list of database versions and platforms on which the issue occurs.
    Step 1: create this table as a user
    CREATE TABLE TST_DATE AS (
    SELECT 1 PERSON_UID,
    Trunc(SYSDATE) BIRTH_DATE,
    To_Char(Trunc(SYSDATE), 'DD-MON-YYYY') CHAR_DATE,
    123456 TAX_ID,
    'Smith, Michael B.' FULL_NAME FROM dual);
    Step 2: grant select rights on the table
    GRANT SELECT ON TST_DATE TO PUBLIC;
    Step 3: switch your login to SYS and run this script:
    CREATE OR REPLACE FUNCTION F_CHECK_ITEM_TST(p_object_schema in varchar2, p_object_name varchar2)
    RETURN VARCHAR2 IS
    V_PREDICATE VARCHAR2(2000) := '1 = 2';
    BEGIN
    RETURN(V_PREDICATE);
    END F_CHECK_ITEM_TST;
    Step 4: As SYS, run this to grant access rights over the function
    GRANT EXECUTE ON F_CHECK_ITEM_TST TO PUBLIC;
    Step 5: As SYS, run this to enable the policy
    BEGIN DBMS_RLS.ADD_POLICY(
    OBJECT_SCHEMA => 'DRAKE',
    OBJECT_NAME => 'TST_DATE',
    POLICY_NAME => 'SecByTST',
    FUNCTION_SCHEMA => 'SYS',
    POLICY_FUNCTION => 'F_CHECK_ITEM_TST',
    STATEMENT_TYPES => 'SELECT',
    POLICY_TYPE => DBMS_RLS.DYNAMIC,
    SEC_RELEVANT_COLS => 'BIRTH_DATE',
    SEC_RELEVANT_COLS_OPT => DBMS_RLS.ALL_ROWS);
    END;
    Note: in the above policy change the OBJECT_SCHEMA name to be the name of the user who owns the table you created in Step 1
    Step 6: Go into Discoverer Admin and import the table as a new folder.
    Be sure to uncheck the "Date hierarchies" box and set "Default aggregate on data points" to detail. Grant access to any user.
    Step 7: Using Desktop or Plus, log in as that user then try to query the folder with the date not included, there should be no problem.
    Step 8: Now try to query with the date included
    On my 10.2 database I get ORA-24334: no descriptor for this position. This happens when logged into Discoverer as the table owner, EUL owner or any other user. However, when logged into Discoverer as SYS which is exempt from all VPD policies, there is no error when the date is included.
    We tried this in Discoverer Desktop, Plus and Viewer with the same results in all three. We can successfully query the table from SQL*Plus, SQL Developer and TOAD.
    There also seems to be no issue at all with the 10.1 database so there seems to be an issue between Discoverer and the 10.2 database.
    What do you think?
    P.S. to cancel the policy use this script when logged in as SYS:
    EXEC DBMS_RLS.drop_policy(
    OBJECT_SCHEMA => 'DRAKE',
    OBJECT_NAME => 'TST_DATE',
    POLICY_NAME => 'SecByTST');
    This same information is available on my blog in a more readable format here:
    http://learndiscoverer.blogspot.com/2006/12/vpd-date-issue-between-101-and-102.html

    Hi Rod
    Well don't you just love Oracle. Obviously, whatever tests were done for certifying Discoverer against the 10.2 database did not include checking VPD policies. This merits a blog entry from me.
    Your workaround for V_PREDICATE VARCHAR2(2000) := 'BIRTH_DATE=TO_DATE(''01-JAN-0001'')'; works. However, I had to write a new function to do this because my real function was trapping about a dozen items at the same time, some dates, some numbers and some varchars - exactly the way that the Oracle example code shows it in the 10.2 database manual.
    So what I did was to create a new function that only handles dates and added a dedicated policy that works with only that function. Unfortuately, because I have many dates to manage, I was unabe to hard code the BIRTH_DATE so here is what I did:
    V_PREDICATE VARCHAR2(2000) := 'SYSDATE = TO_DATE(''01-JAN-0001'')';
    This works perfectly and Discoverer stopped complaining. It just has two policies on the same table for different data items. Isn't VPD cool? I'm hooked.
    I really appreciate your time and effort on this. Now, let's see what Oracle support make of the issue because I raised a service request last night. No reply yet I'm afraid.
    Best wishes
    Michael

  • Interoperability issues between Nexus 5k and HP storageworks (8/20q)

    Hello community,
    I am trying to get a VM host and a windows server to connect to their storage across a nexus and HP (Qlogic) fabric switch. This is currently having issues with the VM host unable to see the datastores, possibly due to interoperability between Cisco and HP (Qlogic)
    I have configured and tested the connectivity using only the cisco nexus and this worked, I then tested it using only the HP fabric switch (HP 8/20q) and this also worked.
    However, when using the HP and Cisco Nexus as shown in the attached diagram, things stop working.
    The connection is using Native Fibre channel, On the Cisco side I performed the following steps
    Configured the Nexus with Domain ID 10 and the HP with Domain ID 20.
    Connected the 2 fabric switches on fc1/48 (Cisco) and port 0 (HP) and confirmed that the ISL came up (E_port 8G), I confirmed connectivity using fcping both ways.
    I connected the SAN to the Nexus and the servers to the HP
    Configured VSAN 10
    Added interfaces fc1/41 to 48 in VSAN 10
    Created 2 zones ( ESXI and Windows)
    Added the PWWN for the ESXI server and the MSA2040 to the ESXI zone
    Added the PWWN for the Windows 2k8 server and MS2040 to the Windows zones
    Created zoneset (Fabric-A) and added both the above zones in it
    Activated the FABRIC-A zoneset
    The result is that the zones and zoneset are synchronised to the HP switch .I confirmed that I was able to see the servers and SAN WWN in the correct zones on the HP.
    From the 8/20q switch I am able to fcping the SAN, Nexus and servers, however the Nexus is only able to fcping the SAN and the HP, it returns a “no response from destination”  when pinging the servers.
    I have added the FCID for all the units in the same zones to see if it makes any difference to no avail the result seem to be the same. I have gone through various Nexus/MDS/HP/Qlogic user guides and forums; unfortunately I have not come across any that shows this specific topology.
    source for HP user guide is here: http://h20565.www2.hp.com/hpsc/doc/public/display?docId=emr_na-c02256394
    I’m attaching the nexus config and partial view of the “show interface brief” showing the fibre channel port status
    Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                      Mode   Trunk                          Mode  Speed  Channel
                             Mode                                 (Gbps)
    fc1/47     10     auto   on      up               swl    F       8    --
    fc1/48     10     auto   on      up               swl    E       8    --
    Any help and advice would be greatly appreciated. thanks in advance

    Hi all, after much reading, Walter Dey provided the hint to put me on the right track. 
    By default the Nexus 5k is in interop mode 1. However, one of the requirement for this to be "interoperable" with other vendor the FCDomain ID in the entire fabric needs to be between 97 and 127 as stated in the Cisco website.
    http://www.cisco.com/en/US/docs/storage/san_switches/mds9000/interoperability/guide/ICG_test.html
    Another issue that had me and my colleague scratching our heads, was that we were seeing high level of CRC errors on the ISL interfaces. This was caused by ARBFF settings mismatch between the Nexus and the HP. This was resolved by ensuring that the ARBFF setting on the HP was set to false and the command "switchport fill-pattern ARBFF speed 8000" is configured on the ISL interface linking the 2 switches. (note that Cisco's default setting for the ports is IDLE, until this is changed the link will not stabilise)
    Thanks for all your help guys.

  • Keychain sync issues between new iMac and older 10.4.11 machine

    I am having a tough time since purchasing a new imac - I can get mobileme working reasonably well with few issues if I have keychain syncing disabled on both machines but I would like to get to the bottom of this and be able to sync it automatically.
    Here is a description of the issues I am getting in spite of performing the regular advice to set up a new account once the issue starts and move all my stuff into that new account.
    After a few syncs I get the advice "please enter the password for "(myname), Aos Powerbook G4 17""
    Now the A has a double dot (umlaut ?) above it and the o has a ^ above it - not sure how to get that with this keyboard or I would have done it ...
    This box is empty below this dialogue (expecting a passcode) and whatever password you enter (I have tried all of mine repeatedly over several weeks now !) it just doesn't accept it. It is as if someone else in a parallel universe has your mac and has entered a new passcode !
    Occasionally I will get 'the keychain on '^&G*)(" has been altered do you wish to merge' (not exact text but something like) and I am no longer able to send emails without entering my email account password first and every so often.
    There are other weird symptoms too - but does this trigger anyones grey matter ?
    IS there an issue between 105 and 104 syncing ?
    Thanks
    Andy

    I should also point out that I have an iphone and this poor puppy has tons of apps and data associated with the apps on it......
    Anyone have a clue as to how I back this up with the new pbook user account I have created to sidestep the keychain issue ?
    The only option it shows erases the iphone's applications and their assoc data from what I can see ....
    Thanks
    Andy

  • Connectivity issues between Cisco 2901 and Cisco SG300-52

    Hello,
    I am having some serious connectivity issues between the hosts in my LAN.
    My LAN is based on a Cisco 2901 router and a Cisco SG300-52 port switch.
    The issue that has been happening is that connections between hosts on the LAN (remote desktop, extended ping, etc) is very unstable, at some point I can see a 35% lost packets on an extended ping. This happens at any time of the day and from any host.
    All hosts are on the same Vlan(default Vlan) and on the same subnet. Some hosts have fixed IP addresses (servers and network equipment) and others obtain their IP address trough a DHCP reservation  established on the router (reserved with the MAC address of every host).
    I can provide further details if needed, because this issue is very serious and I would really appreciate any insight or support.
    Many thanks in advanced.
    Sair Amer
    EDIT:  After doing every test we could think of, we finally found the reason behind this problem.
    It turns out that the switch has problems handling communications between clients at different speeds, because most of the hosts connected were working at 100 Mbps but the servers were working at 1000 Mbps (and the communication between host and servers wasn't stable).
    After manually setting the speed on all ports to 100 Mbps the problems have stopped.
    Many thanks for you help on this issue. 

    Building configuration...
    Current configuration : 4123 bytes
    ! Last configuration change at 12:06:16 PCTime Sat Jul 19 2014 by ccp
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Foninsa
    boot-start-marker
    boot-end-marker
    no logging buffered
    enable secret 5 $1$BDbJ$HN3VP8nmywrGB55RCxPd30
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local 
    aaa session-id common
    clock timezone PCTime -4 0
    clock summer-time PCTime date Apr 6 2003 2:00 Oct 12 2003 12:00
    no ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.10
    ip dhcp excluded-address 192.168.1.151 192.168.1.255
    ip dhcp pool FONINSA
     network 192.168.1.0 255.255.255.0
     default-router 192.168.1.1 
     dns-server 8.8.8.8 8.8.4.4 
    ip dhcp pool Laptop-Sporta-Wifi
     host 192.168.1.10 255.255.255.0
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    no ipv6 cef
    multilink bundle-name authenticated
    crypto pki trustpoint TP-self-signed-213585710
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-213585710
     revocation-check none
     rsakeypair TP-self-signed-213585710
    crypto pki certificate chain TP-self-signed-213585710
     certificate self-signed 01
      30820229 30820192
      quit
    license udi pid CISCO2901/K9 sn
    license boot module c2900 technology-package securityk9
    username ccp privilege 15 password
    redundancy
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    interface GigabitEthernet0/0
     ip address 190.196.21.98 255.255.255.248
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface GigabitEthernet0/1
     ip address 192.168.1.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    no ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip nat inside source static tcp 192.168.1.3 21 190.196.21.98 21 extendable
    ip nat inside source static tcp 192.168.1.3 80 190.196.21.98 80 extendable
    ip nat inside source static udp 192.168.1.8 1194 190.196.21.98 1194 extendable
    ip nat inside source static tcp 192.168.1.4 3389 190.196.21.98 3389 extendable
    ip nat inside source static tcp 192.168.1.9 3389 190.196.21.98 10000 extendable
    ip nat inside source static tcp 192.168.1.3 3389 190.196.21.98 20000 extendable
    ip route 0.0.0.0 0.0.0.0 190.196.21.97
    access-list 1 permit 192.168.1.0 0.0.0.255
    control-plane
    line con 0
     password $
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 5
     access-class 23 in
     privilege level 15
     password #
     transport input telnet ssh
    no scheduler allocate
    end

  • Port-Channel issue between UCS FI and MDS 9222i switch

    Hi
    I have a problem between UCS FI and MDS switch port-channel. When MDS-A is powered down the port-channel fails but UCS blade vHBA does not detect the failure of the port-chanel on UCS-FI and leaves the vHBA online. However, if there is no port-channel between FI-->MDS it works fine.
    UCS version   
    System version: 2.0(2q)
    FI - Cisco UCS 6248 Series Fabric Interconnect ("O2 32X10GE/Modular Universal Platform Supervisor")
    Software
      BIOS:      version 3.5.0
      loader:    version N/A
      kickstart: version 5.0(3)N2(2.02q)
      system:    version 5.0(3)N2(2.02q)
      power-seq: Module 1: version v1.0
                 Module 3: version v2.0
      uC:        version v1.2.0.1
      SFP uC:    Module 1: v1.0.0.0
    MDS 9222i
    Software
      BIOS:      version 1.0.19
      loader:    version N/A
      kickstart: version 5.0(8)
      system:    version 5.0(8)
    Here is the config from MDS switch
    Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                      Mode   Trunk                          Mode  Speed  Channel
                             Mode                                 (Gbps)
    fc1/1      103    auto   on      trunking         swl    TF      4    10
    fc1/2      103    auto   on      trunking         swl    TF      4    10
    fc1/9      103    auto   on      trunking         swl    TF      4    10
    fc1/10     103    auto   on      trunking         swl    TF      4    10
    This is from FI.
    Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                      Mode   Trunk                          Mode  Speed  Channel
                             Mode                                 (Gbps)
    fc1/29     103    NP     on      trunking         swl    TNP     4    103
    fc1/30     103    NP     on      trunking         swl    TNP     4    103
    fc1/31     103    NP     on      trunking         swl    TNP     4    103
    fc1/32     103    NP     on      trunking         swl    TNP     4    103
    Any thoughts on this?

    Sultan,
    This is a recently found issue and is fixed in UCSM 2.0.3a version .
    http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCua88227
    which got duped to  CSCtz21585
    It happens only when following conditions are met
    FI in End host mode
    FC uplinks are configured for portchannel + trunking
    Certain link event failures ( such abrupt power loss by upstream MDS switch )
    Padma

  • FaceTime volume issue between iPad Air and iPad 2

    I've noticed that when making FaceTime calls between iPad Air and iPad 2, the volume on iPad 2 is too soft and the volume on iPad Air is too loud. This only occurs between 2 different type of iPads. If both parties use the same type, the volumes on both sides are roughly the same and loud enough to be heard clearly. I've also verified with Skype which produced roughly the same loudness when video calling between an iPad Air and an iPad 2.
    Just hope Apple can take notice of this issue and rectify in the new iOS release.

    Yeah, what's up with this? I too have PDF's I want to sync between iPhone5s and new iPadAir. I'm not having luck!. You would think it would be SIMPLE!

  • Routing issue between Cisco device and Virtual machine

    Hi Guys,
    We have two local subnets in a virtualized environment, subnet 1 has a VM operating as a firewall, we would like all traffic for subnet 2 to go via VM on subnet 1, this will police traffic on subnet 2 and then reroute.  
    The infrastructure involved comprises,
    Internet Edge Switch -> ASA -> Core Switch -> IBM Flex chassis
    The Internet edge switch is directly connected between the ISP routers and the Cisco ASA firewall pair (A/S). The ASA is then connected to the Core switch. Connected from the core switch is an IBM Flex chassis, via a port channel (all vlans allowed)
    The local subnets in question are as follows:
    Vlan 101 (10.1.1.0/24)
    Vlan 102 (10.2.1.0/24)
    The VM in question has two NIC cards having IP address of both subnets.
    NIC 1:  10.1.1.1
    NIC 2: 10.2.1.1
    We would like packets destined for 10.2.1.1 to land on 10.1.1.1 IP address. At the moment traffic for each vlan routes from the outside to their respective local subnets successfully, what we are having difficulty with is directing traffic for subnet 2 via subnet 1 VM firewall.
    At the moment we have tried adding a static route on the core switch but it didn’t work
    ip route 10.2.0.0 255.255.255.0 10.1.1.1
    I will appreciate if you could share your knowledge and guide me how to achieve this goal.
    Thanks in advance :-)

    Hi,
    I think for this to work you need a transit vlan between the VMs and the core switch. So, if you have 2 vlans on the VM (101 and 102) you use the VM switch to route between the vlans and in order to go outside the local vlans you would use the core switch.  In this scenario you would not have an SVI (layer-3) interface on the core.  The only thing that core will have is the layer-2 vlans (101 and102).  You would than need a static route on the core switch to point to the transit vlan on the VM side.
    so, for example, if the transit vlan is vlan 110 and the ip is 192.168.1.0/24
    on the core you have static routes:
    ip route 10.1.1.0/24 192.168.1.2 (VM side)
    ip route 10.1.2.0/24 192.168.1.2 (VM side)
    You also need an SVI for vlan 110 with ip address 192.168.1.1/24 on the core.
    on the VM you need a default route to point to the core (192.168.1.1).
    Is this what you are trying to do?
    HTH

  • Handoff issues between iPhone 6 and iPad Air

    How to fix Handoff between ipad air and iPhone 6 for messages?

    I Have repeated all the steps that were posted on the apple website and the only handoff that works is between the mail app!

Maybe you are looking for