VPD date issue between 10.1 and 10.2 databases

I have uncovered an issue today with VPD against date fields. The issue came up at a client site on a 10.2 database. When I got back to the hotel and tried this on my own database, which is 10.1, I got no issue and everything worked ok.
Therefore, I am asking if anyone is able to try out the following for me on different Oracle databases and platforms and let me know whether it worked for you or not. I'd like to compile a list of database versions and platforms on which the issue occurs.
Step 1: create this table as a user
CREATE TABLE TST_DATE AS (
SELECT 1 PERSON_UID,
Trunc(SYSDATE) BIRTH_DATE,
To_Char(Trunc(SYSDATE), 'DD-MON-YYYY') CHAR_DATE,
123456 TAX_ID,
'Smith, Michael B.' FULL_NAME FROM dual);
Step 2: grant select rights on the table
GRANT SELECT ON TST_DATE TO PUBLIC;
Step 3: switch your login to SYS and run this script:
CREATE OR REPLACE FUNCTION F_CHECK_ITEM_TST(p_object_schema in varchar2, p_object_name varchar2)
RETURN VARCHAR2 IS
V_PREDICATE VARCHAR2(2000) := '1 = 2';
BEGIN
RETURN(V_PREDICATE);
END F_CHECK_ITEM_TST;
Step 4: As SYS, run this to grant access rights over the function
GRANT EXECUTE ON F_CHECK_ITEM_TST TO PUBLIC;
Step 5: As SYS, run this to enable the policy
BEGIN DBMS_RLS.ADD_POLICY(
OBJECT_SCHEMA => 'DRAKE',
OBJECT_NAME => 'TST_DATE',
POLICY_NAME => 'SecByTST',
FUNCTION_SCHEMA => 'SYS',
POLICY_FUNCTION => 'F_CHECK_ITEM_TST',
STATEMENT_TYPES => 'SELECT',
POLICY_TYPE => DBMS_RLS.DYNAMIC,
SEC_RELEVANT_COLS => 'BIRTH_DATE',
SEC_RELEVANT_COLS_OPT => DBMS_RLS.ALL_ROWS);
END;
Note: in the above policy change the OBJECT_SCHEMA name to be the name of the user who owns the table you created in Step 1
Step 6: Go into Discoverer Admin and import the table as a new folder.
Be sure to uncheck the "Date hierarchies" box and set "Default aggregate on data points" to detail. Grant access to any user.
Step 7: Using Desktop or Plus, log in as that user then try to query the folder with the date not included, there should be no problem.
Step 8: Now try to query with the date included
On my 10.2 database I get ORA-24334: no descriptor for this position. This happens when logged into Discoverer as the table owner, EUL owner or any other user. However, when logged into Discoverer as SYS which is exempt from all VPD policies, there is no error when the date is included.
We tried this in Discoverer Desktop, Plus and Viewer with the same results in all three. We can successfully query the table from SQL*Plus, SQL Developer and TOAD.
There also seems to be no issue at all with the 10.1 database so there seems to be an issue between Discoverer and the 10.2 database.
What do you think?
P.S. to cancel the policy use this script when logged in as SYS:
EXEC DBMS_RLS.drop_policy(
OBJECT_SCHEMA => 'DRAKE',
OBJECT_NAME => 'TST_DATE',
POLICY_NAME => 'SecByTST');
This same information is available on my blog in a more readable format here:
http://learndiscoverer.blogspot.com/2006/12/vpd-date-issue-between-101-and-102.html

Hi Rod
Well don't you just love Oracle. Obviously, whatever tests were done for certifying Discoverer against the 10.2 database did not include checking VPD policies. This merits a blog entry from me.
Your workaround for V_PREDICATE VARCHAR2(2000) := 'BIRTH_DATE=TO_DATE(''01-JAN-0001'')'; works. However, I had to write a new function to do this because my real function was trapping about a dozen items at the same time, some dates, some numbers and some varchars - exactly the way that the Oracle example code shows it in the 10.2 database manual.
So what I did was to create a new function that only handles dates and added a dedicated policy that works with only that function. Unfortuately, because I have many dates to manage, I was unabe to hard code the BIRTH_DATE so here is what I did:
V_PREDICATE VARCHAR2(2000) := 'SYSDATE = TO_DATE(''01-JAN-0001'')';
This works perfectly and Discoverer stopped complaining. It just has two policies on the same table for different data items. Isn't VPD cool? I'm hooked.
I really appreciate your time and effort on this. Now, let's see what Oracle support make of the issue because I raised a service request last night. No reply yet I'm afraid.
Best wishes
Michael

Similar Messages

  • Remote Desktop cannot verify the identity of the computer because there is a time or date diffrence between your computer and remote computer

    Hello.....
    I'm not able to log into Windows Server 2008 r2 server thorugh Remote Desktop connection, receiving below error message.
    This issue is with only three servers in the environment
    "Remote Desktop cannot verify the identity of the computer because there is a time or date diffrence between your computer and remote computer......"
    The date/time is correct on the server when i checked in the console session of the server
    Can see below messages in event logs
    Event ID 1014:
    "Name resolution for the name XYZdomain.com timed out after none of the configured DNS servers responded."
    Event ID 1053:
    The processing of Group Policy failed. Windows could not resolve the user name. This could be caused by one of more of the following:
    a) Name Resolution failure on the current domain controller.
    b) Active Directory Replication Latency (an account created on another domain controller has not replicated to the current domain controller).
    Any thoughts ....

    Hi,
    Have you tried to connect these three servers with IP address instead of computer name or DNS name?
    Check Remote Desktop Connection settings: Option-->Advanced-->Connect from anywhere-->Settings-->Connection Settings-->Select “Do not user an RD Gateway server”
    For more information please refer to following MS articles:
    Remote Desktop cannot verify the identity of the remote computer because there is a time or date difference between your computer and the remote computer
    http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/c1f64836-5606-49b0-82eb-56be7f696520
    Cannot connect via Remote Desktop
    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/5087e897-8313-468c-ad37-ef18b87d4dd6
    Lawrence
    TechNet Community Support

  • Routing issue between Cisco Nexus and Cisco 4510 R+E Chassis

    We have configured Cisco Nexus 7K9 as core and Cisco 4510 R+E as access switches for Server connectivity.
    We are experiencing problem in terms of ARP learning and Ping issues between Cisco Nexus and end hosts.

    Hi,
    So you have N7k acting as L3 with servers connected to 4510?.
    Do you see the MAC associated with failing ARP in 4510?. Is it happening with all or few servers?. Just to verify if it is connectivity issue between N7k and 4510, you can configure an SVI on 4510 and assign address from same raneg (server/core range) and perform a ping.
    This will help narrow down if issue is between server to 4510 or 4510 to N7k.
    Thanks,
    Nagendra

  • Data reconciliation between R/3 and the BW Systems

    How do we do data reconciliation between R/3 and the BW system for the following areas?
    Purchasing
    Controlling:
    Project System:
    COPA
    SD
    AP
    Trgards,
    Tony G

    Tony
    Have you looked these documents??
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/library/biw/how%20to%20validate%20infocube%20data%20by%20comparing%20it%20with%20psa%20data
    https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/docs/library/uuid/7a5ee147-0501-0010-0a9d-f7abcba36b14
    Re: BW v. R/3 data reconciliation
    Hope this helps
    Thanks
    Sat

  • How can we do the data migration between Oracle Applications and SAP R/3.

    Hi All,
    How can we do the data migration between Oracle Applications and SAP R/3 system.What are all the possible ways to move bulk data from Oracle Apps to SAP r/3 system.
    Provide any 3rd party tools which supports data migration and also pls rpovide the SAP's own data migration tools with supports the above feature.
    Awaiting for best possible solution.
    Thanks in advance.
    Regards
    Dharmaraju

    the 3rd party tool is ETL , you can use ETL tool and the prepare the load files then you can use LSMW method to upload the data to SAP.

  • How to do data migration between single node and multi node HANA systems ?

    Data migration between single node and multi node HANA systems ?
    What are limitations ?
    What should be the best practices ?

    Data migration between single node and multi node HANA systems ?
    What are limitations ?
    What should be the best practices ?

  • Score Issues between Captivate 4 and 5

    Hi Everyone,
    We are noticing an issue between Captivate 4 and 5 and we can't seem to figure out what is going on, this issue is with Captivate modules that have no quiz and the completion status is based only on a % of slide views.  We publish as SCORM with complete/incomplete and report percent.
    With these types of modules created in Captivate 4, the LMS would record a completion and a N/A score.  Now, for those created in Captivate 5, the LMS receives a 0% score and the completion.  Our end users are really confused as to why they see a 0%.  Any ideas on what may be causing this?  The LMS is Taleo Learn, formerly Learn.com's LearnCenter.
    Any assitance would be greatly appreciated.
    Thanks,
    Connor

    If you can't download any old versions by logging into your account then clearly these have been discontinued.  Your best bet is ask somebody to lend you their CD/DVD which you can copy for your safe keeping.
    Old products are always discontinued and that is why you should always buy them on a CD/DVD so that they can installed whenever you have a new system or you have a system crash.
    Good luck.

  • I am thinking of buying a iPad but my main desktop machine uses Windows 7 and MS Office.  How easy or difficult is it to transfer data files between the iPad and Windows?  Are there obvious problems or the need for some form of conversion programs?

    I am thinking of buying a iPad but my main desktop machine uses Windows 7 and MS Office.  How easy or difficult is it to transfer data files between the iPad and Windows?  Are there obvious problems or the need for some form of conversion programs?
    Many thanks for any advice.
    David

    You don't need conversion programs, iTunes can copy most of your content over to the iPad via the file sharing section, and some apps also support Dropbox, email attachments, transfer via your wifi network. There are a number of apps that you can get that support Microsoft office file (microsoft don't make an app versions of their software) e.g. from Apple there are Pages (word support), Numbers (excel) and Keynote (powerpoint), and from third-parties there are apps such as Documents To Go and QuickOffice HD

  • User synchronization issue between Active Directory and Solution manager.

    Requirement:
    Synchronize the users between Active directory and solution manager system.
    <u>What we did:</u>
    1.     Created RFC connection (LDAP_RFC) for LDAP connector.
    2.     Created new LDAP connector that utilize the RFC (LDAP_RFC).
    3.     Created new logical LDAP Server(CUA).Here we have to maintain the connection
    details to the physical directory.
    4.     We maintained the communication user that is used by the LDAP connector to bind the LDAP Directory Server.
    5.     In transaction LDAPMAP specific SAP data fields, we mapped to the desired
    directory attributes.
    6.     Testing from LDAP transaction working fine. We are able to see the attributes and
    values       from Active directory.
    <b><u>Issue:</u></b>
    When executed the program RSLDAPSYNC_USER for user synchronization from t-code se38 with below selection .
    LDAP Server = CUA (created earlier)
    LDAP Connector = LDAP_RFC (RFC connection created created ealier)
    In the tab: (Object that exist both in the directory and in the Database:)
    Selected: Compare Time Stamp.
    In the tab: (Objects the only exist in the Directory.)
    Selected : Create in Database.
    In the tab(Objects that only Exist in the Database:
    Selected: Ignore Object.
    Result from the report shows that connection to LDAP server is fine and ‘0’(zero) objects in Directory.
    The program does not create any new user in the Solution Manager system.
    Any help on this issue greatly appreciated.
    Thanks & Regards,
    Harish

    where did you see this error ? is there anymore details.
    i think the account you are using for Sync does not have Replicate Directory Changes permission in AD. follow below article and give Replicate directory changes permission.
    http://technet.microsoft.com/en-us/library/hh296982(v=office.15).aspx
    Thanks, Noddy

  • Data sync between on-premise and azure database

    HI, I am not able to setup data sync between my on-premise database and azure database. Following is the error I am getting after it ran for almost 36 hours...
    Sync failed with the exception "GetStatus failed with exception:Sync worker failed, checked by GetStatus method. Failure details:An unexpected error occurred when applying batch file C:\Resources\directory\4c6dc848db5a4ae88265ee5aa1d44f40.NTierSyncServiceWorkerRole.LS1\DSS_7b1d73b4-d125-466f-94ab-eaa4553ea0ae\ed19f805-3d50-466a-96b3-861c4f22d8a4.batch.
    See the inner exception for more details.Inner exception: Failed to execute the command 'UpdateCommand' for table 'dbo.Transactions'; the transaction was rolled back. Ensure that the command syntax is correct.Inner exception: SqlException Error Code: -2146232060
    - SqlError Number:10054, Message: A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - An existing connection was forcibly closed by the remote host.) "    For more information,
    provide tracing ID ‘e6a1fad1-f995-4ffe-85db-0c6dc02423f1’ to customer support.

    Hi, sorry it has been a long time since your last post. Are you still using SQL Data Sync and hitting any issue which we could help with?
    Linda

  • Keychain sync issues between new iMac and older 10.4.11 machine

    I am having a tough time since purchasing a new imac - I can get mobileme working reasonably well with few issues if I have keychain syncing disabled on both machines but I would like to get to the bottom of this and be able to sync it automatically.
    Here is a description of the issues I am getting in spite of performing the regular advice to set up a new account once the issue starts and move all my stuff into that new account.
    After a few syncs I get the advice "please enter the password for "(myname), Aos Powerbook G4 17""
    Now the A has a double dot (umlaut ?) above it and the o has a ^ above it - not sure how to get that with this keyboard or I would have done it ...
    This box is empty below this dialogue (expecting a passcode) and whatever password you enter (I have tried all of mine repeatedly over several weeks now !) it just doesn't accept it. It is as if someone else in a parallel universe has your mac and has entered a new passcode !
    Occasionally I will get 'the keychain on '^&G*)(" has been altered do you wish to merge' (not exact text but something like) and I am no longer able to send emails without entering my email account password first and every so often.
    There are other weird symptoms too - but does this trigger anyones grey matter ?
    IS there an issue between 105 and 104 syncing ?
    Thanks
    Andy

    I should also point out that I have an iphone and this poor puppy has tons of apps and data associated with the apps on it......
    Anyone have a clue as to how I back this up with the new pbook user account I have created to sidestep the keychain issue ?
    The only option it shows erases the iphone's applications and their assoc data from what I can see ....
    Thanks
    Andy

  • Connectivity issues between Cisco 2901 and Cisco SG300-52

    Hello,
    I am having some serious connectivity issues between the hosts in my LAN.
    My LAN is based on a Cisco 2901 router and a Cisco SG300-52 port switch.
    The issue that has been happening is that connections between hosts on the LAN (remote desktop, extended ping, etc) is very unstable, at some point I can see a 35% lost packets on an extended ping. This happens at any time of the day and from any host.
    All hosts are on the same Vlan(default Vlan) and on the same subnet. Some hosts have fixed IP addresses (servers and network equipment) and others obtain their IP address trough a DHCP reservation  established on the router (reserved with the MAC address of every host).
    I can provide further details if needed, because this issue is very serious and I would really appreciate any insight or support.
    Many thanks in advanced.
    Sair Amer
    EDIT:  After doing every test we could think of, we finally found the reason behind this problem.
    It turns out that the switch has problems handling communications between clients at different speeds, because most of the hosts connected were working at 100 Mbps but the servers were working at 1000 Mbps (and the communication between host and servers wasn't stable).
    After manually setting the speed on all ports to 100 Mbps the problems have stopped.
    Many thanks for you help on this issue. 

    Building configuration...
    Current configuration : 4123 bytes
    ! Last configuration change at 12:06:16 PCTime Sat Jul 19 2014 by ccp
    version 15.2
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Foninsa
    boot-start-marker
    boot-end-marker
    no logging buffered
    enable secret 5 $1$BDbJ$HN3VP8nmywrGB55RCxPd30
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local 
    aaa session-id common
    clock timezone PCTime -4 0
    clock summer-time PCTime date Apr 6 2003 2:00 Oct 12 2003 12:00
    no ip cef
    ip dhcp excluded-address 192.168.1.1 192.168.1.10
    ip dhcp excluded-address 192.168.1.151 192.168.1.255
    ip dhcp pool FONINSA
     network 192.168.1.0 255.255.255.0
     default-router 192.168.1.1 
     dns-server 8.8.8.8 8.8.4.4 
    ip dhcp pool Laptop-Sporta-Wifi
     host 192.168.1.10 255.255.255.0
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    no ipv6 cef
    multilink bundle-name authenticated
    crypto pki trustpoint TP-self-signed-213585710
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-213585710
     revocation-check none
     rsakeypair TP-self-signed-213585710
    crypto pki certificate chain TP-self-signed-213585710
     certificate self-signed 01
      30820229 30820192
      quit
    license udi pid CISCO2901/K9 sn
    license boot module c2900 technology-package securityk9
    username ccp privilege 15 password
    redundancy
    interface Embedded-Service-Engine0/0
     no ip address
     shutdown
    interface GigabitEthernet0/0
     ip address 190.196.21.98 255.255.255.248
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface GigabitEthernet0/1
     ip address 192.168.1.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly in
     duplex auto
     speed auto
    no ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip nat inside source static tcp 192.168.1.3 21 190.196.21.98 21 extendable
    ip nat inside source static tcp 192.168.1.3 80 190.196.21.98 80 extendable
    ip nat inside source static udp 192.168.1.8 1194 190.196.21.98 1194 extendable
    ip nat inside source static tcp 192.168.1.4 3389 190.196.21.98 3389 extendable
    ip nat inside source static tcp 192.168.1.9 3389 190.196.21.98 10000 extendable
    ip nat inside source static tcp 192.168.1.3 3389 190.196.21.98 20000 extendable
    ip route 0.0.0.0 0.0.0.0 190.196.21.97
    access-list 1 permit 192.168.1.0 0.0.0.255
    control-plane
    line con 0
     password $
    line aux 0
    line 2
     no activation-character
     no exec
     transport preferred none
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
     stopbits 1
    line vty 0 5
     access-class 23 in
     privilege level 15
     password #
     transport input telnet ssh
    no scheduler allocate
    end

  • Data sync between exchange 2003 and exchange 2013

    Need assistance on a general direction.
    There is a 2003 domain with exchange 2003 currently in use. On this domain there is also a contact management application that is heavily integrated and cannot be update at this time.  I would like to bring up a new 2013 exchange server.
    Is there a method that I could have user data synchronized between the 2013 exchange data and the 2003 exchange? In this manner users could use the 2013 exchange as primary and the Contact manage application could use the sync copy of exchange 2003. For
    now I am only concerned about he the calendar however I am sure the other information will need to be sync as well.
    Please let me know.  Thank you.

    Hi There,
    Once you install Exchange 2013 it will use the same data your Exchange 2003 is using \ seeing because both of them use Active directory for Directory information.
    Exchange 2013 will see all the users that are 2003 without you needing to sync \ move data.
    If you need to users to be on Exchange 2013 and keep Exchange 2003 all you need to do is move the mailboxes to Exchange 2013.
    Cheers,
    Exchange Blog:
    www.ntweekly.com
    MCSA, MCSE, MCITP:SA, MCITP:EA, MCITP:Enterprise Messaging Administrator 2010,MCTS:Virtualization

  • Issues between power, usb and airport?

    Well, after having my new MacBook Pro for only a couple of weeks, I've come to the conclusion that there are some pretty weird issues between the power manager, usb bus and airport (and from what I've read here, are pretty widespread issues). First, every time I charge the battery, my Logitech MX laser mouse stutters and jumps all over the screen (trackpad works smoothly though). If I turn off airport, the mouse works smoothly again. When the battery is done charging, the mouse will work smoothly again. Second, every now and then (when the mouse isn't connected) the trackpad will start to stutter and jump all over the screen. When this happens, I've noticed that the graphics card is running slowly as well (expose stutters). Both of these issues can then be remedied by one of two actions, either plug something into a usb port, or turn off airport. I am also suffering from the missing first letter issue, which also seems to go away by disabling airport... So, since disabling airport most of the time is not an option, anyone care to take a guess as to how long it will take Apple to come up with a fix to these issues?

    TM does not backup to a networked drive in the same way as a directly connected drive. A networked drive requires the creation of a .sparsebundle disc image file that holds the actual backed up files. So when you shift from direct to networked connection TM actually makes a different backup. This is unrelated to the actual type of port connection. So there's really nothing you can do to have TM use one backup for each type of connection used in your situation.

  • 2008r2 RDS Copy / Paste issue between remote app and client

    I am running a 2008r2 Remote App server with Win7/XP(sp3) clients.  All devices are up to date on current service packs and patches.  I can open RDWeb applications and paste between other RDWeb applications, but cannot paste from RDWeb to local
    applications.  I can also paste between various locally running applications, but not from a local application to an RDWeb application.  Each machine is maintaining it's own paste buffer, but not exchanging between the server and local machine.
    I have tried using different applications on both local and remote app, with the same results (Word, excel, notepad).
    I have verified the client and server settings are set to allow printer and clipboard resources, and have verified that there are no GPO's applied to either the server or client.
    I have tried to include as much relative information as I can, please feel free to ask any questions and I will do my best to get back to you as quickly as possible.
    Any help resolving this is most appreciated!
    Sean

    Hi Sean,
    I wish most of the posters would be as detailed as you are. Good troubleshooting! :)
    Two things to try:
    1) when you connect DIRECTLY to the server via MSTSC and set a checkbox in the OPTIONS/Local Resources - to share Clipboard - do you then get the Copy paste working?
    IF SO
    2) Then please make sure that the Published applications - RemoteApp - have an additional line (Custom RDP settings) in properties (you miht need to recreate the RemoteApp's
    redirectclipboard:i:1
     then it should work.
    Virtualization Conference “PubForum 2011 Dublin”,
    The Bible of Remote Desktop Services! , Microsoft Virtualization Solutions Day Dublin!

Maybe you are looking for

  • How do I get Verizon to send ebills?

    This has been working fine up to now.  Verizon sends ebill through my bank; the bank notifies me; I log in to the bank website and pay the bill.  Now there seems to be something wrong someplace. Message from bank: VERIZON WIRELESS requires additional

  • Ix2-200 VERY slow accessing files via osx 10.10

    ix2-200 running fine. Drives are good. Using latest firmware 2.1.46.30093. Can manage via browser just fine. Connect to server using smb ipaddr and it mounts up just fine. I can open the directory (using osx 10.10.1) with finder just fine, but when I

  • Can I avoid closing Firefox entirely when "red Xing" a page to get rid of it?

    I'm new to Firefox so bear with me......Whenever I use the red x at the top right-hand corner to get rid of a page that doesn't allow me to go back one page, I get a message from Firefox - "Do you want to close all 4 tabs?"......the only answer is "y

  • Stock Transport Price - Inventory Cost

    Hi All, I have 2 plants under the same company code Company code: BP01 Plant 1: BP01 Plant 2: BP02 Material "A" is created in both the plants. BP01 creates a stock transport PO to BP02, BP02 creates the delivery against the PO & goods issue is done f

  • Need help with chart problem

    I have built the attached vi to read a binary file. It has two problems which I have not been able to figure out. The way it works is as follows: Reads the entire file, and grabs the trace names from the file. Populates the list box with these names.