Calculating Bandwidth

How to calculate total bandwidth utilization of a circuit if i have In and Out data rate? Is there any formula?

Um, monitoring the circuit using MRTG or something similar would be a good way of doing this. To work out the average utilization, you could do the following: Average_Input=Total_Input (in BITS)/ Time (in SEC), Avg_Out=Total_Out (BITS) / Time (sec)
Eg:
Last clearing of "show interface" counters 11w3d
Input queue: 0/75/0 (size/max/drops); Total output drops: 2051
Queueing strategy: weighted fair
Output queue: 0/1000/64/2046 (size/max total/threshold/drops)
Conversations 0/81/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
30 second input rate 33000 bits/sec, 3 packets/sec
30 second output rate 7000 bits/sec, 2 packets/sec
53836304 packets input, 2893045321 bytes, 0 no buffer
Received 0 broadcasts, 1384 runts, 3 giants, 0 throttles
1424 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored, 16 abort
58226253 packets output, 1732843968 bytes, 0 underruns
Avg_Input=2893045321bytes / 11w3d
Avg_Input=23144362568bits / 80days so
Avg_Inout=23144362568bits / 6912000seconds... Therefore
Avg_Input=3348 bits-per-second (bps) (Hehe, this is on a T3, the customer is paying us for a T3 for an average of 3.3kbps!)
This is purely an average. They could have been idle for 11w2day and then apssed all of the traffic in the last day. Without historical data there is not way of knowing...

Similar Messages

  • Calculating Bandwidth... - easy question

    I need to calculate bandwitdh to figure out what kind of connection i need. I know if i take ONE single computer with wireshark loaded then run the programs then stop the capture.....How long do i need to capture it for? 1 minute, or 10 minutes, or ? Then once i capture the data, what do i do with it?
    Help!
    Thank you

    I need to calculate bandwitdh to
    figure out what kind of connection i need. I know if i take ONE single
    computer with wireshark loaded then run the programs then stop the
    capture.....How long do i need to capture it for? 1 minute, or 10
    minutes, or ? Then once i capture the data, what do i do with it?Help!Thank you
    Hi,
    By capturing packets it wont help to calculate the bandwidth requirement genral practices and approach is you need to consider the concurrency usage ratio from single PC based on which you can determine the bandwidth to be subscribed from your service provider.You also need to check out whether upload or the download traffic.
    Best practice also would be to subscribe for lesser bandwidth for short duration and observe the peak/average usage on the links and based on that you can decide the actual bandwidth requirement for your facility.
    Hope to Help !!
    Remember to rate the helpful post
    Ganesh.H

  • Calculating bandwidth costs??

    Id like to calculate the per transaction costs of my app
    its pretty much a timer that goes off every 3.5 secs, connects to some server, downloads a chunk of data for processing..it isnt exactly streamed...
    heres the code
    myURL = new URL (someAddy);
    myURLConnection = (HttpURLConnection)myURL.openConnection();
    myURLConnection.setRequestMethod("POST");
    myURLConnection.setDoOutput(true);
    BufferedReader input = new BufferedReader(new InputStreamReader(myURLConnection.getInputStream()));
    while (null != (str = input.readLine())) {
        processString = processString + str + "\n";
    input.close();so im guessing "input" is the chunk of data that is retrieved every 3.5 secs..how can i determine the size of it?
    byte[] bytes = input.toString().getBytes();
    int total = 0;
    for(int i=0; i<bytes.length; i++){
        total += bytes;
    System.out.println("Size at: " + i + " " + bytes[i] + " total: " + total);
    heres the typical output of this: Size at: 29 54 total: 2656
    so it looks like at element 29 of the byte[], totals 54 bytes, but the accumlation of elements 0-29 is 2,656 bytes?
    of course this probably doesnt input packet headers, check sums and all that
    anyone know of a better more accurate way of doing this?
    i tried using network monitoring software "NetLimiter" which gives me the average downloaded # of Bytes...but my boss wants a "per transaction number"
    shrug
    thanks for the help

    Won't the exact number vary based on the contents of the request and the reply.
    The only reliable way to detremine the number and size of the packets is to use a network sniff. You boss may decide she doesn't need to know the exact number that much.

  • Dynamic Buffering Based on Bandwidth and Datarate

    I'm trying to determine an initial value for NetStream.bufferTime based on the client's calculated bandwidth and the video's bitrate.
    As far as I can tell you can't do this, because you must have an initial buffer set BEFORE you call NetStream.play() (or use the default 2 seconds) and FMS does not call NetStream.onMetaData, where one would normally find the videodatarate, until after NetStream.play() is called.
    Even if you modify NetStream.bufferTime during the onMetaData call back it doesn't effect when the video starts playing or when the NetStatus event registers "NetStatus.Buffer.Full".
    Therefore my question is:
    How do I find the Video Data Rate BEFORE I call NetStream.play?
    -Or-
    How do how do I reset the initial bufferTime before acctual play back begins and the NetStatus event fires with "NetStatus.Buffer.Full"

    I think you are right. Without playing the stream you cant decide it datarate.

  • Ipad mirroring or streaming for quality

    I now have two ways of streaming music and movies from my ipad and i phone.to my speakers and tv.
    Both use appletv.
    One is to connect using airplay and the other is to use mirroring.
    Is there any difference in the quality of media when these methods are compared?
    Thanks

    On Thu, 17 Apr 2008 13:40:41 +0000 (UTC), "foxteeth"
    <[email protected]> wrote:
    >progressive will basically push the video immediately to
    >the client regardless of speed and may or may not have to
    buffer
    Video buffering can be adjusted at client side within your
    SWF file,
    which plays FLV.
    >Streaming on the other hand will calculate
    >the speed at which the visitor is trying to
    >connect
    It is easy to do the same using special bandwidthmeter. I saw
    several
    such SWF-based tricks, which all loads a file of known size
    and
    measure downloading time. Then you can switch between
    different video
    sources depending on the the calculated bandwidth value.
    >and serve up different quality (size) videos
    >depending on client connection.
    And this is also doable by simple PHP script, delivering
    video file to
    your client. Just create a file reading cycle with short
    pauses within
    it, defined by the average delivery bandwidth preset value. I
    use such
    method and it works really good for a more or less stable
    cable
    channels. The only disadvantage relatively to true streaming
    is that
    such method works not so good with VBR streams. Because it
    has no
    information about real bitrate of each portion delivered.
    Therefore
    you need to add some extra bandwidth portion for some
    unpredictable
    delivery issues. E.g. if your video has 256 kbps and your
    audio has 64
    kbps it doesn't mean that your total bandwidth preset value
    should be
    320 kbps. It should be done a bit greater, for example 350 to
    380
    kbps. That will work for any case.

  • Snmp and ifspeed

    I am confused about the value that is returned in a snmp query to the 4250-sx for the interface speed. Could you please help me to understand? When I query the ids 5.1 x sensor with snmpwalk, it returns with a value of 10000000 which = 10 Mbps
    root:~# snmpwalk -v2c -c community sensor ifSpeed
    IF-MIB::ifSpeed.1 = Gauge32: 10000000
    IF-MIB::ifSpeed.2 = Gauge32: 10000000
    IF-MIB::ifSpeed.3 = Gauge32: 10000000
    IF-MIB::ifSpeed.4 = Gauge32: 10000000
    This is incorrect as the device has gigabit interfaces installed. It is my understanding that some network monitoring programs use this value when calculating bandwidth used.
    Why does the interface return the incorrect value?

    I have confirmed that the snmp on Firmware v1.0.3.09 doesn't report ifSpeed properly and always reports the same results regardless of port configuration. This has been reported to Linksys engineering.
    For testing I used snmpwalk on a Debian Linux system:
    snmp list interfaces:
    root@McDev1:~# snmpwalk -Os -c public -v 2c 192.168.1.1 1.3.6.1.2.1.2.2.1.2
    iso.3.6.1.2.1.2.2.1.2.1 = STRING: "lo"
    iso.3.6.1.2.1.2.2.1.2.2 = STRING: "ifb0"
    iso.3.6.1.2.1.2.2.1.2.3 = STRING: "ifb1"
    iso.3.6.1.2.1.2.2.1.2.4 = STRING: "teql0"
    iso.3.6.1.2.1.2.2.1.2.5 = STRING: "sit0"
    iso.3.6.1.2.1.2.2.1.2.6 = STRING: "ip6tnl0"
    iso.3.6.1.2.1.2.2.1.2.7 = STRING: "eth0"
    iso.3.6.1.2.1.2.2.1.2.8 = STRING: "eth1"
    iso.3.6.1.2.1.2.2.1.2.9 = STRING: "eth2"
    snmp list interfaces speeds:
    root@McDev1:~# snmpwalk -Os -c public -v 2c 192.168.1.1 1.3.6.1.2.1.2.2.1.5
    iso.3.6.1.2.1.2.2.1.5.1 = Gauge32: 10000000
    iso.3.6.1.2.1.2.2.1.5.2 = Gauge32: 10000000
    iso.3.6.1.2.1.2.2.1.5.3 = Gauge32: 10000000
    iso.3.6.1.2.1.2.2.1.5.4 = Gauge32: 0
    iso.3.6.1.2.1.2.2.1.5.5 = Gauge32: 0
    iso.3.6.1.2.1.2.2.1.5.6 = Gauge32: 0
    iso.3.6.1.2.1.2.2.1.5.7 = Gauge32: 1000000000
    iso.3.6.1.2.1.2.2.1.5.8 = Gauge32: 1000000000
    iso.3.6.1.2.1.2.2.1.5.9 = Gauge32: 10000000
    Please remember to Kudo those that help you.
    Linksys
    Communities Technical Support

  • Bandwidth Calculation based on Network IP Address on SNMP Cisco 3750

    Dear All,
    Instead of getting bandwidth calculation on cisco switch via snmp for total in and out or based on port, is it possible to get the calculation of bandwidth for in and out for the C Class IP on the network ? That mean i can get the calculation for each of my network IP address from the Cisco, what i'm doing now is to get from my bridge server and i run the iptables and some bash script and also MRTG
    Please advice. TQ

    Hi Abhi,
    you're welcome. Thanks for rating & marking as answered!
    I have CISCO 6503 box also with me. Could you please confirm if feature would be supported on 6503 ethernet ports or not?
    Have a look at the Release Notes:
    http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/release/notes/features.html#wp2800031
    "New Software Features in Release 12.2(18)SXF2
    Support with Supervisor Engine 2 for these features, which are already supported with other Supervisor Engines: 
    - IP unnumbered for VLAN-SVI interfaces
    -VLANs over IP unnumbered sub-interfaces"
    I have to say I've never done this so far on a c6500 but I think you can rely on the RN.
    HTH
    Rolf

  • MQC Bandwidth Percenage Calculation

    Hello Guys,
    I want to setup qos bandwidth policing&priority. I want to allocate 50% of my Internet link bandwidth to the PRIORITY-QUEUE, and 50% of the bandwith for other Web-traffic and default-traffic.
    My question is:   while i configure and give 50% bandwidth for priority-queue,     is that 50% calculated from the Fasthethet Interface bandwidth or it is automatically calculated from my  Internet-Bandwidth and allocates  50% from that bandwidth space.
    To make it clear :  lets say a Fastethernet-Interface speed/bandwidth is bydefault  100-Mbps.  and lets say my Interface bandwidth which i have taken from ISP is  512-kbps.     so when i start to do bandwidth alllocation , and give 50% of interface bandwidth to priority-queue and 50% for other traffic.    how the allocation is calculated.....????  
    please instruct

    Hi,
    Please check whether WT /102 is available or not in the input table
    Also you used which function to write PCR? ACTIO or something else??
    Regards,
    Uday

  • ASA5510 VPN Bandwidth Calculations

    Were running an ASA5510 with multiple IPSEC VPN clients over a 100Mb leased line. At the moment we have about 10 active clients however we are looking at gearing up to about 100 clients.
    Question is, is there a known method for calculating the required bandwidth for this number of clients or indeed obtaining metrics from already connected clients to help with this calculation.
    We have tried a few monitoring products, most notably Solarwinds, however none of the products we have tried seems to be able to give us the throughput of the individual VPN connections to assist with our calcs....

    Hi Rob,
    Check  out VPNTTG (VPN Tunnel Traffic Grapher) is a software for SNMP  monitoring and measuring the traffic load for IPsec  (Site-to-Site,  Remote Access) and SSL (With Client, Clientless) VPN  tunnels on a Cisco  ASA. It allows the user to see traffic load on a VPN  tunnel over time  in graphical form.
    Advantage of VPNTTG over other SNMP based monitoring software's is   following: Other (commonly used) software's are working with static OID   numbers, i.e. whenever tunnel disconnects and reconnects, it gets   assigned a new OID number. This means that the historical data,  gathered  on the connection, is lost each time. However, VPNTTG works  with VPN  peer's IP address and it stores for each VPN tunnel  historical  monitoring data into the Database.
    For more information about VPNTTG please visit www.vpnttg.com

  • DMS server sizing calculation

    HI Gurus,
    My client has given that Finance department is generating documents around 20 GB  per month (includes all types of format) now i have to create the Server sizing for this 20 GB kindly help on how to proceed. Is there is any standard calculation for this.
    Regards
    Kannan

    Recommended approach for managing Finance documents is SAP Archivelink solution(refer previous posts in forum).
    Content server sizing is a separate exercise that you need to carry out in conjunction with your Basis team and the customer. Capture details along parameters like Office/Plant from where docs would be accessed, the available network bandwidth,number of users,number of transactions per day,maximum size of a single file,number of documents generated/day that would be uploaded and the growth plan for the next 3 years.Once done,the Basis team will provide you with details like CPU,RAM,OS,bandwidth and hard disk space that would be needed from which the cost can be calculated.
    Regards,
    Pradeepkumar Haragoldavar

  • What should be the quality of video and audio for bandwidth 768KB

    Hello Friends
    We are provoding 768kB bandwidth for our connection. Can any body tell us what should be the quality of video and audio we can set that does not effect frame rate which is 24 FPS.
    thanks in advance.

    Hi Samir
    You could try out the bitrate calculator at http://www.adobe.com/devnet/flash/apps/flv_bitrate_calculator/ . It lets you try various encoding settings to see what fits best for the bandwidth available to you.
    Regards
    Mamata

  • How to calculate network bandwidth for dataguard 11.2

    Hi all,
    have a customer who needs to setup a new data guard environment in release 11.2.0.2. Primary site will be in Italy, standby site will be in New York.
    He would like to know the network bandwidth between primary and standby site needed to obtain the maximum performance in redo transport with or without compression option.
    I found a lot of threads and docs indicating some formulas but none of them explained how to:
    - calculate network bandwidth on a rac system (having a single instance standby database)
    - calculate network bandwidth in case of use redo transport compression
    - calculate cpu consumption if using redo transport compression
    Could you please give any advice?
    A.M.

    Hi,
    customer made ma a lot of technical question just like the following:
    - which are the main factors determining the 30% overhead indicated in the network bandwidth calculation
    Required bandwidth = ((Redo rate bytes per sec. / 0.7) * 8) / 1,000,000 = bandwidth in Mbps
    - how much bandwidth will I gain if I apply redo transport compression and why redo transport compression and why usually the gzip utility gives me 5X less and oracle compression gives me a maximum of 50-60% of compression even if it uses the same engine of zlib compression as indicated below?
    Data Guard redo transport compression uses the same zlib compression engine at level 1 as gzip -1. To estimate the compression ratio you can achieve using Data Guard redo transport compression, first compress an archived redo log file with gzip:
    $ gzip -1 <archive redo logfile>.arc
    Then use the gzip --list option to explicitly display the compression ratio:
    $ gzip --list <archive redo logfile.arc>.gz
    Note: Use gzip version 1.3.3 or later. Refer to www.gzip.org for the latest information on gzip.
    Could anyone give me any direction?
    Thank you
    AM

  • How to monitor bandwidth on Catalyst via SNMP?

    I've got c3750g with 12.2(55)SE.
    When I try ifSpeed (1.3.6.1.2.1.2.2.1.5), i've got 1 peak 999999999 and then only 0. Polling is 1 second.
    When I try ifHighSpeed (1.3.6.1.2.1.31.1.1.1.15), I've 0 also.
    When I try ifInOctets from snmp-v2 MIB (1.3.6.1.2.1.2.2.1.10), I've got results, but since it summary - my software cannot do calculations and I cant get instant interface bandwidth.
    Is there any solutions for catalyst?

    Hi,
    Are you saying ifSpeed. is changing value from one poll to the next? What kind of interface is it? Sounds like a bug, or an error in polling. Please post the snmpwalk of ifDescr, ifType, and ifSpeed.
    For the ifHighSpeed issue, from the IF-MIB entry about that object: "For a sub-layer which has no concept of                bandwidth, this object should be zero." Are you polling ifHighSpeed on a sub-layer interface?
    Bandwidth utilization is always calculated by taking multiple readings of in or out counters. There will not be a separate counter kept in our snmp agent, when separate values already exist and can be calculated. Thus, since you can use ifSpeed and poll ifInOctets to get the delta, and then calculate the result, our snmp agent will not contain the utilization number.
    If you want a graph of bandwidth utilization over time, I would suggest obtaining MRTG. It is available free of charge over the web, just search for MRTG download.
    Hope that helps,
    Curtis

  • IOS-G2, ASR1K how shaper is calculated

    Hi together out there,
    I am doing a little bit troubleshooting with QOS and shaping.
    It s always a little bit difficult to find out how our Provider is calculating the BW they are offering to us and how we are calculating our shaping target rate.
    Normally we are using config like following.
    Now the question is what is used for calculating the shaping-rate:
    Is it the whole packet including L2-Header
    Is it just the packet with L3-Header and GETVPN-Header, without L2-Header
    Is it just the packet only with original L3 Header
    This Info is important so we can shape to the correct BW we agreed with ISP
    Thanks in Advance
    Hubert
    policy-map xQOS-QUEUE-POLICY
     class xQOS-CLASS-EF_Realtime_Voice
        priority percent 20
     class xQOS-CLASS-CS6_Network_Control
        bandwidth remaining percent 5
     class xQOS-CLASS-CS5
     class xQOS-CLASS-AF41
        bandwidth remaining percent 10
     class xQOS-CLASS-CS4_Realtime_Video
        bandwidth remaining percent 35
        queue-limit 256 packets
     class xQOS-CLASS-AF31_Video_Streaming
        bandwidth remaining percent 8
     class xQOS-CLASS-CS3_Realtime_Signalling
        bandwidth remaining percent 3
     class xQOS-CLASS-AF21_Transactional_Data
        bandwidth remaining percent 10
     class xQOS-CLASS-CS2_Management_OAM
        bandwidth remaining percent 3
     class xQOS-CLASS-AF11_Bulk_Data
        bandwidth remaining percent 5
        queue-limit 512 packets
     class xQOS-CLASS-CS1_Scavanger_Data
        bandwidth remaining percent 1
     class xQOS-CLASS-BE_Best_Effort
        bandwidth remaining percent 15
        queue-limit 128 packets
    policy-map xQOS-SHAPED-10000-QUEUE-POLICY
     class class-default
        shape average 10000000 100000 0
      service-policy xQOS-QUEUE-POLICY
    interface GigabitEthernet0/3
     description Provider Etherlink
     bandwidth 100000
     no ip address
     load-interval 30
     duplex full
     speed 100
     media-type rj45
    no shut
    interface GigabitEthernet0/3.1111
     description 10Mbit/s-EthMP to Branch
     bandwidth 10000
     encapsulation dot1Q 1111
     ip address 10.200.111.1 255.255.255.252
    ip tcp adjust-mss 1320
    ip ospf network point-to-point
     bfd interval 200 min_rx 200 multiplier 3
     crypto map MAP-SECURE-WAN
    service-policy output xQOS-SHAPED-10000-QUEUE-POLICY

    Hi together out there,
    I am doing a little bit troubleshooting with QOS and shaping.
    It s always a little bit difficult to find out how our Provider is calculating the BW they are offering to us and how we are calculating our shaping target rate.
    Normally we are using config like following.
    Now the question is what is used for calculating the shaping-rate:
    Is it the whole packet including L2-Header
    Is it just the packet with L3-Header and GETVPN-Header, without L2-Header
    Is it just the packet only with original L3 Header
    This Info is important so we can shape to the correct BW we agreed with ISP
    Thanks in Advance
    Hubert
    policy-map xQOS-QUEUE-POLICY
     class xQOS-CLASS-EF_Realtime_Voice
        priority percent 20
     class xQOS-CLASS-CS6_Network_Control
        bandwidth remaining percent 5
     class xQOS-CLASS-CS5
     class xQOS-CLASS-AF41
        bandwidth remaining percent 10
     class xQOS-CLASS-CS4_Realtime_Video
        bandwidth remaining percent 35
        queue-limit 256 packets
     class xQOS-CLASS-AF31_Video_Streaming
        bandwidth remaining percent 8
     class xQOS-CLASS-CS3_Realtime_Signalling
        bandwidth remaining percent 3
     class xQOS-CLASS-AF21_Transactional_Data
        bandwidth remaining percent 10
     class xQOS-CLASS-CS2_Management_OAM
        bandwidth remaining percent 3
     class xQOS-CLASS-AF11_Bulk_Data
        bandwidth remaining percent 5
        queue-limit 512 packets
     class xQOS-CLASS-CS1_Scavanger_Data
        bandwidth remaining percent 1
     class xQOS-CLASS-BE_Best_Effort
        bandwidth remaining percent 15
        queue-limit 128 packets
    policy-map xQOS-SHAPED-10000-QUEUE-POLICY
     class class-default
        shape average 10000000 100000 0
      service-policy xQOS-QUEUE-POLICY
    interface GigabitEthernet0/3
     description Provider Etherlink
     bandwidth 100000
     no ip address
     load-interval 30
     duplex full
     speed 100
     media-type rj45
    no shut
    interface GigabitEthernet0/3.1111
     description 10Mbit/s-EthMP to Branch
     bandwidth 10000
     encapsulation dot1Q 1111
     ip address 10.200.111.1 255.255.255.252
    ip tcp adjust-mss 1320
    ip ospf network point-to-point
     bfd interval 200 min_rx 200 multiplier 3
     crypto map MAP-SECURE-WAN
    service-policy output xQOS-SHAPED-10000-QUEUE-POLICY

  • Bandwidth requirec for Oracle 11g ADF application

    Hi
    What is the idel bandwidth recomend for oracle 11g ADF web application .

    Can't be answered without knowledge of the app you are talking about.
    100 user doesn't mean they are all active at once and even if they are it depends on how much data your app processes. This can't be answered from out point of view.
    So your task is to find out how many users are doing what at a given time interval and then find out how much data is processed (there are plenty of tools available to measure this).
    How a bout a test run with e.g. 10 users doing normal work with our app, measure the amount of data and calculate the bandwidth from there. Don't forget to take service level agreements (e.g. a page has to be submitted in x seconds) into your calculations.
    Timo

Maybe you are looking for

  • Variant Length 45 char limit - Help

    Friends, Iam developing a program to download all variants from current environment which are to be uploaded on other environment. Im using RS_VARIANT_CONTENTS FM. Problem is : when I Extract I get only 45 length limit for the variable value on the s

  • Org Level in ERM

    Hi , In Role Management Tab, under Roles when we go to search and try to assign the derived roles the system is not able to display any values in the dropdown in Derived Org. Level. These values are already maintained in Configuration. Thanks in adva

  • FM to create Business Partner GUID

    Hi , Is there any FM / report to create Business Partner GUID in CRM ? Thanks & Regards, Rahul D

  • Disabling all communication channels before starting XI

    We are mirroring our XI system for DR purposes and I need to work out how to stop XI from retrieving and delivering messages when I start it up.  I want to be able start up the DR system on the same network to check that it looks OK, but with all com

  • Youtube does not work in the new version 13

    youtube gives you an error message, this is not happening with other browsers or with your older versions