Check for VPN Connection Exists

Hello
I am working on a windows store app for Enterprise. This app will require internet and VPN connection to get data. I have found a way to check for internet access. However, I am not sure how to check if there is a VPN tunnel available. If VPN is available
then I can make a call to a WebService and get data. If there is no VPN then the WebService call will fail [after about 10-15 seconds]. I can assume that if the WebService calls fails that means there is no VPN but there must be another way to find this out
before even calling a Service.
Please help.
Thanks
Bevan

We're using Microsoft Direct Access rather than a VPN but I think this is worth sharing anyway.
Rather than calling a web service I'm just using the HttpClient's GetAsync() method to call a small file hosted on an internally hosted web server. This minimises the payload as much as possible which may be important if your users are connected using devices
with 3G/4G with data limit.
I'm wrapping the call in a Stopwatch to get a rough idea of the round robin request/response and visualising that for the users so they know how good their connection to the corporate network is. This info is far more useful than the WiFi/Mobile signal bars.
Stopwatch stopWatch = new Stopwatch();
stopWatch.Start();
HttpClient httpClient = new HttpClient();
HttpResponseMessage response = await httpClient.GetAsync(nslUri);
response.EnsureSuccessStatusCode(); // -- throw exception if not a success code
stopWatch.Stop();
TimeSpan ts = stopWatch.Elapsed;
This might also be of interest...
https://msdn.microsoft.com/en-us/library/windows/apps/xaml/windows.networking.vpn.aspx

Similar Messages

  • What is the easiest way to check for internet connection in C#?

    Hi!
    I searched a lot but I didn't get my answer. I'm looking for the easiest way to check for internet connection. Can you help me?
    Thanks a lot.

    Hi Pouya Ebrahimzadeh,
    I suggest you could connect a site to check if it can be opened.
    Public Shared Function CheckForInternetConnection() As Boolean
    Try
    Using client = New WebClient()
    Using stream = client.OpenRead("https://msdn.microsoft.com/")
    Return True
    End Using
    End Using
    Catch
    Return False
    End Try
    End Function
    If you have any other concern regarding this issue, please feel free to let me know.
    Best regards,
    Youjun Tang
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click
    HERE to participate the survey.

  • Entering Correct info for VPN connection

    please suggest the correct configuration for entering information in order for my laptop to connect via VPN to my newly installed Leopard Server software. On my laptop, I have entered the following info on the System Preferences> network tab...
    Configuration: Default
    Server Address: 76.173.xx.xxx (my public IP address - do I need anything else?)
    Account name: XXXXXX (same as the account name in Server)
    under Authentication Settings, my password is fine and my shared secret is the same as on the Server.
    Am I entering in everything correctly? i am most concerned as to how the server address is supposed to be written. thanks!!

    Hi
    If Appletalk is enabled server side and you simply enter the IP address afp is assumed as the protocol to be used. If you prefer the extra effort involved in typing afp:// followed by the IP address you can use that as well. If you want to use the smb service rather than afp simply type smb://followed by the IP address. The same thing applies to ftp services. The Finder supports reads only for ftp services.
    If you are using VPN services you simply type in the private IP (LAN-side) address of the server rather than the public IP (WAN-side) address. Once a VPN connection has been established, the remote client behaves as if it is on the same LAN.
    You can make a connection using the Public WAN address if you enable port forwarding to a single LAN IP address for services you are interested in. For example if you wanted to access your server remotely using afp you configure your router to forward requests for port 548 to the internal IP address of your server. You can use this method for as many services you like as well as how many your router supports. Most commercially available routers support 10-20. Depending on the router you may have to configure an appropriate firewall rule as well. When faced with that it makes more sense to use a single VPN connection.
    I may be in danger of teaching granny to suck eggs but for what its worth for VPN connections to work successfully the remote client’s private IP address has to be different from the host site. For example if the remote site is on 192.168.1.x/24 as is the server then you won’t establish a connection. As far as the remote site is concerned its already connected to that network, why look elsewhere? 192.168.1.x/24 to 192.168.2.x/24 or 10.10.10.x/24 to 192.168.0.x/24 should result in successful VPN connections.
    For a list or IP addresses reserved for private use:
    http://www.iana.org/faqs/abuse-faq.htm#SpecialUseAddresses
    Hope this helps, Tony

  • Trying to set a delay in an Applescript for VPN connection

    I need to be able to set some routes upon opening a particular VPN connection so I did some searching and found a really simple Applescript that does the job. Problem is it tries to set the routes before the VPN actually connects so the routes don't go in.
    I added in a 10 second delay which does the trick, but I'm thinking there has to be a way to do this that waits until the VPN actually connects before continuing - so if it takes 5 seconds or 10 or whatever, it waits.
    The other thing I'm doing that I think is bad is I'm sending a route delete command before sending the add command. Why? Because if I don't and for some reason the route is partially in the table, it doesn't give an error and ends up not routing. Again, probably a better way to do this.
    Here is my current script"
    -- Connect Work VPN
    tell application "System Events"
    tell current location of network preferences
    set VPNservice to service "Work" -- name of the VPN service
    if exists VPNservice then connect VPNservice
    end tell
    end tell
    delay 10
    set gateway to "x.x.x.x" -- omitted here for security
    do shell script "route delete 192.168.25.0/24 " & gateway with administrator privileges
    do shell script "route delete 192.168.20.0/24 " & gateway with administrator privileges
    do shell script "route add 192.168.25.0/24 " & gateway with administrator privileges
    do shell script "route add 192.168.20.0/24 " & gateway with administrator privileges
    Any suggestions??
    Thanks.

    you might want to try asking in the Applescript forum under OS X technologies.
    I don't have any VPN connections so can't test anything but applescript dictionary for system events indicates that configuration property of a service has a boolean property "connected". so just run a loop with, say, 1 second delay until this porperty becomes true. presumably it would be something along the lines
    <pre style="
    font-family: Monaco, 'Courier New', Courier, monospace;
    font-size: 10px;
    margin: 0px;
    padding: 5px;
    border: 1px solid #000000;
    width: 720px;
    color: #000000;
    background-color: #ADD8E6;
    overflow: auto;"
    title="this text can be pasted into the Script Editor">
    tell application "System Events"
    tell current location of network preferences
    set VPNservice to service "Work" -- name of the VPN service
    if exists VPNservice then connect VPNservice
    repeat until (connected of current configuration of VPNservice)
    delay 1
    end repeat
    end tell
    end tell
    set gateway to "x.x.x.x" -- omitted here for security
    do shell script "route delete 192.168.25.0/24 " & gateway with administrator privileges
    do shell script "route delete 192.168.20.0/24 " & gateway with administrator privileges
    do shell script "route add 192.168.25.0/24 " & gateway with administrator privileges
    do shell script "route add 192.168.20.0/24 " & gateway with administrator privileges</pre>

  • Cisco ISE posture check for VPN

    Hello community,
    first of all thank you for taking time reading my post. I have a deployment in which requires the feature posture checks on VPN machines from Cisco ISE. I know logically once a machine is in the LAN, Cisco ISE can detect it and enforce posture checks on clients with the Anyconnect agent but how about VPN machines? The VPN will be terminated via a VPN concentrator which then connects to an ASA5555X which is deployed as an IPS only. Are there any clues to this? 
    Thank you!

    The Cisco ASA Version 9.2.1 supports RADIUS Change of Authorization (CoA) (RFC 5176). This allows for posturing of VPN users against the Cisco ISE without the need for an IPN. After a VPN user logs in, the ASA redirects web traffic to the ISE, where the user is provisioned with a Network Admission Control (NAC) Agent or Web Agent. The agent performs specific checks on the user machine in order to determine its compliance against a configured set of posture rules, such as Operating System (OS), patches, AntiVirus, Service, Application, or Registry rules.
    The results of the posture validation are then sent to the ISE. If the machine is deemed complaint, then the ISE can send a RADIUS CoA to the ASA with the new set of authorization policies. After successful posture validation and CoA, the user is allowed access to the internal resources.
    http://www.cisco.com/c/en/us/support/docs/security/adaptive-security-appliance-asa-software/117693-configure-ASA-00.html

  • Unable to set manual IP address for VPN connection

    Recently a VPN connection with a client stopped working. They changed phone companies and changed some of the IP addresses.
    After alerting them I could no longer log in, I received the new server address which I can log in with it,
    BUT my computer is assigned a dynamic address that is already in use on their network. This causes my computer to *not* be connected to their network, even though I am inside their firewall; therefore I cannot adjust the database files I need to.
    I have tried to set the VPN (PPTP) connection TCP/IP address IPv4 manually, using the static address they just gave me. But each time I connect, [I believe] their router assigns me an address that is already in use.
    They do not use IPv6.
    Can anyone give me direction on how to make the manual IP address *stick*?
    The tech person at the site keeps telling me it is a problem with my "Mac, because with Windows.... blah, blah, blah".
    I am pretty sure this is not the case and in fact I was the one who let her know I was receiving a duplicate address.
    Your VPN expertise is really appreciated.
    Thanks in advance,
    Michele

    Hi,
    Please make sure the Ad hoc connection IP adress is at the same range with your local connection. In addition, how about recreate the ad hoc connection for test, please have a try.
    If problem persists, please use Network troubleshooter in Action Center to fix this problem for test.
    Roger Lu
    TechNet Community Support

  • Zone Base Forewall for VPN connections does not work after IOS upgrade

    Hi all,
    We use cisco router 2911 as corporate gateway - there is Zone Based Firewall implemented - I upgraded IOS to last version (15.2(2)T1) - originaly version 15.1(4)M1 - to solve issue with Anyconnect connections (bug CSCtx38806) but I found that after upgrade the VPN users are not able to communicate with sources in other zones.
    More specific
    WebVPN use this virtual template interface
    interface Virtual-Template100
    description Template for SSLVPN
    ip unnumbered GigabitEthernet0/1.100
    zone-member security INSIDE
    There are other zones VOICE, LAB, ...
    In the policy any connection is allowed (used inspection of icmp, tcp and udp) from INSIDE zone to VOICE or LAB zone
    After VPN connection I am able to reach resources in INSIDE zone (which is the most important), but not in other zones. Before upgrade it worked.
    Once I changed zone in Virtual-Template interface to VOICE, I was able to reach sources in VOICE zone but not in any other. I searched more and found the stateful firewall is not working for connections from VPN as ping is blocked by policy on returning way - it means by policy VOICE->INSIDE, once I allowed communication from "destination" zone to INSIDE zone - the connections started to work, but of cause it is not something I want to setup.
    Does anybody has the same experiance?
    Regards
    Pavel

    It seems to me I should add one importatant note - if client is connected directly in INSIDE zone, he can reach resources in other zones without any issue - so the problem is only when the client is connected by VPN - not in ZBF policy setup.
    Pavel

  • Traffic only allowed one-way for VPN connected computers

    Hello,
    I currently have an ASA 5505.  I have set it up as a remote access SSL VPN. My computers can connect to the VPN just fine.  They just can't access the internal LAN (192.168.250.0).  They can't ping the inside interface of the ASA, or any of the machines.  It seems like all traffic is blocked for them.  The strange thing is that when someone is connected to the VPN, I can ping that VPN-connect machine from the ASA and other machines inside the LAN.  It seems the traffic only allows one way.  I have messed with ACL's with no avail.  Any suggestions please?
    DHCP Pool: 192.168.250.20-50 --> For LAN
    VPN Pool: 192.168.250.100 and 192.168.250.101
    Outside interface grabs DHCP from modem
    Inside interface: 192.168.1.1
    Current Running Config:
    : Saved
    ASA Version 8.2(5)
    hostname HardmanASA
    enable password ###### encrypted
    passwd ####### encrypted
    names
    interface Ethernet0/0
    switchport access vlan 20
    interface Ethernet0/1
    switchport access vlan 10
    interface Ethernet0/2
    switchport access vlan 10
    interface Ethernet0/3
    shutdown
    interface Ethernet0/4
    shutdown
    interface Ethernet0/5
    shutdown    
    interface Ethernet0/6
    shutdown
    interface Ethernet0/7
    switchport access vlan 10
    interface Vlan1
    no nameif
    no security-level
    no ip address
    interface Vlan10
    nameif inside
    security-level 100
    ip address 192.168.250.1 255.255.255.0
    interface Vlan20
    nameif outside
    security-level 0
    ip address dhcp setroute
    ftp mode passive
    dns domain-lookup inside
    dns domain-lookup outside
    pager lines 24
    mtu inside 1500
    mtu outside 1500
    ip local pool VPN_Pool 192.168.250.100-192.168.250.101 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    global (outside) 10 interface
    nat (inside) 10 192.168.250.0 255.255.255.0
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.250.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet timeout 5
    ssh 192.168.250.0 255.255.255.0 inside
    ssh timeout 5
    ssh version 2
    console timeout 0
    dhcpd dns 8.8.8.8
    dhcpd address 192.168.250.20-192.168.250.50 inside
    dhcpd enable inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    enable outside
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    svc image disk0:/anyconnect-macosx-i386-2.5.2014-k9.pkg 2
    svc image disk0:/anyconnect-linux-2.5.2014-k9.pkg 3
    svc enable
    tunnel-group-list enable
    group-policy DfltGrpPolicy attributes
    dns-server value 8.8.8.8
    vpn-tunnel-protocol IPSec l2tp-ipsec svc webvpn
    tunnel-group AnyConnect type remote-access
    tunnel-group AnyConnect general-attributes
    address-pool VPN_Pool
    tunnel-group AnyConnect webvpn-attributes
    group-alias AnyConnect enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect ip-options
      inspect netbios
      inspect rsh
      inspect rtsp
      inspect skinny 
      inspect esmtp
      inspect sqlnet
      inspect sunrpc
      inspect tftp
      inspect sip 
      inspect xdmcp
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    call-home
    profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:30fadff4b400e42e73e17167828e046f
    : end

    Hello,
    I seem to be having the same kind of issue although I cannot ping from either end.
    Ive set up a l2tp/ipsec vpn which I am able to connect to and get ip from my ip pool (radius authentication is working).
    I tried running:
    access-list NAT_0 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
    nat (inside) 0 access-list NAT_0
    but i get an error msg saying that the syntax of the nat command is deprecated. Im running ASA version 8.4.
    Ive fiddled around abit to find the correct syntax but have been unsuccessfull so far.
    Any help would be much appreciated
    This is a part of my config:
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network AD1
    host 192.168.1.31
    description AD/RADIUS
    object network NETWORK_OBJ_192.168.1.0_24
    subnet 192.168.1.0 255.255.255.0
    object network vpn_hosts
    subnet 192.168.2.0 255.255.255.0
    access-list AD_splitTunnelAcl standard permit 192.168.1.0 255.255.255.0
    access-list split-acl standard permit 192.168.1.0 255.255.255.0
    access-list inside_nat0_outbound extended permit ip any 192.168.1.0 255.255.255.0
    access-list inside_0_outbound extended permit ip object NETWORK_OBJ_192.168.1.0_24 object vpn_hosts
    ip local pool POOL2 192.168.2.2-192.168.2.10 mask 255.255.255.0
    nat (inside,outside) source static any any destination static NETWORK_OBJ_192.168.1.0_25 NETWORK_OBJ_192.168.1.0_25 no-proxy-arp route-lookup
    nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static NETWORK_OBJ_192.168.1.0_25 NETWORK_OBJ_192.168.1.0_25 no-proxy-arp route-lookup
    nat (inside,outside) source static NETWORK_OBJ_192.168.1.0_24 NETWORK_OBJ_192.168.1.0_24 destination static vpn_hosts vpn_hosts
    object network obj_any
    nat (inside,outside) dynamic interface
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 ########## 1
    no vpn-addr-assign aaa
    no vpn-addr-assign dhcp

  • Making Application deployment working for VPN connection

    Hi Guys,
    Am trying to deploy application to users machines which are connected to VPN.
    I dont have any idea, is that any https connection my SCCM will support. If it is failing, what all the series of steps i need to follow to enable deployment via VPN connection.
    Please suggest.

    If clients are connected through VPN, they will work exactly as any other client you have on your LAN.
    Just make sure that you also specify a boundary for you VPN clients, like you do with you LAN clients.
    Ronni Pedersen | Microsoft MVP - ConfigMgr | Blogs:
    www.ronnipedersen.com/ and www.SCUG.dk/ | Twitter
    @ronnipedersen

  • Advice needed for VPN connections

    OK to first describe what I'm looking at .We have a bookmobile that goes to 13 different locations within our county. At each stop we are using the service provider's DSL modem to connect to their network, we have two different providers and staff changes the modem at each stop, and a Cisco831 router to make a VPN connection to our PIX. We are using the router to make the VPN connection so that we can have two staff computers use internal network resources i.e. Library database, network drives, e-mail. We tried using Cisco VPN client on the local machine but when we have two clients going on two machines at the same time neither would work. So we let the router make that connection.
    We are going to have two bookmobiles operating and I need to purchase another router to make the connection and I am wondering which router would be a better solution for us.
    So for me the question is
    1) should I keep things as they are and buy a 871 and have staff change modems as needed
    2) Should I get an 877, 878 router and make configuration changes daily as needed. Staff have not been able to do this in past. I've enough to do without this!
    3) Up for any suggestions Maybe SDM with a pretty GUI for staff to use. It seems Cisco's CLI was too much for them.
    Thanks to all for any help
    Systems A

    No Nat-traversal is enabled.
    When we tried multiple VPN connections it was through a DSL modem/router. This is why we went to a Cisco831 router and having it make the secure connection to our PIX.
    Thanks for you help

  • Checking for bluetooth connection

    Is there any way to check that the connection is forced to close by shutting off a device connected?
    thanks.

    I have a Logitech Ultrathin Keyboard Folio i5.  Also, even before reading your suggestions, I moved my phone hand set away from the iPad.  There aren't any other sources within 10 feet although the phone base is within 30 feet.  The WiFi router is about 5 feet away.  Haven't had a chance to "troubleshoot" the connection.
    Have you any suggestions for Air Drop or Air Print?  My Pixma MP 450 which in excellent working order isn't compatable with either OS 10.9.x or iOS 7.
    Canon suggested a Pixma MG 3520 which was hellatious to set up, requiring a big download and both a USB cable and Ethernet connection to the router, and isn't working with the iPad. 
    Clearly, technological "advancements" are for teeny boppers who spend their time taking phone pictures, sending mindless messages and listening to music.  Oh, to be 14 again.
    Sorry about the bitters.  Rare opportunity to vent to adults.

  • Checking for secure connection

    We are building an eCommerce site using CFMX 7 on IIS 6 and
    would like to know how, once we have a certificate installed, we
    can be sure a page connection is secure and someone has not typed a
    http:// address instead of a https:// address
    Thanks

    Thanks for the suggestion. Works perfectly.
    Another question though. We have a sign in on everypage on
    the site allowing people to access theur account details. However
    the sign-in processor is in the secure folder. So the checking for
    443 error kicks them out when they submit their details. I have
    tried setting action="https://www.- - - - -/ but it still does not
    connect securely. Is there anyway i can post a form securely from a
    non-secure page? (I suspect i know the answer)
    Rob

  • Best setup for vpn connection

    Hi all, Can anyone tell me the normal way of setting up a vpn connection, here we have a router terminating the internet link, and a cisco pix behind it ?

    you can try a very simple Easy VPN configuration in this document.
    http://www.cisco.com/application/pdf/en/us/guest/products/ps6659/c1650/cdccont_0900aecd80313bdf.pdf
    hope this helps.
    rate this post.

  • Changing router internet IP address for VPN connectivity

    I have a Linksys WRT300N router that I just installed for use with my desktop and laptop in my home office.  One of the things I need to do is connect to a VPN, but apparently I'm unable to do that since their address is the same as my router's address.  How can I change my router's address so there won't be a conflict with connecting to the VPN?  Any help in this would be much appreciated.  Thanks in advance...  DI

    Access setup page of router using the Gateway address....
    Under Setup .... change the Local IP address to 10.10.10.1 or 192.168.X.1 .... click save settings......

  • After a diagnostic check for both connectivity and sync, we may have a conflict.

    fellow iPod classic owners,
                                          after a diagnostic check in which my iPod was found to be connected, on the sync test it was found to not be there. it appears that something is very amiss here. now granted i am not a whiz kid, but when one test tells you that you are connected and the next tells you that you're not, who do you believe? i smell a conflict of some kind or some such thing. clearly we have issues here. i don't know where else to turn. anyone have any ideas? both tests are part of the help tab on the iTunes page. it seemed reasonable to start here, but there is a conflict in the test results.
                                                                                                                                                                      awaiting your comments,
                                                                                                                                                                          hardphil.

    mancave4me,
                        the answer to the question is yes/and yes again. with one comes the other. i still have the problem even after uninstalling and reinstalling the apple apps. it's a thing which plagues pc users. it isn't an issue for my hp laptop however and that intrigues me. i'm no whiz kid with this stuff, but when you pass the connectivity test and it says your iPod is there. then, you fail the sync test because it tells you it is not there. somethings amiss at the circle k. i smell conflict. this is easily solved. just use my laptop for iTunes unless you have a working solution.
    that's the way i see this. it's not the end of the world by a far stretch. let me know if you have a solution. thanks for your concern.                                                                                               sincerely, hardphil.

Maybe you are looking for

  • When converting over to HTTPS and PKI for clients, not all actions are available in configuration manager cpl

    I'm not exactly sure which forum heading this should go under so if this isn't correct please let me know or move it on my behalf.   So I am trying to setup Internet Based Client Management in SCCM 2012 R2 and have come across a few articles on how t

  • No SuchAgorithmException in Adapter Module configured EAR file

    Dear All, I have created an adapter module using 3DES encryption/decryption algorithm for File/FTP adapter configuration and have deployed it at J2EE server of respective XI system. The alogorithm and adapter module are working fine in DEV & QA envir

  • Sent items not saved -- delete accounts/settings/preferences

    I have mail accounts with AOL and Mobile Me. I understand that to save sent items on the server, I must use the setting "Mailbox > Use This Mailbox For." For both AOL and Mobile Me accounts, I successfully set up the sent items folders. Under the pap

  • Disable Documents & Data sync

    Hi, yesterday i got my iPad Air 2 and disable Documents & Data under Settings -> iCloud. I only sync my contacts, so i disable everything there (not "contacts", but everything else). After disabling everything beside "contacts", "Documenst & Data" is

  • Config profile for AppleTV

    Hi all, I have a dozen or so Apple TV's I'm rolling out for our school, and they need configuring with a profile to attach them to our wifi network. I've run into a wall though - I need to give the profile a certificate, but I can't figure out how to