Cisco EEM Documentation

Hello,
where can i find Documentations about the Cisco EEM?
With commands, instructions and so on...
For example: How can i configure my Cisco-819 4G Router to change the SIM-Card if the connection decreases (check with ping and so on).
If i understand the Documents i've read right, it is possible to implement tasks like this with the EEM, but i can't find any usefull Docs.
Thanks for your help!

The following document describes the configuration for dual sim with automatic failover when the primary sim connection is lost.
http://www.cisco.com/c/en/us/td/docs/routers/access/interfaces/software/feature/guide/EHWIC-4G-LTESW.html#wp1305076
If you want to change the primary sim using EEM, you can use a combination of IPSLA and EEM applet to manually configure the primary sim.
Here is a good overview of some EEM commands.
you could potentially use "sh cell 0 sec | inc Active SIM" to determine the current active sim and then change to the opposing.
Below is an example using a GSM dual sim device. This is unvalidated and untested so test and adjust commands as needed but it should give you a start on how to change things.
ip sla 11
 icmp-echo 8.8.8.8
 threshold 4000
 frequency 6
ip sla schedule 11 life forever start-time now
event manager applet CHECKSIM
 event track 11 state down
 action 01 cli command "enable"
 action 02 cli command "sh cell 0 sec | inc Active SIM"
 action 03 set commandresult $_cli_result
 action 04   regexp "0" $commandresult
 action 05   if $_regexp_result eq 1
 action 06   syslog msg  "Changing Primary SIM to 1"
 action 07   cli command "enable"
 action 08   cli command "conf t"
 action 09   cli command "controller cellular 0"
 action 10   cli command "gsm sim primary slot 1"
 action 11   exit 0
 action 12  end
 action 13   regexp "1" $commandresult
 action 14   if $_regexp_result eq 1
 action 15   syslog msg  "Changing Primary SIM to 0"
 action 16   cli command "enable"
 action 17   cli command "conf t"
 action 18   cli command "controller cellular 0"
 action 19   cli command "gsm sim primary slot 0"
 action 20   exit 0
 action 21  end

Similar Messages

  • Documentation of cisco::eem and cisco::lib libs

    Hello Experts,
    Would you be able to help me find the link to complete documentation of cisco:eem / cisco::libs libraries ?
    Thank you.

    Some of the available functions are documented on Cisco.com in the EEM Tcl guide (e.g., the CLI functions and the mail functions).  Some of the others I mention at https://supportforums.cisco.com/docs/DOC-12757#Tcl_Packages .  Between the two sources, I think you'll find everything you're looking for.

  • Cisco EEM. Delay between action cli

    Hi
    I have Cisco  Catalyst 6500 with IOS Version 12.2(17r)SX5
    I need  real-time monitornig of failed interface, to shut it administratively  down and after 5 minutes "no shutdown" it.
    I think is good idea to use Cisco EEM for this task.
    My algorithm is below:
    1. EEM script is looking for event about  failed interface.
    2. EEM script is shutting interface down.
    3. EEM script is waiting 5 minutes.
    4. EEM script is enabling interface.
    I know how to configure EEM for steps 1, 2 and 4, but step 3 I do not.
    Help solve this task, please.

    That's not the version of code running on your switch. That looks like boot ROM code.  In any event, unless you have a Sup2T, you have EEM 2.x.  This solution should work for you.
    event manager environment q "
    event manager applet failed-interface
    event ...
    action 001 cli command "enable"
    action 002 cli command "config t"
    action 003 cli command "interface INTF"
    action 004 cli command "shut"
    action 005 cli command "event manager applet reenable-intf"
    action 006 cli command "event timer countdown time 300"
    action 007 cli command "action 1.0 cli command enable"
    action 008 cli command "action 2.0 cli command $q config t$q"
    action 009 cli command "action 3.0 cli command $q interface INTF$q"
    action 010 cli command "action 4.0 cli command $q no shut$q"
    action 011 cli command "action 4.1 cli command $q no event manager applet reenable-intf$q"
    action 012 cli command "action 5.0 cli command end"
    action 013 cli command "end"

  • Cisco EEM and EOT

    Hi
    Quick question - I am trying to get EOT working with EEM but current IOS I have doesn't seem to support the stub-object. I've upgraded my IOS to c2800nm-entservicesk9-mz.124-25c.bin so it should come with Embedded Event Manager 2.2. However when I try to configure a track 3 stub-object,  the stub-object feature is not there.  What I am trying to do is find a GD release that I could roll out everwhere but I've been through the Cisco Feature Navigator and it would appear that there is none available with the features below  ?  My estate is a mixture of Cisco 2800 routers....Any suggestions?
    Embedded Event Manager (EEM) 2.2
    FHRP - EOT integration with EEM
    Regards
    Mary

    No, all versions of 12.4 mainline have EEM 2.1.  To get EEM 2.2, you need to go with 12.4(2)T or higher.  I have a 2821 running 12.5(1)M in my lab which has EEM 3.1 and EOT.  But you can get it with recent 12.4T as well (e.g. 12.4(24)T).

  • Cisco EEM trigger between two device, it posable?

    Hello I have question, can I see message form Switch to Router for activation EEM?
    I think one way use SMNP for this.
    On router side i have configuration:
    event manager applet snmp
    event snmp-notification oid 1.3.6.1.4.1.12345.1.0 oid-val "1" op eq maxrun 20000
    action 10 syslog msg "Triggered from Trap!"
    Can Cisco switch send SMNP msg to Router on with special OID? for activation Router Event?
    Maybe someone use another way for communication?

    Sure, this is possible.  You don't have to use purely customized traps, either.  You can use standard EEM traps.  From the source device, do something like:
    event manager applet ospf-change event syslog pattern "OSPF-5-ADJCHG" action 1.0 cli command "enable" action 2.0 cli command "debug ip ospf packet" action 3.0 snmp-trap intdata1 424242!snmp-server enable traps event-managersnmp-server host 10.1.1.1 traps public event-manager
    Then on the target device:
    event manager applet ospf-change event snmp-notification oid 1.3.6.1.4.1.9.10.91.1.2.3.1.9. oid-val "424242" op eq src-ip-address 10.1.1.2 action 1.0 cli command "enable" action 2.0 cli command "debug ip ospf packet"!snmp-server manager

  • Cisco EEM 2.1 applet monitoring question

    I need assistance in configuring an eem applet using an 1841 router running IOS version 12.4(3c) and eem version 2.1. I need the applet to monitor multiple interfaces with condition if all interfaces are down for 15 seconds to execute a clear line 3. This is condition is straight forward when using eem version 3.0/ IOS 15.1 because you can track a list and capture the syslog pattern. When using IOS 12.4(3c), the syslog message does not appear when tracking list object is down. Any ideas on how get this to work?
    Thanks.

    This should give you what you want.  You will need to set four EEM environment variables first.
    intfs_interval  : Time to check the tracked object stateintfs_track     : Tracked object IDintfs_line      : Line to clearintfs_time      : Time to wait before the line is cleared
    For example:
    event manager environment intfs_interval 60event manager environment intfs_track 5event manager environment intfs_line 3event manager environment intfs_time 15
    You will still need your tracked object that watches all interfaces (ID number 5 in the example above).

  • Cisco EEM script to detect a sequence of SYSLOG messages

    Hi,
    I am trying to create an EEM "Port-knocking" script which should act upon an ordered sequence of SYSLOG messages. The SYSLOG messages are generated by some "deny tcp any any XXX log STRING" ACLs, applied to the outside interface. 
    Here is what I have already tried:
    ! <------- BEGIN ------->
    ip access-list extended INTERNET
    deny tcp any any eq 1234 log OPEN_SEQUENCE_A
    deny tcp any any eq 1235 log OPEN_SEQUENCE_B
    deny tcp any any eq 1236 log OPEN_SEQUENCE_C
    event manager environment 1ST_MATCH 0
    event manager environment 2ND_MATCH 0
    event manager applet ONE
    event syslog pattern "OPEN_SEQUENCE_A"
    action 1 set 1ST_MATCH "1"
    action 2 syslog msg "DETECTED SEQUENCE A!"
    event manager applet TWO
    event syslog pattern "OPEN_SEQUENCE_B"
    action 1 if $1ST_MATCH eq 1
    action 2 set 2ND_MATCH "1"
    action 3 syslog msg "DETECTED SEQUENCE B!"
    action 4 end
    event manager applet THREE
    event syslog pattern "OPEN_SEQUENCE_C"
    action 1 if $1ST_MATCH eq 1
    action 2 if $2ND_MATCH eq 1
    action 3 syslog msg "DETECTED SEQUENCE C!"
    action 4 syslog msg "PORT KNOCK SUCCESSFUL! UNLOCKING!..."
    action 5 end
    action 6 end
    ! <------- END ------->
    In the above I am somehow trying to "chain" the syslog events, yet I do not seem to be able to pass any information between the applets.
    Any comments are highly appreciated.
    Cheers,
    David

    EEM cannot detect syslog messages that it generates.  If you want to chain together events across multiple applets, use application-specific events.  For example:
    action 2 publish-event sub-system 798 type 1
    event application sub-system 798 type 1
    action 3 publish-event sub-system 798 type 2
    You can also pass up to four arguments as well if you need additional context.

  • I need helping!!! configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.

    I need helping configuring RDP access to my local server from a remote location on my Cisco ASA 5505 Firewall.
    I have attempted to configure rdp access but it does not seem to be working for me Could I please ask someone to help me modify my current configuration to allow this? Please do step by step as I could use all the help I could get.
    I need to allow the following IP addresses to have RDP access to my server:
    66.237.238.193-66.237.238.222
    69.195.249.177-69.195.249.190
    69.65.80.240-69.65.80.249
    My external WAN server info is - 99.89.69.333
    The internal IP address of my server is - 192.168.6.2
    The other server shows up as 99.89.69.334 but is working fine.
    I already added one server for Static route and RDP but when I try to put in same commands it doesnt allow me to for this new one. Please take a look at my configuration file and give me the commands i need in order to put this through. Also please tell me if there are any bad/conflicting entries.
    THE FOLLOWING IS MY CONFIGURATION FILE
    Also I have modified IP information so that its not the ACTUAL ip info for my server/network etc... lol for security reasons of course
    Also the bolded lines are the modifications I made but that arent working.
    ASA Version 7.2(4)
    hostname ciscoasa
    domain-name default.domain.invalid
    enable password DowJbZ7jrm5Nkm5B encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.6.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 99.89.69.233 255.255.255.248
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    ftp mode passive
    dns server-group DefaultDNS
    domain-name default.domain.invalid
    object-group network EMRMC
    network-object 10.1.2.0 255.255.255.0
    network-object 192.168.10.0 255.255.255.0
    network-object 192.168.11.0 255.255.255.0
    network-object 172.16.0.0 255.255.0.0
    network-object 192.168.9.0 255.255.255.0
    object-group service RDP tcp
    description RDP
    port-object eq 3389
    object-group service GMED tcp
    description GMED
    port-object eq 3390
    object-group service MarsAccess tcp
    description MarsAccess
    port-object range pcanywhere-data 5632
    object-group service MarsFTP tcp
    description MarsFTP
    port-object range ftp-data ftp
    object-group service MarsSupportAppls tcp
    description MarsSupportAppls
    port-object eq 1972
    object-group service MarsUpdatePort tcp
    description MarsUpdatePort
    port-object eq 7835
    object-group service NM1503 tcp
    description NM1503
    port-object eq 1503
    object-group service NM1720 tcp
    description NM1720
    port-object eq h323
    object-group service NM1731 tcp
    description NM1731
    port-object eq 1731
    object-group service NM389 tcp
    description NM389
    port-object eq ldap
    object-group service NM522 tcp
    description NM522
    port-object eq 522
    object-group service SSL tcp
    description SSL
    port-object eq https
    object-group service rdp tcp
    port-object eq 3389
    access-list outside_1_cryptomap extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 192.168.0.0 255.255.0.0
    access-list inside_nat0_outbound extended permit ip 192.168.6.0 255.255.255.0 object-group EMRMC
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-data
    access-list outside_access_in extended permit udp 69.16.158.128 255.255.255.128 host 99.89.69.334 eq pcanywhere-status
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ftp
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq ldap
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq h323
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq telnet
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 eq www
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 host 99.89.69.334 object-group SSL
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM522
    access-list outside_access_in extended permit tcp 69.16.158.128 255.255.255.128 192.168.6.0 255.255.255.0 object-group NM1731
    access-list outside_access_in extended permit tcp 173.197.144.48 255.255.255.248 host 99.89.69.334 object-group RDP
    access-list outside_access_in extended permit tcp any interface outside eq 3389
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333
    access-list outside_access_in extended permit tcp host 66.237.238.194 host 99.89.69.333 object-group rdp
    access-list outside_access_in extended permit tcp any host 99.89.69.333 object-group rdp
    access-list out_in extended permit tcp any host 192.168.6.2 eq 3389
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-524.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list inside_nat0_outbound
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp 99.89.69.334 3389 192.168.6.1 3389 netmask 255.255.255.255
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 99.89.69.338 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    http server enable
    http 192.168.6.0 255.255.255.0 inside
    http 0.0.0.0 0.0.0.0 outside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto map outside_map 1 match address outside_1_cryptomap
    crypto map outside_map 1 set peer 68.156.148.5
    crypto map outside_map 1 set transform-set ESP-3DES-MD5
    crypto map outside_map interface outside
    crypto isakmp enable outside
    crypto isakmp policy 10
    authentication pre-share
    encryption 3des
    hash md5
    group 1
    lifetime 86400
    crypto isakmp policy 30
    authentication pre-share
    encryption 3des
    hash md5
    group 2
    lifetime 86400
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside
    tunnel-group 68.156.148.5 type ipsec-l2l
    tunnel-group 68.156.148.5 ipsec-attributes
    pre-shared-key *
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
    service-policy global_policy global
    prompt hostname context
    Cryptochecksum:f47dfb2cf91833f0366ff572eafefb1d
    : end
    ciscoasa(config-network)#

    Unclear what did not work.  In your original post you include said some commands were added but don't work:
    static (inside,outside) tcp interface 3389 192.168.6.2 3389 netmask 255.255.255.255
    and later you state you add another command that gets an error:
    static (inside,outside) tcp 99.89.69.333 3389 192.168.6.2 3389 netmask 255.255.255.255
    You also stated that 99.89.69.333 (actually 99.89.69.233, guessing from the rest of your config and other posts) is your WAN IP address.
    The first static statement matches Cisco's documentation, which states that a static statement must use the 'interface' directive when you are trying to do static PAT utilizing the IP address of the interface.  Since 99.89.69.333 is the assigned IP address of your WAN interface, that may explain why the second statement fails.
    Any reason why you are using static PAT (including the port number 3389) instead of just skipping that directive?  Static PAT usually makes sense when you need to change the TCP port number.  In your example, you are not changing the TCP port 3389.

  • Welcome to the Technical Documentation Idea Center Topic

    Welcome to the NetPro Cisco Technical Documentation Ideas topic. This conversation will provide you the opportunity to suggest ways Cisco technical documentation can be improved to better serve your needs and seek answers to questions about technical documentation. We encourage everyone to share their knowledge and start conversations about ideas involving the Cisco Technical Documentation.
    Remember, just like in the workplace, be courteous to your fellow forum participants. Please refrain from using disparaging or obscene language or posting advertisements.
    We encourage you to tell your fellow networking professionals about the site.
    Dan Bruhn
    NetPro Community Manager

    Welcome to the NetPro Cisco Technical Documentation Ideas topic. This conversation will provide you the opportunity to suggest ways Cisco technical documentation can be improved to better serve your needs and seek answers to questions about technical documentation. We encourage everyone to share their knowledge and start conversations about ideas involving the Cisco Technical Documentation.
    Remember, just like in the workplace, be courteous to your fellow forum participants. Please refrain from using disparaging or obscene language or posting advertisements.
    We encourage you to tell your fellow networking professionals about the site.
    Dan Bruhn
    NetPro Community Manager

  • Cisco ISE and SecurID Integration Questions

    I'm looking for some clarity trying to understand something conceptually. I want to integrate Cisco ISE with RSA SecurID, the idea being that if the user authenticates with RSA SecurID they end up on one VLAN, however, if they don't authenticate with (or don't use, or don't have) SecurID they'll end up on another VLAN. Note that I'm not using SecurID for wireless access...all PCs are wired to Ethernet.
    We have been using RSA SecurID for a while and are currently on version 8.0. Our users are authenticating via the RSA Agent typically on Windows 8.1. Instead of the usual Windows login prompt, the RSA Agent first prompts for the username and passcode (they use an app on their smartphones to get the passcode), then after a moment or two, it prompts for their Windows domain password.
    We have recently installed Cisco ISE version 1.3. With the help of a local Cisco engineer and going through the "Cisco Identity Services Engine User Guide", I have it set up and running along with a few 'test' ports on our Cisco 6809 switch, it basically works...as a test it's simply set up that if they authenticate they're on one VLAN, if not, they end up on another (this is currently without using RSA...just out-of-the-box Windows authentication).
    The Cisco engineer was unable to help me with RSA SecurID, so pressing on without him, out of the same user guide I have followed the directions for "RSA Identity Sources" under the "Managing Users and External Identity Sources", and that went well as far as ISE is concerned; I am now ready to get serious about getting ISE and SecurID working together.
    My mistake in this design so far was assuming that the RSA agent on the Windows client PCs would communicate with Cisco ISE...there doesn't seem to be a way to have them point to a non-RSA SecurID server for authentication. The concept I'm missing is what, or how, the end-user machine is supposed to authenticate taking advantage of both ISE and SecurID.
    I have dug deeper into the Cisco ISE documentation but it seems heavily biased towards Wi-Fi and BYOD implementations and it's not clear to me what applies to wired vs wireless. Perhaps it's a case that I'm not seeing the forest for the trees, but I'm not understanding what the end-user authentication looks like. It apears that as I learn more about ISE, it should become the primary SSO source, that SecurID becomes just an identity source and the PC clients would no-longer directly communicate with the SecurID servers. That being the case, do I need to replace the SecurID client on the PCs and something else Cisco-ish fills this role? An agent for ISE? How do they continue to use their passcode without the RSA agent?
    Thanks!

    The external db not operation indicates that there is no communication between ACS and RSA. Did you fetch the package.cab file to analyse the auth.log file?
    Have you already gone through the below listed link?
    http://www.security-solutions.co.za/cisco-CSACS-1113-SE-4.2-RSA-Authentication-Manager-Integration-Configuration-Example.html
    Regards,
    Jatin Katyal
    - Do rate helpful posts -

  • How to scp a file in 7600 using EEM/Tcl

    Hello All,
    I have a Tcl file on 7600 that produces a file, and I would like to copy this file to a server using scp.
    This is how the file looks like :
    ::cisco::eem::event_register_none maxrun 240
    #::cisco::eem::event_register_timer cron cron_entry "*/5 * * * *" maxrun 240
    namespace import ::cisco::eem::*
    namespace import ::cisco::lib::*
    array set arr_einfo [ event_reqinfo ] ;
    if [ catch {cli_open} rc ] {
           error $rc $errorInfo
    } else {
           array set clifd $rc
    set          filename          "IOS7600.dat_12345" ;
    set     transfer        "copy disk0:/" ;        append transfer $filename ;     append  transfer " scp://username:password@ip:" ;
    if [ catch {cli_exec $clifd(fd) $transfer} rc ] {
            error $rc $errorInfo
    if [ catch {cli_close $clifd(fd) $clifd(tty_id)} rc ]  {
           error $rc $errorInfo
    The problem is that scp: hangs ! Could you please help me to work-around this ? What am I doing wrong ?
    Many Thanks.
    Kind Regards,
    Nikos

    An alternative would be to write an applet, like :
    event timer cron name PUSH-CoPP cron-entry "*/5 * * * *" maxrun 240
    to do the following command :
    set     transfer        "copy disk0:/" ;        append transfer $filename ;     append  transfer " scp://username:password@ip:" ;
    but how can I provide the filename, I could use a regexp like :
    *IOS7600*
    and then answer the related to scp dialog using action statements.
    Could you please help me with this please ?
    Many Thanks.
    Kind Regards,
    Nikos

  • EEM event_register_interface detector issue

    hi,
    Im working on a EEM policy for some of my routers using TCL, this policy checks for the txload value of an interface and reports the value with a syslog message, this policy is already in the eem scriptiong community so as least im sure that im in the right direction.
    This is my policy right now for testing, as you can see its pretty simple:
    ::cisco::eem::event_register_interface name serial1/0 parameter txload poll_interval 5 entry_op ge entry_val 192 entry_val_is_increment FALSE entry_type value
    action_syslog msg "event triggered"
    However it doesn't works, i have tried this code on 2811 and 7200 routerswith 12.4 ios image and i cant get it working, i have been using other kind of detectors (counters, timers, cli, etc) and they are working fine.
    thanks all for your replies.

    Thanks joseph for your reply,
    I applied the policy as you said, however it didn't work, I tested the policy on a 2801 router in a lab enviroment. I have included some output from the router. I have implemented another policy with a timer detector as a workaround, meanwhile I get some other IOS image for testing and production enviroment.
    R1#sh event manager policy registered
    No.  Class   Type    Event Type          Trap  Time Registered           Name
    1    script  user    interface           Off   Sun Apr 17 11:54:26 2011  ifreporter.tcl
    name {serial0/2/0} parameter {txload} entry_op ge entry_val 192 entry_val_is_increment FALSE poll_interval 70.000
    nice 0 queue-priority normal maxrun 20.000
    R1#sh ver
    Cisco IOS Software, 2801 Software (C2801-ADVIPSERVICESK9-M), Version 12.4(19), RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Fri 29-Feb-08 20:54 by prod_rel_team
    ROM: System Bootstrap, Version 12.3(8r)T9, RELEASE SOFTWARE (fc1)
    R1 uptime is 48 minutes
    System returned to ROM by reload at 11:48:07 cst Sun Apr 17 2011
    System image file is "flash:c2801-advipservicesk9-mz.124-19.bin"

  • EEM, puts and terminal length

    When I run this with "event manager run jb.tcl" with 15.0(1)M2,  the "--More--" prompt interrupts the output at different points every time I run it. My terminal length is set to 35. Is there any way to get the "--More--" prompt to work correctly and interrupt the output at the line 35 marker every time?
    Thanks
    Scott
    ::cisco::eem::event_register_none
    namespace import ::cisco::eem::*
    namespace import ::cisco::lib::*
    if { [catch {cli_open} result] } {
        error $result $errorInfo
    array set cli $result
    cli_exec $cli(fd) "enable"
    puts 1
    puts 2
    puts 3
    puts 4
    puts 5
    puts 6
    puts 7
    puts 8
    puts 9
    puts 10
    puts 11
    puts 12
    puts 13
    puts 14
    puts 15
    puts 16
    puts 17
    puts 18
    puts 19
    puts 20
    puts 21
    puts 22
    puts 23
    puts 24
    puts 25
    puts 26
    puts 27
    puts 28
    puts 29
    puts 30
    puts 31
    puts 32
    puts 33
    puts 34
    puts 35
    puts 36
    puts 37
    puts 38
    puts 39
    puts 40
    catch {cli_close $cli(fd) $cli(tty_id)}

    This looks like a bug similar to CSCsm37007 in which the more buffer is not being reset between executions.  After the first, possibly bogus --More-- prompt, you will not see another prompt until 35 lines have scrolled by.

  • Cisco 2950 - 24 WS switch express install issue

    Hi Guys,
    Got a Cisco 2950 24 port switch that I need to setup and I can't seem to get the page for Express install
    In firefox when trying to connect to 10.0.0.1 I get the message "connection was reset" in internet explorer "page cannot be displayed"
    when doing a arp -a I can see that the switch does get the IP address 10.0.0.1 and I can also ping the switch ok.
    Have followed the instructions and reset the switch and all the mode lights are green etc.
    my ethernet adapter does get the address 10.0.0.2 given from the switch (however connectivity is limited / not sure if this is supposed to be like this or not)
    have tried earlier versions of firefox (even 1x 2x 3x 4x) etc and also older versions of IE incase there is something weird going on there. have also tried using a mac and trying safari which gives similar results.
    So i think the http server is enabled on the switch, as it should be by default when it is reset etc. according to cisco's documentation.
    I know using the console cable would be alot easier however I don't have one available and not easy for me to get
    any ideas? has anyone ever successfully been able to use this express install  web page on a cisco 2950 before? It has Version 12.1(22)EA14 so express install should work on this switch!
    cheers,

    managed to get hold of a console cable. checked switch and http-server command was enabled so have no idea why this feature was not working...
    did some research and someone suggested that it is fussy with the version of java you are running on the pc ( requires old version of java?) .. possibly that may have an influence who knows?
    Think ill just carry around a Console cable in future!

  • EEM Scripting for error and drop counters

    Hi,
    We want to check the following counters for drops every 5 minutes and generate an alarm if a certain threshold of errors (example: increment of 100 in the error/drop counters in the last 5 minutes) is overcome:
    My sample script is inline, i'm missing how to parse and generate the alarm if the threshold is surpassed:
    Example command:
    SPLAB_7600_3#remote command module 4 show platform hardware drops | include Selene|drp                
    ------ Selene 0 Channel 0 ------
    Selene Ingress Drop Counters Ch[0]
    Selene Egress Drop Counters Ch[0]
        egr_tot_fifo_drp_ctr                          25
    Selene Drop Counters
    ------ Selene 1 Channel 0 ------
    Selene Ingress Drop Counters Ch[0]
    Selene Egress Drop Counters Ch[0]
    Selene Drop Counters
    Best Regards,
    Afonso
    ::cisco::eem::event_register_timer watchdog time $check_interval nice 1
    # EEM policy to monitor a internal counters
    # August 2012, Cisco Systems
    # Copyright (c) 2012 by cisco Systems, Inc.
    # All rights reserved.
    namespace import ::cisco::eem::*
    namespace import ::cisco::lib::*
    # 2. Execute the counter show commands
    if [catch {cli_open} result] {
        error $result $errorInfo
    } else {
        array set cli1 $result
    if [catch {cli_exec $cli1(fd) "enable"} result] {
        error $result $errorInfo
    if [catch {cli_exec $cli1(fd) "cisco"} result] {
        error $result $errorInfo
    # - - - - - -  Interface error counters
    if [catch {cli_exec $cli1(fd) "remote command module x show platform hardware selene np-idx 0 counters | include drop"} result] {
            error $result $errorInfo
    set egr_drp_ctr $result
    #- Parsing and conditional programming for the generation of traps based on the drop value extracted from the show command
    action_syslog priority info msg "Counter Alarm"
    #Exit
    if [catch {cli_exec $cli1(fd) "end"} result] {
        error $result $errorInfo

    I believe this is what you are looking for:
    set egr_drp_ctr $result
    expr {$egr_drp_ctr + 100} sumof
    if {$egr_drp_ctr >= $sumof}
        puts "Alarm"
    It may need correction on the syntax , but thats the logic.

Maybe you are looking for

  • Using time capsule to migrate to a new macbook

    i just purchased a new macbook (see specs below). i used time capsule to backup my old macbook which i am now selling. two questions... can i use time machine in migration assist to transfer all the info from my old mac to my new one? if so how? than

  • Want to find out how a batch classification is used

    Hello I have previously sent out a message and the idea given was not very helpful. Anyway, this is my question: I have found a class and its characteristic which was setup in the system and I would like to know how this classification` is being use

  • Number of Records in one table

    Hi All, Can anybody let me know that in Oracle9i lite database, one table can have how many records. I mean is their any restriction on maximum number of ROWs for a table, like Palm database (PDB files) has a restriction that one table can have maxim

  • Need to check GR quantity should be less than PO quantity

    Hi,     We have to make sure that the net GR quantity shouldn't be greater than PO quantity (considering one PO line can have more than one GR and GR returns) . Can we achive this by configuration?  I tried using Tolerance limits, but it didn't work

  • Why isn't Breeze Presenter sold seperately?

    Breeze Presenter is an excellent tool that satisfies a common and growing requirement in the market (publishing voice-over presentations on websites). Unfortunately Breeze Presenter is frustratingly hard to buy as Adobe has chosen to tie the Presente