Cisco ISG Integration with AAA & Policy Server

Hi,
We are integrating Cisco ISG (IOS XE - ASR1001) with AAA and Policy Server.   we have below to specific service provider requirement.
1. TAL  - Transparent Automatic Subsriber for Range of IP or Pool of IP  - how we add such identifier in Policy/Control Maps as attibute handshake with AAA
2. Different QoS Enforcement to Single User based on Day and Night Time.. what logic should be used??
Note: The Subscribers are from wired network and DHCP controlled.
Please help, Thanx in advance...
Bhavesh

Dear Bhavesh,
     Try with this it is working & tested policy for TAL & ISG ASR 1001.
QoS will be work with Radius request & will apply on online user with diffrent plan.
class-map type traffic match-any PPPOE
match access-group output name PPPOE-out
match access-group input name PPPOE-in
class-map type control match-any TAL
match source-ip-address 30.30.30.0 255.255.255.0
class-map type control match-all IP_UNAUTH_COND
match timer IP_UNAUTH_TIMER
match authen-status unauthenticated
class-map type control match-all PPPOE-CON
match media ether
match authen-status unauthenticated
match protocol ppp
policy-map type control PPPOE-USR
class type control always event timed-policy-expiry
  10 service disconnect
class type control always event account-logoff
  10 service disconnect delay 2
class type control always event quota-depleted
  10 set-param drop-traffic TRUE
class type control always event session-start
  10 authenticate aaa list PPP-USR
class type control always event service-start
  20 service-policy type service identifier service-name
class type control always event service-stop
  1 service-policy type service unapply identifier service-name
policy-map type control TAL_IP_POLICY_RULE
class type control IP_UNAUTH_COND event timed-policy-expiry
  10 service disconnect
class type control TAL event account-logoff
  10 service disconnect delay 5
class type control TAL event session-start
30 authorize aaa list AAA-STATIC password cisco identifier source-ip-address
  50 set-timer IP_UNAUTH_TIMER 5
class type control TAL event session-restart
  30 authorize aaa list AAA-STATIC password cisco identifier source-ip-address
  50 set-timer IP_UNAUTH_TIMER 5
class type control TAL event quota-depleted
  10 set-param drop-traffic TRUE
class type control TAL event service-start
  10 service-policy type service identifier service-name
bba-group pppoe global
virtual-template 1
interface GigabitEthernet0/0/0
ip address 10.10.10.2 255.255.255.0
no ip proxy-arp
negotiation auto
interface GigabitEthernet0/0/1
ip address 30.30.30.1 255.255.255.0
negotiation auto
pppoe enable group global
service-policy type control TAL_IP_POLICY_RULE
ip subscriber routed
  initiator unclassified ip-address
interface GigabitEthernet0/0/2
ip address 172.16.1.1 255.255.255.0
negotiation auto
interface GigabitEthernet0/0/3
no ip address
shutdown
negotiation auto
interface GigabitEthernet0/2/0
no ip address
shutdown
negotiation auto
interface GigabitEthernet0/2/1
no ip address
shutdown
negotiation auto
interface GigabitEthernet0/2/2
no ip address
shutdown
negotiation auto
interface GigabitEthernet0/2/3
no ip address
shutdown
negotiation auto
interface GigabitEthernet0
vrf forwarding Mgmt-intf
no ip address
shutdown
negotiation auto
interface Virtual-Template1
ip dhcp relay information trusted
ip unnumbered GigabitEthernet0/0/1
ip helper-address 10.10.10.1
timeout absolute 43200 0
peer default ip address dhcp
ppp mtu adaptive
ppp authentication pap
ppp authorization PPP-USR
service-policy type control PPPOE-USR
ip forward-protocol nd
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 172.16.1.2
ip access-list extended DROP-in
deny   ip any any
ip access-list extended DROP-out
deny   ip any any
ip access-list extended PPPOE-in
permit ip any any
ip access-list extended PPPOE-out
permit ip any any
vishal lumbhani

Similar Messages

  • Groupware integration  with microsoft exchange server

    I have a query regarding Groupware integration with microsoft exchange server.whether we require IIS server and microsoft exchange server on the same machine for groupware integration.or they can be on different machines.
    thanks,
    Pramod

    hi,
    We actually implemented integration of SAP with microsoft exchange server. It is not necessary for server and IIS to be in the same machine.
    regards,
    Ganesh.N

  • NAC Framework with TrendMicro Policy Server? External Posture Assessment?

    Hi
    I've got a NAC Framework 2.1 setup using NAC-L2-802.1x with 2950 switches and so far it's working great. I've recently begun testing NAC with TrendMicro OfficeScan, which includes the Trend Policy Server for Cisco NAC.
    I've imported the Trend.adf file, created a new Internal Posture Validation to check these TrendAV settings (DAT version, protection enabled, etc) and it is working great with the clients. (Healthy if up to date, quarantined if out of date).
    What I'm trying to do is get this integrated with the Trend Policy Server for Cisco NAC. I've created an External Posture Validation entry for the Trend Policy Server;
    https://win2k3std:4343/antibody
    And have supplied it with the password (no username is needed to login to the web console of this server). I've also selected Trend:AV as the forwarding credential. I've gone into Network Access Profiles and made sure this was selected as an External Posture Validation Server and set it to quarantine under "Failure Posture Token". When I test this from the client (once I've enable External Posture Validation), it always ends up quarantined (even though the client is fully up to date). If I disable the External Posture Validation server from the NAP, the client test passes as Healthy (since all AV is up to date).
    I've got the Policy Server for Cisco NAC defined under NAC on my Trend OfficeScan server, and on the Policy Server for Cisco NAC, I've got the OfficeScan server defined. Yet, no matter what I've tried, the client always fails with this msg in the CSACS logs;
    Posture Validation Failure on External Policy
    Does anyone have any experience or help with this. Thanks very much.
    Jason Humes

    Please check the links for the Configuration and Troubleshoot of NAC
    www.cisco.com/c/en/us/td/docs/security/nac/appliance/configuration_guide/48/cam/48cam-book/m_agntd.html
    www.cisco.com/c/en/us/td/docs/security/nac/appliance/configuration_guide/47/cam/47cam-book/m_agntd.html#wp1234860

  • Cisco Works Integration with MARS

    Can cisco works be integrated with MARS. I mean cisco works is acting as a syslog server for some switches. Can mars pull the records from Cisco Works and use it for its co-relation

    As Michael pointed out, configuring two syslog destinations on your switch is possible, and allows the switch to send to both CiscoWorks and CS-MARS simultaneously.  This affords the safety that should one system be down, the other system will continue to receive syslog events from the switches.  Should you not wish to configure two logging destinations on your switch, you could configure your switches to send their syslogs to CS-MARS and configure CS-MARS to relay the received syslog messages to CiscoWorks.  This options is outlined in the CS-MARS user guide:
    http://www.cisco.com/en/US/docs/security/security_management/cs-mars/6.0/user/guide/combo/cfgOver.html#wpmkr181270
    Scott

  • Cisco ISE integration with third-party firewalls

    Can Cisco ISE be integrated with a third-party firewall (such as Checkpoint), to provide authentication/authorization services to remote VPN user devices (based on device MAC address)?
    The remote user would establish a VPN connection to a third-party firewall, based on a username/password authentication, but the user would only be allowed to send/receive traffic to the internal network if the MAC address of the device being used was authorized by Cisco ISE.
    Thank you in advance.

    Rui,
    I do not think the vpn client sends the ip address in a called-station-id, that might be the public ip address that the client is initiating the request from. If you have an existing radius server or can run a packet capture you should be able to verify that.
    If the client does send the mac address in the radius packet then you can create a custom condition that can be used to check the mac address along with the username to allow it access to the session. However in VPN deployments there is no concept of profiling since 802.1x deployments usually include the client's mac address.
    Thanks,
    Tarik Admani
    *Please rate helpful posts*

  • OAM (10.1.4.3) Integration with WebLogic App Server (10.3.0 or below)

    Hi All,
    Can I use OAM 10.1.4.3 (Authentication Provider & Identity Asserter) to implement SSO with weblogic App Server 10.3.0 or below?
    OAM 10.1.4.3 Authentication Provider & Identity Asserter is the recommended way to configure SSO with Web Logic App server 10.3.1 ( Oracle Middleware 11g).
    And
    OAM 10.1.4.2 uses WebLogic SSPI to configure SSO between OAM 10g and WebLogic App Server 10.3.0 or below.

    Hi,
    This is how the integration goes with different versions of WLS and OAM.
    There is oamAuthnProvider.jar available with OAM 10.1.4.3 downloads. So it provides the assertion functionality.
    Can I use OAM 10.1.4.3 (Authentication Provider & Identity Asserter) to implement SSO with weblogic App Server 10.3.0 or below?
    Mahendra: Yes
    OAM 10.1.4.3 Authentication Provider & Identity Asserter is the recommended way to configure SSO with Web Logic App server 10.3.1 ( Oracle Middleware 11g).
    Mahendra: Yes, this is the recommended and easy approach.
    OAM 10.1.4.2 uses WebLogic SSPI to configure SSO between OAM 10g and WebLogic App Server 10.3.0 or below.
    Mahendra: Yes, older version of OAM uses SSPI connector installation.
    HTH.
    Mahendra.

  • CISCO IVR integration with Phoenix

    I have phoenix application which is based on ISO 8583.
    I have to integrate Contact-Center IVR solution with it.
    I wanted to know, if such an itnegration was ever developed earlier and is it provided by CISCO or by 3rd party?
    You can get more information about Phoenix from http://www.phoenix-interactive.com/.
    Thanks

    I know this already.
    The problem is specifically about integration with Phoenix.
    If you have or anyone who has some knowledge on the Phoenix side of integration as well.
    What CISCO is offering, I know that.
    But I want to know, if any real work for this integration has already been done.

  • XCelsius Engage Server 2008 integration with Crystal Reports Server 2008

    Hi there....
    I am kinda new to XCelsius and am confused with the integration points XCelsius Engage Server offers for 'Crystal Server 2008' users.
    The trial install package for XCelsius Engage Server (SP1) has a binary installation for XCelsius and then for Adobe LifeCycle DataServices. The installation document in the distribution does not talk about what the 'engage server' part is? and how it can get integrated to an existing CS 2008 installation ?
    any suggestions/pointers would be appreciated. Also is there a document/white paper explaining how this whole family of CS and XCelsius products fits together ?

    user12111287,
    To answer your question.....No, I do not. But we have run Crystal Reports using P6 data.
    As far as I know Crystal Reports only needs a database of some kind in order to do its thing. Are you attempting to set up a "real time" data link (ODBC) to Crystal via SDK?
    If not, you could just build your own P6 exports or develop your own reports that would provide the data for feeding Crystal Reports. Maybe set up an automated Job Service task to run a batch of reports on a daily basis.
    Hope this helps.
    Edited by: p3_scheduler on Mar 25, 2010 1:18 PM

  • Cisco ISE integration with AD fails

    Cisco ISE Ver: 1.1.2.145
    Windows : Win 2003 Server
    I am attempting to integrate ISE with AD, but ISE won't join AD and joining attempts fails, though I am able to add same domain as external LDAP identity store ?
    1.user used to join the domain has admin permission on AD
    2. ISE resolved the domain correctly
    3.There is a firewall inbetween ISE (192.168.100.10) & AD (172.16.100.1), but all the traffic are permited.
    4. No NATing taking place, Firewall is forwarding all trafic between ISE & AD
    Can't really understand why AD connection fails
    From ISE Interface - Detailed Test Connection
    Adinfo (CentrifyDC 4.5.0-357)
    Host Diagnostics
      Uname: Linux Iseadn 2.6.18-274.17.1.el5PAE #1 SMP Wed Jan 4 22:49:48 EST 2012 I686
      OS: Linux
      Version: 2.6.18-274.17.1.el5PAE
      Number Of CPUs: 1
    IP Diagnostics
      Local Host Name: Iseadn
      Local IP Address: 192.168.100.10
      FQDN Host Name:iseadn.gnet.cp
    Domain Diagnostics
      Domain: Gnet.cp
      Subnet Site: Default-first-site-name
        DNS Query For: _ldap._tcp.gnet.cp
        Found SRV Records:
          Gnet.cp:389
      Testing Active Directory Connectivity:
        Domain Controller: Gnet.cp
          Ldap:      389/tcp - Good
          Ldap:      389/udp - Good
          Smb:       445/tcp - Good
          Kdc:        88/tcp - Good
          Kpasswd:   464/tcp - Good
          Ntp:       123/udp - Good
      Domain Controller: Gnet.cp:389
        Domain Controller Type: Windows 2003
        Domain Name:            GNET.CP
        IsGlobalCatalogReady:   TRUE
        DomainFunctionality:           2 = (DS_BEHAVIOR_WIN2003)
        ForestFunctionality:           0 = (DS_BEHAVIOR_WIN2000)
        DomainControllerFunctionality: 2 = (DS_BEHAVIOR_WIN2003)
      Forest Name: GNET.CP
        DNS Query For: _gc._tcp.GNET.CP
      Testing Active Directory Connectivity:
      Forest Name: GNET.CP
    Kerberos Error: Rc=-1765328377 SASL Bind To Ldap/[email protected] - GSSAPI Mechanism With Kerberos Error  : Server Not Found In Kerberos Database
    Computer Account Diagnostics
      Not Joined To Any Domain
    System Diagnostic
      Not Joined To Any Domain
    Centrify DirectControl Status
      Not Joined To Any Domain
    Licensed Features: Enabled
    SELinux Status:                 Disabled
    Amavis1.1.0
    Ccs1.0.0
    Clamav1.1.0
    Dcc1.1.0
    Dnsmasq1.1.1
    Evolution1.1.0
    Ipsec1.4.0
    Iscsid1.0.0
    Milter1.0.0
    Mozilla1.1.0
    Mplayer1.1.0
    Nagios1.1.0
    Oddjob1.0.1
    Pcscd1.0.0
    Postgrey1.1.0
    Prelude1.0.0
    Pyzor1.1.0
    Qemu1.1.2
    Razor1.1.0
    Ricci1.0.0
    Smartmon1.1.0
    Spamassassin1.9.0
    Virt1.0.0
    Zosremote1.0.0
    From Ad-agent log

    Hi Jallaluddin
    I work for Centrify Support and saw your posting. Here our analysis on checking the adlogs.txt.zip:
    Server not found in Kerberos database" (reference base/adbind.cpp:495 rc: -1765328377)
    That error is likely coming from the KDC - meaning there is some problem with server side SPNs
    We need the following:
    1) A network trace.
    2) adcheck output.
    3) adinfo --support output
    4) Run dcdiag or netdiag on the server side.
    Also we partner with Cisco and so would it possible to work with your partners and I am pretty sure they have seen this before with DC issues etc. Can you please work with them and see?. TIA
    Best Regards
    Raghu Srinivasan

  • Oracle HRMS Integration with Microsoft Exchange Server 2007

    I would like to know if it is possible to integrate Oracle HRMS 11.5.10.x with Microsoft Exchange Server 2007 using Microsoft Identity Lifecycle Management (ILM) 2007?
    Has anyone ever come across something like this and successfully achieved it? Does anyone know of a step-by-step guide (or forum discussion) to achieve this?
    Response(s) will be highly appreciated.

    hi,
    We actually implemented integration of SAP with microsoft exchange server. It is not necessary for server and IIS to be in the same machine.
    regards,
    Ganesh.N

  • I/PM ERP Integration with Oracle Application Server instead of Websphere

    I'm just starting an integration between IPM 7.7.1 and JDE EnterpriseOne v8.12.
    In the EIS documentation for 7.7.1 has some specific assumptions regarding integrations with JDE EnterpriseOne (8.12), specifically using IBM Websphere. We opted to go with the Oracle Portal and Oracle Application Server. Just curious if the integration approach/instructions would require some adjustments because of the non-Websphere selection my JDE team chose. Or if it just plan won't work.
    Jim

    Hi Jim,
    The reason that the documentation specifically spells out IBM Websphere is most likely because it was the application server that we developed and tested with at the time. The important requirement for this type of integration is that this server be an Intel based server running a Microsoft OS. The reason for this is because there are dlls with the Oracle IPM product that enable communication between the IPM functions and the JDE Business functions. If the Enterprise server for JDE is intel based then a JAS can exist on the same server, the dlls can be on that machine and the extra server is not required. This server is only required if the Enterprise server is not intel based. As far as your choice to use Oracle Application Server goes, I really have no basis to say if this works or not. My thought is that it shouldn't matter as long as the JAS server is an intel based, 32 bit server running a Microsoft OS. There are many other variables and lots of experience implementing this type of integration with JDE within the Oracle IPM consulting team. Give us a call if we can help.
    Hope this helps,
    Matt

  • Integration with JMS Weblogic server, Couldn't connect to any host

    Hi ,
    I am doing XI to JMS integration(weblogic JMS server) ,have created a communication channel of type JMS and gave the following parameters.
    Transport Protocal  : Access JMS Provider with JNDI
    Message protocal    : JMS 1.X
    JNDI Lookup name with
    queueconnectionfactory :MyJMSConnectionFactory
    JNDI Lookup name with JMS Queue : MyJMSQueue
    Name of JNDI initial context factory : weblogic.jndi.WLInitialContextFactory
    <b>JNDI Server Address: http://isccap:7001/</b>
    all these parameters are working fine when used in a Client java program by which i am able to put and retrive message from Weblogic JMS server queue.
    But the same is not working in XI adapter ,
    I am getting the following error in adapter monitoring
    Zsrl_JMS_Reciever Receiver channel. Details: <u>Couldn't connect to any host</u>
    I guess the problem is with <b>JNDI Server Address: http://isccap:7001/</b>
    Is the format "http://host:port"  correct for weblogic server,
    are the JMS port and JNDI port same or different .
    I have deployed the required drivers "wlclient.jar" in XI server .
    Thanks in advance ,
    srikanth Lanka

    weblogic works on the Tenga3 protocol and hence the URL to connect to the JNDI provider of weblogic is
    t3://host:port
    At least in case of Weblogic you connect to your J2EE resources using your JNDI registry so the port would be the same.
    Rgds,
    Amol

  • Tandberg Codian MCU 4505 integration with Microsoft Lync server 2010

    Hi,
    We are trying to integrate Tandberg Codian MCU 4505 with Microsoft Lync server 2010.
    We do not have any VCS in the setup.
    If anybody has tried it before, please suggest configuration to be done on Tandberg Codian MCU 4505 and Lync server.
    Regards,
    RN

    Hi,
    so, i have the same environment. Lync 2013 and a cisco 1000V router on esxi with VRFs.
    here is m config:
    vrf definition Mgmt-intf
    address-family ipv4
    exit-address-family
    address-family ipv6
    exit-address-family
    voice vrf Mgmt-intf
    voice service voip
    no ip address trusted authenticate
    address-hiding
    media disable-detailed-stats
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      bind control source-interface GigabitEthernet0
      bind media source-interface GigabitEthernet0
      listen-port non-secure  5066
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    voice class codec 2
    codec preference 1 ilbc
    codec preference 2 g722-64
    codec preference 3 g711alaw
    codec preference 4 g711ulaw
    interface GigabitEthernet0
    vrf forwarding Mgmt-intf
    ip address 172.16.1.164 255.255.255.0
    negotiation auto
    dial-peer voice 15 voip
    tone ringback alert-no-PI
    numbering-type unknown
    preference 1
    destination-pattern 4.
    rtp payload-type comfort-noise 13
    session protocol sipv2
    session target ipv4:172.16.2.207:5068
    session transport tcp
    voice-class codec 2
    dtmf-relay rtp-nte
    dial-peer voice 17 voip
    numbering-type unknown
    preference 1
    destination-pattern 7.
    rtp payload-type comfort-noise 13
    session protocol sipv2
    session target ipv4:172.16.1.32:5060
    session transport udp
    voice-class codec 2
    dtmf-relay rtp-nte
    gateway
    timer receive-rtp 1200
    sip-ua
    keepalive target ipv4:172.16.2.207:5068 tcp
    172.16.1.32 - Asterisk with a extensions on it.
    172.16.2.207 - Lync 2013 mediation server with other extension on it
    i can call from Asterisk extension via router and to Lync extension.
    i cannot call from Lync to Asterisk.
    TCP session with the router from Lync on port 5066 does not come up. three way handshake seems to come up.
    strange. lync person seems to configured everything correctly
    any thoughts?

  • Cisco CME integration with NICE recorder

    Hi Team,
    Please let me know if we can integrate Cisco CME with NICE recorder. If yes, please share the steps involved in configuration on CME side and NICE.
    Warm Regards,
    Dinesh Rathi

    Hi Anas,
    If the panasonic prtocol is H323 will be no problem the CME dial peer will configure as below:-
    dial-peer voice 121 voip
    translation-profile outgoing prefix
    destination-pattern x..
    session target ipv4:192.x.x.x
    dtmf-relay h245-alphanumeric h245-signal
    but if the panasonic protocol is SIP the configuration on CME will be as below:-
    voice service voip
    ip address trusted list
      ipv4 0.0.0.0 0.0.0.0
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      registrar server expires max 250 min 200
      no call service stop
    dial-peer voice 2000 voip
    destination-pattern y...
    session protocol sipv2
    session target ipv4:172.x.x.x
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    So please can you advise for the above if the two options are right or not??
    Thanks

  • Continues integration  with OS X Server and Xcode Bot

    I want to to do the continues integration using Xcode bots. I have installed OSX Mavericks and Server(version 3). Iam able to create bots using Xcode 5.0.1. While integrating it is successfully performing analysing testing but always the final integration result is failure.
    Integration failed. Unexpected internal server error. See the integration's logs for more details.
    I didnt understand anything from the server log. Can anyone help me?
    Here is the full Server Error Log
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSLogger.m:483 7e026310 +9ms] Logging to log file /Library/Server/Xcode/Data/BotRuns/BotRun-17675794-26ed-4a92-b196-40399c60f8d9. bundle/output/service-log-file-snippet.log
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildBundle.m:247 7e026310 +0ms] Bot snapstot for bot run: {
                  containerGUID = "d365635a-4607-b2e8-2eca-9ce4821fed31";
                  createdByUserGUID = "732a32f3-8b83-4067-a09d-45076da78906";
                  extendedAttributes =     {
                      buildFromClean = 0;
                      buildOnTrigger = 0;
                      buildProjectPath = "iOS/SocialShare/SocialShareSample/SocialShareSample.xcodeproj";
                      buildSchemeName = SocialShareSample;
                      deviceSpecification = allDevices;
                      integratePerformsAnalyze = 1;
                      integratePerformsArchive = 0;
                      integratePerformsTest = 0;
                      pollForSCMChanges = 1;
                      scmInfo =         {
                          "/" =             {
                              botGroupGUID = "d365635a-4607-b2e8-2eca-9ce4821fed31";
                              credentialGUID = "fb7cf346-fe6e-4336-b893-8b9a06a550e0";
                              displayName = "https://harry-common.robosoft.co.in/Source";
                              isLocal = 0;
                              scmBranch = "";
                              scmCredentialType = password;
                              scmGUID = "80651525-4146-ab29-6f93-2cf11466ea32";
                              scmRepoPath = "https://harry-common.robosoft.co.in/Source";
                              scmRepoType = svn;
                              scmUsername = "anil.varghese";
                      scmInfoGUIDMap =         {
                          "/" = "80651525-4146-ab29-6f93-2cf11466ea32";
                  guid = "4e122aa2-56dd-4e3a-ad6e-25be1a65e657";
                  isBlogEnabled = 0;
                  isDeleted = 0;
                  isFavorite = 0;
                  isHidden = 0;
                  isMyPage = 1;
                  isPermanentlyDeleted = 0;
                  isWatched = 0;
                  lastActivityUserGUID = "742d3a53-c7b0-4911-9465-90a98fd3cf7c";
                  latestFailedBotRunGUID = "642d6a1b-0831-45b5-989e-65b319c3f084";
                  latestRunStatus = failed;
                  latestRunSubStatus = "internal-error";
                  longName = "Test Bot";
                  notifyCommitterOnFailure = 0;
                  notifyCommitterOnSuccess = 0;
                  ownerGUID = "d365635a-4607-b2e8-2eca-9ce4821fed31";
                  ownerType = "com.apple.entity.BotGroup";
                  parentGUIDs =     (
                      "70f4d626-c3cd-4678-8cb5-22648c1305b4",
                      "d365635a-4607-b2e8-2eca-9ce4821fed31",
                      "4e122aa2-56dd-4e3a-ad6e-25be1a65e657"
                  privateAttributes =     {
                  revision = 8;
                  shortName = testbot;
                  tags =     (
                  tinyID = testbot6;
                  type = "com.apple.entity.Bot";
                  updatedByUserGUID = "742d3a53-c7b0-4911-9465-90a98fd3cf7c";
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildBundle.m:893 7e026310 +0ms] Updating bot and bot run status to running, substatus to
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 6e81000 +45ms] didReceiveResponse
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 6e81000 +0ms] response=<NSHTTPURLResponse: 0x7fd9b2530270> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 120;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:41 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 6e81000 +0ms] didReceiveData
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 6e81000 +0ms] connectionDidFinishLoading
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 6e81000 +0ms] Out of runloop; request completed
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 6e81000 +0ms] Received successful response.
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 6e81000 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 6e81000 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 6e81000 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{XCWorkQueueService.waitForChangesToWorkQueue:forTimeInterval:sin ceDate:(control-17675794-26ed-4a92-b196-40399c60f8d9,30,<CSDateTime date=1970-01-01 00:00:00 +0000 epochValue=0 isoValue=1970-01-01T05:30:00.000+0530>)}
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 6e81000 +0ms] Secure, async request
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 6e81000 +0ms] Before runloop; request pending
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +2ms] Connecting to https://localhost:4443/svc to execute [https]Request{AuthService.enterMagicalAuthRealm()}
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +1ms] Secure, async request
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:260 7e026310 +8ms] canAuthenticateAgainstProtectionSpace
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:270 7e026310 +0ms] didReceiveAuthenticationChallenge
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:281 7e026310 +0ms] Server trust auth challenge. Host is localhost, sanityCheck 0, trust <SecTrust 0x7fd9b253da10 [0x7fff7d91aeb0]>
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:260 7e026310 +1ms] canAuthenticateAgainstProtectionSpace
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:270 7e026310 +0ms] didReceiveAuthenticationChallenge
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:293 7e026310 +0ms] Client cert auth challange.
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSSSLUtility.m:308 7e026310 +0ms] GetIdentityAndCertChainForName for com.apple.server.xcsbuildd
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSSSLUtility.m:353 7e026310 +2ms] Match found
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSSSLUtility.m:208 7e026310 +0ms] GetChainForCert common name: com.apple.server.xcsbuildd, summary: com.apple.server.xcsbuildd
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSSSLUtility.m:225 7e026310 +0ms] Chain for com.apple.server.xcsbuildd has 1 certs
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:300 7e026310 +0ms] didReceiveAuthenticationChallenge: GetIdentityAndCertChainForName returned identity and certs
    Oct 29 09:15:41 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:315 7e026310 +0ms] didReceiveAuthenticationChallenge using Cert: Identity Cert 1 - com.apple.server.xcsbuildd
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +402ms] didReceiveResponse
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +0ms] response=<NSHTTPURLResponse: 0x7fd9b2539cd0> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 1579;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:42 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:97 7e026310 +0ms] Updating bot run with GUID 17675794-26ed-4a92-b196-40399c60f8d9
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:102 7e026310 +0ms] Updating bot run (17675794-26ed-4a92-b196-40399c60f8d9): {
                  guid = "17675794-26ed-4a92-b196-40399c60f8d9";
                  status = running;
                  subStatus = "";
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{XCBotService.updateBotRun:({
                  guid = "17675794-26ed-4a92-b196-40399c60f8d9";
                  status = running;
                  subStatus = "";
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +0ms] Secure, async request
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +126ms] didReceiveResponse
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +0ms] response=<NSHTTPURLResponse: 0x7fd9b2540a60> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 3444;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:42 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:108 7e026310 +0ms] Updating bot with GUID 4e122aa2-56dd-4e3a-ad6e-25be1a65e657
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:117 7e026310 +0ms] Updating bot with latest bot run GUID key
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:124 7e026310 +0ms] Updating bot (4e122aa2-56dd-4e3a-ad6e-25be1a65e657): {
                  guid = "4e122aa2-56dd-4e3a-ad6e-25be1a65e657";
                  latestRunStatus = running;
                  latestRunSubStatus = "";
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{XCBotService.updateBot:({
                  guid = "4e122aa2-56dd-4e3a-ad6e-25be1a65e657";
                  latestRunStatus = running;
                  latestRunSubStatus = "";
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +0ms] Secure, async request
    Oct 29 09:15:42 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +741ms] didReceiveResponse
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +0ms] response=<NSHTTPURLResponse: 0x7fd9b24735d0> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 1725;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:43 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildBundle.m:837 7e026310 +0ms] Updating bot run with dictionary {
                  startTime = "<CSDateTime date=2013-10-29 03:45:43 +0000 epochValue=1383018343.023076 isoValue=2013-10-29T09:15:43.023+0530>";
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:141 7e026310 +0ms] Updating bot run with GUID 17675794-26ed-4a92-b196-40399c60f8d9: {
                  startTime = "<CSDateTime date=2013-10-29 03:45:43 +0000 epochValue=1383018343.023076 isoValue=2013-10-29T09:15:43.023+0530>";
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{AuthService.enterMagicalAuthRealm()}
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +0ms] Secure, async request
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +150ms] didReceiveResponse
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +0ms] response=<NSHTTPURLResponse: 0x7fd9b2541da0> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 1579;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:43 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{XCBotService.updateBotRun:({
                  guid = "17675794-26ed-4a92-b196-40399c60f8d9";
                  startTime = "<CSDateTime date=2013-10-29 03:45:43 +0000 epochValue=1383018343.023076 isoValue=2013-10-29T09:15:43.023+0530>";
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +0ms] Secure, async request
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +682ms] didReceiveResponse
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +0ms] response=<NSHTTPURLResponse: 0x7fd9b25444f0> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 3526;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:43 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildBundle.m:610 7e026310 +0ms] Starting credential download operation
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildBundle.m:908 7e026310 +0ms] Updating bot run status to running, substatus to preparing
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{AuthService.enterMagicalAuthRealm()}
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +0ms] Secure, async request
    Oct 29 09:15:43 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +341ms] didReceiveResponse
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +1ms] response=<NSHTTPURLResponse: 0x7fd9b2542480> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 1579;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:44 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:97 7e026310 +0ms] Updating bot run with GUID 17675794-26ed-4a92-b196-40399c60f8d9
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildHelper.m:102 7e026310 +0ms] Updating bot run (17675794-26ed-4a92-b196-40399c60f8d9): {
                  guid = "17675794-26ed-4a92-b196-40399c60f8d9";
                  status = running;
                  subStatus = preparing;
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSConfig.m:55 7e026310 +0ms] Reading plist at /Library/Server/Wiki/Config/collabd.plist
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Info>: [CSRemoteServiceClient.m:151 7e026310 +0ms] Connecting to https://localhost:4443/svc to execute [https]Request{XCBotService.updateBotRun:({
                  guid = "17675794-26ed-4a92-b196-40399c60f8d9";
                  status = running;
                  subStatus = preparing;
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:159 7e026310 +0ms] Secure, async request
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:169 7e026310 +0ms] Before runloop; request pending
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:223 7e026310 +417ms] didReceiveResponse
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:225 7e026310 +0ms] response=<NSHTTPURLResponse: 0x7fd9b2540640> { URL: https://localhost:4443/svc } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 3535;
                  "Content-Type" = "x-apple/msgpack";
                  Date = "Tue, 29 Oct 2013 03:45:44 GMT";
                  Status = 200;
                  "X-Apple-collabd" = yes;
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:233 7e026310 +0ms] didReceiveData
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:246 7e026310 +0ms] connectionDidFinishLoading
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceClient.m:172 7e026310 +0ms] Out of runloop; request completed
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [CSRemoteServiceProxy.m:79 7e026310 +0ms] Received successful response.
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:34 7e026310 +0ms] Initialized a credential download operation for run GUID 17675794-26ed-4a92-b196-40399c60f8d9 scmInfo {
                  "/" =     {
                      botGroupGUID = "d365635a-4607-b2e8-2eca-9ce4821fed31";
                      credentialGUID = "fb7cf346-fe6e-4336-b893-8b9a06a550e0";
                      credentialToken = "O8}}H$q;-n;.}Lz-}Lq&~pSvmrT[$uOyFe^#~daG\\76[V~X#ghC{|T>2-HGnn<)_";
                      displayName = "https://harry-common.robosoft.co.in/Source";
                      isLocal = 0;
                      scmBranch = "";
                      scmCredentialType = password;
                      scmGUID = "80651525-4146-ab29-6f93-2cf11466ea32";
                      scmRepoPath = "https://harry-common.robosoft.co.in/Source";
                      scmRepoType = svn;
                      scmUsername = "anil.varghese";
              } downloadToken map {
                  "https://harry-common.robosoft.co.in/Source" = "O8}}H$q;-n;.}Lz-}Lq&~pSvmrT[$uOyFe^#~daG\\76[V~X#ghC{|T>2-HGnn<)_";
              } and credential path /Library/Server/Xcode/Data/BotRuns/BotRun-17675794-26ed-4a92-b196-40399c60f8d9. bundle/credentials
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSOperation.m:16 7e026310 +0ms] Executing operation: XCSCredentialOperation
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:68 7e026310 +0ms] Processing credentials for each scm URI in (
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:84 7e026310 +0ms] Processing scmItem / with credential download token O8}}H$q;-n;.}Lz-}Lq&~pSvmrT[$uOyFe^#~daG\76[V~X#ghC{|T>2-HGnn<)_
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:94 7e026310 +0ms] Creating credential path at /Library/Server/Xcode/Data/BotRuns/BotRun-17675794-26ed-4a92-b196-40399c60f8d9. bundle/credentials/fb7cf346-fe6e-4336-b893-8b9a06a550e0
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:104 7e026310 +0ms] Fetching credential with downloadToken O8}}H$q;-n;.}Lz-}Lq&~pSvmrT[$uOyFe^#~daG\76[V~X#ghC{|T>2-HGnn<)_
    Oct 29 09:15:44 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:148 7e026310 +0ms] headerDict before request: {
                  "X-Apple-Credential-botRunGUID" = "17675794-26ed-4a92-b196-40399c60f8d9";
                  "X-Apple-Credential-command" = getCredential;
                  "X-Apple-Credential-downloadToken" = "O8}}H$q;-n;.}Lz-}Lq&~pSvmrT[$uOyFe^#~daG\\76[V~X#ghC{|T>2-HGnn<)_";
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:173 7e026310 +381ms] Got data in the download credential request <3c3f786d 6c207665 7273696f 6e3d2231 2e302220 656e636f 64696e67 3d225554 462d3822 3f3e0a3c 21444f43 54595045 20706c69 73742050 55424c49 4320222d 2f2f4170 706c652f 2f445444 20504c49 53542031 2e302f2f 454e2220 22687474 703a2f2f 7777772e 6170706c 652e636f 6d2f4454 44732f50 726f7065 7274794c 6973742d 312e302e 64746422 3e0a3c70 6c697374 20766572 73696f6e 3d22312e 30223e0a 3c646963 743e0a09 3c6b6579 3e706173 73776f72 643c2f6b 65793e0a 093c7374 72696e67 3e736861 646f772e 383c2f73 7472696e 673e0a09 3c6b6579 3e757365 726e616d 653c2f6b 65793e0a 093c7374 72696e67 3e616e69 6c2e7661 72676865 73653c2f 73747269 6e673e0a 3c2f6469 63743e0a 3c2f706c 6973743e 0a>
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:174 7e026310 +0ms] Got a response to a download credential request <NSHTTPURLResponse: 0x7fd9b2549980> { URL: https://127.0.0.1:2012/ } { status code: 200, headers {
                  "Accept-Ranges" = bytes;
                  "Content-Length" = 289;
                  Date = "Tue, 29 Oct 2013 03:45:45 GMT";
                  "X-Apple-Credential-credentialType" = password;
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:175 7e026310 +0ms] Got credential with type password
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:189 7e026310 +0ms] Mapping credential to an XCSCredential instance
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:192 7e026310 +0ms] Dealing with a password credential, attempting to initialize an XCSCredentialPassword
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialServerHTTPClient.m:204 7e026310 +0ms] Got a credential object <XCSCredentialPassword: 0x7fd9b255e850> of type password
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:109 7e026310 +0ms] Credential callback fired credential = <XCSCredentialPassword: 0x7fd9b255e850>, error = (null)
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:117 7e026310 +0ms] Processing credential <XCSCredentialPassword: 0x7fd9b255e850> for downloadToken O8}}H$q;-n;.}Lz-}Lq&~pSvmrT[$uOyFe^#~daG\76[V~X#ghC{|T>2-HGnn<)_
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:125 7e026310 +0ms] Updating operation result with credential
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:130 7e026310 +0ms] Expecting 1 credentials, have 1 credentials already
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSCredentialOperation.m:132 7e026310 +0ms] Done processing credentials
    Oct 29 09:15:45 AnilV-InetliMac.local xcsbuildd[3914] <Debug>: [XCSBuildBundle.m:637 7e026310 +0ms] Got credentials from credential operation: {
                  "fb7cf346-fe6e-4336-b893-8b9a06a550e0" = "<XCSCredentialPassword: 0x7fd9b255e850>";

    Hi Anil,
    Am curious to know if this problem has been solved. Have you tried with Xcode 5.1 ?
    Am trying to do this with Xcode 5.1, however am not able succeed the integration. However, am getting a little different error "NSLocalizedDescription=HTTP credential request failed, got HTTP status 400 with headers ".
    From your logs, I can see that you are able to successfully download th credentials, which is failing at my end. Hence it would be great if you let me know where have saved your credentials? Below is the error excerpt:
    Apr 15 13:04:52 estmacsvr01.local xcsbuildd[70827] <Debug>: [XCSCredentialOperation.m:104 7db26310 +0ms] Fetching credential with downloadToken JK~C]!>G!vzyVv)"e?C5j(TNAYYyI[-yV4)/ZAe|t]sfkK+f]u<\vbth^,u.0tVP Apr 15 13:04:52 estmacsvr01.local xcsbuildd[70827] <Debug>: [XCSCredentialServerHTTPClient.m:148 7db26310 +0ms] headerDict before request:
    "X-Apple-Credential-botRunGUID" = "afc45888-b5b4-4d0c-80a1-127ac3d3aa24";
    "X-Apple-Credential-command" = getCredential;
    "X-Apple-Credential-downloadToken" = "JK~C]!>G!vzyVv)\"e?C5j(TNAYYyI[-yV4)/ZAe|t]sfkK+f]u<\\vbth^,u.0tVP";
    Apr 15 13:04:52 estmacsvr01.local xcsbuildd[70827] <Error>: [XCSCredentialServerHTTPClient.m:155 7db26310 +139ms] Got a nil response to a download credential request
    "X-Apple-Credential-botRunGUID" = "afc45888-b5b4-4d0c-80a1-127ac3d3aa24";
    "X-Apple-Credential-command" = getCredential;
    "X-Apple-Credential-downloadToken" = "JK~C]!>G!vzyVv)\"e?C5j(TNAYYyI[-yV4)/ZAe|t]sfkK+f]u<\\vbth^,u.0tVP";
    Apr 15 13:04:52 estmacsvr01.local xcsbuildd[70827] <Debug>: [XCSCredentialOperation.m:109 7db26310 +0ms] Credential callback fired credential = (null), error = Error Domain=XCSCredentialErrorDomain Code=-1 "HTTP credential request failed, got HTTP status 400 with headers { "Accept-Ranges" = bytes; "Content-Length" = 0; Date = "Tue, 15 Apr 2014 07:34:52 GMT"; "X-Apple-Credential-error" = itemNotFound; }" UserInfo=0x7f91e4122ae0 {NSLocalizedDescription=HTTP credential request failed, got HTTP status 400 with headers { "Accept-Ranges" = bytes; "Content-Length" = 0; Date = "Tue, 15 Apr 2014 07:34:52 GMT"; "X-Apple-Credential-error" = itemNotFound; }}
    Your help is greatly appreciated!

Maybe you are looking for