Detecting the host application type

I have a plug-in for Acrobat Professional. Is there any way for this plug-in to determine the host application like if it is running inside a Acrobat Professional or inside a browser container etc?
I need to know this becasuse my plug-in is causing the browsers to crash whenever they open PDF files. My idea is to detect the host for my app and abort loading the plug-in if it is not full blows Acrobat app.
Thanks
Shreedhar

You don't need to!
When you create your toolbar button, don't add EXTERNAL to the parameters you pass it.
How else is your plugin invoked other than button (see above) or menu (not present)?

Similar Messages

  • How to dispatch an event to the host application?

    Can I create a keyboardEvent and dispatch it to the host application?
    I'm trying to create an onscreen keyboard, so on every mouseUp event, a corresponding keyboardEvent is created and dispatched to the host application.
    Is it even possible to dispatch a keyboard event programatically?

    I can dispatch Keyboard Events programatically, and event listener inside my extension works just fine.
         var evnt:KeyboardEvent = new KeyboardEvent(KeyboardEvent.KEY_DOWN, true, false, Keyboard.M);
         this.dispatchEvent(evnt);
    However, the KeyBoardEvent is not propogating up to the host application (Illustrator).
    What do I need to do to send it on to the host application?

  • Executing the host application

    Hi, i developed a host application with OCF to communicate with my applet, everything is OK. now i wonder if i can execute the host application from an HTML page

    SYNCHRONIZE will update the display with the internal stae of the application (so don't think you should be expecting any performance improvements).
    HOST command will generally run synchronously - so it will wait for the host command to finish executing. If you want to asynchronously you could HOST out to a BAT file a put your commands in the BAT file.
    Regards
    Grant Ronald
    Forms Product Management

  • U330: "Catalyst Control Center: The Host Application Stopped Working"

    I've been getting this nagging message whenever I boot windows.  Tried uninstalling and re-installing the driver and ATI software from Lenovo's site but the problem persists.  I can produce the message at anytime by running "ATI Restart Runtime".  Someone please tell me how to fix this, it's really annoying.

    What was recently installed or changed on your system?  A quick option will be to use the System Restore Tool to restore the computer to an earlier point in time before this problem started. Using the System Restore tool may not necessarily help you determine the issue. When you use System Restore to restore the computer to a previous state, programs and updates that you installed are removed.
    To restore the operating system to an earlier point in time, follow these steps:
    1.      Click Start, type system restore in the Start Search box, and then click System Restore in the Programs list. If you are prompted for an administrator password or confirmation, type your password or click Continue.
    2.      In the System Restore dialog box, click Choose a different restore point, and then click Next.
    3.      In the list of restore points, click a restore point that was created before you began to  experience the issue, and then click Next.
    4.      Click Finish.
    5.      The computer restarts, and the system files and settings are returned to the state that they were in at the time that the restore point was created.
    If my reply was helpful please click the "Kudos" star.
    If your problem is solved please click the "Accept as Solution" button

  • Run extension without restarting the host application ?

    While developing, is there a way to test/debug the extenstion without restarting illustrator everytime the time? This is really time-consuming...
    Extension Builder 2.1 in combination with FB had an "Attach as" feature that would take care of this, but I cannot seem to get EB 3 working in FB.
    Tom

    Happy to answer my own question. Here's what you do to reload the panel, by creating a simple button that reloads the 'window'. Useful for Illustrator scripts.
    In yout HTML:
        <button id="bt_reload" class="hostButton">Reload</button>
    In your main.js file (or similar)
    $("#btn_reload").click(reloadPanel);
        // Reloads extension panel
        function reloadPanel() {
            location.reload();

  • Unable to connect multiple MAF components in a WPF host application

    I'm trying to connect my MAF component parts for the addin extensibility to work, however I'm getting certain errors while trying to build my add in store.
    string path = @"...\MyProject\Extensibility\Output";
    string[] errorList = AddInStore.Rebuild(path);
    that's the pipeline path, which looks like according to documentation:
    Extensibility\
    Output\
    AddIns
    AddInSideAdapters
    AddInViews
    Contracts
    HostSideAdapters
    My WPF host app DLL file is located under this directory:
    MyProject\WPFApp\bin\debug
    So, I'm unsure where to build my HostView. Currently the output is the pipeline root directory (Extensibility\Output)
    I have 4 errors in my errorList:
    While examining an assembly for pipeline segments, got a ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information. File Name: ...MyProject\Extensibility\Output\AddInSideAdapters\AddInSideAdapters.dll
    2:
    Could not connect up a part in a pipeline to its neighbors: Contract Name: "IAddInContract" Location: "Contracts\Contracts.dll".
    3:
    Could not connect up a part in a pipeline to its neighbors: AddInBase Name: "AddInView" Location: "AddInViews\AddInViews.dll".
    4:
    Could not connect 2 valid add-in model parts.
    And the code of addin side adapter, contact and addin view respectively:
    [AddInAdapter]
    public class AddInSideAdapter : ContractBase, IAddInContract
    private AddInView view;
    public AddInSideAdapter(AddInView view)
    this.view = view;
    public void Initialize(IPluginHandler handler)
    view.Initialize(handler);
    public INativeHandleContract GetCustomUI()
    return FrameworkElementAdapters.ViewToContractAdapter(view.GetCustomUI());
    [AddInContract]
    public interface IAddInContract: IContract
    void Initialize(IPluginHandler handler);
    INativeHandleContract GetCustomUI();
    [AddInBase]
    public abstract class AddInView
    public abstract void Initialize(IPluginHandler handler);
    public abstract FrameworkElement GetCustomUI();
    They're output directories are ok, all building into the corresponding pipeline segments. I really cannot understand what's failing. Pipeline structure is ok, build paths of segments are ok (just not sure about the HostView and the host app). The path variable
    is ok, i just omitted the entire path for brevity

    Hi Mefhisto,
    >>”So, I'm unsure where to build my
    HostView. Currently the output is the pipeline root directory”
    I found some information about your problem in “Pipeline Development Requirements”,It said “The host application and the host view are typically deployed
    in the same directory. The pipeline directory can be in any location but is typically in the same directory as the host application.”This is the link of the document :
    https://msdn.microsoft.com/en-us/library/bb384240(v=vs.90).aspx. And there are several samples,you can refer to it for reference.
    http://clraddins.codeplex.com/wikipage?title=Samples&referringTitle=Home

  • Accessing the host component in a PDF navigator

    Hi all,
    I'm trying to access the host (i.e reader or acrobat) in a PDF navigator (Portfolio) created in flash builder.
    I have seen numerous examples that override the host set method by doing the following:
    public function set host(host:INavigatorHost):void
                                                 if(host != null) {
                                                           _host = host;
                                                           startEverything();
                                                 } else {
                                                           _host = null;
                                                           //Alert.show("Navigator Ending");
    Then the _host:INavigatorHost is used to access the host application.
    When I try to do this using Flex 4.1 it tells me that this method is not marked for override.
    If i just try to access 'host' it tells me that it is 'write-only'.
    Any help at all, or another method would be greatly appreciated.
    Thanks,
    Chris

    Hi,
    there are several possibilities to achieve that.
    For example
    - JDO
    - SQLJ
    - direct access to the database via JDBC from your WD Controller (not recommended).
    For more information about JDO see at
    /program files/SAP/JDT/eclipse/examples
    There you will find the tutorial J2EE_GettingStartedJDO
    For general information about Java persistence have a look at
    http://help.sap.com/saphelp_erp2004/helpdata/de/61/fdbc3d16f39e33e10000000a11405a/content.htm
    Regards
    Helmut

  • How can I launch configurator from host application in a specefic language.

    Hi,
    I want to access R12 configurator from a host application and I have no problems accessing it.
    But I want that the configurator should Launch in Japanese Language. Can I specify any XML parameter to the UIServlet to achieve this or is there any other Method?
    Thanks

    Per the "Deploying a User Interface that Supports MLS" section in Chapter 14 ("Multiple Language Support") of the Oracle Configurator Implementation Guide:
    "When a host application launches Oracle Configurator to configure an item, the language specified in the database ICX session ticket is passed to Oracle Configurator.  Oracle Configurator uses this information to determine which translated text to retrieve from the database and display in the UI."
    So essentially, Configurator will display the same language that the hosting application is displaying, the language the user has logged into EBS with.  (Of course, translated text will only appear in Configurator if you have supplied translations in the CZ_LOCALIZED_TEXTS table.)  If you need Configurator to display a different language than its hosting application, that would require a customization of the initialization string the hosting application sends to Configurator, specifying a different icx_session_ticket parameter value.
    Hope this helps.
    Eogan

  • Host application strange error, please help !!

    hello everyone,
    can anybody of you help me with this error:
    >> cannot find symbol; symbol : method getMessage(), location: class java.lang.ClassNotFoundException
    it is displayed as I am writing the host application for an applet using OCF, at this level:
    >> my_Card_Proxy = (MyCardProxy) card.getCardService(MyHostSideApp.class, true);
    what do you think of this? I tried many codes but I am always having the same error, I dont know where does the problem come from.
    please if you have any suggestion, I really need it
    thank you

    Hmmm.
    Are u sure that u have put all the JSP page in a proper folder where if u do not put them in a proper folder it want work.
    Else where in side jsp code the naming part as been misplaced . Go through that code again I hope u can find out the error.
    mostly the second one normally occurred every time....
    Good site too.

  • Application type  & out put type

    Hi ,
    For MI21 (Physical Inventory Documents) reprt what is the
    1)application type
    2)out put type
    Thanks & Regards
    Krishna

    Here are the standard ones for printing
    Output Types Mode (1= Printing)  Application
    ET01   1                                     ME
    J1IB    1                                      ME
    J1IF     1     ME
    WA01   1     ME
    WA02   1     ME
    WA03   1     ME
    WAE1   1     ME
    WAE2   1     ME
    WAE3   1     ME
    WE01   1     ME
    WE02   1     ME
    WE03   1     ME
    WEE1   1     ME
    WEE2   1     ME
    WEE3   1     ME
    WEK1   1     ME
    WF01   1     ME
    WF02   1     ME
    WLB1   1     ME
    WLB2   1     ME
    WLB3   1     ME
    Hope That Helps
    Anirban M.

  • Host application authentication

    Excuse my newbie question, but I'm wondering how do you authenticate a host application? If you do that by sharing some keys, then the host application must have a copy of such keys stored somewhere, right? But is it safe? I mean, what if the hacker is able to somehow get the keys from your host application?
    THanks!

    To authenticate- read the Global Platform specifications. It's detailed very well in there ( follow this thread http://forum.java.sun.com/thread.jsp?forum=23&thread=279804)
    Key security - develop a good design to protect them.

  • Multiple Attachments in Email Payload declaring with Application Types

    Hi XI Experts,
    I am currently working on an Email Module to handle multiple attachments. I have read all forum entries to this topic but I got know answer to my question.
    My question:
    Is it technically possible to declare more than one Atttachment of the Payload with the tag <Application Type>? From the coding point of view I know that it is possible like this
    for ( int  i = 0; i < XMBMessageOperator.numberOfPayloads(message); i++){
    XMBPayload payload = XMBMessageOperator.getPayload(message, i);
    payload .setPayloadType(PayloadType.APPLICATION);
    but does the XI then also process all application attachment messages correctly as separate messages?
    So from the coding point of view does the XI iterate over all application attachments and processes the messages?
    best regards,
    Dries

    Hi Dries,
    I would suggest to do it using SAPConnect instead of ccBPM.Check this blog.
    It splits the payload and sends it as multiple attachment.https://weblogs.sdn.sap.com/pub/wlg/3007.Source [original link is broken] [original link is broken] [original link is broken] [original link is broken] code sends multple attachments as an email.
    You have to use the viceversa.Read the thomas jung blogs for further info /people/thomas.jung3/blog/2004/09/09/receiving-e-mail-and-processing-it-with-abap--version-610-and-higher .
    vasanth

  • BRM - Default Application Type..?

    Hi All,
    Is there any way to set up the default Application Type as SAP in BRM, while going to create Roles?
    I need this field to be set as SAP and non-editable. (kinldy rfer the attached screen grab)
    Would appreciate for your quick and positve response.
    Thanks,
    Ameet

    Hi Ameet
    If you aren't using the others why not remove them from your configuration for connector groups? If you need business role you will need to leave that one there.
    To make default and display only would probably require configuration of web dynpro screen.
    Regards
    Colleen

  • HI friends i am facing issue regarding the hosting of an application on the firewall .

    Dear friends i configure public ip on firewall interface ,and i have one more public ip for hosting of the sqp application publicly,so please how can i do this can any one let me know configuration is below.
    THE BELOW ARE THE IP ADD FOR THE SERVER HOSTING ,AND CONFIGURATION OF THE FIREWALL AND ROUTER FOLLLOW BELOW.
    PC IP : 72.93.232.66
    Subnet Mask: 255.255.255.252
    Gate Way ( Router IP ) : 72.93.232.65
    Domain Name : www.hrmstadrees.com
    Server Local IP for Application: http://10.10.10.4/MenaITech/Mename/
    ASA-CONFIG
    ASA Version 8.2(5)
    domain-name RAQ.com
    enable password lpW.MGeEHg0ISQZq encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface Ethernet0/0
    description Connected to TAD-Router G0/1
    nameif outside
    security-level 0
    ip address 72.93.19.174 255.255.255.252
    interface Ethernet0/1
    description Connected to Cisco SMB Switch G1
    nameif inside
    security-level 100
    ip address 10.15.1.1 255.255.255.248
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    no ip address
    management-only
    banner login ********  RAQ FIREWALL ********
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
    name-server 8.8.8.8
    name-server 84.22.224.11
    name-server 84.22.224.12
    domain-name tadrees.com
    access-list split-tunnel standard permit 10.10.0.0 255.255.0.0
    access-list nonat extended permit ip 10.1.1.0 255.255.255.0 10.10.0.0 255.255.0.0
    access-list nonat extended permit ip 10.10.0.0 255.255.0.0 10.1.1.0 255.255.255.0
    access-list Mename-Access extended permit tcp any host 72.93.19.174 eq www
    pager lines 24
    logging enable
    logging buffered debugging
    logging asdm debugging
    mtu outside 1500
    mtu inside 1500
    mtu management 1500
    ip local pool sslvpnpool 10.1.1.1-10.1.1.254 mask 255.255.255.0
    no failover
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-702.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 0 access-list nonat
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) tcp interface www 10.10.10.4 www netmask 255.255.255.255
    access-group Mename-Access in interface outside
    router rip
    network 10.0.0.0
    version 2
    route outside 0.0.0.0 0.0.0.0 72.93.19.173 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server TAD-AD protocol nt
    aaa-server TAD-AD (inside) host 10.10.10.1
    aaa authentication ssh console LOCAL
    http server enable 444
    http 192.168.1.0 255.255.255.0 management
    http 0.0.0.0 0.0.0.0 outside
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet 0.0.0.0 0.0.0.0 inside
    telnet timeout 2
    ssh 0.0.0.0 0.0.0.0 outside
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 20
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    enable outside
    no anyconnect-essentials
    svc image disk0:/anyconnect-win-2.5.2014-k9.pkg 1
    svc enable
    tunnel-group-list enable
    internal-password enable
    group-policy sslvpn internal
    group-policy sslvpn attributes
    wins-server none
    dns-server none
    vpn-tunnel-protocol svc webvpn
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value split-tunnel
    default-domain value tadrees.com
    group-policy DfltGrpPolicy attributes
    webvpn
      svc ask enable default webvpn timeout 30
    username admin password s8Vngsgpp8NmOJP7 encrypted privilege 15
    username cisco password HWFflA1bzYiq7Uut encrypted privilege 15
    tunnel-group TAD-SSLV type remote-access
    tunnel-group TAD-SSLV general-attributes
    address-pool sslvpnpool
    authentication-server-group TAD-AD LOCAL
    default-group-policy sslvpn
    tunnel-group TAD-SSLV webvpn-attributes
    group-alias ssl enable
    group-url https://72.93.19.174/ssl enable
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:c23556bcb54d60cbd598593f6429d106
    : end
    ROUTER CONFIGURATION
    RAQ-Router#sho run
    Building configuration...
    Current configuration : 5623 bytes
    ! Last configuration change at 13:59:42 UTC Sat Sep 21 2013 by cisco
    ! NVRAM config last updated at 13:44:13 UTC Sat Sep 21 2013 by cisco
    ! NVRAM config last updated at 13:44:13 UTC Sat Sep 21 2013 by cisco
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname TAD-Router
    boot-start-marker
    boot-end-marker
    logging buffered 51200 warnings
    enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY
    no aaa new-model
    no ipv6 cef
    ip source-route
    no ip cef
    ip domain name yourdomain.com
    ip name-server 8.8.8.8
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1513054491
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1513054491
    revocation-check none
    rsakeypair TP-self-signed-1513054491
    crypto pki certificate chain TP-self-signed-1513054491
    certificate self-signed 01
      3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31353133 30353434 3931301E 170D3132 30393236 31363239
      33385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35313330
      35343439 3130819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100AADE 6F39CF31 6832A80B DBCC6E4D 82AA4F8A B71E7118 50B53E0E FD94E7E9
      A6557FD6 30A099C0 D44E36BA 92CBE1EB 1C2789B6 A1260D38 B24637A5 255F18D7
      0B6F2B70 44CF0583 DADB7687 E4102B24 4FA18CDA 36A7CA2A 96F78C1C B92214D8
      087DC6D5 240F7449 DBC4AD01 17FBDC0A 9ECC24DF C7D57E33 9C9CF327 27F2A905
      78470203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
      551D2304 18301680 14D06F56 4B82A937 E11730CB BDEECF51 BDAE337F 98301D06
      03551D0E 04160414 D06F564B 82A937E1 1730CBBD EECF51BD AE337F98 300D0609
      2A864886 F70D0101 05050003 8181005A 297C5954 817B8D56 1443D1D5 B21DBA42
      F7EC486D B82CBA55 C2953C0E 756FAC1F B04C48C3 D208E4AF DE412F1C C4A97B38
      856AC4F2 A664C6CB 3E241FB6 4AD2DC4B BE5B4809 DE6269CC 0826E822 33F853B3
      3FE1E0E9 AA125902 C632B6E6 BE2EC625 0F7F2259 F408844B 9813429F 422EDBE0
      ADE0EA0D A2138291 D806C4F1 72C4A9
            quit
    license udi pid CISCO2911/K9 sn FCZ1633771T
    username bciscoadmin password 0 tadreesadmin
    username cisco privilege 15 password 0 c1sc0
    ip ssh version 1
    track 1 interface Dialer0 ip routing
    interface Embedded-Service-Engine0/0
    no ip address
    shutdown
    interface GigabitEthernet0/0
    description Connected to Internet Temp
    no ip address
    duplex auto
    speed auto
    interface GigabitEthernet0/1
    ip address 72.93.19.173 255.255.255.252
    ip tcp adjust-mss 1452
    duplex auto
    speed auto
    interface GigabitEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface ATM0/0/0
    no ip address
    no atm ilmi-keepalive
    pvc 0/35
      pppoe-client dial-pool-number 1
    pvc 0/99
      pppoe-client dial-pool-number 1
    interface Dialer0
    no ip address
    interface Dialer1
    description $FW_OUTSIDE$
    ip address negotiated
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip mtu 1492
    ip flow ingress
    ip nat outside
    ip nat enable
    ip virtual-reassembly in
    encapsulation ppp
    ip tcp adjust-mss 1452
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname [email protected]
    ppp chap password 0 123456
    ppp pap sent-username [email protected] password 0 123456
    no cdp enable
    ip forward-protocol nd
    no ip http server
    ip http access-class 23
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    ip route 0.0.0.0 0.0.0.0 Dialer1
    access-list 23 permit 10.10.10.0 0.0.0.7
    no cdp run
    control-plane
    banner login ^CC
    **    TADREES PRIVATE NETWORK ..... AUTHORIZED USERS ONLY    **
    ***************************************************************^C
    banner motd ^CC
                                                      ==================
                                                           WARNING
                                                      ==================
    If you are an unauthorized user LOG OFF NOW, all unauthorized access will be prosecuted to the full extent of the law
    This is a Private Network Device. This resource including all related equipment, networks and network devices, are provided for authorized Private use. Private systems are monitored for all lawful purposes, including ensuring authorized use, for manageme
    The monitoring on this system may include audits by authorized personnel to test or verify the validity, security and survivability of this system. During monitoring information may be examined, recorded, copied and used for authorized purposes. All
    Use of this system, constitutes consent to this policy and the policies and procedures set forth by the company
    Evidence of unauthorized use collected during monitoring will be used for criminal prosecution by  staff, legal counsel and law enforcement agencies.^C
    line con 0
    login local
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    login local
    transport input telnet ssh
    line vty 5 15
    login local
    transport input telnet ssh
    scheduler allocate 20000 1000
    end

    Let me get this correctly, you want to access the server over the public IP?

  • Detecting the type of Internet Connection

    Hi..
    I am trying ... build an application that detects the kind of internet
    connection (Dial-up, T1, DSL etc) that you are using and then disconnects it.
    This application, must then send a response to a server-side program
    containing information about the user and the connection type. This
    application has to also trip the current connection if it is dial-up. Thats much later on, I first need to be able to detect the connection type.
    I was was wondering whether there is some documentation/code samples about the same ?
    Thanks a lot,
    Abhijeet

    Thanks for the information...let me explain now...
    hi:
    reply inline --
    I am trying ... build an application that detectsthe
    kind of internet
    connection (Dial-up, T1, DSL etc) that you areusing
    i don't think there's a Java API for doing this
    intrinsically.
    on the other hand, there one easy (yet not very
    reliable) way
    of detecting type of connection...
    xfer speed | type of connection
    -----------------+-------------------
    0 - 50kbps | dial-up
    50 - 130kbps | ISDN
    130kbps - 1Mbps | DSL
    1-1.5Mbps | T1
    400MB-more | Cable
    but these figures are idealistic, and there are some
    overlaps.
    generally these figures hold only in few countries
    around the
    world... not even all US networks guarantee these
    values...
    and infact you can have variations which deviate...
    fractional-T1, HDSL, ADSL, SDSL, DSL-Lite, and to top
    it all
    the service-provider may choose to limit the
    port-speeds...
    so in short there is no very well defined way to get
    around
    this... in all the above cases except dial-up, the
    endpoint
    connectivity on the host processor is an Ethernet
    card, which
    in turn would be connected to a router... so, how can
    you say
    what technology router uses to get onto the WAN... of
    course
    without some proprietary API's that the router may
    provide,
    or some SNMP MIB's that router may support... !!!Ok ... I should have been a little more specific here, actually its not that complicated.. I just want to be able to distinguish whether the user is on a dial-up or a permanenet connection ( Modem VS T1-,DSL, Cable ) .... if I can do that much.. its fine...
    >
    and then disconnects it. what do you mean by disconnect... ??? is it
    disconnecting the
    modem, or the total LAN connectivity towards all other
    hosts
    or a particular host ??? for modem disconnection,
    JTAPI etc.
    or Java Serial port control might help... (not
    sure)... for
    others, updating the routing-table on the host (using
    JNI) or
    bringing down an ethernet-interface etc. would be
    required...so then ... the question of disconnection is applicable only in case of a modem-dial up kind of connection.. I'll look into the JTAPI or SerialPort control working.
    >
    best regards,
    banibrata dutta.
    --Thanks...any more info would be welcome !
    Regards,
    Abhijeet

Maybe you are looking for

  • Intermittent mssql4 Connection Pool Failure problems

    Ocaisionally we are getting the following error: weblogic.jdbcbase.mssqlserver4.TdsConnection.registerOutgoingPipeline(TdsConnection.java:414) at weblogic.jdbcbase.mssqlserver4.TdsConnection.registerPipeline(TdsConnection.java:430) at weblogic.jdbcba

  • Changed Adobe ID can no longer access BC live site

    Hi Having some problems with my Creative Cloud / BC site. I created a Muse site and pushed it live with my CC subscription. I then had to change my Adobe ID due to my old domain expiring (ensure I receive emails etc). Since changing the Adobe ID I ca

  • Draw image between edges in another image

    HI i try to draw an image between a specified edges in another image can any one help me and provide me with a code that perform this task

  • How do I remove the file name extension form a 'file name' cross reference?

    I have a cross reference which is refeencing another InDesign file using the cross reference format 'file name', however it includes the file extension. Is there a way to have this extension not display? Maybe a delimiter or perhaps a differnt format

  • Star schema - History

    Say I have a star-lite schema with just 2 dimension tables and 1 fact table. The classic many-to-many relationship with a resolver/intersection table. For discussion purposes, let's take the standard student/test/score tables. Student and Test are th