Dynamic LOV with two static entries

I need an additional static entry in a List of Values field.
As my first static entry I use the Null condition.
Or maybe somebody has a different idea how to accomplish the following:
I want to be able to select all the entries of a table with a certain foreign key, all entries with the "value" NULL or just all entries.
thanks

I ran into more problems but i resolved them :D
Since I want that at the first load 'all values' is selected... I needed to set :P1_SELECT to -1 when its NULL but that got me some trouble with select 'NULL Values'... thus I changed the NULL value of :P1_SELECT to -2.
This solution has also the other convenience that at top of the select box is 'all values', second entry is 'null values' and all the following are build up dynamicly
select d, r from (
select ename d, empno r from emp -- your foreign key condition
union
select 'NULL Values' d, -2 r from dual -- NULL values
union
select 'All values' d, -1 r from dual -- All data condition. Use a return value that is not in the empno domain
default: -1
In your report, create a where condtion like
WHERE (empno = :P1_SELECT AND :P1_SELECT IS NOT NULL) -- foreign key
OR (:P1_SELECT = -2 AND empno IS NULL) -- Null values
OR (:P1_SELECT = -1) -- All values

Similar Messages

  • Dynamic LOV with where conditions

    Hi all! I have a question regarding Dynamic LOVs. I have a List of values that can be used from three pages, the query is something like this:
    SELECT a.CODE CODE_DISPLAY,
    a.CODE CODE_RETURN
    FROM OREF_COUNTRIES a,
    OREF_REGIONS b
    WHERE a.REG_ID = b.ID AND
    b.CODE = :P336_LOV_REGION;
    The thing is I don't want to hardcode the name of the item ":P336_LOV_REGION" because this is the name of 1 item of one page, and I'd like to use this LOV from another two pages, so the name of the item won't be ":P336_LOV_REGION". How can I create a reusable dynamic LOV with a where condition depending on one item of the page?
    Thanks!!

    hi! anyone has any information about this?
    Daniela.

  • Problem in aligning dynamic UI with the static UI

    Hi All,
    I have problem in aligning dynamic UI with the static UI, I am using Matrix layout.
    Static fields are spread over 2 colums and 3 rows:
    lableA SPACE input field SPACESPACE lable B SPACE input field
    lableC SPACE dropdown SPACESPACElableD SPACE dropdown
    lableE SPACE dropdown SPACESPACElableF SPACE dropdown
    Now when a value is selected in C, than E becomes visible, and depending on the values selected in E, there are dynamic UI generated, i.e dynamic lables and depending on some validation it will be either a dropdowns or input fiels or both.
    at run time screen is like this:
    lableA SPACE input field SPACESPACE lable B SPACE input field
    lableC SPACE dropdown SPACESPACElableD SPACE dropdown
    lableE SPACE dropdown SPACESPACElableF SPACE dropdown
    dynaSPACEdropdown
    dynbSPACEinput field
    if I change my selection in E than layout looks like:
    lableA SPACE input field SPACESPACE lable B SPACE input field
    lableC SPACE dropdown SPACESPACElableD SPACE dropdown
    lableE SPACE dropdown SPACESPACElableF SPACE dropdown
    dynaSPACESPACEdropdown
    dynbSPACESPACEinput field
    Requirment: I need all the lables as well as dropdown/ input fiels in line with the static fields irrespective of my selection in E.
    Something like this:
    lableA SPACE input field SPACESPACE lable B SPACE input field
    lableC SPACE dropdown SPACESPACElableD SPACE dropdown
    lableE SPACE dropdown SPACESPACElableF SPACE dropdown
    dyna   SPACEdropdown
    dynbSPACESinput field
    dyncSPACESdropdown
    All this elements are in a group and that group has 2 transparent containers, 1 for static and for holding dynamic UI.
    I tried playing with the container properties, and also tried fixing width of dynamic UI but still the alignment issue is encountered.
    Can U guys plz give in ur valuable inputs as i need to fix this urgently.
    Regards,
    JJ

    Hi Armin,
    Can you please elaborate your solution ?, I do not have an idea of InvisibleElement & IWDView.resetView() ,
    If you can give me the exact pointer than it would be great and a good learning exp. for me.
    Thanks for the action assignment part, it worked.
    if (wdContext.nodeMaterialClass().size() > 0 && wdContext.currentContextElement().getActionMatCls()) {
         if (wdContext.currentMaterialClassElement().getMaterialClass_Description() != null || !wdContext.currentMaterialClassElement ().getMaterialClass_Description().equalsIgnoreCase(" ")) {
               IWDGroup Searchgroup = (IWDGroup) view.getElement("DynGroup");
    Searchgroup.destroyAllChildren();
    view.getContext().reset(false);
                                                      for (int i = 0; i < wdContext.nodeMaterialCharateristcs().size(); i++) {
                                  //this for label
         IWDLabel CharLabel = (IWDLabel) view.createElement(IWDLabel.class, "label" + i);
         CharLabel.setText(wdContext.nodeMaterialCharateristcs().getMaterialCharateristcsElementAt(i).getDescr_Char());
         CharLabel.setDesign(WDLabelDesign.EMPHASIZED);
         CharLabel.createLayoutData(MatrixHeadData.class);                              CharLabel.setWidth("154px");                              Searchgroup.addChild(CharLabel);
                 further there are conditions to create either dropdown or input field
    Can you please point where and how to apply your solution.
    Regards,
    JJ

  • Dynamic Table with two columns

    Hi!
    i have to create a Dynamic Table with two columns having 5-5 links each with some text...... three links r based on certain conditions....they r visible only if condition is true...
    if the links r not visible in this case another links take it's place & fill the cell.
    links/text is coming from database.
    i am using Struts with JSP IDE netbeans
    Please help me
    BuntyIndia

    i wanna do something like this
    <div class="box_d box_margin_right">
              <ul class="anchor-bullet">
              <c:forEach items="${data.faqList}" var="item" varStatus="status"
                        begin="0" end="${data.faqListSize/2-1}">
                        <li>${item}</li>
                   </c:forEach>
              </ul>
              </div>
              <div class="box_d">
              <ul class="anchor-bullet">
              <c:forEach items="${data.faqList}" var="item" varStatus="status"
                        begin="${data.faqListSize/2}" end="${data.faqListSize}">
                        <li>${item}</li>
                   </c:forEach>
              </ul>
              </div>
    wanna divide table in two columns....if one link got off due to condition other one take it's position...
    I have created a textorderedlist
    Bunty

  • Dynamic LOV with dates and selected default value

    Hello,
    I have a dynamic lov with dates. Query looks like this:
    select distinct concat(to_char(b.send_day_time,'YYYY.MM.DD HH24'),':00') display_value, to_char(b.send_day_time,'YYYY.MM.DD HH24') return_value
    from ...
    No I want to select a specific date as the default value. I put the following code for the default value:
    declare
    begin
    return to_char ('2008.02.19 10:00');
    end;
    But it doesn't work.The date (string) exists in the lov but it is not selected.
    Can someone tell me where the problem is?
    Thx in advance.
    Greetings,
    hamburger

    Hi hamburger,
    As return value you specified to_char(b.send_day_time,'YYYY.MM.DD HH24'),
    so your default value should be like to_char('2008.02.19 10'). Also pay attention to select the "Default Value Type".
    Hope this helps.
    chrissy

  • Report module: LOV with two columns

    I would like to create a LOV with two columns in a designer generated report module.
    scott@ntw>select deptno, loc
      2  from dept;
        DEPTNO LOC
            10 NEW YORK
            20 DALLAS
            30 CHICAGO
            40 BOSTON
            50 LAS VEGASIs it possible to create the lov of the report module with an indivdual select statement?
    Does anyobody have an idea?

    Hi,
    There are probably a number of ways that you can handle this, but the underlying principle for all of these would be that you need to have 2 reports. The first report would contain the first ten records and the second report would contain the next ten.
    The way to do that would be to get the ROW_NUMBER() value for each line and, in the query defintion for each report, you would have a WHERE clause that restricted the results based on this value. The best way to do this would be to create a view and base the reports on this view. The view definition would include:
    ROW_NUMBER() OVER (ORDER BY xxxx) AS ROW_NUMBER
    where xxxx is the same order definition as the main ORDER BY clause. Each row will then get a ROW_NUMBER value that matches it's position in the query resultset.
    Your first report would then have a WHERE clause of:
    WHERE ROW_NUMBER < 11
    the second report would have:
    WHERE ROW_NUMBER BETWEEN 11 AND 20
    The final step would be styling/positioning the reports. The first would probably be in Column 1 in the region and the second in Column 2. You would almost certainly have to adjust the styling and/or positioning using a style attribute in the region/report definitions.
    Regards
    Andy

  • Error in Dynamic LOV with Bind Variable

    Hi
    I created 2 Dynamic LOV's in which Second one is with a Bind Variable.Then I creted a Form and Attached the LOV's to the form fields.But I am getting the below mentioned error when i choose a value in the First LOV and the Second LOV is not Populated. I tried the same thing with the scott.dept and scott.emp table which is working fine.but when i try the same on my tables it is throwing me error.
    Can Anyone Suggest me what is the problem of these LOVs
    FYI
    1)I am writing SELECT on Views in the LOVs and the views are created on tables of a different of database.
    2)Below Mentioned LINK_TIT is my DB Link.
    Error Message:
    An unexpected error occurred: ORA-01722: invalid number
    ORA-02063: preceding line from LINK_TIT (WWV-16016)
    Error displaying form : ORA-01722: invalid number
    ORA-02063: preceding line from LINK_TIT (WWV-16408)
    Error displaying block : ORA-01722: invalid number
    ORA-02063: preceding line from LINK_TIT (WWV-16406)
    Error displaying item : ORA-01722: invalid number
    ORA-02063: preceding line from LINK_TIT (WWV-16404)
    Error ORA-01722: invalid number
    ORA-02063: preceding line from LINK_TIT, displaying DUMMY_FRM_BLEND.DEFAULT.SKU5ID.01, combobox (WWV-16405)
    The preference path does not exist: ORACLE.WEBVIEW.PARAMETERS.16172911255 (WWC-51000)

    Hi Everyone,
    This was a known Issue in Oracle 9i AS Portal.I referred to the
    metalink note ID 174116.1 which talks about the BUG No:1584284.and it gives some workaround to come across the BUG.
    I got my dependent LOV work after changing the NUMBER datatype in the Procedure to VARCHAR2.(Then in the PL i converted the character to number by the SQL function.)
    Regds
    Rajesh Kanna.V

  • Dynamic Select Query including Dynamic Tables with For all Entries

    Hello everyone,
    I need to create a select query which involves using of Dynamic Tables.
    Suppose I have a dynamic table <d1> which consist of let say 10 records.
    Now i need to make a select query putting data into another dynamic table <d2>
    CONCATENATE keyfield '=' '<d1>' INTO g_condition SEPARATED BY space.
    CONCATENATE g_condition '-' keyfield INTO g_condition.
    SELECT * FROM (wa_all_tables-name) INTO CORRESPONDING FIELDS OF TABLE <d1>
            FOR ALL ENTRIES IN <d1>
    WHERE (g_condition).
    But it is giving dump.
    Please help me on this....

    Short text
        A condition specified at runtime has an unexpected format.
    What happened?
        Error in the ABAP Application Program
        The current ABAP program "ZNG_CUSTOMWRITE" had to be terminated because it has
        come across a statement that unfortunately cannot be executed.
    Error analysis
        An exception occurred that is explained in detail below.
        The exception, which is assigned to class 'CX_SY_DYNAMIC_OSQL_SEMANTICS', was
         not caught in
        procedure "WRITE_ARCHIVE_PROD" "(FORM)", nor was it propagated by a RAISING
         clause.
        Since the caller of the procedure could not have anticipated that the
        exception would occur, the current program is terminated.
        The reason for the exception is:
        The current ABAP program has tried to execute an Open SQL statement
        which contains a WHERE, ON or HAVING condition with a dynamic part.
        The part of the WHERE, ON or HAVING condition specified at runtime in
        a field or an internal table, contains the invalid value "ZCOURIER-ZCOURIERID".
    CONCATENATE keyfield '=' g_header INTO g_condition SEPARATED BY space.
    CONCATENATE g_condition '-' keyfield INTO g_condition.
    SELECT * FROM (wa_all_tables-name) INTO CORRESPONDING FIELDS OF TABLE <dyn_table1>
    FOR ALL ENTRIES IN <dyn_table>
      WHERE (g_condition).

  • Dynamic SELECT with FOR ALL ENTRIES IN: take 2

    Hello Xperts,
    we are now having a bit of new trouble with the following SELECT ... special thanks to Raul and Suhas for their previous contributions.
    FIELD-SYMBOLS:
            <itab1>      TYPE standard table.
      ASSIGN ATTR_T_I->* TO <itab1>.
        select
          FIELD1
          FIELD2
        from DBTAB1
        into CORRESPONDING FIELDS OF table <itab1>
        FOR ALL ENTRIES IN <itab1>
        where
           (condition).
    ATTR_T_I is a static attibute of type table containing 10 records where all records have FIELD1 and FIELD2 empty.
    The select finds in DBTAB1 entries fulfilling the 'condition' for 8 of the above 10 records in ATTR_T_I.
    Hence, after the select 8 of the 10 records in ATTR_T_I have the fields FIELD1 and FIELD2 filled (ie not empty).
    So far so good!
    BUT: the 2 remaining records (i.e. those without entries in DBTAB1 fullfilling 'condition') have been deleted! Why? This is not what we want nor expected.
    Any ideas out there how to fix this?
    Thanx!

    Martin Helmstein wrote:
    > Yes, 'condition' contains all the key fields of DBTAB1.
    Hi Martin,
    It's not the Where condition fields i was talking about. I was referring to the Select fields, you have to SELECT all the keyfields when using FAE. Something like this:
    SELECT key1 key2 ... keyn "all the key fields of the table
    field1 field2 ... fieldn
    FROM table
    INTO CORRESPONDING FIELDS OF it_data
    FOR ALL ENTRIES IN <itab>
    WHERE (condition).
    You can search in the forums for further details. It has been discussed many a times.
    BR,
    Suhas

  • Dynamic SELECT with FOR ALL ENTRIES IN

    Hello Xperts,
    we are having a bit of trouble with the following SELECT
    FIELD-SYMBOLS:
            <itab1>      TYPE standard table.
      ASSIGN ATTR_T_I->* TO <itab1>.
        select
          FIELD1
          FIELD2
        from DBTAB1
        into CORRESPONDING FIELDS OF table <itab1>
        FOR ALL ENTRIES IN <itab1>
        where
          FIELD3     =   <itab1>-FIELD3    and
          FIELD4     =   <itab1>-FIELD4
    ATTR_T_I is a static attibute of type table.
    The syntax check throws the following message:
    The specified type has no structure and therefore no component  called FIELD3.
    Any ideas out there how to solve this issue?
    Thanx!

    Hi Martin,
    Change your code like this and try.
    DATA: itab2 TYPE TABLE OF string.
    FIELD-SYMBOLS:
            <itab1>      TYPE standard table.
      ASSIGN ATTR_T_I->* TO <itab1>.
    APPEND 'FIELD3     =   <itab1>-FIELD3    and' TO itab2.
    APPEND 'FIELD4     =   <itab1>-FIELD4' TO itab2.
        select
          FIELD1
          FIELD2
        from DBTAB1
        into CORRESPONDING FIELDS OF table <itab1>
        FOR ALL ENTRIES IN <itab1>
        where
          (itab2)
    Regards,
    Rahul Muraleedharan.

  • I have problem with a dynamic failover with two isps

    Hello, I would like to help me with something.
    I would like to do failover on my cisco router  but the problem is that i have two isp but one of them is DSL. I meam that It learns gateway for dhcp and this is my main gateway.
    I tried to do the same thing but I can´t put track in this command "ip route 0.0.0.0 0.0.0.0 dhcp.."
    I also use "ip dhcp-client default-route 25" but It didn´t work..
    could you help me ? please
    I upload a file with configuration that i actually have it. In this file I don´t have any configuration about failover because i tried many option but i haven´t found any solution

    I did this but on router didn´t change deafult route.
    This is the configuration that i tried:
    Current configuration : 9940 bytes
    ! Last configuration change at 22:10:41 UTC Fri Aug 29 2014 by Conssa
    version 15.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname RT_Conssaccs
    boot-start-marker
    boot system flash:c890-universalk9-mz.153-3.M2.bin
    boot-end-marker
    aqm-register-fnf
    logging buffered 51200 warnings
    enable secret 5 $1$RK//$OFh6Dnk96LlX1VFKQwsme.
    aaa new-model
    aaa authentication login default enable
    aaa authentication login consola local
    aaa authentication login vty line
    aaa authentication login userauthen local
    aaa authorization network EZAUTHR local
    aaa session-id common
    crypto pki trustpoint TP-self-signed-4275920401
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-4275920401
     revocation-check none
     rsakeypair TP-self-signed-4275920401
    ip dhcp ping timeout 100
    ip dhcp update dns
    ip dhcp-client default-router distance 100
    ip cef
    no ipv6 cef
    multilink bundle-name authenticated
    license udi pid CISCO891-K9 sn FTX145104B5
    object-group network conssaremoto
     description vpnremoto
     range
    object-group network pruebasael
     description vpnremoto
     range
    redundancy
    track 1 ip sla 1 reachability
    no ip ftp passive
    crypto isakmp policy 10
     encr 3des
     authentication pre-share
     group 5
     lifetime 180
    crypto isakmp policy 20
     encr 3des
     hash md5
     authentication pre-share
     group 2
     lifetime 28800
    crypto isakmp key cisco address
    crypto isakmp keepalive 10 4
    crypto isakmp client configuration group conssa
     key vpnbna
     pool conssaVPN
     acl 121
     mode transport
    crypto ipsec transform-set TSET esp-3des esp-md5-hmac
     mode tunnel
    crypto ipsec profile CiscoCP_Profile1
     set transform-set ESP-3DES-SHA
     set pfs group5
    crypto ipsec profile EZPROFILE
     set transform-set TSET
    interface Tunnel0
     description VPNConssaCCs
     bandwidth 1000
     ip address
     ip mask-reply
     ip mtu
     ip nhrp authentication DMVPN_NW
     ip nhrp map multicast
     ip nhrp map
     ip nhrp network-id 100000
     ip nhrp holdtime 360
     ip nhrp nhs
     ip nhrp registration no-unique
     ip nhrp registration timeout 30
     ip tcp adjust-mss 1360
     delay 1000
     tunnel source GigabitEthernet0
     tunnel destination
     tunnel key 100000
     tunnel protection ipsec profile CiscoCP_Profile1
    interface FastEthernet0
     no ip address
    interface FastEthernet1
     no ip address
    interface FastEthernet2
     switchport access vlan 2
     no ip address
     shutdown
    interface FastEthernet3
     no ip address
    interface FastEthernet4
     no ip address
    interface FastEthernet5
     no ip address
    interface FastEthernet6
     no ip address
    interface FastEthernet7
     no ip address
    interface FastEthernet8
     description $ETH-WAN$
     no ip address
     shutdown
     duplex auto
     speed auto
    interface Virtual-Template1 type tunnel
     ip unnumbered Vlan1
     tunnel mode ipsec ipv4
     tunnel protection ipsec profile EZPROFILE
    interface GigabitEthernet0
     description $ETH-WAN$
     ip dhcp client route track 1
     ip ddns update hostname
     ip ddns update noip
     ip address dhcp
     ip nat outside
     ip virtual-reassembly in
     duplex auto
     speed auto
    interface Vlan1
     description $ETH-LAN$
     ip address
     ip nat inside
     ip virtual-reassembly in
     ip tcp adjust-mss 1452
    interface Vlan2
     no ip address
     shutdown
    interface Async1
     no ip address
     encapsulation slip
    ip local policy route-map prueba
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http client username conssa
    ip nat inside source list 1 interface GigabitEthernet0 overload
    ip route 0.0.0.0 0.0.0.0 10.10.6.1 200
    ip sla auto discovery
    ip sla 1
     icmp-echo 8.8.8.8 source-interface GigabitEthernet0
     frequency 5
    ip sla schedule 1 life forever start-time now
    no logging trap
    no cdp run
    route-map prueba permit 10
     match ip address 101
     set ip next-hop dynamic dhcp
    access-list 1 permit any
    access-list 101 permit icmp any host 8.8.8.8 echo
    sh ip route
    Gateway of last resort is 200.84.32.1 to network 0.0.0.0
    S*    0.0.0.0/0 [100/0] via 200.84.32.1
          10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks

  • Dynamic LOV with inactive row

    Hi everyone,
    I need your help on this one as I can't seems to find an intelligent solution.
    I have a select list LOV based on a table that show only active values of that table when you create an object. That works well. But now I need to display an object for modification years after (The same page display as creation). The value entered at that time is not active anymore and is not showing up in the select list. Because of that you cannot see the old value in the select list
    CREATE TABLE TYPE
         IDE           NUMBER (9) NOT NULL ,
         NAME      VARCHAR2 (50) ,
         ACTIVE     NUMBER (1)
    LOV
    select NAME display_value, IDE return_value
    from type
    WHERE active = 1
    order by 1
    My best guess is to add a given value to the LOV using application/page variable like this but I find this very ugly.
    select NAME display_value, IDE return_value
    from type
    WHERE active = 1
    OR ide = :P10_ide
    order by 1
    Do you see any other solution ?
    I would really like a better one as I need to do this 20+ times on many pages .... going to be a mess ...

    Checkout this post on my blog:
    http://simonhunt.blogspot.com/2009/02/how-to-cope-with-list-of-values-lovs.html
    It's similar to your solution and I agree that it's ugly, but I've not seen a better solution. I would be interested to know if anyone has any better ideas.
    I hope it helps
    Shunt

  • Bug or feature? - DHCP with static entries gives "wrong" DNS?

    Server 10.4.8 G4 Xserve
    Bonded interface (built-in and PCI, LACP)
    DHCP, DNS and "more" running.
    DHCP static IP entry (?) windows (and mac?) machines get their DNS IP from the server DNS setting from Network config, not from DHCP config ???
    Machines with no static entry get the DNS IP from the DHCP server setting.
    If you use 127.0.0.1 as the nameserver setting in Network config the static clients obviuosly can't lookup names. I had to use the "hostname IP" instead.

    Hi,
    I did not quiet understand what you mean. It looks completely visible for me.
    You did not set scene width and height so maybe that is reason why it was not visible.
    This code works for me:
    package playground;
    import javafx.application.Application;
    import javafx.scene.Group;
    import javafx.scene.Scene;
    import javafx.scene.control.Label;
    import javafx.scene.effect.Reflection;
    import javafx.scene.layout.BorderPane;
    import javafx.scene.text.Font;
    import javafx.stage.Stage;
    public class LayoutLabel extends Application {
        @Override
        public void start(Stage stage) throws Exception {
            stage.setTitle("Test JFX");
            stage.setScene(createScene());
            stage.setVisible(true);
        private Scene createScene() {
            Label label = new Label("Hello world!");
            label.setFont(new Font(24));
            Reflection reflection = new Reflection();
            reflection.setFraction(1.0);
            reflection.setBottomOpacity(1.0);
            reflection.setTopOffset(0.0);
            label.setEffect(reflection);
    //        Group pane = new Group();
            BorderPane pane = new BorderPane();
            pane.setCenter(label);
    //        pane.setTop(label);
    //        pane.setBottom(label);
    //        Pane pane = new StackPane();
    //        Pane pane = new FlowPane();
    //        Pane pane = new HBox();
    //        pane.getChildren().add(label);
            Scene scene = new Scene(pane, 200,200); // changes to 200 200 maybe that is reason why it does not show
            return scene;
        public static void main(String[] args) {
            Application.launch(args);
    }

  • Return statment for dynamic LOV - exception handling

    Hello All,
    Good Morning.
    Oracle 11g, apex 3.2.1
    I am having an dynamic LOV with a return statement.
    code :-
    ==========================
    declare
    owner varchar2(12) :='';
    stmt varchar2(4000) :='';
    No_Records_Exception exception ;
    phase varchar2(30);
    year varchar2(30);
    month_quarter varchar2(30);
    begin
    stmt :='select distinct famid d, famid r from '
    ||:P1_SCHEMA||'.'||'FMLY';
    return stmt;
    exception
    when No_Records_Exception then
    raise_application_error (-20998 , ' Schema does not exist ' );
    when OTHERS then
    raise_application_error (-20999,' Select the schema first ' );
    end;
    ===================
    My question is - why the exception is not handled when there are no table found.
    Am getting the following errr ..
    Error: ORA-06550: line 1, column 120: PL/SQL: ORA-00903: invalid table name ORA-06550: line 1, column 7: PL/SQL: SQL Statement ignored performing List of Values query: "select distinct famid d, famid r from .FMLY".
    Pls let me know how to handle this error.. if the table is invalid.
    scenario for poping this error:-
    ==================
    I am having three "select list with redirect" items and one radio group ( having two Radion buttons - Relation , Famid )
    The requirement is when the user selects Famid radio then the lov is suppose to populate the multiselect list with famid values from table P2D2008M05.FMLY and the schema P2D2008M05 is selected from three list items
    P2D, 2008 , M05 one from each item .
    If the schema is not selected and the user selects radio famid , then the error is coming , I need to put a validation or error handling mechanism when in which ,if the user selects famid radio and the schema is not selected , I need to raise an exception with proper error message to the user saying that the schema is not selected.
    Pls helpin this regard.
    Thanks/kumar.

    Hi,
    Your exception is for function that return select.
    Error is raised when Apex procedures try use select your function returns.
    You need test your select inside function or create validations
    Your function could look something like this
    DECLARE
      stmt    VARCHAR2(4000);
      l_count NUMBER;
    BEGIN
      IF NVL(:P1_SCHEMA,'%'||'null%') = '%'||'null%' THEN
        raise_application_error (-20999,' Select the schema first ' );
      END IF;
      SELECT COUNT(1) INTO l_count FROM all_users WHERE username = :P1_SCHEMA ;
      IF l_count = 0 THEN
        raise_application_error (-20998 , ' Schema does not exist ' );
      END IF;
      stmt :='select distinct famid d, famid r from ' ||:P1_SCHEMA ||'.' ||'FMLY';
      RETURN stmt;
    END;That is just example, I did not test it. And I think it is not good idea raise errors inside LOV function.
    You should use Apex after submit validations
    Br,Jari

  • Item Selection on a dynamic LOV (SQL Query)

    Hi,
    I've a dynamic LOV with an SQL query who return a list of data (one column). When i select a data in this LOV to be use as an item (sql query) in the same page the data is always null. In debug mode substitution string is null.
    FYI : when the data is selected, a button is clik to perform an sql query for a report in another page.
    Thanks. Sorry Abasolute beginner
    Message was edited by:
    user581765

    Thanks for Your help.
    The date is in fact a CHAR display (not really a date) so that is not the error.
    For your information when i select a row in the list (format char YYYYMMDD_HHMM) it seems that Apex do not catch my select in the Session state.
    I've change the item name with P2_DATE_FLOW but the problem remain.
    This is the debug log if can help
    0.03: Application 114, Authentication: CUSTOM2, Page Template: 3644802034190382
    0.06: ...Session ID 1868105032215374 can be used
    0.06: ...Application session: 1868105032215374, user=Neop
    0.06: ...Determine if user "Neop" workspace "2859608277950243" can develop application "114" in workspace "2859608277950243"
    0.06: Session: Fetch session header information
    0.06: ...Metadata: Fetch page attributes for application 114, page 3
    0.06: Fetch session state from database
    0.06: Branch point: BEFORE_HEADER
    0.06: Fetch application meta data
    0.08: Computation point: BEFORE_HEADER
    0.08: Processing point: BEFORE_HEADER
    0.08: Show page template header
    0.08: Computation point: AFTER_HEADER
    0.08: Processing point: AFTER_HEADER
    0.08: Computation point: BEFORE_BOX_BODY
    0.08: Processing point: BEFORE_BOX_BODY
    0.08: Region: Report 1
    Report 1
    0.08: show report
    0.09: determine column headings
    0.09: parse query as: CFM_MDRE
    0.12: binding: ":P2_DATE_FLOW"="P2_DATE_FLOW" value="0"
    0.14: print column headings
    0.14: rows loop: 15 row(s)
    No data found.

Maybe you are looking for

  • Problem showing BI report in SAP CRM 7.0

    Problem showing BI report in SAP CRM 7.0 We are facing a problem in our SAP CRM, when we show a BI report in the fact sheet we can see the report correctly. But when we click on the match code of the query, (in order to choose a value from the help)

  • Error while parsing Stored Procedure

    Hi all, i try to migrate a MS SQL Server 2000 database to Oracle 9.2 with the Migration Workbench and got into trouble with some Stored Procedures, that contain LEFT JOINS on SELECT-Statements. While parsing the following example Stored Procedure sp_

  • Issue with Adobe Air and Rosetta Stone in Mountain Lion.

    After installing Mountain Lion, I tried to open Rosetta Stone.  I was directed to update and install adobe air.  I did that, then tried to open Rosetta Stone again and it said the installation of Adobe Air was damaged.  I went to Adobe to reinstall a

  • Who's who ESS portal - How to customize the way it's displayed?

    Hi everyone, I'd like to make a structured list of fields with titles. Do you know know if it's possible to customize parts in the "output fields detail" view of the who's who. In the standard view there are two main sections, one for data from OM an

  • OBIEE Evaluate - "Essbase error : Repeated dimension in MDX query"

    Hi, I'm using OBIEE 11.1.1.6.2 BP1 on top of Essbase. I have a project dimension in Essbase with three levels - Total Project -> Project Class -> Project. I have created a new logical column in OBIEE to query two levels from project dimension, using