Dynamic nat entire group

Hello,
Is there any way to setup dynamic nat for an entire group without having to setup dynamic nat for every single network?
For example,
network a: 10.168.32.0/24
network b: 10.184.32.0/24
network c: 10.16.38.0/24
I want to setup dynamic nat for all of these subnets at one time.
Of couse I have more than 3, more like 200 of them, so I don't want to have to setup dynamic nat individually.
Thanks,
Dan.

Hi,
Well if you want to perform Dynamic PAT to different public IP addresses based on source interface for example then you could do it in the following way
object network INSIDE-PAT
host 1.1.1.1
object network DMZ-PAT
host 1.1.1.2
nat (inside,outside) after-auto source dynamic any INSIDE-PAT
nat (dmz,outside) after-auto source dynamic any DMZ-PAT
You could follow the above logic that applies to your network setup.
Ofcourse if you have only one source interface but several different networks or groups of networks that you want to use different PAT IP addresses then you would have to create the source address group for those networks
For example
object network PRODUCTION-PAT
host 1.1.1.1
object network TESTING-PAT
host 1.1.1.2
object-group network PRODUCTION-NETWORKS
network-object 10.10.0.0 255.255.0.0
network-object 10.20.0.0 255.255.0.0
object-group network TESTING-NETWORKS
network-object 10.30.0.0 255.255.0.0
network-object 10.40.0.0 255.255.0.0
nat (inside,outside) after-auto source dynamic PRODUCTION-NETWORKS PRODUCTION-PAT
nat (inside,outside) after-auto source dynamic TESTING-NETWORKS TESTING-PAT
or was it something else that you were after?
- Jouni

Similar Messages

  • Dynamic NAT ASA 8.4 Packet Tracer not working

    Hi guys,
    I've tried to ping and go to a site from 192.168.1.6 to 10.10.10.12, but it's not working. I've followed a couple dynamic NAT tutorials, but I can't figure out what I'm missing. The config is below, and I'd appreciate any help.
    Thanks!
    ASA Version 8.4(2)
    hostname ciscoasa
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.2 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 10.10.10.2 255.0.0.0
    object network inside-subnet
    subnet 192.168.1.0 255.255.255.0
    object network inside-subnet
    nat (inside,outside) dynamic interface
    telnet timeout 5
    ssh timeout 5
    dhcpd address 192.168.1.5-192.168.1.35 inside
    dhcpd auto_config outside

    Thanks guys. I'm one step closer. I can ping from 192.168.1.0 to 10.0.0.0, but I can't open a webpage. I try visiting 10.0.0.6/index.html in packet tracer and get a "Request time out" message. I tried to mirror the ACL for www, but it's not working. 
    Does anyone have a suggestion? My updated config is below.
    Thanks!
    ASA Version 8.4(2)
    hostname ciscoasa
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 10.0.0.1 255.0.0.0
    object network inside-subnet
    subnet 192.168.1.0 255.255.255.0
    object network outside-subnet
    subnet 10.0.0.0 255.0.0.0
    access-list TEST extended permit icmp any any echo-reply
    access-list TEST extended permit tcp any any eq www
    access-list http extended permit tcp any any eq www
    access-list http2 extended permit udp any any eq www
    access-group TEST in interface outside
    object network inside-subnet
    nat (inside,outside) dynamic interface
    telnet timeout 5
    ssh timeout 5
    dhcpd auto_config outside
    dhcpd address 192.168.1.5-192.168.1.35 inside
    dhcpd enable inside

  • Static/Dynamic NAT Conflict

    My static NAT configuration is somehow conflicting with my dynamic NAT configuration. Am I doing something wrong?
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    access-list 1 permit 192.168.126.0 0.0.0.255
    access-list 1 permit 10.18.0.0 0.0.255.255
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    ip nat inside source static tcp 192.168.126.4 20 xx.xx.xx.19 20 extendable
    ip nat inside source static tcp 192.168.126.5 25 xx.xx.xx.19 25 extendable
    ip nat inside source static tcp 192.168.126.5 80 xx.xx.xx.19 80 extendable
    ip nat inside source static tcp 192.168.126.5 443 xx.xx.xx.19 443 extendable
    ip nat inside source static tcp 192.168.126.7 3101 xx.xx.xx.19 3101 extendable
    ip nat inside source static tcp 192.168.126.4 3389 xx.xx.xx.19 3389 extendable
    ip nat inside source static tcp 192.168.126.7 5901 xx.xx.xx.19 5901 extendable
    ip nat inside source static tcp 192.168.126.20 25 xx.xx.xx.20 25 extendable
    ip nat inside source static tcp 192.168.126.20 80 xx.xx.xx.20 80 extendable
    interface GigabitEthernet0/0
    description Outside Interface
    ip address xx.xx.xx.18 255.255.255.248
    ip access-group Incoming in
    ip access-group Outgoing out
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat outside
    no ip mroute-cache
    duplex auto
    speed auto
    ntp disable
    no cdp enable
    hold-queue 32 in
    hold-queue 100 out

    Thanks for the help.
    I tried modifying the access list as you suggested but ran into problems. The host at 192.168.126.4 is my DNS server and the updates prevented it from forwarding queries to external DNS servers. I think I am running into problems because I dont' know general rules for configuring dynamic NAT to accomodate client PCs and static NAT to accomodate servers at the same time. From the issues I am having it seems there are general rules for dividing the two classes of hosts which I just don't know. My external interface has a .18 address which all my client PCs get NAT'ed through and then I have static NAT entries NAT'ing to .19 and .20 for internal services such as DNS, SMTP, HTTP etc. I thought that would divide the two however certain 'things' conflict, such as XBOX Live connections. If I remove my static NAT entries then I can connect to XBOX Live.

  • [Question] Dynamic NAT on 2 different networks

    Hi,
    I just want to ask if its possible to have same dynamic translation within 2 different networks like:
    interface gig 0/1
    1.1.1.1 255.255.255.0 (LAN Connection w/ DHCP enabled)
    inteface gig 0/2
    2.2.2.1 255.255.255.0 (Wireless Connection w/ DHCP enabled)
    Actually, the scenario was 1.1.1.1 is my LAN connection and 2.2.2.1 are my Wireless connection.
    Hope this merits their favorable response. Thanks.

    Hi,
    Do you mean that you want both of the said LAN networks to use Dynamic NAT/PAT towards a third interface on the ASA?
    If you simply want to use the same NAT/PAT address for 2 different networks on the ASA then you can use the following configurations as example
    These are PAT translations to a single IP address. Using a NAT Pool would change the configurations slightly.
    For ASA software 8.2 and below
    global (outside) 100 3.3.3.1
    nat (inside) 100 1.1.1.0 255.255.255.0
    nat (wireless) 100 2.2.2.0 255.255.255.0
    Where
    outside,inside and wireless = Interface "nameif" on the ASA firewall
    100 = Is just an ID number for the NAT configuration. You can use other one also
    For ASA software 8.3 and after
    object-group network PAT-SOURCE-NETWORKS
    network-object 1.1.1.0 255.255.255.0
    network-object 2.2.2.0 255.255.255.0
    nat (inside,outside) after-auto source dynamic PAT-SOURCE NETWORKS interface
    nat (wireless,outside) after-auto source dynamic PAT-SOURCE NETWORKS interface
    Where
    PAT-SOURCE-NETWORKS = Is an "object-group" where you can define the source networks for the NAT/PAT rule
    Hope this helps Please if you found the information helpfull
    Feel free to ask more if this didnt answer your question.
    - Jouni

  • Dynamic NAT on selected machines

    Hi
    What is the best way to setup dynamic NAT if I only wanted it to function on
    a group of 30 workstations.
    I was considering putting these workstations into a seperate subnet, but
    doesn't dynamic nat pick up all subnets on the private interface?
    Any Ideas?
    Thanks
    Peter H

    Peter,
    > What is the best way to setup dynamic NAT if I only wanted it to function on
    > a group of 30 workstations.
    > I was considering putting these workstations into a seperate subnet, but
    > doesn't dynamic nat pick up all subnets on the private interface?
    indeed, this won't work.
    You can use NAT for everyone, and then regulate the access with packet
    filters. It's a limitation of the Netware nat, indeed.
    Caterina
    Novell Support Connection Volunteer Sysop

  • Is there a way to reject an entire group of photos at once?

    I am going through my projects and would like to be able to reject an entire group of files at once, but when it only seems to let me apply the rating to one file at a time. Is there something I'm missing?
    thanks in advance for the help.

    I solved the problem a couple days ago. The mistake I made was that I neglected to shut Firefox down before making the changes to persdict.dat. Once I did that, everything worked as I expected it to work after bringing Firefox up again. I guess that's the equivalent of what you suggested. Thanks for your response.

  • How to configure inbound ruleset in dynamic nat.

    Hi ,
    I have a doubt on configure the inbound rules for dynamic nat. I want to allow my web server (172.16.101.115) able connect from outside with tcp/443.
    How do I configure the inbound ruleset for allow public connect to my webserver with tcp/443 in dynamic nat.
    Here I have draw a diagram and some configuration i have configure in my ASA 8.2. Please correct me if I was wrong config it. 
    Public IP: 10.10.10.28
    Private IPs:
    172.16.101.115
    172.16.101.116
    172.16.101.117
    172.16.101.118
    172.16.101.119
    172.16.101.120
    access-list Web_nat permit ip host 172.16.101.115 any
    access-list Web_nat permit ip host 172.16.101.116 any
    access-list Web_nat permit ip host 172.16.101.117 any
    access-list Web_nat permit ip host 172.16.101.118 any
    access-list Web_nat permit ip host 172.16.101.119 any
    access-list Web_nat permit ip host 172.16.101.120 any
    nat (firewall-dmz) 1 access-list Web_nat
    global (firewall-outbound) 1 10.10.10.28
    access-list fw-outbound-access permit tcp any host 10.10.10.28 eq 443 //allow outside connect to my external ip.
    access-list fw-dmz-access permit tcp any host 172.16.101.115 eq 443 //allow my translation ip connect to my webserver with tcp/443.

    Hi,
    I am not sure what you are attempting to configure here.
    But what the NAT configuration above does is do a Dynamic PAT for all the servers on the "firewall-dmz" to a single IP address towards the "firewall-outbound"
    This Dynamic translation doesnt however enable connections to be initiated from behind the "firewall-outbound" interface. When your hosting a server which needs a NAT towards the users then the NAT type has to be Static NAT or Static PAT.
    Static NAT will essentially use up one public IP address for just the single local host/server.
    Static PAT will do a Port Forward from the public IP address and public port to the local IP and local port. And this is most commonly used with environments which only public IP address is the one that the ASA holds in its WAN interface.
    A typical Static NAT configuration is this
    static (inside,outside) 1.1.1.1 10.10.10.10 netmask 255.255.255.255
    Where
    inside = is the interface behind which the host is
    outside = is the interface towards which the host is NATed
    1.1.1.1 = is the public NAT IP address for the host
    10.10.10.10 = is the local IP address of the host
    A typical Static PAT configuration is this
    static (inside,outside) tcp interface 80 10.10.10.10 80 netmask 255.255.255.255
    Where
    tcp = specifies the protocol for which the Static PAT configured
    interface = specifies that we will be using the public IP address of the destination interface "outside" as the public IP address for this single Port Forward.
    80 = first "80" specifies the public port visible to users behind the destination interface
    80 = second "80" specifies the actual local port on which the local host is listening on
    Hope this helps
    - Jouni

  • HELP!  Is there a way to change column information in iTunes such as name of artist, genre etc, other than deleting them one at a time? Such as the way you delete an entire group of songs by holding down control keys or selecting the Select All command.

    HELP!  Is there a way to change column information in iTunes such as name of artist, genre etc, other than deleting them one at a time? Such as the way you delete an entire group of songs by holding down control keys or selecting the Select All command. Thanks.

    If you select all the songs you want to change, Be it one song or an akbum, or an Artist, Or Genre, or playlist. Then Right mouse click  and Get Info. You then get a slightly different from normal Get Info box as this is the One for Multiple items.
    In there have a look at the tags and see if the one you want to changes is in there. There are a few tabs so if for example you wanted to change the Media Type from Home Movie to Movie go to the Options tab and select Movie and OK and it will change the whole selection.

  • When I send a Group message from my address book, the entire group gets listed in the "To" line. How do I get each member to receive the message individually without listing all members? Its just messy is all.

    When I send a Group message from my address book, the entire group gets listed in the "To" line. How do I get each member to receive the message individually without listing all members? Its just messy is all. Any help is greatly appreciated.

    Hey Grupo Castillo,
    Thanks for the question. You can actually configure this behavior from Mail preferences:
    1. Choose Preferences from the Mail menu.
    2. Click Composing.
    3. Deselect the checkbox for "When sending to a group, show all member addresses".
    When you send an email to the group, only the groups name will be seen.
    Mac OS X: Mail - How to Hide Address Book Group Member Names When Sending an Email
    http://support.apple.com/kb/TA21082
    Thanks,
    Matt M.

  • How to send an email to entire group

    Hi,
    I have the same question that Ram asked back on 11/15 ......
    Is there a mechanism I can use within Beehive to send an email to the entire group ?
    Thanks
    Bill
    RamRamanathan asked
    Hi,   is there a way to email all group members in Beehive Online Group/Workspace; for example, to alert them that you have uploaded some documents and they should review/respond by a certain date?

    Yes, the group has an email address by default. The group has an email address made up of the group name with "_" inserted instead of spaces with @beehiveonline.oracle.com as the domain.
    An example would be the "Acme Industries" group will have an email address of "[email protected]" - sending email to the address will forward on the message to all the members of the group.
    Phil

  • I have finally set up a group in my contacts. Can anyone please tell me how to send an email to the entire group? running Mavericks on iMac

    I have finally set up a group in my contacts. Can anyone please tell me how to send an email to the entire group? running Mavericks on iMac

    Drag the entire group into the To: field of a new message. The group is in your Address Book. You've used a name for it, like My Group. You can simply start typing "My Group" in that To: field and it should appear in a context menu.

  • How to send one email to entire group.

    Looking for reference on how to send one email to entire group.

    I think you're confused about some basic Java programming techniques.
    There are two obvious ways to do this.
    1. Call the addRecipient method in a loop.
    2. Collect all the recipients in a List, convert it to an array, and call addRecipients.

  • ASA 8.2 - Static NAT and Dynamic NAT Policy together

    Hello community,
    I have the following problem using a ASA with version 8.2.
    1) I have this segment on interface Ethernet 0/0: 192.168.1.0/24
    2) Through interface Ethernet 0/1 I will reach several servers using the same source IP, but other servers must be reached using only one IP, for example 192.168.1.70
    so, I have configured a Static NAT Rule from interface Ethernet0/0 to interface Ethernet 0/1 which NAT the source IPs to the same IPs: 192.168.1.0/24->192.168.1.0/24. Also I have configured a Dynamic NAT Policy that states when destination IP is "server list" then all the source IPs must be translated to 192.168.1.70.
    PROBLEM: when testing it...always the static wins....and Dynamic is never analyzed...Also, no priority for the NAT policy and NAT rules can be done on ASDM...what can I do? is there a way to do this on ASDM or CLI? (preferrely at ASDM)
    Thanks for your reply and help!

    Hello community,
    I have the following problem using a ASA with version 8.2.
    1) I have this segment on interface Ethernet 0/0: 192.168.1.0/24
    2) Through interface Ethernet 0/1 I will reach several servers using the same source IP, but other servers must be reached using only one IP, for example 192.168.1.70
    so, I have configured a Static NAT Rule from interface Ethernet0/0 to interface Ethernet 0/1 which NAT the source IPs to the same IPs: 192.168.1.0/24->192.168.1.0/24. Also I have configured a Dynamic NAT Policy that states when destination IP is "server list" then all the source IPs must be translated to 192.168.1.70.
    PROBLEM: when testing it...always the static wins....and Dynamic is never analyzed...Also, no priority for the NAT policy and NAT rules can be done on ASDM...what can I do? is there a way to do this on ASDM or CLI? (preferrely at ASDM)
    Thanks for your reply and help!

  • Dynamic NAT & Dynamic/TCP + Dynamic/UDP filters

    I've enabled dynamic NAT on BM38sp2a... Is it important to setup
    dynamic/tcp and dynamic/udp filters if running ipflt? What are the
    purposes of the two filters?
    Jimmy

    [email protected] wrote:
    > I've enabled dynamic NAT on BM38sp2a... Is it important to setup
    > dynamic/tcp and dynamic/udp filters if running ipflt? What are the
    > purposes of the two filters?
    >
    > Jimmy
    Please see my reply in the packet filtering forum.
    Caterina
    Novell Support Connection Volunteer Sysop

  • PcAnywhere and dynamic NAT

    I have Bordermanager 3.51 that uses dynamic NAT on the public interface
    connected to DSL with a static IP address. I have followed TID #
    10024898 " Creating filter exception for PCAnywhere".
    I have double checked settings of the filter exceptions but still cannot
    remote access a internal host using PcAnywhere v 11.0. My question is
    should I be using dynamic NAT or static nat or a static/dynamic nat
    configuration ?
    Thanks,
    Karl

    > In article <HmmFc.236$[email protected]>, wrote:
    > > . My question is
    > > should I be using dynamic NAT or static nat or a static/dynamic nat
    > > configuration ?
    > >
    > If you want inbound pcAW traffic, you have two choices when NAT is
    > involved: static NAT, or generic proxies. (Both are described in my
    > BMgr / Filtering books at the URL below).
    >
    > You will not be able to get to an internal PC with just dynamic NAT
    > enabled. There is no way to route the packets in then.
    >
    > Craig Johnson
    > Novell Support Connection SysOp
    > *** For a current patch list, tips, handy files and books on
    > BorderManager, go to http://www.craigjconsulting.com ***
    Thanks Craig for your direction. I will check out the URL
    Happy 4th !
    >

Maybe you are looking for

  • A Foot Each In Leopard & Lion - 1st few problems :

    A Foot Each In Leopard & Lion - 1st few problems : When my late `06 iMac went basically kaput, I went to booting off an external clone of it's entire 600+ gb's from an `06 MacBook . . . ( never knew so much beach-ball and force quits were possible !

  • All items needs to be entered again in Import MIRO (for customs)

    We are doing imports. Now when we have to pay customs duty, we do MIRO. For custom duty payment, i have to copy all the items (like material number and quantity) in MIRO screen which is very hectic. So is there any way / setting where all the items a

  • PageBreak with blank page at the starting page of report.

    My report has 2layouts based on parameter Iam printing each one on to the screen. First layout is working fine and when I try to run the second layout which is below the first one ,and after grand total section(which is separate frame). On the screen

  • What is staging table in BW?

    Hi Experts, Can you tell me what is staging table in BW. What does "staging" means? What is the definiction?definition? Where can i get more information about staging table ? Thanks very much for your input.

  • Help in Push Registry On S40

    i have a problem in push registry on s40 it throw the exception ClassNotFoundException : Midlet Not Found i try the Same Code In S60 it run Well The Code:::: private void Test() { try { System.out.println ("Befffforrrrrrrrrrrrr"); long x= DF.getDate(