Environment variables not passed through to player in flexunit 4.1.0-beta3

fyi, to get flexunit-4.1.0-beta3 FlexUnit4AntTasks invocation of flashplayer to not be rejected by the vncserver, i needed to modify the FlexUnitLauncher to pass through the environment variables to the command environment.
the reason this is required, i think, is the use of Runtime.exec() directly in CustomPlayerCommand -- in flexunit-4.0.0, the same function was accomplished using the ant executor, which does passthrough by default.
anyway, curious if anyone else has seen this issue, or if i'm doing something dumb.
--- flexunit/flexunit-4.1.0-beta3/flexunit-flexunit-da29198/FlexUnit4AntTasks/src/org/flexuni t/ant/launcher/FlexUnitLauncher.java    (revision 7250)
+++ flexunit/flexunit-4.1.0-beta3/flexunit-flexunit-da29198/FlexUnit4AntTasks/src/org/flexuni t/ant/launcher/FlexUnitLauncher.java    (revision 7251)
@@ -79,7 +82,13 @@
       command.setSwf(swf);
       if (runHeadless())
-         command.setEnvironment(new String[]{ "DISPLAY=:" + xvncStart.getCurrentDisplay() });
+         Map<String, String> env = System.getenv();
+         List<String> envArgs = new ArrayList<String>();
+         for (Map.Entry<String, String> entry : env.entrySet()) {
+            envArgs.add(entry.getKey() + "=" + entry.getValue());
+         }
+         envArgs.add("DISPLAY=:"+xvncStart.getCurrentDisplay());
+         command.setEnvironment(envArgs.toArray(new String[0]));
          LoggingUtil.log("Setting DISPLAY=:" + xvncStart.getCurrentDisplay());

ok. i went looking for a JIRA link somewhere around here and couldn't find it.  do you have a URL handy?
there are a couple of other things too:
you probably want trustDirectory.mkdirs() rather than mkdir() in TrustFile.java
you probably want CustomPlayerCommand.setLocalTrusted() -- my player command isn't in the machine's path, but i still want to be able to touch the trust file.  So I copied the trustFile.add() stuff from FlashPlayerCommand.launch() into CustomPlayerCommand.launch().  probably a better solution would be refactoring CustomPlayerCommand to be more like FlashPlayerCommand.
anyway, if you want patches, tell me where to put them and i'll post some.

Similar Messages

  • SQLPATH environment variable not read by Sql Developer

    Does anyone know why Sql Developer doesn't seem to read the SQLPATH environment variable? I've googled this situation quite a bit with no luck. Am frankly very confused...How can Sql Developer not have the ability to read from the SQLPATH environment variable?
    Considering all the scripts out there that have been written for Sql*Plus, with the assumption that the SQLPATH variable has been set to allow for multiple directories?
    I feel like I'm just missing something in Tools->Preferences in Sql Developer. I just can't see what it is. As a side note, my overall intention is to enable my team members to run the db build scripts from Sql Developer, rather than Sql*Plus...
    Thanks in advance.

    Hi 917092 ,
    Gary Graham wrote:
    Hi,
    The closest equivalent is Tools|Preferences|Database|Worksheet|Select default path to look for scripts, but supports only a single directory.
    This parameter takes multiple directories. For example in Windows the separation character is ";" . The chooser only allows one directory to be chosen at a time - but multiple paths can be typed in.
    SQLPATH reads the environmental variable (it may not read the windows registry setting).
    set SQLPATH=C:\Documents and Settings\THE_USER\first;C:\Documents and Settings\THE_USER\second
    @first
    (reads first.sql from C:\Documents and Settings\THE_USER\first)
    @second
    (reads second.sql from C:\Documents and Settings\THE_USER\second)
    Is that sufficient?
    If there is a bug to be logged please provide more details:
    Including:
    -OS
    -SQLPATH (environmental variable or set via preferences)
    -worksheet command
    -.sql file / reproducible test case
    -output
    -expected output
    Turloch
    SQLDeveloper Team

  • Changing environment variables not reflected in axis2.

    Hi,
    I am using axis2(1.2).And my problem is that I am trying to call two or more webservice from the same host .Let me explain.I have a web page .Its take some info to serach and also the parameter to which service to call.Suppose there are two service running (A and B).For A, need the following environment to set before calling :
    System.setProperty("javax.net.ssl.keyStore",keyStore);
    System.setProperty("javax.net.ssl.keyStorePassword", keyPwd);
    System.setProperty("javax.net.ssl.keyStoreType",keyType);
    System.setProperty("javax.net.ssl.trustStoreType",trustType);
    System.setProperty("javax.net.ssl.trustStore",trustStore);
    System.setProperty("javax.net.ssl.trustStorePassword",trustPwd);And for B do not required any environment variable.
    When I try to connect the B(clear all the environment) after accessing the A its throw the following exception :
    org.apache.axis2.AxisFault: sun.security.validator.ValidatorException:
    PKIX path building failed:
    sun.security.provider.certpath.SunCertPathBuilderException: unable to find
    valid certification path to requested targetBut if I restart the webserver and try to call B its working but if I try to access A its failed.
    So its seem to me that once the environment is set its not possible to reset it.
    So is there any solution.
    Thanks & Regrads

    i haven't used axis2 specifically, but i would imagine that it provides a way to configure that connection information for a specific webservice connection (as opposed to globally for the jvm). a quick google for "axis 2 custom keystore" found this link: http://shivendra-tripathi.blogspot.com/2010/11/enabling-ssl-for-axis2-service-and.html which shows how to configured an axis2 client with a custom keystore ("Approach 2", at the very end of the article). actually, looking again at that article, it may be configuring a system-wide setting (the Protocol.registerProtocol() call looks to be static). this looks better: http://wso2.org/library/1646 .
    Edited by: jtahlborn on Jul 11, 2011 2:06 PM

  • Hierarchy variable not passed over to universe

    Hierarchy variable is not passed to the universe from the query, note 1007048 is not applicable to our system.
    Any ideas on what other config to check and change ?

    Hi,
    - does the query work without any issues in transaction RSRT ?
    - do you see the variable as filter in the Universe ?
    Ingo

  • GRE traffic can not pass through LRT224 IPSec Tunnel

    Hi,
    We have a trouble when using Cisco Router GRE tunnel plus LRT224 IPSec Gateway-Gateway Tunnel.
    We found after reboot, GRE packets can not pass trough LRT224 IPSec tunnel. need to restart serval time then gre will back to normal.
    Besides that, GRE keepalive packets can not pass trough LRT224 IPSec Tunnel.
    please help. I had tried to upgrade to latest firmware version.
    Firmware Version : v1.0.3.09 (Dec 26 2014 14:28:46) 
    A-END:
    interface Tunnel1
    ip address 10.216.80.105 255.255.255.252
    ip mtu 1400
    ip nat outside
    ip virtual-reassembly in
    ip tcp adjust-mss 1360
    ip ospf network point-to-point
    ip ospf hello-interval 3
    ip ospf cost 10000
    tunnel source 10.216.81.2
    tunnel destination 10.216.80.90
    end
    B-END:
    interface Tunnel11
    ip address 10.216.80.110 255.255.255.252
    ip mtu 1400
    ip tcp adjust-mss 1360
    ip ospf network point-to-point
    ip ospf cost 10000
    ip ospf hello-interval 3
    tunnel source 10.216.80.91
    tunnel destination 10.216.81.3
    end
    CISCO2911 <> LRT224 <> INTERNET <> LRT224 <> CISCO 2621
    San

    Can you post the results from the below command for the Cisco Routers?
    IOS Command: "sh version"
    Why not static route without NAT through the LRT224 IPSec VPN?
    Just curious why did you use LRT224's for the Site to Site VPN instead of the Cisco Routers?
    Please remember to Kudo those that help you.
    Linksys
    Communities Technical Support

  • Guest LAN and DHCP Options not passing through

    Managed to get the Guest LAN up and running for wired clients and all's working well.  Users are sat behind a proxy and if I force the use of a appropriate wpad file I can get the WLC auth to happen and then push off to the proxy.
    I'm trying to use option 252 in DHCP to present the WPAD url.  Only issue that happens is that while the DHCP server on the egress interface is handing out addresses to clients on the ingress interface correctly, the WLC doesn't appear to be handing through the option 252 I have set in DHCP.  I've used network monitor to see what the dhcp request process is dishing out in terms of options, and all look good if I'm not behind the WLC.
    Anyone know if theres a limitation on the WLC that prevents DHCP options being passed through to the guest LAN?
    TIA

    When configured as a DHCP server, some of the firewalls do not support DHCP requests from a relay agent. The WLC is a relay agent for the client. The firewall configured as a DHCP server ignores these requests. Clients must be directly connected to the firewall and cannot send requests through another relay agent or router. The firewall can work as a simple DHCP server for internal hosts that are directly connected to it. This allows the firewall to maintain its table based on the MAC addresses that are directly connected and that it can see. This is why an attempt to assign addresses from a DHCP relay are not available and the packets are discarded. PIX Firewall has this limitation.
    For more information please refer to the link-http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a008070ba8f.shtml

  • Win7 11g  -- Environment variables not set?

    I have an 11g installation on a school harddrive that doesn't seem to have any of the environment variables set properly. Even ORACLE_HOME is not set. How can I fix that situation and how many environment variables need to be defined?
    Also some of the Oracle scripts seem to use the forward-slash rather than the back-slash for paths. Will Win7 care?
    Thanks

    >
    I have an 11g installation on a school harddrive that doesn't seem to have any of the environment variables set properly. Even ORACLE_HOME is not set. How can I fix that situation and how many environment variables need to be defined?
    >
    You can set the following 3 basic environment variable in your system variables list. So that you can connect to database with out manually specifying the variables every time.
    ORACLE_HOME: the ORACLE_HOME variable should be set.
    ORACLE_SID: it is the name of the instance.
    PATH=$ORACLE_HOME/bin : this is the place where your oracle binaries exists.
    >
    Also some of the Oracle scripts seem to use the forward-slash rather than the back-slash for paths. Will Win7 care?
    >
    Windows server uses back-slash
    Unix flavours use forward-slash

  • Ora-7217 sltln environ variable not set..

    Here's the story..
    Oracle 8.1.7 on RHat 6.2..
    Installation unbelievably perfect!!!
    no core dump in any programs like sqlpus, svrmgrl..but..
    trying to start with svrmgrl..connect internal or thru sqlplus as sysdba
    ora-7217--sltln environment var not set
    keeps coming..made sure all the vars are
    set in .profile..any clue what's happening?
    vinny.

    A way to set environment variables to binaries is to specify
    it on the command line. For example:
    LD_LIBRARY_PATH=/usr/mylibs httpd
    If you are using apache, it could be changed in the /etc/init.d/apache
    script.
    If you use a script to startup the server, you can use the same approach.
    I am not sure about the obj.conf file.
    Sun - DTS

  • Changing Environment Variables (not jre path)

    I am writing a setup program which will modify an Environment Variables. I need to add the string ";%PROGRAM_HOME%bin"to the Path variable. The problem lies in appending the new string onto the old one. For instance, say that
    Path=%SystemRoot%\system32;andSystemRoot=C:\WINDOWSIf I get the current Path variable (so I can append to it) I get Path=C:\WINDOWS\system32After appending my new variable I getPath=C:\WINDOWS\system32;%PROGRAM_HOME%\binWhile this will work, problems will arise in the future if changes are made to the SystemRoot variable, since the Path value no longer contains a link to the SystemRoot variable.
    Basically, is there a way to append to Environmental Variables?

    I am writing a setup program which will modify an
    Environment Variables. I need to add the string
    ";%PROGRAM_HOME%bin"to the Path
    variable. The problem lies in appending the new
    string onto the old one. For instance, say that
    Path=%SystemRoot%\system32;andSystemRoot=C:\WINDOWSIf I get the current Path variable (so I can append
    to it) I get Path=C:\WINDOWS\system32After appending my new variable I
    getPath=C:\WINDOWS\system32;%PROGRAM_HOME%\bin[/
    code]
    While this will *work,* problems will arise in the
    future if changes are made to the SystemRoot
    variable, since the Path value no longer contains a
    link to the SystemRoot variable. 
    Basically, is there a way to append to Environmental
    Variables?set PATH=%PROGRAM_HOME%\bin;%PATH%
    (T)

  • Pass Through Theme Still Not "Passing Through"

    So I'm working on this project and it looks completely AWESOME on my computer with the "pass through" theme, but when I burn it to DVD I just get a blurry picture behind a "white" scrolling title. I know this has been addressed before and I've checked out all the "fixes" so far on this issue from past topics but I'm still pulling my hair out.
    I've tried "deleting my preferences" and "repairing my permissions" but still end up with the same thing... a white scrolling text over a blurry picture. My Mac is only 2 months old!
    Perhaps the solution is to just fly my family out to watch the dvd on my computer???
    Help! Anyone? Bueller?

    Nevermind!
    I went back to an awesome answer by Rich839 who suggested the following:
    +Sometimes permissions and preferences can get corrupted. Whenever iDVD starts acting funny, a common maintenance procedure is to do the following: Delete preferences by closing iDVD and trashing the file com.apple.iDVD.plist found in User (the House icon)/Library/Preferences. Then do a permissions repair using the Utilities/Disk Utility App on your Mac. Open the Disk Utilities window and select the Mac hard drive icon at the top of the side pane at the left. Then click on the Repair Permissions button. When you have repaired permissions and deleted preferences, restart your computer and launch iDVD. iDVD will replace the .plist file that you deleted. Be sure also that you have sufficient free disk space on your hard drive for iDVD to function correctly. 25GB often is recommended by users of this forum. After doing all of the above, relaunch iDVD and see whether you still have the problem.+
    I failed to restart my computer after deleting and repairing, but after I did the above seemed to work! *crosses fingers* At least the "Pass Through" feature seems to be working in the little preview window while it's burning. Before, the scrolling text in the preview window was just white!
    Hope this somehow helps others who've had the same issue!

  • Session variable not passing between pages

    Hi, I've got a form that calculates checkbox values and puts them in a total field called txtTotal. When the user clicks send, I need to pass the total to a payment page.  The form page has PHP
    session_start();
    $_SESSION['sessTotal'] = $_POST['txtTotal'];
    and the payment page has
    session_start(); at the top of the page and <?php echo $_SESSION['sessTotal']; ?> where I want the total to display. The total does not carry over to the payment page and I can't work out why.
    Here is all the PHP from the form page as I'm pretty new to PHP and not sure if there's a conflict (should session_start appear more than once?)  Thanks guys
    <?php require_once('Connections/df.php'); ?>
    <?php
    //initialize the session
    if (!isset($_SESSION)) {
    session_start();
    $_SESSION['sessTotal'] = $_POST['txtTotal'];
    // ** Logout the current user. **
    $logoutAction = $_SERVER['PHP_SELF']."?doLogout=true";
    if ((isset($_SERVER['QUERY_STRING'])) && ($_SERVER['QUERY_STRING'] != "")){
      $logoutAction .="&". htmlentities($_SERVER['QUERY_STRING']);
    if ((isset($_GET['doLogout'])) &&($_GET['doLogout']=="true")){
      //to fully log out a visitor we need to clear the session varialbles
      $_SESSION['MM_Username'] = NULL;
      $_SESSION['MM_UserGroup'] = NULL;
      $_SESSION['PrevUrl'] = NULL;
      unset($_SESSION['MM_Username']);
      unset($_SESSION['MM_UserGroup']);
      unset($_SESSION['PrevUrl']);
      $logoutGoTo = "index.php";
      if ($logoutGoTo) {
        header("Location: $logoutGoTo");
        exit;
    ?>
    <?php
    if (!isset($_SESSION)) {
      session_start();
    $MM_authorizedUsers = "";
    $MM_donotCheckaccess = "true";
    // *** Restrict Access To Page: Grant or deny access to this page
    function isAuthorized($strUsers, $strGroups, $UserName, $UserGroup) {
      // For security, start by assuming the visitor is NOT authorized.
      $isValid = False;
      // When a visitor has logged into this site, the Session variable MM_Username set equal to their username.
      // Therefore, we know that a user is NOT logged in if that Session variable is blank.
      if (!empty($UserName)) {
        // Besides being logged in, you may restrict access to only certain users based on an ID established when they login.
        // Parse the strings into arrays.
        $arrUsers = Explode(",", $strUsers);
        $arrGroups = Explode(",", $strGroups);
        if (in_array($UserName, $arrUsers)) {
          $isValid = true;
        // Or, you may restrict access to only certain users based on their username.
        if (in_array($UserGroup, $arrGroups)) {
          $isValid = true;
        if (($strUsers == "") && true) {
          $isValid = true;
      return $isValid;
    $MM_restrictGoTo = "index.php";
    if (!((isset($_SESSION['MM_Username'])) && (isAuthorized("",$MM_authorizedUsers, $_SESSION['MM_Username'], $_SESSION['MM_UserGroup'])))) {  
      $MM_qsChar = "?";
      $MM_referrer = $_SERVER['PHP_SELF'];
      if (strpos($MM_restrictGoTo, "?")) $MM_qsChar = "&";
      if (isset($_SERVER['QUERY_STRING']) && strlen($_SERVER['QUERY_STRING']) > 0)
      $MM_referrer .= "?" . $_SERVER['QUERY_STRING'];
      $MM_restrictGoTo = $MM_restrictGoTo. $MM_qsChar . "accesscheck=" . urlencode($MM_referrer);
      header("Location: ". $MM_restrictGoTo);
      exit;
    ?>
    <?php
    if (!function_exists("GetSQLValueString")) {
    function GetSQLValueString($theValue, $theType, $theDefinedValue = "", $theNotDefinedValue = "")
      if (PHP_VERSION < 6) {
        $theValue = get_magic_quotes_gpc() ? stripslashes($theValue) : $theValue;
      $theValue = function_exists("mysql_real_escape_string") ? mysql_real_escape_string($theValue) : mysql_escape_string($theValue);
      switch ($theType) {
        case "text":
          $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
          break;   
        case "long":
        case "int":
          $theValue = ($theValue != "") ? intval($theValue) : "NULL";
          break;
        case "double":
          $theValue = ($theValue != "") ? doubleval($theValue) : "NULL";
          break;
        case "date":
          $theValue = ($theValue != "") ? "'" . $theValue . "'" : "NULL";
          break;
        case "defined":
          $theValue = ($theValue != "") ? $theDefinedValue : $theNotDefinedValue;
          break;
      return $theValue;
    $colname_userDets = "-1";
    if (isset($_SESSION['MM_Username'])) {
      $colname_userDets = $_SESSION['MM_Username'];
    mysql_select_db($database_df, $df);
    $query_userDets = sprintf("SELECT usersId, userName, password, name FROM users WHERE userName = %s", GetSQLValueString($colname_userDets, "text"));
    $userDets = mysql_query($query_userDets, $df) or die(mysql_error());
    $row_userDets = mysql_fetch_assoc($userDets);
    $totalRows_userDets = mysql_num_rows($userDets);
    ?>

    OK I got it.  I needed 
    session_start();
    $_SESSION['sessTotal'] = $_POST['txtTotal'];
    on the payments page as well, not just session_start();

  • HT4241 Audio not passing through

    I purchased my MiniDisplay port to HDMI adapter from Apple and it doesn't pass the audio through.  It doesn't make sense to me that they would sell an adapter that doesn't work like the article above describes.  Any advice?  Am I missing something?

    The adaptor almost certainly works as described.  How old is your MBP?  MBPs earlier than mid-2010 do not support audio through the mini-displayport - as described in the article you reference. If your MBP is a recent one, then option click on the speaker icon on the menu bar and check under 'Output device'.

  • CK-20W Music and Voice does not pass through Car A...

    Hi...
    I just bought a CK-20W from a store and install in the Car Audio shop, guess what I bought a new head unit in order to use the multimedia function through out the mobile phone Music Player.
    All installation is 100% follow by the instruction.
    The problem is the Music or Voice just went through the Mono Speaker, which provide with the set.
    There's Beep sound in background some like 1-2 times every 5 minute through the Car Audio System.
    However I went to two Car Audio Shop and both of them confirmed the installation is 100%. We also try to use MP3 direct into AuxIn of the head unit and it works fine.
    So I confirmed, there's nothing wrong with the installation, or the Car Audio System.
    Can somebody tell me what I did wrong or some settings might need to complete.
    Regards,
    Kawinpat W.
    EDIT : Removed E-mail Address.Message Edited by sapere_aude on 22-Oct-2007 07:23 AM
    ==============
    Kawinpat W.
    ==============

    Dear Jonphelps,
    I really appreciated for your reply.
    a) My Phone is Nokia N80 (V5.0719.0.2) 24-05-2007 RM-92
    b) My car head unit is Pioneer DEH-P7950UB
    c) My installation option is B1
    d) My CK-20W has stereo mode, tells from low beep and indicator light flashes in the rhythm of the beeps.
    When I connect MP3 direct with 3.5mm with the same cable to AuxIn of the head unit the music is fine.
    When phone paired to the CK-20W and then call my phone the head unit did not mute the MP3 audio because I disconnected the car radio mute.
    The beeps or buzz sound comes from all speakers in the car like in stereo mode. I try to disconnected the AuxIn cable from CK-20W no beeps or buzz sound at all, so it must be from the CK-20W.
    *** What I can do for now to play MP3 out of my phone is to be able to use only the supplies speaker, which the quality of the sound is not quite good. ***
    I really thank you for your kind question, I hope I'd answer all the question correctly.
    Please let me know what I should do with this because in Thailand CK-20W is quite new, and I asked NOKIA Thailand they said it must be less than 50 people who's using this.
    Thank you again,
    KawinpatMessage Edited by kawinpat on 27-Oct-200704:47 AM
    ==============
    Kawinpat W.
    ==============

  • SMF environment variables not working

    I have a Glassfish application in SMF with the following manifest file. I am trying to set the JAVA_HOME to /usr/jdk/latest.
    svccfg -s svc:/application/SUNWappserver/domain1 setenv -m stop JAVA_HOME /usr/jdk/latest
    svccfg -s svc:/application/SUNWappserver/domain1 setenv -m start JAVA_HOME /usr/jdk/latest
    svcadm refresh svc:/application/SUNWappserver/domain1:default
    # svcs -av |grep appser
    online - 12:22:51 249170 svc:/application/SUNWappserver/domain1:default
    # svccfg -s svc:/application/SUNWappserver/domain1 listprop | grep JAVA
    start/environment astring JAVA_HOME=/usr/jdk/latest
    stop/environment astring JAVA_HOME=/usr/jdk/latest
    I have a default instance and the stop/start methods are not defined inside it. After the refresh and restart, I still don't see Java using the /usr/jdk/latest JDK. Does anyone know why?
    Do those variables need to be defined inside the "default1" instance? If so, how do I do that with svccfg?
    <service_bundle type="manifest"
    name="SUNWasu appserver services">
    <service name="application/SUNWappserver/domain1"
    version="1"
    type="service">
    <single_instance/>
    <exec_method type="method"
    name="start"
    exec="/usr/local/glassfish/bin/asadmin start-domain --user admin --passwordfile /usr/local/glassfish/passfile --domaindir /usr/local/glassfish/domains domain1"
    timeout_seconds="0">
    <method_context working_directory=":default">
    <method_credential user="root"
    group=":default"/>
    <!-- privileges="basic,net_privaddr" -->
    </method_context>
    <stability value="Evolving"/>
    </exec_method>
    <exec_method type="method"
    name="stop"
    exec="/usr/local/glassfish/bin/asadmin stop-domain --domaindir /usr/local/glassfish/domains domain1"
    timeout_seconds="0">
    <method_context working_directory=":default">
    <method_credential user="root"
    group=":default"/>
    </method_context>
    <stability value="Evolving"/>
    </exec_method>
    <instance name="default" enabled="false">
    <dependency
    name='network'
    grouping='require_all'
    restart_on='none'
    type='service'>
    <service_fmri value='svc:/milestone/network:default' />
    </dependency>
    <!-- for ZFS, we need this to state this dependency -->
    <dependency
    name='filesystem-local'
    grouping='require_all'
    restart_on='none'
    type='service'>
    <service_fmri value='svc:/system/filesystem/local:default' />
    </dependency>
    </instance>
    <stability value="Evolving"/>
    <template>
    <common_name>
    <loctext xml:lang="C"> Appserver Domain Administration Server </loctext>
    </common_name>
    <documentation>
    <manpage title="Appserver" section="1" manpath="/opt/SUNWappserver/appserver/man"/>
    </documentation>
    </template>
    </service>
    </service_bundle>

    You're right....... it worked.
    The Content Server is case sensitive and the documentation is wrong......
    Thanks!

  • GetURL(varLink01, "_self"); variable not passing???

    i'm passing varLink01 from PHP to a flash file no problem (it
    loads into a dynamic text field fine).
    but when i try and load this variable to the getURL command
    the link is not working, the flash takes me to a "page not found."
    here is my code:
    DECLARE VAR
    var passed:String = varLink01;
    (different layer, same frame)
    ACTION SCRIPT
    on (release) {
    getURL(varLink01, "_self");
    i've put hours into this.... any help???
    Thanks, Joe

    i'm getting this in my Output Panel:
    "One or more breakpoints have been removed because they are
    not on valid lines of code." this is weird since the SWF file runs
    perfectly other than this issue.
    i updated my code to be sure my vars are declared and
    defined--
    var varImage01:String = "
    http://www.liquidmilitia.com/gallery2/d/2966-1/01.jpg";
    var varLink01:String = "
    http://www.yahoo.com";
    var passed:String = varImage01;
    i01load.contentPath = varImage01;
    var passed:String = varLink01;
    BUT-
    i'm using Actionscript 2.0. if i can RUN and DISPLAY the
    value of varLink01 in a dynamic text box like
    i am in the SWF file -- doesn't this confirm that the
    variable is succifiently declared and defined?
    I'm really sorry if i'm missing something here...

Maybe you are looking for

  • Video Chat

    what can't I seem to start a video chat anywhere on my Nexus.  Seems this was a well-advertised feature of this phone and now I can't seem to find any way to do it or any icon that will initiate a video chat

  • Photos blurry when upload to MobileMe

    When I upload certain photos from Aperture to MobileMe, a lot of them come out blurry! I notice that all of the blurry ones are ones I originally photographed in RAW format. Am I not saving these files correctly in Aperture?? Are the masters being up

  • Delete email addresses that are not stored contacts

    Can anyone tell me how to mass delete email addresses that are not part of my contacts? Why would the iphone store random email addresses?

  • Pre-Ordered my S4 will it be here on the 1st of June?

    Like the title says I pre-ordered my s4 pretty pumped about it and wondering if it'll be here on June 1st or will it be later.

  • I can not use FaceTime

    I open FaceTime and gets me off the page to enter your credentials. I enter the credentials , until you get to [email protected] credentials. I enter the credentials and comes out as [email protected] as verified. The interface of FaceTime is in Ital