Error: The decapsulated inner packet doesn't match the negotiated policy in the SA

I upgraded my ASA from 8.2(1) to 8.4(3) as I wanted to try to get Android devices to properly connect via VPN.
After some effort, I was able to get the Android devices to connect via VPN.  However, my syslog server has a number of errors recorded that look this this:
%ASA-4-402116: IPSEC: Received an ESP packet (SPI= 0x1E76EFA6, sequence number= 0x1F0) from x.x.x.x (user= testuser) to y.y.y.y.  The decapsulated inner packet doesn't match the negotiated policy in the SA.  The packet specifies its destination as z.z.z.z, its source as a.a.a.a, and its protocol as tcp.  The SA specifies its local proxy as y.y.y.y/255.255.255.255/udp/42246 and its remote_proxy as x.x.x.x/255.255.255.255/udp/0.
Digging further, it seems this error might be due to a NAT issues with the VPN connections.  VPN previously worked with Cisco's VPN client on Windows, though I did not test to see if that is no longer working.  However, I made no changes in the config, except for those related to additions needed to support L2TP.  With the below config, Android clients can connect to the ASA and access the internal network, but they cannot connect to external addresses.  I'm at a loss.
The addresses used in the config: 192.168.1.0/24 are on the internal LAN and 192.168.3.0/24 are addresses assigned to VPN clients.
I noted in the config this line:
access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
The access list is not referenced anywhere, though it was referenced in the 8.2(1) config like this:
nat (inside) 0 access-list inside_nat0_outbound
I'm not sure what else changed, but I've looked over the config and I just cannot see what the issue might be.  I'm hoping somebody might be able to point out my error.
Here's the config file (at least the parts that might be of interest):
: Saved
ASA Version 8.4(3)
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
boot system disk0:/asa843-k8.bin
object network obj-192.168.3.0
subnet 192.168.3.0 255.255.255.0
object network obj_any
subnet 0.0.0.0 0.0.0.0
access-list outside_access_in extended permit icmp any interface outside time-exceeded
access-list outside_access_in extended permit icmp any interface outside echo-reply
access-list outside_access_in extended permit icmp any interface outside unreachable
access-list outside_mpc extended permit ip any interface outside
access-list inside_mpc extended permit ip 192.168.1.0 255.255.255.0 any
access-list testVPN_splitTunnelAcl extended permit ip 192.168.1.0 255.255.255.0 any
access-list inside_nat0_outbound extended permit ip any 192.168.3.0 255.255.255.0
ip local pool VPN-Pool-1 192.168.3.1-192.168.3.254 mask 255.255.255.0
ip verify reverse-path interface outside
nat (inside,any) source static any any destination static obj-192.168.3.0 obj-192.168.3.0 no-proxy-arp
object network obj-192.168.3.0
nat (outside,outside) dynamic interface
object network obj_any
nat (inside,outside) dynamic interface
access-group outside_access_in in interface outside
crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
crypto ikev1 policy 5
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
crypto ikev1 policy 10
authentication pre-share
encryption aes-256
hash sha
group 2
lifetime 86400
group-policy testVPN internal
group-policy testVPN attributes
wins-server value 192.168.1.8
dns-server value 192.168.1.8 192.168.1.4
vpn-idle-timeout none
vpn-tunnel-protocol ikev1
split-tunnel-policy tunnelspecified
split-tunnel-network-list value testVPN_splitTunnelAcl
default-domain value test.us
group-policy testVPNnsl2tp internal
group-policy testVPNnsl2tp attributes
wins-server value 192.168.1.8
dns-server value 192.168.1.8 192.168.1.4
vpn-idle-timeout none
vpn-tunnel-protocol l2tp-ipsec
group-policy testVPNns internal
group-policy testVPNns attributes
wins-server value 192.168.1.8
dns-server value 192.168.1.8 192.168.1.4
vpn-idle-timeout none
vpn-tunnel-protocol ikev1
username testuser password PASSWORD encrypted privilege 15
username testuser2 password PASSWORD nt-encrypted privilege 15
tunnel-group DefaultRAGroup general-attributes
address-pool VPN-Pool-1
default-group-policy testVPNnsl2tp
tunnel-group DefaultRAGroup ipsec-attributes
ikev1 pre-shared-key *****
tunnel-group DefaultRAGroup ppp-attributes
authentication ms-chap-v2
tunnel-group testVPN type remote-access
tunnel-group testVPN general-attributes
address-pool VPN-Pool-1
default-group-policy testVPN
tunnel-group testVPN ipsec-attributes
ikev1 pre-shared-key *****
tunnel-group testVPNns type remote-access
tunnel-group testVPNns general-attributes
address-pool VPN-Pool-1
default-group-policy testVPNns
tunnel-group testVPNns ipsec-attributes
ikev1 pre-shared-key *****
tunnel-group testVPNnsl2tp type remote-access
tunnel-group testVPNnsl2tp general-attributes
address-pool VPN-Pool-1
default-group-policy testVPNnsl2tp
tunnel-group testVPNnsl2tp ipsec-attributes
ikev1 pre-shared-key *****
tunnel-group testVPNnsl2tp ppp-attributes
authentication ms-chap-v2
One last question: in order to get the connection from Android to work, I was forced to use "tunnel-group DefaultRAGroup".  Is that actually a limitation, or did I make an error that forced that requirement?  I wanted to use "tunnel-group testVPNnsl2tp".
Thanks!

Chris,
This is still a bit off the mark.  I think I might be confusing the issue by including some of the VPN configuration that I had previously installed and working (e.g., two other VPN tunnel groups with split tunneling on one of them).  Let's just remove that stuff from consideration.  I actually tested the current configs just to see if they are working since the upgrade.  testVPN is working with the split tunneling, but testVPNns (no-split tunneling) does not allow external access.  I guess there is a NAT config issue there, too, but not sure what it is, yet.  I've not investigated that closely.
I want to solve one problem at a time, though I understand there are some interdependencies.
What I'd like to focus on right now is just the L2TP VPN connection.
From what I've been able to understand from the documentation, what I need are these lines:
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP esp-aes esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-AES-128-SHA-TRANSP mode transport
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP esp-des esp-sha-hmac
crypto ipsec ikev1 transform-set ESP-3DES-SHA-TRANSP mode transport
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 10 set ikev1 transform-set ESP-AES-128-SHA-TRANSP ESP-3DES-SHA-TRANSP
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto ikev1 enable outside
group-policy testVPNnsl2tp internal
group-policy testVPNnsl2tp attributes
wins-server value 192.168.1.8
dns-server value 192.168.1.8 192.168.1.4
vpn-idle-timeout none
vpn-tunnel-protocol l2tp-ipsec
tunnel-group DefaultRAGroup general-attributes
address-pool VPN-Pool-1
default-group-policy testVPNnsl2tp
tunnel-group DefaultRAGroup ipsec-attributes
ikev1 pre-shared-key P74bmqL6rT40bl5
tunnel-group DefaultRAGroup ppp-attributes
authentication ms-chap-v2
crypto ikev1 policy 5
authentication pre-share
encryption aes
hash sha
group 2
lifetime 86400
I still want to assign the IP addresses to VPN clients out of 192.168.3.0/24.
The tricky part is understanding exactly what NAT rules to insert and to avoid that error message I'm getting relatred to the encapsulated packets.  I tried to introduce the commands you had, but it's missing stuff that I would need for L2TP/IPSec (e.g., "mode transport").  I also don't think I want "pfs group5".  The above config "works" in that I get connected -- all negotiation is done.  It's just that packets from the VPN client are not able to go out to the Internet and I'm seeing that encapsulation error messages when I try to send a packet.
Paul

Similar Messages

  • Payment error credit card doesn't match records?

    I can't update my apps. Keep getting error code saying credit card doesn't match bank records or doesn't match card on file?

    Hello Shutterbug2011,
    You may need to update your payment information.
    iTunes Store: Changing your payment information
    http://support.apple.com/kb/HT1918
    Cheers,
    Allen

  • HT1918 I'm trying to change my CC on iTunes and it gives me an error saying that the info doesn't match my banks info. But it's the same card I had on there before. Then took it off and now it won't take it again. Grrrr. Does anyone know what's up?

    I'm trying to change my CC on iTunes and it gives me an error saying that the info doesn't match my banks info. But it's the same card I had on there before. Then took it off and now it won't take it again. Grrrr. Does anyone know what's up?

    Click here and request assistance.
    (91679)

  • The app console doesn't match. It gives error -1712

    THE app console doesn't match. It gives erro -1712. The store has already changed the memory

    Try using Google's DNS instead of the one your IPS is providing.
    - To change on the iPod go to Settings>wifi and change the DNS to 8.8.8.8
    - For the computer see:
    Public DNS — Google Developers
    - Did anything happen to your router right before this started? Maybe the router is blocking the port used.

  • HT204406 hi!!!! I keep getting an "error" when trying to activate my iTunes match. I get to the 1st step, then it gets stopped, and I get the error message. HELP!!!!!!

    hi!!!! I keep getting an "error" when trying to activate my iTunes match. I get to the 1st step, then it gets stopped, and I get the error message. HELP!!!!!!

    That's definitely enough to start.
    It sure seems like it should work...and then I saw that you're using a router. It could very well be that the router is the weak link here.
    Instead connecting to your network router, try using a direct USB connection from your MBP. If that doesn't work, you read this post, which may be relevant to your problem:
    http://h30434.www3.hp.com/t5/Mac-Printing-and-Scanning/Scanning-from-Mac-10-7-fa ils-after-all-recommendations-Not-ready/td-p/1287003
    It seems you're up to date with software. Post with your results.

  • Error with calendar database: Program version 4.2 doesn't match enviroment

    hi!
    im instaling jes in a windows 2000 machine and i get this error when trying to start calendar:
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Information: Log created (1156170958)
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: Sun Java System Calendar Server 6 2005Q4 (built Dec 27 2005) csadmind starting up
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: csadmind attempting to open Counters Database
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: csadmind successfully opened the Counters Database
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: HTTP Module is refreshing
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: csadmind is refreshing
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: csadmind is refreshed
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: HTTP Module has refreshed
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: csadmind argc=1 argv[0]=C:\Sun\CalendarServer\bin\csadmind.exe
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Notice: csadmind attempting to open Calendar Database
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Error: caldb: Error with calendar database: Program version 4.2 doesn't match environment version
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Error: caldb: caldb_InitializeEnvironment: dbenv->open returned 22
    [21/Aug/2006:16:35:58 +0200] jes csadmind[1752]: General Critical: Fatal error 70: Cannot open calendar database
    anyone have faced same problem?
    thanks in advance

    Hi Vyacheslav,
    its wierd that when I run db_stat on windows, for my environment, it works.... I installed Berkeley DB XML 2.4.16 from a self extracting package.
    When I tried running from my Linux box, the error message appear... The native library on my Linux box was built from the zip package dbxml-2.4.16.zip
    Arent they the same?
    Thanks!

  • Error FFFFFFFE: FPGA Signature doesn't match

    Hi,
    I am using 5640R. When I tried to run the "ni5640R Analog Input" example, the first time would be okay, but the next time will fail with an error FFFFFFFE. The source is "private_5640_signature Register Verify.vi" and the message is "FPGA Signature doesn't match". What can I do to eliminate this error?
    Thanks very much!
    Best Regards,
    Tim Kuo

    hello Sir,
    I want to Generate the Single Side bands (LSB,USB). I got the Am Modulation output but failed in to get side bands.
    I am using PCI 5640R card, i have to check these signals on external oscillsocope.
    please guide me to get these signals.
    Thanks.

  • No error if source directory and package doesn't match

    Hello,
    I am using Sun's jdk1.5.0_09 "javac" compiler and the package name in my Test class is written as "com.hrishijoshi.asdf". This file compiles even if I put it in a directory called "com" (or anything else, as a matter of fact).
    javac doesn't throw error even if the source file's directory structure doesn't match the package name defined in that file! It creates a directory structure matching the package name (not the source tree) in the output "classes" directory.
    Is this a feature or a bug? ;-)
    - Hrishi Joshi.
    PS: Here is a log of my compilation attempt on Fedora Core 5 Linux:
    [hrishi@hrishi test]$
    [hrishi@hrishi test]$ rm -rf classes/com/
    [hrishi@hrishi test]$ cat src/com/Test.java
    package com.hrishi.asdf;
    public class Test {
    [hrishi@hrishi test]$ javac -Xlint:all -sourcepath src -d classes src/com/Test.java
    [hrishi@hrishi test]$
    [hrishi@hrishi test]$ tree classes
    classes
    `-- com
        `-- hrishi
            `-- asdf
                `-- Test.class
    3 directories, 1 file
    [hrishi@hrishi test]$ 

    There is no requirement that source code files are in the correct directory structure. If you want javac to be able to automatically compile dependent files, then the source code must be in an appropriate structure and find-able from the classpath.
    Also, when you use the -d option, javac will create an appropriate directory relative to the directory specified in the -d option. That's how it is supposed to work.
    So it is working as designed and specified.

  • 3201: The publisher display name FooBar, specified in the package doesn't match the publisher name, FooBar

    I've updated a WP 8.0 application to WP 8.1 Silverlight. When I try to deploy a demo application I get the following error;
    3201: The publisher display name, FooBar, specified in the package doesn’t match the publisher name,
    FooBar, that’s associated with the developer account.
    I've seen several cases with people encounter this issue and then solved by modifying WPAppManifest or the Packages file. My problem is that the
    display name and publisher name is exactly the same. Both in the application xml files and in the error message displayed by windows phone store. 
    Any suggestions?

    There is no requirement that source code files are in the correct directory structure. If you want javac to be able to automatically compile dependent files, then the source code must be in an appropriate structure and find-able from the classpath.
    Also, when you use the -d option, javac will create an appropriate directory relative to the directory specified in the -d option. That's how it is supposed to work.
    So it is working as designed and specified.

  • Error - The file must match the template type. Upload one file per language

    hi,
    Error - The file must match the template type. Upload one file per language and territory combination.
    i am getting above error while registering RTF template in oracle application e -business suite using XML publisher admistrator responsibility.
    My work :
    i generated xml output using concurrent program.
    for this i used standard PO report,
    the executable name: POXPRPOP.
    i designed the template using MS Office word (for RTF template)
    for this :
    <?start: body?>
    <? for-each: G_Headers?>
    VENDOR:
    <?POH_VENDOR_NAME?>
    <?POH_VENDOR_COUNTRY?>
    PURCHASEORDER NO.
    <?POH_PO_NUM?>
    SHIP TO:
    <?C_COMPANY?>
    <?POH_SHIP_ADDRESS_LINE1?>
    <?POH_SHIP_COUNTRY?>
    BILL TO:
    <?C_COMPANY?>
    <?POH_BILL_ADDRESS_LINE1?>
    <?POH_BILL_COUNTRY?>
    <?end for-each?>
    <?end body?>
    saved this file as "Purchasing.rtf" on desk top
    i registered data definition
    name:purchase order data definition.
    code : short name of concurrent program.
    i try to create template Or register the template in oracle e-business suite.
    name: purchasing template
    code: concurrent program short name
    type : RTF.
    file : browse from desk top (purchasing.rtf)
    language:english
    territory: US.
    but i am getting above error
    could any one help to come out of this problem.
    thank you
    regarding,
    sai krishna@cavaya

    Hi,
    I am getting the error as
    The file must match the template type. Upload one file per language and territory combination.
    I have checked the template name. It doesn't exist already. Please help me.
    Thanks in Advance,
    Jeganathan

  • SDK 3.0 error: profile doesn't match Application Identifier

    I'm testing my app w/ iPhone SDK 3.0 beta 5 on Xcode 3.1.3.
    Development provisioning profile under "Project-> Info -> Code Signing Identity" is grayed out & shows the error(including quote at the end):
    profile doesn't match Application Identifier "
    any ideas? The same profile has no such issue w/ SDK 2.2.1 on Xcode 3.1.
    My Bundle Identifier is of the below format :
    com.<mycompanyname>.{PRODUCT_NAME:identifier}
    I specified the "Product name" under both "Project -> Info" & "Target -> Info".. that didn't help either.
    I also noticed that there is no such problem under "Target -> Info -> Code Signing Identity"
    I'm testing to ensure compatibility of my 2.2.1 app with 3.0. I appreciate any help with this issue.. It has been a frustrating couple of days trying to resolve just this one issue which is preventing me from codesigning onto my iphone

    I was able to deploy to my iphone by following the instructions here
    http://www.loonsoft.com/posts/21
    Note: it is {} and not () ${SDKROOT}/ResourceRules.plist
    I was getting the below error during codesign & I thought that the above "graying out" of the dev provisioning profile in the "Code Signing Identity" was causing it.
    "object file format invalid or unsuitable"
    Turns out it does not prevent me from deploying to my iphone after I fixed the SDKROOT. I still have the dev provisioning profile grayed out and would be interested to know how to solve this problem "cleanly" even though it doesn't seem to have any immediate downside.. fingers crossed for distribution signing.

  • Error: parse error before '.' & number of arguments doesn't match

    Compiling my simple source code reports error error: parse error before '.' . But in fact there is not any "." token on this line.
    At my guess it has something to do with JNI C macros but I really have no idea how to find that bug
    // ##net_java_dev_jssm_MulticastSSM.h: line 55
    JNIEXPORT void JNICALL Java_net_java_dev_jssm_MulticastSSM_join2
      (JNIEnv *, jobject, jstring, jstring);
    // ##net_java_dev_jssm_MulticastSSM.c: line 306
    JNIEXPORT void JNICALL Java_net_java_dev_jssm_MulticastSSM_join2
      (JNIEnv *env, jobject obj, jstring s_addr, jstring g_addr) {
    // no code yet
    mingw32-gcc.exe -DWIN32 -Wall -c -IC:\java\JNI_headerFiles\jdk1.6.0/include -IC:\java\JNI_headerFiles\jdk1.6.0/include/win32 -shared src_c/net_java_dev_jssm_MulticastSSM.c -DNODEBUG
    src_c/net_java_dev_jssm_MulticastSSM.c:307: error: parse error before '.' token
    src_c/net_java_dev_jssm_MulticastSSM.c: In function `Java_net_java_dev_jssm_MulticastSSM_join2':
    src_c/net_java_dev_jssm_MulticastSSM.c:307: error: number of arguments doesn't match prototype
    src_c/net_java_dev_jssm_MulticastSSM.h:56: error: prototype declaration
    make: *** [all] Error 1
    C compiler: mingw32-gcc.exe
    JNI: jdk1.6.0
    Any help would be really appreciated.

    Hi radone,
    I just read your posting and suddently got an idea why your compiler was complaining about the period. In most C environment, there is a definition
    #define s_addr S_un.S_addr
    in some socket-related header file! Now you know where the dot is coming from.

  • Data Collection Set 'Server Activity' Failure Waiting on a kernel object(s) failed. Inner Error ------------------ The handle is invalid.

    All of the system data collection sets have been running for 6+ months without any issues, couple of weeks ago the 'Server Activity' collection set failed to restart after a planned maintenance server reboot.
    When attempting to manually start the collection set it indicates "success", but after refreshing the collection set it showing as stopped. Viewing the logs for the Data Collection (Server Activity) I am getting the message:
    Waiting on a kernel object(s) failed. Inner Error ------------------>
    The handle is invalid.
    After some research into this really unhelpful message I came across one posting where this error has been found to occur in SP1. We are running SP2 which include the fix so this shouldn't be the problem (ref http://connect.microsoft.com/SQLServer/feedback/details/585210/sql-server-2008-data-collection-execmasterpackage-timeout).
    To see more detail on the root cause of the error I enabled the additional tracing for data collection (http://blogs.msdn.com/b/sqlagent/archive/2011/07/13/enabling-additional-tracing-for-data-collector.aspx). This provided an exception stack which indicated
    that the issue was thrown to what looks like an existing file, referring to a location (e:\) which doesn't exist in our system.
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::    wmain _IN
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::    Command line: dcexec -c -s 2 -i "S160OLTP\OLTP" -m 0 -e 0x09C1635DD4C4C6478A145D679AFE718F_1_STOP
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Application::Init _IN
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Console code page (m_codePage): 437
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::      Application::ParseCommandLine _IN
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::      Application::ParseCommandLine _OUT:00000000
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Application::Init _OUT:00000000
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Application::Main _IN
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Started continuous mode collection on thread 12036
    DCEXEC!26d0!2f04!2012/11/28!11:17:25::      StartCachedCollectionWrapper _IN
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::      Waiting for collection to exit or stop event to be signaled
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::       StartCollection _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::       StartCollection(iSetId = 2, iCollectionMode = 0, pwszInstanceName = S160OLTP\OLTP)
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::        CDataCollectorController::ExecuteCollectionSet _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::        SQL Instance Name: OLTP
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::         CDataCollectorController::TryExecuteCollectionSetOnce _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CDataCollectorController::Initialize _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CDataCollectorController::Initialize _OUT:00000000
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CDataCollectorController::PopulateCollectorPackageParameters _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CacheWindow=1, CacheDirectory='I:\MSSQL10.OLTP\MSSQL\dccache'
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CDataCollectorController::PopulateCollectorPackageParameters _OUT:00000000
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CDataCollectorController::PopulateSetPackageParameters _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CollectionSetUID='{49268954-4FD4-4EB6-AA04-CD59D9BB5714}', ExecutionMode=0, IsSystem=-1, LoggingLevel=0, DaysUntilExpiration=14, ExitEventName=''
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CDataCollectorController::PopulateSetPackageParameters _OUT:00000000
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CreateControlEvents _IN
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25:: e        ERROR: Win32 Error: GetLastError=183, retCode=0x4, function CDataCollectorController::CreateControlEvents, line 470, file e:\sql10_katmai_t\sql\mpu\shared\dc\runtime\controller\src\datacollectorcontroller.cpp
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25:: e        ERROR: Failed to create kernel event for collection set: {49268954-4FD4-4EB6-AA04-CD59D9BB5714}. Inner Error ------------------>
    Cannot create a file when that file already exists.
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::          CreateControlEvents _OUT:00000000
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25:: e       ERROR: DC_FAILED: function CDataCollectorController::TryExecuteCollectionSetOnce, line 350, file e:\sql10_katmai_t\sql\mpu\shared\dc\runtime\controller\src\datacollectorcontroller.cpp
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::         CDataCollectorController::TryExecuteCollectionSetOnce _OUT:0x000004
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::        Collection set execution failed, retrying in 5 seconds...
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::        Waiting for exit event or retry timer failed.
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25:: e      ERROR: Win32 Error: GetLastError=6, retCode=0x4, function CDataCollectorController::ExecuteCollectionSet, line 278, file e:\sql10_katmai_t\sql\mpu\shared\dc\runtime\controller\src\datacollectorcontroller.cpp
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25:: e      ERROR: Waiting on a kernel object(s) failed. Inner Error ------------------>
    The handle is invalid.
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::        CDataCollectorController::ExecuteCollectionSet _OUT:0x000004
    DataCollectorController!26d0!2f04!2012/11/28!11:17:25::       StartCollection _OUT:00000000
    DCEXEC!26d0!2f04!2012/11/28!11:17:25::      StartCachedCollectionWrapper _OUT:0x000004
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Collection thread returned (00000001)
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Waiting for collection thread to exit
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Collection thread signaled
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::     Application::Main _OUT
    DCEXEC!26d0!1b88!2012/11/28!11:17:25::    wmain _OUT:0x000004
    I am now stumped as I haven't found anyone else experiencing this issue.
    Any ideas, please help??

    Thanks for the pointer Eileen, problem solved.
    Can't believe I missed it, but after reading the last section on system hangs it occurred to me that I hadn't checked that all dcexec.exe processes were killed when I disable the data collection service.
    For anyone else experiencing this issue I identified the dcexec.exe processes using the following in cmd line:
    TASKLIST /SVC /FI "IMAGENAME EQ DCEXEC.EXE"
    On the default setup of the data collection there should be two dcexec.exe processes constantly running, one for "Server Activity" and another for "Query Statistics". On our server there were five running with the data collection disabled.
    After killing all of the processes and restarting the data collection problem solved!!
    Still need to understand why the processes didn't shut down cleanly when the server was restarted, but at least I know where to look now.

  • The license state for the current server doesn't match the farm's license state

    I am trying to build a development Server, to mirror our Production Server. 
    I have copied the Config_Database and WSS_Content from our Production Server to a Development Server that is on a separate network. I installed SharePoint 2010 and ran the Config Wizard, entered in the database server and chose the Config_database that I
    copied over previously.
    But I receive the error:
    "The license state for the current server doesn't match the farm's license state"
    Can anyone help me with this.
    dfrancis

    Hi,
    Please have a look at links below:
    https://sharelockpoint.wordpress.com/2014/01/09/sharepoint-2013-installation-error-the-current-server-cannot-be-joined-to-this-farm/
    http://blogs.msdn.com/b/sowmyancs/archive/2012/08/08/the-license-state-for-the-current-server-doesn-t-match-the-farm-s-license-state-sharepoint-psconfig-error.aspx
    Hope it helps!
    Thanks,
    Avni Bhatt
    If this helped you resolve your issue, please mark it Answered

  • Itunes will no longer accept any of my credit cards.  Says security code doesn't match with any card I use.  I have inputted new card info in the apple store area and it still says the same thing in itunes.  Customer service is no help at all.

    Itunes will no longer accept any of my credit cards.  It says vcode doesn't match when it does.  Customer service is no help.  I have re-inputted the info in the account section of the apple store and in itunes--still says vcode doesn't match.

    Itunes will no longer accept any of my credit cards.  It says vcode doesn't match when it does.  Customer service is no help.  I have re-inputted the info in the account section of the apple store and in itunes--still says vcode doesn't match.

Maybe you are looking for

  • FM G_SET_GET_ALL_VALUES

    hey guys i have one more question to ask. i want to check whether the input parameter Business Area value exists in table or not thru FM G_SET_GET_ALL_VALUES Used code is below. parameter:p_gsber2 like bseg-gsber  obligatory. I called FM> in AT SELEC

  • How do i add something to my firewall ask me password when somebody try to exchange information from another browser

    <pre><i>Locking duplicate thread. Please continue here: [[/questions/972954]] </i></pre> Hi, I have master password add-one because i don't like any body can access to my browser since last week i don't have any problem but after that one of my frien

  • How can active portfolio feature on adobe reader X?

    Hi; we use our company adobe reader X, some user want to use protfolio feature on the reader X. I checked reader x web site said that reader x has a portfolio feature. Our users want to put a lot pdf files on the same pdf window. they wnat to open on

  • UAG External Load Balancing and ISATAP

    Hi Experts, I am deploying a UAG Array to be used for Direct Access. The Array will consist of two servers and use an F5 External Load Balancer. In addition and in similarity to 90% of the other corporate intranets out there, the internal network is

  • Network Account Unavailable

    On login window it tells me network accounts are unavailable. I can log in to local accounts and the computer is connected to our network but I just can't login to the network accounts. I repaired permissions and ran Disk Warrior to no avail. Any ide