Export map on a vrf

With the following config, does it export only the 10.2.3.3/32 route with
the 114.3.1.1:4 RT set ? Or does all routes from the vrf get exported
(because there is no set extcommunity statement below the
route-map) ?? My intention is to export only that route from the vrf..
ip vrf bv_1.135_fe.0.0.112-Hub
rd 135:5
export map bv_1.135_fe.0.0.112
route-target export 114.3.1.1:4
route-target import 114.3.1.1:5
route-map bv_1.135_fe.0.0.112 permit 1
match ip address prefix-list bv_EVpn1-bv_1.135_fe.0.0.112-Hub
ip prefix-list bv_EVpn1-bv_1.135_fe.0.0.112-Hub seq 1 permit 10.2.3.3/32
Thanks !
/bala

Martin-
The intent is this: the VRF hosts a management site and our customer wants to export only specific routes from the management hub site to the spokes....enough for them to get to the mgmt site. We had cupla options - using ACLs vs prefix-list and chose the prefix list per customer request due to perf reasons (see my last post).
I;m curious to know how you'd control this via redistribution. So under my PE-CE redistribution to my mgmt site, I'd then have to throw away 'other routes' ? I'd end up using route-map there too right ? it'd just be a different place (instead of "export map" under my "ip vrf" then it'd be under say my "router bgp" ??)
Thanks !
/bala

Similar Messages

  • Continue Statement in export map

    Hey all,
      I need a definative answer on why the following is not working:
    ip prefix-list Management seq 5 192.168.0.0/16 le 32
    route-map Exp-Map permit 5
    description Management Nets to Management Provider 1
    match ip address prefix-list Management
    set extcommunity rt  1:1 additive
    continue
    route-map Exp-Map permit 10
    description Management Nets to Management Provider 2
    match ip address prefix-list Management
    set extcommunity rt  2:2 additive
    continue
    ip vrf Customer
    rd 3:3
    export-map Exp-Map
    route-target both 3:3
    PE1#show ip bgp vpnv4 all  192.168.1.1/32
    BGP routing table entry for 3:3:192.168.1.1/32, version 22
    Paths: (1 available, best #1, no table)
    Flag: 0xA20
      Advertised to update-groups:
         1        
      64774, (Received from a RR-client)
        10.98.98.98 (metric 30) from 10.98.98.98 (10.98.98.98)
          Origin IGP, metric 0, localpref 400, valid, internal, best
          Extended Community: RT:1:1 RT:3:3
          mpls labels in/out nolabel/33
    As you can see, it is though the continue statement is not working.
    I want to be able to use varying communities to allocate an RT.
    If the continue statement does not work, then I would need to allocate a community based on every permutation possible, which is allot.
    Cheers
    Adam

    Hi Adam,
    The "continue" keyword in a route-map forces the router to look at the next route-map sequence instead of stopping in the event of a match, as per normal route-map operation.
    In your example, you are making a match in sequence 10, the continue keyord will kick in and sequence 20 will be looked at, however, since you are matching on the same sequence of that prefix-list, the extra extcommunity will not be applied that you have requested in sequence 20.
    To get around this and acheive what you are trying to do, you can add both RT's to your route-map in sequence 10:
    Configured on PE1:
    ip prefix-list TEST_LOOPS seq 5 permit 25.25.25.25/32
    route-map EXP_MAP permit 10
    match ip address prefix-list TEST_LOOPS
    set extcommunity rt  25:25 35:35 additive
    ip vrf CUST_A
    rd 1010:1
    export map EXP_MAP
    route-target export 1010:79
    route-target import 2020:79
    Output from PE2:
    AS2020_PE#sh ip bgp vpnv4 all 25.25.25.25
    BGP routing table entry for 1010:1:25.25.25.25/32, version 30
    Paths: (1 available, best #1, no table)
      Not advertised to any peer
      1010
        6.6.6.6 (metric 20) from 6.6.6.6 (6.6.6.6)
          Origin incomplete, metric 0, localpref 100, valid, internal, best
          Community: 250:1
          Extended Community: RT:25:25 RT:35:35 RT:1010:79
            OSPF DOMAIN ID:0x0005:0x000000640200 OSPF RT:0.0.0.0:5:1
            OSPF ROUTER ID:1.1.1.1:1281,
          mpls labels in/out nolabel/19
    As you can see, the router assigns the two RTs to that 1 prefix you are matching on.
    If you are going to be adding more sequences to that same prefix-list, then yes you the "continue" keywork would work fine as the next route-map sequence would be matching on the next prefix-list sequence where it hits a match:
    Configured on PE1:
    ip prefix-list TEST_LOOPS seq 5 permit 25.25.25.25/32
    ip prefix-list TEST_LOOPS seq 10 permit 35.35.35.35/32     
    route-map EXP_MAP permit 10
    match ip address prefix-list TEST_LOOPS
    set extcommunity rt  25:25 additive
    continue
    route-map EXP_MAP permit 20
    match ip address prefix-list TEST_LOOPS
    set extcommunity rt  35:35 additive
      continue
    Output from PE2:
    AS2020_PE#sh ip bgp vpnv4 all 25.25.25.25
    BGP routing table entry for 1010:1:25.25.25.25/32, version 22
    Paths: (1 available, best #1, no table)
      Not advertised to any peer
      1010
        6.6.6.6 (metric 20) from 6.6.6.6 (6.6.6.6)
          Origin incomplete, metric 0, localpref 100, valid, internal, best
          Community: 250:1
          Extended Community: RT:25:25 RT:1010:79
            OSPF DOMAIN ID:0x0005:0x000000640200 OSPF RT:0.0.0.0:5:1
            OSPF ROUTER ID:1.1.1.1:1281,
          mpls labels in/out nolabel/19
    AS2020_PE#
    AS2020_PE#sh ip bgp vpnv4 all 35.35.35.35
    BGP routing table entry for 1010:1:35.35.35.35/32, version 24
    Paths: (1 available, best #1, no table)
      Not advertised to any peer
      1010
        6.6.6.6 (metric 20) from 6.6.6.6 (6.6.6.6)
          Origin incomplete, metric 0, localpref 100, valid, internal, best
          Community: 250:1
          Extended Community: RT:35:35 RT:1010:79
            OSPF DOMAIN ID:0x0005:0x000000640200 OSPF RT:0.0.0.0:5:1
            OSPF ROUTER ID:1.1.1.1:1281,
          mpls labels in/out nolabel/18
    AS2020_PE#
    HTH
    Joe.

  • Vpnv4 prefix dynamic update on export-map changes

    Hi guys,
    I have a 76k running 12.2(33)SRE9a with this vrf configuration:
    ip vrf B
    rd 2:2
    export map RM-R3
    route-target import 2:2
    route-map RM-R3 permit 10
    match ip address prefix-list PL-R3
    set extcommunity rt 4:4  2:2  additive
    route-map RM-R3 permit 15
    set extcommunity rt 2:2
    ip prefix-list PL-R3 seq 5 permit 172.3.3.3/32
    ip prefix-list PL-R3 seq 10 permit 172.33.33.33/32
    So I expect that prefixes matching prefix-list PR-R3 will have route-target 2:2 4:4, and all other prefixes will have route-target 2:2.
    The question is: What happens if I remove this line of the prefix list?
    no ip prefix-list PL-R3 seq 10 permit 172.33.33.33/32
    Will there be any dynamic update? Do I have to clear bgp or ip routing table?
    Thanks!
    Diego.

    Hi Diego,
    I checked in IOU with SRE9a image and observed that there is no dynamic update and we need to do "clear ip bgp <as> soft out from CE side.
    Topology
    R1--ebgp--[vrf CUST-A] R3----vpnv4 ibgp -----R4
    ip vrf CUST-A
     rd 300:1
     export map RM-R3
     route-target export 300:1
     route-target import 300:1
    R3#show route-map RM-R3
    route-map RM-R3, permit, sequence 10
      Match clauses:
        ip address prefix-lists: PL-R3 
      Set clauses:
        extended community RT:300:1 RT:300:2 additive
      Policy routing matches: 0 packets, 0 bytes
    route-map RM-R3, permit, sequence 15
      Match clauses:
      Set clauses:
        extended community RT:300:2
      Policy routing matches: 0 packets, 0 bytes
    R3#show ip prefix  PL-R3
    ip prefix-list PL-R3: 1 entries
       seq 5 permit 172.16.17.0/24
       seq 10 permit 172.16.19.0/24
    R3#
    R4#show ip b vpnv4 all 172.16.19.0/24
    BGP routing table entry for 300:1:172.16.19.0/24, version 34
    Paths: (1 available, best #1, table CUST-A)
      Not advertised to any peer
      100
        3.3.3.3 (metric 11) from 3.3.3.3 (3.3.3.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
          Extended Community: RT:300:1 RT:300:2
          mpls labels in/out nolabel/36
    R4#
    R3(config)#no ip prefix-list PL-R3 seq 10 permit 172.16.19.0/24
    R3(config)#end
    after 10 min
    R4#show ip b vpnv4 all 172.16.19.0/24
    BGP routing table entry for 300:1:172.16.19.0/24, version 34
    Paths: (1 available, best #1, table CUST-A)
      Not advertised to any peer
      100
        3.3.3.3 (metric 11) from 3.3.3.3 (3.3.3.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
          Extended Community: RT:300:1 RT:300:2
          mpls labels in/out nolabel/36
    R4#
    R1#clear ip bgp 300 soft out
    R1#
    R4#show ip b vpnv4 all 172.16.19.0/24
    BGP routing table entry for 300:1:172.16.19.0/24, version 50
    Paths: (1 available, best #1, table CUST-A)
      Not advertised to any peer
      100
        3.3.3.3 (metric 11) from 3.3.3.3 (3.3.3.3)
          Origin IGP, metric 0, localpref 100, valid, internal, best
          Extended Community: RT:300:2
          mpls labels in/out nolabel/36
    R4#
    I hope it helps

  • Inter-VPN routing with export map for host routes

    Hi,
    I am trying to export host routes from a connected network from one VRF to multiple other VRFs. This is to allow the leaking specific host routes for management purposes. However, I suspect that the /32 host route(s) actually need to be present in the management VRF so the RTs are added accordingly, rather than just specified in the match clause of the MGMT VRF export map.
    Ideally here, I only want to export 10.111.111.254/32 from the connected network 10.111.111.0/24 in the MGMT VRF. The only way around this I can see it to move 10.111.111.0/24 behind another device, and add specific host route(s) within the MGMT VRF for the 10.111.111.X/32 host routes (which are redistributed into the MGMT VRF), using the additional device as the next-hop.
    ip vrf MGMT
    rd 1:1
    export map MGMT-EXPORT-MAP
    route-target export 1:1
    route-target import 1:1
    route-target import 1:1001
    ip vrf CUST-B
    rd 1:2
    export map CUSTOMERS-EXPORT-MAP
    route-target export 1:2
    route-target import 1:2
    route-target import 1:1000
    interface FastEthernet0/0.100
    encapsulation dot1Q 100
    ip vrf forwarding MGMT
    ip address 10.111.111.1 255.255.255.0
    interface FastEthernet0/0.200
    encapsulation dot1Q 101
    ip vrf forwarding CUST-B
    ip address 10.96.2.1 255.255.254.0
    router bgp 65000
    bgp router-id 1.1.1.1
    no bgp default ipv4-unicast
    bgp log-neighbor-changes
    address-family ipv4 vrf CUST-B
      redistribute connected
      no synchronization
    exit-address-family
    address-family ipv4 vrf MGMT
      redistribute connected
      no synchronization
    exit-address-family
    ip prefix-list CUSTOMERS seq 5 permit 10.96.2.0/23
    ip prefix-list ONPREMISE seq 5 permit 10.111.111.0/24
    ip prefix-list ONPREMISE seq 10 permit 10.111.111.254/32
    route-map CUSTOMERS-EXPORT-MAP permit 10
    match ip address prefix-list CUSTOMERS
    set extcommunity rt  1:1001 additive
    route-map MGMT-EXPORT-MAP permit 10
    match ip address prefix-list ONPREMISE
    set extcommunity rt  1:1000 additive
    Cheers,
    Matt

    Hi Matt
    Yes the X/32 routes needs to be present in the VRF Routing-Table and if they are to be learnt statically then the MP-iBGP config for that particular VRF address-family has to redistribute static routes as well.
    Regards
    Varma

  • How to Import exported mapping in SAP XI

    Hello
    I have a exported mapping from Integration repository file with .xim extension. How we can can import it another XI server.
    Thanks
    Chaitanya

    Hi,
    If u import any objects then ur file be .tpz extension. I m surprised how ur file extension is .xim extension.
    have u followed the same process which is mentioned below:
    1) tools->export->select->FTP/CMS-> selct whole SWCV,individual objects,namespace and finish.
    after whole process it will give the .tpz file name u need to take the file from that FTp server and u need to follow the reverse process in IR.
    Import:
    tools->import->ans go on.
    Refer the link for process.
    http://help.sap.com/saphelp_nw04/helpdata/en/a8/5e56006c17e748a68bb3843ed5aab8/frameset.htm
    Thnx
    Chirag

  • Export map to Excel dates issue

    Hi,
    I created an export map exporting several dates fields.
    the problem is that the format is not the same:
    Finish date format was: dd-mm-yy
    Finish1 date format was: mm-dd-yy
    in MSP itself I see both formats the same (dd-mm-yy)
    Please help.
    Thank you, Yuval

    Yuval,
    The version number your show for Project looks like it is not updated with SP2 and it should be. Although the version number you show for Office looks like it may be updated with SP2, you need to check. In both Project and Excel, go to File/Help. On the
    right side of the screen under find "additional version and copyright information". Click on that. If you do not see SP2 listed as part of the version number, then that application is not updated. All updates can be downloaded from: http://technet.microsoft.com/en-us/office/ee748587.
    Until you can verify that everything is updated it is pointless to guess about a problem.
    After verifying that both Project and Excel are fully updated, try exporting a new Project file into a new Excel file. Does the problem still occur?
    John

  • Export maps from PI 1.3

    Is it possible to do an export of a map that is already in PI ? If so, can you relay the details?

    Hi Ben,
    It is possible to export the maps from PI.
    In classic view of PI go to
    Monitor >                Site Maps then from the drop down click on export maps.
    Thanks,
    Roopesh

  • Exporting map to .mdl file - error mdl1427

    I get this error in the log file when I try to export a map into mdl even after the deployment is successful
    Warning: MDL1427: Cannot export selected PROJECT <ADMIN> because it does not exist in target repository.
    what is the mistake I am doing, what is target repository. Will it not be there after
    deployment

    Try clicking on the project and go to the top menu and to Design > Export > Warehouse Builder Metadata. This is the only method that works for me. You also get access to the advanced tab this way.
    Cheers,
    James

  • New import map in existing VRF

    Hello,
    On my PE, I defined a VRF. My VRF contains routes. Now, I want to create/modify a import map to filter/modify some routes. All new routes will pass through the new import map but not old ones. How can I do to reapply this route-map to all existing routes with the lowest impact ?
    I know some commands to do it, but I'm looking for the best one for a live network.
    For example, I perform following command :
    no route-target import X:Y and route-target import X:Y but I'm not sure it's the best one. It's worked.
    Rgds,
    Xavier

    doesn't seem to work.
    But actually I think it's automatic without any command. The bgp scan-time IMPORT timer seems to do the job.
    Xavier

  • Export map?

    Hi gang,
    I would like to get a high res version of my Places map with the pins in it. I can get a screen capture, but is there some way to export the map?
    Cheers!

    Thanks Larry,
    The problem is that iPhoto will only allow so many photos into a book, and I want all of the places that we have been to be part of the map. I could grab some representative photos of each place, and make a book out of that, hopefully keeping the photo count below the iPhoto maximum, but that seems like a lot of work. Too bad iPhoto can't just export the map.
    Thanks for your suggestion. I'll give it a try.
    Cheers!

  • Shiiping/Export mapping problem in SAP B1

    Hi all:
    My present client(SE) has a case of transaction where in for the case of Export they based on Sales Order they directly use to create A/R Invoice
    (Commercial) after which they send this Commercial Invoice to Exporter(agent) who further book the space and time of actual delivery from the ship yard. After confirmation of time and the export rate he used to send his Bill to us(SE) back so that we(SE) can send the material/goods at the shipyard at actual time and date of delivery.
    But while creating Commercial A/R Invoice my stock is getting reduced but in actual case it is not.
    Also while going to make an excise invoice for the same base documents SAP B1  gives error as"base document is already closed". So I acnt prepare Excise Invoice also.
    Kindly give me the soution of this mess.
    Regards
    Khushwant Singh Sansowa
    India(Mumbai)

    Hello Khushwant Singh,
    It is important to understand the Sales Order > Delivery > Invoice process in Business One.
    Though most business use the 3 step process of SO > Del > Invoice, the delivery can be an optional step in Business One.  You could create an Invoice directly from a Sales Order and SBO creates all necessary Journal entries in the Invoice transaction and closes the Sales Order.. and thats why in your case when you are creating the Invoice (commercial) from Sales Order the Sales Order gets closed and the Stock is Reduced.
    You will need determine what data is required to printed in the Commercial Invoice and at what stage you want to realise Revenue.  Based on this you can use one of the following two options:
    option 1: Customize the Sales Order template (PLD) and use it as a Commercial Invoice, Create the delivery and Excise Invoice
    option 2: Create a A/R Reserve Invoice
    option 3: Create a Draft delivery / draft Invoice and use it as a Commercial Invoice
    If you need further help on this please let me know.  Also provide me details of how you want to handle the whole process.
    Regards
    Suda

  • Exporting mapping from OWB

    Hi all,
    I want take back up of all my mappings in OWB. Can we do that in OWB ? If yes then how to do it ?
    Please help me out with this. Its urgent
    Thanks
    Regards

    http://www.oracle.com/webfolder/technetwork/tutorials/obe/db/10g/r2/owb/owb_migrate/lesson2/lesson2.htm
    http://cy-berg.blogspot.com/2010/03/export-all-owb-objects-as-individual.html

  • Vrf for Internet Access

    Hello,
    i'd like to configure a dedicated vrf for Internet access only. On my CE router i configured three vrf (Internet, red and blue) in the vrf internet i import the route target from blue and red, and the vrf blue and red i import only the default route. Everything is working fine, only one thing bothers me, i can ping from the vrf red destinations in the vrf blue and vice versa. How can i prevent this routing?
    thanks in advanced.
    Alex
    here the config of my router.
    ip prefix-list internet seq 5 permit 0.0.0.0/0
    route-map internet permit 10
    match ip address prefix-list internet
    set extcommunity rt 100:200
    ip vrf internet
    rd 100:100
    route-target both 100:100
    route-target import 100:110
    route-tarbet import 100:120
    export map internet
    ip vrf red
    rd 100:110
    route-target both 100:110
    route-target import 100:200
    ip vrf blue
    rd 100:120
    route-target both 100:120
    route-target import 100:200

    Hi Alex,
    Given the FW is the next hop for the default route, the traffic from one vrf to the other goes through the FW and get routed back to the CE and then to the respective vrf router. You could add the rules on the FW to prevent
    traffic being routed between FW.
    Regards

  • Mpls vrf monitor

    Hi all,
    I need to monitor every CE which belongs to different VRF, their IP address may be overlapping. Is there any good idea to do that.
    Thanks.

    Hi,
    Your task has two parts as it seems to me:
    1) get IP connectivity into all VRFs
    2) access all CEs
    The second task requires unique IP addresses from the viewpoint of the monitoring device. This has nothing to do with VRFs per se, just a plain IPv4 unicast requirement. Two solutions are known: give unique IPv4 addresses to all CEs (loopback IPs for monitoring) or use NAT.
    The first task is achieved by creating a central service VPN for monitoring. An example config:
    ip vrf NMS
    rd 65000:1
    route-target import 65000:162
    export map NMS2vrfs
    ip vrf Customer1
    rd 65000:101
    route-target export 65000:101
    route-target import 65000:101
    route-target import 65000:161
    export map CEloopbacks
    ip vrf Customer2
    rd 65000:102
    route-target export 65000:102
    route-target import 65000:102
    route-target import 65000:161
    export map CEloops2NMS
    route-map CEloops2NMS permit 10
    match ip address 1
    set extcommunity rt 65000:162 [additive]
    route-map NMS2vrfs permit 10
    match ip address 2
    set extcommunity rt 65000:161 [additive]
    access-list 1 permit host 10.1.1.1
    access-list 1 permit host 10.2.2.2
    access-list 2 permit 192.0.2.0 0.0.0.255
    Your IP addresses, naming, RDs and RTs might be different. In my example I assume two CEs with 10.1.1.1 and 10.2.2.2 as monitoring Loopback IPs. The export map selectively exports only those IPs into the NMS vrf. Be aware that your monitoring LAN (192.0.2.0/24 in the example) must be reachable from all CEs, which means you have to import this prefix into all VRFs. Thus an official IPv4 address range might be required to avoid address conflicts with customer IPs.
    Hope this helps! Please rate all posts.
    Regards, Martin

  • NetFlow VRF Export

    Hi Guys!!! I need your help please. I have a Router 12404/PRP (IP=1.1.1.1) and I'm trying to connect it to a Traffic Analiser (IP=1.1.1.2) in order to send flow records. When I connect the Router directly to Analiser without VRF configuration [Case-1], there is no problem and can see flow packets arriving to Analiser through a sniffer. But, when I configured VRF [Case-2], these flow packets are not arriving, I do not know if I need to configure something else inside or outside VRF. This is the configuration:
    [Case-1] Configuration without VRF:
    interface  FastEthernet0
      ip address 1.1.1.1  255.255.255.0
      no ip directed-broadcast
      negotiation  auto
    ip flow-export destination 1.1.1.2  63636
    [Case-2] Configuration with VRF:
    interface  FastEthernet0
    ip address 1.1.1.1  255.255.255.0
      ip vrf forwarding ANALISER
      no ip  directed-broadcast
      negotiation  auto
    ip flow-export destination 1.1.1.2 63636 vrf ANALISER
    Common Configuration:
    ip vrf ANALISER
    rd 19114:200001
    export map RM-vrf-ANALISER
    route-target export 19114:200001
    route-target import 19114:200001
    route-target import 19114:200011
    route-target import 19114:200004
    1.- Do I need to configure anything else?
    2.- Is it possible to use the vrf interface as source of netflow packets?
    3.- Can I export flow records within a VRF.
    Thanks  in advance for your kindly help guys!
    Saludos,
    Carlos*

    Hello Carlos,
    according to netflow command reference support for export of netflow data to a VRF is recent
    http://www.cisco.com/en/US/docs/ios/netflow/command/reference/nf_01.html#wp1049093
    Before Cisco IOS Releases 12.4(4)T, only one routing option existed for NetFlow export data packets. NetFlow sent all export data packets to the global routing table for routing to the export destinations you specified.
    this is clearly an IOS release for ISR routers.
    looking at feature navigator at www.cisco.com/go/fn
    using search by feature and typing netflow several netflow features are displayed but no explicit export to VRF feature appears.
    You may want to open a service request to ask if and when it is supported on GSR.
    As you can understand up to now netflow data export has been done in the global routing table and it is common practice for service providers to do so.
    Hope to help
    Giuseppe

Maybe you are looking for