External counter timebase source in two edge separation task

Hi all,
I use a NI 6220 board and want to perform something very similiar to what is described in the knowledgebase article "How Do I Count Digital Edges Between a Start and Stop Trigger on an NI 6602 Counter/Timer Board?".
Does anybody know how I have to change the example program "TwoEdgeSep.c" to use not the internal timebase but to use an external source (the one I want to count the edges?
Thank's for your time,
Uli
Solved!
Go to Solution.

What errors were you getting?
The counter can count between 2 and 232-1 ticks.  So... the rate that you specify will determine the minimum and maximum value (in terms of seconds) that you can count.  These values are set when you create the channel:
It seems intuitive to try to put "0" for the minimum value, but that will give you error -200527 (Requested values of the Minimum and Maximum properties for the counter channel are not supported...).  The real minimum value (in seconds) should be no less than 2 * (1/ timebase rate).  I'm not sure if this is your issue or not, I'm just speculating.
EDIT:  I just realized the default (if left unwired) for the minimum value is 1 µs.  This would be below 2 ticks of your 10 kHz timebase so would give the same error.  You need a minimum value of at least 200 µs.
The actual timebase rate itself shouldn't have a minimum or maximum value that I'm aware of (I guess maximum would be 100 MHz on your X Series, but in reality you can only pass through ~25 MHz from an external PFI line due to bandwidth limitations).  
Best Regards,
John Passiak

Similar Messages

  • External counter timebase when trying out NI sample Meas2EdgeSeparation_BufCont C#

    I have a newbie question on measurement of edge separation between two rising edges.
    I am trying to configure an external counter timebase to measure the time between the rising edges of two digital signals. The external counter timebase is 10MHz. Is it possible to phase lock this signal so that the internal 80MHz uses this as the reference?
    I am using the C# example code from NI, Meas2EdgeSeparation_BufCont
    CIChannel cChannel = myTask.CIChannels.CreateTwoEdgeSeparationChannel(
    counterComboBox.Text,"",
    Convert.ToDouble(minimumTextBox.Text),
    Convert.ToDouble(maximumTextBox.Text),
    firstEdge, secondEdge, CITwoEdgeSeparationUnits.Seconds);
    cChannel.CounterTimebaseSource = "/Dev1/PFI7";
    cChannel.CounterTimebaseRate = 10000000;
    Is this the correct way to specify the external counter timebase rate?

    GPS_user, 
    That looks correct for specifying the external counter timebase.  As far as using a phase lock loop, the actual programming techniques required to synchronize the sample clocks of multiple boards through a phase-locked loop depends on the type of hardware in use.  What devices are you using?
    For more information, see this link: http://digital.ni.com/public.nsf/allkb/07BC8D77D4E9AE258625708B007CE74F
    Patrick W.
    Applications Engineer
    National Instruments

  • Samples Not Acquired on NI 660x or NI 6624 Devices When using pulse width, semi-period or two-edge separation buffered measurements with the NI 660x and NI 6624 on counters 0 and 1, some samples may not be acquired under certain circumstances.

    In the DAQmx 9.4 Readme the following is stated:
    Samples Not Acquired on NI 660x or NI 6624 Devices When using pulse width, semi-period or two-edge separation buffered measurements with the NI 660x and NI 6624 on counters 0 and 1, some samples may not be acquired under certain circumstances.
    Could anyone elaborate on this? I am particularly interested in knowing under what circumstances this problem arises for the 6602 PCI devices.
    How should I understand 'NI 660x and NI 6624 on counters 0 and 1'. Is it only a problem on counter 0 and 1 for the 660x or does this only apply for the 6624 devices.
    /mola 

    Are there any NI Product Support Engineers out there who has an answer to this question and who are willing to share it with me?

  • Two edge separation only on first 2 channels?

    Hello,
    I have encountered a strange behaviour of the NI6602 Counter/Timer.
    When I use the C# Meas2EdgeSeparation example as provided by NI, I am only able to have correct time measurement on channels 1 and 2. For the other remaining 6 channels the time will always be measured immediately when I only have a start signal, the stop signal is not required. This results in a measurement of 1.25 e-8 s, being the minimum value of this counter. It seems that the start signal is also seen as stop signal, but Two Edge Separation should not have this.
    I have tried:
    - using the wires of the other channels on channel 1 or 2: no problem
    - disconnecting all other wires apart from the start signal for a channel: still a measurement of time, stop signal not necessary.
    I have no idea what to do next, channels 1 and 2 are OK, which is bugging me the most.
    Any suggestions are more than appreciated!
    Best regards,
    Rob

    One simple idea is to parallel wire the opto signals to 2 different counters.  Let one measure the forward time and the other one measure the rebound time.
    If the edge sequence goes 1-2-2-1 (with two discrete pass-through events on opto2), you may need to set up the 2nd counter to use the trailing edge of the
    opto2 pulse as an "Arm Start" trigger.
    If you're using an M-series multifunction board, it may be easier to create a hardware-timed digital task and then figure out the timing with some post-processing.
    -Kevin P.

  • Synchronizing the read of two timer tasks (Period and Two Edge Separation)

    Hello,
    I am using labview 2011 and need to latch the data from two timer tasks of a 6602 board at the same time and then perform the read. One task is a period measurement the other is a two edge speration.  It sounds pretty simple and I am sure it is, I just haven't located the correct information yet,  If someone would point point me in the correct direction.
    Thanks,
    Mike

    While it's true that a digital edge arm start trigger can help to sync the tasks to begin together, the nature of the measurements you're making also have a big impact on whether you can depend on the buffered data remaining "synced."   Both measurement types will latch measurement data at times determined by the signal(s) being characterized.  You cannot configure either task type to sample at a known constant rate.  You can only accept samples at the rate dictated by the signals' own edges.
    Ok, so having said all that, here are some implications:
    1. a cumulative sum of all your period data will effectively give you timestamps for all the active edges, with t=0 set by the arm start trigger edge.
    2. there is no information inherent in a two edge separation measurement that can identify the time relative to the arm start trigger.  You'll get a bunch of measured interval times with completely unknown times between those intervals
    3. caveat: if you are somehow using the same signal edge for both measurements AND getting one measurement of two-edge separation for each and every period measurement, ONLY then would you be able to reconstruct the timestamps relative to the arm start trigger edge.
    So I'd caution you that the idea of latching readings in sync or reconstructing relative edge times between the measurements is pretty unlikely to work except under some very specific circumstances.
    -Kevin P

  • How to use external timebase for Two Edge Separation measurement with PCIe 6351

    Hi
    I am working with PCIe 6351 x series DAQ card.
    counter measurements.
    Here i need to measure the time/no edges between two edges. Falling to Raising of two signals.
    I got the measurement with internal time base.
    here i need to synchronize the measurements with external clock from the external setup.
    so i need to use that external clock,timebase for the counters.
    Any solution please..
    Regards,
    Hari

    First, the VI you mention is NOT for STC timer/counters. Therefore, it won't work.
    If you want to get the time interval between two edges, you want to use the Functions -> Data Acquisition -> Counter -> Count Events or Time VI. This will do the function you are looking for.
    Mark

  • Two edge separator with a NI DAQCard-6024E for PCMCIA

    Hi,
    I have two different TTL-level signals available, and I want to measure the duration of time starting when one signal goes high and stoping when the next signal goes high.
    How can I do this using LabVIEW 5.1 and a NI DAQCard-6024E (PCMCIA)?
    Thankful for every answer.
    Regards,
    Henrik

    Probably the best way to do this is to set up counter 0 to do triggered pulse generation and then do buffered period measurement on counter 1, with the second signal being the gate signal. In other words, the first TTL signal starts the first counter producing a pulse train and the second counter measures this pulse train until the second signal causes it to latch. Look at some of the examples for triggered pulse generation and buffered period measurement and this will probably help you get started.

  • Two Edge Seperation / PCI-6238 / Error -200140

    Trying to use a PCI-6238 card to measure the time between Digital Inputs rising or falling.  From what I was directed, this should be able to be done via the Two Edge Seperation Task... However, when I configure the task it seems that no matter what the Min. and Max Time I set, I get the error:
    <<<<
    Error -200140 occured at MyTwoEdgeSeperationTask - DAQ Assistant
    Possible Reason(s):
    Two consecutive active edges of the input signal occurred without a counter timebase edge. 
    Use a faster counter timebase. 
    >>>>
    I can I change the Counter Timebase?? I thought the system selected the optimum counter timebase based on the Min and Max value entered in..
    Thanks for any help.

    Not at hw to test, but here are some brief thoughts anyway:
    1. Error message sounds a little odd to me, almost like it's only looking at 1 input signal rather than 2.  Could simply be poor choice of error text though...
    2. There's a property called "Duplicate Count Prevention" that is frequently relevant to situations where the signals to be timed are faster than the timebase used to time them.  If you search the forums for that term, you'll find more detailed info.  The summary is that it can either be enabled or disabled and the behavior when the inputs are too fast are either to produce an error like yours or to return a measurement of 0.  (I honestly don't know which setting does which -- it's easy enough to experiment and find out though).
    3. The timebase can be chosen explicitly, though DAQmx should indeed have picked the appropriate one for your specified Min / Max.  You'd probably want a Min of 0 and a Max that's less than about 50 seconds.  My guess: DAQmx *did* pick the appropriate timebase, and the error text suggesting you use a faster one is just generic advice that doesn't actually apply to your case.
    4. Two Edge Separation requires you to know which signal will come first.  If you don't know which one will come first, you may still be able to accomplish your goal by setting up a "change-detection" DI task and then measuring the period of the change detection pulse signal with a counter.  I know this would work on the 5V DIO versions of the M-series, but I'm not so familiar with your particular board.
    -Kevin P.

  • How do I setup multiple users to use one source but manage playlists separately?  For example, play counts are specific to each user.

    How do I setup multiple users to use one source but manage playlists separately?  For example, play counts are specific to each user.

    Hi,
    Thank you for posting in Windows Server Forum.
    Here adding to the words of “Tim”, a forwarder is a DNS server on a network used to forward DNS queries for external DNS names to DNS servers outside of that network. You can also forward queries according to specific domain names using conditional forwarders.
    A DNS server on a network is designated as a forwarder by having the other DNS servers in the network forward the queries they cannot resolve locally to that DNS server. You can refer information regarding forwarders and how to configure from beneath link.
    Understanding forwarders
    http://technet.microsoft.com/en-us/library/cc782142(v=ws.10).aspx
    Configure a DNS Server to Use Forwarders
    http://technet.microsoft.com/en-us/library/cc754941.aspx
    Hope it helps!
    Regards.

  • Two edge seperation counter

    Hi,
    I'm struggling to use the counter on a USB 6251 to count edges - can anyone advise?
    I need to count edges on the source input between aux and gate inputs, using Two-Signal Edge Seperation Measurement as described on page 7-18 of the M series manual (April 06 371022F-01 release of this document). The device should be capable of this, it was sold to me specifically to perform this task.
    My problem is that I can get seconds or ticks between edges on the Aux and Gate signals (on PFI 10 and 9 for counter 0), but not a count from the source input.
    I have verified both in MAX and my own code that the source input works - level changes can be detected there.
    Is there a setting I have missed that forces the device to read from the Source input (PFI8 for counter 0), instead of using it's own clock?
    See attachment for code.
    Bandit
    Attachments:
    Test Harness - Test counter.vi ‏23 KB

    Hi Jon, thanks for the reply.
    I'm measuring dynamic wear on a rotating drive nut. The nut is driven up and down a fixed threaded rod. Start trigger (edge one) is from a fixed position the nut passes. Pulses are counted from regular spaced lines around the nut. An index mark against one of these lines provides the stop trigger (edge 2). As the nut wears, the pulse count between edges will change and so wear in the thread can be measured. For this application a time isn't what I need - it's the fraction of a turn the nut makes between the start and stop trigger that I need to measure.
    The USB 6251 was chosen for this task in conjunction with my local NI field engineer. We selected it after reading the M series manual section on Two-Edge Seperation, which describes measuring the seperation of 2 signals either in time, or as a count of source events (as per my original, not very detailed post). I have posted after spending a day trawling help files, product manual, vi libraries, user forum and knowledge base.
    Two edge measurement should work from rising or falling edge of aux to rising or falling edge of gate (and it does). You get to choose rising or falling edge for each with the DAQmx Create Channel.vi in it's (CI Two Edge Seperation) variation.
    The only problem I have is getting a timing input from the source connection.
    I will check the DAQmx Count Edges task as you suggest, though at the moment I don't know how I use both start and stop triggers.
    Watch this space for an update, or post any further info you come up with.
    Regards,
    Bandit. 

  • MPLS TRUNK CONFIGURATION on TWO EDGE

    Hi
    Actually we have a network operate VRF on two EDGE (ASR9000) the diagram is this:
    we try to configurate a MPLS conection between ASR (PE-1) and ASR (PE-2) try to use MPLS LDP and use a VRF OAM between this devices but the comunication is not possible
    MPLS LDP is the option? or L2VPN or EoMPLS for this connection?
    the actually configuration is:
    ASR-2
    mpls ldp
    router-id 172.16.14.1
    discovery hello holdtime 30
    discovery hello interval 10
    graceful-restart
    explicit-null
    interface Bundle-Ether100
    ASR-1
    mpls ldp
    router-id 172.16.14.2
    discovery hello holdtime 30
    discovery hello interval 10
    graceful-restart
    explicit-null
    interface Bundle-Ether100
    but the VRF OAM only configurated between PE-1 and PE-2 is not neighbord
    We don´t know if we are using the correct concept to connect the devices, can help us
    thanks
    Best Regards

    Harold, thanks for your comments
    we are making change for your comments and the final diagrame is:
    on ASR9K - PE-1 we have configurated VRF, IGP and Conectivity for BUNDLE-Ethe 100 conectivity
    ASR9K (PE-1):
    vrf OAM
    address-family ipv4 unicast
      import route-policy pass-all
      import route-target
       64518:64518
      export route-policy pass-all
      export route-target
       64518:64518
    interface Bundle-Ether100
    ipv4 address 172.16.14.1 255.255.255.252
    interface Loopback10
    vrf OAM
    ipv4 address 172.16.162.1 255.255.255.255
    router ospf 100
    router-id 172.16.14.1
    mpls ldp sync
    mpls ldp auto-config
    area 0
      interface Bundle-Ether100
    mpls ldp
    router-id 172.16.14.1
    interface Bundle-Ether100
    ASR9K (PE-2):
    vrf OAM
    address-family ipv4 unicast
      import route-policy pass-all
      import route-target
       64518:64518
      export route-policy pass-all
      export route-target
       64518:64518
    interface Bundle-Ether100
    ipv4 address 172.16.14.2 255.255.255.252
    interface Loopback10
    vrf OAM
    ipv4 address 172.16.162.2 255.255.255.255
    router ospf 100
    router-id 172.16.14.2
    mpls ldp sync
    mpls ldp auto-config
    area 0
      interface Bundle-Ether100
    mpls ldp
    router-id 172.16.14.2
    interface Bundle-Ether100
    when we verifying  the MPLS neighbor is UP
    RP/0/RSP0/CPU0:ED_MEX_1#sho mpls ldp neighbor
    Wed May 22 18:29:03.496 UTC
    Peer LDP Identifier: 172.16.14.2:0
      TCP connection: 172.16.14.2:39527 - 172.16.14.1:646
      Graceful Restart: No
      Session Holdtime: 180 sec
      State: Oper; Msgs sent/rcvd: 25/25; Downstream-Unsolicited
      Up time: 00:18:46
      LDP Discovery Sources:
        Bundle-Ether100
      Addresses bound to this peer:
        172.16.14.2     
    RP/0/RSP0/CPU0:ED_MEX_2#sho mpls ldp neighbor
    Wed May 22 16:24:53.223 UTC
    Peer LDP Identifier: 172.16.14.1:0
      TCP connection: 172.16.14.1:646 - 172.16.14.2:39527
      Graceful Restart: No
      Session Holdtime: 180 sec
      State: Oper; Msgs sent/rcvd: 26/26; Downstream-Unsolicited
      Up time: 00:19:19
      LDP Discovery Sources:
        Bundle-Ether100
      Addresses bound to this peer:
        172.16.14.1  
    on OSPF 100 the neighbor is UP
    RP/0/RSP0/CPU0:ED_MEX_2#sho ospf neighbor
    Wed May 22 16:26:15.169 UTC
    * Indicates MADJ interface
    Neighbors for OSPF 100
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    172.16.14.1     1     FULL/BDR        00:00:31    172.16.14.1     Bundle-Ether100
        Neighbor is up for 00:54:34
    Total neighbor count: 1
    RP/0/RSP0/CPU0:ED_MEX_1#sho ospf neighbor
    Wed May 22 18:31:18.614 UTC
    * Indicates MADJ interface
    Neighbors for OSPF 100
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    172.16.14.2     1     FULL/DR         00:00:36    172.16.14.2     Bundle-Ether100
        Neighbor is up for 00:54:59
    Total neighbor count: 1
    but when try to send a PING from Loopback 10 from ASR 1 to ASR 2 ocurre this one and viceverse
    RP/0/RSP0/CPU0:ED_MEX_1#ping vrf OAM 172.16.162.1
    Wed May 22 18:32:54.046 UTC
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.162.1, timeout is 2 seconds:
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
    RP/0/RSP0/CPU0:ED_MEX_1#ping vrf OAM 172.16.162.2
    Wed May 22 18:32:57.794 UTC
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.162.2, timeout is 2 seconds:
    UUUUU
    Success rate is 0 percent (0/5)
    the routing table for OAM on ASR-1  is:
    RP/0/RSP0/CPU0:ED_MEX_1#sho route vrf OAM
    Wed May 22 18:33:59.485 UTC
    Codes: C - connected, S - static, R - RIP, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
           U - per-user static route, o - ODR, L - local, G  - DAGR
           A - access/subscriber, - FRR Backup path
    Gateway of last resort is not set
    L    172.16.162.1/32 is directly connected, 00:34:13, Loopback10
    for ASR-2
    RP/0/RSP0/CPU0:ED_MEX_2#sho route vrf OAM
    Wed May 22 16:30:23.400 UTC
    Codes: C - connected, S - static, R - RIP, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
           U - per-user static route, o - ODR, L - local, G  - DAGR
           A - access/subscriber, - FRR Backup path
    Gateway of last resort is not set
    L    172.16.162.2/32 is directly connected, 00:34:47, Loopback10
    i don´t know if need something on OSPF
    Best Regards

  • Mapping with Scd operator set to type 2 reading source records two times

    Mapping with Scd operator set to type 2 reading source records two times.Records selected count being displayed at the end of execution is double the source record count.This possibly is affecting the performance of the mapping.
    Is this a bug in scd type 2 operagtor in OWB 11gR2.How to rectify this umwamted double loop through the source data selectiom?

    Hi Roelant,
    I think it is important to be aware that although Paris - 10gR2 - is not actually buggy (in this respect!), it is really quite idiosyncratic in exactly how it processes SCDs.
    I followed up on your and Mark's comments, and did an in depth analysis of this topic. It is at http://www.donnapkelly.pwp.blueyonder.co.uk/documents/OWB_10gR2_SCD.pdf
    My conclusions are perhaps of interest to anyone considering doing SCD processing with Paris.
    I'll be doing a follow-up this weekend, and publishing a sort of 'how-to-do-it' guide.
    Cheers,
    Donna
    Message was edited to add the words: "in this respect"

  • Err. -200303: External sample clock source...

    Dear Readers
    I'm using Ni-DAQmx 8 and have a PCIe-6259 card.
    I wrote the following code (in VC++ 6).
    int main(int argc, char* argv[])
        int32       error=0;
        TaskHandle  taskHandle=0;
        uInt8      data[10]={1,2,4,8,16,32,64,128,256,0xFFFFFFFF};
        char        errBuff[2048]={'\0'};
        (error = DAQmxCreateTask("",&taskHandle));
        (error = DAQmxCreateDOChan(taskHandle,"Dev1/port0","",DAQmx_Val_ChanForAllLines));
        (error = DAQmxCfgSampClkTiming(taskHandle,NULL,1000.0,DAQmx_Val_Rising,DAQmx_Val_ContSamps,1000));
        error = DAQmxWriteRaw(taskHandle, 10, true, 10.0, data, NULL, NULL);
            if( DAQmxFailed(error) )
            DAQmxGetExtendedErrorInfo(errBuff,2048);
        ERROR: -200303: External sample clock source must be specified for this application
        error = DAQmxStartTask(taskHandle);
    I See no output on the oscilloscope.
    I tried to put in several values for ClockSource in DAQmxCfgSampClkTiming like Dev1/PFI0, .... - but it never worked.
    Could anyone please help me?
    Thanks...
    Pascal

    Hi Robert
    Do yo mean something like this:
    int main(int argc, char* argv[])
        int32       error=0;
        TaskHandle digiTaskHandle = 0;
        TaskHandle aiTaskHandle = 0;
        uInt32      data[10]={0xFFFFFFFF,2,4,8,16,32,64,128,256,0xFFFFFFFF};
        float64        dummyBuffer[10];
        char        errBuff[4096]={'\0'};
        error = DAQmxCreateTask("",&digiTaskHandle);
        error = DAQmxCreateTask("",&aiTaskHandle);
        error = DAQmxCreateDOChan(digiTaskHandle,"Dev1/port0","",DAQmx_Val_ChanForAllLines);
        error = DAQmxCreateAIVoltageChan(aiTaskHandle, "Dev1/ai0", "", DAQmx_Val_RSE, -5.0, 5.0, DAQmx_Val_Volts, "");
        error = DAQmxCfgSampClkTiming(aiTaskHandle, "/Dev1/ai/SampleClock", 1000.0, DAQmx_Val_Rising, DAQmx_Val_ContSamps, 1000);
        error = DAQmxCfgSampClkTiming(digiTaskHandle,"/Dev1/ai/SampleClock" ,1000.0,DAQmx_Val_Rising,DAQmx_Val_ContSamps,1000);
        error = DAQmxStartTask(aiTaskHandle);
    ERROR:
    "An attempt has been made to perform a route when the source and the destination are the same terminal.
    In many cases, such as when configuring an external clock or a counter source, you must select a PFI, PXI Trigger, or RTSI line as the sou"
    //    error = DAQmxReadAnalogF64(aiTaskHandle, 10, 20.0, DAQmx_Val_GroupByChannel, dummyBuffer, 10, NULL, NULL);
        if( DAQmxFailed(error) )
          DAQmxGetExtendedErrorInfo(errBuff,4096);
        error = DAQmxWriteRaw(digiTaskHandle, 10, true, 10.0, data, NULL, NULL);
        //error = DAQmxStartTask(aiTaskHandle);
        if( DAQmxFailed(error) )
          DAQmxGetExtendedErrorInfo(errBuff,2048);
        return 0;
    Could you please explain me how to do it right?
    Pascal

  • Problem in edge separation measurement by using NI PCI 6251 card

    I am trying to measure time delay between two TTL pulses (rising edge of the first signal and falling edge of 2nd signal) generated by two Photo detectors (APD) . These pulses are random pulses. Pulse width is 20ns and height is 2.5 volt at 50 ohm termination. I am using NI PCI 6251 card (M series card) for this job. I have attached my program and DAQ assist settings using for this job to this mail. Problem is   6251 card couldn't detect the pulses from APD. Exactly error shown is
                                                             "Error 200474: specified operation did not complete because the specified timeout expired".
    I have tried by increasing the waiting time but it didn't solve the problem.  I have tested my program with 20ns pulse width TTL pulses which are generated by a function generator, in this case my program worked well and given expected result.[both the signals are from same  function generator and they are synchronized so edge separation measurement gives width of the pulse ] The height (voltage) of the TTL pulse generated by the function generator is 4v at 50 ohm termination. Is this height difference creating the problem? What can be the reason ? Can anyone suggest a better way to do this job.
                                                                                     Thanks in advance
                                                                                                                                                                                                                          Regards
                                                                                                                                                                                                                           surya
    Research student
    Attachments:
    daqassist.jpg ‏71 KB
    edgeseparatio.jpg ‏26 KB

    Hey JmBone,
    It's possible that you are just suppose to send a 32-bit integer to control the 32 valves. The 'byte offset' is probably just there to allow grouping of 8 valves (8 bits as 1 byte). So instead of sending an 8-bit number with some offset, you just send a 32-bit number and only change the bits corresponding to the valves you want to change. It would be easiest to just have a 32-bit binary array in your code for changine the individual valves and then cast that to a U32 integer before sending it to the Set Attributes VI. Maybe I am misunderstanding the manual, but I don't think 'byte offset' is a parameter you are suppose to specify, and is just there to indicate how the valves can be bundled into a single 32-bit value.
    Regards,
    Ryan

  • I have been paying for two edge agreements for the past 3-4 months AND i have not gotten a reimbursment for anything...

      10/11/2013                      
    Debit Card Transaction
    VERIZON WRLS 08253-01 800-9220204 CA         10/09
    $92.30 
    On October 11th I started an EDGE agreement for the NOTE 3. I make a $92.30 payment over the phone (which is listed above). The lady said it would arrive two days after the phone comes out. It didn't show up two days after it came out and my little Droid X went dead on me. I called customer service and asked if the phone has been shipped yet. They said it has not. I asked if I could pick it up in the store instead. They said yes. They said they would cancel the shipment so I can pick it up in the store. I end up going to the store at Torrance Crossroads and I was just about to get the phone. Then sales rep was trying to force me into buying the case and charger package that was a deal with the phone for $100.I said no and he got hurt and quiet over it. 5 minutes later he comes up to me saying the edge agreement is not cancelled and they can not give me the phone. I asked if there is anything he can do or call customer service and verify because customer service told me it could be done. He said no and walked away.
    I call customer service and they say that they stopped the order and told me to go back to the store and try again. I did not wanna see the sales rep at Torrance Crossroads so I go to another Verizon store on hawthorne blvd in Torrance. I try the same process and the same thing happens. I tell them to call customer service and verify what is going on. I wait for 2 hours while they talk to customer service and the financial department. They tell me they will start another edge agreement on my girlfriends line and give me the note 3 so I can use it on my line. They said they waved the fee through some promotion since I went through a lot of trouble getting the phone and I should be getting a check in the mail for the $92.30 I paid on 10/11/13.
    Ever since then I have been paying for two edge agreements at $29.16 a piece. I have also been paying an extra $8 for insurance on a note 3 that I do not have. I have not gotten reimbursed the $92.30 I paid on 10/11/13. I have been calling customer service since December and have not gotten any where. Today was the last straw when the guy put me on hold and I ended up getting transferred to the sales department... What should I do? Is there anyone that can actually help my situation out. I already suspended my line and will do so for the next 5 months until this is fixed.

    @Dakotaep
    I am so sorry to hear of your experience with purchasing your new Samsung Galaxy Note 3!  This definitely should have been resolved in your first call to us.  I would be glad to review your account and ensure the Edge Agreement is corrected.  Please accept my "Follow" request and send me a direct message so I can further assist.  Thanks!
    AnthonyTa_VZW
    Follow us on Twitter VZWSupport on Twitter.

Maybe you are looking for

  • Haven't been able to use MyKuler for months.

    Hi!  I used to really like using Kuler.  Then, a few months ago, something went haywire, and I was no longer able to use MyKuler at all.  I haven't been able to use it, since.  I use both the website AND the desktop application (and CS5.5 integration

  • Reg XML generation from java objects using SAX 2.0

    i'm using java 1.6 and i've imported following class to generate XML from java objects import com.sun.org.apache.xml.internal.serialize.OutputFormat; import com.sun.org.apache.xml.internal.serialize.XMLSerializer; the following class has been imple h

  • Creating a FD sales order for free service

    Hi thr, We have a requirement to create a free of charge sales order with item category similar to TAD (like a service material). I've copied FD sales order type to create a new sales doc type and then I created a new item category similar to TAD. I

  • How to install CR 2008 Basic on web Server

    Hello, I'm a web developer using Visual Studio 2008 .NET. Need to install Crystal Report 2008 Basic on web server and can't. Is there any .msi on sap.com to download and install on my web server? Thank you

  • Bex Query in ABAP report

    Can i call a BEx query in ABAP report and display in ALV grid. if so please give me the syntax. Thanks Akila.R