Filling of the cache server

i would want to know the main system parameters involved in the management of the cache server. Indeed our cacher server fills up until it's full and then some entries are deleted after some delay; i don't know which parameters manage these events.
Eric.

Caching server is backed by an sqlite database.  If you want to see what you currently have downloaded, you can glean some information by accessing the database.  Use this command to connect to the database:
sudo sqlite3 /Library/Server/Caching/Data/AssetInfo.db
Once connected, you can use .tables to see the tables in the database but the one with the most information appears to be ZASSET.  Use:
   select * from ZASSET;
To list the current contents.  You will get a series of records similar to the following:
26|1|5|0|868991341|402440412.42114|402507221.969799|ffaf18a45cd5dd5e853233629036 5767|30B9108D-ABE4-4061-A2E0-42E91301249B|Fri, 06 Sep 2013 18:21:34 GMT|/content/downloads/14/11/091-9722/ognnjd4fno85m4pbapjtnv23b7rf1mkufx/OSXUpd Combo10.8.5.pkg|
Note that the final value is a human recognizable name of the package.  However, you may also see items like this:
125|1|4|0|11622676|406739736.508118|406739736.508125|4f1f9b08b32f9f6211e4569604b 1efef|481BF3D9-99BB-415F-ADB6-860EDD24B08E|Thu, 14 Nov 2013 10:24:30 GMT|/us/r1000/032/Purple6/v4/37/a3/d2/37a3d2f7-2594-8224-7eda-712f17a3fd8b/mzps 6227198657217312566.D2.pd.ipa|
This is an iOS application.  There is no real way that I know of yet to match the package name (mzps6227198657217312566.D2.pd.ipa) to a product name.
When finished, type .quit
R-
Apple Consultants Network
Apple Professional Services
Author "Mavericks Server – Foundation Services" :: Exclusively available on the iBooks Store

Similar Messages

  • How can I create a client console and work together with the Cache Server?

    How can I edit the following Cache-Server.cmd file to create a client console and work together with the Cache Server?
    The following is the cache server file: contacts-cache-server.cmd
    @echo off
    setlocal
    if (%COHERENCE_HOME%)==() (
    set COHERENCE_HOME=c:\coherence
    set CONFIG=C:\home\oracle\coherence\Contacts
    set COH_OPTS=%COH_OPTS% -server -cp %COHERENCE_HOME%\lib\coherence.jar;C:\home\oracle\
    coherence\Contacts;C:\home\oracle\coherence\Contacts\classes;
    set COH_OPTS=%COH_OPTS% -Dtangosol.coherence.cacheconfig=%CONFIG%\contacts-cache-config.xml
    java %COH_OPTS% -Xms1g -Xmx1g -Xloggc: com.tangosol.net.DefaultCacheServer %2 %3 %4 %5 %6 %7
    :exitEdited by: junez on 23-Oct-2009 09:20

    Hi
    To run the console, change DefaultCacheServer to CacheFactory
    Paul

  • How can i see the content of the cache server 2 ?

    How can i see the content of the cache server 2 ?

    Caching server is backed by an sqlite database.  If you want to see what you currently have downloaded, you can glean some information by accessing the database.  Use this command to connect to the database:
    sudo sqlite3 /Library/Server/Caching/Data/AssetInfo.db
    Once connected, you can use .tables to see the tables in the database but the one with the most information appears to be ZASSET.  Use:
       select * from ZASSET;
    To list the current contents.  You will get a series of records similar to the following:
    26|1|5|0|868991341|402440412.42114|402507221.969799|ffaf18a45cd5dd5e853233629036 5767|30B9108D-ABE4-4061-A2E0-42E91301249B|Fri, 06 Sep 2013 18:21:34 GMT|/content/downloads/14/11/091-9722/ognnjd4fno85m4pbapjtnv23b7rf1mkufx/OSXUpd Combo10.8.5.pkg|
    Note that the final value is a human recognizable name of the package.  However, you may also see items like this:
    125|1|4|0|11622676|406739736.508118|406739736.508125|4f1f9b08b32f9f6211e4569604b 1efef|481BF3D9-99BB-415F-ADB6-860EDD24B08E|Thu, 14 Nov 2013 10:24:30 GMT|/us/r1000/032/Purple6/v4/37/a3/d2/37a3d2f7-2594-8224-7eda-712f17a3fd8b/mzps 6227198657217312566.D2.pd.ipa|
    This is an iOS application.  There is no real way that I know of yet to match the package name (mzps6227198657217312566.D2.pd.ipa) to a product name.
    When finished, type .quit
    R-
    Apple Consultants Network
    Apple Professional Services
    Author "Mavericks Server – Foundation Services" :: Exclusively available on the iBooks Store

  • HT203071 How does the clients (iOS devices) to configure/use the caching server to download apps from local caching server instead of App store?

    Hi ... How does the clients (iOS devices) to configure/use the caching server to download apps from local caching server instead of App store?

    Hi,
    If you want to restore a reomoved app,you need to use
    Add-AppxPackage to add a signed app package (.appx) to a user account.
    But we cannot extract them from the ISO.
    The behavior is by design.And this is a software protection regime.
    Thanks for your understanding.
    Regards,
    Kelvin Xu
    TechNet Community Support

  • Exception while connecting to the cache server

    Hi,
    I am getting the following exception when I try to connect using .NET client to connect to the server cache.
    Tangosol.Net.Messaging.ConnectionException was unhandled
    Message="could not establish a connection to one of the following addresses: [10.158.144.57:9099]; make sure the \"remote-addresses\" configuration element contains an address and port of a running TcpAcceptor"
    Source="Coherence"
    Name="Tangosol.Net.Messaging.ConnectionException"
    StackTrace:
         at Tangosol.Util.Daemon.QueueProcessor.Service.Peer.Initiator.TcpInitiator.OpenConnection()
    at Tangosol.Util.Daemon.QueueProcessor.Service.Peer.Initiator.Initiator.EnsureConnection()
    at Tangosol.Net.Impl.RemoteCacheService.OpenChannel()
    at Tangosol.Net.Impl.RemoteService.DoStart()
    at Tangosol.Net.Impl.RemoteService.Start()
    at Tangosol.Net.Impl.SafeService.StartService(IService service)
    at Tangosol.Net.Impl.SafeService.RestartService()
    at Tangosol.Net.Impl.SafeService.EnsureRunningService(Boolean drain)
    at Tangosol.Net.Impl.SafeService.Start()
    at Tangosol.Net.DefaultConfigurableCacheFactory.EnsureService(IXmlElement xmlScheme)
    at Tangosol.Net.DefaultConfigurableCacheFactory.EnsureCache(CacheInfo info, IXmlElement xmlScheme)
    at Tangosol.Net.DefaultConfigurableCacheFactory.ConfigureCache(CacheInfo info, IXmlElement xmlScheme)
    at Tangosol.Net.DefaultConfigurableCacheFactory.EnsureCache(String cacheName)
    at Tangosol.Net.CacheFactory.GetCache(String name)
    at myApplication.Form1..ctor() in c:\Documents and Settings\royamba\Local Settings\Application Data\Temporary Projects\myApplication\Form1.cs:line 20
    at myApplication.Program.Main() in c:\Documents and Settings\royamba\Local Settings\Application Data\Temporary Projects\myApplication\Program.cs:line 17
    at System.AppDomain._nExecuteAssembly(Assembly assembly, String[] args)
    at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
    at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
    at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    at System.Threading.ThreadHelper.ThreadStart()
    The cache-config.xml has the following :
    <cache-config xmlns="http://schemas.tangosol.com/cache">
    <caching-scheme-mapping>
    <cache-mapping>
    <cache-name>seller</cache-name>
    <scheme-name>seller-distributed</scheme-name>
    </cache-mapping>
    </caching-scheme-mapping>
    <caching-schemes>
    <remote-cache-scheme>
    <scheme-name>seller-distributed</scheme-name>
    <service-name>ExtendTcpCacheService</service-name>
    <initiator-config>
    <tcp-initiator>
    <remote-addresses>
    <socket-address>
    <address>localhost</address>
    <port>9099</port>
    </socket-address>
    </remote-addresses>
    </tcp-initiator>
    <outgoing-message-handler>
    <request-timeout>30s</request-timeout>
    </outgoing-message-handler>
    </initiator-config>
    </remote-cache-scheme>
    </caching-schemes>
    </cache-config>

    Check that the <tcp-acceptor> configuration element of the target Cache Server corresponds to the client's <tcp-initiator> configuration element.
    /Mark J
    Oracle Coherece

  • Some Crystal Reports are not using the Cache Server

    Hi...we are currently running BOE XI R2 SP2.  I setup a server group with a Cache Server and a Page Server.  In the CMC, I set this cache server to keep reports cached for 15 minutes.  On the Process tab of some reports, I specifically set the report to use this new server group.  On some of the reports this works as expected.  For others, it does not appear to be since the cache folder's Date Modified date does not change.  So far the only similarity between the reports that do not use cache is that these reports have sub-reports.  Has anyone experienced this before?  If so, how did you resolve it? 
    Thanks!

    Hi Rich,
    the connectivity on the Designer an don the BusinessObjects system is identical. Is region the only characteristic being used in the report ? which connectivity did you use in Crystal Reports ?
    ingo

  • Getting exception while connecting to the cache server.

    Tangosol.Net.Messaging.ConnectionException: could not establish a connection to one of the following addresses: [locohost:9099]; make sure the "remote-addresses" configuration element contains an address and port of a running TcpAcceptor
    [ConnectionException: could not establish a connection to one of the following addresses: [localhost:9099]; make sure the "remote-addresses" configuration element contains an address and port of a running TcpAcceptor]
    Tangosol.Util.Daemon.QueueProcessor.Service.Peer.Initiator.TcpInitiator.OpenConnection() +1222
    Tangosol.Util.Daemon.QueueProcessor.Service.Peer.Initiator.Initiator.EnsureConnection() +92
    Tangosol.Net.Impl.RemoteCacheService.OpenChannel() +17
    Tangosol.Net.Impl.RemoteService.DoStart() +377
    Tangosol.Net.Impl.RemoteService.Start() +87
    Tangosol.Net.Impl.SafeService.StartService(IService service) +745
    Tangosol.Net.Impl.SafeService.RestartService() +202
    Tangosol.Net.Impl.SafeService.EnsureRunningService(Boolean drain) +148
    Tangosol.Net.Impl.SafeService.Start() +78
    Tangosol.Net.DefaultConfigurableCacheFactory.EnsureService(IXmlElement xmlScheme) +407
    Tangosol.Net.DefaultConfigurableCacheFactory.EnsureCache(CacheInfo info, IXmlElement xmlScheme) +40
    Tangosol.Net.DefaultConfigurableCacheFactory.ConfigureCache(CacheInfo info, IXmlElement xmlScheme) +82
    Tangosol.Net.DefaultConfigurableCacheFactory.EnsureCache(String cacheName) +236
    Tangosol.Net.CacheFactory.GetCache(String name) +21
    Default.PageLoad(Object sender, EventArgs e) in d:\21362\projects\OCTest1\Default.aspx.cs:19
    System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
    System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +35
    System.Web.UI.Control.OnLoad(EventArgs e) +99
    System.Web.UI.Control.LoadRecursive() +50
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627
    please give solution for this...
    Tx in advance...

    Is this a type-o, or is "locohost" specified in the remotes-addresses configuration element?
    /Mark J

  • How to apply Qos in the precedence of cache server

    m in an isp  and iwant to apply the QOS to enhance my network internet performance
    actually i  have two requests , i will start with showing brief topology about my network and start asking the questions .
    here is the topology below :
    from the topology above , my access is only on R1 which is BGP internet gateway router and R2 is my ISP router.
    1- i want to apply Qos on R1 so that a subnet of 32 ips to have gurantee bandwidth of 30M .
    assume  the subnet  is 10.20.30.0/27  that need to be bw gurantee .
    2- i want the download traffic by idman or ftp on my Router R1 dont exceed 50 % of my total bw .
    i mean that i have 450M bandwith from my isp , & sometimes we have a  slow in browsing , so i want to enhance the browsing quality because  its more important that downloading files from internet.
    here is my two requests above , i dont know how it will work with the precedence of the cache server .
    anyway , i will paste my config of router and i will replace my puplic ips with xxx for privacy .
    7200Gateway#sh run
    Building configuration...
    Current configuration : 10149 bytes
    upgrade fpd auto
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    hostname 7200Gateway
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    logging buffered 50000
    enable secret xxxxxxxxxxxxxx
    no aaa new-model
    ip source-route
    ip wccp 80 redirect-list CACHE80
    ip wccp 90 redirect-list CACHE90
    ip cef
    no ip domain lookup
    ip accounting-threshold 4294967295
    login block-for 180 attempts 3 within 60
    login quiet-mode access-class telnet
    login on-failure log
    login on-success log
    no ipv6 cef
    multilink bundle-name authenticated
    username xxxxxx password xxxxx
    archive
    log config
      hidekeys
    interface GigabitEthernet0/1
    description LAN
    bandwidth 230000
    ip address 10.160.150.2 255.255.255.0
    ip wccp 80 redirect in
    ip policy route-map CACHE-REDIRECT
    load-interval 30
    duplex auto
    speed auto
    media-type rj45
    negotiation auto
    interface FastEthernet0/2
    no ip address
    shutdown
    duplex auto
    speed auto
    interface GigabitEthernet0/2
    description Cache
    bandwidth 150000
    ip address x.x.x.x 255.255.255.248
    ip wccp redirect exclude in
    load-interval 30
    duplex auto
    speed 1000
    media-type rj45
    negotiation auto
    interface GigabitEthernet0/3
    description Internet
    bandwidth 230000
    ip address x.x.x.x 255.255.255.252
    ip wccp 90 redirect in
    load-interval 30
    duplex full
    speed 1000
    media-type sfp
    negotiation auto
    router bgp zzzzzzz
    no synchronization
    bgp log-neighbor-changes
    network xxxx mask xxxxx
    network xxxx mask xxxx
    network xxxx mask xxxxx
    network xxxx mask xxxx
    network xxxx mask xxxxx
    network xxxx mask xxxx
    redistribute connected
    redistribute static
    neighbor zzzzzzzz remote-as zzzzzzz
    neighbor zzzzzzz password zzzzzzz
    neighbor zzzzzz route-map Pipo out
    no auto-summary
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 xxxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    ip route xxxxxxxx 255.255.0.0 xxxxxxxxxx
    no ip http server
    no ip http secure-server
    ip flow-top-talkers
    top 200
    sort-by bytes
    cache-timeout 5000
    ip access-list extended bb
    permit ip xxxx.xxxx.xx.0 0.0.1.255 any
    ip access-list extended CACHE80
    permit tcp xxxxxxx any eq www
    ip access-list extended CACHE90
    permit tcp any xxxxx.0 0.0.0.255
    ip access-list extended pipo
    permit ip xxxxx xxxxxxx any
      permit ip xxxxx xxxxxxx any
    ip access-list extended private
    permit tcp 172.16.0.0 0.0.255.255 any eq www
    permit ip 10.20.30.0 0.0.0.255 any
    ip access-list extended telnet
    permit ip xxxxxx xxxxxxx.255.255 any log
    permit ip xxxx xxxxx 0.0.0.255 any log
    ip prefix-list bb seq 5 permit xxxxx
    ip prefix-list bbseq 10 permit xxxxxx
    logging history size 500
    no cdp run
    route-map pipo permit 10
    match ip address prefix-list pipo1
    route-map pipo permit 20
    match ip address prefix-list newsubnet
    set metric 500
    set origin incomplete
    set as-path prepend xxxxxxxxx
    route-map permit 10
    match ip address prefix-list bibo
    route-map CACHE-REDIRECT permit 10
    match ip address  private
    set ip next-hop 1vvvvvv
    route-map CACHE-REDIRECT permit 20
    match ip address bibo e1
    set ip next-hop vvvvvv
    route-map CACHE-REDIRECT permit 30
    match ip address pipo
    set ip next-hop vvvvvvvvvv
    route-map CACHE-REDIRECT permit 100
    snmp-server community xxxxxx RO
    control-plane
    dial-peer cor custom
    line con 0
    password xxxxxxxx
    logging synchronous
    login
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    exec-timeout 60 0
    password xxxxxxxxxxxxxxxxx
    logging synchronous
    login local
    end

    Hi Vinay,
    Please check the program. I have used the replace statement but it is not working.
    IF NOT v_sap_bom_rec IS INITIAL.
    Spliting the records at '~' delimiter
        SPLIT v_sap_bom_rec AT c_del INTO  wa_bom_file-model_name
                                           wa_bom_file-product_code
                                           wa_bom_file-description
                                           wa_bom_file-product_type
                                           wa_bom_file-mfg_part_num
                                           wa_bom_file-mfg_part_desc.
        REPLACE cl_abap_char_utilities=>horizontal_tab IN wa_bom_file-mfg_part_desc WITH space .
        wa_bom_file-status = c_status.
        APPEND wa_bom_file  TO i_bom_file.
    But it is not working.
    Please help me..
    Thanks
    Neelima

  • What does the "Only cache local content" box do under Caching Server?

    Just upgraded to Mavericks server, but I don;t understand what the "Only cache local content option" does? Does that mean it caches content on an on-demand basis, or dowloads all availavle updates?
    Thanks!
    Joel

    https://help.apple.com/advancedserveradmin/mac/3.0/#apd5E1AD52E-012B-4A41-8F21-8 E9EDA56583A
    I suppose it's hidden in the Key 'PeerFilterRanges'
    When PeerFilterRanges is boolean true, the caching server does the same as the above but uses the ListenRanges rather than the PeerFilterRanges value.

  • When using the OS X caching server, after the first update is made, do the rest of the computers have to enter the Apple ID to download the cached update

    Hello,
    I have a question that I had not found an answer to yet. I would like to use the OS X caching server, and I know that it caches a software update as soon as the first computer downloads it. If an application requires authentication using an Apple ID, and the first computer authenticates and downloads that update, do the rest of the computers have to authenticate as well, even though the update is downloaded from the caching server?
    I am looking for a solution in that regard. For the company that I work, I would like a solution for users to be able to download software updates (OS or Application), without having to authenticate with the company Apple ID, for security reasons.
    Would anybody be able to help?

    Yes.  You still need to authenticate on the subsequent machines if you are interactively applying the updates.  Caching server stores the application data, not the App Store authorization information.
    You have some alternatives.
    1:  If you are using a single "corporate" Apple ID to claim your free apps (iMovie, iPhoto, etc), then you can download them on your master machine and then user ARD, JAMF, or other tool to push the full application packages out to all the clients.  They will already be tagged to the Apple ID and since the push is happening in the background, as long as the user is not using the application, they will not know you are updating.  Remember, App Store updates are the entire application, not update packages.  So pushing the entire .app bundle is effective.
    2:  If you are looking to distribute purchased apps, you really should look at the VPP (volume purchase plan) from Apple (http://www.apple.com/business/vpp/) (there is also one for education but you mentioned company).  This allows you as the organization to purchase the correct number of copies and then control the distribution of the apps to your end users.  They can use their own Apple ID to claim the apps but you can reclaim the license should the user leave the organization.
    Reid
    Apple Consultants Network
    Apple Professional Services
    Author "Mavericks Server – Foundation Services" :: Exclusively available in Apple's iBooks Store

  • Preload Cache Server Records Management

    Hello,
    I want to fill/update the content from the content server to the cache server every night. It is possible to do this.
    The content is from the Records Management ( TA SCASE).
    Which report is necassery for this task.
    SAP Content Server: CS Release 6.30 Patch 15
    SAP Content Cache Server: CS Release 6.30 Patch 15
    Thanks in advance
    Matthias Nitschke

    Hi,
    You can try using the report RSCMSPLD. This report is not application dependent.
    Hope it helps you.
    Regards,
    Ananth

  • Content server - Cache server

    Hi,
      We have installed content server and it is working fine. We would like to install cache server to access content server from different location to reduce the access time. Is there any document/guide to link cache server to the existing content server.
         For ex.When the user in Delhi stores the original, it has to route through cache server (Located at Delhi) to the content server (Located at Chennai) and get stored in Content server.
    My mail ID is [email protected]
    Prasanna

    Hi Prasanna,
    the installation of a cache server is pretty similar to a content sever. Therefore it's covered in the installation guide of the content server. You find the installation guide on
    http://service.sap.com/instguides -> SAP Netweaver -> SAP Netweaver 7.0 (NW2004S) -> Installation
    In the Window scroll down to the end. You find the Installtion Guides under
    3 - Installation - Standalone Engines - > Installation - Content Server 6.40 on UNIX
    3 - Installation - Standalone Engines - > Installation - Content Server 6.40 on Windows
    On http://service.sap.com/ContentServer you find additional information including an FAQ answering your questions on the cache server.
    Bye, Michael

  • Cache Server Post Customization

    Hello Team,
    We have installed Windows based 6.40 cache server in addition to Unix based Content server to impove  network response time in DMS functions.
    We have done post customization settings (OALO,SCMSCA,SCMSHO, SCMSIP) . We can successfully test the cache server with URL as mentioned in installation guide ( http://localhost:1095/Cache/CSProxyCache.dll) , and with report RSCMST from backend R3 system. However , how can we verify the existing content server to cache server intrgration. Are there any post steps need to be carried out to know the cache server existisance in DMS system .
    The available cache server notes ( 216419,0407520)  does not provide sufficeint information.
    Thanks
    Makrand

    Hi Makrand,
    Have you performed the cache connectivity test?
    http://help.sap.com/saphelp_nwpi71/helpdata/en/13/a051421705be30e10000000a155106/content.htm
    Additionally,the below thread discusses on post cache sever installation activities
    SAP Cache Server integration with Content Server in DMS
    Hope this helps.
    Regards,
    Pradeepkumar Haragoldavar

  • How to avoid links upp/down being propagated to the syslog server?

    How do you avoid approx 5 billion links up/down filling up the Syslog server when you connect a couple of hundred Cisco Switches? Apart from setting the Level to Critical.
    If possible we would like to gett messages from Warning and upwards in order to be able to pinpoint problems before they happen (or atleast find out what caused them) but not at the cost of having the whole logg drenched in links upp/down! We would also like the link-messages to remain in the switch log.

    You can create a logging discriminator to filter out those messages and then specify the discriminator in the logging host definition.
    For instance:
    logging discriminator FILTER mnemonics drops UPDOWN
    logging trap notifications
    logging host <syslog_server_address> discriminator FILTER
    (Note the discriminator name is limited to 8 characters.)

  • Dual NICs and Caching Server

    Hi All -
    We currently have a Mac Mini and utilize its caching server functionality on our "normal" subnet.  We also have a "guest" subnet which is abstracted from our normal subnet (used for guest wireless devices/BYOT).  Would it be possible to use the Thunderbolt to Gigabit ethernet adapter on our Mac Mini and have the caching server serve updates on both interfaces/subnets so we do not have to buy a separate Mini to serve the guest subnet?

    Both networks and the server will have to have the same single WAN IP address. The following diagram shows a possible configuration that would work.
    Subnet A -------------+
        |                            |
    Server                     +---------- Firewall/NAT ------ Internet
       |                            |
    Subnet B -------------+
    The following should also work
    Subnet A ---------- Server ---------- Subnet B --------- Firewall/NAT --- Internet
    The above however requires the Server to act as a router to forward traffic
    The following would not work
    Subnet A -------------+
                                    |
                                   +---------- Firewall/NAT ------ Internet
                                     |                                             |
                                    |                                             |
    Subnet B -------------+---------------------------------- Server
    With the above the Server has its own public IP address and is also directly connected to one of the internal networks. As the server has its own public IP address this will be different to the shared (NATed) public IP address that everything else is using. As the public IP addresses are different the clients will not be able to use the Caching server.

Maybe you are looking for