Help:Limiting ancestors of a dimension leaf member:10g :OLAPDML

We have a dimension Operating unit which has a standard parent child hierarchy.
At run time we want to restrict the list of members visible to each user based on a security table. For leaf members we want to show the leaf member and the immediate parent. For members at any other level we want to show the member only.
So e.g operating unit 6000 is a leaf member with parent 6100.
In this case we want user to see 6000 and 6100.
If operating unit is 6100 (not a leaf member) we want user to see 6100 only.
Question is how do we 1) detect a leaf member and 2) find its immediate parent using ? via OLAPDML using the relationship CR_OU_PARENTREL or any other alternative method.
[ We will be invoking this program via ONATTACH].
Thanks,
Sudip

Suppose that your dimension is named op_unit and that the parent relation is op_unit_parentrel.
I will assume that you have limited the the op_unit dimension to the initial list of members and that you have limited the hierarchy dimension (op_unit_hierlist) to a single member. The following limit statement will add the parents of all leaf members in status.
limit op_unit add limit(limit(op_unit keep bottomdescendants using op_unit_parentrel) to parents using op_unit_parentrel)
Here is an example
rpr op_unit_parentrel
OP_UNIT      RENTREL
6000     6100
6100     6200
6200     NA
5900     6100
First show that parent members are added for leaves
limit op_unit to '6000'
limit op_unit add limit(limit(op_unit keep bottomdescendants using op_unit_parentrel) to parents using op_unit_parentrel)
rpr op_unit
OP_UNIT
6000
6100
Now show that parent members are not added for non-leaf members
limit op_unit to '6100'
limit op_unit add limit(limit(op_unit keep bottomdescendants using op_unit_parentrel) to parents using op_unit_parentrel)
rpr op_unit
OP_UNIT
6100

Similar Messages

  • Import dimension and member via maxl, how to create data file and rule file

    Hi
    I have a task to import dimension and member into Essbase, for project requirement, I have to use text file or spreadsheet file.
    I wonder which format can be imported into Essbase?
    I tried to create them, failed.
    Do you have any samples to help me? dimension file and rule file...
    I search a lot in http://gerardnico.com/wiki/epm/essbase/dimension_build#about , but there are no samples.
    Thanks in advance...
    Best regards,
    Samantha

    import database Sample.Basic data from data_file 'C:\TEMP\GENREF.txt' using rules_file 'C:\TEMP\GENREF.rul' on error append to 'C:\TEMP\logs\dimbuild.log';Here issue is not with rulefile but in reading the rule file.
    I hope rule file is in the database directory (By default it will get saved there only)
    Try with the below command
    import database Sample.Basic data from data_file 'C:\TEMP\GENREF.txt' using server rules_file 'GENREF' on error append to 'C:\TEMP\logs\dimbuild.log';
    Rule file also had one issue
    Market, Product, Measures, Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, DecHere I am seeing only four dimensions from the Sample.Basic database
    Scenario is missing. So define Actual (Scenario Dimension member) in the rule file header definition.
    All dimensions must be identified to parse one data file with rule file.
    PS: Naming (GENREF) is also irrelevant if you are loading data. It is apt for dim load.

  • Why an infocube is limited to only 16 dimensions ?

    Hi,
    Could any one please tell me , why an infocube is limited to only 16 dimensions ?
    I know that we can only have 16 dimension all together for an infocube, but I want to know
    What made SAP to limit the number to 16 ?
    IS there any proper reason behind this concept ?
    Thanx in advance,
    Rekha

    Hello Rekha,
    The combination of all dimension id's ideally make the primary(composite) key of the fact table.
    it seems that there is a database restriction of 16 fields to be combined to make a joint primary key.
    This probably is the reason for the same.
    Hope it helps..
    (Dont forget to rewards points for helpful answers on sdn)
    ( you can post it only once in any of the forums within Bw)

  • Load data filtering on a dimension's member - ESSCMD MaxL

    Hi.
    I would like to load data filtering records on a dimension's member. Referring as example to Sample's database outline, I would like to load only records with product 100-10.
    I know that I can use Select command from Record 's rule menu in Administration Console; however, I would like to use ESSCMD or Maxl to do the same.
    Is it possible? Any issue?
    Thanks a lot in advance.

    No it's not possible. The selection/rejection criteria are in the load rules and you can't pass parameters to them.
    I think in 9.3.1 you could put a substitution variable in a load rule but have not tried it yet. If so, you could add that to MaxL to update the variable then use the load rule to load the data. You will have to try it as I have not done so yet.

  • Need help to populate Calendar/Time Dimension

    Hi,
    I need experts help in populating the calender dimension with the table structure as below. I need to populate this table from year 1900 to 2100. I was able to get the sql queries for some of the columns from web but could not find any help for most columns like 'DAY_IN_QUARTER'. If somebody could help me with a PL/SQL procedure to populate this table, I really appreciate your help. I know this is too much to ask for, but I have a time constraint in completing this!! :-(
    DM_CALENDAR_ID is the primary kay with date in julian format.
    Thanks in advance,
    Ganesh
    Calendar Dimension Table:
    DM_CALENDAR_ID
    DAY_NAME
    DAY_ABBREVIATION
    DAY_IN_WEEK
    DAY_IN_MONTH
    DAY_IN_QUARTER
    DAY_IN_YEAR
    WEEKDAY_IN_WEEK
    WEEKDAY_IN_MONTH
    WEEKDAY_IN_QUARTER
    WEEKDAY_IN_YEAR
    IS_MONTH_START_WEEKDAY
    IS_QUARTER_START_WEEKDAY
    IS_YEAR_START_WEEKDAY
    IS_MONTH_END_WEEKDAY
    IS_QUARTER_END_WEEKDAY
    IS_YEAR_END_WEEKDAY
    IS_MONTH_END
    IS_QUARTER_END
    IS_YEAR_END
    DAYS_TO_GO_IN_MONTH
    DAYS_TO_GO_IN_QUARTER
    DAYS_TO_GO_IN_YEAR
    WEEKDAYS_TO_GO_IN_MONTH
    WEEKDAYS_TO_GO_IN_QUARTER
    WEEKSDAYS_TO_GO_IN_YEAR
    MONTH_ID
    MONTH_LONG
    MONTH_SHORT
    MONTH_NUMBER_IN_YEAR
    MONTH_NUMBER_IN_QUARTER
    DAYS_IN_MONTH
    WEEKDAYS_IN_MONTH
    QUARTER_ID
    QUARTER_NAME
    QUARTER_NUMBER_IN_YEAR
    DAYS_IN_QUARTER
    WEEKDAYS_IN_QUARTER
    YEAR_ID
    DAYS_IN_YEAR
    WEEKDAYS_IN_YEAR
    CREATE_LOAD_DATE
    CREATE_LOAD_USER_NAME

    If somebody could help me with a PL/SQL procedure to populate this tablethis is one kind of proc, you can change according with your requirements...
    CREATE OR REPLACE PROCEDURE TIME_DIM_PROC
    (p_start_year IN NUMBER, p_end_year IN NUMBER) AS
    v_calendar_date DATE ;
    v_calendar_start_date DATE;
    v_calendar_end_date DATE;
    v_year NUMBER;
    v_calendar_day NUMBER;
    v_week_id VARCHAR2(12);
    v_week_start_date DATE;
    v_week_end_date DATE;
    v_week_number NUMBER;
    v_month NUMBER;
    v_month_mm VARCHAR2(5);
    v_month_start_date DATE;
    v_month_end_date DATE;
    v_month_id VARCHAR2(12);
    v_quarter_start_date DATE;
    v_quarter_end_date DATE;
    v_quarter_id VARCHAR2(12);
    v_half_year_start_date DATE;
    v_half_year_end_date DATE;
    v_half_year_id VARCHAR2(12);
    v_year_start_date DATE;
    v_year_end_date DATE;
    v_fiscal_week_id VARCHAR2(12);
    v_fiscal_week_month VARCHAR2(12);
    v_fiscal_month NUMBER;
    v_fiscal_month_start_date DATE;
    v_fiscal_month_end_date DATE;
    v_fiscal_month_id VARCHAR2(12);
    v_fiscal_quarter_start_date DATE;
    v_fiscal_quarter_end_date DATE;
    v_fiscal_quarter NUMBER;
    v_fiscal_quarter_id VARCHAR2(12);
    v_fiscal_half_year_start_date DATE;
    v_fiscal_half_year_end_date DATE;
    v_fiscal_half_year_id VARCHAR2(12);
    v_fiscal_year_start_date DATE;
    v_fiscal_year_end_date DATE;
    v_fiscal_year_id VARCHAR2(12);
    v_fiscal_year NUMBER;
    v_period_name VARCHAR2(12);
    v_year_yy VARCHAR2(12);
    v_year_id VARCHAR2(12);
    v_loop_counter NUMBER;
    v_number_of_days NUMBER;
    v_fiscal_month_name VARCHAR2(10);
    v_fiscal_quarter_name VARCHAR2(10);
    v_fiscal_half_name VARCHAR2(10);
    parameters_exception EXCEPTION;
    BEGIN
    IF p_start_year > p_end_year THEN
    RAISE parameters_exception;
    END IF;
    v_calendar_start_date := to_date( p_start_year || '-01-01','YYYY-MM-DD');
    v_calendar_end_date := to_date( p_end_year || '-12-31','YYYY-MM-DD');
    v_calendar_date := v_calendar_start_date -1;
    SELECT ( (v_calendar_end_date + 1 ) - v_calendar_start_date ) INTO v_number_of_days FROM dual;
    FOR v_loop_counter IN 1..v_number_of_days
    LOOP
    v_calendar_date := v_calendar_date + 1;
    v_year := TO_NUMBER(TO_CHAR(v_calendar_date,'YYYY'));
    v_year_yy := TO_CHAR(v_calendar_date,'YY');
    v_month := TO_NUMBER(TO_CHAR(v_calendar_date,'MM'));
    v_month_mm := TO_CHAR(v_calendar_date,'MM');
    v_calendar_day := TO_NUMBER(TO_CHAR(v_calendar_date,'DD'));
    v_month_start_date := add_months(last_day( v_calendar_date ) +1 ,-1) ;
    v_month_end_date := last_day( v_calendar_date );
    v_week_id :=
    CASE WHEN v_calendar_day BETWEEN 1 AND 7 THEN 'WK1'
    WHEN v_calendar_day BETWEEN 8 AND 14 THEN 'WK2'
    WHEN v_calendar_day BETWEEN 15 AND 21 THEN 'WK3'
    WHEN v_calendar_day BETWEEN 22 AND 28 THEN 'WK4'
    ELSE 'WK5'
    END ;
    v_week_id := v_week_id || '-' || v_month_mm || '-' || v_year_yy;
    v_week_start_date :=
    CASE WHEN v_calendar_day BETWEEN 1 AND 7 THEN add_months(last_day( v_calendar_date ) +1 ,-1)
    WHEN v_calendar_day BETWEEN 8 AND 14 THEN add_months(last_day( v_calendar_date) +1 ,-1) + 7
    WHEN v_calendar_day BETWEEN 15 AND 21 THEN add_months(last_day( v_calendar_date ) +1 ,-1) + 14
    WHEN v_calendar_day BETWEEN 22 AND 28 THEN add_months(last_day( v_calendar_date ) +1 ,-1) + 21
    ELSE add_months(last_day( v_calendar_date) +1 ,-1) + 28
    END ;
    v_week_end_date :=
    CASE WHEN v_calendar_day BETWEEN 1 AND 7 THEN add_months(last_day( v_calendar_date ) +1 ,-1) + 6
    WHEN v_calendar_day BETWEEN 8 AND 14 THEN add_months(last_day( v_calendar_date) +1 ,-1) + 13
    WHEN v_calendar_day BETWEEN 15 AND 21 THEN add_months(last_day( v_calendar_date ) +1 ,-1) + 20
    WHEN v_calendar_day BETWEEN 22 AND 28 THEN add_months(last_day( v_calendar_date ) +1 ,-1) + 27
    ELSE last_day( v_calendar_date )
    END ;
    v_week_number :=
    CASE WHEN v_calendar_day BETWEEN 1 AND 7 THEN 1
    WHEN v_calendar_day BETWEEN 8 AND 14 THEN 2
    WHEN v_calendar_day BETWEEN 15 AND 21 THEN 3
    WHEN v_calendar_day BETWEEN 22 AND 28 THEN 4
    ELSE 5
    END ;
    v_period_name :=
    case when v_month = 1 then 'JAN'
    when v_month = 2 then 'FEB'
    when v_month = 3 then 'MAR'
    when v_month = 4 then 'APR'
    when v_month = 5 then 'MAY'
    when v_month = 6 then 'JUN'
    when v_month = 7 then 'JUL'
    when v_month = 8 then 'AUG'
    when v_month = 9 then 'SEP'
    when v_month = 10 then 'OCT'
    when v_month = 11 then 'NOV'
    else 'DEC'
    end || '-' || v_year_yy;
    v_month_id :=
    case when v_month = 1 then 'M01'
    when v_month = 2 then 'M02'
    when v_month = 3 then 'M03'
    when v_month = 4 then 'M04'
    when v_month = 5 then 'M05'
    when v_month = 6 then 'M06'
    when v_month = 7 then 'M07'
    when v_month = 8 then 'M08'
    when v_month = 9 then 'M09'
    when v_month = 10 then 'M10'
    when v_month = 11 then 'M11'
    else 'M12'
    end || '-' || v_year_yy;
    v_quarter_start_date := case
    when v_month between 1 and 3 then to_date( v_year || '-' || '01-01' , 'YYYY-MM-DD')
    when v_month between 4 and 6 then to_date( v_year || '-' || '04-01' , 'YYYY-MM-DD')
    when v_month between 7 and 9 then to_date( v_year || '-' || '07-01' , 'YYYY-MM-DD')
    else to_date( v_year || '-' || '10-01' , 'YYYY-MM-DD')
    end;
    v_quarter_end_date := case
    when v_month between 1 and 3 then to_date( v_year || '-' || '03-31' , 'YYYY-MM-DD')
    when v_month between 4 and 6 then to_date( v_year || '-' || '06-30' , 'YYYY-MM-DD')
    when v_month between 7 and 9 then to_date( v_year || '-' || '09-30' , 'YYYY-MM-DD')
    else to_date( v_year || '-' || '12-31' , 'YYYY-MM-DD')
    end;
    v_quarter_id := case
    when v_month between 1 and 3 then 'Q1'
    when v_month between 4 and 6 then 'Q2'
    when v_month between 7 and 9 then 'Q3'
    else 'Q4'
    end || '-' || v_year_yy;
    v_half_year_start_date :=
    case
    when v_month between 1 and 6 then to_date( v_year || '-' || '01-01' , 'YYYY-MM-DD')
    else to_date( v_year || '-' || '07-01' , 'YYYY-MM-DD')
    end;
    v_half_year_end_date :=
    case
    when v_month between 1 and 6 then to_date( v_year || '-' || '06-30' , 'YYYY-MM-DD')
    else to_date( v_year || '-' || '12-31' , 'YYYY-MM-DD')
    end;
    v_half_year_id :=
    case
    when v_month between 1 and 6 then 'HALF1'
    else 'HALF2'
    end || '-' || v_year_yy ;
    v_year_start_date := to_date( v_year || '-' || '01-01' , 'YYYY-MM-DD') ;
    v_year_end_date := to_date( v_year || '-' || '12-31' , 'YYYY-MM-DD') ;
    v_year_id := 'YR-' || substr(to_char(v_year),3,4) ;
    v_fiscal_month_start_date:=add_months(last_day( v_calendar_date ) +1 ,-1) ;
    v_fiscal_month_end_date:= last_day( v_calendar_date );
    v_fiscal_month :=
    case
    when v_month = 1 then 10
    when v_month = 2 then 11
    when v_month = 3 then 12
    when v_month = 4 then 1
    when v_month = 5 then 2
    when v_month = 6 then 3
    when v_month = 7 then 4
    when v_month = 8 then 5
    when v_month = 9 then 6
    when v_month = 10 then 7
    when v_month = 11 then 8
    else 9
    end ;
    v_fiscal_month_id :=
    case
    when v_month = 1 then 'M10' || '-' || substr(to_char((v_year-1)),3,4)
    when v_month = 2 then 'M11' || '-' || substr(to_char((v_year-1)),3,4)
    when v_month = 3 then 'M12' || '-' || substr(to_char((v_year-1)),3,4)
    when v_month = 4 then 'M01' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 5 then 'M02' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 6 then 'M03' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 7 then 'M04' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 8 then 'M05' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 9 then 'M06' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 10 then 'M07' || '-' || substr(to_char((v_year)),3,4)
    when v_month = 11 then 'M08' || '-' || substr(to_char((v_year)),3,4)
    else 'M09' || '-' || substr(to_char((v_year)),3,4)
    end ;
    v_fiscal_quarter_start_date :=
    case
    when v_month between 1 and 3 then to_date( v_year || '-' || '01-01' , 'YYYY-MM-DD')
    when v_month between 4 and 6 then to_date( v_year || '-' || '04-01' , 'YYYY-MM-DD')
    when v_month between 7 and 9 then to_date( v_year || '-' || '07-01' , 'YYYY-MM-DD')
    else to_date( v_year || '-' || '10-01' , 'YYYY-MM-DD')
    end;
    v_fiscal_quarter_end_date :=
    case
    when v_month between 1 and 3 then to_date( v_year || '-' || '03-31' , 'YYYY-MM-DD')
    when v_month between 4 and 6 then to_date( v_year || '-' || '06-30' , 'YYYY-MM-DD')
    when v_month between 7 and 9 then to_date( v_year || '-' || '09-30' , 'YYYY-MM-DD')
    else to_date( v_year || '-' || '12-31' , 'YYYY-MM-DD')
    end;
    v_fiscal_quarter :=
    case
    when v_month between 1 and 3 then 4
    when v_month between 4 and 6 then 1
    when v_month between 7 and 9 then 2
    else 3
    end;
    v_fiscal_quarter_id :=
    case
    when v_month between 1 and 3 then 'Q4' || '-'|| substr(to_char((v_year-1)),3,4)
    when v_month between 4 and 6 then 'Q1' || '-'|| substr(to_char((v_year)),3,4)
    when v_month between 7 and 9 then 'Q2' || '-'|| substr(to_char((v_year)),3,4)
    else 'Q3' || '-'|| substr(to_char((v_year)),3,4)
    end;
    v_fiscal_half_year_start_date :=
    case
    when v_month between 4 and 9 then to_date(v_year ||'-04-01','YYYY-MM-DD')
    when v_month between 10 and 12 then to_date(v_year ||'-10-01','YYYY-MM-DD')
    else to_date((v_year-1) ||'-10-01','YYYY-MM-DD')
    end;
    v_fiscal_half_year_end_date :=
    case
    when v_month between 4 and 9 then to_date(v_year ||'-09-30','YYYY-MM-DD')
    when v_month between 10 and 12 then to_date(v_year ||'-03-31','YYYY-MM-DD')
    else to_date((v_year) ||'-03-31','YYYY-MM-DD')
    end;
    v_fiscal_half_year_id :=
    case
    when v_month between 4 and 9 then 'HALF1' || '-' || substr(to_char((v_year)),3,4)
    when v_month between 10 and 12 then 'HALF2' || '-' || substr(to_char((v_year)),3,4)
    else 'HALF2' || '-' || substr(to_char((v_year-1)),3,4)
    end;
    v_fiscal_year_start_date :=
    case
    when v_month between 4 and 12 then to_date(v_year ||'-04-01','YYYY-MM-DD')
    else to_date((v_year-1) ||'-04-01','YYYY-MM-DD')
    end;
    v_fiscal_year_end_date :=
    case
    when v_month between 4 and 12 then to_date((v_year+1) ||'-03-31','YYYY-MM-DD')
    else to_date((v_year) ||'-03-31','YYYY-MM-DD')
    end;
    v_fiscal_year_id :=
    case
    when v_month between 4 and 12 then 'FY' || '-' || substr(to_char((v_year)),3,4)
    else 'FY' || '-' || substr(to_char((v_year-1)),3,4)
    end;
    v_fiscal_year :=
    case
    when v_month between 4 and 12 then v_year
    else (v_year-1)
    end;
    v_fiscal_month_name :=
    case when v_month = 1 then 'JAN'
    when v_month = 2 then 'FEB'
    when v_month = 3 then 'MAR'
    when v_month = 4 then 'APR'
    when v_month = 5 then 'MAY'
    when v_month = 6 then 'JUN'
    when v_month = 7 then 'JUL'
    when v_month = 8 then 'AUG'
    when v_month = 9 then 'SEP'
    when v_month = 10 then 'OCT'
    when v_month = 11 then 'NOV'
    else 'DEC'
    end;
    v_fiscal_quarter_name :=
    case
    when v_month between 1 and 3 then 'Q4'
    when v_month between 4 and 6 then 'Q1'
    when v_month between 7 and 9 then 'Q2'
    else 'Q3'
    end;
    v_fiscal_half_name :=
    case
    when v_month between 4 and 9 then 'HALF1'
    else 'HALF2'
    end;
    INSERT INTO TIME_DIM
    VALUES
    ( TIME_KEY_S.NEXTVAL ,
    v_calendar_date,
    'STANDARD-FISCAL',
    v_week_start_date,
    v_week_end_date ,
    v_week_id ,
    v_week_number ,
    v_period_name,
    v_month_start_date,
    v_month_end_date,
    v_month_id,
    v_quarter_start_date,
    v_quarter_end_date,
    v_quarter_id,
    v_half_year_start_date,
    v_half_year_end_date,
    v_half_year_id,
    v_year_start_date,
    v_year_end_date,
    v_year_id,
    v_year,
    v_week_start_date,
    v_week_end_date ,
    v_week_id ,
    v_week_number ,
    v_fiscal_month_start_date,
    v_fiscal_month_end_date,
    v_fiscal_month,
    v_fiscal_month_id,
    v_fiscal_quarter_start_date,
    v_fiscal_quarter_end_date,
    v_fiscal_quarter,
    v_fiscal_quarter_id,
    v_fiscal_half_year_start_date,
    v_fiscal_half_year_end_date,
    v_fiscal_half_year_id,
    v_fiscal_year_start_date,
    v_fiscal_year_end_date,
    v_fiscal_year_id,
    v_fiscal_year,
    1,
    sysdate,
    sysdate,
    user,
    user,
    -1,
    v_fiscal_month_name,
    v_fiscal_quarter_name,
    v_fiscal_half_name
    COMMIT;
    END LOOP;
    COMMIT;
    DBMS_OUTPUT.PUT_LINE ( 'v_calendar_date ' || v_calendar_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_year ' || v_year );
    DBMS_OUTPUT.PUT_LINE ( 'v_month ' || v_month);
    DBMS_OUTPUT.PUT_LINE ( 'v_month_start_date ' || v_month_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_month_end_date ' || v_month_end_date );
    DBMS_OUTPUT.PUT_LINE ( 'v_period_name ' || v_period_name );
    DBMS_OUTPUT.PUT_LINE ( 'v_month_id ' || v_month_id);
    DBMS_OUTPUT.PUT_LINE ( 'v_quarter_start_date ' || v_quarter_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_quarter_end_date ' || v_quarter_end_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_quarter_id ' || v_quarter_id);
    DBMS_OUTPUT.PUT_LINE ( 'v_half_year_start_date ' || v_half_year_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_half_year_end_date ' || v_half_year_end_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_half_year_id ' || v_half_year_id);
    DBMS_OUTPUT.PUT_LINE ( 'v_year_start_date ' || v_year_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_year_end_date ' || v_year_end_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_year ' || v_year);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_month ' || v_fiscal_month);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_month_id ' || v_fiscal_month_id);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_quarter_start_date ' || v_fiscal_quarter_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_quarter_end_date ' || v_fiscal_quarter_end_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_quarter ' || v_fiscal_quarter);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_quarter_id ' || v_fiscal_quarter_id);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_half_year_start_date ' || v_fiscal_half_year_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_half_year_end_date ' || v_fiscal_half_year_end_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_half_year_id ' || v_fiscal_half_year_id );
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_year_start_date ' || v_fiscal_year_start_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_year_end_date ' || v_fiscal_year_end_date);
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_year_id ' || v_fiscal_year_id );
    DBMS_OUTPUT.PUT_LINE ( 'v_fiscal_year ' || v_fiscal_year );
    EXCEPTION
    WHEN parameters_exception THEN
    raise_application_error (-20001,'PASS p_start_date lesser than or equal to p_end_date');
    WHEN OTHERS THEN
    raise_application_error(-20002,'An error was encountered - '||SQLCODE||' -ERROR- '||SQLERRM);
    END;
    /

  • Dimension default member has a strange impact both in dimension browser and excel filters

    Hello All,
    I have a scenario where I need to set a default member in a dimension attribute.
    The problem is that when I am browsing the dimension attribute (that is a parent-child) in Visual Studio I cannot see all the values only the ones that are filtered by the default member. In addition the same happens when I create
    a pivot table in excel with filter values, even if I change the attribute that has a default value.
    My goal is to list (by default) all the distinct values in excel filter selectors.
    Is this a limitation? Is there any way to overcome this? Is this a problem related with parent-child attributes?
    Best Regards,
    André Cunha

    Hello All, <o:p></o:p>
    Update on the situation.<o:p></o:p>
    We normalized the dimension and we achieved a
    satisfactory solution maintaining the default values and aggregation
    settings in the new dimensions and the parent-child attribute now shows
    all possible values.<o:p></o:p>
    I believe this is a by design that excel does not
    reflect the applied filters in the pivot tables depending of the attribute
    filters selected.<o:p></o:p>
    Any thoughts, <o:p></o:p>
    Regards, <o:p></o:p>
    André<o:p></o:p>

  • BPC NW 7.5 Problems with dimension ID member "Item has already been added"

    Hi experts,
    I have a problem when mantaining the dimension members in SAP BPC 7.5 in the administration console.
    I try to introduce numeric values for the ID like for example 971048000011001 and 971048000011002, but when trying to save them, I get the error "Item has already been added. Key in dictianary: "9.71048E14" Key beeing added:  "9.71048E14". It seems that BPC transforms the format into a text format before saving. Am I wrong? Is thera a solution?
    I tried modifying the number format in the excel sheet, but nothing worked. Can anybody help me, please?
    Thanks in advance,
    Àlex

    Hi Àlex.
    Try to put an simple quote before de member value, for example '1234567890
    Best Regards
    Eduardo

  • Dimension Name = Member Name?

    For an ASO cube in Essbase, can a member name be the same as the Dimension name? As per my understanding, the hierarchy name in Essbase Studio becomes the dimension name (I understand this can be overwritten in Model Properties). But I also want a member to be exactly the same as the my dimension name. Is this possible using Studio?
    The duplicate member support flag causes can error while building the outline. I'm not sure if this is the setting I want to use.

    The business reason for doing this is to work around the limitation of not being able to drill-through on Gen1 members (for cubes build via Studio). For 6/14 dimensions most of our users leave the dimension at the highest level (or Gen1). While drilling via EIS worked great, when the cubes are built from Studio, DT is supported only for Gen2 and above members. That's why I wanted to move the hierarchy down one level (or make Gen1 -> Gen2, make Gen2 -> Gen3, etc). Since I don't want to ask my users to change their gazillion spreadsheets, I wanted to keep my Gen1 and Gen2 member names the same, meaning the dimension name and the Gen2 member name would have to be the same....

  • Please Help! I need to delet "Fellow member" on Sk...

    Please Help!
    I need to delete a "Fellow member" on the Skype manager. I don't know what is "Skype manager" and why the user Greiman Gomez Garcia (scanman113)  is registered there, I DON'T KNOW HIM.
    I already have seen the screens on the FQA, but I never can get to those.
    I'm logging on web.
    Thank you very much for your answer.

    Hi, moremay, and welcome to the Community,
    Your report reads as if your account may have been compromised.  Can you still sign in to your account dashboard?  If yes, check that the account's registered e-mail address is accurate and valid.  Then, change your account's password - I prefer to do this from within the Skype software itself.  After this, you can contact Skype Customer Service to close the "Skype Manager" set-up.
    If you can not access your account, create a new account to use in order to contact Skype Customer Service and to recover your first account, as well as to disengage the "Skype Manager" which account hackers tend to use when they hack accounts.
    Here is a link to the instruction on how to contact Skype Customer Service via their secure portal: Contact Customer Service
    Skype is aware of lingering problems with the website when contacting their customer service agents. If you experience difficulty reaching Skype Customer Service or find yourself redirected back to the Community, please try again using a different web browser and choosing a different path through the various drop-down menu options presented. Also, look to approve a pop-up dialogue box which would connect you to start an instant message chat with a customer service agent. If you have pop-ups blocked in your browser settings, this will also block reaching an agent.
    Regards,
    Elaine
    Was your question answered? Please click on the Accept as a Solution link so everyone can quickly find what works! Like a post or want to say, "Thank You" - ?? Click on the Kudos button!
    Trustworthy information: Brian Krebs: 3 Basic Rules for Online Safety and Consumer Reports: Guide to Internet Security Online Safety Tip: Change your passwords often!

  • Help required in creating a dimension from an excel sheet

    Hello all ,
    We have a new requirement ,where we need to create a Dimension from an excel sheet. I tried creating it from a . csv file. But , I am not sure how to set the across, down statement ( if any) . The procedure is able to peek the data from the excel sheet. But , it says that the dimension member is not a selected member of variables. We have not created any variable yet. The transcript of the procedure is below :
    remove dimension MODULE
    ACCESS EXTERNAL
    USE 'C:\module.csv'
    DESCRIPTION FREE ,
    peek only 5
    read
    BEGIN
    construct MODULE
    level MODULE_CD
    label MODULE_DESC
    preface "custom 5 allocate 1000,30,1"
    END
    end
    compile dimension MODULE
    Please advise
    Thanks and Regards
    Vijay

    Hi Vijay,
    I believe you should be identifying the fields you have in your csv file, in your case MODULE_CD and MODULE_DESC:
    DESCRIPTION FREE ,
    MODULE_CD text 10
    MODULE_DESC text 20
    Can you try that to see if it makes a difference?
    Regards!
    Ricardo

  • Dimension Default member use a otherdimension.currentmember.level.ordinal = 3

    Hi
    I am trying to create a condition in a dimension defaultMember attribute where I use another dimension as a condition.
    It's possible to call another dimension or a measure to the dimension defaultMember expression ?
    I am getting the error: Error Loading Metadata: DefaultMember(Dim Item, Item) The dimension [DimStore] wasnot found in the cube when the string [Dim Store].[H - Store by Region] was parsed.
    The mdx used:
     case when [Dim Store].[H - Store by Region].currentmember.level.ordinal  = 3 
    then [Dim Item].[tem].&[3] 
    else   [Dim Item].[Item].[All] end
    Thanks

    Hi MJGomes,
    According to your description, you call another dimension when defining a default member of a dimension. Right?
    In Analysis Services, the default member of an attribute is used for queries where members from this attributes is not specified. It can't refer to another dimension in condition or using other dimension member because the member should be a static member
    within the current dimension. Otherwise it can be confused when executing the MDX query.
    Reference:
    Define a Default Member
    Setting default member in role playing dimensions
    If you have any question, please feel free to ask.
    Simon Hou
    TechNet Community Support

  • Conjoin dimension limited to its base dimension is too slow

    Our application has a conjoin dimension conjdim including 4 base dimensions, the definition is
    DEFINE CONJDIM DIMENSION <BaseDim1 BaseDim2 Basedim3 BaseDim4> BTREE
    CONJDIM has 21 millions values while BaseDim4 has 130 values. In middle of application,
    " limit cnjdim to a small valueset which has only 3487 values
    limit CONJDIM to CONJDIM_SMALL_VALUESET
    show statlen(CONJDIM)
    3487
    " limit BaseDim4 to 7 values
    limit BaseDim4 to 'v1' 'v2' 'v3' 'v4' 'v5' 'v6' 'v7'
    "Then limit cnjdim into BaseDim4's status
    limit CONJDIM KEEP BaseDim4 ***** took 15 minutes !!
    show statlen(CONJDIM)
    2610
    However the last limit command took very long time (more than 15 minutes) !! which doesn't make sense ?!
    Since we use KEEP in limit command, it should reduce the statue of CONJDIM from 3487 values to 2610 values,
    the OLAP data searching is only against small data range no matter how big the CONJDIM's original size is, correct ?
    That's OLAP's multi-dimension operation benefit. But our operation is so slow, what is the issue ??

    I suspect that it is the transfers occurring at g speeds that is causing your backups to be so slow. I did my initial backup wirelessly using 802.11n (5 GHz only) and it took about 20 hours to backup about 80 GB.
    Here is the setup I now use, thanks to a lot of help from other posters both here and over at Macrumors: My TC is directly connected to the cable modem with Ethernet. It is also directly connected via Ethernet to the router for my original 802.11g network, a Belkin Pre-N. The TC is set in bridge mode, 802.11n (5 GHz only). The Belkin provides all routing and is set for 802.11b.g only.
    Before my current setup, I used the TC as a separate router on its own n network. I soon gave up on this configuration, though, because it required me to from the n network to the g when I wanted to print and then back to the n network for backups. The speed of backups has been the same using the one network configuration as it was when I was doing them with the n only network.

  • Help limiting throughput by IP address- Cisco 831

    I have a cisco 831 with about 40 users behind it. I need to limit throughput to certain stations by IP address. Is this possible? Using CAR maybe? My config is below:
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    no service dhcp
    hostname xxxxx
    enable secret xxx
    enable password xxx
    username admin password xxx
    ip subnet-zero
    ip domain name xxxxx
    ip name-server x.x.x.x
    ip name-server x.x.x.x
    ip dhcp excluded-address 10.10.10.1
    ip dhcp pool CLIENT
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    lease 0 2
    ip dhcp pool xxxxx
    ip audit notify log
    ip audit po max-events 100
    ip ssh source-interface Ethernet0
    ip address-pool dhcp-pool
    vpdn enable
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    interface Ethernet0
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    no cdp enable
    hold-queue 32 in
    hold-queue 100 out
    interface Ethernet1
    ip address dhcp
    ip nat outside
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap pap callin
    ppp chap hostname xxxxxx
    ppp chap password xxx
    ppp pap sent-username xxxx password xxx
    ip nat inside source list 101 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip http server
    access-list 101 permit ip host 10.10.10.8 any
    access-list 101 permit ip host 10.10.10.36 any
    access-list 101 permit ip host 10.10.10.39 any
    access-list 101 permit ip host 10.10.10.54 any
    access-list 101 permit ip host 10.10.10.55 any
    access-list 101 permit ip host 10.10.10.63 any
    access-list 101 permit ip host 10.10.10.78 any
    access-list 101 permit ip host 10.10.10.85 any
    access-list 101 permit ip host 10.10.10.90 any
    access-list 101 permit ip host 10.10.10.91 any
    access-list 101 permit ip host 10.10.10.92 any
    access-list 101 permit ip host 10.10.10.102 any
    access-list 101 permit ip host 10.10.10.116 any
    access-list 101 permit ip host 10.10.10.123 any
    access-list 101 permit ip host 10.10.10.126 any
    access-list 101 permit ip host 10.10.10.127 any
    access-list 101 permit ip host 10.10.10.134 any
    access-list 101 permit ip host 10.10.10.144 any
    access-list 101 permit ip host 10.10.10.158 any
    line con 0
    exec-timeout 120 0
    no modem enable
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    exec-timeout 120 0
    login local
    length 0
    scheduler max-task-time 5000
    end
    Any help is appreciated.

    Hi Brian,
    Generally, rate limiting is possible with qos acls, class-maps and policy-maps.
    But I have no knowledge about the scale of qos features in Cicso 831 routers.
    I suggest you going in this direction with your search.
    Cheers:
    Istvan

  • Create Support Message via Help - Limitation for certain people

    Hi,
    i try to configure my SolMan, so that only a couple of person can create a support message with Help -> Create Support Message.
    I look for a role, but can't find anything to solve this issue. Does anyone now what I have to customize, that only people I allow can create a support message in that way?
    Thanks in advance
    Michael

    Thanks for your replies, but this doesn't solve my problem
    1) When I don't create a business partner for those people, they can create messages, but then then the filed "message processor" would be empty in SolMan
    2) which role do you mean? I tested with a test-user without any role - he can create support messages as well...
    regards
    Michael

  • Solution Manager-Search help limitation

    Dear friends,
       I am using SOl Man 4.0 , service pack level SP12.
       I have maintained hundred document types in SOLAR_PROJECT_ADMIN for my project.
    Now i want to extract a report through transaction SOLAR_EVAL, based on document type. In SOLAR_EVAL, under "Document type" field if i press F4, system is only listing first 79 document types only. It is not listing remaining 21 document types in search help. How to extend this search help from 79 to 500?
    Expecting your valuable reply
    Regards
    Senthil

    Hi Senthil,
    just curious, how did you come up with 100 different document types?
    I can't imagine why it would only show 79, but here is a work around that will take some time to setup but will save time in the long run.
    Go to your configuration and get the 100 document type abbreviations.
    Then go to the report filter screen and enter the document type abbreviation in the document type field. Now save this as a variant (Goto > Variant > Save as Variant). Now you won't have to remember the abbreviation, but rather a descriptive variant name.
    This will also allow you to save reports that combine two or more document types, such as a report that lists FDS & TDS together.
    To load the variant you click Goto > Variants > Get and select the one you want.
    If you want to speed it up even more, assign the variant to a transaction and you'll get your reports in one click. Let me know if you need the directions for this.
    Hope this is a good enough work around.
    regards,
    Jason

Maybe you are looking for

  • How does this make any sense??

    My husband gets the three bureao FICO subscription....this is on his credit report under "negative factors" HOW does this make ANY sense?!? It has "too many credit accounts with balances" as a negative factor...he has one credit card.... You have too

  • In Mountain Lion how to keep Dashboard from opening each time awakening from sleep?

    Every time awakening from sleep and/or screen saver, the dashboard screen comes up as the opening display, how can I stop this?

  • How to Retrieve Spool ID

    Scenario: I'm calling submit RPCEDT_LIST_TO_MEMORY to SAP-Spool SPOOL PARAMETERS PARAMS WITHOUT SPOOL DYNPRO and return. for Submitting the Remuneration Statement to Spool. Now how can i retrieve the ID of the spool created. This SPOOL ID is required

  • IPhone App Download Problem

    I need assistance....I have a problem with downloaded apps showing up on my phone (3Gs). When I download the app is says installing then disappears off the home screen when it is done. When I sync to iTunes, it shows up as I downloaded it and appears

  • [Solved] OpenArena removed from community?

    I went to install OpenArena on a new system of mine today and noticed it is no longer in the Community repo. What happened? I found it in AUR, but have not given it a try to see how well it works. Last edited by Brett VanKirk (2013-10-28 22:42:52)