Help on SIP

Hi guys,
I need to develop an application where SIP communication takes place between my client (WTK emulator) and the server (PHP, MySQL, Apache).
For the client part is not a problem as I can use SIP API for J2ME. What i need to know is how do i interface with the server?
Do I need SIP server/proxy in the middle?
What interface should i use on the server side?
I would really appreciate some recommendation. Thanks!!

Hi.
I'm developing a some like this...I'm using BEA web logic SIP server for the server-side part this is a SIP-Servlet container which let deploy applications that uses combined technologies like as SIP-Servlets, HTTP-servlets, and static web pages....
i hope that this is information helps you.
best regards

Similar Messages

  • Please help with SIP configuration on 2801 router

    Hi All.
    Please help me to setup a SIP account. I’m already struggling to do that for a few days, and can’t find out how to finish that. We have 2xISDN lines running, so I need to add a SIP trunk to existing config.
    The information from our SIP provider:
    We have issued the following DDI range: 018877000 – 99
    There is no need to register the DDI’s as these will be offered to your PABX IP address provided to in the completed SIP trunking form.
    Configuration details are as follows:
    Our Primary Proxy:-        99.234.56.78
    Codec supported:-             G711Alaw, G729 (G711Alaw is the preferred codec)
    Fax Support:-                     T38 and G711Alaw
    DTMF:-                                 RFC2833 and INFO
    CLI Method:-                     Remote-Party-ID
    Trunk doesn’t require registration; you just need to send Invite. In cisco this is done through Dial-peer session-target command. We are authenticating your IP address for outgoing calls and incoming calls we then forward to the IP mentioned in the sip form.
    This is a SIP configuration on Cisco2801 router (I used outgoing calls only):
    translation-rule 10
    Rule 0 ^90 0
    Rule 1 ^91 1
    Rule 2 ^92 2
    Rule 3 ^93 3
    Rule 4 ^94 4
    Rule 5 ^95 5
    Rule 6 ^96 6
    Rule 7 ^97 7
    Rule 8 ^98 8
    Rule 9 ^99 9
    interface FastEthernet0/0.1
    description ***DATA VLAN***
    encapsulation dot1Q 1 native
    ip address 10.1.1.101 255.255.255.0
    interface FastEthernet0/0.2
    description ***VOICE VLAN***
    encapsulation dot1Q 2
    ip address 192.168.22.1 255.255.255.0
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    h323
      call start slow
    sip
      bind control source-interface FastEthernet0/0.2
      bind media source-interface FastEthernet0/0.2
      registrar server expires max 36000 min 600
    voice class codec 1
    codec preference 1 g729r8
    codec preference 2 g711ulaw
    codec preference 3 g711alaw
    dial-peer voice 1 pots
    description ### External Dialling via BRI ###
    preference 7
    destination-pattern 9T
    translate-outgoing called 10
    direct-inward-dial
    port 0/0/0
    forward-digits all
    dial-peer voice 2 pots
    description ### External Dialling via BRI ###
    preference 2
    destination-pattern 9T
    translate-outgoing called 10
    direct-inward-dial
    port 0/0/1
    forward-digits all
    dial-peer voice 9000 voip
    description ** Outgoing calls to SIP **
    preference 1
    destination-pattern 9T
    voice-class sip dtmf-relay force rtp-nte
    session protocol sipv2
    session target ipv4:99.234.56.78:5060
    dtmf-relay rtp-nte
    codec g711alaw
    no vad
    sip-ua
    timers connect 100
    sip-server ipv4:99.234.56.78
    I used debugging commands to troubleshoot the calls.
    2801(config-dial-peer)#
    094509: Jan 24 09:27:06.204: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=211, Called Number=, Voice-Interface=0x65FA35B4,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOICE, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    094510: Jan 24 09:27:06.204: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=20018
    094511: Jan 24 09:27:06.716: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=9, Peer Info Type=DIALPEER_INFO_SPEECH
    094512: Jan 24 09:27:06.716: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=9
    094513: Jan 24 09:27:06.716: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094514: Jan 24 09:27:06.716: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094515: Jan 24 09:27:06.816: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90, Peer Info Type=DIALPEER_INFO_SPEECH
    094516: Jan 24 09:27:06.816: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90
    094517: Jan 24 09:27:06.816: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094518: Jan 24 09:27:06.816: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094519: Jan 24 09:27:06.912: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=908, Peer Info Type=DIALPEER_INFO_SPEECH
    094520: Jan 24 09:27:06.912: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=908
    094521: Jan 24 09:27:06.916: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094522: Jan 24 09:27:06.916: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094523: Jan 24 09:27:07.012: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=9086, Peer Info Type=DIALPEER_INFO_SPEECH
    094524: Jan 24 09:27:07.012: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=9086
    094525: Jan 24 09:27:07.016: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094526: Jan 24 09:27:07.016: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094527: Jan 24 09:27:07.116: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862, Peer Info Type=DIALPEER_INFO_SPEECH
    094528: Jan 24 09:27:07.116: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862
    094529: Jan 24 09:27:07.116: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094530: Jan 24 09:27:07.116: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094531: Jan 24 09:27:07.212: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=908621, Peer Info Type=DIALPEER_INFO_SPEECH
    094532: Jan 24 09:27:07.212: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=908621
    094533: Jan 24 09:27:07.216: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094534: Jan 24 09:27:07.216: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094535: Jan 24 09:27:07.316: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=9086215, Peer Info Type=DIALPEER_INFO_SPEECH
    094536: Jan 24 09:27:07.316: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=9086215
    094537: Jan 24 09:27:07.316: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094538: Jan 24 09:27:07.316: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094539: Jan 24 09:27:07.412: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157, Peer Info Type=DIALPEER_INFO_SPEECH
    094540: Jan 24 09:27:07.412: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157
    094541: Jan 24 09:27:07.416: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094542: Jan 24 09:27:07.416: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094543: Jan 24 09:27:07.516: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=908621577, Peer Info Type=DIALPEER_INFO_SPEECH
    094544: Jan 24 09:27:07.516: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=908621577
    094545: Jan 24 09:27:07.516: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094546: Jan 24 09:27:07.516: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094547: Jan 24 09:27:07.612: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=9086215777, Peer Info Type=DIALPEER_INFO_SPEECH
    094548: Jan 24 09:27:07.612: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=9086215777
    094549: Jan 24 09:27:07.616: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094550: Jan 24 09:27:07.616: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094551: Jan 24 09:27:07.716: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    094552: Jan 24 09:27:07.716: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774
    094553: Jan 24 09:27:07.716: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Partial Matches(1) after DP_MATCH_DEST
    094554: Jan 24 09:27:07.716: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=MORE_DIGITS_NEEDED(1)
    094555: Jan 24 09:27:10.711: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157774T, Peer Info Type=DIALPEER_INFO_SPEECH
    094556: Jan 24 09:27:10.711: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774T
    094557: Jan 24 09:27:10.711: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    094558: Jan 24 09:27:10.711: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    094559: Jan 24 09:27:10.711: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=90862157774, Called Number=90862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    094560: Jan 24 09:27:10.711: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774
    094561: Jan 24 09:27:10.715: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    094562: Jan 24 09:27:10.715: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    094563: Jan 24 09:27:10.715: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=90862157774, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    094564: Jan 24 09:27:10.715: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=9000
    094565: Jan 24 09:27:10.715: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    094566: Jan 24 09:27:10.715: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774
    094567: Jan 24 09:27:10.715: //-1/6A877F6F9054/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    094568: Jan 24 09:27:10.715: //-1/6A877F6F9054/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    094569: Jan 24 09:27:10.719: fb_get_reject_cause_code: ERROR cause_code NULL
    094570: Jan 24 09:27:10.727: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.22.1:5060;branch=z9hG4bK47D116D3
    Remote-Party-ID: "Sam " <sip:[email protected]>;party=calling;screen=no;privacy=off
    From: "Sam " <sip:[email protected]>;tag=CDCFB8AC-F98
    To: <sip:[email protected]>
    Date: Tue, 24 Jan 2012 09:27:10 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 1787264879-1168380385-2421457215-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327397230
    Contact: <sip:[email protected]:5060>
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 244
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 3237 2021 IN IP4 192.168.22.1
    s=SIP Call
    c=IN IP4 192.168.22.1
    t=0 0
    m=audio 18258 RTP/AVP 8 101
    c=IN IP4 192.168.22.1
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    094571: Jan 24 09:27:11.227: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.22.1:5060;branch=z9hG4bK47D116D3
    Remote-Party-ID: "Sam" <sip:[email protected]>;party=calling;screen=no;privacy=off
    From: "Sam " <sip:[email protected]>;tag=CDCFB8AC-F98
    To: <sip:[email protected]>
    Date: Tue, 24 Jan 2012 09:27:11 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 1787264879-1168380385-2421457215-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327397231
    Contact: <sip:[email protected]:5060>
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 244
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 3237 2021 IN IP4 192.168.22.1
    s=SIP Call
    c=IN IP4 192.168.22.1
    t=0 0
    m=audio 18258 RTP/AVP 8 101
    c=IN IP4 192.168.22.1
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    094572: Jan 24 09:27:12.227: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.22.1:5060;branch=z9hG4bK47D116D3
    Remote-Party-ID: "Sam " <sip:[email protected]>;party=calling;screen=no;privacy=off
    From: "Sam " <sip:[email protected]>;tag=CDCFB8AC-F98
    To: <sip:[email protected]>
    Date: Tue, 24 Jan 2012 09:27:12 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 1787264879-1168380385-2421457215-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327397232
    Contact: <sip:[email protected]:5060>
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 244
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 3237 2021 IN IP4 192.168.22.1
    s=SIP Call
    c=IN IP4 192.168.22.1
    t=0 0
    m=audio 18258 RTP/AVP 8 101
    c=IN IP4 192.168.22.1
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    094573: Jan 24 09:27:14.227: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 192.168.22.1:5060;branch=z9hG4bK47D116D3
    Remote-Party-ID: "Sam" <sip:[email protected]>;party=calling;screen=no;privacy=off
    From: "Sam" <sip:[email protected]>;tag=CDCFB8AC-F98
    To: <sip:[email protected]>
    Date: Tue, 24 Jan 2012 09:27:14 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 1787264879-1168380385-2421457215-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327397234
    Contact: <sip:[email protected]:5060>
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 244
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 3237 2021 IN IP4 192.168.22.1
    s=SIP Call
    c=IN IP4 192.168.22.1
    t=0 0
    m=audio 18258 RTP/AVP 8 101
    c=IN IP4 192.168.22.1
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    I made some changes in the router configuration.
    I removed FA0/0.2 Voice interface from Voice service voip configuration (bind control source-interface FastEthernet0/0.2 and bind media source-interface FastEthernet0/0.2). And now it’s using ip address 10.1.1.101 (data ip).
    The debugging is changed now. I can send and receive a respond from SIP server. But  It shows an error: SIP/2.0 404 Not Found
    Then it moves to ISDN line, and use this line to make a call.
    102988: Jan 24 14:45:47.290: //-1/EDCA21089304/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157774T, Peer Info Type=DIALPEER_INFO_SPEECH
    102989: Jan 24 14:45:47.290: //-1/EDCA21089304/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774T
    102990: Jan 24 14:45:47.290: //-1/EDCA21089304/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    102991: Jan 24 14:45:47.290: //-1/EDCA21089304/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    102992: Jan 24 14:45:47.290: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=90862157774, Called Number=90862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    102993: Jan 24 14:45:47.290: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774
    102994: Jan 24 14:45:47.294: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    102995: Jan 24 14:45:47.294: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    102996: Jan 24 14:45:47.294: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=90862157774, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    102997: Jan 24 14:45:47.294: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=9000
    102998: Jan 24 14:45:47.294: //-1/EDCA21089304/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    102999: Jan 24 14:45:47.294: //-1/EDCA21089304/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774
    103000: Jan 24 14:45:47.294: //-1/EDCA21089304/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    103001: Jan 24 14:45:47.294: //-1/EDCA21089304/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    103002: Jan 24 14:45:47.298: fb_get_reject_cause_code: ERROR cause_code NULL
    103003: Jan 24 14:45:47.310: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.101:5060;branch=z9hG4bK4875CB9
    Remote-Party-ID: "Sam" <sip:[email protected]>;party=calling;screen=no;privacy=off
    From: "Seam" <sip:[email protected]>;tag=CEF37490-172C
    To: <sip:[email protected]>
    Date: Tue, 24 Jan 2012 14:45:47 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 3989446920-1171263969-2466545983-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327416347
    Contact: <sip:[email protected]:5060>
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 247
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 2438 9821 IN IP4 10.1.1.101
    s=SIP Call
    c=IN IP4 10.1.1.101
    t=0 0
    m=audio 19412 RTP/AVP 8 101
    c=IN IP4 10.1.1.101
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    103004: Jan 24 14:45:47.354: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Received:
    SIP/2.0 404 Not Found
    From: "Sam "<sip:[email protected]>;tag=CEF37490-172C
    To: <sip:[email protected]>;tag=7fad61f03708-100007f-13c4-55013-a0142-10fd12c8-a0142
    Call-ID: [email protected]
    CSeq: 101 INVITE
    Via: SIP/2.0/UDP 10.1.1.101:5060;received=88.99.77.44;branch=z9hG4bK4875CB9
    Content-Length: 0
    103005: Jan 24 14:45:47.362: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    ACK sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.101:5060;branch=z9hG4bK4875CB9
    From: "Sam " <sip:[email protected]>;tag=CEF37490-172C
    To: <sip:[email protected]>;tag=7fad61f03708-100007f-13c4-55013-a0142-10fd12c8-a0142
    Date: Tue, 24 Jan 2012 14:45:47 GMT
    Call-ID: [email protected]
    Max-Forwards: 70
    CSeq: 101 ACK
    Allow-Events: telephone-event
    Content-Length: 0
    103006: Jan 24 14:45:47.374: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0/0/1, TEI 96 changed to up
    103007: Jan 24 14:45:51.313: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=211, Peer Info Type=DIALPEER_INFO_SPEECH
    103008: Jan 24 14:45:51.313: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=211
    103009: Jan 24 14:45:51.317: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    103010: Jan 24 14:45:51.317: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=20018
    103011: Jan 24 14:45:51.317: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=0862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    103012: Jan 24 14:45:51.317: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=0862157774
    103013: Jan 24 14:45:51.317: //-1/xxxxxxxxxxxx/DPM/dpMatchPeersCore:
       No Outgoing Dial-peer Is Matched; Result=NO_MATCH(-1)
    103014: Jan 24 14:45:51.317: //-1/xxxxxxxxxxxx/DPM/dpMatchPeers:
       Result=NO_MATCH(-1)
    103015: Jan 24 14:46:08.815: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0/0/1, TEI 96 changed to down
    2801(config-dial-peer)#
    Then I removed SIP-UA as I was told there is no registration necessary, only Dial-peer configuration.
    But it didn’t affect anything.
    Then I add translate-outgoing called 10 command to dial-peer 9000, nothing happened.
    Really stuck and don't know where to look at.
    Any help will be highly appreciated.
    Thanks.

    Hi Dan.
    Yes, I saw that RTP debugging, but what can I change there? Maybe I need to open more ports on ASA for RTP like 19412?
    I use Cisco ASDM for ASA to make changes.
    There are static NAT rules for: Server source IPs(10.1.1.100) to Outside(translated IPs, 88.99.77.44)  for a few ports.
    Also I added Security policy access rules for LAN: Any to SIP, and Outside: SIP to any.
    For NAT:
    I can't add this: for LAN: STATIC ROUTER IP 10.1.1.101 (AS SOURCE) UDP 5060 TO OUTSIDE IP 88.99.77.44
    (AS TRANSLATED) UDP 5060
    Because there is already translation for the Server.
    Debugging looks like that now. There is no Received: SIP/2.0, but I can make an outside call with no audio.
    116013: Jan 25 15:28:25.584: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Calling Number=90862157774, Called Number=, Voice-Interface=0x0,
       Timeout=TRUE, Peer Encap Type=ENCAP_VOIP, Peer Search Type=PEER_TYPE_VOICE,
       Peer Info Type=DIALPEER_INFO_SPEECH
    116014: Jan 25 15:28:25.584: //-1/xxxxxxxxxxxx/DPM/dpAssociateIncomingPeerCore:
       Result=Success(0) after DP_MATCH_ORIGINATE; Incoming Dial-peer=9000
    116015: Jan 25 15:28:25.584: //-1/0D0EB9CE9708/DPM/dpMatchPeersCore:
       Calling Number=, Called Number=90862157774, Peer Info Type=DIALPEER_INFO_SPEECH
    116016: Jan 25 15:28:25.584: //-1/0D0EB9CE9708/DPM/dpMatchPeersCore:
       Match Rule=DP_MATCH_DEST; Called Number=90862157774
    116017: Jan 25 15:28:25.584: //-1/0D0EB9CE9708/DPM/dpMatchPeersCore:
       Result=Success(0) after DP_MATCH_DEST
    116018: Jan 25 15:28:25.584: //-1/0D0EB9CE9708/DPM/dpMatchPeersMoreArg:
       Result=SUCCESS(0)
       List of Matched Outgoing Dial-peer(s):
         1: Dial-peer Tag=9000
         2: Dial-peer Tag=2
         3: Dial-peer Tag=1
    116019: Jan 25 15:28:25.588: fb_get_reject_cause_code: ERROR cause_code NULL
    116020: Jan 25 15:28:25.600: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.101:5060;branch=z9hG4bK491484D
    Remote-Party-ID: "Sam " ;party=calling;screen=no;privacy=off
    From: "Sam " ;tag=D4410748-1C9D
    To:
    Date: Wed, 25 Jan 2012 15:28:25 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 219068878-1184895457-2533916991-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327505305
    Contact:
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 247
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 1984 5803 IN IP4 10.1.1.101
    s=SIP Call
    c=IN IP4 10.1.1.101
    t=0 0
    m=audio 18782 RTP/AVP 8 101
    c=IN IP4 10.1.1.101
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    116021: Jan 25 15:28:26.096: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.101:5060;branch=z9hG4bK491484D
    Remote-Party-ID: "Sam " ;party=calling;screen=no;privacy=off
    From: "Sam " ;tag=D4410748-1C9D
    To:
    Date: Wed, 25 Jan 2012 15:28:26 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 219068878-1184895457-2533916991-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327505306
    Contact:
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 247
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 1984 5803 IN IP4 10.1.1.101
    s=SIP Call
    c=IN IP4 10.1.1.101
    t=0 0
    m=audio 18782 RTP/AVP 8 101
    c=IN IP4 10.1.1.101
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    116022: Jan 25 15:28:27.096: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.101:5060;branch=z9hG4bK491484D
    Remote-Party-ID: "Sam " ;party=calling;screen=no;privacy=off
    From: "Sam " ;tag=D4410748-1C9D
    To:
    Date: Wed, 25 Jan 2012 15:28:27 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 219068878-1184895457-2533916991-1958389771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327505307
    Contact:
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 247
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 1984 5803 IN IP4 10.1.1.101
    s=SIP Call
    c=IN IP4 10.1.1.101
    t=0 0
    m=audio 18782 RTP/AVP 8 101
    c=IN IP4 10.1.1.101
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    116026: Jan 25 15:28:57.092: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
    Sent:
    INVITE sip:[email protected]:5060 SIP/2.0
    Via: SIP/2.0/UDP 10.1.1.101:5060;branch=z9hG4bK491484D
    Remote-Party-ID: "Sam" ;party=calling;screen=no;privacy=off
    From: "Sam " ;tag=D4410748-1C9D
    To:
    Date: Wed, 25 Jan 2012 15:28:57 GMT
    Call-ID: [email protected]
    Supported: 100rel,timer,resource-priority,replaces
    Min-SE:  1800
    Cisco-Guid: 219068878-1184895457-2533916991-1958389preference 1771
    User-Agent: Cisco-SIPGateway/IOS-12.x
    Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
    CSeq: 101 INVITE
    Max-Forwards: 70
    Timestamp: 1327505337
    Contact:
    Expires: 180
    Allow-Events: telephone-event
    Content-Type: application/sdp
    Content-Disposition: session;handling=required
    Content-Length: 247
    v=0
    o=CiscoSystemsSIP-GW-UserAgent 1984 5803 IN IP4 10.1.1.101
    s=SIP Call
    c=IN IP4 10.1.1.101
    t=0 0
    m=audio 18782 RTP/AVP 8 101
    c=IN IP4 10.1.1.101
    a=rtpmap:8 PCMA/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    I'll add Incoming dial-peer now.
    Not sure what kind of NAT rule should I put into ASA to allow in and out sip traffic.
    Appretiate your help.
    Thanks a mill.

  • Need some Help configuring sip

    Hi all ! ,
    Im kind off new to sip calling and cisco telephony , but here goes ,: i have a 2821 router with CME installed
    IOS : C2800NM-IPVOICEK9-M
    Sofware version : 15.1(4)M4 / CME 8.6
    Attached to GE0/0 is a CISCO 3750 switch
    GEO - consisfts of 3 VLANS  , the native
    172.22.1.X
    172.22.100.X VOICE
    172.22.101.X DATA
    my tftpserver = 172.22.1.150
    i need some help configuring a sip trunk , i have 10 testing phonenumbers from vodafone , but i do not know where to start to get this working
    i have tried
    http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_example09186a00808f9666.shtml
    but im getting stuck with what to fill in where .. is there anyone form NL whom has the same setup ? or similar ? or can give me some guidance on how to make the test calls

    ok.. here goes
    Building configuration...
    Current configuration : 9721 bytes
    ! Last configuration change at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    ! NVRAM config last updated at 15:26:14 CET Thu Jan 2 2014
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    no aaa new-model
    clock timezone CET 1 0
    network-clock-participate wic 0
    network-clock-participate wic 1
    network-clock-select 1 E1 0/0/0
    network-clock-select 2 E1 0/0/1
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp pool VOICE
    network 172.22.100.0 255.255.255.0
    option 150 ip 172.22.1.150
    default-router 172.22.100.1
    ip dhcp pool DATA
    network 172.22.101.0 255.255.255.0
    default-router 172.22.101.1
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    isdn switch-type primary-net5
    voice service voip
    ip address trusted list
      ipv4 172.22.1.50
      ipv4 172.22.1.51
      ipv4 172.22.100.1
      ipv4 172.22.101.1
      ipv4 62.140.159.225
    callmonitor
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      registrar server expires max 3600 min 3600
    voice class codec 1
    codec preference 1 g711ulaw
    codec preference 2 g711alaw
    codec preference 3 g729r8
    codec preference 4 g729br8
    voice register global
    voice translation-rule 1
    rule 1 /5123781291/ /601/
    rule 2 /5123781290/ /600/
    voice translation-rule 2
    rule 1 /^112$/ /112/
    voice translation-rule 3
    rule 1 /^.*/ /0262610290/
    voice translation-rule 4
    rule 2 /600/ /5123788000/
    rule 3 /601/ /5123788001/
    rule 4 /^2(..)$/ /51237812\1/
    voice translation-profile CUE_Voicemail/AutoAttendant
    translate called 1
    voice translation-profile PSTN_CallForwarding
    translate redirect-target 4
    translate redirect-called 4
    voice translation-profile PSTN_Outgoing
    translate calling 3
    translate called 2
    translate redirect-target 4
    translate redirect-called 4
    voice-card 0
    crypto pki token default removal timeout 0
    controller E1 0/0/0
    framing NO-CRC4
    pri-group timeslots 1-31
    controller E1 0/0/1
    framing NO-CRC4
    pri-group timeslots 1-31
    ip ftp username cisco
    ip ftp password cisco123
    ip tftp source-interface GigabitEthernet0/0.1
    interface GigabitEthernet0/0
    no ip address
    duplex auto
    speed auto
    no keepalive
    interface GigabitEthernet0/0.1
    encapsulation dot1Q 1 native
    ip address 172.22.1.51 255.255.255.0
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20
    ip address 172.22.101.1 255.255.255.0
    interface GigabitEthernet0/0.100
    encapsulation dot1Q 100
    ip address 172.22.100.1 255.255.255.0
    interface GigabitEthernet0/1
    no ip address
    shutdown
    duplex full
    speed 100
    interface Serial0/0/0:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface Serial0/0/1:15
    no ip address
    encapsulation hdlc
    isdn switch-type primary-net5
    isdn incoming-voice voice
    no cdp enable
    interface BRI0/1/0
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    interface BRI0/1/1
    no ip address
    isdn switch-type basic-net3
    isdn point-to-point-setup
    ip forward-protocol nd
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http max-connections 16
    ip http path flash:gui
    ip route 0.0.0.0 0.0.0.0 172.22.1.50
    tftp-server flash:7941/apps41.8-4-1-23.sbn alias apps41.8-4-1-23.sbn
    tftp-server flash:7941/cnu41.8-4-1-23.sbn alias cnu41.8-4-1-23.sbn
    tftp-server flash:7941/dsp41.8-4-1-23.sbn alias dsp41.8-4-1-23.sbn
    tftp-server flash:7941/jar41sccp.8-4-1-23.sbn alias jar41sccp.8-4-1-23.sbn
    tftp-server flash:7941/cvm41sccp.8-4-1-23.sbn alias cvm41sccp.8-4-1-23.sbn
    tftp-server flash:7941/SCCP41.8-4-2S.loads alias SCCP41.8-4-2S.loads
    tftp-server flash:7941/term41.default.loads alias term41.default.loads
    tftp-server debug
    control-plane
    voice-port 0/0/0:15
    voice-port 0/1/0
    voice-port 0/1/1
    voice-port 0/0/1:15
    voice-port 2/0/0
    voice-port 2/0/1
    voice-port 2/0/2
    voice-port 2/0/3
    voice-port 2/0/4
    voice-port 2/0/5
    voice-port 2/0/6
    voice-port 2/0/7
    voice-port 2/0/8
    voice-port 2/0/9
    voice-port 2/0/10
    voice-port 2/0/11
    voice-port 2/0/12
    voice-port 2/0/13
    voice-port 2/0/14
    voice-port 2/0/15
    voice-port 2/0/16
    voice-port 2/0/17
    voice-port 2/0/18
    voice-port 2/0/19
    voice-port 2/0/20
    voice-port 2/0/21
    voice-port 2/0/22
    voice-port 2/0/23
    mgcp profile default
    dial-peer voice 1 voip
    description **Incomming Call from SIP Trunk**
    translation-profile incoming CUE_Voicemail/AutoAttendant
    session protocol sipv2
    session target ipv4:172.22.1.50
    incoming called-number .%
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9........
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 3 voip
    description **Outgoing Call to SIP Trunk **
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 4 voip
    description **Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[0-1][2-9]..[2-9]......
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 5 voip
    description **911 Outgoing Call to SIP trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 6 voip
    description **Emergency Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9911
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 7 voip
    description **911/411 Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9[2-9]11
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 8 voip
    description **International Outgoing Call to SIP Trunk**
    translation-profile outgoing PSTN_Outgoing
    destination-pattern 9011T
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 9 voip
    description **Star Code to SIP Trunk**
    destination-pattern *..
    session protocol sipv2
    session target ipv4:172.22.1.50
    voice-class codec 1
    voice-class sip dtmf-relay force rtp-nte
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 10 voip
    description **CUE Voicemail**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 600
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    dial-peer voice 11 voip
    description **CUE Auto Attendant**
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 601
    b2bua
    session protocol sipv2
    session target ipv4:172.22.1.155
    dtmf-relay sip-notify
    codec g711ulaw
    no vad
    sip-ua
    authentication username 0262610290 password 7 15020A1F173D24362C realm 62.140.1
    59.225
    authentication username 0262610290 password 7 021605481811003348
    no remote-party-id
    retry invite 2
    retry register 10
    timers connect 100
    registrar ipv4:62.140.159.225 expires 3600
    sip-server ipv4:62.140.159.224
    host-registrar
    telephony-service
    max-ephones 58
    max-dn 192
    ip source-address 172.22.100.1 port 2000
    calling-number initiator
    system message testing
    cnf-file location TFTP tftp://172.22.1.150/
    load 7960-7940 P00307020200.loads
    load 7941 SCCP41.8-4-2S.loads
    load 7941GE SCCP41.8-4-2S
    time-format 24
    dialplan-pattern 1 26261029.. extension-length 3 extension-pattern 9..
    voicemail 600
    max-conferences 12 gain -6
    call-forward pattern 9.T
    moh music-on-hold.au
    web admin system name admin password password
    dn-webedit
    time-webedit
    transfer-system full-consult
    secondary-dialtone 9
    directory entry 1 101 name 101
    create cnf-files version-stamp 7960 Jan 02 2014 08:40:49
    ephone-dn  1
    number 290 secondary 0262610290
    name Phone 1
    hold-alert 30 originator
    ephone-dn  2
    number 291 secondary 0262610291
    name phone 2
    hold-alert 30 originator
    ephone-dn  3
    number 292 secondary 0262610292
    name Phone 3
    hold-alert 30 originator
    ephone-dn  4
    number 293 secondary 0262610293
    name Phone 4
    hold-alert 30 originator
    ephone-dn  5
    number 294 secondary 0262610294
    label Phone 5
    hold-alert 30 originator
    ephone  1
    mac-address 0019.E88F.3BDD
    button  1:1
    ephone  2
    mac-address 001E.4A92.0A27
    type 7961
    button  1:2
    ephone  3
    mac-address 0012.43F5.03AF
    button  1:3
    ephone  4
    mac-address 000F.F7AC.502A
    button  1:4
    ephone  5
    mac-address 0019.E851.090A
    button  1:5
    line con 0
    line aux 0
    line vty 0 4
    login
    transport input all
    scheduler allocate 20000 1000
    ntp master
    end

  • Need help in SIP Chat

    Hello...
    I am a newbie in JAVA. I'd like to create a Voice Chat with SIP.
    But first of all I will try to create a chat situation, where 2 different hosts can receive AND send messages. It worked when I have a sender ONLY and a receiver ONLY. I couldnt make them put 2 abilities at all, 1 host - two in one - a receiver and sender.
    I thought of making it P2P.
    I am using Wireless Toolkit2.5, because at the end I will implement it on pdas or mobile phones.
    Can anyone help me ? Pleeease.

    i dont understand what you mean when it can only send OR receive messages. Cant you juct copy and paste code and change the relevant pieces around?

  • Psychomania.. ! Help ! SIP problems

    Hello...
    Here is one for Psychomania. Please help.
    I am trying to set up 'VoipTalk' on my E71 running in offline mode only (I have no SIM in it).
    As standard, I set uo the account on a softphone on my PC and its all running well. I even tried the auto-message when I heard the confirmation that that the account is set up... great !!
    So, then I went to my E71 (offline mode) and fed into the SIP settings all the VoipTalk details and the damn thing will not register !!!  Message saying on my E71 'Registration Failed'.
    Any ideas... ?
    I double checked but all is according to the instructions of VoipTalk 'E70' settings (they dont have a guide for E71)
    here it is.... https://www.voiptalk.org/products/nokia-e70-voip-setup.html
    So, could there be a difference between the E71 and E71 settings ????
    Psycomanis - please help me.... !!
    Could it be coz I am in Offline mode ?
    Please tell me..somebody...  its driving me craaazy.
    Harry

    "A port conflict was detected in the server configuration. The server is configured to listen on two ports that have the same port number and IP address.
    Channel "sip" address "sip://fe80:0:0:0:fcff:ffff:feff:ffff:5060" conflicts with channel "sip" address "sip://fe80:0:0:0:fcff:ffff:feff:ffff:5060""
    Check your config.xml file and see how many times the 5060 port is configured.

  • Need help on SIP configuration

    hi guys
    i m a starter with the SIP technology ,i m planning to use SIP as session protocol instead of cisco properitry.can anyone pls tell me do i need to configure a SIP proxy or anything that kind to use this.
    i have total 6 locations and i want all the 6 locations to communicate between each other.so i planned for SIP in this scenario.this is a IP based network
    all u r comments r welcome
    regds
    prem

    hi
    pls go thru the details of the H/W ,IOS ver and about the interface
    System image file is "flash:c1700-sv8y-mz.122-8.T1.bin"
    cisco 1751 (MPC860P) processor (revision 0x200) with 55706K/9830K bytes of memory.
    Processor board ID JAD06200B7K (241514676), with hardware revision 0000
    MPC860P processor: part number 5, mask 2
    Bridging software.
    X.25 software, Version 3.0.0.
    1 FastEthernet/IEEE 802.3 interface(s)
    2 Serial(sync/async) network interface(s)
    2 Voice FXS interface(s)
    my doubt is shall i give this command Router(config-dial-peer)# session protocol {cisco | sipv2} and go ahead with the config or do i need to configure the SIP proxy server.??
    if i use session protocol as Cisco it will take as H.323 is it equivalent to not putting this entry since its going to take h.323 only as its default ..
    regds
    prem

  • Help troubleshoot sip traffic

    Hello,
    I have a problem with a small IP telephony system (sip) and i'm using a cisco 881 router as router/firewall.
    The problem is that sometimes you can not call in. It happens only occasionally and when it does our ip phone provider says that there is no response from our ip phone/switch back to them on the internet.
    We have an ip-phone/switch-device on our local network. We we receive calls they are first routed to our ip phone provider which then sends it to us.
    It can work 20 times and then it is a call that can not get to us.
    How should I start debugging? Is there any logging for SIP traffic so I can send logs to a syslog server?
    Thanks for any suggestions.

    So if was troubleshooting this the first question I would ask would be is this a new set up or something that was working fine and is now having problems.
    If new set up post the configs and strip out passwords.
    If was working and you now have problems start running debugs to see if you can isolate issue.
    SIP Debug Commands that Support Output Filtering
    debug ccsip all
    debug ccsip calls
    debug ccsip events
    debug ccsip messages
    debug ccsip preauth
    debug ccsip states

  • Help with SIP RFQ

    I am looking for a boiler plate RFQ for SIP trunking. The SIP trunking will be located at several locations  Can anyone point me to a good resource, I hate to recreate the Wheel, I havesomething to start with but dont want to miss something on such a project that can save us alot of money.
    Thanks for pointers.

    What you are doing is inefficient.  
    It is better to configure a call server box, like Cisco CUCM.  
    All your phones talk to your call server and your call server talks to your VSP.    What you are planning is all your phones talk to your VSP.  That's inefficient.

  • SIP TLS/sRTP on Cisco border router (CUBE)

    Hello!
    Need help configuring SIP TLS for Skype Connect on CUBE (Cisco 2821, 15.1 IOS). Maybe someone has already set up at a similar functionality. Particularly interested in the question about the CA-signed certificate (maintain, installation).

    I think you need to post here: https://communities.cisco.com/community/developer

  • CVP call server service?

    How call server service(ICM,SIP,IVR) are intercommunicating. i was gone through comprehensive call flow, when call hits on CVP with help of SIP service and communicate with ICM using ICM service.
    HOw ICM and SIP service are communicating.

    Hi Bala,
    The call server uses a central messaging bus to allow each service to communicate. All the messages between these services passes via Message Bus.
    Regards,
    Senthil

  • Cisco SIP Phone 9971 won't register on CME 8.6 or 8.5 Please HELP

    Please help me , I have problem with registering Cisco SIP phone 9971 with CME 8.6 on ISR 2901.
    I configured CME for SIP clients, then I add configuration for 9971 phone and create profiles.  Phone downloaded SEP...xml file from CME,after that phone look for g4-tones.xml and gd-sip.jar files, I added them to CME after that phone downloaded them and reboot. Now phone is stuck in some kind of loop and does not register on CME.
    On phone log I can see repeting next few messeges.
    12:01:58a No DNS Server IP
    12:01:59a Updating Trust list
    12:01:59a No Trust List instaled
    12:01:59a SEP04C5AB03B0D.cnf.xml (TFTP)  // at this time phone download SEP...xml file from CME
    12:02:00a VPN Error: VPN is not Configured
    on CME if issue DEBUG TFTP EVENTS i receive next few lines
    *Aug 18 18:20:19.891: TFTP: Looking for CTLSEP04C5A4B03B0D.tlv
    *Aug 18 18:20:19.987: TFTP: Looking for ITLSEP04C5A4B03B0D.tlv
    *Aug 18 18:20:20.083: TFTP: Looking for ITLFile.tlv
    *Aug 18 18:20:20.347: TFTP: Looking for SEP04C5A4B03B0D.cnf.xml
    *Aug 18 18:20:20.351: TFTP: Opened flash:/SEP04C5A4B03B0D.cnf.xml, fd 14, size 4585 for process 141
    *Aug 18 18:20:20.363: TFTP: Finished flash:/SEP04C5A4B03B0D.cnf.xml, time 00:00:00 for process 141
    here you can see verison info of CME
    Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M, RELEASE SOFTWARE (fc1)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2011 by Cisco Systems, Inc.
    Compiled Thu 24-Mar-11 15:31 by prod_rel_team
    ROM: System Bootstrap, Version 15.0(1r)M9, RELEASE SOFTWARE (fc1)
    ELTOSAN_ROUTER uptime is 1 hour, 50 minutes
    System returned to ROM by reload at 16:29:20 UTC Thu Aug 18 2011
    System image file is "flash:/c2900-universalk9-mz.SPA.151-4.M.bin"
    Last reload type: Normal Reload
    Last reload reason: Reload Command
    Cisco CISCO2901/K9 (revision 1.0) with 471040K/53248K bytes of memory.
    Processor board ID FGL1508252Y
    3 Gigabit Ethernet interfaces
    2 terminal lines
    1 Virtual Private Network (VPN) Module
    4 Voice FXO interfaces
    4 Voice FXS interfaces
    1 Internal Services Module (ISM) with Services Ready Engine (SRE)
       Survivable Remote Site Voicemail (SRSV) on Cisco Unity Express (CUE) 8.5.1 in slot/sub-slot 0/0
    DRAM configuration is 64 bits wide with parity enabled.
    255K bytes of non-volatile configuration memory.
    254464K bytes of ATA System CompactFlash 0 (Read/Write)
    License Info:
    License UDI:
    Device#   PID                   SN
    *0        CISCO2901/K9          xxxxxxxxxxxxx
    Technology Package License Information for Module:'c2900'
    Technology    Technology-package          Technology-package
                  Current       Type          Next reboot
    ipbase        ipbasek9      Permanent     ipbasek9
    security      securityk9    Permanent     securityk9
    uc            uck9          Permanent     uck9
    data          None          None          None
    Configuration register is 0x2102
    this is RUNNING CONFIGURATION
    ! Last configuration change at 16:10:12 UTC Thu Aug 18 2011
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname ELTOSAN_ROUTER
    boot-start-marker
    boot system flash:/c2900-universalk9-mz.SPA.151-4.M.bin
    boot-end-marker
    no aaa new-model
    no ipv6 cef
    ip source-route
    no ip routing
    no ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.5.1 192.168.5.10
    ip dhcp excluded-address 192.168.5.200 192.168.5.255
    ip dhcp pool phone
       network 192.168.5.0 255.255.255.0
       default-router 192.168.5.251
       option 150 ip 192.168.5.251
    ip dhcp pool data
       relay source 192.168.2.0 255.255.255.0
       relay destination 192.168.2.201
    multilink bundle-name authenticated
    crypto pki token default removal timeout 0
    voice-card 0
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    supplementary-service h450.12
    fax protocol pass-through g711alaw
    sip
      registrar server expires max 3600 min 120
    voice register global
    mode cme
    source-address 192.168.5.251 port 5060
    max-dn 6
    max-pool 6
    load 9971 sip9971.9-1-1SR1.loads
    authenticate register
    tftp-path flash:
    create profile sync 0005135312289902
    voice register dn  1
    number 207
    allow watch
    name GossaVM
    label 207
    voice register dn  3
    number 101
    name Dejan
    label 101
    mwi
    voice register pool  1
    id mac 000C.29C5.0011
    number 1 dn 1
    dtmf-relay sip-notify
    username testvm password testera
    codec g711alaw
    voice register pool  3
    id mac 04C5.A4B0.3B0D
    type 9971
    number 3 dn 3
    presence call-list
    dtmf-relay rtp-nte
    username dejan password 1234
    codec g711alaw
    no vad
    license udi pid CISCO2901/K9 sn xxxxxxxxxxxx
    hw-module ism 0
    hw-module pvdm 0/0
    redundancy
    interface GigabitEthernet0/0
    description INTERFACE INTERNAL
    no ip address
    no ip route-cache
    duplex auto
    speed auto
    no mop enabled
    interface GigabitEthernet0/0.2
    description LAN DATA
    encapsulation dot1Q 2
    ip address 192.168.2.251 255.255.255.0
    no ip route-cache
    interface GigabitEthernet0/0.5
    description LAN VOICE
    encapsulation dot1Q 5
    ip address 192.168.5.251 255.255.255.0
    no ip route-cache
    interface ISM0/0
    no ip address
    no ip route-cache
    shutdown
    !Application: SRSV-CUE Running on ISM
    interface GigabitEthernet0/1
    no ip address
    no ip route-cache
    shutdown
    duplex auto
    speed auto
    interface ISM0/1
    description Internal switch interface connected to Internal Service Module
    shutdown
    interface Vlan1
    no ip address
    no ip route-cache
    shutdown
    ip forward-protocol nd
    no ip http server
    no ip http secure-server
    snmp-server community public RO
    tftp-server flash:dkern9971.100609R2-9-1-1SR1.sebn alias dkern9971.100609R2-9-1-1SR1.sebn
    tftp-server flash:kern9971.9-1-1SR1.sebn alias kern9971.9-1-1SR1.sebn
    tftp-server flash:rootfs9971.9-1-1SR1.sebn alias rootfs9971.9-1-1SR1.sebn
    tftp-server flash:sboot9971.031610R1-9-1-1SR1.sebn alias sboot9971.031610R1-9-1-1SR1.sebn
    tftp-server flash:skern9971.022809R2-9-1-1SR1.sebn alias skern9971.022809R2-9-1-1SR1.sebn
    tftp-server flash:sip9971.9-1-1SR1.loads alias sip9971.9-1-1SR1.loads
    tftp-server flash:United_States/g4-tones.xml
    tftp-server flash:English_United_States/gd-sip.jar
    control-plane
    voice-port 0/0/0
    voice-port 0/0/1
    voice-port 0/0/2
    voice-port 0/0/3
    voice-port 0/1/0
    voice-port 0/1/1
    voice-port 0/1/2
    voice-port 0/1/3
    mgcp profile default
    gatekeeper
    shutdown
    line con 0
    line aux 0
    line 67
    no activation-character
    no exec
    transport preferred none
    transport input all
    transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    stopbits 1
    line vty 0 4
    password jebiga
    login
    transport input all
    end
    I did not have any kind of problem with X-LITE to register to CME. also try with few SCCP phones 7940  and I did not any kind of problem .
    this is content of SEP....xml file for 9971
    <device>
    <deviceProtocol>SIP</deviceProtocol>
    <devicePool>
    <dateTimeSetting>
    <dateTemplate>M/D/YA</dateTemplate>
    <timeZone>Pacific Standard/Daylight Time</timeZone>
    <ntps>
    <ntp priority="0">
    <name>0.0.0.0</name>
    <ntpMode>unicast</ntpMode>
    </ntp>
    </ntps>
    </dateTimeSetting>
    <callManagerGroup>
    <members>
    <member priority="0">
    <callManager>
    <ports>
    <sipPort>5060</sipPort>
    </ports>
    <processNodeName>192.168.5.251</processNodeName>
    </callManager>
    </member>
    </members>
    </callManagerGroup>
    </devicePool>
    <sipProfile>
    <sipProxies>
    <registerWithProxy>true</registerWithProxy>
    </sipProxies>
    <sipCallFeatures>
    <cnfJoinEnabled>true</cnfJoinEnabled>
    <localCfwdEnable>true</localCfwdEnable>
    <callForwardURI>service-uri-cfwdall</callForwardURI>
    <callPickupURI>service-uri-pickup</callPickupURI>
    <callPickupGroupURI>service-uri-gpickup</callPickupGroupURI>
    <callHoldRingback>2</callHoldRingback>
    <semiAttendedTransfer>true</semiAttendedTransfer>
    <anonymousCallBlock>2</anonymousCallBlock>
    <callerIdBlocking>2</callerIdBlocking>
    <dndControl>2</dndControl>
    <remoteCcEnable>true</remoteCcEnable>
    </sipCallFeatures>
    <sipStack>
    <remotePartyID>true</remotePartyID>
    </sipStack>
    <sipLines>
    <line button="1" lineIndex="1">
    <featureID>9</featureID>
    <featureLabel></featureLabel>
    <proxy>USECALLMANAGER</proxy>
    <port>5060</port>
    <name></name>
    <displayName></displayName>
    <autoAnswer>
    <autoAnswerEnabled>2</autoAnswerEnabled>
    </autoAnswer>
    <callWaiting>1</callWaiting>
    <authName>dejan</authName>
    <authPassword>1234</authPassword>
    <sharedLine>false</sharedLine>
    <messagesNumber></messagesNumber>
    <ringSettingActive>5</ringSettingActive>
    <forwardCallInfoDisplay>
    <callerName>true</callerName>
    <callerNumber>true</callerNumber>
    <redirectedNumber>true</redirectedNumber>
    <dialedNumber>true</dialedNumber>
    </forwardCallInfoDisplay>
    </line>
    <line button="2" lineIndex="2">
    <featureID>9</featureID>
    <featureLabel>101</featureLabel>
    <proxy>USECALLMANAGER</proxy>
    <port>5060</port>
    <name>101</name>
    <displayName>Dejan Rakic</displayName>
    <autoAnswer>
    <autoAnswerEnabled>2</autoAnswerEnabled>
    </autoAnswer>
    <callWaiting>1</callWaiting>
    <authName>dejan</authName>
    <authPassword>1234</authPassword>
    <sharedLine>false</sharedLine>
    <messagesNumber></messagesNumber>
    <ringSettingActive>5</ringSettingActive>
    <forwardCallInfoDisplay>
    <callerName>true</callerName>
    <callerNumber>true</callerNumber>
    <redirectedNumber>true</redirectedNumber>
    <dialedNumber>true</dialedNumber>
    </forwardCallInfoDisplay>
    </line>
    </sipLines>
    <enableVad>true</enableVad>
    <preferredCodec>g711alaw</preferredCodec>
    <dialTemplate></dialTemplate>
    <kpml>1</kpml>
    <phoneLabel></phoneLabel>
    <stutterMsgWaiting>2</stutterMsgWaiting>
    <disableLocalSpeedDialConfig>true</disableLocalSpeedDialConfig>
    <dscpForAudio>184</dscpForAudio>
    <dscpVideo>136</dscpVideo>
    </sipProfile>
    <commonProfile>
    <phonePassword>1234</phonePassword>
    <callLogBlfEnabled>2</callLogBlfEnabled>
    </commonProfile>
    <featurePolicyFile>featurePolicyDefault.xml</featurePolicyFile>
    <loadInformation>sip9971.9-1-1SR1.loads</loadInformation>
    <vendorConfig>
    </vendorConfig>
    <commonConfig>
    <videoCapability>0</videoCapability>
    <ciscoCamera>0</ciscoCamera>
    </commonConfig>
    <sshUserId>dejan</sshUserId>
    <sshPassword>1234</sshPassword>
    <userId></userId>
    <phoneServices>
    <provisioning>2</provisioning>
    <phoneService  type="1" category="0">
    <name>Missed Calls</name>
    <phoneLabel></phoneLabel>
    <url>Application:Cisco/MissedCalls</url>
    <vendor></vendor>
    <version></version>
    </phoneService>
    <phoneService  type="1" category="0">
    <name>Received Calls</name>
    <phoneLabel></phoneLabel>
    <url>Application:Cisco/ReceivedCalls</url>
    <vendor></vendor>
    <version></version>
    </phoneService>
    <phoneService  type="1" category="0">
    <name>Placed Calls</name>
    <phoneLabel></phoneLabel>
    <url>Application:Cisco/PlacedCalls</url>
    <vendor></vendor>
    <version></version>
    </phoneService>
    <phoneService  type="2" category="0">
    <name>Voicemail</name>
    <phoneLabel></phoneLabel>
    <url>Application:Cisco/Voicemail</url>
    <vendor></vendor>
    <version></version>
    </phoneService>
    </phoneServices>
    <versionStamp>0131511014412102</versionStamp>
    <userLocale>
    <name>English_United_States</name>
    <langCode>en</langCode>
    </userLocale>
    <networkLocale>United_States</networkLocale>
    <networkLocaleInfo>
    <name>United_States</name>
    </networkLocaleInfo>
    <authenticationURL></authenticationURL>
    <directoryURL></directoryURL>
    <servicesURL>http://192.168.5.251:80/CMEserverForPhone/serviceurl</servicesURL>
    <dscpForSCCPPhoneServices>0</dscpForSCCPPhoneServices>
    <dscpForCm2Dvce>96</dscpForCm2Dvce>
    <transportLayerProtocol>2</transportLayerProtocol>
    </device>

    Hello,
    I'm facing exactly the same problem, that is:
    a Cisco SIP Phone 9971 won't register on CME 8.6 running on a 2811
    I have read all the postings to this Forum, but I have not been able to solve it.
    In my case the commands voice register dn  and  voice register pool are OK.
    So frankly, I have no idea what I could be missing.
    I'm pasting the Router's config.
    I hope somebody is able to point me in the right direction.
    Here is the config.  Thank you!
    C2811#sh run
    Building configuration...
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname C2811
    no aaa new-model
    dot11 syslog
    ip source-route
    ip cef
    ip dhcp excluded-address 172.25.140.1 172.25.140.10
    ip dhcp excluded-address 172.35.140.1 172.35.140.10
    ip dhcp pool Data
    network 172.25.140.0 255.255.255.0
    default-router 172.25.140.1
    option 150 ip 172.25.140.1
    dns-server 172.25.140.1
    ip dhcp pool Voice
    network 172.35.140.0 255.255.255.0
    default-router 172.35.140.1
    option 150 ip 172.35.140.1
    dns-server 172.35.140.1
    no ip domain lookup
    no ipv6 cef
    multilink bundle-name authenticated
    voice service voip
    allow-connections sip to sip
    sip
      registrar server expires max 3600 min 120
    voice register global
    mode cme
    source-address 172.25.140.1 port 5060
    max-dn 40
    max-pool 42
    load 9971 sip9971.9-4-1-9.loads
    authenticate register
    authenticate realm cisco
    tftp-path flash:
    create profile sync 0004820400584603
    voice register dn  1
    number 1010
    allow watch
    name Phone10
    label Phone10
    mwi
    voice register pool  1
    id mac 189C.5DB6.BD09
    type 9971
    number 1 dn 1
    presence call-list
    dtmf-relay rtp-nte
    username adm password adm
    call-forward b2bua busy 68600
    codec g711ulaw
    no vad
    camera
    video
    voice-card 0
    crypto pki token default removal timeout 0
    crypto pki trustpoint TP-self-signed-1879153754
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1879153754
    revocation-check none
    rsakeypair TP-self-signed-1879153754
    crypto pki certificate chain TP-self-signed-1879153754
    certificate self-signed 01
    (details ommited)
    license udi pid CISCO2811 sn FTX1146A44H
    username admin privilege 15 password 0 admin
    redundancy
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    interface FastEthernet0/0.25
    description Data VLAN
    encapsulation dot1Q 25
    ip address 172.25.140.1 255.255.255.0
    interface FastEthernet0/0.35
    description Voice VLAN
    encapsulation dot1Q 35
    ip address 172.35.140.1 255.255.255.0
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    tftp-server flash:P00308010200.bin
    tftp-server flash:P00308010200.sbn
    tftp-server flash:P00308010200.sb2
    tftp-server flash:P00308010200.loads
    tftp-server flash:SCCP42.9-3-1SR3-1S.loads
    tftp-server flash:apps42.9-3-1ES19.sbn
    tftp-server flash:cnu42.9-3-1ES19.sbn
    tftp-server flash:cvm42sccp.9-3-1ES19.sbn
    tftp-server flash:dsp42.9-3-1ES19.sbn
    tftp-server flash:jar42sccp.9-3-1ES19.sbn
    tftp-server flash:term42.default.loads
    tftp-server flash:term62.default.loads
    tftp-server flash:SCCP45.9-3-1SR3-1S.loads
    tftp-server flash:apps45.9-3-1ES19.sbn
    tftp-server flash:cnu45.9-3-1ES19.sbn
    tftp-server flash:cvm45sccp.9-3-1ES19.sbn
    tftp-server flash:dsp45.9-3-1ES19.sbn
    tftp-server flash:jar45sccp.9-3-1ES19.sbn
    tftp-server flash:term45.default.loads
    tftp-server flash:term65.default.loads
    tftp-server flash:/Ringtones/Ringlist.xml alias Ringlist.xml
    tftp-server flash:/Ringtones/DistinctiveRingList.xml alias DistinctiveRingList.x
    ml
    tftp-server flash:sip9971.9-4-1-9.loads
    tftp-server flash:kern9971.9-4-1-9.sebn
    tftp-server flash:rootfs9971.9-4-1-9.sebn
    tftp-server flash:dkern9971.100609R2-9-4-1-9.sebn
    tftp-server flash:sboot9971.031610R1-9-4-1-9.sebn
    tftp-server flash:skern9971.022809R2-9-4-1-9.sebn
    tftp-server flash:/g4-tones.xml alias United_States/g4-tones.xml
    tftp-server flash:/gd-sip.jar alias English_United_States/gd-sip.jar
    control-plane
    mgcp profile default
    telephony-service
    max-ephones 24
    max-dn 48
    ip source-address 172.25.140.1 port 2000
    cnf-file location flash:
    load 7960-7940 P00308010200
    load 7942 SCCP42.9-3-1SR3-1S.loads
    load 7945 SCCP45.9-3-1SR3-1S.loads
    load 7962 SCCP42.9-3-1SR3-1S.loads
    load 7965 SCCP45.9-3-1SR3-1S.loads
    max-conferences 8 gain -6
    dn-webedit
    transfer-system full-consult
    create cnf-files version-stamp 7960 Feb 11 2014 07:18:32
    ephone-dn  1
    number 1001
    description Phone 1
    name Phone 1
    hold-alert 30 originator
    ephone-dn  2
    number 1002
    description Phone 2
    name Phone 2
    hold-alert 30 originator
    ephone-dn  3
    number 1003
    description Phone 3
    name Phone 3
    hold-alert 30 originator
    ephone  1
    device-security-mode none
    mac-address 001C.58FB.6E0F
    button  1:1
    ephone  2
    device-security-mode none
    mac-address 0014.A981.7F8A
    button  1:2
    ephone  3
    device-security-mode none
    mac-address 0006.5356.A4B8
    button  1:3
    alias exec con conf t
    alias exec sib show ip int brief
    alias exec srb show run | b
    alias exec sri show run int
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    transport output telnet ssh
    line vty 5 15
    privilege level 15
    login local
    transport input telnet ssh
    transport output telnet ssh
    scheduler allocate 20000 1000
    ntp master 1
    end
    C2811#

  • CME\7960 running SIP firmware - How do i setup incoming calls? - Can anyone help please?

    Hi Guys,
    I have a SIP trunk setup with a 2811 running CME version 7.  I can make outbound calls ok but having issues getting the incoming calls working, i have 1 number on my SIP trunk and that is 01133501788 and i want that to ring my Cisco 7960 which is running SIP firmware not SCCP.  I have included by config for anyone who can help me, i just want the incoming call to work. 
    Many Thanks.
    Matthew.
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    no aaa new-model
    clock timezone GMT 0
    dot11 syslog
    ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1
    ip dhcp excluded-address 10.10.10.1
    ip dhcp pool DATA_POOL
       network 10.10.10.0 255.255.255.0
       default-router 10.10.10.1
       dns-server 188.92.232.50 188.92.232.100
    ip dhcp pool VOICE_POOL
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.1
       dns-server 188.92.232.50 188.92.232.100
       option 150 ip 192.168.1.1
    ip name-server 188.92.232.50
    ip name-server 188.92.232.100
    no ipv6 cef
    multilink bundle-name authenticated
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      bind control source-interface FastEthernet0/1.20
      bind media source-interface FastEthernet0/1.20
      registrar server
    voice class codec 1
    codec preference 2 g711ulaw
    codec preference 3 g711alaw
    voice register global
    mode cme
    source-address 192.168.1.1 port 5060
    max-dn 144
    max-pool 42
    load 7960-7940 P0S3-8-12-00
    authenticate register
    tftp-path flash:
    create profile sync 0008072514198272
    voice register dn  1
    number 6999
    allow watch
    name SIP
    label SIP
    voice register pool  1
    id mac 000F.902B.40E0
    type 7960
    number 1 dn 1
    dtmf-relay sip-notify
    username cisco password cisco
    codec g711ulaw
    voice translation-rule 1
    rule 1 /^9\(.*\)/ /\1/
    voice translation-rule 2
    rule 1 /^6...$/ /4143*002/
    voice translation-profile DiscardDigit9
    translate calling 2
    translate called 1
    voice translation-profile IncomingSIP
    translate calling 1133501788
    voice-card 0
    no dspfarm
    username matt privilege 15 secret 5 $1$DCD0$SjWqnKgDSGVzzIKRerXh11
    archive
    log config
      hidekeys
    interface FastEthernet0/0
    ip address 194.12.0.222 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1
    no ip address
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1.10
    description DATA
    encapsulation dot1Q 10
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface FastEthernet0/1.20
    description VOICE
    encapsulation dot1Q 20
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 194.12.0.221
    ip http server
    ip http authentication local
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 1 permit 10.10.10.0 0.0.0.255
    tftp-server flash:P003-8-12-00.bin
    tftp-server flash:P003-8-12-00.sbn
    tftp-server flash:P0S3-8-12-00.loads
    tftp-server flash:P0S3-8-12-00.sb2
    tftp-server flash:P003-8-12-00
    tftp-server flash:P003-8-12-00.loads
    tftp-server flash:P003-8-12-00.sb2
    tftp-server flash:SIP000F902B40E0.cnf.xml
    control-plane
    mgcp behavior g729-variants static-pt
    dial-peer cor custom
    dial-peer voice 2 voip
    description Outgoing Geographic
    translation-profile outgoing DiscardDigit9
    destination-pattern 0[7]........
    voice-class codec 1
    session protocol sipv2
    session target dns:sip.cloudcalling.co.uk
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 1 voip
    description IncomingSIP
    translation-profile incoming IncomingSIP
    voice-class codec 1
    session protocol sipv2
    session target dns:sip.cloudcalling.co.uk
    incoming called-number .T
    dtmf-relay sip-notify rtp-nte
    no vad
    sip-ua
    credentials username 4143*002 password 7 password realm sip.cloudcalling.co.uk
    authentication username 4143*002 password 7 password
    nat symmetric role passive
    nat symmetric check-media-src
    calling-info sip-to-pstn number set 4143*002
    no remote-party-id
    retry invite 3
    retry register 3
    timers connect 100
    registrar dns:sip.cloudcalling.co.uk expires 60
    sip-server dns:sip.cloudcalling.co.uk
      host-registrar
    gatekeeper
    shutdown
    telephony-service
    load 7960-7940 P0S3-8-12-00
    max-ephones 24
    max-dn 30
    ip source-address 192.168.1.1 port 2000
    max-conferences 8 gain -6
    web admin system name Admin secret 5 $1$Fktw$t9GQkdDdHmoYdwptO8.or.
    transfer-system full-consult
    create cnf-files version-stamp Jan 01 2002 00:00:00
    line con 0
    line aux 0
    line vty 0 4
    login
    scheduler allocate 20000 1000
    ntp server 85.119.80.232
    end
    Router#

    You my friend are a star! worked straight away, many thanks.  Just one more thing, when i make an outgoing call, it always appears as "blocked" on my phone, my sip trunk is set to allow CME to alter outgoing CLI's how would i program the outgoing CLI to 01133501788 also?
    The new working config is below with your suggestion, which works!
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    hostname Router
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    no aaa new-model
    clock timezone GMT 0
    dot11 syslog
    ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.1.1
    ip dhcp excluded-address 10.10.10.1
    ip dhcp pool DATA_POOL
       network 10.10.10.0 255.255.255.0
       default-router 10.10.10.1
       dns-server 188.92.232.50 188.92.232.100
    ip dhcp pool VOICE_POOL
       network 192.168.1.0 255.255.255.0
       default-router 192.168.1.1
       dns-server 188.92.232.50 188.92.232.100
       option 150 ip 192.168.1.1
    ip name-server 188.92.232.50
    ip name-server 188.92.232.100
    no ipv6 cef
    multilink bundle-name authenticated
    voice service voip
    allow-connections h323 to h323
    allow-connections h323 to sip
    allow-connections sip to h323
    allow-connections sip to sip
    no supplementary-service sip moved-temporarily
    no supplementary-service sip refer
    sip
      registrar server
    voice class codec 1
    codec preference 2 g711ulaw
    codec preference 3 g711alaw
    voice register global
    mode cme
    source-address 192.168.1.1 port 5060
    max-dn 144
    max-pool 42
    load 7960-7940 P0S3-8-12-00
    authenticate register
    tftp-path flash:
    create profile sync 0015244443466064
    voice register dn  1
    number 6999
    allow watch
    name SIP
    label SIP
    voice register pool  1
    id mac 000F.902B.40E0
    type 7960
    number 1 dn 1
    dtmf-relay sip-notify
    username cisco password cisco
    codec g711ulaw
    voice translation-rule 1
    rule 1 /^6...$/ /4143*002/
    voice translation-rule 3
    rule 1 /^01133501788$/ /6999/
    rule 2 /^1133501788$/ /6999/
    voice translation-profile IncomingSIP
    translate called 3
    voice translation-profile Translatetrunk
    translate calling 1
    voice-card 0
    no dspfarm
    username matt privilege 15 secret 5 $1$DCD0$SjWqnKgDSGVzzIKRerXh11
    archive
    log config
      hidekeys
    interface FastEthernet0/0
    ip address 194.12.0.222 255.255.255.252
    ip nat outside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1
    no ip address
    ip nat inside
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet0/1.10
    description DATA
    encapsulation dot1Q 10
    ip address 10.10.10.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface FastEthernet0/1.20
    description VOICE
    encapsulation dot1Q 20
    ip address 192.168.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 194.12.0.221
    ip http server
    ip http authentication local
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet0/0 overload
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 1 permit 10.10.10.0 0.0.0.255
    tftp-server flash:P003-8-12-00.bin
    tftp-server flash:P003-8-12-00.sbn
    tftp-server flash:P0S3-8-12-00.loads
    tftp-server flash:P0S3-8-12-00.sb2
    tftp-server flash:P003-8-12-00
    tftp-server flash:P003-8-12-00.loads
    tftp-server flash:P003-8-12-00.sb2
    tftp-server flash:SIP000F902B40E0.cnf.xml
    control-plane
    mgcp behavior g729-variants static-pt
    dial-peer cor custom
    dial-peer voice 1 voip
    description IncomingSIP
    translation-profile incoming IncomingSIP
    voice-class codec 1
    session protocol sipv2
    session target sip-server
    incoming called-number .T
    dtmf-relay sip-notify rtp-nte
    no vad
    dial-peer voice 2 voip
    description Outgoing Geographic
    translation-profile outgoing Translatetrunk
    destination-pattern 0[7]........
    voice-class codec 1
    session protocol sipv2
    session target dns:sip.cloudcalling.co.uk
    dtmf-relay rtp-nte
    no vad
    sip-ua
    credentials username 4143*002 password 7 password realm sip.cloudcalling.co.uk
    authentication username 4143*002 password 7 password
    nat symmetric role passive
    nat symmetric check-media-src
    calling-info sip-to-pstn number set 4143*002
    no remote-party-id
    retry invite 3
    retry register 3
    timers connect 100
    registrar dns:sip.cloudcalling.co.uk expires 60
    sip-server dns:sip.cloudcalling.co.uk
      host-registrar
    gatekeeper
    shutdown
    telephony-service
    load 7960-7940 P0S3-8-12-00
    max-ephones 24
    max-dn 30
    ip source-address 192.168.1.1 port 2000
    max-conferences 8 gain -6
    web admin system name Admin secret 5 $1$Fktw$t9GQkdDdHmoYdwptO8.or.
    transfer-system full-consult
    create cnf-files version-stamp 7960 Dec 17 2013 14:35:13
    line con 0
    line aux 0
    line vty 0 4
    login
    scheduler allocate 20000 1000
    ntp server 85.119.80.232
    end
    Router#

  • Help needed in receiving  two consecutive msges from SIP Ser in UDP server!

    Hi everyone,
    I am Mitul Gogoi,from Assam,North-east part of India.
    I am writing a SIP proxy server,which is simly a UDP server and which will sit between the Client(X-Lite softphone) and Brekeke SIP Server and just receive and send messages.
    Client---------------->My UDP Server-------------------------->SIP Server (This is for requests)
    again,
    SIP Server---------->My UDP Server-------------------------->Client (This is for responses)
    (couldnot draw the arrows together)
    My server will receive any msg coming from Client in port 7000 from Client and My server will send the msg to SIP Server to its IP address and port 5060.So, I just wanted to change the port number to which Client will send msges;i.e. instead of earlier port 5060,it will now send to port 7000.
    The msg sending and receiving scenerio:
    1.The first msg from Client is received by My Server.
    2.My server sends the msg to SIP Server.
    3.My server then waits for response from SIP server.
    4.One msg comes to My server and received successfully. and it closes the socket.
    5.This msg is sent to Client.
    6.Second msg comes from SIP server to My server.But My server is unable to receive this second msg.maybe because My server closes the socket to receive the next msg.
    I am using ResponseHandler Thread in main which will listen to any msges that may come from SIP server to My server.
    My question is :
    Is it not possible to receive two consecutive msg from SIP server ?
    If one msg comes,it then closes the socket.
    My code for sending and receiving :
    udpClSocket = new DatagramSocket();
    packet = new DatagramPacket(buf, buf.length,InetAddress.getByName(server), port);
    udpClSocket.send(packet);//it will send to SIP Server as well as Client,by changing the server and port
    byte resbuf[] = new byte[msgSize];
    packet = new DatagramPacket(resbuf, resbuf.length);
    udpClSocket.receive(packet);//it will receive msg from SIP server only
    packet = null;
    udpClSocket.close();
    The first msg comes to My server successfully,but the second msg is not being received.
    I have tried in so many ways,such as taking two different ports :one for receiving for Client and My server ,and another port for My server and SIP server.
    If anyone can help me in this ,then I will be highly grateful.
    regards,
    Mitul

    Why? Throw all this code away, and use the NIST reference implementation of JAIN-SIP. They've done all the hard work for you. All you have to do to write a stateless proxy is a little mild header processing.
    Thank you ejp for your reply.Mine is a Outbound SIP proxy server,which uses a port other than default 5060 SIP server port.The client will REGISTER SIP server via my server.and moreover,I want to build my own server at least once for learning purpose.
    maybe because My server closes the socket to receive the next msg.
    Why?
    I donot know why.may be I am very new to network programming or did not do much research in networking.But,my code should work;couldn't find out any fault.
    Here is my code:
    package com.ef;
    import java.net.DatagramPacket;
    import java.net.DatagramSocket;
    import java.net.InetAddress;
    import java.util.Date;
    * It sends UDP packets to following destinations-
    * 1. SIP Server
    * 2. SIP UACs
    public class OBUDPClient extends Thread {
         private DatagramSocket udpClSocket;
         private DatagramPacket packet;
         private String server = "192.168.1.2";//IP of Brekeke SIP server
         private int port = 5060;
    //SIP Message Size
         private int msgSize = 2048;
         private byte buf[];
         private boolean serFlag = true;
         private OBMessage m;
         * Send Request to SIP Server
         * @param in_packet
         * @throws Exception
         public OBUDPClient(DatagramPacket in_packet) throws Exception{
              super("Client-"+String.valueOf((new Date()).getTime()));
              this.buf = in_packet.getData();
              m = new OBMessage();
              * Keep track of IP and Port of the source of this packet. Response
              * from SIP Server will be redirected to this IP and Port
              m.setTargetIP(in_packet.getAddress().getHostAddress());
              m.setTargetPort(in_packet.getPort());
              start();
         * Send Request to SIP UAC (). This constructor gets call from OBResponseHandler.java
         * @param server
         * @param port
         * @param buf
         * @throws Exception
         public OBUDPClient(String server, int port, byte buf[]) throws Exception{
              super(String.valueOf((new Date()).getTime()));
              this.server = server;
              this.port = port;
              this.buf = buf;
              serFlag = false;
              start();
         public void run(){
              try{
              System.out.println("OBUDPClient Redirecting packet");
              udpClSocket = new DatagramSocket();
              //Send Request
              packet = new DatagramPacket(buf, buf.length,InetAddress.getByName(server), port);
              udpClSocket.send(packet);
              //Receive Response
              byte resbuf[] = new byte[msgSize];
              packet = new DatagramPacket(resbuf, resbuf.length);
              udpClSocket.receive(packet); //could not receive two consecutive msg from SIP server
              if(serFlag){
              * If request is sent to SIP Server we are interested for the
              * response otherwise not
              System.out.println("<----------------Handle Response----------------->");
         System.out.println("++++++++++++++++++++++++++++++++++++++++++++++++++");
         System.out.println("Response from SIP Server: "+new String(packet.getData()).trim());
         System.out.println("++++++++++++++++++++++++++++++++++++++++++++++++++");
         //Read SIP reseponse sent by SIP Server
         m.setMessage(new String(packet.getData()).trim());
         //Store the Response message in Queue
         OBMain.q.push(m);
         }catch(Exception ex){
         ex.printStackTrace();
         packet = null;
         udpClSocket.close();
    Note:Everything starts from the Client.First,Client makes a REGISTER request;it is passed through Outbound server to SIP server.Then,SIP server responds with 100 Trying;this is received successfully by my outbound server and sent to Client.Then,again,SIP server responds with 200 OK;this is not received by my outbound server;hence cannot reach Client,as a result of which Registration fails.
    regards,
    mitul

  • Flash to SIP live video - can anyone help?

    We are looking for a simple solution that enables a 2-way
    video call between a SIP client and a browser-based Flash client
    (which grabs the webcam).
    Does anyone have any ideas as to where we should look? Does
    anyone want to build this for us for a fee?
    Help appreciated - this is an immediate requirement so let me
    know if you'd like more details around this.

    I'm interested in doing something similar - bridging FMS to a
    an Asterisk conference. I know breeze has this capability, does
    anyone know if this can be done using FMS?

  • E52 - Nokia SIP VoIP application - help needed

    Hi there,
    I am pretty new here.  I need the Nokia SIP VoIP application for my E52, something like SIP_VoIP_3_1_Settings_S60_3.... .sis
    Where can I get it?
    My problem is, that I can set up easily an VoIP service with my phone and it connects perfectly.  However, I can't use it with my E52 since I can't activitate it on my phone.  I would need the option:  > connection > Internet Tel. Settings   which is not there.
    I guess I need the Nokia SIP VoIP application, however I can't find a compatible version, and the SIP_VoIP_3_1_Settings_S60_5_x_v1_0_en.sis does not work.
    Thanx
    Caristeo

    Although I've never used it, I was able to install the SIP Settings program for my E73 (same OS and Feature Pack as your phone) from http://www.developer.nokia.com/info/sw.nokia.com/id/d476061e-90ca-42e9-b3ea-1a852f3808ec/SIP_VoIP_Se... .  (You need to make an account if you don't have one already.)  Download the "SIP VOIP 3.x" version.  I do have a Settings -> Connection -> SIP Settings option on my phone, as well as Control Panel -> Net Settings -> Advanced VOIP Settings.  Hope that helps.

Maybe you are looking for