Hosting 2 web servers

Is it possible for me to host 2 web servers using 1 public ip, if I do a nat statement to both of them, how will it know which server to use from the outside ?

Hello Carl,
I can see that you have some trouble configuring NAT.
Please check the following link for some usefull information:
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008044eddc.html
But answering your question:
straight link:
Avoiding Server Overload Using TCP Load Balancing
Perform this task to configure server TCP load balancing by way of destination address rotary translation. These commands allow you to map one virtual host to many real hosts. Each new TCP session opened with the virtual host will be translated into a session with a different real host.
SUMMARY STEPS
1. enable
2. configure terminal
3. ip nat pool name start-ip end-ip {netmask netmask | prefix-length prefix-length} type rotary
4. access-list access-list-number permit source [source-wildcard]
5. ip nat inside destination-list access-list-number pool name
6. interface type number
7. ip address ip-address mask
8. ip nat inside
9. exit
10. interface type number
11. ip address ip-address mask
12. ip nat outside
http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008044eddc.html#wp1048769
example:
ip nat pool real-hosts 192.168.15.2 192.168.15.15 prefix-length 28 type rotary
ip nat inside destination list 2 pool real-hosts
interface serial 0
ip address 192.168.15.129 255.255.255.240
ip nat outside
interface ethernet 0
ip address 192.168.15.17 255.255.255.240
ip nat inside
access-list 2 permit 192.168.15.1
All from cisco website.
If this helps, please rate my post.
Thanks,
Vlad

Similar Messages

  • 2 Logical Host, 2 Web Servers, Big Problem?

    I am setting up a sun HA cluster using 2 E4500 servers. I have created 2 logical hosts, each one needs to host a Netscape iPlanet 4.0 web server sitting at port 80. Each logical host is serving up web applications for different clients.
    If I need to fail over one of the logical hosts so that they are both running on the same system, the newly imported instance of the web server will fail because port 80 is already in use by the logical host that is on that physical host.
    At first this seemed totally wrong. Each logical host should be able to run applications on any port they need to. Then someone who has a lot more time on Solaris told me that this was not the case, and each logical host had to steer clear of using the same ports as other logical hosts in the same cluster.
    Can someone clue me into what is reality?
    Any good documentation that tells how to set this stuff up?
    Thanks!
    Bruce

    Hi,
    The best way to resolve this would be to try implementing the same.
    Instead of going through an entire cluster install/configuration
    process, you may want to try setting up two different web servers
    on a single node. You may want to set up a virtual interface (like
    le0:1, hme0:1 etc) for this. You coud then try connecting to
    individual web servers on port 80. If this works, then the two
    webserver/two node cluster implementation should also work.
    Hope this helps.
    Thanks,
    Gopinath.

  • ACE probing of "virtual hosts" on web servers

    We got some web servers that hosts multiple web sites and would like to probe each of these sites.  Is there a way to configure a probe to present the request for a particular web site versus the other without falling into the catch all clause of the http server configured on the box ?
    Thanks

    Hello Folks,
    I wonder if you could get away with just using the built-in HTTP probe rather than the scripted probe?  With the built-in HTTP probe, you can configure all sorts of HTTP headers, including the Host header which might be all you need for your server hosting multiple sites.
    Just to clarify on the support for scripted probes that TAC supports:  If the script is downloaded from cisco.com, and is not modified, then TAC will support it.  It is not supported if it is modified, and TAC will not support custom-created scripts.
    Hope this helps,
    Sean

  • Move and redeploy application- and web-servers for Planing?

    Hi, all!
    Have Hyperion Planing ability to move application- and web-servers from unix-machine to another win-machine and after redeploy existing unix-installed planing on it?

    They are actually for for 2 different things. The Sun WAS is for enterprise applications, EJBs and the like.
    Tomcat is for simpler Servlet/JSP hosting.
    The Sun WAS actually uses the Tomcat server as its Servlet/JSP engine then adds EJBs on top.

  • I'm using a Mac. After swithcing to ICloud will I be able to use IWeb to upload and publish my sites hosted by other servers like Prohosting ?

    I'm using a Mac. After swithcing to ICloud will I be able to use IWeb to upload and publish my sites hosted by other servers like Prohosting ?

    iWeb has two other ways to publish your site...
    http://www.iwebformusicians.com/iWeb/Publish-Website.html
    ... and the second method allows you a choice of how you upload the files...
    http://www.iwebformusicians.com/iWeb/URLs-Favicons.html
    Here's a publishing workflow checklist...
    http://www.iwebformusicians.com/Search-Engine-Optimization/Website-Publishing-Wo rkflow.html
    The MobileMe only features can be replaced by alternatives...
    http://www.iwebformusicians.com/iWeb/Comments-Password-Protect.html
    If you have folders of assets outside of the main website folder on MobileMe, download them from the Apple server. From the Finder Go menu, follow the path iDisk/My iDisk/ to get there. Your website files are in the Web/Sites folder. Drag any files/folders onto the desktop.
    Use an FTP application to upload these assets to the root folder on your new server...
    http://www.iwebformusicians.com/Search-Engine-Optimization/Upload.html
    ...and change the relevant URLs to...
    http://www.domain-name.com/Folder-Name/file-name.file-extension
    There are lots of options for hosting for about half the cost of MobileMe...
    http://www.iwebformusicians.com/iWeb/Website-Hosting.html
    If you have been using a web.me.com domain name, you need to register a new one. Most hosting services give you at least one free and registering with your hosting company will make forwarding and managing it a lot easier.
    Make sure you add the new name to Google and create, upload and enter a new sitemap.xml...
    http://www.iwebformusicians.com/Search-Engine-Optimization/SEO.html
    If you have inbound links on other sites...
    http://www.iwebformusicians.com/Search-Engine-Optimization/Inbound-Link.html
    ... remember to inform the webmasters of you new URL.
    "I may receive some form of compensation, financial or otherwise, from my recommendation or link."

  • Load balancing across 4 web servers in same datacentre - advice please

    Hi All
    Im looking for some advice please
    The apps team have asked me about load balancing across some servers but im not that well up on it for applications
    Basically we have 4 apache web servers with about 2000 clients connecting to them, they would like to load balance connections to all these servers, they all need the same DNS name etc.
    what load balancing methods would I need for this, I believe they run on Linux
    Would I need some sort of device, or can the servers run some software that can do this, how would it work? and how would load balancing be achieved here?
    cheers

    Carl,
    What you have mentioned sounds very straightforward then everything should go well.
    The ACE is a load balancer which takes a load balancing decisions based on different matching methods like matching virtual address, url, source address, etc then once the load balance decision has been taken then the ACE will load balance the traffic based on the load balance method which you have configured (if you do not configure anything then it will use the default which is "round robin"), then it will send the traffic to the servers which it has available and finally the client should get the content.
    If you want to get some details about the load balancing methods here you have them:
    http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/overview.html#wp1000976
    For ACE deployments the most common designs are the following.
    Bridge Mode
    One Arm Mode
    Routed Mode
    Here you have a link for Bridge Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_Bridged_Mode_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Here you have a link for One Arm Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_One_Arm_Mode_with_Source_NAT_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Here you have a link for Routed Mode and a sample for that:
    http://docwiki.cisco.com/wiki/Basic_Load_Balancing_Using_Routed_Mode_on_the_Cisco_Application_Control_Engine_Configuration_Example
    Then as you could see in all those links you may end up having a configuration like this:
    interface vlan 40
      description "Default gateway of real servers"
      ip address 192.168.1.1 255.255.255.0
      service-policy input remote-access
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.16.1.1
    class-map match-all slb-vip
      2 match virtual-address 172.16.1.100 any
    policy-map multi-match client-vips
      class slb-vip
        loadbalance vip inservice
        loadbalance policy slb
    policy-map type loadbalance http first-match slb
      class class-default
        serverfarm web
    serverfarm host web
      rserver lnx1
        inservice
      rserver lnx2
        inservice
      rserver lnx3
        inservice
    rserver host lnx1
      ip address 192.168.1.11
      inservice
    rserver host lnx2
      ip address 192.168.1.12
      inservice
    rserver host lnx3
      ip address 192.168.1.13
      inservice
    Please mark it if it answered you question then other users can use it as reference in the future.
    Hope this helps!
    Jorge

  • ASA single outside IP address to an inbound NAT pool that round robins request to 2 web servers

    How do I create a single outside IP address 1.2.3.4 to an inbound NAT pool that round robins request to 2 web servers?
    I have 2 web server 10.0.0.1 and 10.0.0.2. They have the exact same content.
    I think I start with defining the pool as an object group which contains 2 server 10.0.0.1 and 10.0.0.2
    object-group network appservers
    network-object host 10.0.0.1
    network-object host 10.0.0.2
    What to do next?
    object-group network appservers
    nat (inside,outside) static 1.2.3.4
    gives me an error.

    No, unfortunately you can't configure round robin static inbound NAT for 2 internal web servers.

  • Getting web host name, web-port, oral-report server name and virtual path

    Hi.
    I have been using oralce forms 6i on oracle application server 10g. I have three servers installed on remote locations.I just want that when i am hosting an application on a server, the web host name, web port , oracle report server name and the path of directory should be selected in a dynaminc variable at application level at run time. In this manner, I will be able to make a single application for all three servers. Any other solution to this problem is also welcomed. Please help anyone and oblige me.

    Hi Rajesh,
    Actually Web AS Host name is <Servername>.<domain name>:<Port no>
                 Web AS Path for R/3 is </sap/bc/bsp/sapd>
    Refer the following link.
    <a href="https://forums.sdn.sap.com/thread.jspa?threadID=402561">https://forums.sdn.sap.com/thread.jspa?threadID=402561</a>
    <a href="https://www.sdn.sap.com/irj/sdn/thread?threadID=265076">https://www.sdn.sap.com/irj/sdn/thread?threadID=265076</a>
    Regards
    Hemalatha
    /Assign points if helpful/

  • Protecting Web Servers

    I have a client that hosts websites email me and said they are having hackers place code in script tags or iframe tags on web pages that point to another site where an unsuspecting user would then download malware.
    My question is would CSA be the best solution to protect their web servers? I am open to other suggestions.
    Thanks.
    Dan

    Beside CSA (or any other HIPS like ISS, Mcafee Entercept etc.) you also have to focus on the following:
    > Keep Security Patches for OS and WebServer software/components up to date.
    > Secure Web Programming
    > Vulnerability Assessment using Custom Tools like WatchFire AppScan, Nikto, WebScarab, SPI Dynamics (Forgot the product name), Cenzic Hailstrom, Acunetix etc.
    > Manually validating the various inputs/forms/fields etc. yourself (if possible) or by hiring a professional pen-test company.
    > Other security best practices.
    Regards
    Farrukh

  • Two web servers cant use same port forwarding rule???

    I have two web servers, each configured to respond to http reqests on port 80.  I use NoIP service to map a domain name to my router. I create a port forwarding assignment for Server A by selecting the WebServer rule in the port forwarding rule table.  All is fine.  For Server B, I select the same Webserver rule and the router says there is a conflict.
    I don't understand why.  I think the router has enough information to route a http request for Server B by knowing its MAC address, which is different than Server A MAC address.
    What am I missing here???
    I was able to do this on my previous router with DD-WRT.....
    So it would appear the way to resolve this is to assign a different port address to Server B???
    grrrrrrrrrr I hate this router

    You shouldn't have been able to do that on any router.  You have to change the listening port of server 2, to 8080 or something like that, or make one a secure server and run it over 443
    That is a known issue with port forwarding
    Problem #8:
    Same Port in Multiple Rules
    There are some routers such as Linksys, D-Link and many others that do not do any checks if a port is already in another port forwarding rule. A port can only be forwarded to one Computer/IP at a time. So when there are multiples of the same port number the port forwarding rule will not work.
    Here is an example.
    As you can see port 2350 is in 2 rules. The 1st one points to a different IP than that of the 2nd rule. So the router will honor the 1st rule and the 2nd port forwarding rule to port 2350 fails.
    By removing the 1st rule the 2nd one will now work.

  • CF Licensing on two front end web servers

    I'm currently running CF 9 Standard on a since server that runs as my web and db server.  I use Rackspace Cloud btw.
    I've been thinking about changing my infrustructure around so it would look like this:
    - 1 Load Balancer
    - 2 Web Servers
    - 1 Database Server
    My question is about licensing on the 2 web servers.
    - Is it possible to use a single CF Standard license to cover both web servers (since they are just syncing each other, they are basically the same server but split into two separate virtual machines), or would I need to purchase 2 individual licenses to make this work?
    Any help or advice is appreciated. Thanks!

    Thanks vishu,
    I can read the license agreement, but it's the interpretation of legal wording that I'm having troubles with.  Basically, I'm looking for a real world YES or NO to my question.  I'm sure others have had this question, that's why I came to this forum.
    2.1 General Use. You may install and use one copy of the Software on up to the Permitted Number of your compatible Computers as long as, when required by the Software, you present a valid serial number for each copy; and
    2.2 Distribution from Server. You may copy an image of the Software onto file server(s) within your Internal Network for the purpose of downloading and installing the Software onto Computers within the same Internal Network for use as permitted by Section 2.1; and
    2.3 Server Use. You may install the Software on Computer file server(s) within your Internal Network only for use of the Software initiated by an individual from a Computer within the same Internal Network as permitted by Section 2.1. The total number of users (not the concurrent number of users) able to use the Software on such Computer file server(s) may not exceed the Permitted Numbe

  • What is the recommended ratio of publish nodes to dispatcher web servers for CQ5.5?

    What is the recommended ratio of publish nodes to dispatcher web servers for CQ5.5?
    We are getting conflicting opinions on this form the field. I realize this is a loaded question. I'd like to see how Adobe presents this opinion. In the past scaling at the webserver level was only loosely tied to the publishing layer. Now it seems as dynamic functionality increases the ratio is getting closer to 1:1.
    Also,I'd like to know in what use cases this load on publisher increases dramatically.

    Hello, this is an evergreen. Just call setPickOnBounds(false) on the CustomHexagon.
    An issue tracking this problem is open here: https://javafx-jira.kenai.com/browse/RT-17024

  • CF10 Some pages render blank, No configured web servers

    I'm moving from CF8 to CF10 and having some issues. My CF10 install is a clean install on brand new server running Windows Server 2008 R2 64bit IIS 7.5. I've upgraded to CF version 10,0,11,285437. Out of the 50 or so Apps on the server almost everything works, but there are a few pages that just don't render at all. No error, nothing. Viewing the source for the page just shows an empty HTML page. Coldfusion logs are empty and there's 500 null error in the IIS logs.
    While researching that issue I found many people recommending I rerun wsconfig after patching CF, so I tried that and it looks like my sites aren't configured correctly. During install I configured the sites individually (2 of them run in 32 bit while the cfadmin site runs in 64.) Now when I run the Web Server Configuration Tool as administrator I just get a Configured Web Servers box that is empty. When I click add the next window shows IIS, but the drop down for IIS Web Sites is disabled. Checking the Configure 32 bit web server option doesn't change anything. 99 out of a 100 pages work just fine, so it seems odd that the tool is telling me the server isn't configured. I'm not even sure where to start at this point.
    EDIT: I've read most of the posts related to the wsconfig and none of the solutions presented yet make any difference. ASP.NET, .NET Extensibility, CGI, ISAPI Extensions, ISAPI Filters are all already installed. I've tried reinstalling CF, IIS, even going back to a clean snapshot of he OS several times and the result is always the same. I've even tried it with and without IIS Compatability.
    Edit2: I've figured out the problem with wsconfig (McAfee IPS was preventing it from working.) Unfortunately, even after reconfiguring the servers I'm still getting the blank page problem. Nothing in any of the CF logs and a 500 null error in the IIS logs.

    Hi
    Out of 20, if there are 10 coldfusion (.cfm) pages which are working fine and rest of the 10 are not working fine then you must run the code analyzer to check the error on those pages as you mentioned that you have moved to CF 10 from CF 8.
    Run wsconfig as Run as Admin and then see how many connector showing up there? Like if you have configure webserver with All option, then it will display on 1.
    Thanks
    VJ

  • Use WLS 8.1 to HttpProxyServlet to multiple web servers

    I am trying to set up an environment so my client connects to the WLS server SSL&PKI. The WLS server will then proxy to multiple other web servers so all data returned between WLS and clint is SSL.
                        -------|        |-----|-------------| apache/tomcat 8880
              Client|---------| WLS |
              -------|        |-----|-------------| apache 3443
                                  Here is the problem, I have been successful getting SSL&PKI and proxying to one to work, but not both servers. Each server runs different web server functions, this is not a cluster.
              web.xml and weblogic.xml below
              If I go to https://<WLSserver>:7002/cgi-bin
              It always goes to the second server, it seems as soon as I map a <url-pattern>/</url-pattern> whichever servlet is defined last wins.
              As added note, the client will never be able to connect to the apache and apache/tomcat server directly because the ports are blocked at the router level.
              Is what I trying to do possible? Is there another way to proxy to multiple servers so the data back to the client is always SSL?
              Thanks
              --Sam
              Weblogic.xml
              <context-root>/<context-root>
              web.xml
              <web-app>
              <servlet>
              <servlet-name>ProxyServlet1</servlet-name>
              <servlet-class>weblogic.servlet.proxy.HttpProxyServlet</servlet-class>
              <init-param>
              <param-name>redirectURL</param-name>
              <param-value>
              http://targethost1:8880/
              </param-value>
              </init-param>
              </servlet>
              <servlet-mapping>
              <servlet-name>ProxyServlet1</servlet-name>
              <url-pattern>/</url-pattern>
              </servlet-mapping>
              <servlet-mapping>
              <servlet-name>ProxyServlet1</servlet-name>
              <url-pattern>*.html</url-pattern>
              </servlet-mapping>
              <servlet-mapping>
              <servlet-name>ProxyServlet1</servlet-name>
              <url-pattern>*.htm</url-pattern>
              </servlet-mapping>
              <servlet-mapping>
              <servlet-name>ProxyServlet1</servlet-name>
              <url-pattern>*.jsp</url-pattern>
              </servlet-mapping>
              <servlet>
              <servlet-name>ProxyServlet2</servlet-name>
              <servlet-class>weblogic.servlet.proxy.HttpProxyServlet</servlet-class>
              <init-param>
              <param-name>redirectURL</param-name>
              <param-value>
              http://targethost:3443/
              </param-value>
              </init-param>
              </servlet>
              <servlet-mapping>
              <servlet-name>ProxyServlet2</servlet-name>
              <url-pattern>/</url-pattern>
              </servlet-mapping>
              <servlet-mapping>
              <servlet-name>ProxyServlet2</servlet-name>
              <url-pattern>*.html</url-pattern>
              </servlet-mapping>
              <servlet-mapping>
              <servlet-name>ProxyServlet2</servlet-name>
              <url-pattern>*.htm</url-pattern>
              </servlet-mapping>
              <servlet-mapping>
              <servlet-name>ProxyServlet2</servlet-name>
              <url-pattern>*.jsp</url-pattern>
              </servlet-mapping>
              </web-app>
              Message was edited by bea_samham at Jan 14, 2005 6:02 PM

    I was still investigating. One suggestion is to run multiple server instances, each with its own <conxext-root>/</context-root> in weblogic.xml. This should work because each managed server runs in its own JVM, so you can have multiple context-root's set to /
              I tried marking the case a answered but get javax exceptions, there must be something going on with the forum pages.
              Message was edited by bea_samham at Jan 26, 2005 3:37 PM

  • Setting apache as a front end host-proxy web server for weblogic 10.3.3

    Hi ,
    i have installed apache 2.2.21 in the red hat linux 6 environment.Now i am trying to set that apache web server as a front end host ,proxy web server for my weblogic 10.3 application server cluster. My apache is listening to the port 8080.
    What changes i had to made in admin console of my server as well as in the httpd.conf file of apache.
    Can any one guide me how to proceed ?
    Any help is highly appreciated......

    Thanks Ravi,
    i have already gone through http://docs.oracle.com/cd/E12840_01/wls/docs103/plugins/apache.html.
    In my case "mod_wl_22.so" was not available but i downloaded this p10051826_1033_Generic.zip file from where i got that file and make it available in the modules directory, changed the file permissions (using chmod 755 mod_wl_22.so) and also changed the httpd.conf file as below :
    LoadModule weblogic_module modules/mod_wl_22.so
    <IfModule mod_weblogic.c>
    WebLogicCluster wlserv1:7001,wlserv2.com:7001
    MatchExpression *.jsp
    </IfModule>
    By using /bin/ls command i checked the following :
    /bin/ls: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.18, stripped
    Using file mod_wl_22.so i checked the following:
    mod_wl_22.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped
    My problem is when i used ./apachectl -t i got the following error :
    httpd: Syntax error on line 112 of /u40/app/apache/conf/httpd.conf:
    Cannot load /u40/app/apache/modules/mod_wl_22.so into server: libstdc++.so.5:
    cannot open shared object file: No such file or directory
    So can u please guide me where my problem is and how to rectify it ? Its urgent. please help me.
    Thanks
    Jyoti Ranjan

Maybe you are looking for

  • Transfer Structure - Transport Problem

    Hi Experts, I am transporting infosource from BW DEV to BW QA ( Datasource is transported and it is replicated) but when the request is imported in QA it gives me error saying " Transfer structure does not exist " . This Infosource is used for Remote

  • Best all purpose Audio Video Interface for capturing older Tapes,LP's, VHS?

    I'm looking at the Elgato Video Capture Interface to use with my iMac to transfer both audio and video from Record LP's, Casette Tapes, and VHS.  Wondering if anyone had any experience with getting this unit to capture just audio from an analog sourc

  • Nokia c5- receiving speaker(ear piece) has low vol...

    Y nokia is not increasing ear piece (receiving) volume??? Its almost an year I bought c5, only trouble I have is receiving volume is very low, if it is in traffic I can't hear any thing. I waited for June software update thinkin dis prob will b solve

  • Declaring a var

    I am running into an issue with embedding javascript inside a servlet. I have a method to generate a window to type in text. I want to use javascript to alert the user if they are passing in an invalid char. here is what i have any ideas, thanks in a

  • Is the glossy screen available in the Apple Store?

    Just wondering, is the MBP with the glossy screen available at Apple retail stores or only online?