___How to access database behind firewall with JDBC___

How to access a database behind a firewall? I have an applet that runs from a server behind that firewall. I can make applet-servlet-database calls, but I cannot make applet-database calls. Therefore, I must go through servlets.
This causes a problem as the ResultSet object is not serializable. I have found two solutions using a search.
1) Store info into a Vector and transmit the vector. This option will take up a huge amount of time with large ResultSets.
2) Used sun's CachedRowSet which is serializable. I read the liscence under the CashedRowSet, and it does not allow use for "productive and commercial" use.
Does anyone have any other suggestions I am missing?

I'm pretty sure there are other implementations of CachedResultSet out there that don't have the licensing restrictions on them, so maybe you could hunt down one of those.
As far as storing it in a Collection of some kind, I've never found a huge performance problem in doing so. When iterating through the ResultSet anyway, the additional cost of placing data in a different structure is minimal, even on larger results.

Similar Messages

  • Migrating Access Database to Web WITH FORMS (not just backend)

    How difficult would this be, what steps would be involved and is Dreamweaver capable of helping?
    The server uses IIS and ASP so compatibility should be fine with access.
    I have enough of a programming history to replace vbasic code with ASP code if I read about the language, but would like to do the least amount of work required.

    Lets just say that Access and Oracle are completly different animals and leave it at that. What I believe you need to do is:
    1. Create an Oracle Database using the Database Creation Assistant. (Keep all the Defaults, and keep track of any passwords that are used.
    2. Using the System (DBA) account, crate a user to hold the Access Schema (Never create objects in the SYS account and you shouldn't do that with the SYSTEM account either.
    3. Run the Access Migration Workbench.

  • Can Access Databases be used with Dreamweaver

    I have created a database with Access, and am wondering if it can be used with a site created with Dreamweaver

    You will need to convert it to MySql.
    http://www.mysql.com/why-mysql/white-papers/a-guide-for-migrating-from-microsoft-access-to -mysql/
    Nancy O.

  • SG300-20 behind firewall with two vlans

    Hello,
    i have the following network running: see attachment. The switch has two VLANs, one for the 10. network, the other should be for the 192. network. Now i want to access 10.0.1.11 from 192.168.178.1 but i get blocked by the firewall. The switch is now in the 192.network, but i want to connect the 10.* ports directly to the router. I am grateful for every hint.
    Best regards,
    Rome

    I would recommend adding a 2nd vlan interface to your firewall, and enable inter vlan routing on the firewall.
    It would be good to set a different network segment between the router and firewall,
    It would look something like this.
    router --> firewall vlan1 -->switch vlan1 -->192.168.178.x clients
                    firewall vlan10 -->switch vlan 10 --> 10.0.1.x clients
    You don't say what the router or firewall models are, or the subnet masks...
    The default gateways for the clients would point to the firewall, and it would do intervlan routing.
    Or:
    You can do intervlan routing on the switch.
    set the switch in layer3 mode (this will factory reset the switch).  Set up the 2 client vlans, including dhcp with default gateways for the clients pointing to the switch.
    select a different network segment for the firewall to switch connection (say 192.168.180.x)
    add a route, rules, and nat statements in the firewall for both networks 192.168.178 and 10.0.1.x.
    add a default route in the switch pointing to the firewall.
    that would look something like
    router - firewall -(192.168.180.x) - switch  - vlan 10.0.1.x
                                                                 \- vlan 192.168.178
    This would put the inter vlan routing load on the switch instead of the firewall.
    you can also call in to the small business TAC and request assistance 866-606-1866 in US and Canada.  These devices come with 1 year free tech support.
    Hope this helps,
    Dan

  • How can i load data from access database to datagridview with custom columns all days of a month ?

    Hi guys
    I am newbie in vb net and I want your help to solve a problem.
    I have this datagridview with two columns and all days of a month in custom columns.
    [IMG]http://i59.tinypic.com/2qwpj15.png[/IMG]
    I also have one combobox to change Year and a combobox to change Month.
    Here is the code to load data
    Private Sub fill_plan()
    dgMonth.Rows.Clear()
    Try
    Dim i As Integer = 0
    Dim query As String = "SELECT MonID,Unitname,Personel,Udate FROM tblMonth ORDER BY Unitname"
    con.Open()
    cmd = New OleDbCommand(query, con)
    myDR = cmd.ExecuteReader
    If myDR.HasRows Then
    While myDR.Read
    dgMonth.Rows.Add()
    dgMonth.Rows(i).Cells(0).Value = myDR.GetInt32(myDR.GetOrdinal("MonID"))
    dgMonth.Rows(i).Cells(1).Value = myDR.GetString(myDR.GetOrdinal("Unitname"))
    dgMonth.Rows(i).Cells(2).Value = myDR.GetInt32(myDR.GetOrdinal("Personel"))
    i = i + 1
    End While
    End If
    myDR.Close() : con.Close()
    Catch ex As Exception
    MsgBox(ex.Message, MsgBoxStyle.Critical, "Error")
    End Try
    End Sub
    With
    this code the
    personel column
    loads the first
    day of the month.
    I want to load
    the column the date that is
    in the database.

    Hello,
    This can be done with less code
    Private Sub fill_plan()
    dgMonth.DataSource = Nothing
    Dim dt As New DataTable
    Try
    Dim query As String = "SELECT MonID,Unitname,Personel,Udate FROM tblMonth ORDER BY Unitname"
    con.Open()
    cmd = New OleDbCommand(query, con)
    dt.Load(cmd.ExecuteReader)
    dgMonth.DataSource = dt
    Catch ex As Exception
    MsgBox(ex.Message, MsgBoxStyle.Critical, "Error")
    End Try
    End Sub
    The above loads all rows, if you want to limit the rows placed in the DataGridView this is best done in the SQL via WHERE conditions and/or with SELECT TOP x.
    Formatting of the data is best done via the property window for the DataGridView on whatever column you want too. Using the above you now need to set the data property for each column and set dgMonth.AutoGenerateColumns = False, in the end we end up with
    less code
    edit is there a reason for returning the primary key? If so then using my method we can hide that field but I see no reason for having it in this case
    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem.

  • Problems converting access database to excel

    is there any method to convert access db to excel spreadsheet.
    currently i'm using a 'cheat' way of retrieving the results to a table and convert to excel using this:
    response.setContentType("application/vnd.ms-excel");
    response.setHeader("Content-Disposition","attachment; filename=\"file.xls\";");
    the problem is that i need to delete the records in the database after saving the the excel file. this method does not let me perform response.sendRedirect() method after saving as excel. so, after i retrieve the results into a table, i delete the records in the database and prompt the user to save the excel file. this is risky cos if the user select cancel when prompted to save, the records in the databse will long be gone.
    i need help if anyone could suggest a solution to this.
    1. another method to convert access db to excel spreadsheet , or
    2. the excel file will be saved automatically without having the user to click to save, or
    3. to be able to get to delete the db records after saving.
    i really need the help from you people. thanks.

    I find your problem description confusing.
    Here's what it sounds like you're saying:
    You've got records in an Access database to start with. A user makes a request to see records in a browser. You've got a servlet that queries the Access database using JDBC, turns the result set into a CSV file, sets the content type to "application/vnd.ms-excel", and then displays the response as an MS Excel spreadsheet in the browser.
    So far, so good?
    That sounds like one use case to me - call it "Query Database For Records".
    Then it sounds like you want to implement another use case - call it "Modify Database". You'd like to be able to let the client manipulate the Excel data you've sent down and then resynch with the database when they say they're done.
    Again, okay?
    If that's true, treat them like two separate cases. It sounds like you want to do a multipart file upload of the Excel data where you'd have your servlet take the uploaded data and insert it back into the Access database.
    If I understand you correctly, Access is your persistence mechanism. I don't understand why you'd want to update Access AND save the Excel file. I read this as "I want to have one data source of record with the latest info, and I happen to like sending it down to clients in an Excel spreadsheet because that's what they're used to seeing."
    I'm sure this doesn't help you solve your problem yet, but it might help my understanding of what you're really trying to do here. - MOD

  • Apex with Database XE behind Firewall?

    Hi. I have an Apex application that I would like to put up on the Internet. The associated database must be protected with a firewall between it and the HTTP server. I would like to use the Express Edition (XE) version of the database, at least initially.
    Is it possible with XE to have a listener connect through a firewall to an HTTP Server?

    Absolutely, wasn't talking about the internet facing firewall in the DMZ but the inner firewall between the OHS/Apex Listener server and Database. Obviously the best solution is to have a reverse proxy server in the DMZ (i.e. between inner and outer firewalls) and the OHS and database on the internal side of the DMZ.
    First case Standard HTTP or HTTPS port open on the outer DMZ firewall to OHS/Apex Listener Server obviously better to be HTTPS, SQLNET listener port to access Database on the inner firewall better if it's a not the standard 1521
    Second Case Standard HTTP or HTTPS port open on the outer DMZ firewall to reverse proxy server, non-standard HTTP(s) e.g. 7777 to OHS server on the inner firewall there would be no firewall between OHS and Database in this case.

  • Accessing application 11.5.7  through internet and behind firewall

    Hi,
    We are going to install Oracle application 11.5.7 on Sunsolaris 8 on Single Node. We want to access our application through internet i.e www.abc.com/myapplications, is it possible. what are the prerequistes for this.
    And one more thing, our application are going to be behind firewall. what are all the precautions do I need to take before I install.
    Are there any documents in the metalink or in any other website.
    Any help on this is highly appreciated.
    Thanks
    Giri

    shailendra
    in apps when you are connecting to database using sqlplus you should mention the service name too.this could be generally your sid name , for example : system/manager@prod.
    regarding your second query sysadmin is the default username created by apps to carry out the system administration , and this user has number of responsibilities defined , out of which application developer is one such responsibility. so when you login using this username then you have to metion to the apps by what responsibility you want to carry with you.
    if you want to directly login to application developer responsibility ,then create one user and assign him this responsibility. login with this user.
    Any way you have one more default user is there called operations and password is welcome
    hope this will helps you , pls get back with ur comments.
    Note: I request all the working APPS DBA's to share their knowledge in this forum.
    regards
    srinivas

  • PAT with a single public IP and several servers behind firewall

    Hi,
    New to the ASA 5505 8.4 software version, but here is what I'm trying to do:
    Single static public IP:  16.2.3.4
    Need to PAT several ports to three separate servers behind firewall
    One server houses email, pptp server, ftp server and web services: 10.1.20.91
    One server houses drac management (port 445): 10.1.20.92
    One server is the IP phone server using a range of ports: 10.1.20.156
    Basically, need to PAT the ports associated with each server to the respective servers behind the ASA 5505. 
    Here is what I have.  Is anything missing from this config? Do I need to include a global policy for PPTP and SMTP?
    ASA Version 8.4(4)1
    hostname kaa-pix
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 10.1.20.1 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 16.2.3.4 255.255.255.0
    ftp mode passive
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    object network server_smtp
    host 10.1.20.91
    object service Port_25
    service tcp source eq smtp
    object service Port_3389
    service tcp source eq 3389
    object service Port_1723
    service tcp source eq pptp
    object service Port_21
    service tcp source eq ftp
    object service Port_443
    service tcp source eq https
    object service Port_444
    service tcp source eq 444
    object network drac
    host 10.1.20.92
    object service Port_445
    service tcp source eq 445
    access-list acl-out extended permit icmp any any echo-reply
    access-list acl-out extended permit icmp any any
    access-list acl-out extended permit tcp any interface outside eq pptp
    access-list acl-out extended permit tcp any object server_smtp eq smtp
    access-list acl-out extended permit tcp any object server_smtp eq pptp
    access-list acl-out extended permit tcp any object server_smtp eq 3389
    access-list acl-out extended permit tcp any object server_smtp eq ftp
    access-list acl-out extended permit tcp any object server_smtp eq https
    access-list acl-out extended permit tcp any object server_smtp eq 444
    access-list acl-out extended permit tcp any object drac eq 445
    pager lines 24
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    nat (inside,outside) source static server_smtp interface service Port_25 Port_25
    nat (inside,outside) source static server_smtp interface service Port_3389 Port_
    3389
    nat (inside,outside) source static server_smtp interface service Port_1723 Port_
    1723
    nat (inside,outside) source static server_smtp interface service Port_21 Port_21
    nat (inside,outside) source static server_smtp interface service Port_443 Port_4
    43
    nat (inside,outside) source static server_smtp interface service Port_444 Port_4
    44
    nat (inside,outside) source static drac interface service Port_445 Port_445
    object network obj_any
    nat (inside,outside) dynamic interface
    route outside 0.0.0.0 0.0.0.0 16.2.3.1 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    user-identity default-domain LOCAL
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    telnet timeout 5
    ssh timeout 5
    ssh key-exchange group dh-group1-sha1
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    prompt hostname context
    no call-home reporting anonymous

    Thanks Lcambron...I got PPTP to work.  Everything else works fine.  I can access email, access my web server, FTP server, and PPTP server.  However, from the above configuration, I cannot access my DRAC over the internet..The DRAC runs on a different internal server, and over port 445.  So I have th following lines:
    object network drac
    host 10.1.20.92
    object service Port_445
    service tcp source eq 445
    access-list acl-out extended permit tcp any object drac eq 445
    nat (inside,outside) source static drac interface service Port_445 Port_445
    Am I missing something here?  Internally, i can telnet to port 445 on 10.1.20.92, so I know it is listening.  However, externally, i cannot telnet to my external ip address of the ASA through port 445. 
    Thanks

  • Issue with Adobe flex data.xml file not reachable from bsp behind firewall

    Hi Gurus,
    I have a problem with the <mx:HTTPService> tag the following is the actual tag,
    <mx:HTTPService
    id="Srv"
    url="data.xml"
    useProxy="false"
    method="POST" result="resultHandler(event)"/>
    When accessed locally I can see the data in the flex as the data.xml can be reached. when the same is accessed from internet behind firewall, the url is entirely different and the .swf file in the BSP page cannot access the data.xml. I cannot give the absolute url in the tag as the BSP page application is accessed differently in different servers. any help on this would be greatly appreciated
    Thanks
    Akbar

    Sorry somehow I missed this question, an even easier way to do this is to allow your Flash movie to "script" ( this is the default behavior for a Flex application ) and then call some javascript to obtain exactly what the page URL is and then go from there to get your data:
    import flash.external.ExternalInterface;
    import mx.utils.URLUtil;
    var
    if(ExternalInterface.available){
         pageURL = ExternalInterface.call("window.location.href.toString");
    // Do whatever you need with the URL here.
         var serverName:String = URLUtil.getServerNameWithPort(pageURL);
    -d

  • SQL Query with MS-Access Database

    Hi,
    I have linked my oracle database with MS-Access via a DB LINK. i can access the data from MS-ACCESS, but i have a problem that when i specify the column name or define a where clause in my query it gives me the error ORA-00904: invalid identfier ..
    This query fetch the data without any problem SELECT * FROM TBLREPORT@M_ACCESS but when i run SELECT EMP_ID FROM TBLREPORT@M_ACCESS it gives me the error i mentioned above. (Column name have No problem or mistake of spelling even CASE)
    also when i try to put where clause in the query it gives me same error SELECT * FROM TBLREPORT@M_ACCESS WHERE EMP_ID = '100' (Error)
    is there any change in SQL query for ACCESS database ??
    any clue
    Regards
    Rehman

    Are column/table names in access case sensitive? Issue
    DESC TBLREPORT@M_ACCESS If column EMP_ID actual name shows up in mixed/lower case, enclose it in double quotes and use the exact case. E.g., if column name shows up as Emp_Id, use:
    SELECT "Emp_Id" FROM TBLREPORT@M_ACCESSSY.

  • To connect oracle database with ms access database

    i want to connect oracle database with ms access database
    i have follow the following steps
    1. create ms access database.
    2. create system dsn.
    3. make change in listener.ora.
    4. make change in hs folder.
    5.change the tnsname.ora.
    6. lsnrctl stop and lsnrct start.
    7. create database link in oracle sql*plus.
    8.select the table of ms access
    but i have return the foloowing error.
    ORA-12154: TNS:could not resolve the connect identifier specified
    using window 2000, oracle 10g

    Have a look on ths thread, may it helps ...
    Re: copy access data into oracle with form builder 9i

  • Help needed with populating a drop-down list from an Access Database

    Topic
    data drop-down list
    Jason Murthy - 11:39am Feb 14, 2005 Pacific
    Hello,
    I am trying to use the data drop-down list from the custom library. I enter the name of my data connection and the other 2 variables in quotes when they are initialized, just like the example says to, but it still doesn't work. Anyone have any thoughts?
    Thanks,
    Jason
    Reply To This Discussion | Back to Topic List | Bookmark | Change Subscription
    To start a NEW discussion click on the Back to Topic List link and select Add Topic.
    If you are in an archive forum please go up to the main topic list (archives are read only).
    Messages 11 messages. Displaying 10 through 11.
    First Previous Next Last Show All Messages
    Denzil White - 5:46am Jul 28, 05 PST (#10 of 11)
    Oh and before you say anything more I have also tried changing it from Javascript to the FormCalc, and no diff, maybe I am more stupid than I realised, heh,heh
    Post Reply | Bookmark
    Henk Pisuisse - 12:06am Aug 9, 05 PST (#11 of 11)
    I am having trouble (sleepless nights) with populating a drop-down list from an Access Database. The result is: I only get the first record from the data connection. So the connection works but I cannot go through the other records. Maybe there is an other way to do this.
    I am trying to selectively fill a form with data from an MS-access database.
    I hope someone can help me.
    [email protected]
    The Netherlands (small country in Europe)

    If you email the access DB and the form to [email protected], I will try to take a look at it for you.

  • Size limit of access database with image files stored outside database

    I have read 2GB limit on size of Access database.  We are using Access 2013 database with fields that are data type attachment and storing attached images outside the database.  Does the size of the folder that is holding these images count
    in any way toward 2GB size limit?

    Hi,
    As far as I know, Access database limit size 2GB based on itself, not related to the folder size.  Attachment data
    type is similar to attaching files to e-mail messages. We need to control the Access database size is smaller then 2GB.
    When a field is defined with the attachment data type, you can store one or more files for each record in it.
    Attachments can dramatically increase the size of the database, but since the attached file is stored as a part of the dabatbase, you are not dependent on network drives being available as you would be if you inculded a hyperlink to the file. As a matter of
    fact, feel free to backup the origainal file to other disk after you attach it to the database.
    Regards,
    George Zhao
    TechNet Community Support

  • Logon failed with an Access Database

    Hello,
    I am trying to create a Crystal Reports application that allows the user to view previously created reports (.rpt files).  When I use a .rpt file that has a absolute path for the access database files, it works perfectly.  If I use a .rpt file that uses a relative path (i.e. set the database location in the report to 'same as report') the report prompts me to enter the logon information.  If I cancel those dialogs, I get a logon failed error.
    The application copies the .rpt files and access database files and places them in a specific directory.
    I know, for a fact, that the reports work in another program and in the Crystal Reports designer.  I just don't know why I get this error with this application.
    I am using Crystal Reports XI to create the reports.
    The databases are created using Access 95 (I cannot change this)
    The development computer is Windows 7 64bit
    The IDE is Visual Studio 2008 SP1
    The .net language is C#
    Any help would be greatly appreciated.

    Well, that did allow me to set the location.  I am recieving one error when I do that though.  I believe that it has to do with the fact that the file extension for one of the databases doesn't end with the default .mdb.  I solved this, but then I get an error when trying to load a specific report:
    Failed to load database: 0xce0
    Invalid Join Operation
    Would this be due to the change in the databas name?  I wouldn't think so but I want to be sure.  Other reports work perfectly (of course, the report with the error is the important one!).  And the report that gives the error works in the designer and other applications as well.
    Please let me know if I need to start a new thread on this.

Maybe you are looking for

  • My ratings aren't getting synced????

    Anyone know what is up with this? I am trying to sync my ipod nano 3rd GEN with songs that I have rated (on the ipod), and the sync goes just fine (set to "sync selected playlists") but none of the rating changes I have made on the ipod transfer back

  • Bug 5088398 for JDK 1.5 in SOLARIS SPARC 10

    The above bug relates to a java.lang.instrument TCK test deadlock (test11). The bug was solved about a month ago (March, 2008). My question is when it is going to be integrated in solaris 10 patches or maybe there is already a patch for it. Thank you

  • Special sound when emails arrives on a particular account/mailbox

    Hi, I have a email account where I'm receiving URGENT alarms. So, I'd need two things : 1) To check this IMAP box more frequently than every 15mins 2) I need to change the alarm-sound for this particular box Could somebody here suggest these type of

  • Can't find UIX Demos

    it seems that there has been a zip-File with UIX-demos but I can't locate it. Or is the UIX-framework no longer supported ?

  • FM 10: Downloading of trialversion doesn' t work

    Hey, I am from Germany. I want to download the trialversion of Framemaker 10. But that isn' t working. What can I do? Thanks, lola