How to configure multiple outgoing interfaces + NAT + PfR

Hello,
I have the following config running on Cisco2851.
Five interfaces (four ADSL and one LAN 10Mb/s) connected to Internet using pppoe.
Local policy is used to make working route tracking.
The PfR also configured to load balance traffic coming from LAN to Internet.
PAT is also configured with "oer" keyword at the end of string to not relocate working translations.
But the router is not performing good. :-(
After investigation I found that the selection of the exit interface and setting source ip for
NAT is not synchronized. The provider's router just drops the incoming packet due to uRPF check.
Also, the selection of the exit interface is not PFR aware (mode select-exit best) during
NAT session setup, and router selects one of the possible exit interfaces randomly.
I have two questions:
1. How to make synchronization of NAT and Routing to build matching pair of Out_IP=Out_Interface and make my setup working?
2. How to select the less loaded interface during setup of NAT phase and Routing phase and really involve PfR?
Actually, these two questions is just my one requirement: during setup of NAT session, I need
to find less loaded interface (PfR should check current rx/tx load), select it, and keep it untouched.
Thanks,
Sergey
Config:
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
hostname bif
boot-start-marker
boot system flash:c2800nm-adventerprisek9-mz.151-4.M8.bin
boot-end-marker
enable secret 5 $1$3ggj$huERPVt0luOX6qo6
no aaa new-model
crypto pki token default removal timeout 0
dot11 syslog
no ip source-route
ip cef
no ip domain lookup
ip domain name zzz.mgm
no ipv6 cef
multilink bundle-name authenticated
key chain PFR
 key 0
  key-string 7 107E2F2B
voice-card 0
pfr master
 logging
 border 192.168.254.254 key-chain PFR
  interface Dialer5 external
  interface Dialer4 external
  interface Dialer3 external
  interface Dialer2 external
  interface Dialer1 external
  interface GigabitEthernet0/0 internal
 mode select-exit best
pfr border
 logging
 local Loopback0
 master 192.168.254.254 key-chain PFR
license udi pid CISCO2851 sn FCZ0929
username se privilege 15 secret 5 $1$DUbm$RuZKP8X.19uBtm21
username ru privilege 15 secret 5 $1$1V.h$iotp/bjhUg4ho93d
redundancy
ip ssh version 2
track 1 ip sla 1 reachability
 delay down 30 up 15
track 2 ip sla 2 reachability
 delay down 30 up 15
track 3 ip sla 3 reachability
 delay down 30 up 15
track 4 ip sla 4 reachability
 delay down 30 up 15
track 5 ip sla 5 reachability
 delay down 30 up 15
interface Loopback0
 ip address 192.168.254.254 255.255.255.255
interface GigabitEthernet0/0
 description ### LAN ###
 ip address 192.168.68.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 ip flow ingress
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
interface GigabitEthernet0/1
 description ### WDSL link to Dialer 5 ###
 no ip address
 duplex auto
 speed auto
 pppoe enable group global
 pppoe-client dial-pool-number 5
interface ATM0/0/0
 description ### DSL link 1 to Dialer 1 ###
 no ip address
 no atm ilmi-keepalive
 shutdown
 pvc 1/32
  pppoe-client dial-pool-number 1
interface ATM0/1/0
 description ### DSL link 2 to Dialer 2 ###
 no ip address
 no atm ilmi-keepalive
 pvc 1/32
  pppoe-client dial-pool-number 2
interface ATM0/2/0
 description ### DSL link 3 to Dialer 3 ###
 no ip address
 no atm ilmi-keepalive
 pvc 1/32
  pppoe-client dial-pool-number 3
interface ATM0/3/0
 description ### DSL link 4 to Dialer 4 ###
 no ip address
 no atm ilmi-keepalive
 pvc 1/32
  pppoe-client dial-pool-number 4
interface GigabitEthernet1/0
 description ### Virtual interface to NME-16ES-1G-P ###
 ip address 192.168.254.253 255.255.255.254
interface Dialer1
 description ### Dialer for line 1 ###
 bandwidth 224
 bandwidth receive 1728
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 load-interval 30
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname
 ppp chap password
 no cdp enable
interface Dialer2
 description ### Dialer for line 2 ###
 bandwidth 224
 bandwidth receive 1728
 ip address negotiated
 ip mtu 1492
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 2
 ppp authentication chap callin
 ppp chap hostname
 ppp chap password
 no cdp enable
interface Dialer3
 description ### Dialer for line 3 ###
 bandwidth 224
 bandwidth receive 1728
 ip address negotiated
 ip mtu 1492
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 3
 ppp authentication chap callin
 ppp chap hostname
 ppp chap password
 no cdp enable
interface Dialer4
 description ### Dialer for line 4 ###
 bandwidth 224
 bandwidth receive 1728
 ip address negotiated
 ip mtu 1492
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 4
 ppp authentication chap callin
 ppp chap hostname
 ppp chap password
 no cdp enable
interface Dialer5
 description ### Dialer for WDSL line ###
 bandwidth 10000
 bandwidth receive 10001
 ip address negotiated
 ip mtu 1492
 ip flow ingress
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 load-interval 30
 dialer pool 5
 ppp authentication chap callin
 ppp chap hostname
 ppp chap password
 no cdp enable
ip local policy route-map LOCAL-PBR
no ip forward-protocol nd
no ip http server
no ip http secure-server
ip nat inside source route-map NAT1 interface Dialer1 overload oer
ip nat inside source route-map NAT2 interface Dialer2 overload oer
ip nat inside source route-map NAT3 interface Dialer3 overload oer
ip nat inside source route-map NAT4 interface Dialer4 overload oer
ip nat inside source route-map NAT5 interface Dialer5 overload oer
ip nat inside source static tcp 192.168.68.160 22 $$$Dialer5-IP$$$ 2222 extendable
ip nat inside source static tcp 192.168.68.160 22 $$$Dialer2-IP$$$ 2222 extendable
ip nat inside source static tcp 192.168.68.160 22 $$$Dialer3-IP$$$ 2222 extendable
ip nat inside source static tcp 192.168.68.160 22 $$$Dialer4-IP$$$ 2222 extendable
ip nat inside source static tcp 192.168.68.230 21 $$$Dialer1-IP$$$ 21 extendable
ip nat inside source static tcp 192.168.68.160 25 $$$Dialer1-IP$$$ 25 extendable
ip nat inside source static tcp 192.168.68.22 143 $$$Dialer1-IP$$$ 143 extendable
ip nat inside source static tcp 192.168.68.22 443 $$$Dialer1-IP$$$ 443 extendable
ip nat inside source static tcp 192.168.68.160 22 $$$Dialer1-IP$$$ 2222 extendable
ip route 0.0.0.0 0.0.0.0 Dialer1 track 1
ip route 0.0.0.0 0.0.0.0 Dialer2 track 2
ip route 0.0.0.0 0.0.0.0 Dialer3 track 3
ip route 0.0.0.0 0.0.0.0 Dialer4 track 4
ip route 0.0.0.0 0.0.0.0 Dialer5 track 5
ip sla 1
 icmp-echo 8.8.8.8 source-ip $$$Dialer1-IP$$$
 timeout 1000
 frequency 5
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo 8.8.8.8 source-ip $$$Dialer2-IP$$$
 timeout 1000
 frequency 5
ip sla schedule 2 life forever start-time now
ip sla 3
 icmp-echo 8.8.8.8 source-ip $$$Dialer3-IP$$$
 timeout 1000
 frequency 5
ip sla schedule 3 life forever start-time now
ip sla 4
 icmp-echo 8.8.8.8 source-ip $$$Dialer4-IP$$$
 timeout 1000
 frequency 5
ip sla schedule 4 life forever start-time now
ip sla 5
 icmp-echo 8.8.8.8 source-ip $$$Dialer5-IP$$$
 timeout 1000
 frequency 5
ip sla schedule 5 life forever start-time now
access-list 100 permit ip any any
access-list 101 permit ip host $$$Dialer1-IP$$$ any
access-list 102 permit ip host $$$Dialer2-IP$$$ any
access-list 103 permit ip host $$$Dialer3-IP$$$ any
access-list 104 permit ip host $$$Dialer4-IP$$$ any
access-list 105 permit ip host $$$Dialer5-IP$$$ any
access-list 199 permit ip 192.168.68.0 0.0.0.255 any
route-map LOCAL-PBR permit 10
 match ip address 101
 set interface Dialer1
route-map LOCAL-PBR permit 20
 match ip address 102
 set interface Dialer2
route-map LOCAL-PBR permit 30
 match ip address 103
 set interface Dialer3
route-map LOCAL-PBR permit 40
 match ip address 104
 set interface Dialer4
route-map LOCAL-PBR permit 50
 match ip address 105
 set interface Dialer5
route-map LOCAL-PBR permit 100
 match ip address 100
 set global
route-map NAT3 permit 10
 match ip address 199
 match interface Dialer3
route-map NAT2 permit 10
 match ip address 199
 match interface Dialer2
route-map NAT1 permit 10
 match ip address 199
 match interface Dialer1
route-map NAT5 permit 10
 match ip address 199
 match interface Dialer5
route-map NAT4 permit 10
 match ip address 199
 match interface Dialer4
control-plane
mgcp profile default
line con 0
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 session-timeout 15
 login local
 transport input all
line vty 5 15
 session-timeout 15
 login local
 transport input all
scheduler allocate 20000 1000
end
Show ip route:
sh ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "static", distance 1, metric 0 (connected), candidate default path
  Routing Descriptor Blocks:
    directly connected, via Dialer5
      Route metric is 0, traffic share count is 1
  * directly connected, via Dialer3
      Route metric is 0, traffic share count is 1
    directly connected, via Dialer4
      Route metric is 0, traffic share count is 1
    directly connected, via Dialer2
      Route metric is 0, traffic share count is 1
Log:
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Stateful Inspection(5), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Ingress-NetFlow(21), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Virtual Fragment Reassembly(25), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Access List(31), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Virtual Fragment Reassembly After IPSec Decryption(39), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, MCI Check(80), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=192.168.68.2 (GigabitEthernet0/0), d=8.8.4.4, len 66, input feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, TCP Adjust MSS(82), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: FIBipv4-packet-proc: route packet from GigabitEthernet0/0 src 192.168.68.2 dst 8.8.4.4
*Apr 16 07:04:18.103: FIBfwd-proc: Default:0.0.0.0/0 process level forwarding
*Apr 16 07:04:18.103: FIBfwd-proc: depth 0 first_idx 3 paths 4 long 0(0)
*Apr 16 07:04:18.103: FIBfwd-proc: try path 3 (of 4) v4-ap-Dialer5 first short ext 0(-1)
*Apr 16 07:04:18.103: FIBfwd-proc: v4-ap-Dialer5 valid
*Apr 16 07:04:18.103: FIBfwd-proc: Dialer5 no nh type 3  - deag
*Apr 16 07:04:18.103: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Dialer5 nh none deag 1 chg_if 0 via fib 0 path type attached prefix
*Apr 16 07:04:18.103: FIBfwd-proc: packet routed to Dialer5 p2p(0)
*Apr 16 07:04:18.103: FIBipv4-packet-proc: packet routing succeeded
*Apr 16 07:04:18.103: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if Dialer5 nh none uhp 1 deag 0 ttlexp 0
*Apr 16 07:04:18.103: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if Dialer5 nh none uhp 1 deag 0 chgif 0 ttlexp 0 rec 0
*Apr 16 07:04:18.103: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Post-routing NAT Outside(24), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, Stateful Inspection(27), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.103: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.103:     UDP src=61183, dst=53, CCE Post NAT Classification(38), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.107:     UDP src=61183, dst=53, Firewall (firewall component)(39), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.107:     UDP src=61183, dst=53, TCP Adjust MSS(50), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.107:     UDP src=61183, dst=53, NAT ALG proxy(55), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.107:     UDP src=61183, dst=53, Post-Ingress-NetFlow(68), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.107:     UDP src=61183, dst=53, Dialer idle reset(84), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), len 66, output feature
*Apr 16 07:04:18.107:     UDP src=61183, dst=53, Dialer idle reset(85), rtype 1, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Dialer5), g=8.8.4.4, len 66, forward
*Apr 16 07:04:18.107:     UDP src=61183, dst=53
*Apr 16 07:04:18.107: IP: s=$$$Dialer4-IP$$$ (GigabitEthernet0/0), d=8.8.4.4 (Virtual-Access3), len 66, sending full packet
*Apr 16 07:04:18.107:     UDP src=61183, dst=53

hi,is this question is ok?
if you forget do this config like below:
pfr master
learn
delay
throughput
periodic-interval 3
monitor-period 1
pfr master
delay threshold 200
jitter threshold 50 
mode route control 
mode monitor passive
mode select-exit best 
i will do like this,four ADSL connect a switch ,this switch connect a router 2911(with data license)
at 2911 do four  pppoe
i want to load balance at this four adsl.

Similar Messages

  • Configuring multiple dynamic interfaces in 5508

    Hi,
    I have 5508 controller where as ap-manager interface configuration is optional but since i have different topology at other end , I have 4507 configured with HSRP and i want to divide the AP traffic in both the switches therefore I will have to go ahead and configure multiple AP-manager interface and map with two different physical ports.
    But I have challenge to configure multiple dynamic interfaces.
    I want to create two wlans ( Internal wlan and guest wlan )
    Internal WLAN : 192.168.10.0
    default gateway : 192.168.10.1
    internal DHCP server : 172.16.10.1
    Physical Port : ............... ?  which port to configure ? ( I have connectivity with port 1 & port 2 )
    Guest WLAN : 192.168.20.0
    Default gateway : 192.168.20.1
    Internal DHCP server : 172.16.10.1
    Physical port :  ............... ?  which port to configure ? ( I have connectivity with port 1 & port 2 )
    I want to map it to multiple ports of dynamic interfaces for client traffic to physical ports.
    how do i configure it ?

    In adition to Nico's answer, I would go throught the detailed guide for the configuration of dynamic interfaces:
    http://www.cisco.com/en/US/docs/wireless/controller/7.0/configuration/guide/c70mint.html#wp1167723.
    HTH,
    Tiago
    If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

  • How to configure multiple domains in Active directory

    HI,
    How can I configure multiple domains on Active Directory. When I installed AD it asked for a domain name, there I gave ravigupta.com as domain name. But now I find no way of creating another domain.
    I am a java developer and my task is to write a programme which returns all the domains available in LDAP server.
    To start with ,I tried to create few domains in LDAP server ( AD ) but stuck up ,as i found there could exist only one domain.
    Please tell me how to configure multiple domains in LDAP server ( Active Directory).
    I skiped DNS configuration while AD installation.
    -ravi

    I'm sorry, but you should be asking on a different forum. This has nothing to do with Java.

  • How to configure multiple listeners to listen for the same instance.

    Hello everyone,
    I am running oracle database 11g and I want information regarding how to configure multiple listeners to listen for the same database instance. Actually I know how to configure more than one listener but the main thing that I am confused about is when we create listener.ora file, do we have to statically register the database instance with both the listeners or the instance will register itself with both the listeners.
    According to my knowledge the instance will register with the listener specified by LOCAL_LISTENER parameter and we cannot have more than one value for this parameter.
    Please only give detailed answers with example as I am tired of simple answers with details that I already know.

    Hello,
    Yes, it can make sense to have several listener for one Oracle instance. For instance you may have one listener for the applications another listener for DBA administration tasks as well as one listener dedicated to dataguard broker. It is not possible to have several listeners listening on the same IP and Port.
    By default the database try to automatically register to a listener on port 1521. To instruct the instance to register to a specifc list of listeners you can add in the init.ora the local_listener parameter with an alias definition:
    i.e
    local_listener=MY_SET_OFF_LISTENERS
    in your tnsname.ora add an entry called:
    MY_SET_OFF_LISTENERS_LOCAL= (ADDRESS_LIST=
    (ADRESS=(PROTOCOL=TCP)(HOST=myhostname)(PORT=1530))
    (ADRESS=(PROTOCOL=TCP)(HOST=myhostname)(PORT=1531))
    (ADRESS=(PROTOCOL=TCP)(HOST=myhostname)(PORT=1532))
    In this sample your instance will register to three listeners listening on respectively port 1530, 1531 and 1532
    If you want your clients can be balanced over the 3 listeners

  • How to configure multiple databases in single listener

    Hi,
    I want to configure upto 8 standby databases in a server. But I do not know how to configure multiple databases within the listener.
    Also can I use the same port number for all the databases.
    please give your suggestions.
    thankyou
    satyanag

    Please check (http://download.oracle.com/docs/cd/B10501_01/network.920/a96580/toc.htm)
    Jonathan Ferreira
    http://oracle4dbas.blogspot.com

  • How to configura multiple ldap server to the sun access manager

    Hi,
    please help how to configure multiple ldap server to the sun access manager, for example access manager does't find the user in ldap1 then it should search in ldap2.
    Thanks
    Mouli

    There�s no need for deleting the default amSDK based datastore because it�s needed for some default accounts.
    You may try to create the datastore using the commandline (amadmin)
    Have a look /etc/opt/SUNWam/config/xml/idRepoService.xml
    You may also try to create amadmin account in the external ldap directory.
    (Un)fortunately i�ve never tried to remove the default datastore.
    -Bernhard

  • How to configure multiple IP addresses on one NIC?

    Hi,
    I just installed a OVM Server in version 3.2.1 and the according VMManager. Now i wanted to try to configure the Server/Server Pool. Now i come across a problem, which was already a big problem in OVM 2 while configuring the Networks.
    All our OVM Servers have three NICs in them. One is for VMs and Management, the others are for connection to our SAN (Dell PowerVault MD 3220i). My problem is, that due to the network setup, the two NICs for storage need two IP addresses in two different networks each. This shouldn't be a problem, because usually in linux all you have to do is configure something like eth1:1. I remember having huge trouble configuring it in our OVM 2 cluster up to the point where I had to write a shell script to configure the second IP.
    Anyways, I have configured two of the storage networks on eth1 and eth2 of the VM Server. Now i cannot configure any more IP addresses, because eth1 and eth2 are not available anymore for configuration in a third network. I really hoped that it would be possible in OVM 3 to configure multiple IP addresses. And probably it is only my lack of knowledge of how to configure it.
    So any advice is well appreciated.
    Thanks!
    Regards,
    Marek Hubatka

    You should be able to do this by using "VLAN Groups".
    http://docs.oracle.com/cd/E35328_01/E35332/E35332.pdf
    Check out the VLAN groups section. You must great the VLAN groups before you can assign them to interfaces.

  • How to handle multiple inbound interfaces with WSDL messages

    Hi All,
    We have a synchronous: Abap Proxy -> XI -> WebService Scenario. The webservice has multiple SoapActions e.g. SearchForProduct_WithX, SearchForProduct_WithY each with different message types. We have tried to use the receiver determination to send the request to the correct soapaction using conditions e.g. if field X in the request is populated use SearchForProduct_WithX action/message.
    But when we run it through the proxy we get this error:
      <CODE>IF_DETERMINATION.TOO_MANY_IIFS_CASE_BE</CODE>
      <ERRORTEXT>Multiple inbound interfaces not supported for synchronous calls</ERRORTEXT>
    Does anybody know how we can get around this or how best to deal with the multiple soap actions per wsdl situation.

    Hi Yaghya,
    We have used conditions in the Interface Determination. Interestingly if we use an HTTP sender adapter we can use this configuration ... but once we try and use ABAP proxies we get the previous error.
    Another related question ... when we use the http adapter we get a connection time out exception. Same thing happens if we try and use the wsdl tester at /wsnavigator but we can open the wsdl through the browser. Any idea on this one?
    Thanks for all your help.

  • How to configure multiple IP-Adresses on one NIC in OVM

    Hi guys,
    we have some OVM Servers 2.2.1 installed. They all have three NICs in them (eth0-2). For eth0 and eth2 we need multiple IP-Adresses configured to work with our storage solution. The configuration should look like this:
    eth0:0 - 192.168.31.x
    eth0:1 - 192.168.33.x
    eth1 - 192.168.0.x
    eth2:0 - 192.168.32.x
    eth2:1 - 192.168.34.x
    I tried creating gonfig files ifcfg-eth0:0 in /etc/sysconfig/network-scripts with the following content
    DEVICE=eth0:0
    BOOTPROTO=static
    ONBOOT=yes
    NETMASK=255.255.255.0
    IPADDR=192.168.31.3
    TYPE=Ethernet
    HWADDR=00:1b:21:06:f0:fa
    But it does not work. Neither eth0:0 nore an additional xenbr is configured when i restart.
    I can configure multiple ip addresses for xenbr0 by calling something like "ifconfig xenbr0 192.168.31.x". But these settings get lost as sonn as i reboot the server.
    I have already searched google, forums and blogs for a solution but could not find one. I thought that this should be a pretty common task. In "normal" linux it is not an issue at all.
    Has somebody any experience with a setup like this? I would really apreciate your help.
    Thanks
    Marek

    Hi,
    configuring IP aliasses seems to work the same way like configuring VLANs. You will have to configure the appropriate bridges at system startup manually.
    E.g. this little script is what I use to configure VLANs and briges on my OVM:
    #!/bin/bash
    echo "Configuring VLANs and bridges\n"
    echo "Configuring VLAN 24 on eth2"
    vconfig add eth2 24
    brctl addbr br2.24
    brctl addif br2.24 eth2.24
    ifconfig eth2.24 up
    ifconfig br2.24 up
    echo "Configuring VLAN 31 on eth2"
    vconfig add eth2 31
    brctl addbr br2.31
    brctl addif br2.31 eth2.31
    ifconfig eth2.31 up
    ifconfig br2.31 up
    This script is run at startup by init using this startup skript in /etc/init.d, which is what I think you're missing as you can already seem to bring up the needed IPs manually - you'd have to change the chkconfig accordingly, that is make sure that the config script gets startet after the network has been brought up, like this: # chkconfig: 2345 11 91
    [root@oraclevm01 ~]# cat /etc/init.d/vlan-config
    #! /bin/bash
    # vlan-config configure VLANs
    # chkconfig: 2345 11 89
    # description: Configures VLANs at boot time before the \
    # network is started.
    ### BEGIN INIT INFO
    # Provides: $vlan
    ### END INIT INFO
    # Source function library.
    . /etc/init.d/functions
    if [ ! -f /etc/vlan-config ]; then
    exit 0
    fi
    # See how we were called.
    case $1 in
         start)
                   # configure vlans
                   /etc/vlan-config
              echo $"Usage: $0 {start}"
              exit 1
    esac
    exit 0
    Hth,
    budy
    Edited by: budachst on Jun 29, 2011 8:11 AM

  • How to Configure Multiple Purchase Requisitions per Service Order

    Hi experts!
    Sorry if this is in the wrong spot, but I was wondering how I can configure multiple Purchase Requisitions to be created from a service or maintenance order (IW31) based on the control key (or if it's even possible).
    What would be the pros and cons of doing this?  We currently only have one PR being created for one order (a 1-to-1 relationship), however now with implementing external services, we want 2 or more PRs created based on the control key.  Is the control key the best way to go, or should I be looking at a different deciding field?
    Thanks in advance!
    Stephanie

    Raj,
    Thank you so much for the information.  That does help!  However business requirements are now changing to have different Purchase Requisitions created for a single order in the following scenarios:
                 - New Purchase Req created for different operations (you explained how above, perfect!)
                 - Seperate Purchase Req created for non-stock items (your answer above seems to group service operations and non-stock into the same Purchase Req).
                 - New Purchase Req created if the order has already been released.  (If the order's status is still at "Create", then the additional component can be appended to the existing Purchase Req.  If the order's status is "Released", and a new component is added, a new Purchase Req is created).
    As mentioned, you explained how to do the first requirement.  Is there anyway SAP can handle the next two requirements using standard config and not customizing anything?
    Thanks in advance!
    Steph

  • How to configure the web interface of service desk

    Hi All,
    We are currently doing a configuration on solman service desk. I am on a stage where in i need to use the web interface of service desk via tcode notif_create_bsp. However, every time i call the transaction code (call the url) i cant view the web. Only an error the "Network Access Message: The website cannot be found".
    I already activate needed services and already publish
    SIAC_PUBLISH_ALL_INT but it still doesnt work.
    I might have missed some configs/procedure on how to do it correctly.
    My questions are.
    1. How am i going to know the qualified domain name
    of the Web AS for solman? How to configure it?
    2. Can anyone give me some guide and any step by step documentation/procedure on this.
    You help/suggestion will be very much appreciated
    Thank you very much,
    Ice

    Hi,
    +"Check the following 2 things. See if the port 8000 is open and in the url for the BSP in internet explorer, replace the host name with the IP address of your Solman server.+
    +"+
    That was a helpful tip. I change the host name with the ip address ofour solman server. However, upon login, it promts me to enter username and password. I've tried to login using my solman password but it shows an error like this.
    Business Server Page (BSP) error
    What happened?
    Calling the BSP page was terminated due to an error.
    SAP Note
    The following error text was processed in the system:
    Die URL enthält keine vollständige Domainangabe (10.123.161.125 statt 10.123.161.125.).
    Exception Class CX_FQDN
    Error Name 
    Program CX_FQDN=======================CP
    Include CX_FQDN=======================CM002
    ABAP Class CX_FQDN
    Method CHECK
    Line 10 
    Long text -
    Error type: Exception
    Your SAP Business Server Pages Team
    Is there anything i need to configure so that i can maintan the username and password?
    Thank you for your assistance,
    Ice

  • How to configure multiple dev environment in single IP

    HI,
    I have a WLS running on a Windows NT machine. I want to configure multiple partition/environment
    in that single WLS so that each user will have their own partition/environment to
    play around. Once they are happy with their EJBs then we shall move them to a testing
    environment. Is that possible in WLS??. Can anyone please guide me to a good documentation
    about this one.
    Many Thanks
    Vasan.
    PS: I dont want a clustering technology all i want is that in a single ip i wanna
    multiple development environment.

    Tom,
    looks like you are specifying http protocol in
    sky.framework.ejb.SkySessionBean.getInitialContext method.
    Change it to t3 or, if the JNDI lookup is in the same JVM, don't specify
    PROVIDER_URL. If you have to use http tunneling due to any reason , you have to
    enable HTTP Tunneling in server to which initial context is created. It is
    disabled by default in 60. You can do so via console. Please refer to
    documentation , let me know if you need additional help.
    Viresh Garg
    Principal Developer Relations Engineer
    BEA Systems
    Tom Purcell wrote:
    Kevin,
    You said that with 6.0 the following happens:
    On the second server I get an error when I do
    http://host:secondServerPort/index.html
    Is this the error you get on the Admin Server:
    <Feb 28, 2001 12:42:24 PM EST> <Info> <HTTPTunneling> <Login rejected with
    code: 'Failed', reas
    on: You are trying to use http tunneling
    The server will not let you connect'>
    <Feb 28, 2001 12:42:24 PM EST> <Error> <HTTP> <Problem dispatching servlet
    request
    weblogic.common.T3Exception: You are trying to use http tunneling
    The server will not let you connect
    at weblogic.socket.TunnelLogin.rejectConnection(TunnelLogin.java:87)
    at weblogic.socket.TunnelLogin.service(TunnelLogin.java:59)
    at
    weblogic.servlet.internal.MuxableSocketHTTP.dispatch(MuxableSocketHTTP.java:
    467)
    at
    weblogic.socket.NTSocketMuxer.processSockets(NTSocketMuxer.java:638)
    at
    weblogic.socket.SocketReaderRequest.execute(SocketReaderRequest.java:23)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:137)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
    >
    And on the Managed Server:
    <Feb 28, 2001 12:42:24 PM EST> <Error> <ConnectionManager> <Could not
    connect to: '0S:127.0.0.1
    :[-1,7001,-1,-1,-1,-1,-1]'
    java.net.ProtocolException: Tunneling result unspecified - is the HTTP
    server at host: 'localho
    st' and port: '7001' a WebLogic Server?
    at
    weblogic.rjvm.http.HTTPClientJVMConnection.handleNullResponse(HTTPClientJVMC
    onnectio
    n.java:152)
    at
    weblogic.rjvm.http.HTTPClientJVMConnection.connect(HTTPClientJVMConnection.j
    ava:194)
    at
    weblogic.rjvm.http.HTTPClientJVMConnection.createConnection(HTTPClientJVMCon
    nection.
    java:98)
    at weblogic.rjvm.Protocol.createConnection(Protocol.java:207)
    at
    weblogic.rjvm.ConnectionManager.findOrCreateConnection(ConnectionManager.jav
    a:997)
    at
    weblogic.rjvm.ConnectionManager.bootstrap(ConnectionManager.java:364)
    at
    weblogic.rjvm.ConnectionManager.bootstrap(ConnectionManager.java:330)
    at
    weblogic.rjvm.RJVMManager.findOrCreateRemoteInternal(RJVMManager.java:228)
    at weblogic.rjvm.RJVMManager.findOrCreate(RJVMManager.java:188)
    at
    weblogic.rjvm.RJVMFinder.findOrCreateRemoteServer(RJVMFinder.java:180)
    at weblogic.rjvm.RJVMFinder.findOrCreate(RJVMFinder.java:149)
    at weblogic.rjvm.ServerURL.findOrCreateRJVM(ServerURL.java:207)
    at
    weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialCon
    textFact
    oryDelegate.java:232)
    at
    weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialCon
    textFact
    oryDelegate.java:174)
    at
    weblogic.jndi.WLInitialContextFactory.getInitialContext(WLInitialContextFact
    ory.java
    :123)
    at
    javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:668)
    at
    javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:246)
    at javax.naming.InitialContext.init(InitialContext.java:222)
    at javax.naming.InitialContext.<init>(InitialContext.java:198)
    at
    sky.framework.ejb.SkySessionBean.getInitialContext(SkySessionBean.java:112)
    at
    sky.framework.ejb.SkySessionBean.setSessionContext(SkySessionBean.java:94)
    at
    sky.ejb.session.skyreferencesession.SkyReferenceSessionBeanImpl.setSessionCo
    ntext(Sk
    yReferenceSessionBeanImpl.java:87)
    at
    weblogic.ejb20.internal.StatelessEJBHome.createBean(StatelessEJBHome.java:22
    9)
    at
    weblogic.ejb20.pool.StatelessSessionPool.createBean(StatelessSessionPool.jav
    a:90)
    at
    weblogic.ejb20.pool.StatelessSessionPool.getBean(StatelessSessionPool.java:7
    5)
    at
    weblogic.ejb20.manager.StatelessManager.preInvoke(StatelessManager.java:67)
    at
    weblogic.ejb20.internal.BaseEJBObject.preInvoke(BaseEJBObject.java:113)
    at
    weblogic.ejb20.internal.StatelessEJBObject.preInvoke(StatelessEJBObject.java
    :55)
    at
    sky.ejb.session.skyreferencesession.SkyReferenceSessionBeanEOImpl.setDataSou
    rce(SkyR
    eferenceSessionBeanEOImpl.java:22)
    at
    sky.ejb.session.skyreferencesession.SkyReferenceSessionBeanEOImpl_WLSkel.inv
    oke(SkyR
    eferenceSessionBeanEOImpl_WLSkel.java:161)
    at
    weblogic.rmi.internal.BasicServerAdapter.invoke(BasicServerAdapter.java:373)
    at
    weblogic.rmi.cluster.ReplicaAwareServerRef.invoke(ReplicaAwareServerRef.java
    :128)
    at
    weblogic.rmi.internal.BasicServerAdapter.invoke(BasicServerAdapter.java:237)
    at
    weblogic.rmi.internal.BasicRequestHandler.handleRequest(BasicRequestHandler.
    java:103
    at
    weblogic.rmi.internal.BasicExecuteRequest.execute(BasicExecuteRequest.java:1
    7)
    at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:137)
    at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
    >
    Thanks,
    Tom
    <Feb 28, 2001 12:42:24 PM EST> <Info> <ConnectionManager> <Bootstrap unable
    to get a: 'Protocol
    : 'http'' connection to: 'localhost/127.0.0.1' on port: '7001'>
    "Kevin Apte" <[email protected]> wrote in message
    news:[email protected]...
    This advice applies to WL5.1. I have been trying to configure a
    multiinstance Weblogic with no success. I want multiple copies
    of the sample petStore available for test by multiple users.
    I think in 6.0
    You would need to open an admin server
    Open the configuration file for say PetStore.
    Clone the petStore- call it petStore2. .
    Create a copy of the startup script and modify it to start PetStore2.
    After doing this only one config.xml is created for both servers.
    I am able to start the first server and view the petStore application,
    On the second server I get an error when I do
    http://host:secondServerPort/index.html
    How does one create multiple instances in WL6.0 using the console
    or using a XML editor ?
    Jesse E Tilly <[email protected]> wrote:
    [This followup was posted to weblogic.developer.interest.management
    and
    a copy was sent to the cited author.]
    In article <[email protected]>, [email protected]
    says...
    HI,
    I have a WLS running on a Windows NT machine. I wantto configure multiple partition/environment
    in that single WLS so that each user will have theirown partition/environment to
    play around. Once they are happy with their EJBs thenwe shall move them to a testing
    environment. Is that possible in WLS??. Can anyoneplease guide me to a good documentation
    about this one.
    Many Thanks
    Vasan.
    PS: I dont want a clustering technology all i wantis that in a single ip i wanna
    multiple development environment.
    NT isn't a multiuser environment. I will assume that
    you mean some
    Win32 box sitting in a room where people can copy their
    classes/EJBs and
    test their stuff. If this is the case, the setup is easy.
    Create a directory and startup script for every developer.
    Have a
    global properties file in the same directory as the scripts
    so that
    common settings are, well, common. Tell each user to
    modify the various
    parts of the properties files in their directories to
    deploy EJBs and
    register servlets, etc etc.
    In each startup script, you will have to specify the server
    directory
    and the binding port for each person. Pick a port (something
    easy to
    remember and high, like 30000, 30001, etc etc) for each
    person. Why?
    Well, when they connect to the app server, they'll know
    they're hitting
    only their server. Also, TCP/IP won't let more than one
    JVM bind to the
    same port, so if you want simultaneous instances (> 4
    you better have
    one kick ass Win32 box) you have to do this.
    Hope this solves your problem.
    JT
    Senior Developer, HotelTools INC
    [email protected]

  • How to configure multiple smtp servers per domain

    Hi,
    how do we configure multiple smtp servers per domain/corporate in iplanet messaging server 5.2. i wanted to do this so that i can configure some domains with virus scanning and some domains without antivirus.

    Hi Martin,
    Well we are trying to run a report without exactly specifying the name of reports server anywhere, e.g. in database or in form or anywhere else. Now if I do not supply a reports server name using RUN_REPORT_OBJECT, the error it displays is FRM-41211: Integration Error : SSL failure ... However if I specify the reports server name in the form, the reports run perfect. Also the name of reports server is specified in rwservlet.properties.
    Now the question goes as follows:
    Can I run my report from Form without specifying the name of the Reports server anywhere at all. This is so because either an in-process reports server should be picked or the one which is entered in rwservlet.properties should be pickec up by default. Please correct us if we are wrong. once we are through with it, we have to move to Oracle 10gR2 concept of reports server.
    Thanks in anticipation,
    Ruchi/Saurabh

  • How to configure multiple report servers in Oracle 10 G R2?

    I want to configure multiple report servers with my application deployed on Oracle 10G R2. Since R2 does not support report server clustering, how can this be achieved without any change in the application?
    Currently, the application is running with single report server.

    Hi Martin,
    Well we are trying to run a report without exactly specifying the name of reports server anywhere, e.g. in database or in form or anywhere else. Now if I do not supply a reports server name using RUN_REPORT_OBJECT, the error it displays is FRM-41211: Integration Error : SSL failure ... However if I specify the reports server name in the form, the reports run perfect. Also the name of reports server is specified in rwservlet.properties.
    Now the question goes as follows:
    Can I run my report from Form without specifying the name of the Reports server anywhere at all. This is so because either an in-process reports server should be picked or the one which is entered in rwservlet.properties should be pickec up by default. Please correct us if we are wrong. once we are through with it, we have to move to Oracle 10gR2 concept of reports server.
    Thanks in anticipation,
    Ruchi/Saurabh

  • ASA 5510 Configuration. how to configure 2 outside interface.

    Hi 
    I Have Cisco 5510 ASA and from workstation I want create a new route to another Router (Outside) facing my ISP.
    From Workstation I can Ping ASA E0/2 interface but I cant ping ISP B router inside and outside interface.
    I based all my configuration on the existing config. which until now is working 
    interface Ethernet0/0
     description outside interface
     nameif outside
     security-level 0
     ip address 122.55.71.138 255.255.255.2
    interface Ethernet0/1
     description inside interface
     nameif inside
     security-level 100
     ip address 10.34.63.252 255.255.240.0
    interface Ethernet0/2
     description outside interface
     nameif outsides
     security-level 0
     ip address 121.97.64.178 255.255.255.240
    global (outside) 1 interface
    global (outsides) 2 interface ( I created this for E0/2)
    nat (inside) 0 access-list nonat
    nat (inside) 1 10.34.48.11 255.255.255.255 (Working: To E0/0 to Router ISP A inside and outside interface)
    nat (inside) 2 10.34.48.32 255.255.255.255 (Working: To E0/2 to Router ISP A inside interface only but outside cant ping).
    route outside 0.0.0.0 0.0.0.0 122.55.71.139 1 (Working)
    route outside 10.34.48.32 255.255.255.255 121.97.64.179  1 (Test For New Route)
    ISP Router A working Can ping and I can access the internet
    interface FastEthernet0/0
     description Connection to ASA5510 
     ip address 122.55.71.139 255.255.255.248
     no ip redirects
     no ip proxy-arp
     ip nat inside
     duplex auto
     speed auto
    interface S0/0
     ip address 111.54.29.122 255.255.255.252
     no ip redirects
     no ip proxy-arp
     ip nat outside
    ip nat inside source static 122.55.71.139 111.54.29.122
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0/0
     ISP 2
    interface FastEthernet0/0 ( ASA Can ping this interface)
     description Connection to ASA5510 
     ip address 121.97.64.179 255.255.255.248
     no ip redirects
     no ip proxy-arp
     ip nat inside
     duplex auto
     speed auto
    interface E0/0 ( ASA Can 't ping this interface)
     ip address 121.97.69.122 255.255.255.252
     no ip redirects
     no ip proxy-arp
     ip nat outside
    ip nat inside source static 121.97.64.179 121.97.69.122 
    ip http server
    ip classless
    ip route 0.0.0.0 0.0.0.0 E0/0
    CABLES
    ASA to ISP Router B ( Straight through Cable)
    ISP Router to IDU ( Straight through Cable)
    Hope you could give some tips and solution for this kind of problem thanks

    Hi,
    You can only use a single Default route on the ASA device.
    Now , as per your requirement ,
    route outside 10.34.48.32 255.255.255.255 121.97.64.179  1 (Test For New Route)
    (Why do you have this route on the ASA device ?) I see this in the Inside interface Subnet.
    Route lookup would be Destination based.
    Are you looking to route specific traffic out thru the "outsides" interface ?
    If yes , this configuration would not work unless you use some workaround configuration on the ASA device.
    Refer:-
    https://supportforums.cisco.com/document/59986/loadbalancing-dual-isp-asa
    https://supportforums.cisco.com/document/49756/asapix-load-balancing-between-two-isp-options
    Thanks and Regards,
    Vibhor Amrodia

Maybe you are looking for

  • How to generate web svc data control from WSDL in 10.1.3 to secure web svc

    When I try to connect to web service via https, I get the error: WARNING: Unable to connect to URL: https://remove.site.com/service java.security.PrivilegedActionException: javax.xml.soap.SOAPException: Message send failed: javax.net.ssl.SSLException

  • HT1420 How can I see a list of which computers I have authorized?

    How can I see a list of which computers I have authorized? 

  • Bdc's

    hi expert's plz solve my doubt, 1. in real time which method do u prefer call transaction or session method why? plz tell me with real time scenario plzz.....     ii. in call transaction how many records can we uploaded  exactly, i mean is there any

  • How to insert or update to user_type fields

    hi all, i created an user type as, create or replace type file_ty as object(name varchar2(100), content blob); file_ty is created. and a table which is using this type, create table issues (id number primary key, subj varchar2(20), area varchar2(20),

  • Change view

    Hello All, I need to create two web dynrpo iviews based on a single database table.One is a read view which everyone can access and one is an admin iview which only someone who has the admin role assigned to him can access. Can i check for roles at r