Immediate  actions

Hi all,
Ok this is my problem.
i have a cancel button on my page that should bypass validation and refresh all the data on the page.
So i know immediate actions occur after the apply request values phase
but it seems that the getter values arn't called when an immediate action is invoked so my immediate method which refreshes the local data doesn't work as the local data is never called to repopulate the model.
What approach can i take to bypass the validation phase but still do all the rest?

I have the same type of problem but its little different In my case. I need to
skip the PROCESS_VALIDATION phase.
Please help. My post is
http://forum.java.sun.com/thread.jspa?threadID=708758&tstart=0
My problem is when the items in a selectiononelistbox is empty and if i click the back button on the browser and then click a command button. The validation phase is trying to do something and i dont understand what is happening.
I have reproducible example here.
http://forum.java.sun.com/thread.jspa?threadID=708758&tstart=0
Please help.
Thanks
--Aron                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

Similar Messages

  • After J1IIN Creation of Excise Invoice, wat is the next immediate actions

    after J1IIN Creation of Excise Invoice, wat is the next immediate actions/activities with respective to SD Point of view.
    In each level wat r the things of updations happen upto end of Excise process in SD
    WAT R THE THINGS R TO BE CHECKED IN EACH LEVEL

    Hi,
    for SD point of view we only do the RG1 extraction and printing only.
    If u want to see the Updation of RG1 check the Table:  j_1irg1. Here u can find the values that are updated.This can be updated only after the Extraction of the RG1.
    Printing the RG1 go to T.Code : J2I6
    Prininting of the Excise Invoice : J1IP.
    I hope this will clarify u r doubts.
    regards.

  • Incident/Accident log - Immediate Action taken

    Hi,
    can anyone explain me where to record immediate actions taken against an incident or accident.
    thanks in advance
    kavi

    Hi Ravi,
    You can use the following methods to  solve your problem:
    1. In the Investigation tab, u will find the Root cause tree.. For each node, you can link the Safety Measures.
    2. Provide the Action details in More accident data tab
    3. If you need a new tab, create a new Value assignment type in the Customizing, assign it to Object type "IAL - Incident/ Accident Log entry" and then you can provide Free text or assign phrases as Immediate actions taken (If you opt for Phrase Management).
    Hope it Helps,
    Raghu

  • How to update an HTMLSelectManyCheckbox from an immediate action

    We are creating a News system where the news entries contain tags to identify the contents.
    The entry form contains:
    * "Title" - a required text field
    * "Tags" - an HtmlSelectManyCheckbox that displays the already selected Tags and allows the user to deselect Tags.
    * "Tag Name" - a text field for the user to enter the name of a tag to be added.
    * "Add Tag" - a button that calls a method on my managed bean to add the tag to the entry
    When I added the "required" attribute to the title the "add tag" button would no longer work when the title was null. I fixed this by binding the "tag name" to a HTMLInputText component on my managed bean and marking both the "add tag" button and "Tag Name" field as "immediate". This introduced problems that I have yet been unable to solve.
    First, since the "immediate" flag is set, the HtmlSelectManyCheckbox does not get updated and the newly added checkboxes are not selected.
    Second, it would be useful to have the htmlSelectManyCheckbox component updated when the "Add Tag" button is clicked. This way the unselected checkboxes would be removed.
    Is there anything I can do to make the "tags" HTMLSelectManyCheckbox act as though the form was submitted and update normally (without having the title component processed) so no validation error is thrown?
    Any help would be appreciated, Thanks!
    Relavant Portions of my ManagedBean
    public class NewsEntryFacade implements JSFReturnCodes {
         @EJB
         TagManagerLocal tagManager;
         private Long id;
         private String title;
         private HtmlInputText tagNameInput;
         private List<Tag> tags;
          * <p>
          * Add a tag to the list and then redraw the page.
          * </p>
         public String addTag() {
              String lTagName = (String) tagNameInput.getValue();
              if (lTagName != null && lTagName.trim().length() > 0) {
                   Tag lTag = tagManager.getTagForName(lTagName.trim());
                   /* Add the tag to the collection */
                   ArrayList<Tag> lTags = new ArrayList<Tag>();
                   lTags.addAll(tags);
                   lTags.add(lTag);
                   setTags(lTags);
                   /* Sort the Collection of Tags */
                   Collections.sort(tags);
                   /* Clear the tagName field */
                   tagNameInput.setValue("");
              return RETURN_TO_PAGE;
    }Relavant portions of the facelets xhtml file.
    <h:messages showDetail="true" />
    <h:form>
         <h:inputHidden value="#{newsEntryFacade.id}" />
         <p>
              <h:outputLabel for="title" value="Title" styleClass="formElementLabel" />
              <h:inputText value="#{newsEntryFacade.title}" id="title" required="#{true}" styleClass="formElementTextInput" />
         </p>
         <fieldset>
              <legend>Tags</legend>
              <h:outputLabel for="tagName" value="Tag Name" styleClass="formElementLabel" />
              <h:inputText immediate="#{true}" value="#{newsEntryFacade.tagName}" id="tagName" />
              <h:commandButton immediate="#{true}" action="#{newsEntryFacade.addTag}" value="AddTag" />
              <h:selectManyCheckbox value="#{newsEntryFacade.tags}" converter="tagConverter" layout="pageDirection">
                   <c:forEach var="tag" items="#{newsEntryFacade.tags}">
                        <f:selectItem itemLabel="#{tag.name}" itemValue="#{tag}" />
                   </c:forEach>
              </h:selectManyCheckbox>
         </fieldset>
         <h:commandButton action="#{newsEntryFacade.save}" value="Submit"></h:commandButton>
    </h:form>

    You may find this article useful: http://balusc.blogspot.com/2007/12/action-dependent-requireness.html

  • Populating an inputtext after immediate action

    I'm having a problem trying to implement this functionality:
    I have one page on which I have a data table with (for example) cars. Underneath I have a panel grid with outputtext (labels) and inputtext fields which allow the user enter all the details necessary to add a new car.
    But what I'm trying to do is have the data table entries (car names) be links, which when clicked will populate all of the inputtext fields with the values of the car details, and then allow the user to edit the details.
    How I've tried to do this, is to value bind the inputtext values to a car object that is in my backing bean class. The car links are set to immediate (so that the empty inputtext fields won't validate), and the method that is called sets the car object which the fields are value bound to, to populate based on the row data of the selected row in the data table (the car).
    Debugging shows that the car object IS populated correctly with all the values, but when the page re-renders, all of the inputtext fields are blank, they are not populated with the values of the car object they are bound to.
    Does someone know what I'm missing, or how this is supposed to be done?
    Thanks.
    Edit: I should specify that I'm using JSF 2.0
    Edited by: a-rex on Feb 25, 2010 6:25 AM

    I hope this code will solve your problem
    import java.io.*;
    import java.util.*;
    public class ReadDVDFile
        String MName;
         String Gener;
         String Actor;
         ReadDVDFile(String m, String g, String a){
              MName = m;
               Gener = g;
               Actor = a;
         public static void main(String[] args){
                ArrayList al = new ArrayList();
         try{
            File dvd = new File("e:\\DVDInfo.txt");
            BufferedReader br = new BufferedReader(new FileReader(dvd));
            String s;
            while((s = br.readLine()) != null){
            String[] result = s.split("/");
               al.add(new ReadDVDFile(result[0],result[1],result[2]));
              }  // end of while
         catch(Exception e){
               System.out.println(e);
           Iterator i = al.iterator();
           int j = 1;
            System.out.println("printing contents of ArrayList");
            while(i.hasNext()){
                 ReadDVDFile rd = (ReadDVDFile) i.next();
              System.out.println(j + " " + rd.MName + ";" + rd.Gener + ";" + rd.Actor );
               j++;
    }

  • HT4623 After updating my iPhone5 with latest iOS7, the rear camera became blurry. Anyone can advise to correct this problem that happened on updating of iOS7??? This was really a mesh of APPLE and they have to take immediate action...

    I tried reset of my iPhone5 but the same problem happened... Paging APPLE Support please help us with this problem of your software/hardware....

    Do you have a case on your device?

  • Payment was made with requested info changes, but my Skype, still shows Action Alert

    Skype stated that date on my credit card (for annual auto payments) was ending. 3 days ago I entered required info re: my updated card (good to 07-1 and paid. Soon as I paid, message from Skype appeared, saying they'd send me an email. That has not arrived; also, when I get into my Skype, message is still there re: immediate action required, my card was running out before next auto payment in September. So what happened to my payment????

    First thing to always do is write a Certified Return Receipt letter or just copy the post you made and send it to Verizon Wireless and dispute it in writing.
    Then walk down to your local court and file a small claims court case against Verizon for all the fraudulent charges. Verizon will call you before that court case and then it may be possible to get this wiped off your account.
    Also file a BBB complaint http://www.bbb.org
    Again Verizon will contact you to offer to settle. Get the settlement in writing not verbal. Or proceed to court.
    Sorry you are going through hell for something you should never have had to go through.
    Good Luck

  • Contracts info is not getting updated in VEDA table

    Hello Firends,
    Please find below my issue in detail:
    I have created two contracts : one created first ( ex:1111) and then wrt to this I created another one (ex:1112),
    When I run the table VEDA , sytem is fetching all the info of the first contract but not the second one's info as shown below,
    contract 1111 has line items 00000,00010,00020,00030
    contract 1112 also has line items 00000,00010,00020,00030
    but when I run VEDA table , sytem is displaying as shown below :
    1111   00000
    1111   00010
    1111   00020
    1111   00030
    1112   00000
    Please provide your valuable inputs,
    Immediate action will be apprecaited,
    Thanks in advance.
    Thanks & Regards
    Suresh Kumar T

    Hello Siva,
    Thanks alot for your inputs but there were many contracts created long back and now I am trying to pull out those with VEDA table where I am unable to do it and also tried with newly created one where I am facing the same problem.
    Thanks & Regards
    Suresh Kumar T

  • Failed installation of Avast

    Trying to install the latest Avast on a MBA running 10.9.5. No sign of any problems. Machine running fine. I had installed Avast on another machine of his and it did some good, so he wanted it on his MBAir.
    The problem, the installer fails at the final stage with a completely generic message that's no help.
    Looking at the console log, lead me to believe a couple things:
    - Perhaps it was tripping over a permission problem.
    - or perhaps it wasn’t happy that Chrome was not installed.
    One specific log line item says (which might be the key if someone can interpret, my Google searches haven't been able to untangle):
    "CoreServicesUIAgent: Error: qtn_file_apply_to_path error: Read-only file system"
    So, here are the things the DIDN'T solve the problem
    1) repaired permissions
    2) installed Chrome
    3) repaired home permissions
    4) restarted
    5) turned off Gatekeeper
    6) redownloaded installer
    7) ran Disk Repair, which led me to booting into Recovery Mode to fix a couple directory structure mismatches.
    Any ideas what else it could be tripping up this install?
    I don’t have enough experience with Avast to know whether or not this is an “Avast problem”, but I certainly have more experience with installing under Mavericks to say Avast is most likely the culprit here.
    I suppose I could give up on Avast and go to ClamAV, but he’s “sold” on Avast. I realize there are other virus protection solutions and I realize there's some debate on whether or not anti-virus software SHOULD be installed on a Mac. Just looking for suggestions on the installation problem itself.
    Have submitted a ticket to Avast, but only a canned response so far.

    Non-Apple "anti-virus" products are worthless and will prevent your Mac from working as designed. Some such products are malicious. "Avast" is not the worst of them, but it comes close.
    Nothing in the world can prevent you from succumbing from "phishing" scams.
    There will always be threats to your information security associated with using any Internet - connected communications tool:
    You can mitigate those threats by following commonsense practices
    Delegating that responsibility to software is an ineffective defense
    Assuming that any product will protect you from those threats is a hazardous attitude that is likely to result in neglecting point #1 above.
    OS X already includes everything it needs to protect itself from viruses and malware. Keep it that way with software updates from Apple.
    A much better question is "how should I protect my Mac":
    Never install any product that claims to "clean up", "speed up", "optimize", "boost" or "accelerate" your Mac; to "wash" it, "tune" it, or to make it "shiny". Those claims are absurd.Such products are very aggressively marketed. They are all scams.
    Never install pirated or "cracked" software, software obtained from dubious websites, or other questionable sources.
    Illegally obtained software is almost certain to contain malware.
    "Questionable sources" include but are not limited to spontaneously appearing web pages or popups, download hosting sites such as C net dot com, Softonic dot com, Soft pedia dot com, Download dot com, Mac Update dot com, or any other site whose revenue is primarily derived from junk product advertisements.
    If you need to install software that isn't available from the Mac App Store, obtain it only from legitimate sources authorized by the software's developer.
    Don’t supply your password in response to a popup window requesting it, unless you know what it is and the reason your credentials are required.
    Don’t open email attachments from email addresses that you do not recognize, or click links contained in an email:
    Most of these are scams that direct you to fraudulent sites that attempt to convince you to disclose personal information.
    Such "phishing" attempts are the 21st century equivalent of a social exploit that has existed since the dawn of civilization. Don’t fall for it.
    Apple will never ask you to reveal personal information in an email. If you receive an unexpected email from Apple saying your account will be closed unless you take immediate action, just ignore it. If your iCloud, iTunes, or App Store account becomes disabled for valid reasons, you will know when you try to buy something or log in to this support site, and are unable to.
    Don’t install browser extensions unless you understand their purpose:Go to the Safari menu > Preferences > Extensions. If you see any extensions that you do not recognize or understand, simply click the Uninstall button and they will be gone.
    Don’t install Java unless you are certain that you need it:
    Java, a non-Apple product, is a potential vector for malware. If you are required to use Java, be mindful of that possibility.
    Java can be disabled in System Preferences.
    Despite its name JavaScript is unrelated to Java. No malware can infect your Mac through JavaScript. It’s OK to leave it enabled.
    The same precaution applies to Adobe Flash Player. Newly discovered Flash vulnerabilities appear almost weekly.
    Beware spontaneous popups: Safari menu > Preferences > Security > check "Block popup windows".
    Popup windows are useful and required for some websites, but unsolicited popups are commonly used to deceive people into installing unwanted software they would never intentionally install.
    Popups themselves cannot infect your Mac, but many contain resource-hungry code that will slow down Internet browsing.
    If you ever receive a popup window indicating that your Mac is infected with some ick or that you won some prize, it is 100% fraudulent. Ignore it.
    The same goes for a spontaneously appearing dialog insisting that you upgrade your video player right this instant. Such popups are frequently associated with sites that promise to deliver "free" movies or other copyrighted content that is not normally "free".
    The more insistent it is that you upgrade or install something, the more likely it is to be a scam. Close the window or tab and forget it.
    Ignore hyperventilating popular media outlets that thrive by promoting fear and discord with entertainment products arrogantly presented as "news". Learn what real threats actually exist and how to arm yourself against them:
    The most serious threat to your data security is phishing. Most of these attempts are pathetic and are easily recognized, but that hasn't stopped prominent public figures from recently succumbing to this age-old scam.
    OS X viruses do not exist, but intentionally malicious or poorly written code, created by either nefarious or inept individuals, is nothing new.
    Never install something without first knowing what it is, what it does, how it works, and how to get rid of it when you don’t want it any more.
    If you elect to use "anti-virus" software, familiarize yourself with its limitations and potential to cause adverse effects, and apply the principle immediately preceding this one.
    Most such utilities will only slow down and destabilize your Mac while they look for viruses that do not exist, conveying no benefit whatsoever - other than to make you "feel good" about security, when you should actually be exercising sound judgment, derived from accurate knowledge, based on verifiable facts.
    Do install updates from Apple as they become available. No one knows more about Macs and how to protect them than the company that builds them.
    Summary: Use common sense and caution when you use your Mac, just like you would in any social context. There is no product, utility, or magic talisman that can protect you from all the evils of mankind.

  • Operational Issues vs Operator Error

    The concept of the Android operational system got many rave reviews, and many positive comments regarding the many things an android phone can achieve.  However,  as a functionally smartphone to use in business to organize, file and utilize contacts, it falls short in the performance department.  Many of the primarily functions as a smart phone of the Droid X falls short and at this time after nearly four months and 4 droid's, the solution appears far in the distance.
    I am presently using my 4th Motorola Droid X, which all the 3 previous models were deemed defective by Motorola & Verizon Tech's.  I find it interesting that it appears that despite numerous telephone calls for help & assistance, that I am told by both Motorola & Verizon support that the following concerns do not show as problems with the Droid X.  After spending over 7 hours with a Level 3 directed Motorola Tech, after spending hours with a Verizon Tech, that "there are more people having issues with the DROIDX than I want to know."  this was told to me after I inquired that I just couldn't be the only user to file concerns about the product.   So I ask you try to see if you experience any of the listed problems below and please respond.  This is the only way we are going to get both Verizon or Motorola to take immediate action. 
    Don't believe me... Get out your DROID X now and try the following:
    1. Why when selecting either a phone number, address or email as "DEFAULT", absolutely nothing is displayed to indicate that a default was set?   
             SOLUTION:  Upon selecting either a phone number, address or email as DEFAULT, why not have the entire entry change color to GREEN.  (keep in mind those that might be color blind).  Green is the color that means go, first, and is most easily viewed immediately.
    2. Why when selecting a contact to edit does information appear in different order in "edit" screen that in the "contact data screen.?
           SOLUTION:  Programmers you need to fix this discrepancy.  It is too confusing when trying to compare data.
    3. Why does the data also appear differently in different order when comparing information to that which is displayed on google.account?
           SOLUTION:  See answer to number 2.
    4. Why when conducting searches in which many of the contacts have similar names (like "Marina") that the search will not list all of the contacts matching criteria requested in search?
           SOLUTION:  Correct search criteria to examine all data fields and to ensure multiple entries in each field is identified by the search feature. 
      NOTE: it would be nice that when search results are listed that user have the option to see requested search first rather than all other contacts that have matching criteria.  Example.  if searching for Marina,  if typing Ma...  as the letters are typed only list those matches that the MA is matching as the first two characters FIRST rather than every match that contains the letters MA. 
    But still problem remains that the search criteria leaves out contacts that have the exact match requested criteria.
    5.  Why have the ability  to create groups if groups will not sync  between the phone and gmail? 
        SOLUTION:  Programmers need to investigate and determine why when creating groups on the phone or on gmail do not sync.   If the phone is designed to be a phone to work with the google /gmail features, then perhaps all of the features should be tested... or make a disclosure prior to sale of functions that do not work.
    6. Does this Droid X, have the ability to work as designed with more than one gmail contact?  IF YES, then how is a particular gmail account linked to a contact?  Can this contact gmail link be changed or linked to more than one email without having to retype contact data?  There appears to be no method in which to select a gmail in which to link a contact?
           SOLUTION:  enable feature to select which account to link a contact.   Also, enable ability to select multiple links and/or ability to switch links.  
    7. What causes differences in total number of contacts on the phone than that listed in the gmail account?  Phone constantly shows fewer contacts than the gmail account,  in my case, there are (402) missing contacts on the phone?
          SOLUTION:  There should be mathematical check to ensure contacts match both phone and gmail account and an error message when the count differs.   NOTE: is there a problem not disclosed regarding an OUTLOOK C.V. file not syncing with a google account data?
    8. Constantly getting message:  SORRY, The application Google Services Framework (process com.google.process.gapps) has stopped unexpectedly. Please try again.   FORCE CLOSE.   Why? What is constantly not working?
      NOTE: This problem appears,often several times, then is followed by phone resetting itself. 
            SOLUTION:  BE PRO ACTIVE IN NOTIFYING CUSTOMERS USING EQUIPMENT OF ISSUES DEEMED NECESSARY TO BE ADDRESSED IN SOFTWARE FIX.  IN FACT, WHY NOT AN APPLICATION THAT IDENTIFYS ALL ISSUES WITH ANTICIPATED STATUS ON WHEN CORRECTIONS WILL BE FORTHCOMING.
    I  have spent the past 4 months extensively trying to work with Verizon and Motorola.  Verizon wants to blame Motorola and takes no responsibility for its beta team to find at least the above issues.  If they did find issues and know these issues prior to releasing the equipment for user usage, I believe Verizon owes every consumer a disclosure of known problems in advance.  Many of the above issues are so obvious it is impossible to believe these issues were not noted as problems prior to release.  I hold Verizon accountable for my data loss, the wasted time spent explaining over and over the problems, and I hold them accountable for failure to test the accessories prior to sale. 
    The DROIDX can be a great smartphone if it uses smart beta testers and if at the least the above issues can be resolved quickly. 
    What is your opinion? 

    frogman80 wrote:
    Don't believe me... Get out your DROID X now and try the following:
    Don't believe me... Get out your DROID X now and try the following:
    1. Why when selecting either a phone number, address or email as "DEFAULT", absolutely nothing is displayed to indicate that a default was set?
    The Default selected number moves to top of phone list for the contact and this is how you know it’s the default.
    2. Why when selecting a contact to edit does information appear in different order in "edit" screen that in the "contact data screen.?
    Same answer as previous question.
    3. Why does the data also appear differently in different order when comparing information to that which is displayed on google.account?
    Because the site has cells configured by category where the phone has order configured by user input.
    4. Why when conducting searches in which many of the contacts have similar names (like "Marina") that the search will not list all of the contacts matching criteria requested in search?
    I am unsure how you are searching but when I do a search all matches are listed from search criteria, Google search does this automatically but when you do it from phone dialer you have to press the arrow in left corner above input cell to display all found items that match search.
    5. Why have the ability to create groups if groups will not sync between the phone and gmail?
    Now this option I can agree needs some work but nothing is perfect
    6. Does this Droid X, have the ability to work as designed with more than one gmail contact? IF YES, then how is a particular gmail account linked to a contact? Can this contact gmail link be changed or linked to more than one email without having to retype contact data? There appears to be no method in which to select a gmail in which to link a contact?
    I do not know why you would want to have two accounts that would have the same exact information like contacts because the device pulls contacts from the phone book listing… But if you want to do this Google has a option from website to merge two accounts and I believe this should do just what you are wanting.
    7. What causes differences in total number of contacts on the phone than that listed in the gmail account? Phone constantly shows fewer contacts than the gmail account, in my case, there are (402) missing contacts on the phone?
    This can happen because on counts the number of numbers listed instead of the number of contacts, so if you have 4 numbers for a contact this will list a 4 in one area but only one in other location… I do agree that this is something that can make things a bit confusing at times.
    8. Constantly getting message: SORRY, The application Google Services Framework (process com.google.process.gapps) has stopped unexpectedly. Please try again. FORCE CLOSE. Why? What is constantly not working?
    This is most likely a incompatible app installed that it causing this controller to FC but I can not trouble shoot this issue because I haven't experience this problem myself.
    The DROIDX can be a great smartphone if it uses smart beta testers and if at the least the above issues can be resolved quickly.
    Beta testers can not take all users habits and installed softwares in consideration because there is to many new apps created daily and to many custom configurations done by so many users. I have developed a number of 3rd party apps for WM over the years and I can openly say that the chance of isolating all possible configuration issues is impossible, the SDK only allow you limited access to the systems base codes that makes a true custom code to overlay a UI a little complex.
    What is your opinion?
    Hope this cleared some things for you.

  • How to run multiple DOS commands from a single Webutil Client_Host session?

    Hello all,
    I have a requirement where I need to create an interface with SVN from Forms for basic checkin-checkout of files.
    So, I've been trying to use webutil client_host to open a command line session and issue svn commands.
    For svn, sometimes I need to give multiple commands like change to a particular directory and then run an svn command.
    But client_host takes in only one command at a time and I'm unable to issue a series of DOS commands to perform
    a particular task.
    Is there a way to do this?
    Pls suggest.
    Regards,
    Sam

    First your original question... You can put more than one DOS command on a single line, simply separate each command with an ampersand (&). For example:
    mkdir c:\abc & cd abc & dir*
    Regarding your concerns about performance, well that would depend on exactly what you mean. Using CLIENT_HOST (or HOST on the server) simply opens a shell (DOS in this case) then passes your command to it. The performance of performing this action really isn't measurable. Basically you are just pressing a button and you should get a near immediate action. As for the performance of executing each command, that has nothing to do with Forms. Once the command is passed to the shell, the rest is a function of the shell and whatever command you passed.
    Having said that, if you were to write something sloppy like a loop (in pl/sql) which called CLIENT_HOST lots of times repeatedly, then yes there would be a performance problem because the pushing of the button will cause an exchange to and from the server and each cycle in the loop will do the same.
    So the answer to how performance is impacted will depend on what exactly you need to accomplish. If it is a single call to CLIENT_HOST, this should be fine.

  • 2 ISPs with addresses /32 and PPtP Server onboard of Cisco 3825

    First of all, excuse me for my bad English, it's not my native language.
    A couple of years ago our company changed our central router Cisco 1841 with more powerfull 3825 ISR.
    Here is show ver
    Cisco IOS Software, 3800 Software (C3825-ADVENTERPRISEK9-M), Version 12.4(24)T7
    This Cisco 3825 contains 2 DIMMs - 256Mb and 512 Mb of RAM onboard.
    Now it works with 2 ISPs (take a glance on pdf picture http://www.intelcom-ug.ru/scheme.pdf or in the attached file). We're using the failover scheme, the ISP1 with statically assigned IP address 85.20.20.20/32 (Dialer 1)  is used as Backup link. The ISP2 L2TP link is main.
    Now our authorities organize the remote office with Cisco 1841. And we face with the problem, we cannot connect via PPtP from anywhere to the  85.20.20.20/32 (Dialer 1). And we need some help or advise. The config of Cisco 3825 is like this:
    version 12.4
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime localtime
    service password-encryption
    hostname CENTRAL-OFFICE
    boot-start-marker
    warm-reboot
    boot-end-marker
    security authentication failure rate 3 log
    logging message-counter syslog
    logging buffered 64000
    enable secret 5 HEREISTHESECRETPASSWORD
    aaa new-model
    aaa local authentication attempts max-fail 3
    aaa authentication login default local
    aaa authentication ppp default local
    aaa authentication ppp vpn-users local
    aaa authorization exec default local 
    aaa authorization exec vpn-users local 
    aaa authorization network vpn-users local 
    aaa session-id common
    clock timezone MSK 4
    ip source-route
    no ip gratuitous-arps
    ip cef
    no ip domain lookup
    ip domain name somewhere.net
    ip name-server 8.8.8.8
    no ipv6 cef
    multilink bundle-name authenticated
    vpdn enable
    vpdn-group 239
     accept-dialin
      protocol pptp
      virtual-template 100
    vpdn-group global
    ! Default L2TP VPDN group
    ! Default PPTP VPDN group
     accept-dialin
      protocol any
    password encryption aes
    voice-card 0
    username administrator privilege 15 password 7 737364645252414571
    username vpnuser password 7 85956353413120384645373930
    archive
     log config
      hidekeys
    ip tcp selective-ack
    ip tcp timestamp
    ip tcp synwait-time 5
    ip tcp path-mtu-discovery
    ip ssh version 2
    l2tp-class beeline
    pseudowire-class pw-beeline
     encapsulation l2tpv2
     protocol l2tpv2 beeline
    buffers tune automatic
    interface Loopback0
     ip address 10.111.111.111 255.255.255.255
    interface GigabitEthernet0/0
    descrition --Our Local Network--
     ip address 192.168.7.2 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     duplex auto
     speed auto
     media-type rj45
    interface GigabitEthernet0/1
     description --Trunk Connection--
     no ip address
     duplex auto
     speed auto
     media-type rj45
    interface GigabitEthernet0/1.10
    description --Connection to ISP1 through vlan on our managed switch--
     encapsulation dot1Q 10
     pppoe enable group global
     pppoe-client dial-pool-number 2
    interface GigabitEthernet0/1.20
    description --Connection to ISP2 through vlan on our managed switch--
     encapsulation dot1Q 20
     ip address dhcp
     ip virtual-reassembly
    interface Virtual-PPP5
    description --Interface for ISP2--
     ip address negotiated
     no ip proxy-arp
     ip nat outside
     ip virtual-reassembly
     ip tcp adjust-mss 1380
     no peer neighbor-route
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname 8282828282828
     ppp chap password 7 theSecretForISP2
     pseudowire 10.255.255.242 10 pw-class pw-beeline
    interface Virtual-Template100
    description --TEMPLATE for incoming PPtP connections of our users--
     ip unnumbered Dialer1
     autodetect encapsulation ppp
     peer default ip address pool for-vpn
     no keepalive
     ppp authentication ms-chap ms-chap-v2 vpn-users
     ppp authorization vpn-users
    interface Dialer1
    description --Interface for ISP1. PPPoE--
     bandwidth 10240
     ip address negotiated
     ip accounting output-packets
     ip nbar protocol-discovery
     ip nat outside
     ip virtual-reassembly
     encapsulation ppp
     ip tcp adjust-mss 1400
     load-interval 30
     dialer pool 2
     dialer-group 2
     no fair-queue
     ppp authentication chap callin
     ppp pap sent-username reteretere password 7 PasswordForISP1
    ip local policy route-map External_VPN
    ip local pool for-vpn 172.16.135.1 172.16.135.10
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer1 100 track 1
    ip route 0.0.0.0 0.0.0.0 Virtual-PPP5 track 2
    ip route 192.168.239.0 255.255.255.0 172.16.135.1 name C1841-Rossiyskaya70
    ip route 194.87.0.8 255.255.255.255 Dialer1
    ip route 194.87.0.9 255.255.255.255 Virtual-PPP5
    ip route 10.255.255.242 255.255.255.255 dhcp
    ip route 10.255.255.247 255.255.255.255 dhcp
    no ip http server
    no ip http secure-server
    ip nat inside source route-map Beeline interface Virtual-PPP5 overload
    ip nat inside source route-map UTK interface Dialer1 overload
    ! This access-list is for local Network proxy
    ip access-list standard fwd-squid
     permit 192.168.7.100
     permit 192.168.7.0 0.0.0.255
    ! This access-list is for ip local policy
    ip access-list extended External_VPN_access
     permit tcp host 85.20.20.20 eq 1723 any
     permit tcp host 85.20.20.20 eq 22 any
     permit tcp host 85.20.20.20 eq telnet any
     permit icmp host 85.20.20.20 any echo-reply
    track 1 ip sla 1 reachability
    ip sla 1
     icmp-echo 194.87.0.8 source-interface Dialer1
     timeout 7000
     threshold 100
     frequency 15
    ip sla schedule 1 life forever start-time now
    ip sla reaction-configuration 1 react timeout threshold-type immediate action-type triggerOnly
    track 2 ip sla 2 reachability
    ip sla 2
     icmp-echo 194.87.0.9 source-interface Virtual-PPP5
     timeout 7000
     threshold 400
     frequency 15
    ip sla schedule 2 life forever start-time now
    ip sla reaction-configuration 2 react timeout threshold-type immediate action-type triggerOnly
    access-list 1 remark --SNMP Watching--
    access-list 1 permit 192.168.7.0 0.0.0.255
    access-list 100 permit ip 192.168.7.0 0.0.0.255 any
    dialer-list 1 protocol ip permit
    dialer-list 2 protocol ip permit
    dialer-list 3 protocol ip permit
    route-map External_VPN permit 10
     match ip address External_VPN_access
     set default interface Dialer1
    route-map UTK permit 10
     match ip address 100
     match interface Dialer1
    route-map Beeline permit 10
     match ip address 100
     match interface Virtual-PPP5
    snmp-server community public RO 1
    control-plane
    line con 0
    line aux 0
    line vty 0 4
     exec-timeout 30 0
    line vty 5 15
    exception memory ignore overflow processor
    exception memory ignore overflow io
    scheduler allocate 20000 1000
    ntp update-calendar
    ntp peer 194.33.84.1
    event manager applet nat_clear_isp1 
     event track 1 state any
     action 1 wait 5
     action 2 cli command "enable"
     action 3 cli command "clear ip nat translation *"
    event manager applet nat_clear_isp2 
     event track 2 state any
     action 1 wait 5
     action 2 cli command "enable"
     action 3 cli command "clear ip nat translation *"
    end

    Okay, you are not going to be able to do this using the interconnect between the switch and the router. The issue is -
    1) if you make the interconnect a L2 trunk then you would have subinterfaces on the router interface connecting to the switch. But you cannot have multiple interfaces on the router configured from the same IP range so it won't work ie. you would need a subinterface using the same IP range as one of the other interfaces
    2) if you make the interconnect L3 as you have then you cannot route to the same subnet ie. think of it as two separate devices, a L3 switch and a router. You connect the L3 switch to the router using a L3 connection.
    On the switch you then configure a client with a public IP and on another interface on the router ie. not the interface used to connect to the switch, you use the same public IP range.
    You cannot then route from the client to that other interface because you don't route to the same IP subnet and the client and the other interface are separated by a different IP subnet.
    So neither will work. The L3 switch is usually used where you have multiple vlans/IP subnets and you create L3 vlan interfaces for these on the switch and then you route to other subnets that are reachable from the router, whether these are directly connected subnets or remote networks.
    But you aren't doing that.
    The only way i could see you doing what you need is to not configure the interconnect at all and instead run cables from the relevant router interfaces to the switch. Then you could configure vlans on the switch and have them route via the physical router interface.
    The switch is then only acting as a L2 switch and all L3 is done on the router.
    One thing i should say is i have never used the switch module this way so i can't guarantee it will work although i can't see why it wouldn't.
    Jon

  • IMac CPU3.06 GHz Intel Core 2 Duo, 8GB, Extremely slow and repeatedly "out of Memory" since migration from Mountain Lion to Mavericks

    Dear Apple Support Community.
    As mentioned by a number of users reporting the same problem, my 2009 iMac CPU3.06 GHz Intel Core 2 Duo, 8GB RAM, has become extremely slow and repeatedly "out of Memory" since it was migrated from Mountain Lion to Mavericks (OS 10.9 then OS 10.9.1).
    I have already run CleanMyMac, deleted 5GB of useless stuffs, which did not translate into any improvement. Following the advices collected in other Apple Support Community threads, I have applied EtreCheck the outcome of which is provided below.
    For information, I have also upgraded my 2011 MacBook CPU2.3 GHz Core i7, 8GB which became only a bit slower than before, sometimes freezing which it almost never did before. However, I am used to the fact that Mac get usually slower and more prompt fo freeze after upgrading to a more recent OS.
    Both my 2009 iMac and my 2011 MacBook have F-Secure installed. So the problem with the 2009 IMac is unlikly to be due to the presence of F-Secure. Interestingly, the few abnormalities found by Etrecheck were exacly identical before I ran CleanMyMac. There are two more findings (mentioned below) since I ran CleanMyMac on the 2009 iMac, which again didn't improve the problem.
    So please find below the details of the EtreCheck experience and some additional measurements made with iStat while running EtreCheck:
    Hardware Information:
    iMac (24-inch, Early 2009)
    iMac - model: iMac9,1
    1 3.06 GHz Intel Core 2 Duo CPU: 2 cores
    8 GB RAM
    Video Information:
    ATI Radeon HD 4850 - VRAM: 512 MB
    Audio Plug-ins:
    BluetoothAudioPlugIn: Version: 1.0 - SDK 10.9
    AirPlay: Version: 1.9 - SDK 10.9
    AppleAVBAudio: Version: 2.0.0 - SDK 10.9
    iSightAudio: Version: 7.7.3 - SDK 10.9
    System Software:
    OS X 10.9.1 (13B42) - Uptime: 0 days 2:40:57
    Disk Information:
    WDC WD1001FALS-40K1B0 disk0 : (1 TB)
    EFI (disk0s1) <not mounted>: 209.7 MB
    XooS5 HD (disk0s2) /: 999.35 GB (189.85 GB free)
    Recovery HD (disk0s3) <not mounted>: 650 MB
    OPTIARC DVD RW AD-5670S 
    USB Information:
    Apple Inc. Built-in iSight
    Canon CanoScan
    Apple Computer, Inc. IR Receiver
    Apple Inc. BRCM2046 Hub
    Apple Inc. Bluetooth USB Host Controller
    FireWire Information:
    WD My Passport 071D 800mbit - 800mbit max
    EFI (disk1s1) <not mounted>: 209.7 MB
    disk1s2 (disk1s2) <not mounted>: 2 TB
    Boot OS X (disk1s3) <not mounted>: 134.2 MB
    Thunderbolt Information:
    Kernel Extensions:
    com.f-secure.kext.fsauth          (1.0.0d1)
    Problem System Launch Daemons:
    [failed] com.apple.wdhelper.plist [REMARK: this abnormality appeared only after running CleanMyMac. It does not appear on my 2011 MacBook]
    Problem System Launch Agents:
    Launch Daemons:
    [loaded] com.adobe.fpsaud.plist
    [invalid] com.bjango.istatlocaldaemon.plist [REMARK: this abnormality pre-existed to running CleanMyMac. It appears also on my 2011 MacBook]
    [loaded] com.f-secure.fsavd.dbhelper.plist
    [loaded] com.f-secure.fsavd.plist
    [loaded] com.f-secure.fsmac.firewall.plist
    [loaded] com.f-secure.fsmac.fsupdated_guts2.plist
    [loaded] com.f-secure.fsmac.licensetool.plist
    [loaded] com.macpaw.CleanMyMac2.Agent.plist
    Launch Agents:
    [loaded] com.babylon.activation.plist
    [loaded] com.bjango.istatlocal.plist
    [loaded] com.f-secure.relauncher.plist
    [loaded] com.f-secure.trasher.plist
    User Launch Agents:
    [loaded] com.adobe.ARM.[...].plist
    [loaded] com.google.keystone.agent.plist
    [loaded] com.macpaw.CleanMyMac2Helper.diskSpaceWatcher.plist
    [loaded] com.macpaw.CleanMyMac2Helper.scheduledScan.plist
    [loaded] com.macpaw.CleanMyMac2Helper.trashWatcher.plist
    User Login Items:
    iTunesHelper
    Dropbox
    F-Secure Anti-Virus for MAC
    3rd Party Preference Panes:
    Flash Player
    Internet Plug-ins::
    FlashPlayer-10.6: Version: 11.9.900.170 - SDK 10.6
    Default Browser: Version: 537 - SDK 10.9
    AdobePDFViewerNPAPI: Version: 11.0.04 - SDK 10.6
    AdobePDFViewer: Version: 11.0.04 - SDK 10.6
    DivXBrowserPlugin: Version: 2.1
    Flash Player: Version: 11.9.900.170 - SDK 10.6
    OfficeLiveBrowserPlugin: Version: 12.2.8
    Google Earth Web Plug-in: Version: 6.1
    QuickTime Plugin: Version: 7.7.3
    iPhotoPhotocast: Version: 7.0
    User Internet Plug-ins::
    Picasa: Version: 1.0
    Bad Fonts:
    None
    Old applications:
    None
    Time Machine:
    Skip System Files: NO
    Mobile backups: OFF
    Auto backup: YES
    Volumes being backed up:
    XooS5 HD: Disk size: 930.71 GB Disk used: 753.90 GB
    Destinations:
    XooS5 TM [Local] (Last used)
    Total size: 2 
    Total number of backups: 32
    Oldest backup: 2013-09-15 01:11:39 +0000
    Last backup: 2013-12-07 12:48:45 +0000
    Size of backup disk: Too small. Backup size 2  < (Disk used 753.90 GB X 3)
    Time Machine details may not be accurate. All volumes being backed up may not be listed.
    REMARK: The above finding is unlikely to be accurate. In fact, my Time Machine is supported by a 2TB WD My Passport Studio external HD connected with a Firewire 800. As mentionned, only 754GB of the 2000GB are used.
    Top Processes by CPU:
    5%          backupd
    5%          Mail
    5%          WindowServer
    3%          Finder
    3%          Dropbox
    Top Processes by Memory:
    1.60 GB          mds_stores REMARK: this item was marked in red in the outcome of EtreCheck, so I assume there is something wrong there
    82 MB          Finder
    74 MB          Mail
    49 MB          softwareupdated
    49 MB          Dropbox
    Virtual Memory Statistics:
    97 MB          Free RAM
    1.21 GB          Active RAM
    1.19 GB          Inactive RAM
    1.21 GB          Wired RAM
    1.83 GB          Page-ins
    36 MB          Page-outs
    Please find now some additional measurements collected with iStat while running EtreCheck:
    Practically:
    The iMac can work slowly with only one software e.g. either Mail or Safari or Firefox, but still the below "out of Memory" message occurs about every 3 minutes.
    Aperture has becomre to slow to be useable
    If trying to write a mail (with Mail) while Safari or Firefox is open, then the "out of Memory" message occurs about every 20 seconds so I need to check on "Resume" several times per minute.
    Conclusions
    From the above, unless anyone in the Apple Support Community proves to be able to identify a specific problem leading to a way to find a cure, I tend to conclude that Mavericks is not suitable for computers operating with a Core 2 Duo CPU even with a 8GB of RAM.
    Unless I missed something, I did not see any warning from Apple Computer Inc. informing their customers they should refrain from upgrading Core 2 Duo Computers.
    The only solution I see so far is to downgrade from Mavericks to Mountain Lion. And the Apple Support Community would confirm that it is the only solution, I would appreciate to get your guidance on how to proceed.
    Intended action plan
    Migrate the above 2009 iMac to a 2014 Mac Mini Server operating on Mavericks to ensure that no data may be lost while downgrading to Montain Lion.
    Provided the above downgrading operation is successful, assign this 2009 iMac to partial retirement e.g. Mail, Skype, iTunes  and DVD player.
    In advance, I would like to thank the Apple Community for helping me either i) finding a cure to the problem, ii) or confirming that Mavericks cannot operate properly on Core 2 Duo computers, iii) and in such a case, guiding me on how to downgrade to Mountain Lion.
    Yours sincerely
    Core

    ... what anti-virus would you recommend using?
    Use what is already included with OS X. It already includes everything it needs to protect itself from viruses and malware. Keep it that way with software updates from Apple.
    A much better question is "how should I protect my Mac":
    Never install any product that claims to "speed up", "clean up", "optimize", or "accelerate" your Mac. Without exception, they will do the opposite.
    Never install pirated or "cracked" software, software obtained from dubious websites, or other questionable sources. Illegally obtained software is almost certain to contain malware.
    Don’t supply your password in response to a popup window requesting it, unless you know what it is and the reason your credentials are required.
    Don’t open email attachments from email addresses that you do not recognize, or click links contained in an email:
    Most of these are scams that direct you to fraudulent sites that attempt to convince you to disclose personal information.
    Such "phishing" attempts are the 21st century equivalent of a social exploit that has existed since the dawn of civilization. Don’t fall for it.
    Apple will never ask you to reveal personal information in an email. If you receive an unexpected email from Apple saying your account will be closed unless you take immediate action, just ignore it. If your iTunes or App Store account becomes disabled for valid reasons, you will know when you try to buy something or log in to this support site, and are unable to.
    Don’t install browser extensions unless you understand their purpose. Go to the Safari menu > Preferences > Extensions. If you see any extensions that you do not recognize or understand, simply click the Uninstall button and they will be gone.
    Don’t install Java unless you are certain that you need it:
    Java, a non-Apple product, is a potential vector for malware. If you are required to use Java, be mindful of that possibility.
    Disable Java in Safari > Preferences > Security.
    Despite its name JavaScript is unrelated to Java. No malware can infect your Mac through JavaScript. It’s OK to leave it enabled.
    Block browser popups: Safari menu > Preferences > Security > and check "Block popup windows":
    Popup windows are useful and required for some websites, but popups have devolved to become a common means to deliver targeted advertising that you probably do not want.
    Popups themselves cannot infect your Mac, but many contain resource-hungry code that will slow down Internet browsing.
    If you ever see a popup indicating it detected registry errors, that your Mac is infected with some ick, or that you won some prize, it is 100% fraudulent. Ignore it.
    Ignore hyperventilating popular media outlets that thrive by promoting fear and discord with entertainment products arrogantly presented as "news". Learn what real threats actually exist and how to arm yourself against them:
    The most serious threat to your data security is phishing. To date, most of these attempts have been pathetic and are easily recognized, but that is likely to change in the future as criminals become more clever.
    OS X viruses do not exist, but intentionally malicious or poorly written code, created by either nefarious or inept individuals, is nothing new.
    Never install something without first knowing what it is, what it does, how it works, and how to get rid of it when you don’t want it any more.
    If you elect to use "anti-virus" software, familiarize yourself with its limitations and potential to cause adverse effects, and apply the principle immediately preceding this one.
    Most such utilities will only slow down and destabilize your Mac while they look for viruses that do not exist, conveying no benefit whatsoever - other than to make you "feel good" about security, when you should actually be exercising sound judgment, derived from accurate knowledge, based on verifiable facts.
    Do install updates from Apple as they become available. No one knows more about Macs and how to protect them than the company that builds them.
    Summary: Use common sense and caution when you use your Mac, just like you would in any social context. There is no product, utility, or magic talisman that can protect you from all the evils of mankind.

  • Open a new url in  same  window

    I am displayed a button using web dynpro abap,
    if i click the button means a new url page should be
    opened in the same window.
    I did the application but when i click the button means
    a new window is opened.It should not be happened.
    Anyone can plz send me the correct coding immediately....

    >
    cranjith kumar wrote:
    > I am displayed a button using web dynpro abap,
    > if i click the button means a new url page should be
    > opened in the same window.
    >
    > I did the application but when i click the button means
    > a new window is opened.It should not be happened.
    >
    > Anyone can plz send me the correct coding immediately....
    First of all how is anyone supposed to help you correct your coding when you have posted any.  We can't possibly know what is going on inside the event handler for your button. I suggest that post some of your coding here.  In general if you want to open another URL in the same page without using the linkToURL UI element, you should consider the usage of Exit Plugs:
    [http://help.sap.com/saphelp_nw70/helpdata/EN/45/1bc575ba064574e10000000a114a6b/frameset.htm|http://help.sap.com/saphelp_nw70/helpdata/EN/45/1bc575ba064574e10000000a114a6b/frameset.htm]
    Second, please don't ask people to do something "immediately".  Everything done in the forum is on a volunteer basis and people help out as fast as possible.  Your prompting for immediate action is quite unnecessary and could be considered somewhat rude.

  • Schedule Lines not confirmed

    Hi SAP experts
    Can somebody tell me as to why schedule lines for a material is not confirmed for a material while creating a sales order. I tried creating an order for two materials and since one of the material does not have confirmed schedule lines, it is affecting the delivery and the subsequent functions.
    Issue requires immediate action. Pl help me

    Hi,
    It looks like you don't have enough stock for this item as in availability check,it is not able to confirm item. In case MMBE shows that you have stock available in that particular plant, then it could be possible that the stock is already reserved for other order to be delivered later. To check that, goto the order, select the item which is giving problem, click on display availability. check if you have any customer order in the list confirmed for a later date.( It will show confirmed quantity. ).
    Now you can decide, based on the priority, how you want to go. You can un-confirm the quantity in confirmed order, so that quantity is available for other orders.
    Thanks,
    Gagan

Maybe you are looking for