Intercept all outgoing http calls

Similar to HttpFilter  (javax.Servlet.Filter ) which when added in web.xml can intercept any incoming request to JVM / outgoing (as response) independent of framework ( Spring/CXF/Jersy etc ) without any code changes (excluding the filter itself), I am trying to find an API or approach which could intercept any outgoing HTTP calls from JVM to add/modify headers independent of framework.
Quite often the word Outgoing HTTP call is misinterpreted in the forums so let me explain with example.
Let us assume there are two JVMs, jvm1 and jvm2. and there are HTTP calls being made from JVM1 to JVM2. I would like to intercept the HTTP connection being made from JVM1 to modify the headers information before the call happens. I do not want the code to be tied to a specific framework so that I can as bundle the interceptor as a jar and share it with application team. Changes in web.xml is fine.
Any suggestions? Please HELP!

> without any code changes...add/modify headers independent of framework.
I doubt that is possible.
Only way I can think of this being technically possible it to replace the VM socket factory with a custom factory which is just a wrapper (wrapped sockets) which intercept calls.  The wrapped calls would then identify http and manipulate it.  No idea how that interacts with SSL though.  That would probably some more custom work.
I suppose an injection process might be able to insert something like a custom socket factory but that functionality would need to be supported by every framework  And I doubt it is.

Similar Messages

  • What customization is required to webmail in NMS4.15 to allow text such as a disclaimer to be included in all outgoing http mail?

    My understanding is that comp_fs.html needs to be modified but I am unsure of which function?
    The text should not be visible to the user when composing the email, only the recipient(s) should see this.

    I haven't had the occasion to dissect the webmail internals enough to know where you'd add such functionality specific to HTTP, but if adding it to all outgoing messages is satisfactory, then you can write a plugin.
    In fact, here are two links. One describes the method of creating a plugin and uses an example that includes a number of other features. The second link contains the actual code for the entire plugin. You can just remove the additional functionality that you don't want to employ before compiling.
    Sample SMTP Plugin
    SMTP Plugin Code

  • Reuse of outgoing http connection in osb

    Hi,
    Does bussiness services can reuse tcp connection when invoking http webservice ?
    In other words , does oracle service bus create a new tcp connection for each outgoing http call , or is it reuse existing tcp connection ?
    Thank you,
    Amit

    Thank you Anuj for your early reply.
    As I checked in the network traces, neither the client nor the server sends the Connection: close header, connections remains established and unused for 200 seconds before the client (OSB Server) sends the FIN signal and meanwhile new connections are set (this is the keep-alive timeout of the client). And the server-side timeout is greater.
    For example...
    T0. Connection 1 established
    T+1s. Request sent and processed using Conn1
    T+2s. Request sent and processed using Conn1
    T+4s. Connection 2 established
    T+5s. Request sent and processed using Conn2
    T+200s. Connection 1 Closed.
    T+204s. Connection 2 Closed.
    From T+4 to T+199, two connections remains established. If the traffic continues this way for about one minute you can achieve 12 or 13 connections opened.
    Regards,
    Ruben.

  • How to know all outgoing calls time?

    how to know all outgoing calls time?
    4S

    It all depends on your carrier whether incoming vs. outgoing times even matter.
    For example, here in the U.S., AT&T doesn't charge any differently whether a call is incoming or outgoing.  The carrier (AT&T) accepts a text code *646# to give you a summary of your call minutes, but they're divided into "Daytime", "Night and Weekend", and "Mobile to Mobile".  Those three types of minutes are billed differently here.

  • Intercepting all http traffic and forwarding to VIP on CSM?

    We would like to intercept all http traffic from clients from all vlans and redirect them to a VIP on the CSM for loadbalancing to 2 proxy servers. Is this possible? I can't seem to find a solution similar to our issue? Please help thanks!

    Thx Giles! Do you mean a policy that uses route-maps with next-hop? So would I point the next-hop address to the CSM client vlan IP? Do you have a support link that covers this in detail? Thx!

  • All off-silte call directly goes to Auto Attendant

        Hello  everyone,
    I have an issue with UC520. There is one PSTN line connected to the voice port 0/2/0, All dial out works fine,  All off-site calls goes directley to the Auto Attendant, however, interal dial-in works fine, I mean user can dial internal extension properly but not from offsite to insite.
    I was wondering if any one can help me.
    Here is the partal UC configuration:
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2014.01.13 13:51:51 =~=~=~=~=~=~=~=~=~=~=~=
    sh run
    Building configuration...
    Current configuration : 31685 bytes
    dot11 syslog
    dot11 ssid uc520-data
    vlan 1
    authentication open
    dot11 ssid uc520-voice
    vlan 100
    authentication open
    ip source-route
    ip cef
    ip dhcp relay information trust-all
    ip dhcp excluded-address 10.1.1.1 10.1.1.10
    ip dhcp excluded-address 192.168.10.1 192.168.10.10
    ip dhcp pool phone
    network 10.1.1.0 255.255.255.0
    default-router 10.1.1.1
    option 150 ip 10.1.1.1
    ip dhcp pool data
    import all
    network 192.168.10.0 255.255.255.0
    default-router 192.168.10.1
    ip name-server 63.203.35.55
    ip inspect WAAS flush-timeout 10
    ip inspect name SDM_LOW dns
    ip inspect name SDM_LOW ftp
    ip inspect name SDM_LOW h323
    ip inspect name SDM_LOW https
    ip inspect name SDM_LOW icmp
    ip inspect name SDM_LOW imap
    ip inspect name SDM_LOW pop3
    ip inspect name SDM_LOW netshow
    ip inspect name SDM_LOW rcmd
    ip inspect name SDM_LOW realaudio
    ip inspect name SDM_LOW rtsp
    ip inspect name SDM_LOW esmtp
    ip inspect name SDM_LOW sqlnet
    ip inspect name SDM_LOW streamworks
    ip inspect name SDM_LOW tftp
    ip inspect name SDM_LOW tcp
    ip inspect name SDM_LOW udp router-traffic
    ip inspect name SDM_LOW vdolive
    no ipv6 cef
    multilink bundle-name authenticated
    stcapp ccm-group 1
    stcapp
    stcapp feature access-code
    stcapp supplementary-services
    port 0/0/0
    fallback-dn 301
    port 0/0/1
    fallback-dn 302
    port 0/0/2
    fallback-dn 303
    port 0/0/3
    fallback-dn 304
    trunk group ALL_BRI
    translation-profile outgoing PROFILE_ALL_BRI
    voice call send-alert
    voice rtp send-recv
    voice service voip
    sip
    no update-callerid
    voice class codec 1
    codec preference 2 g729r8
    voice class custom-cptone CCAjointone
    dualtone conference
    frequency 600 900
    cadence 300 150 300 100 300 50
    voice class custom-cptone CCAleavetone
    dualtone conference
    frequency 400 800
    cadence 400 50 200 50 200 50
    voice register global
    max-dn 56
    max-pool 14
    voice translation-rule 4
    rule 15 /^...$/ /0354434848/
    voice translation-rule 1000
    rule 1 /.*/ //
    voice translation-rule 1111
    voice translation-rule 1112
    rule 1 /^0/ /*/
    voice translation-rule 2222
    voice translation-profile CALLER_ID_TRANSLATION_PROFILE
    translate calling 1111
    voice translation-profile CallBlocking
    translate called 2222
    voice translation-profile OUTGOING_TRANSLATION_PROFILE
    translate called 1112
    voice translation-profile PROFILE_ALL_BRI
    translate calling 4
    voice translation-profile nondialable
    translate called 1000
    voice-card 0
    dspfarm
    dsp services dspfarm
    license udi pid UC520W-8U-2BRI-K9 sn FHK131827A2
    archive
    log config
    logging enable
    logging size 600
    hidekeys
    username cisco privilege 15 secret 5 $1$TC0B$LXMORw4u1vQpD/2eJdN4W1
    username admin privilege 15 password 0 admin
    username parham privilege 15 password 0 parham
    ip tftp source-interface Loopback0
    translation-rule 22
    bridge irb
    interface Loopback0
    description $FW_INSIDE$
    ip address 10.1.10.2 255.255.255.252
    ip access-group 101 in
    ip nat inside
    ip virtual-reassembly in
    interface FastEthernet0/0
    description $FW_OUTSIDE$
    ip address dhcp
    ip access-group 104 in
    ip nat outside
    ip inspect SDM_LOW out
    ip virtual-reassembly in
    duplex auto
    speed auto
    interface Integrated-Service-Engine0/0
    description cue is initialized with default IMAP group
    ip unnumbered Loopback0
    ip nat inside
    ip virtual-reassembly in
    service-module ip address 10.1.10.1 255.255.255.252
    service-module ip default-gateway 10.1.10.2
    interface FastEthernet0/1/0
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/1
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/2
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/3
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/4
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/5
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/6
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/7
    switchport voice vlan 100
    no ip address
    macro description cisco-phone
    spanning-tree portfast
    interface FastEthernet0/1/8
    switchport mode trunk
    no ip address
    macro description cisco-switch
    interface BRI0/1/0
    no ip address
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn sending-complete
    interface BRI0/1/1
    no ip address
    isdn point-to-point-setup
    isdn incoming-voice voice
    isdn sending-complete
    interface Dot11Radio0/5/0
    no ip address
    ssid uc520-data
    ssid uc520-voice
    speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
    station-role root
    interface Dot11Radio0/5/0.1
    encapsulation dot1Q 1 native
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    interface Dot11Radio0/5/0.100
    encapsulation dot1Q 100
    bridge-group 100
    bridge-group 100 subscriber-loop-control
    bridge-group 100 spanning-disabled
    bridge-group 100 block-unknown-source
    no bridge-group 100 source-learning
    no bridge-group 100 unicast-flooding
    interface Vlan1
    no ip address
    bridge-group 1
    bridge-group 1 spanning-disabled
    interface Vlan100
    no ip address
    bridge-group 100
    bridge-group 100 spanning-disabled
    interface BVI1
    description $FW_INSIDE$
    ip address 192.168.10.1 255.255.255.0
    ip access-group 102 in
    ip nat inside
    ip virtual-reassembly in
    interface BVI100
    description $FW_INSIDE$
    ip address 10.1.1.1 255.255.255.0
    ip access-group 103 in
    ip nat inside
    ip virtual-reassembly in
    ip forward-protocol nd
    ip http server
    ip http authentication local
    ip http secure-server
    ip http path flash:/gui
    ip nat inside source list 1 interface FastEthernet0/0 overload
    ip route 10.1.10.1 255.255.255.255 Integrated-Service-Engine0/0
    control-plane
    bridge 1 route ip
    bridge 100 route ip
    voice-port 0/0/0
    cptone AU
    voice-port 0/0/1
    cptone AU
    voice-port 0/0/2
    cptone AU
    voice-port 0/0/3
    cptone AU
    voice-port 0/1/0
    cptone AU
    voice-port 0/1/1
    cptone AU
    voice-port 0/2/0
    translate calling 1112
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/0-Custom-AA
    caller-id enable
    voice-port 0/2/1
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/1-Custom-AA
    caller-id enable
    voice-port 0/2/2
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/2-Custom-AA
    caller-id enable
    voice-port 0/2/3
    connection plar opx 398
    description Configured by CCA 4 FXO-0/2/3-Custom-AA
    caller-id enable
    voice-port 0/4/0
    auto-cut-through
    signal immediate
    input gain auto-control -15
    description Music On Hold Port
    sccp local Loopback0
    sccp ccm 10.1.1.1 identifier 1 version 4.0
    sccp
    sccp ccm group 1
    associate ccm 1 priority 1
    associate profile 1 register confprof1
    dspfarm profile 1 conference
    description DO NOT MODIFY, active CCA conference profile - CCA2.0 codec711
    codec g711alaw
    codec g711ulaw
    maximum conference-participants 32
    maximum sessions 2
    associate application SCCP
    dial-peer voice 2000 voip
    description ** cue voicemail pilot number **
    destination-pattern 300
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2001 voip
    description ** cue auto attendant number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 398
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 2012 voip
    description ** cue prompt manager number **
    translation-profile outgoing PSTN_CallForwarding
    destination-pattern 739
    b2bua
    session protocol sipv2
    session target ipv4:10.1.10.1
    voice-class sip outbound-proxy ipv4:10.1.10.1
    dtmf-relay rtp-nte
    no vad
    dial-peer voice 90 pots
    description AU-Mobile
    preference 1
    destination-pattern 04........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 68 pots
    description NSW Number
    preference 1
    destination-pattern 02........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 69 pots
    description TAS Number
    preference 1
    destination-pattern 03........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 70 pots
    description WA-SA-NT number
    preference 1
    destination-pattern 08........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 72 pots
    description QA-number
    preference 1
    destination-pattern 07........
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 74 pots
    description International number
    preference 1
    destination-pattern 0011T
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 30 pots
    description Australia-1800
    preference 1
    destination-pattern 1800......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 31 pots
    description Australia-1300
    preference 1
    destination-pattern 1300......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 32 pots
    description 13 Australia
    preference 5
    destination-pattern 13....
    port 0/2/0
    forward-digits all
    dial-peer voice 67 pots
    description mel-number
    preference 1
    destination-pattern 9.......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 75 pots
    description mel-Number
    preference 1
    destination-pattern 8.......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 76 pots
    description VIC number
    preference 1
    destination-pattern 5.......
    port 0/2/0
    forward-digits all
    no sip-register
    dial-peer voice 33 pots
    description Emergency NUmber
    preference 1
    destination-pattern 0000
    port 0/2/0
    forward-digits all
    no sip-register
    no dial-peer outbound status-check pots
    telephony-service
    sdspfarm conference mute-on 111 mute-off 222
    sdspfarm units 5
    sdspfarm tag 1 confprof1
    conference hardware
    video
    max-ephones 14
    max-dn 56
    ip source-address 10.1.1.1 port 2000
    max-redirect 20
    auto assign 1 to 1 type bri
    calling-number initiator
    service phone videoCapability 1
    service phone webAccess 0
    service dnis overlay
    service dnis dir-lookup
    timeouts interdigit 7
    system message UC520
    url services http://10.1.10.1/voiceview/common/login.do
    url authentication http://10.1.10.1/CCMCIP/authenticate.asp
    load 7906 SCCP11.9-2-1S
    load 7911 SCCP11.9-2-1S
    load 7931 SCCP31.9-1-1SR1S
    load 7960-7940 P00308010200
    load 521G-524G cp524g-8-1-17
    time-zone 48
    date-format dd-mm-yy
    voicemail 300
    max-conferences 8 gain -6
    call-forward pattern .T
    call-forward system redirecting-expanded
    hunt-group logout HLog
    multicast moh 239.10.16.16 port 2000
    web admin system name cisco secret 5 $1$NPt8$6I2moMN32fQoz083VCFm90
    dn-webedit
    time-webedit
    transfer-system full-consult dss
    transfer-pattern 0.T
    transfer-pattern .T
    secondary-dialtone 0
    night-service day Sun 17:00 09:00
    night-service day Mon 17:00 09:00
    night-service day Tue 17:00 09:00
    night-service day Wed 17:00 09:00
    night-service day Thu 17:00 09:00
    night-service day Fri 17:00 09:00
    night-service day Sat 17:00 09:00
    create cnf-files version-stamp 7960 Dec 23 2013 10:55:20
    ephone-template 15
    softkeys remote-in-use Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    button-layout 7931 2
    ephone-template 16
    softkeys remote-in-use Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    ephone-template 17
    softkeys remote-in-use CBarge Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    ephone-template 18
    softkeys remote-in-use CBarge Newcall
    softkeys idle Redial Newcall Cfwdall Pickup Gpickup Dnd HLog Login
    softkeys seized Cfwdall Endcall Redial Pickup Meetme Gpickup Callback
    softkeys connected Hold Endcall Trnsfer Confrn ConfList RmLstC Acct Park Select Join
    button-layout 7931 2
    ephone-dn 5 dual-line
    number 301 no-reg primary
    label 301
    description PhoneA Analog
    name PhoneA Analog
    ephone-dn 6 dual-line
    number 302 no-reg primary
    label 302
    description PhoneB Analog
    name PhoneB Analog
    ephone-dn 7 dual-line
    number 303 no-reg primary
    label 303
    description PhoneC Analog
    name PhoneC Analog
    ephone-dn 8 dual-line
    number 304 no-reg primary
    label 304
    description PhoneD Analog
    name PhoneD Analog
    ephone-dn 9
    number BCD no-reg primary
    description MoH
    moh out-call ABC
    ephone-dn 10 dual-line
    number 201 no-reg primary
    pickup-group 1
    label 201
    description Extension 201
    name Receptionist Receptionist
    mobility
    call-forward busy 300
    call-forward noan 300 timeout 20
    ephone-dn 11 dual-line
    number 207 no-reg primary
    label 207
    description Extension 207
    name None None
    ephone-dn 12 dual-line
    call-waiting ring
    number 203 no-reg primary
    pickup-group 1
    label 203
    description Extension 203
    name Peter Steve
    call-forward busy 300
    call-forward noan 300 timeout 15
    huntstop channel
    ephone-dn 13 dual-line
    call-waiting ring
    number 204 no-reg primary
    pickup-group 1
    label 204
    description Extension 204
    name Tim OConnor
    call-forward busy 300
    call-forward noan 300 timeout 20
    huntstop channel
    ephone-dn 14 dual-line
    number 205 no-reg primary
    pickup-group 1
    label 205
    description 205
    name 205
    ephone-dn 15 dual-line
    number 206 no-reg primary
    pickup-group 1
    label 206
    description 206
    name 206
    ephone-dn 16 dual-line
    call-waiting ring
    number 202 no-reg primary
    pickup-group 1
    label 202
    description Extension 202
    name David Holmes
    call-forward busy 300
    call-forward noan 300 timeout 15
    huntstop channel
    ephone-dn 17 dual-line
    number 208 no-reg primary
    label 208
    description 208
    name 208
    ephone-dn 18 dual-line
    number 209 no-reg primary
    label 209
    description 209
    name 209
    ephone-dn 19 dual-line
    number 210 no-reg primary
    label 210
    description 210
    name 210
    ephone-dn 43 octo-line
    number 771 no-reg primary
    conference meetme
    preference 3
    ephone-dn 44 octo-line
    number 771 no-reg primary
    conference meetme
    preference 2
    no huntstop
    ephone-dn 45 octo-line
    number 771 no-reg primary
    conference meetme
    preference 1
    no huntstop
    ephone-dn 46 octo-line
    number 771 no-reg primary
    conference meetme
    no huntstop
    ephone-dn 49 octo-line
    number C001 no-reg primary
    conference ad-hoc
    preference 3
    ephone-dn 50 octo-line
    number C001 no-reg primary
    conference ad-hoc
    preference 2
    no huntstop
    ephone-dn 51 octo-line
    number C001 no-reg primary
    conference ad-hoc
    preference 1
    no huntstop
    ephone-dn 52 octo-line
    number C001 no-reg primary
    conference ad-hoc
    no huntstop
    ephone-dn 55
    number A801... no-reg primary
    mwi off
    ephone-dn 56
    number A800... no-reg primary
    mwi on
    ephone 1
    device-security-mode none
    mac-address 4142.4DB8.0000
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:5
    ephone 2
    device-security-mode none
    mac-address 4142.4DB8.0001
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:6
    ephone 3
    device-security-mode none
    mac-address 4142.4DB8.0002
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:7
    ephone 4
    device-security-mode none
    mac-address 4142.4DB8.0003
    ephone-template 16
    max-calls-per-button 2
    type anl
    button 1:8
    ephone 5
    device-security-mode none
    mac-address 0024.97AA.E811
    ephone-template 15
    max-calls-per-button 2
    username "Receptionist" password receptionist
    type 7931
    button 1:10
    --More--                    !
    ephone 6
    device-security-mode none
    mac-address 0024.C4FC.4013
    ephone-template 16
    username "None"
    type 7911
    button 1:11
    ephone 7
    device-security-mode none
    video
    mac-address 000F.34FA.168B
    ephone-template 16
    username "steve" password petersteve
    speed-dial 1 xxx label "Peter - Home"
    speed-dial 2 xxx label "David - Mobile"
    speed-dial 3 xxx label "Tim - Mobile AUS"
    speed-dial 4 xxx label "Tim - Mobile USA"
    type 7960
    button 1:12
    ephone 8
    device-security-mode none
    video
    mac-address A40C.C394.B1F0
    ephone-template 16
    username "tim" password timoconnor
    speed-dial 1 xxx label "David - Mobile"
    speed-dial 2 xxx label "Peter - Mobile"
    speed-dial 3 xxx label "Clare - Mobile"
    type 7911
    button 1:13
    ephone 9
    device-security-mode none
    mac-address 0024.C4FC.5425
    ephone-template 16
    type 7911
    button 1:14
    ephone 10
    device-security-mode none
    mac-address 0024.C4FD.E27C
    ephone-template 16
    type 7911
    button 1:15
    ephone 11
    device-security-mode none
    video
    mac-address 0007.5098.1AB6
    ephone-template 16
    username "holmes" password davidholmes
    speed-dial 1 xx label "David - Home"
    speed-dial 2 xxxl abel "Sue - Mobile"
    speed-dial 3 xxx label "Peter - Mobile"
    speed-dial 4 xxx label "Tim - Mobile USA"
    speed-dial 5 xxx label "Tim - Mobile AUS"
    type 7960
    button 1:16
    ephone-hunt 1 sequential
    pilot 501
    list 202, 203, 204
    final 300
    timeout 8, 8, 8
    no-reg pilot
    statistics collect
    description Sales
    alias exec cca_vm_notification schedule from_time=00 to_time=24
    banner login ^CCisco Configuration Assistant. Version: 3.2 (3). Fri Nov 15 22:54:23 EST 2013^C
    line con 0
    no modem enable
    line aux 0
    line 2
    no activation-character
    no exec
    transport preferred none
    transport input all
    line vty 0 4
    transport input all
    line vty 5 100
    transport input all
    ntp master
    end
    UC520#

    I was configure custom disconnect tone refer to this site:
    http://ciscoflair.blogspot.com/2009/05/cisco-fxo-disconnect-issue.html
    And the tone is in the attachment, and the custom disconnect tone configuration like below:
    voice class custom-cptone Disconnect
    dualtone disconnect
      frequency 420 420
      cadence 251 255 245 250 249 250 250 250
    and the port configuration was like below:
    voice-port 0/1/2
    supervisory disconnect dualtone mid-call
    supervisory custom-cptone Disconnect
    cptone NL
    timeouts interdigit 4
    timeouts call-disconnect 5
    timeouts wait-release 5
    timing hookflash-out 500
    connection plar 334
    impedance complex2
    caller-id enable
    caller-id alerting line-reversal
    caller-id alerting dsp-pre-allocate
    but it was not working and the phone still ringing after the PSTN caller disconnect.
    but i was read about "dualtone-detect-params", and i was add the below command and i do not understand it, but it was solve hte problem:
    voice class dualtone-detect-params 1
    freq-max-deviation 20
    cadence-variation 50
    so what it is and how to determine this parameters.

  • Is it possible to reduce the number of HTTP calls when using a ReportViewer control?

    My application is written in .Net 4 using Visual Studio 2010 (version 10 of the ReportViewer control). The report in question contains a lot of data in the dropdowns used for parameter selection. For example, one dropdown contains 95k options and another
    uses 24k options (I know this is bad design, but we need to keep it as-is for this release). When I use Fiddler to profile the report, I see that it makes a lot of HTTP calls and a majority return the same dataset. There are three phases of loading data. Each
    one initiates a series of HTTP calls.
    Loading the initial header with the filter controls (dropdowns, textboxes, etc).
    Changing one of the dropdowns that has a dependent dropdown (start date/end date)
    Loading the final report after clicking the View Report button
    In total, 13 HTTP calls are made and 10 of those are returning the same 10MB of data. The final report only returns 13 records, but the whole process of loading the report filters, changing report filters and loading the report require 130MB of data to be
    exchanged. This is an extreme example, but we do have other reports that are doing the same with smaller amounts of data.
    My question: is there any way to modify the ReportViewer or the SSRS server to reduce the number of calls? Is this related to ViewState? Please understand that I am new to Reporting Services and have a lot to learn.

    Hi rodeofive,
    As per my understanding, the issue is a performance issue. And it is caused by there are thousands of values in the drop-down list of parameters in the report.
    To work around this issue, I suggest you should make some changes in the report. For example, we can add additional two parameters with multiple keywords ahead, one for the dropdown contains 95k options, another for dropdown contains 24k options. Then all
    of available values which are begin with the keywords will display in the parameter list. In this scenario, we can create cascading parameters. One is a keyword parameter, and the other parameter is the drop-down list that based on the keyword to display the
    available values.
    For more details about the method, please refer to the following FAQ:
    http://social.msdn.microsoft.com/Forums/sqlserver/en-US/8de6c783-9cb4-4b95-9be8-b59bc0049866/forum-faqhow-do-i-add-a-search-feature-in-the-parameter-with-long-drop-down-list?forum=sqlreportingservices#8de6c783-9cb4-4b95-9be8-b59bc0049866
    Hope this helps.
    Thanks,
    Katherine Xiong
    Katherine Xiong
    TechNet Community Support

  • Can you make an SSL (https) call from a Java Stored Procedure?

    I have loaded a bunch of java classes. Ultimately, one of my routines makes an
    https call to another machine (https://machine:443/foo?xml...). I am receiving
    the following error message:
    SSL implementation not available
    I read
    http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_
    id=NOT&p_id=103051.1
    Which states
    3.17.6 You can not do SSL callouts from within 8i to other CORBA or EJBs. This
    also means that you can not callback with an SSL connection a CORBA object
    running in an 8i client.
    Does this mean that I can't do what I am trying to do from within 8.1.7?
    If there is any way to do this, I would really appreciate the advice. I need
    to call this Java API from a pl/sql routine, and it has to be via SSL. I would
    prefer to load all the Java into the database and avoid an exproc call.

    Anton/Joe,
    Yes, you can do this, but it might not be straightforward based on the version of Oracle you have. I've noticed there's a higher chance of getting this to work with 8.1.7 or higher (otherwise, you may need to load more classes, etc.). Mark Piermarini posted a nice example in a previous thread in this group:
    http://osi.oracle.com/~mbpierma/SSL_Java_DB.html
    Basically, he connected to UPS to get package tracking info.
    Hope this helps,
    -Dan
    http://www.compuware.com/products/devpartner/db/oracle_debug.htm
    Debug PL/SQL and Java in the Oracle Database

  • Change over from a simple Xml call to a rpc-Http call ....

    Hi there,
    I need to change over from a simple Xml call:
    <mx:XML id="urlsGeneral" source="http://www.mySite.com//.../AFS.xml"/>
    to a rpc-Http call which is updating the readout if Xml is changed at any time.
    I forgot to mention the most important item yet a very simple one: I need this only to be displayed in a title etc, and NOT a datagrid or else example below.
    title="{urlsGeneral.urlGeneral.(@name==0).age}
    I tried a lot today, but just can't get it right as the id="urlsGeneral" is always the problem.
    Any help would be appriciated !!! Thanks in advance. regards aktell2007
    <urlsGeneral>
    <urlGeneral>
    <name>Jim</name>
    <age>32</age>
    </urlGeneral>
    <urlGeneral>
    <name>Jim</name>
    <age>32</age>
    </urlGeneral>
    </urlsGeneral>
    Another call:
    <mx:Script>
    <![CDATA[
    import mx.collections.ArrayCollection;
    import mx.rpc.events.ResultEvent;
    public var myData:ArrayCollection;
    protected function myHttpService_resultHandler(event:ResultEvent):void {
    myData = event.result.urlsGeneral.urlGeneral;
    ]]>
    </mx:Script>
    <mx:HTTPService
    id="myHttpService"
    url="http://www.mySite.com//..../AFS.xml"
    result="myHttpService_resultHandler(event)"/>
    Preferable I wanted something like this to work:
    <mx:Script>
    <![CDATA[
    import mx.rpc.events.FaultEvent;
    import mx.managers.CursorManager;
    import mx.controls.Alert;
    import mx.rpc.events.ResultEvent;
    import mx.rpc.xml.SimpleXMLDecoder;
    // Don't use here as it is already used in .swc !
    /* import mx.rpc.http.HTTPService; */
    private var myHTTP:HTTPService;
    private function initConfigCall():void {
    myHTTP = new HTTPService();
    myHTTP.url = "com/assets/data/changesAppAIRPIOne001.xml";
    myHTTP.send();
    myHTTP.resultFormat = "xml";
    myHTTP.addEventListener(ResultEvent.RESULT, resultHandler);
    myHTTP.addEventListener(FaultEvent.FAULT, faultHandler);
    CursorManager.setBusyCursor();
    private function resultHandler(evt:ResultEvent):void {
    var xmlStr:String = evt.result.toString();
    var xmlDoc:XMLDocument = new XMLDocument(xmlStr);
    var decoder:SimpleXMLDecoder = new SimpleXMLDecoder(true);
    var resultObj:Object = decoder.decodeXML(xmlDoc);
    // Removed [0] on single node !
    appUpdateAvl.text = resultObj.application.configApp.appNewUpDate;
    appLastChanged.text = resultObj.application.configApp.appLastChanged;
    appChangedSections.text = resultObj.application.configApp.appChangedSections;
    CursorManager.removeBusyCursor();
    myHTTP.disconnect();
    private function faultHandler(event:mx.rpc.events.FaultEvent):void {
    var faultInfo:String="fault details: "+event.fault.faultDetail+"\n\n";
    faultInfo+="fault faultString: "+event.fault.faultString+"\n\n";
    mx.controls.Alert.show(faultInfo,"Fault Information");
    var eventInfo:String="event target: "+event.target+"\n\n";
    eventInfo+="event type: "+event.type+"\n\n";
    mx.controls.Alert.show(eventInfo,"Event Information");
    CursorManager.removeBusyCursor();
    myHTTP.disconnect();
    ]]>
    </mx:Script>

    Hi again,
    These days there are more quetions than answeres on any forum, and very seldom anybody shares the answer if they lucky enough to work it out so here is my answer for the above question
    Change over from a simple Xml call to a rpc-Http call ....
    I had it all along as a commend noted: // Removed [0] on single node !
    So instead of title="{urlsGeneral.urlGeneral.(@name==0).age} it would be now title="{resultObj.urlsGeneral.urlGeneral.[0].age} and now it works perfectly well. I hope that one or the other of you can use the answer and the code !!! regards aktell2007

  • Sender SOAP Adapter with HTTPs call

    Hello,
    Our scenarion is ..  we will have a sender SOAP adater .. but it needs to be called using HTTPs(SSL).
    Now considering we have the certificate generated and installed ..and that integration server is HTTPs enabled....What URL should the sending system call..?
    For normal HTTP call the inbound address for inbound Adapter is: http://host:port/XISOAPAdapter/MessageServlet?channel=party:service:channel
    For the case of HTTPs just changing the htttp to https and the port number in in the calling system will suffice? Or is there other configurations that needs to be done??
    Thanks and Regards,
    Himadri

    Hi Himadri,
    Firstly as suggested by others you can call using https and give the https port in the soap adapter servler URL. Secondly you need to do the following configurations:
    1) If its PI 7.0/3.0, deploy the latest version of the SAP Java cryptography toolkit.
    2) Configure SAP PI as the server for HTTPS calls. In short
          Using the SSL Provider service:
                                a.      Select whether the J2EE Engine should:
                                   ■      Request (but not require) that the user presents a client certificate for authentication.
                                   ■      Require that client certificates are to be used for authentication.
                                b.      Import the CAu2019s root certificate into the Trusted Certification Authorities list. (Choose Add.) using the following For all the steps, link is mentioned below for XI 3.0, you can find similar ones for PI 7.0
    http://help.sap.com/saphelp_nw04/helpdata/en/f1/2de3be0382df45a398d3f9fb86a36a/content.htm
    3) If you want to enable client authentication then you would need to add the client certificate in the TrustedCA keystore view of the SAP J2EE engine.
    4) In the SOAP Adapter sender channel, configure Inbound Security level as HTTPS or HTTPs with client authentication based on your scenario.
    Best Regards,
    Pratik

  • BPM Synchronous Call: Error HTTP call to IS unsupported in AEX case

    Hello,
    we had an PO System 7.4 SP 7 and tried to call  a synchronous Interface on PI via an "automated Activity".
    But we get the error
    "Could not invoke service reference name 0a5b605b-fc7a-410f-920a-0f6952dee18f......
    Error while sending message. Reason: Error sending MS message. Exception: HTTP call to IS unsupported in AEX case"
    in the same process to call an asynchromous  interface on PI is possible.
    We also did build the Process and Product complete new in the NWDS, but no change.
    Any Ideas ?
    Regards
       Thorsten

    Hello Thorsten,
    I have a similar issue right now. 
    My automated activity is relate to an idoc message
    XI30 -> PI -> IDOC_AAE.
    This is only the ICO for this step, but I have many other steps (syncrhronous) in this model and all of them Work fine.  Actually the idoc is processed, and ok, in ECC, but the entire process remain in "still processing" about 2 hours.
    You found the problem? any ideas?
    thank u.
    Regards
    Carlos Andres

  • HTTP Call to SOAP Sender Adapter

    Hi All,
    I'm working on a scenario where i plan to use SOAP Sender Adapter for receiving Plain HTTP Calls from the client.
    The purpose behind this exercise is to have control over the message flow in case of sender HTTP protocol in XI.
    I configured a SOAP channel and used the option 'DO Not Use SOAP Envelope'. But when i post  the message to the adapter engine using a HTTP client, it fails.
    Can somebody guide me in this case.
    Regards,
    Anurag

    Hi,
    >>>But when i post the message to the adapter engine using a HTTP client, it fails.
    with which error ?
    Regards,
    Michal Krawczyk

  • Ipad shows all regular Iphone inbound calls as Facetime.  I only want true FT calls to appear. I switch audio/video and it still happens.  How can I set the Ipad to only register true facetime calls rather than all inbound regular calls?  thanks

    My Ipad  will show all regular inbound calls, from Iphone, as Facetime calls.  I would like only TRUE facetime calls to appear. I have switched audio/video on Ipad but it still happens.  How can I set the Ipad to only register only true FT calls rather than all inbound calls that a re not facetime calls?  Yes, you may have to reread this twice and slowly to understand..... Thanks!

    Hi webn,
    I understand that you do not wish to see phone calls on your iPad anymore. I have an article for you with some information on accomplishing this goal:
    Connect your iPhone, iPad, iPod touch, and Mac using Continuity - Apple Support
    https://support.apple.com/en-us/HT6337
    Turn off iPhone cellular calls
    To turn off iPhone cellular calls on your iPad or iPod touch, go to Settings > FaceTime and turn off iPhone Cellular Calls.
    On your Mac, open the FaceTime app and go to FaceTime > Preferences. Click Settings and deselect the iPhone Cellular Calls option.
    Thanks for coming to the Apple Support Communities!
    Cheers,
    Braden

  • Cant see synchronous http-calls in message monitoring

    Hi all,
    I 've got a synchronous http call. When the request was bad I saw the failed request and response messages in XI message monitoring with red lights. But now the call seems to work fine, because the sequenced step is showing. But I can not see the http-message in message monitoring.
    Any ideas?
    Regards
    Mathias

    hi,
    have a look at my blog:
    /people/michal.krawczyk2/blog/2005/05/10/xi-i-cannot-see-some-of-my-messages-in-the-sxmbmoni
    how to turn it on
    logging_sync
    Regards,
    michal
    <a href="/people/michal.krawczyk2/blog/2005/06/28/xipi-faq-frequently-asked-questions"><b>XI / PI FAQ - Frequently Asked Questions</b></a>

  • Recently upgraded to iOS7.0 on my iPhone 4s. The Phone app is not showing any 'all' or 'missed' calls under the Recents icon.

    I recently upgraded my iPhone 4S to iOS7. I noticed that when I place calls or receive calls there Phone app - under Recents does not show any calls under 'all' or 'missed' calls.

    Try This...
    Close All Open Apps... Sign Out of your Account... Perform a Reset... Try again...
    Reset  ( No Data will be Lost )
    Press and hold the Sleep/Wake button and the Home button at the same time for at least ten seconds, until the Apple logo appears. Release the Buttons.
    http://support.apple.com/kb/ht1430

Maybe you are looking for

  • Decode a blob field with a C script in a select query

    HI I have a coded field in a table which has been populated using 3rd party software. I need to decode this field so that i could rub a few reports. I have a C script that can decode this field but do not know how to call it up from a select statemen

  • Screen Exit for LT12

    Hi Folks,   I need a help regarding Screen Exit for LT12 Tcod.My requirement is to add a screen for Serial Number Keyin for a material and confirm the TO.I try to find an Exit and a Badi where i can put my Custom logic which updats the Serial Number

  • Hey hi i am a iOS developer just wanted to know is there a way that i can know that the user of my app has deleted my app plzz reply its really urgent......

    iOS5 iphone 4s I recently developed a App and wanted to know has the user deleted the app??? The Scenario is like Consider a User ...... In my App he adds 100 tasks and scedules it for APNS on a daily basis and deletes the app and on the other day ag

  • InDesign CS5 Crashing on Launch

    Hello, InDesign CS5 Hangs on launch at "Calling Late Initializers" Has been fine, just started doing it. Win7 64 generates the following error report Problem signature:   Problem Event Name:    APPCRASH   Application Name:    InDesign.exe   Applicati

  • Lost admin username

    I am on my fathers computer and he cannot install any new update because he dont know he username. I know the password but it seams that the username is wrong. I can see in preference system user account; Mario  Masse and it looks like theres 2 "spac