Internal error int reply to ClientHello on ACE20 module with end-to-end SSL

Hello, world!
We have weird behaviour of our Cisco ACE20 module configured for end-to-end SSL (initiation+termination) - the module from time to time replies with SSLv3/TLSv1 alert "Fatal: internal error" message to the client right after client have sent 'ClientHello' SSL message. So sometimes SSL connection works and sometimes will be immediately closed due to this fatal error. The behaviour is very similar to the one described below:
CSCtc52085—After a client sends a ClientHello message, the SSL hand shake may fail with a fatal alert internal error sent by the ACE. This behavior is intermittent and may occur under the following conditions:
1. An SSL service is configured with the session-cache timeout command (session reuse).
2. SSL connections are aborted by the client after the client sends a ClientHello message to the service in condition 1 and before an internal resource state is changed. This behavior puts the internal resource in an improper state. This error is very timing sensitive.
3. The next connection that uses the internal resource in the improper state fails with a fatal alert internal error. That connection does not have to go to the service in condition 1 to experience this error because the internal resource is shared by all the SSL services.
Workaround: None.
But we have software version A2(3.1) and this bug must have been resolved in this release (at least it's listed in resolved caveats section of release notes).
Software
  loader:    Version 12.2[123]
  system:    Version A2(3.1) [build 3.0(0)A2(3.1)]
  system image file: [LCP] disk0:c6ace-t1k9-mz.A2_3_1.bin
Again, we don't have session-cache timeout configured on the ACE.
On the ACE we have following stats:
ACE1/VC_UNIX# sh stats crypto server
SSL Server Statistics:
SSL alert CLOSE_NOTIFY rcvd:                      0
SSL alert UNEXPECTED_MSG rcvd:                    0
SSL alert BAD_RECORD_MAC rcvd:                    0
SSL alert DECRYPTION_FAILED rcvd:                 0
SSL alert RECORD_OVERFLOW rcvd:                   0
SSL alert DECOMPRESSION_FAILED rcvd:              0
SSL alert HANDSHAKE_FAILED rcvd:                  0
SSL alert NO_CERTIFICATE rcvd:                    0
SSL alert BAD_CERTIFICATE rcvd:                   0
SSL alert UNSUPPORTED_CERTIFICATE rcvd:           0
SSL alert CERTIFICATE_REVOKED rcvd:               0
SSL alert CERTIFICATE_EXPIRED rcvd:               0
SSL alert CERTIFICATE_UNKNOWN rcvd:               0
SSL alert ILLEGAL_PARAMETER rcvd:                 0
SSL alert UNKNOWN_CA rcvd:                        0
SSL alert ACCESS_DENIED rcvd:                     0
SSL alert DECODE_ERROR rcvd:                      0
SSL alert DECRYPT_ERROR rcvd:                     0
SSL alert EXPORT_RESTRICTION rcvd:                0
SSL alert PROTOCOL_VERSION rcvd:                  0
SSL alert INSUFFICIENT_SECURITY rcvd:             0
SSL alert INTERNAL_ERROR rcvd:                    0
SSL alert USER_CANCELED rcvd:                     0
SSL alert NO_RENEGOTIATION rcvd:                  0
SSL alert CLOSE_NOTIFY sent:                      0
SSL alert UNEXPECTED_MSG sent:                    1
SSL alert BAD_RECORD_MAC sent:                    0
SSL alert DECRYPTION_FAILED sent:                 0
SSL alert RECORD_OVERFLOW sent:                   0
SSL alert DECOMPRESSION_FAILED sent:              0
SSL alert HANDSHAKE_FAILED sent:                  2
SSL alert NO_CERTIFICATE sent:                    0
SSL alert BAD_CERTIFICATE sent:                   0
SSL alert UNSUPPORTED_CERTIFICATE sent:           0
SSL alert CERTIFICATE_REVOKED sent:               0
SSL alert CERTIFICATE_EXPIRED sent:               0
SSL alert CERTIFICATE_UNKNOWN sent:               0
SSL alert ILLEGAL_PARAMETER sent:                 0
SSL alert UNKNOWN_CA sent:                        0
SSL alert ACCESS_DENIED sent:                     0
SSL alert DECODE_ERROR sent:                      0
SSL alert DECRYPT_ERROR sent:                     0
SSL alert EXPORT_RESTRICTION sent:                0
SSL alert PROTOCOL_VERSION sent:                  0
SSL alert INSUFFICIENT_SECURITY sent:             0
SSL alert INTERNAL_ERROR sent:                   16
SSL alert USER_CANCELED sent:                     0
SSL alert NO_RENEGOTIATION sent:                  0
SSLv2 client hello received:                      0
SSLv3 client hello received:                      0
TLSv1 client hello received:                     68
SSLv3 negotiated protocol:                        0
TLSv1 negotiated protocol:                       68
SSLv3 full handshakes:                            0
SSLv3 resumed handshakes:                         0
Cipher sslv3_rsa_rc4_128_md5:                     0
Cipher sslv3_rsa_rc4_128_sha:                     0
Cipher sslv3_rsa_des_cbc_sha:                     0
Cipher sslv3_rsa_3des_ede_cbc_sha:                0
Cipher sslv3_rsa_exp_rc4_40_md5:                  0
Cipher sslv3_rsa_exp_des40_cbc_sha:               0
Cipher sslv3_rsa_exp1024_rc4_56_md5:              0
Cipher sslv3_rsa_exp1024_des_cbc_sha:             0
Cipher sslv3_rsa_exp1024_rc4_56_sha:              0
Cipher sslv3_rsa_aes_128_cbc_sha:                 0
Cipher sslv3_rsa_aes_256_cbc_sha:                 0
TLSv1 full handshakes:                           33
TLSv1 resumed handshakes:                         0
Cipher tlsv1_rsa_rc4_128_md5:                    68
Cipher tlsv1_rsa_rc4_128_sha:                     0
Cipher tlsv1_rsa_des_cbc_sha:                     0
Cipher tlsv1_rsa_3des_ede_cbc_sha:                0
Cipher tlsv1_rsa_exp_rc4_40_md5:                  0
Cipher tlsv1_rsa_exp_des40_cbc_sha:               0
Cipher tlsv1_rsa_exp1024_rc4_56_md5:              0
Cipher tlsv1_rsa_exp1024_des_cbc_sha:             0
Cipher tlsv1_rsa_exp1024_rc4_56_sha:              0
Cipher tlsv1_rsa_aes_128_cbc_sha:                 0
Cipher tlsv1_rsa_aes_256_cbc_sha:                 0
Total SSL client authentications:                 0
Failed SSL client authentications:                0
SSL authentication cache hits:                    0
SSL static CRL lookups:                           0
SSL best effort CRL lookups:                      0
SSL CRL lookup cache hits:                        0
SSL revoked certificates:                         0
Total SSL server authentications:                 0
Failed SSL server authentications:                0
Session headers extracted:                        0
Session headers failed:                           0
Server cert headers extracted:                    0
Server cert headers failed:                       0
Client cert headers extracted:                    0
Client cert headers failed:                       0
Headers truncated:                                0
Redirects due to cert not yet valid:              0
Redirects due to cert expired:                    0
Redirects due to unknown issuer cert:             0
Redirects due to cert revoked:                    0
Redirects due to no client cert:                  0
Redirects due to no CRL available:                0
Redirects due to expired CRL:                     0
Redirects due to bad cert signature:              0
Redirects due to other cert error:                0
Internal error:                                  27
Handshake FlushRX operations:                     0
Handshake FlushTX operations:                     0
Xscale messages rcvd from ME:               1313330
Xscale messages sent to ME:                 2041768
Finish msg split across ssl recs:                 0
Fasttx msg ring full:                             0
SSL_ME tx msg ring full:                          0
N2 encrypt_record:                                0
N2 decrypt_record:                           144433
N2 random:                                   439915
N2 handshake_hash:                           878094
N2 hash:                                          0
N2 gpop_master:                              291164
N2 gpop_import_master_secret:                     5
N2 gpop_pkcs1v15enc:                         144430
N2 gpop_pkcs1v15enc_crt:                          0
N2 gpop_finish:                              291140
N2 gpop_verify:                                   0
N2 gpop_pkcs1v15dec:                              0
N2 gpop_pkcs1v15dec_crt:                     146752
N2 rsa_server_full:                              15
N2 resume:                                       12
UXP A:                                        24576
UXP B:                                            0
The "Internal error" counter increases with failed connections.
Printscreen from wireshark attached.
Maybe someone has the problem like ours? I have no idea how to troubleshoot these "internal errors"... :-(
Thanks for your replies.

Thanks for your reply.
The problem is not server-related, I have exactly the same situation if I do SSL termination only, with unencrypted connection between ACE and backend servers (another servers, with blank apache installed and listening on 443 port for non-SSL traffic) - generally speaking, it works, but often with these "internal errors" - not suitable for production.
Here is the output from the commands
# show np 1 me-stats -E0
SSL Server Statistics:
SSL alert CLOSE_NOTIFY rcvd:                      0
SSL alert UNEXPECTED_MSG rcvd:                    0
SSL alert BAD_RECORD_MAC rcvd:                    0
SSL alert DECRYPTION_FAILED rcvd:                 0
SSL alert RECORD_OVERFLOW rcvd:                   0
SSL alert DECOMPRESSION_FAILED rcvd:              0
SSL alert HANDSHAKE_FAILED rcvd:                  0
SSL alert NO_CERTIFICATE rcvd:                    0
SSL alert BAD_CERTIFICATE rcvd:                   0
SSL alert UNSUPPORTED_CERTIFICATE rcvd:           0
SSL alert CERTIFICATE_REVOKED rcvd:               0
SSL alert CERTIFICATE_EXPIRED rcvd:               0
SSL alert CERTIFICATE_UNKNOWN rcvd:               0
SSL alert ILLEGAL_PARAMETER rcvd:                 0
SSL alert UNKNOWN_CA rcvd:                        0
SSL alert ACCESS_DENIED rcvd:                     0
SSL alert DECODE_ERROR rcvd:                      0
SSL alert DECRYPT_ERROR rcvd:                     0
SSL alert EXPORT_RESTRICTION rcvd:                0
SSL alert PROTOCOL_VERSION rcvd:                  0
SSL alert INSUFFICIENT_SECURITY rcvd:             0
SSL alert INTERNAL_ERROR rcvd:                    0
SSL alert USER_CANCELED rcvd:                     0
SSL alert NO_RENEGOTIATION rcvd:                  0
SSL alert CLOSE_NOTIFY sent:                      0
SSL alert UNEXPECTED_MSG sent:                    0
SSL alert BAD_RECORD_MAC sent:                    0
SSL alert DECRYPTION_FAILED sent:                 0
SSL alert RECORD_OVERFLOW sent:                   0
SSL alert DECOMPRESSION_FAILED sent:              0
SSL alert HANDSHAKE_FAILED sent:                  0
SSL alert NO_CERTIFICATE sent:                    0
SSL alert BAD_CERTIFICATE sent:                   0
SSL alert UNSUPPORTED_CERTIFICATE sent:           0
SSL alert CERTIFICATE_REVOKED sent:               0
SSL alert CERTIFICATE_EXPIRED sent:               0
SSL alert CERTIFICATE_UNKNOWN sent:               0
SSL alert ILLEGAL_PARAMETER sent:                 0
SSL alert UNKNOWN_CA sent:                        0
SSL alert ACCESS_DENIED sent:                     0
SSL alert DECODE_ERROR sent:                      0
SSL alert DECRYPT_ERROR sent:                     0
SSL alert EXPORT_RESTRICTION sent:                0
SSL alert PROTOCOL_VERSION sent:                  0
SSL alert INSUFFICIENT_SECURITY sent:             0
SSL alert INTERNAL_ERROR sent:                    0
SSL alert USER_CANCELED sent:                     0
SSL alert NO_RENEGOTIATION sent:                  0
SSLv2 client hello received:                      0
SSLv3 client hello received:                      0
TLSv1 client hello received:                      0
SSLv3 negotiated protocol:                        0
TLSv1 negotiated protocol:                        0
SSLv3 full handshakes:                            0
SSLv3 resumed handshakes:                         0
Cipher sslv3_rsa_rc4_128_md5:                     0
Cipher sslv3_rsa_rc4_128_sha:                     0
Cipher sslv3_rsa_des_cbc_sha:                     0
Cipher sslv3_rsa_3des_ede_cbc_sha:                0
Cipher sslv3_rsa_exp_rc4_40_md5:                  0
Cipher sslv3_rsa_exp_des40_cbc_sha:               0
Cipher sslv3_rsa_exp1024_rc4_56_md5:              0
Cipher sslv3_rsa_exp1024_des_cbc_sha:             0
Cipher sslv3_rsa_exp1024_rc4_56_sha:              0
Cipher sslv3_rsa_aes_128_cbc_sha:                 0
Cipher sslv3_rsa_aes_256_cbc_sha:                 0
TLSv1 full handshakes:                            0
TLSv1 resumed handshakes:                         0
Cipher tlsv1_rsa_rc4_128_md5:                     0
Cipher tlsv1_rsa_rc4_128_sha:                     0
Cipher tlsv1_rsa_des_cbc_sha:                     0
Cipher tlsv1_rsa_3des_ede_cbc_sha:                0
Cipher tlsv1_rsa_exp_rc4_40_md5:                  0
Cipher tlsv1_rsa_exp_des40_cbc_sha:               0
Cipher tlsv1_rsa_exp1024_rc4_56_md5:              0
Cipher tlsv1_rsa_exp1024_des_cbc_sha:             0
Cipher tlsv1_rsa_exp1024_rc4_56_sha:              0
Cipher tlsv1_rsa_aes_128_cbc_sha:                 0
Cipher tlsv1_rsa_aes_256_cbc_sha:                 0
Total SSL client authentications:                 0
Failed SSL client authentications:                0
SSL authentication cache hits:                    0
SSL static CRL lookups:                           0
SSL best effort CRL lookups:                      0
SSL CRL lookup cache hits:                        0
SSL revoked certificates:                         0
Total SSL server authentications:                 0
Failed SSL server authentications:                0
Session headers extracted:                        0
Session headers failed:                           0
Server cert headers extracted:                    0
Server cert headers failed:                       0
Client cert headers extracted:                    0
Client cert headers failed:                       0
Headers truncated:                                0
Redirects due to cert not yet valid:              0
Redirects due to cert expired:                    0
Redirects due to unknown issuer cert:             0
Redirects due to cert revoked:                    0
Redirects due to no client cert:                  0
Redirects due to no CRL available:                0
Redirects due to expired CRL:                     0
Redirects due to bad cert signature:              0
Redirects due to other cert error:                0
Internal error:                                   0
SSL Client Statistics:
SSL alert CLOSE_NOTIFY rcvd:                      0
SSL alert UNEXPECTED_MSG rcvd:                    0
SSL alert BAD_RECORD_MAC rcvd:                    0
SSL alert DECRYPTION_FAILED rcvd:                 0
SSL alert RECORD_OVERFLOW rcvd:                   0
SSL alert DECOMPRESSION_FAILED rcvd:              0
SSL alert HANDSHAKE_FAILED rcvd:                  0
SSL alert NO_CERTIFICATE rcvd:                    0
SSL alert BAD_CERTIFICATE rcvd:                   0
SSL alert UNSUPPORTED_CERTIFICATE rcvd:           0
SSL alert CERTIFICATE_REVOKED rcvd:               0
SSL alert CERTIFICATE_EXPIRED rcvd:               0
SSL alert CERTIFICATE_UNKNOWN rcvd:               0
SSL alert ILLEGAL_PARAMETER rcvd:                 0
SSL alert UNKNOWN_CA rcvd:                        0
SSL alert ACCESS_DENIED rcvd:                     0
SSL alert DECODE_ERROR rcvd:                      0
SSL alert DECRYPT_ERROR rcvd:                     0
SSL alert EXPORT_RESTRICTION rcvd:                0
SSL alert PROTOCOL_VERSION rcvd:                  0
SSL alert INSUFFICIENT_SECURITY rcvd:             0
SSL alert INTERNAL_ERROR rcvd:                    0
SSL alert USER_CANCELED rcvd:                     0
SSL alert NO_RENEGOTIATION rcvd:                  0
SSL alert CLOSE_NOTIFY sent:                      0
SSL alert UNEXPECTED_MSG sent:                 4108
SSL alert BAD_RECORD_MAC sent:                    0
SSL alert DECRYPTION_FAILED sent:                 0
SSL alert RECORD_OVERFLOW sent:                   0
SSL alert DECOMPRESSION_FAILED sent:              0
SSL alert HANDSHAKE_FAILED sent:              63355
SSL alert NO_CERTIFICATE sent:                    0
SSL alert BAD_CERTIFICATE sent:                   0
SSL alert UNSUPPORTED_CERTIFICATE sent:           0
SSL alert CERTIFICATE_REVOKED sent:               0
SSL alert CERTIFICATE_EXPIRED sent:               0
SSL alert CERTIFICATE_UNKNOWN sent:               0
SSL alert ILLEGAL_PARAMETER sent:                 0
SSL alert UNKNOWN_CA sent:                        0
SSL alert ACCESS_DENIED sent:                     0
SSL alert DECODE_ERROR sent:                      0
SSL alert DECRYPT_ERROR sent:                     0
SSL alert EXPORT_RESTRICTION sent:                0
SSL alert PROTOCOL_VERSION sent:                  0
SSL alert INSUFFICIENT_SECURITY sent:             0
SSL alert INTERNAL_ERROR sent:                37662
SSL alert USER_CANCELED sent:                     0
SSL alert NO_RENEGOTIATION sent:                  0
SSLv2 client hello received:                      0
SSLv3 client hello received:                      0
TLSv1 client hello received:                      0
SSLv3 negotiated protocol:                        0
TLSv1 negotiated protocol:                  4062020
SSLv3 full handshakes:                            0
SSLv3 resumed handshakes:                         0
Cipher sslv3_rsa_rc4_128_md5:                     0
Cipher sslv3_rsa_rc4_128_sha:                     0
Cipher sslv3_rsa_des_cbc_sha:                     0
Cipher sslv3_rsa_3des_ede_cbc_sha:                0
Cipher sslv3_rsa_exp_rc4_40_md5:                  0
Cipher sslv3_rsa_exp_des40_cbc_sha:               0
Cipher sslv3_rsa_exp1024_rc4_56_md5:              0
Cipher sslv3_rsa_exp1024_des_cbc_sha:             0
Cipher sslv3_rsa_exp1024_rc4_56_sha:              0
Cipher sslv3_rsa_aes_128_cbc_sha:                 0
Cipher sslv3_rsa_aes_256_cbc_sha:                 0
TLSv1 full handshakes:                      4015344
TLSv1 resumed handshakes:                         0
Cipher tlsv1_rsa_rc4_128_md5:                     0
Cipher tlsv1_rsa_rc4_128_sha:                     0
Cipher tlsv1_rsa_des_cbc_sha:                     0
Cipher tlsv1_rsa_3des_ede_cbc_sha:                0
Cipher tlsv1_rsa_exp_rc4_40_md5:                  0
Cipher tlsv1_rsa_exp_des40_cbc_sha:               0
Cipher tlsv1_rsa_exp1024_rc4_56_md5:              0
Cipher tlsv1_rsa_exp1024_des_cbc_sha:             0
Cipher tlsv1_rsa_exp1024_rc4_56_sha:              0
Cipher tlsv1_rsa_aes_128_cbc_sha:           4062020
Cipher tlsv1_rsa_aes_256_cbc_sha:                 0
Total SSL client authentications:                 0
Failed SSL client authentications:                0
SSL authentication cache hits:              4059147
SSL static CRL lookups:                           0
SSL best effort CRL lookups:                      0
SSL CRL lookup cache hits:                        0
SSL revoked certificates:                         0
Total SSL server authentications:           4059888
Failed SSL server authentications:                0
Session headers extracted:                        0
Session headers failed:                           0
Server cert headers extracted:                    0
Server cert headers failed:                       0
Client cert headers extracted:                    0
Client cert headers failed:                       0
Headers truncated:                                0
Redirects due to cert not yet valid:              0
Redirects due to cert expired:                    0
Redirects due to unknown issuer cert:             0
Redirects due to cert revoked:                    0
Redirects due to no client cert:                  0
Redirects due to no CRL available:                0
Redirects due to expired CRL:                     0
Redirects due to bad cert signature:              0
Redirects due to other cert error:                0
Internal error:                               20380
Handshake FlushRX operations:                     0
Handshake FlushTX operations:                     0
Xscale messages rcvd from ME:              12092768
Xscale messages sent to ME:              0x0176adac
Finish msg split across ssl recs:                 0
Fasttx msg ring full:                             0
SSL_ME tx msg ring full:                          0
N2 encrypt_record:                                0
N2 decrypt_record:                          4015344
N2 random:                                  8148797
N2 handshake_hash:                          4322635
N2 hash:                                          0
N2 gpop_master:                             4041700
N2 gpop_import_master_secret:                     0
N2 gpop_pkcs1v15enc:                        4041700
N2 gpop_pkcs1v15enc_crt:                          0
N2 gpop_finish:                             4031710
N2 gpop_verify:                                   0
N2 gpop_pkcs1v15dec:                              0
N2 gpop_pkcs1v15dec_crt:                          0
N2 rsa_server_full:                               0
N2 resume:                                        0
UXP A:                                        24576
UXP B:                                            0
# show np 1 me-stats "-shttp -v"
HTTP Statistics (Current)
Unknown msgs received:                            0             0
Data rx msgs received:                    288293958             4
TCP proxy rx msgs received:                 9816884             1
Ack trigger rx msgs received:                     0             0
TCP event rx msgs received:                52961189             2
Dest decision tx msgs received:            55155089             1
LB dest decision tx msgs received:                0             0
Close tx msgs received:                    83942817             0
Inspect allow tx msgs received:                   0             0
Inspect drop tx msgs received:                    0             0
DRAM blocks read:                         577612022            16
Buffers dropped:                            2702255             0
Regex states read:                         38438408            25
Unproxy cancellations:                            0             0
Redundant closes:                           2990271             0
Internal errors:                                  0             0
Conn mismatch errors:                       2748628             0
Exception with close:                             6             0
Dest errors:                                      1             0
Total Packet count (Tx  & Rx):            490169937             8
Stop regex:                                      12             0
(Context 5 Statistics)
Parse result LB msgs sent:                   121180             0
Drop: LB queue full:                              0             0
Parse result Inspect msgs sent:                   0             0
Drop: Inspect queue full:                         0             0
TCP data msgs sent:                           96215             0
TCP queue full:                                   0             0
SSL data msgs sent:                          516306             0
SSL queue full:                                   0             0
TCP fin msgs sent:                              939             0
TCP rst msgs sent:                              147             0
SSL fin msgs sent:                           102907             0
SSL rst msgs sent:                            38548             0
Bounced fin msgs sent:                         1481             0
Bounced rst msgs sent:                            2             0
Unproxy msgs sent:                            25333             0
Drain msgs sent:                             113966             0
Reuse msgs sent:                               2304             0
Particles read:                             1448314             0
HTTP requests:                               121688             0
Reproxied requests:                           17680             0
Headers inserted:                              3825             0
Headers removed:                                 51             0
Headers rewritten:                                0             0
HTTP redirects:                                   0             0
HTTP chunks:                                  42154             0
Unproxy conns:                                25325             0
Pipelined requests:                               0             0
Pipeline flushes:                                 0             0
Whitespace appends:                               0             0
Response entries recycled:                    24493             0
Second pass parsing:                              0             0
Vserver mismatch errors:                          5             0
Analysis errors:                                  0             0
Static parse errors:                             20             0
Max parselen errors:                              0             0
Resource errors:                                 75             0
Invalid path errors:                              0             0
Bad HTTP version errors:                          0             0
Header insert errors:                            75             0
Header rewrite errors:                            0             0
Invalid policy errors:                            0             0
Invalid rserver errors:                           0             0
Recycled requests:                                0             0
SSL header insert success:                        0             0
SSL header insert errors:                         0             0
SSL spoof header deleted:                         0             0
Drop: RST pipelined request:                      0             0
There's nothing in ACE logs.
Forgot to mention - we are running ACE in one-arm mode, but I don't believe it makes a difference.

Similar Messages

  • Internal error in FORM/FUNCTION CKMC_REVALUATE_ENDING_STOCK in position 1 with RC

    Hello SAP Gurus,
    I am getting this error while trying to close a material in Material Ledger Cockpit
    Internal error in FORM/FUNCTION CKMC_REVALUATE_ENDING_STOCK in position 1 with RC
    Message no. C+099
    Procedure
    Please inform your system administrator.
    CKMC reports no inconsistency.
    Does anyone have any suggestion?
    Cheers,
    TD

    Shipa,
    Thanks for your suggestions.  Thanks for taking the time to help.
    I was able to resolve these issues using the following steps in our sandbox/test environments.  I have also included other problems I faced in material ledger month end closing steps for the benefit of readers.
    **** Caution:  Do not do the following steps in production environment.  You will destroy your production data irretrievably.  Material Ledger is unforgiving!!! ***
    1.  For the materials with "Internal Error in Form/Function etc issue, I performed a CKMM in the respective plants changing for 3S to 2S and then did the same in reverse (2S to 3S).  Then ran the ML close.  This seems to have temporarily solved the problem.
    2.  I was also getting a short dump -- either during MMPV or during period close in the cockpit.  The message at both times was "Error in MLCCS ...".  I realized it related to Cost Component Split.  I identified the company codes of the materials that caused the errors, then got all the plants within each of these company codes.  I ran MLCCS_RESET and then MLCCS_Startup in SE38.  Then ran MMPV/ML Close.  This seems to have resolved the issues at least temporarily.
    3.  Occasionally I noticed some "material valuation is inconsistent in valuation area xxxx" error.  I executed steps 1 and 2 above in succession.  This seems to have resolved the issue temporarily.
    4.  There was also the issue of "duplicate entry in CKMLKEV" while performing Single/Multi-Level steps in the closing cockpit.  This pointed to MLCCS.  So I ran step 2 above.  Again this seems to have fixed the issue temporarily.
    I was able to accomplish all of these using the steps above because these were in our test environments.  The reasons as to why these happened are manifold:
    MMPV was not carried out for a long, long, long time in certain plants within a company code.  When ML is active, it is necessary to close previous period.  In cases where MMPV was not carried out for a long time, I ran CKMHELP program to set the material status to 70 for the immediately preceding posting period.  This helped run the ML cockpit for the current/previous periods.
    Users were processing too many transactions with unrealistically large quantities and prices resulting in overflow errors.  I carried out reversal of movements for each process category to reduce the inventory balances to reasonable quantities, and ran MR21 to set the prices correctly.  This helped resolve the overflow issue.
    Reckless, repeated running of CKMM and MLCCS_Reset/MLCCS_Startup also contributed to these problems.  Every time a standard had to be released, but the material status in ML is "30-Quantities and Values entered", would prevent users from doing that. So they resort to CKMM and then reset status using CKMHELP program to set the status to 10 and then release the new cost.  It works, but wreaks havoc on ML as a whole eventually.
    Hope my comments are useful for some!!!
    Cheers,
    TD

  • Internal error in FORM/FUNCTION CKML_F_BUILD_INDEX in position 1 with RC 4

    Hi,
    Whenever I am trying to post a GR against PO I am receiving the following error message:
    Internal error in FORM/FUNCTION CKML_F_BUILD_INDEX in position 1 with RC 4
    I am not able to understand what this message is telling.
    How to resolve. Pl suggest.
    Regds
    Amitava

    error is because of a program bug,
    fix can be found in OSS note 1015263

  • Internal error in FORM/FUNCTION OUTSPLIT_SCLAE_UPDOWN in position 1 with RC

    Hi All,
    when I try to do MFBF with reporting points I'm getting error "internal error in FORM/FUNCTION OUTSPLIT_SCLAE_UPDOWN in position 1 with RC4" can anybody give me some idea to how to comeout of this error.
    Thanks and Regards
    Ramana

    we have contacted SAP and they have resolved the issue.
    Regards
    Ramana

  • Internal error in FORM/FUNCTION CKMLKEPH_ROLLUP in position 2 with RC 4

    The order settlement terminates with the error Message no. MLCCS 099 "Internal error in FORM/FUNCTION CKMLKEPH_ROLLUP in position 2 with RC 4".
    The material ledger is active. The actual cost component split is active. I want to  carry out the order settlement for one plants.
    With the same production material no.in the plant. There are many other productin order are settled in thid period. But, only one production order got the error message, why?
    I knew that I could change the Price determ. (in material master) from 3 Single-/multi-level to 2          Activity-related, then I can continute settlement transaction in CO88. But , I want to know what's wrong this the order. What should I check about the order. Why other orders are settled without error with the same material no, and  plant.
    I had check about SAP note 711416 & 729901 & 523100 & 623701 & 653523, those can't slove my problem in CO88.

    Thanks for your answer.
    But, I have two production orders product the same material in the same plant and  will be settled in this period. Both of those two orders were consumed material in 3 months ago. But, only one of them were terminated with error message in CO88. Why? How can I find out the difference between those two orders? They seems the same.
    For SAP note 623701 & 871926 & 867755, I think we already implemented those. I had found program "MLCCS_KO88_TREATMENT " in SE38. And, I can find the message 013 & 015 in message class MLCCS. So, do you have other commendations?
    Do you know how could I check about "Display order history" that mentioned in note 86775. Which T-code should I go to?
    Thanks a lot.

  • Internal error in LMLCCS_UPDATEF02 LCL_DB method get_normvector position A with RC 1 when VL31N processing only

    HI Everyone,
    I have mentioned error (Internal error in LMLCCS_UPDATEF02 LCL_DB method get_normvector position A with RC 1) only when I try to process IB GR in transaction VL31N.
    This problem does not occur in other Material related transaction.
    The Plan that we have problem was created many years ago and also ML was activated at that time.
    We did not any changes to ML settings since.
    I had revived followings notes:
    639675 - Initialization of the actual cost component split
    710808 - Activating actual cost comp split: check actual costing
    584904 - MIRO: no procurement alternative/wrong price diff in ML
    Seems like first one fit our problem the best, but in our cases we do not activated component split after the material ledger production startup and also we do not have such problem besides VL31N. In addition using above solution, even try, would lead to lost of historical data which we would like to avoid.
    Does anyone faced similar issue and have an idea how to deal with this?
    Thanks,
    Rafał

    Hi Felipe,
    Raise an message to sap.When you are getting this dump.
    Regards,
    Madhu.

  • KO88:Internal error in FORM/FUNCTION CKMLKEPH_ROLLUP in position 2 with RC

    hi,expert,
       When i settle production order , it issue MLCSS099 error.
       The message is ' Internal error in FORM/FUNCTION CKMLKEPH_ROLLUP in position 2 with RC 8'.
       The report 'MLCCS_KO88_TREATMENT' can not solve the problem.
       How to correct this?
      Thanks for advance.
    Tony

    Hi Tony,
    The error during the order settlement is produced because in earlier
    periods the cost component split for standard price is missing
    for the materials involved in the order that you are trying to settle
    with KO88.
    Please, change the settings in report MLCCS_KO88_TREATMENT to treatment
    option "S" for this order as explained in the note 623701.
    You need to delete the existing entry settings in program
    MLCCS_KO88_TREATMENT first.
    Afterwards, it should be possible to maintain the new settings for
    period ?/2011 (treatment type 'Split Delta by S price').
    Therefore, the steps should be:
    1. Delete the existing entry in program MLCCS_KO88_TREATMENT
       (-> processing type: delete settings), for the company code
       and period X/XXXX.
    2. Maintain option = 'Split Delta according to Standard Price,'
       with report MLCCS_KO88_TREATMENT for the orders that are causing
       the problem and period X/2011.
    I hope this helps you to solve the problem.
    Kind regards,
    MLM

  • Custom Oracle Report errored with Enter Password:  REP-0004: Warning: Unable to open user preference file. REP-0300: ORACLE error occurred. REP-0069: Internal error REP-57054: In-process job terminated:Terminated with error:  REP-300: ORACLE error occurre

    Hi Gurus
    We have created a custom oracle report and concurrent program and when we ran the concurrent program it is error out with below error
    Enter Password:
    REP-0004: Warning: Unable to open user preference file.
    REP-0300: ORACLE error occurred.
    REP-0069: Internal error
    REP-57054: In-process job terminated:Terminated with error:
    REP-300: ORACLE error occurred.
    Can any one help us
    Thanks in advance.
    Kumar

    Please see
    REP-0004 Warning - Unable to Open User Preference File. (Doc ID 26014.1)
    ApPsMaStI
    sharing is Caring

  • Internal Error when trying to create a custom controller with execute comma

    Hi,
    I have got the following problem. I created a new web dynpro project and added an existing RFC model. But when I try to create a custom controller by applying a service controller including an execute command, I only get an internal error message. The message shows the following information:
    Plugin name:
    Web Dynpro Controller Editor Services
    Plugin ID:
    com.sap.ide.webdynpro.service.controllereditor
    Class:
    com.sap.ide.webdynpro.service.controllereditor.implementation.ImplementationService
    Method:
    getJDTMethod(Controller, String, IProgressMonitor)
    Message:
    Source controller implementation file is not accessible (Path to workspace folder: P:/.../gen_wdp/packages/com/clariant/ml5/types/ML5Cust.java)
    Exception:
    java.lang.Exception: 0
    Maybe someone could help me to fix this problem.
    Thanks Andy
    Ok... I found a way to fix by myself. All I have to do is to create a controller first and after this I have to apply the service controller. I don´t know why but it works. Both steps together doesn´t.
    Bye
    Andy
    Message was edited by: Andreas Choma

    I e-mailed tech support and got my answer.
    I should have been using /dev/rdsk and not /dev/dsk when specifying the disk slice to put the file system on.

  • ACE20 Module with Exchange 2010 Configuration

    Hello all,
    I have deployed the following configuration for Exchange 2010, if all services are up on the two servers it functions good but if a service goes down on one server (especially outlook) some clients are disconnected (stickiness) ...
    Stickiness is needed for all services by ip source sticky and by coockies for OWA.
    Because all services are on the same server (ip address) the configured sticky causes problems !!! when a service is down the ACE usually forwards  requests to it !!!! Any help please.
    Configuration :
    XXXXX-ACE1/CTXT-EXCHANGE(config)# do sh run
    Generating configuration....
    access-list BPDU-Allow ethertype permit bpdu
    access-list EXCH-LB line 10 extended permit ip any any
    probe http HTTP-GET
      interval 10
      passdetect interval 10
      request method get url /iisstart.htm
      expect status 200 202
    probe icmp PING
      interval 3
    probe tcp abport
      port 7575
      interval 2
      faildetect 2
      passdetect interval 10
      passdetect count 1
      connection term forced
    probe tcp epmap
      port 135
      interval 2
      faildetect 2
      passdetect interval 10
      passdetect count 1
      connection term forced
    probe tcp http
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    probe http http-probe
      interval 60
      passdetect interval 60
      passdetect count 2
      request method get url /exchweb/bin/auth/owalogon.asp
      expect status 400 404
    probe tcp https
      port 443
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    probe http https-probe
      interval 60
      passdetect interval 60
      passdetect count 2
      request method get url /owa/auth/login.aspx
      expect status 400 404
    probe tcp imap
      port 143
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    probe tcp imaps
      port 993
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    probe udp ipsec
      port 500
      interval 2
      passdetect interval 2
      passdetect count 1
    probe icmp ping
      interval 2
      passdetect interval 2
      passdetect count 1
    probe tcp pop3
      port 110
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    probe tcp pop3s
      port 995
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    probe tcp rpcport
      port 7576
      interval 2
      faildetect 2
      passdetect interval 10
      passdetect count 5
      connection term forced
    probe tcp smtp
      port 25
      interval 2
      passdetect interval 2
      passdetect count 1
      connection term forced
    rserver host CAS1
      ip address 172.22.101.74
      inservice
    rserver host CAS2
      ip address 172.22.101.76
      inservice
    rserver host HUB1
      ip address 172.22.101.75
      inservice
    rserver host HUB2
      ip address 172.22.101.77
      inservice
    rserver redirect RPC-REDIRECT
    rserver redirect SSLREDIRECT
      webhost-redirection https://mail.tunisiana.com/owa 302
      inservice
    serverfarm host CAS-Outlook
      probe PING
      probe abport
      probe epmap
      probe rpcport
      fail-on-all
      rserver CAS1 135
        inservice
      rserver CAS1 7575
        inservice
      rserver CAS1 7576
        inservice
      rserver CAS2 135
        inservice
      rserver CAS2 7575
        inservice
      rserver CAS2 7576
        inservice
    serverfarm host CAS-http
      probe HTTP-GET
      probe PING
      rserver CAS1 80
        inservice
      rserver CAS2 80
        inservice
    serverfarm host CAS-https
      probe https
      probe ping
      rserver CAS1 443
        inservice
      rserver CAS2 443
        inservice
    serverfarm host CAS-imap
      probe PING
      probe imap
      rserver CAS1 143
        inservice
      rserver CAS2 143
        inservice
    serverfarm host CAS-imaps
      probe imaps
      probe ping
      rserver CAS1 993
        inservice
      rserver CAS2 993
        inservice
    serverfarm host CAS-ipsec
      probe ipsec
      probe ping
      rserver CAS1
        inservice
      rserver CAS2
        inservice
    serverfarm host CAS-pop3
      probe ping
      probe pop3
      rserver CAS1 110
        inservice
      rserver CAS2 110
        inservice
    serverfarm host CAS-pop3s
      probe ping
      probe pop3s
      rserver CAS1 995
        inservice
      rserver CAS2 995
        inservice
    serverfarm host CAS-smtp
      probe ping
      probe smtp
      fail-on-all
      rserver CAS1 25
        inservice
      rserver CAS2 25
        inservice
    serverfarm host HUB
      probe ping
      probe smtp
      rserver HUB1
        inservice
      rserver HUB2
        inservice
    serverfarm redirect RPC-REDIRECT
    serverfarm redirect SSLREDIRECT
      rserver SSLREDIRECT
        inservice
    parameter-map type http STICKY
      persistence-rebalance
    parameter-map type connection TCP_IDLE_30min
      set timeout inactivity 1800
    sticky ip-netmask 255.255.255.255 address source HUB-ST
      timeout 30
      replicate sticky
      serverfarm HUB
    sticky ip-netmask 255.255.255.255 address source CAS-http-ST
      timeout 30
      replicate sticky
      serverfarm CAS-http
    sticky ip-netmask 255.255.255.255 address source CAS-https-ST
      timeout 30
      replicate sticky
      serverfarm CAS-https
    sticky ip-netmask 255.255.255.255 address source CAS-imap-ST
      timeout 30
      replicate sticky
      serverfarm CAS-imap
    sticky ip-netmask 255.255.255.255 address source CAS-imaps-ST
      timeout 30
      replicate sticky
      serverfarm CAS-imaps
    sticky ip-netmask 255.255.255.255 address source CAS-smtp-ST
      timeout 30
      replicate sticky
      serverfarm CAS-smtp
    sticky ip-netmask 255.255.255.255 address source CAS-pop3-ST
      timeout 30
      replicate sticky
      serverfarm CAS-pop3
    sticky ip-netmask 255.255.255.255 address source CAS-pop3s-ST
      timeout 30
      replicate sticky
      serverfarm CAS-pop3s
    sticky ip-netmask 255.255.255.255 address source CAS-ipsec-ST
      timeout 30
      replicate sticky
      serverfarm CAS-ipsec
    sticky ip-netmask 255.255.255.255 address source CAS-Outlook-ST
      timeout 30
      replicate sticky
      serverfarm CAS-Outlook
    sticky http-cookie sessionid exchange-sticky-sessionid-grp
      timeout 20
      serverfarm CAS-http
    sticky http-cookie cookie OWA-STICKY
      cookie insert browser-expire
      timeout 60
      replicate sticky
      serverfarm CAS-http
    sticky http-header Authorization CAS-RPC-HTTP
      serverfarm CAS-http
    class-map match-any CAS-OUTL-MAPI-VIP
      2 match virtual-address 172.22.101.69 tcp any
    class-map match-any CAS-Outlook-VIP
      2 match virtual-address 172.22.101.69 tcp eq 135
      3 match virtual-address 172.22.101.69 tcp eq 7575
      4 match virtual-address 172.22.101.69 tcp eq 7576
    class-map match-any CAS-http-VIP
      2 match virtual-address 172.22.101.69 tcp eq www
    class-map match-any CAS-https-VIP
      2 match virtual-address 172.22.101.69 tcp eq https
    class-map match-any CAS-imap-VIP
      2 match virtual-address 172.22.101.69 tcp eq 143
    class-map match-any CAS-imaps-VIP
      2 match virtual-address 172.22.101.69 tcp eq 993
    class-map match-any CAS-ipsec-VIP
      2 match virtual-address 172.22.101.69 udp eq 500
    class-map match-any CAS-pop3-VIP
      2 match virtual-address 172.22.101.69 tcp eq pop3
    class-map match-any CAS-pop3s-VIP
      2 match virtual-address 172.22.101.69 tcp eq 995
    class-map match-any CAS-smtp-VIP
      2 match virtual-address 172.22.101.69 tcp eq smtp
    class-map match-all CAS_SERVERS
      2 match source-address 172.22.101.64 255.255.255.192
    class-map match-any HUB-VIP
      2 match virtual-address 172.22.101.80 any
    class-map match-all HUB_SERVERS
      2 match source-address 172.22.101.64 255.255.255.192
    class-map match-all OWA-OUTLOOKANYWHERE-SSL
      2 match virtual-address 172.22.101.69 tcp eq https
    class-map match-all OWA-SSL-CM
      2 match virtual-address 172.22.101.69 tcp eq https
    class-map match-all OWAREDIRECT
      2 match virtual-address 172.22.101.69 tcp eq www
    class-map type management match-any REMOTE-MGT
      201 match protocol snmp any
      202 match protocol http any
      203 match protocol https any
      204 match protocol icmp any
      205 match protocol ssh any
      206 match protocol telnet any
    policy-map type management first-match REMOTE-MGT
      class REMOTE-MGT
        permit
    policy-map type loadbalance first-match CAS-Outlook-policy
      class class-default
        sticky-serverfarm CAS-Outlook-ST
    policy-map type loadbalance first-match CAS-http-policy
      class class-default
        sticky-serverfarm CAS-http-ST
    policy-map type loadbalance first-match CAS-https-policy
      class class-default
        sticky-serverfarm CAS-https-ST
    policy-map type loadbalance first-match CAS-imap-policy
      class class-default
        sticky-serverfarm CAS-imap-ST
    policy-map type loadbalance first-match CAS-imaps-policy
      class class-default
        sticky-serverfarm CAS-imaps-ST
    policy-map type loadbalance first-match CAS-ipsec-policy
      class class-default
        serverfarm CAS-ipsec
    policy-map type loadbalance first-match CAS-pop3-policy
      class class-default
        sticky-serverfarm CAS-pop3-ST
    policy-map type loadbalance first-match CAS-pop3s-policy
      class class-default
        sticky-serverfarm CAS-pop3s-ST
    policy-map type loadbalance first-match CAS-smtp-policy
      class class-default
        serverfarm CAS-smtp
    policy-map type loadbalance first-match HUB-policy
      class class-default
        serverfarm HUB
    policy-map type loadbalance first-match OWA-OUTLOOKANYWHERE
      match OUTLOOK_ANYWHERE http header User-Agent header-value "MSRPC"
    policy-map type loadbalance first-match OWA-SSL-PM
      class class-default
        sticky-serverfarm OWA-STICKY
    policy-map type loadbalance http first-match SSLREDIRECT
      class class-default
        serverfarm SSLREDIRECT
    policy-map multi-match CAS-Outlook-POLICY-MAP
      class CAS-Outlook-VIP
        loadbalance vip inservice
        loadbalance policy CAS-Outlook-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-http-POLICY-MAP
      class CAS-http-VIP
        loadbalance vip inservice
        loadbalance policy CAS-http-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-https-POLICY-MAP
      class CAS-https-VIP
        loadbalance vip inservice
        loadbalance policy CAS-https-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-imap-POLICY-MAP
      class CAS-imap-VIP
        loadbalance vip inservice
        loadbalance policy CAS-imap-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-imaps-POLICY-MAP
      class CAS-imaps-VIP
        loadbalance vip inservice
        loadbalance policy CAS-imaps-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-ipsec-POLICY-MAP
      class CAS-ipsec-VIP
        loadbalance vip inservice
        loadbalance policy CAS-ipsec-policy
        loadbalance vip icmp-reply
    policy-map multi-match CAS-pop3-POLICY-MAP
      class CAS-pop3-VIP
        loadbalance vip inservice
        loadbalance policy CAS-pop3-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-pop3s-POLICY-MAP
      class CAS-pop3s-VIP
        loadbalance vip inservice
        loadbalance policy CAS-pop3s-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match CAS-smtp-POLICY-MAP
      class CAS-smtp-VIP
        loadbalance vip inservice
        loadbalance policy CAS-smtp-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match EXCH-POLICY
      class CAS-imap-VIP
        loadbalance vip inservice
        loadbalance policy CAS-imap-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-imaps-VIP
        loadbalance vip inservice
        loadbalance policy CAS-imaps-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-pop3-VIP
        loadbalance vip inservice
        loadbalance policy CAS-pop3-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-pop3s-VIP
        loadbalance vip inservice
        loadbalance policy CAS-pop3s-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-smtp-VIP
        loadbalance vip inservice
        loadbalance policy CAS-smtp-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-http-VIP
        loadbalance vip inservice
        loadbalance policy CAS-http-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-https-VIP
        loadbalance vip inservice
        loadbalance policy CAS-https-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
      class CAS-OUTL-MAPI-VIP
        loadbalance vip inservice
        loadbalance policy CAS-Outlook-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    policy-map multi-match HUB-POLICY-MAP
      class HUB-VIP
        loadbalance vip inservice
        loadbalance policy HUB-policy
        loadbalance vip icmp-reply
        connection advanced-options TCP_IDLE_30min
    interface vlan 52
      description #### vlan client side EXCHANGE ####
      bridge-group 1
      access-group input BPDU-Allow
      access-group input EXCH-LB
      service-policy input REMOTE-MGT
      service-policy input HUB-POLICY-MAP
      service-policy input EXCH-POLICY
      no shutdown
    interface vlan 54
      description #### vlan client side ACE_EXCHANGE ####
      bridge-group 1
      access-group input BPDU-Allow
      access-group input EXCH-LB
      service-policy input REMOTE-MGT
      service-policy input HUB-POLICY-MAP
      service-policy input EXCH-POLICY
      no shutdown
    interface bvi 1
      ip address 172.22.101.123 255.255.255.192
      peer ip address 172.22.101.122 255.255.255.192
      description EXCHANGE-Bridged-vlans
      no shutdown
    ip route 0.0.0.0 0.0.0.0 172.22.101.126
    Best Regards

    Thank you for your email. I am out of the office until March 25th, I will have limited access to my e-mail during this period.
    In my absence, please feel free to contact Mr Akram Allani : [email protected]
    Thank you for your understanding.
    Best regards,
    Youssef Boukari

  • TT14000: TimesTen daemon internal error: Could not send 'manage' request

    Hi
    I have got error like TimesTen daemon internal error: Could not send 'manage' request .Can any one help, why this error is came and what is solution for this.
    I have restarted the Timesten Daemon now its working fine.But why i got that error?
    Below is the tterror log :
    12:50:27.53 Err : : 31518: TT14000: TimesTen daemon internal error: Could not send 'manage' request to subdaemon rc 400 err1 703 err2 836
    12:50:28.52 Warn: : 31518: 31522 ------------------: subdaemon process exited
    14:04:21.95 Warn: : 31518: 31619/0xcce7500: Recovery started
    14:04:23.01 Warn: : 31619: subd: Warning identified in [sub.c: line 2152]
    14:04:23.01 Warn: : 31619: subd: (Warning 20100): TT20100: This connection required recovery due to an improper shutdown -- file "db.c", lineno 12011, procedure "sbDbConnect"
    14:04:23.01 Warn: : 31619: -- file "db.c", lineno 12011, procedure "sbDbConnect"
    14:04:23.01 Warn: : 31619: subd: connect trouble, rc 2, reason 20100
    14:04:23.01 Warn: : 31619: Warn 20100: TT20100: This connection required recovery due to an improper shutdown -- file "db.c", lineno 12011, procedure "sbDbConnect"
    20:23:57.74 Warn: : 31518: 9216 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=1
    21:15:17.79 Warn: : 31518: 22608 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=1
    09:22:11.63 Warn: : 31518: 32431 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=21
    09:28:03.52 Warn: : 31518: 32417 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=1
    20:26:56.30 Warn: : 31518: 1165 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=1
    20:40:31.73 Warn: : 31518: 21549 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=3
    23:17:52.64 Warn: : 31518: 29899 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=20 '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=215
    09:42:29.96 Warn: : 31518: 22044 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=10
    13:12:19.91 Warn: : 31518: 16923 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=10
    19:42:46.21 Warn: : 31518: 10794 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1174700038 count=10
    00:00:06.83 Warn: : 6786: Invalidating the data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because it had 34 users
    00:00:06.83 Warn: : 6786: WARNING: data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 was in use at daemon termination.
    00:00:06.83 Warn: : 6786: WARNING: data store no longer considered in use
    00:00:06.84 Warn: : 6786: WARNING: PL/SQL shared segment existed at time of daemon termination
    00:00:06.84 Err : : 6786: TT14000: TimesTen daemon internal error: Could not destroy PL/SQL shared memory, error
    00:00:06.84 Warn: : 6786: TimesTen Daemon Release 11.2.1.3.0.TT_tt70_32 started.
    00:00:15.32 Warn: : 6786: 6792/0x1edfc500: Recovery started
    00:00:16.39 Warn: : 6792: subd: Warning identified in [sub.c: line 2152]
    00:00:16.39 Warn: : 6792: subd: (Warning 20100): TT20100: This connection required recovery due to an improper shutdown -- file "db.c", lineno 12011, procedure "sbDbConnect"
    00:00:16.39 Warn: : 6792: -- file "db.c", lineno 12011, procedure "sbDbConnect"
    00:00:16.39 Warn: : 6792: subd: connect trouble, rc 2, reason 20100
    00:00:16.39 Warn: : 6792: Warn 20100: TT20100: This connection required recovery due to an improper shutdown -- file "db.c", lineno 12011, procedure "sbDbConnect"
    17:51:04.03 Warn: : 6786: 17730 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1225031686 count=10
    10:03:44.61 Warn: REP: 7064: TT_TT70_32:receiver.c(7921): TT16191: Replacing old table definition (OASTT.USER_AUTH) with the one received from peer (TT_TT70_32_MASTER)
    10:03:52.28 Warn: REP: 7064: TT_TT70_32:receiver.c(7921): TT16191: Replacing old table definition (OASTT.USER_AUTH) with the one received from peer (TT_TT70_32_MASTER)
    10:04:02.73 Warn: REP: 7064: TT_TT70_32:receiver.c(7921): TT16191: Replacing old table definition (OASTT.USER_AUTH) with the one received from peer (TT_TT70_32_MASTER)
    17:58:15.58 Warn: : 6786: 15156 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1225031686 count=7
    18:02:14.24 Warn: REP: 7064: TT_TT70_32:receiver.c(2682): TT16060: Failed to read data from the network. select() timed out
    18:02:25.07 Warn: REP: 7064: got termination signal, stopping
    18:02:25.81 Warn: : 6790: got termination signal, stopping
    18:02:25.86 Warn: : 6792: got termination signal, stopping
    18:02:25.87 Err : : 6786: TT14006: TimesTen daemon disconnect failed: 6792/0x2aaab80008c0: disconnect complete: Disconnect not started. Info: 0 7064 0x1f758520 (/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32)
    18:02:25.87 Err : : 6792: TT14000: TimesTen daemon internal error: subd: Monitor thread failed to disconnect, tt error 798 (TT0798: Daemon reports error 0 -- file "db.c", lineno 16124, procedure "sbDbDisconnect").
    18:02:25.87 Warn: : 6786: got termination signal, stopping
    18:02:25.91 Warn: : 6789: got termination signal, stopping
    18:02:25.95 Warn: : 6791: got termination signal, stopping
    18:02:26.05 Err : : 6786: TT14000: TimesTen daemon internal error: Could not connect to subdaemon port 43791
    18:02:26.05 Err : : 6786: TT14006: TimesTen daemon disconnect failed: error -1 in stopManaging
    18:02:26.05 Err : REP: 7064: TT_TT70_32:repagent.c(3338): TT16005: Failed to disconnect from datastore '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' for 'REPHOLD' thread
    18:02:26.05 Err : REP: 7064: TT_TT70_32:repagent.c(3338): TT791: TT0791: Cannot communicate with subdaemon -- file "db.c", lineno 16124, procedure "sbDbDisconnect"
    18:02:26.05 Warn: : 6786: 6792 ------------------: subdaemon process exited
    18:02:26.05 Warn: : 6786: 6792 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1225031686 count=10
    18:02:26.05 Warn: : 6786: daRecovery: subdaemon 6792, managing data store, failed: invalidate (failcode=202)
    18:02:26.05 Warn: : 6786: Invalidating the data store (failcode 202, recovery for 6792)
    18:02:26.11 Err : : 6786: Could not connect to subdaemon 6794, port 56784
    18:02:26.28 Warn: : 6786: 6789 ------------------: subdaemon process exited
    18:02:26.53 Warn: : 6786: 6791 ------------------: subdaemon process exited
    18:02:26.59 Warn: : 6786: 6790 ------------------: subdaemon process exited
    18:02:26.71 Err : : 6786: Could not connect to subdaemon 7064, port 45797
    13:42:14.95 Warn: : 10502: TimesTen Daemon Release 11.2.1.3.0.TT_tt70_32 started.
    13:42:32.63 Err : : 10502: TT14000: TimesTen daemon internal error: Error 22 creating shared segment, KEY 0x4e048006
    13:42:32.63 Err : : 10502: -- OS reports invalid shared segment size
    13:42:32.63 Err : : 10502: -- Confirm that SHMMAX kernel parameter is set > datastore size
    13:42:32.63 Err : : 10508: subd: Error identified in [sub.c: line 2152]
    13:42:32.63 Err : : 10508: subd: (Error 836): TT0836: Cannot create data store shared-memory segment, error 22 -- file "db.c", lineno 9572, procedure "sbDbConnect"
    13:42:32.63 Err : : 10508: -- file "db.c", lineno 9572, procedure "sbDbConnect"
    13:42:32.63 Warn: : 10508: subd: connect trouble, rc 1, reason 836
    13:42:32.63 Err : : 10508: Err 836: TT0836: Cannot create data store shared-memory segment, error 22 -- file "db.c", lineno 9572, procedure "sbDbConnect"
    13:42:32.63 Err : : 10502: TT14000: TimesTen daemon internal error: Could not send 'manage' request to subdaemon rc 400 err1 703 err2 836
    13:42:33.63 Warn: : 10502: 10508 ------------------: subdaemon process exited
    13:46:59.96 Warn: : 10502: 10605/0x819500: Recovery started
    13:47:01.02 Warn: : 10605: subd: Warning identified in [sub.c: line 2152]
    13:47:01.02 Warn: : 10605: subd: (Warning 20100): TT20100: This connection required recovery due to an improper shutdown -- file "db.c", lineno 12011, procedure "sbDbConnect"
    13:47:01.02 Warn: : 10605: -- file "db.c", lineno 12011, procedure "sbDbConnect"
    13:47:01.02 Warn: : 10605: subd: connect trouble, rc 2, reason 20100
    13:47:01.02 Warn: : 10605: Warn 20100: TT20100: This connection required recovery due to an improper shutdown -- file "db.c", lineno 12011, procedure "sbDbConnect"
    15:37:47.14 Warn: : 10502: 28930 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1392803846 count=1
    19:41:05.92 Warn: : 10502: 28950 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=1
    12:18:40.18 Warn: : 10502: 19264 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=16
    19:09:15.13 Warn: : 10502: 29472 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=24
    20:29:21.07 Warn: : 10502: 6896 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=27
    11:11:30.98 Warn: REP: 18767: TT_TT70_32:receiver.c(2682): TT16060: Failed to read data from the network. select() timed out
    14:26:06.81 Warn: : 10502: 25502 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=3
    10:52:42.36 Warn: : 10502: 6487 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=12
    11:06:20.50 Warn: : 10502: 15322 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=1
    13:19:36.58 Warn: REP: 18767: TT_TT70_32:receiver.c(2682): TT16060: Failed to read data from the network. select() timed out
    16:48:45.24 Warn: : 10506: got termination signal, stopping
    16:48:45.48 Warn: : 10505: got termination signal, stopping
    16:48:45.95 Warn: : 10502: 10505 ------------------: subdaemon process exited
    16:48:45.95 Warn: : 10502: 10506 ------------------: subdaemon process exited
    16:48:45.99 Warn: REP: 18767: got termination signal, stopping
    16:48:46.20 Warn: : 10507: got termination signal, stopping
    16:48:46.26 Warn: : 10502: got termination signal, stopping
    16:48:46.86 Warn: : 10605: got termination signal, stopping
    16:48:46.95 Warn: : 10502: 10507 ------------------: subdaemon process exited
    16:48:46.99 Err : : 10502: TT14000: TimesTen daemon internal error: Could not connect to subdaemon port 36872
    16:48:46.99 Err : : 10502: TT14006: TimesTen daemon disconnect failed: error -1 in stopManaging
    16:48:46.99 Err : REP: 18767: TT_TT70_32:repagent.c(3338): TT16005: Failed to disconnect from datastore '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' for 'REPLISTENER' thread
    16:48:46.99 Err : REP: 18767: TT_TT70_32:repagent.c(3338): TT791: TT0791: Cannot communicate with subdaemon -- file "db.c", lineno 16124, procedure "sbDbDisconnect"
    16:48:46.99 Warn: : 10502: 10605 ------------------: subdaemon process exited
    16:48:46.99 Warn: : 10502: 10605 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1594130438 count=10
    16:48:46.99 Warn: : 10502: daRecovery: subdaemon 10605, managing data store, failed: invalidate (failcode=202)
    16:48:46.99 Warn: : 10502: Invalidating the data store (failcode 202, recovery for 10605)
    16:48:47.09 Err : : 10502: Could not connect to subdaemon 10510, port 58206
    16:48:47.16 Err : : 10502: Could not connect to subdaemon 18767, port 49611
    13:17:45.67 Warn: : 8602: TimesTen Daemon Release 11.2.1.3.0.TT_tt70_32 started.
    13:17:52.84 Warn: : 8602: 8605/0x12207500: Recovery started
    13:18:41.73 Err : : 8602: 8789/(nil): /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/snmp.ini: bad -trap_dest value SMARTS4: Host not found (authoritative answer)
    13:31:31.49 Warn: : 8602: 5706 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1745125382 count=1
    01:25:41.22 Warn: : 8602: 18419 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1745125382 count=158
    10:29:11.03 Warn: : 8602: 30002 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1745125382 count=43
    12:47:07.86 Warn: : 8602: Invalidating in-RAM shared data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because in use at exit
    12:47:07.87 Warn: : 8602: 8605/0x123481a0: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    12:47:07.88 Warn: : 8605: Stopping subdaemon Log Marker thread for /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because db is invalid.
    12:47:07.88 Warn: : 8602: 8605/0x123a47b0: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    12:47:07.96 Warn: : 8602: 8605/0x1243c900: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    12:47:08.88 Warn: : 8602: 8605 ------------------: subdaemon process exited
    12:47:08.88 Warn: : 8602: 8605 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 1745125382 count=10
    12:47:34.78 Warn: : 20263: Invalidating the data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because it had 11 users
    12:47:34.78 Warn: : 20263: WARNING: data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 was in use at daemon termination.
    12:47:34.78 Warn: : 20263: WARNING: data store no longer considered in use
    12:47:34.78 Warn: : 20263: TimesTen Daemon Release 11.2.1.3.0.TT_tt70_32 started.
    12:51:06.94 Warn: : 20263: 20266/0x14690500: Recovery started
    16:29:00.34 Warn: : 20263: 22849 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 134512646 count=1
    10:12:26.98 Warn: REP: 20784: TT_TT70_32:receiver.c(2682): TT16060: Failed to read data from the network. TimesTen replication agent is stopping
    10:12:30.91 Warn: : 20263: Invalidating in-RAM shared data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because in use at exit
    10:12:30.91 Warn: : 20263: 20266/0x1479ff40: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:30.91 Warn: : 20266: Stopping subdaemon Log Marker thread for /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because db is invalid.
    10:12:30.91 Warn: : 20263: 20266/0x1488b830: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:30.96 Warn: : 20263: 20266/0x1486fa40: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:31.03 Warn: : 20263: 20266/0x2aaac40008c0: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:31.34 Warn: : 20263: 20266/0x2aaac401c6b0: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:31.40 Warn: : 20263: 20266/0x2aaac00008c0: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:31.66 Warn: : 20263: 20266/0x2aaac4078700: Forced Disconnect /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32
    10:12:31.91 Warn: : 20263: 20266 ------------------: subdaemon process exited
    10:12:31.91 Warn: : 20263: 20266 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 134512646 count=10
    10:12:36.28 Warn: : 14678: Invalidating the data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because it had 11 users
    10:12:36.28 Warn: : 14678: WARNING: data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 was in use at daemon termination.
    10:12:36.28 Warn: : 14678: WARNING: data store no longer considered in use
    10:12:36.28 Warn: : 14678: TimesTen Daemon Release 11.2.1.3.0.TT_tt70_32 started.
    10:13:25.52 Warn: : 14678: 14683/0x5121500: Recovery started
    10:10:12.39 Warn: : 14678: 15486 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 201621511 count=1
    10:06:55.19 Warn: : 14678: 30796 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 201621511 count=2
    09:58:48.69 Warn: : 14678: 12930 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 201621511 count=2
    15:27:42.39 Warn: : 14678: 7811 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 201621511 count=2
    10:16:36.60 Warn: REP: 14964: TT_TT70_32:receiver.c(2682): TT16060: Failed to read data from the network. select() timed out
    10:53:27.24 Warn: : 14678: 11658 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 201621511 count=1
    15:11:33.81 Warn: : 14678: got termination signal, stopping
    15:11:34.63 Err : : 14678: Could not connect to subdaemon 14686, port 41664
    15:11:34.72 Warn: : 14682: got termination signal, stopping
    15:11:35.10 Warn: : 14681: got termination signal, stopping
    15:11:35.11 Warn: : 14684: got termination signal, stopping
    15:11:35.23 Warn: : 14683: got termination signal, stopping
    15:11:35.35 Warn: : 14678: 14684 ------------------: subdaemon process exited
    15:11:35.43 Warn: REP: 14964: got termination signal, stopping
    15:11:35.53 Warn: : 14678: 14681 ------------------: subdaemon process exited
    15:11:35.55 Warn: : 14678: 14682 ------------------: subdaemon process exited
    15:11:36.29 Err : : 14678: TT14000: TimesTen daemon internal error: 14683: Error processing 'unmanage' in subdaemon rc -2
    15:11:36.29 Err : : 14678: TT14000: TimesTen daemon internal error: Unparsable reply to unmanage
    15:11:36.29 Err : : 14678: TT14006: TimesTen daemon disconnect failed: error -1 in stopManaging
    15:11:36.29 Err : REP: 14964: TT_TT70_32:repagent.c(3338): TT16005: Failed to disconnect from datastore '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' for 'REPLISTENER' thread
    15:11:36.29 Warn: : 14678: 14683 ------------------: subdaemon process exited
    15:11:36.29 Err : REP: 14964: TT_TT70_32:repagent.c(3338): TT798: TT0798: Daemon reports error 0 -- file "db.c", lineno 16124, procedure "sbDbDisconnect"
    15:11:36.30 Warn: : 14678: 14683 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 201621511 count=1
    15:11:37.63 Warn: : 14678: Invalidating in-RAM shared data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because in use at exit
    15:54:42.72 Warn: : 8962: Invalidating the data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 because it had 1 users
    15:54:42.73 Warn: : 8962: WARNING: data store /opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32 was in use at daemon termination.
    15:54:42.73 Warn: : 8962: WARNING: data store no longer considered in use
    15:54:42.73 Warn: : 8962: WARNING: PL/SQL shared segment existed at time of daemon termination
    15:54:42.73 Err : : 8962: TT14000: TimesTen daemon internal error: Could not destroy PL/SQL shared memory, error 22
    15:54:42.73 Warn: : 8962: TimesTen Daemon Release 11.2.1.3.0.TT_tt70_32 started.
    15:54:48.61 Warn: : 8962: 8973/0x17292500: Recovery started
    16:15:24.25 Warn: : 8962: 5703 exited while connected to data store '/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_tt70_32' shm 251953159 count=1
    15:32:17.57 Warn: : 8962: 8974/0xff51500: Recovery started
    15:32:55.78 Warn: REP: 28114: SIPT_TT_SUB4:receiver.c(2682): TT16060: Failed to read data from the network. select() timed out

    1)
    TimesTen Release 11.2.1.3.0 (64 bit Linux/x86_64) (TT_tt70_32:53388) 2009-08-21T05:34:23Z
    Instance admin: timesten
    Instance home directory: /opt/timesten/tt7032/TimesTen/TT_tt70_32
    Group owner: timesten
    Daemon home directory: /opt/timesten/tt7032/TimesTen/TT_tt70_32/info
    PL/SQL enabled.
    2)
    [TT_1121]
    Driver=/opt/timesten/tt7032/TimesTen/TT_tt70_32/lib/libtten.so
    DataStore=/opt/timesten/tt7032/TimesTen/TT_tt70_32/info/TT_1121
    DatabaseCharacterSet=US7ASCII
    3)
    kernel.shmmax = 2147483648
    kernel.shmall = 2097152
    4)
    MemTotal: 8171576 kB
    MemFree: 3754532 kB
    Buffers: 312052 kB
    Cached: 1656640 kB
    SwapCached: 0 kB
    Active: 3924072 kB
    Inactive: 309660 kB
    HighTotal: 0 kB
    HighFree: 0 kB
    LowTotal: 8171576 kB
    LowFree: 3754532 kB
    SwapTotal: 8388600 kB
    SwapFree: 8388600 kB
    Dirty: 652 kB
    Writeback: 4 kB
    AnonPages: 2265060 kB
    Mapped: 153924 kB
    Slab: 126580 kB
    PageTables: 12320 kB
    NFS_Unstable: 0 kB
    Bounce: 0 kB
    CommitLimit: 12474388 kB
    Committed_AS: 4718116 kB
    VmallocTotal: 34359738367 kB
    VmallocUsed: 284328 kB
    VmallocChunk: 34359452663 kB
    HugePages_Total: 0
    HugePages_Free: 0
    HugePages_Rsvd: 0
    Hugepagesize: 2048 kB

  • Error while posting GR "Internal error in FORM/FUNCTION CKML_F_BUILD_INDEX

    Dear Experts,
    While posting GR for any non-valuated material, I am getting an error "Internal error in FORM/FUNCTION CKML_F_BUILD_INDEX in position 1 with RC 0
    Message no. C+099"
    Kindly explore the possibilities of solution for the above error. The abve error only showing at the time of posting and not whicle Check.
    Regards,
    Tushar

    Hi Tushar,
    Your problem is happening because of the applicaiton of an SAP Note. I think PM has nothing to do with this Error. Pl. read the following (which I read this from one SAP website) & check the relevant SAP notes and take action or write to SAP  for solution.
    Symptom
    The posting of goods receipts results in a long runtime.
    Other terms
    ACTUPD, MIGO, performance, material ledger
    Reason and Prerequisites
    The actual costing is active.
    The performance problems usually occur when there are several procurement alternatives or procurement processes (tables CKMLMV001 and CKMLMV002) for certain materials.
    This can be caused by implementing the modification according to Note 1017470 or 919869, [...]
    Regards,
    Bala.

  • Finally determined what causes an "Internal Error Occurred" message in FW

    I use Fireworks for creating wireframes. One FW png file may contain many layers
    with each layer representing a web page. The intention is to create the png file, and then to export it to a PDF file so that developers can use it to view the pages and to understand page navigation. I learned this technique by watching Jim Babbage's excellent video on using Fireworks for wireframing.
    I create hotspots in the FW png file on one layer and use that to point to another layer that represents another web page. The purpose is to show a kind of flow or extra info for the developers. I've been struggling for over a year with an error that would pop up now and then when attempting to save the png file. The error would show "Internal Error Occurred" and I had no idea why this was occurring. I tried multiple things to get rid of the error and recently I finally discovered what was causing it.
    It turns out that if you create a FW png file with layers, and you insert a hotspot that points to one of those layers, and then later when editing the FW png file you decide to delete a layer that is being referenced via a hotspot in a different layer, this error will occur. It doesn't occur every time you attempt to save the png file, but it will occur if you save the png file (no error shown), then export to a pdf file, then (as required by FW) attempt to save the png file again. That's when you will see the error for sure.
    The cause is a hotspot link that points to a layer that no longer exists. This is most often caused by creating hotspots that point to the layer, then later deciding to delete that layer but you don't go back and remove any hotspot links to the deleted layer. For some reason, FW will let you attempt to save the file and may or many not show the dreaded "Internal Error Occurred" pop-up message. If you were able to save your png file and didn't see the error show up, and then you decide to export the png file to a PDF file, FW requires you to save the png file after the export option completes. It's when you attempt to save it at this time that it will show up for sure if your hotspot points to a deleted layer. The error message won't go away either.
    It's kind of a pain if you have a bunch of layers with a bunch of hotspot links, but you will have to click on each hotspot and determine if it points to a layer that exists in the current png file. If that layer doesn't exist, you will have to point to a layer that does exist, or delete the hotspot to get rid of the "Internal Error Occurred" message.
    Hope this helps,
    Stevebo

    After doing further testing, I've noticed that the error can't be reproduced every time a hotspot points to a nonexistent layer. BUT, every time I've encountered the "internal error occurred" message when saving a png file with hotspots and multiple layers, I have found one or more hotspots pointing to layers that no longer exist. Once pointing the hotspot(s) to a layer that does exist, or simply removing the hotspot(s), the "internal error occurred" message goes away.
    So in my encounters with this error, finding the hotspot(s) that point to layer(s) that have been removed fixes the problem. The problem is that it doesn't always occur, just sometimes. It may have to do with the number of png files that may be open and the number of layers that exist, or once the error begins showing up. Just not sure, but I am sure of what I need to do to make the error go away in my case (remove hotspots that point to nonexistent layers). So far it's fixed the problem every time.
    It would be interesting to see if others encounter this same error and if there is one or more hotspots pointing to deleted layers. It may be that the error message is simply a "catch-all" for errors that can't be determined and this just happens to be one scenario.
    steve

  • MSG-00000: ORA-20001: -: XLA-95103: An internal error occurred

    hi All,
    OS OUL5x64
    ebs r12 12.1.1
    we applied patch # 9325101 and have about 32 invalid packages and manually compile and now only 12 invalid packages left.
    one of the post installation was to run
    XLAABACR module: Validate Application Accounting Definitions
    when running this program we receive error below.
    can someone please help.
    Thanks,
    MSG-00000: ORA-20001: -: XLA-95103: An internal error occurred. Please inform your system administrator or support representative that:
    An internal error has occurred in the program xla_compile_pad_pkg.CompileProductRule. ORA-06508: PL/SQL: could not find program unit being
    ORA-06512: at "APPS.XLA_AMB_AAD_PKG", line 2192
    REP-1419: 'beforereport': PL/SQL program aborted.
    REP-0069: Internal error
    REP-57054: In-process job terminated:Terminated with error:
    REP-1419: MSG-00000: ORA-20001: -: XLA-95103: An internal error occurred. Please inform your system administrator or support representative that:
    An internal error has occurred in the program xla_compile_pad_pkg.CompileProductRule. ORA-06508: PL/SQL: could not find program unit being
    ORA-06512: at "APPS.XLA_AMB_AAD_PKG", line 2192
    REP-1419: 'beforereport': PL/SQL program aborted.

    Hi,
    we applied patch # 9325101 and have about 32 invalid packages and manually compile and now only 12 invalid packages left.Please compile the invalid objects manually and post the error here.
    one of the post installation was to run
    XLAABACR module: Validate Application Accounting Definitions
    when running this program we receive error below.
    can someone please help.
    Thanks,
    MSG-00000: ORA-20001: -: XLA-95103: An internal error occurred. Please inform your system administrator or support representative that:See if these documents help.
    Note: 472564.1 - R12 XLAABACR Error XLA-95103 When Attempting to Validate Application Accounting Definitions
    Note: 601318.1 - R12 Validate Application Accounting Definitions FAQs
    Note: 1073855.1 - Application Accounting Definition fails due to XLA_CMP_CREATE_PKG
    Thanks,
    Hussein

  • Unexpected internal error near index 1

    Hi,
    I am convering al l occurance of "\" into "/" in a string.
    private String format(){
            input="java\\software\\";
            System.out.println("Before formating, input:" + input);
            try{           
                input=input.replaceAll("\\", "/");
                System.out.println("After formating, Input:" + input);
            }catch(Exception e){
                System.out.println("Error in formatting:" + e.getMessage());
            return input;
        }And I am getting this Error:
    Unexpected internal error near index 1
    Any idea whats wrong with above code?

    If you want to replace two backslashes with asingle
    forward slash, then you need to specify the former
    (as a regular expression) as "\\\\"OH! Thanks. I got another way and its working.
    I am using
    s.replace('\\', '/'); insteadd of
    replaceAll
    Yes, that's definitely better in this case, since that API is simpler for single-char replacements. If you sometime need to replace strings though (back to the replaceAll) you'll need to be aware of how regular expressions are formed and how the backslash character plays a part in forming them.

Maybe you are looking for