Internet Packet based Chat

Hi there,
Im creating an internet based chat program, with a client, and a server program. It works by sending and recieving packets. I can get both my applications sending packets which are in a char array of maximum size 285. I know I have them sending because I have used hyperterminal and seen the output I want. However, they dont seem to be displaying on the other program. The code I have is this to send:
        public void sendPacket (char[] packet) {
            list.add("sendPacket function recieved: " + new String (packet));
            //send the packet passed to it
            try {
                for(int i = 0; i < PACKETLENGTH; i++)
                    System.out.print(packet);
bw.write(packet[i]);
} catch (IOException e) {
list.add("Error Sending packet.");
The code I have to recieve it which doesnt seem to work is this:
        public void run()
                while (true)
                        try                         //HANDLE RECIEVED MESSAGES
                            list.add(br.readLine());
                        }catch (Exception e){}
     }Could it be because the packets are larger than one line? Im fairly new to programming, and hope someone can help me out with this, because all has been going well with this project until now.. :-(
the list is the window which displays all the messages, and bw and br are bufferedreader and bufferedwriter,,
-Tom

just a follow up question.
but when you send it through a socket maybe, don't
they like get transported as a raw data (not java
specific types). Yes. What led you to believe that a char was "raw" data?
Or alternatively, what led you to believe that you could read raw data as if it were a String?
This doesn't work:
String hello = new char[];And that's essentialy what you tried to do.
My point is im confused on whether the types would
really matter. Yes. If you write bytes, you must read bytes. If you write chars you must read chars. If you write String objects, you must read String objects.
Take a look at ObjectInputStream and ObjectOutputStream.
Dave.

Similar Messages

  • Java Update 5 (1.0) breaks Java for Volano based chats

    I installed the Java Update 5 (1.0) for Leopard on my Intel based Mac mini and then was unable to enter Volano (Java applet) based chat rooms. I was forced to reinstall my system to revert to my prior version of System 10.5.8 in oder to be able to continue use the Java based Volano chats. The update that will NOT work states: "This release updates Java SE 6 to to version 1.6.0_1.5, J2SE 5.0 to version 1.5.0_20, and J2SE 1.4.2 to 1.4.2_22."
    According to Volano developers -
    Note that Apple calls Java 5 (version 1.5) "J2SE 5.0", while it calls Java 6 (version 1.6) "Java SE 6". I think I finally have the following chart correct:
    J2SE 5.0 = Java 5 (version 1.5)
    - Available as 32-bit and 64-bit packages in Leopard
    - Removed in Snow Leopard
    Java SE 6 = Java 6 (version 1.6)
    - Available only as 64-bit packages in Leopard
    - Available as 32-bit & 64-bit packages in Snow Leopard
    In Leopard, the 32-bit Safari can run Java applets only with the 32-bit
    J2SE 5.0 support. To run applets using Java SE 6, you need to bypass
    Safari using the "appletviewer" Terminal command in Leopard, or upgrade
    to Snow Leopard where Safari can run Java SE 6.
    Volano says the possible work arounds for Leopard users (10.5.8( are:
    According to what I've read, if you have a 64-bit capable Intel processor (i.e., an Intel Core 2 Duo), the software update that you removed should have given you 64-bit Java SE 6 even on Mac OS X Leopard (10.5). Java SE 6 works fine with the VOLANO applets, but unfortunately the Safari browser that runs the applets is only 32-bit on Leopard, so applets in Safari still run with the 32-bit Java SE 5 instead of the 64-bit Java SE 6.
    So you have three options to solve the problem -- two free options (one rather easy, one more difficult), and one easy non-free option.
    (1) The Free and Relatively Easy Option
    If you have an Intel Core 2 Duo processor (not a Core Solo or Core Duo), you can install all the software updates from Apple so that you'll have the 64-bit Java SE 6.
    About Java for Mac OS X 10.5 Update 2 http://support.apple.com/kb/HT2733 "Java SE 6 is available on 64-bit, Intel-based Macs only."
    You would then modify your Java Preferences so that Java SE 6 is chosen first for the Java Application Runtime settings. You can verify the modified setting by running the following "java -version" command from the Terminal application (Finder > Applications > Utilities > Terminal):
    $ java -version
    java version "1.6.0_20"
    Java(TM) SE Runtime Environment (build 1.6.0_20-b02-279-10M3065)
    Java HotSpot(TM) 64-Bit Server VM (build 16.3-b01-279, mixed mode)
    There are some more detailed instructions here:
    Install Java 6 on Mac OS X Leopard
    http://gephi.org/users/install-java-6-mac-os-x-leopard/
    Then you can bypass Safari and run the applet directly in the 64-bit Java SE 6 using the "appletviewer" command in Terminal. For example:
    $ appletviewer http://www.actionchat.com/chat/english.shtml
    You just put the URL of the page containing the VOLANO chat applet you want to load. I just tried it on my system, and it works fine. You bypass Java SE 5, which is broken for the VOLANO applets, and you bypass Safari, which cannot run the 64-bit Java SE 6. Instead, you run the VOLANO applet using your Java SE 6 directly!
    (2) The Free and Not-So-Easy Option
    You can download and install SoyLatte as an alternative to the Apple Java VM for your Mac OS X Leopard system.
    SoyLatte: Java 6 Port for Mac OS X 10.4 and 10.5 (Intel)
    http://landonf.bikemonkey.org/static/soylatte/
    I have not tried SoyLatte on my iMac, though.
    (3) The Best but Non-Free Option
    For only $29, you can upgrade your system to the latest Snow Leopard and get both the 32-bit and 64-bit Java SE 6 along with a Safari Web browser that works with Java SE 6 for running applets!
    Mac OS X 10.6 Snow Leopard
    http://store.apple.com/us/product/MACOS_XSNGL
    I hope this information is of help to any Leopard users having trouble with the latest Java update.

    Thanks for the suggestion.
    Please bear in mind that this issue, presumably introduced by Apple's own update, affects not only the command line java interpreter but any other app that depends on Java (including some GUI apps). So it perhaps fits the larger scope of Leopard instead of the Unix area.
    Message was edited by: bhapca

  • Question about modifying the Packet-based link into ASK modulation

    Hello everybody,
        Recently I learned the Packet-based link and I  modified it into ask scheme. But after I test the modified code, I find that it doesn't work as I image.
    I don't know why, can anybody help me about it?
        Thanks very much.
    Attachments:
    Packet-based Link(ASK).zip ‏445 KB

    I have a couple of questions that may seem silly, but...
    USB A = Windows DaRT 7.0 x86 for Windows 8 ISO burned
    USB B = Windows DaRT 7.0 x64 for Windows 8 ISO burned
    Is this a typo? You have it correctly above that where you list all 4 DaRT images, but not in the section I quoted.
    This TechNet article lists compatibility of DaRT versions:
    DaRT 8.1 supports Windows 8.1 and Windows Server 2012 R2.
    DaRT 8.0 supports Windows 8 and Windows Server 2012.
    DaRT 7.0 supports Windows 7 and Windows Server 2008 R2.
    DaRT 6.5 supports Windows 7 and Windows Server 2008 R2.
    DaRT 6.0 supports Windows Vista and Windows Server 2008.
    DaRT 5.0 supports Windows 2000, Windows XP, and Windows Server 2003.
    Also, did you use a Windows 8 ISOs with both DaRT versions? You need Windows 7 disks to create the DaRT 7 recovery disk.
    Let us know,
    Thanks
    David

  • Questions about tuning the USRP packet -based link examples

    Hi everyone,
       Today I do some tests and tunning on the USRP packet-based link examples, and I find these questions:
       First I set the following parameters to the Packet Transmitter.vi: Tx frequency=2441M, samples per symblol=8, sample rate=800k, then the symbol rate should be 100k
       Then I set the Rx frequency to 2441=M and do three tests to the USRP packet receiver.vi:
       1. set the samples per symbol to 8,  the sample rate to 800k, all the packets can be received correctly very fast.
       2. set the samples per symbol to 40, the sample rate to 4M, all the packtes can be received correctly, but slower than the former test.
       3. set the samples per symbol to 50, the sample rate to 5M, all the packets can be received correctly, but much slower than the former two tests.
       4.  set the samples per symbol to 40, the sample rate to 5M, but change the sample rate to  4M  when input the argument to the resample&demod_shell.vi, then I find that no packets can be received correctly.(According to my understanding, resampling the data with 4M sample rate should make the input data time-aligned)
       Can anyone help me interprete above  test? Thanks in advance!

    Hi 0711,
    You are correct.  If you sample at 5MS/s and have a samples/sym of 40, resampling with a sample rate of 4MS/s will allow you to receive the signal.  Digging into the sub_resample_and_demodulate.vi, I found the issue.  The modulation toolkit resample VI that is being used pulls the sample rate of the incoming signal from the incoming waveform (or the dt of the incoming waveform).  In the resample and demodulate subvi, the dt of the incoming signal was hard wired to be 1/x of the desired sampling rate.  For all other uses cases, having these 2 parameters hard wired together does not cause a problem, but for the 4th case you described it does.  I edited the subvi like shown in the image below and was able to get it working:
    Hope that helps and let me know if you have any further questions.  I'll do my best to get you an answer.
    Sarah Y
    SDR Product Manager
    National Instruments | Ettus Research

  • Web based chat

    plase send me the working code of a multi-user web based chat application in java

    Don't crosspost. Continue here: http://forum.java.sun.com/thread.jspa?threadID=5261859

  • Dropping 40%+ internet packets, Spartansburg PA. Not losing packets beyond gateway.

    To start, this is not an isolated issue.  Others in Spartansburg PA are experiencing this issue after investigating, plus my friend in Spring Creak PA (a completely different service station) is experiencing this issue.  This is NOT an issue with my line due to ANY reason.
    I am losing over 40% of my internet packets when pinging google.com for over ten mins!  I also tried yahoo.com, facebook.com... this isn't just one url I am loosing packets too!
    To make sure this wasn't a line issue, I pinged my gateway address at the same time I was pinging those urls.. 0% packet lose!
    My success rate for completing a Speakeasy speed test is also not 100% (It'd be one thing if the line was slow, its winter after all, but it’s another thing to loose packets entirely!)
    I would like someone from Verizon to investigate this by running their own test.  This has been going on for over a week and it is a serious hindrance.  I have never had a Quality of Service issue like this with any other ISP.
    Thank you for your time.

    I am also having the same issues as mentioned above.   This is coming from the subarbs of Philadelphia.  I noticed it start last Thursday.  Below are a couple ping/packet loss and traceroutes.   I gathered these pings when I noticed extreme lag.  7 second pings for multiple seconds is terrible.
    PING google.com (74.125.115.147) 56(84) bytes of data.
    64 bytes from google.com (74.125.115.147): icmp_req=3 ttl=53 time=27.8 ms
    64 bytes from google.com (74.125.115.147): icmp_req=4 ttl=53 time=28.2 ms
    64 bytes from google.com (74.125.115.147): icmp_req=6 ttl=53 time=27.5 ms
    64 bytes from google.com (74.125.115.147): icmp_req=8 ttl=53 time=26.7 ms
    64 bytes from google.com (74.125.115.147): icmp_req=9 ttl=53 time=28.2 ms
    64 bytes from google.com (74.125.115.147): icmp_req=11 ttl=53 time=28.2 ms
    64 bytes from google.com (74.125.115.147): icmp_req=12 ttl=53 time=26.7 ms
    64 bytes from google.com (74.125.115.147): icmp_req=14 ttl=53 time=27.1 ms
    64 bytes from google.com (74.125.115.147): icmp_req=15 ttl=53 time=189 ms
    64 bytes from google.com (74.125.115.147): icmp_req=16 ttl=53 time=356 ms
    64 bytes from google.com (74.125.115.147): icmp_req=17 ttl=53 time=533 ms
    64 bytes from google.com (74.125.115.147): icmp_req=18 ttl=53 time=27.0 ms
    64 bytes from google.com (74.125.115.147): icmp_req=20 ttl=53 time=27.6 ms
    64 bytes from google.com (74.125.115.147): icmp_req=21 ttl=53 time=27.4 ms
    64 bytes from google.com (74.125.115.147): icmp_req=22 ttl=53 time=28.0 ms
    64 bytes from google.com (74.125.115.147): icmp_req=23 ttl=53 time=26.1 ms
    64 bytes from google.com (74.125.115.147): icmp_req=24 ttl=53 time=27.7 ms
    64 bytes from google.com (74.125.115.147): icmp_req=25 ttl=53 time=27.6 ms
    64 bytes from google.com (74.125.115.147): icmp_req=26 ttl=53 time=27.4 ms
    64 bytes from google.com (74.125.115.147): icmp_req=27 ttl=53 time=29.5 ms
    64 bytes from google.com (74.125.115.147): icmp_req=28 ttl=53 time=27.5 ms
    64 bytes from google.com (74.125.115.147): icmp_req=29 ttl=53 time=26.4 ms
    64 bytes from google.com (74.125.115.147): icmp_req=32 ttl=53 time=28.3 ms
    64 bytes from google.com (74.125.115.147): icmp_req=33 ttl=53 time=413 ms
    64 bytes from google.com (74.125.115.147): icmp_req=34 ttl=53 time=916 ms
    64 bytes from google.com (74.125.115.147): icmp_req=35 ttl=53 time=1395 ms
    64 bytes from google.com (74.125.115.147): icmp_req=36 ttl=53 time=1747 ms
    64 bytes from google.com (74.125.115.147): icmp_req=37 ttl=53 time=2238 ms
    64 bytes from google.com (74.125.115.147): icmp_req=38 ttl=53 time=2751 ms
    64 bytes from google.com (74.125.115.147): icmp_req=43 ttl=53 time=4245 ms
    64 bytes from google.com (74.125.115.147): icmp_req=46 ttl=53 time=4268 ms
    64 bytes from google.com (74.125.115.147): icmp_req=47 ttl=53 time=4429 ms
    64 bytes from google.com (74.125.115.147): icmp_req=48 ttl=53 time=4700 ms
    64 bytes from google.com (74.125.115.147): icmp_req=51 ttl=53 time=5095 ms
    64 bytes from google.com (74.125.115.147): icmp_req=52 ttl=53 time=4896 ms
    64 bytes from google.com (74.125.115.147): icmp_req=57 ttl=53 time=1609 ms
    64 bytes from google.com (74.125.115.147): icmp_req=58 ttl=53 time=799 ms
    64 bytes from google.com (74.125.115.147): icmp_req=59 ttl=53 time=107 ms
    64 bytes from google.com (74.125.115.147): icmp_req=60 ttl=53 time=28.1 ms
    64 bytes from google.com (74.125.115.147): icmp_req=61 ttl=53 time=26.5 ms
    64 bytes from google.com (74.125.115.147): icmp_req=62 ttl=53 time=26.9 ms
    64 bytes from google.com (74.125.115.147): icmp_req=63 ttl=53 time=28.4 ms
    64 bytes from google.com (74.125.115.147): icmp_req=64 ttl=53 time=27.9 ms
    64 bytes from google.com (74.125.115.147): icmp_req=66 ttl=53 time=26.7 ms
    64 bytes from google.com (74.125.115.147): icmp_req=67 ttl=53 time=26.7 ms
    64 bytes from google.com (74.125.115.147): icmp_req=68 ttl=53 time=26.9 ms
    64 bytes from google.com (74.125.115.147): icmp_req=69 ttl=53 time=29.3 ms
    ^C
    --- google.com ping statistics ---
    69 packets transmitted, 47 received, 31% packet loss, time 68192ms
    rtt min/avg/max/mdev = 26.162/882.890/5095.440/1554.459 ms, pipe 6
    ING google.com (74.125.113.103) 56(84) bytes of data.
    64 bytes from google.com (74.125.113.103): icmp_req=1 ttl=53 time=7021 ms
    64 bytes from google.com (74.125.113.103): icmp_req=2 ttl=53 time=6912 ms
    64 bytes from google.com (74.125.113.103): icmp_req=3 ttl=53 time=6896 ms
    64 bytes from google.com (74.125.113.103): icmp_req=4 ttl=53 time=7168 ms
    64 bytes from google.com (74.125.113.103): icmp_req=5 ttl=53 time=7361 ms
    64 bytes from google.com (74.125.113.103): icmp_req=6 ttl=53 time=7417 ms
    64 bytes from google.com (74.125.113.103): icmp_req=8 ttl=53 time=7675 ms
    64 bytes from google.com (74.125.113.103): icmp_req=9 ttl=53 time=7710 ms
    64 bytes from google.com (74.125.113.103): icmp_req=11 ttl=53 time=7770 ms
    64 bytes from google.com (74.125.113.103): icmp_req=13 ttl=53 time=7719 ms
    64 bytes from google.com (74.125.113.103): icmp_req=14 ttl=53 time=7231 ms
    64 bytes from google.com (74.125.113.103): icmp_req=15 ttl=53 time=7125 ms
    64 bytes from google.com (74.125.113.103): icmp_req=16 ttl=53 time=7196 ms
    64 bytes from google.com (74.125.113.103): icmp_req=17 ttl=53 time=7283 ms
    64 bytes from google.com (74.125.113.103): icmp_req=19 ttl=53 time=7354 ms
    64 bytes from google.com (74.125.113.103): icmp_req=20 ttl=53 time=7326 ms
    64 bytes from google.com (74.125.113.103): icmp_req=21 ttl=53 time=7616 ms
    64 bytes from google.com (74.125.113.103): icmp_req=23 ttl=53 time=7763 ms
    64 bytes from google.com (74.125.113.103): icmp_req=25 ttl=53 time=7518 ms
    64 bytes from google.com (74.125.113.103): icmp_req=26 ttl=53 time=7334 ms
    64 bytes from google.com (74.125.113.103): icmp_req=30 ttl=53 time=7050 ms
    64 bytes from google.com (74.125.113.103): icmp_req=31 ttl=53 time=6918 ms
    64 bytes from google.com (74.125.113.103): icmp_req=32 ttl=53 time=7035 ms
    64 bytes from google.com (74.125.113.103): icmp_req=33 ttl=53 time=7126 ms
    64 bytes from google.com (74.125.113.103): icmp_req=34 ttl=53 time=6854 ms
    64 bytes from google.com (74.125.113.103): icmp_req=37 ttl=53 time=7040 ms
    64 bytes from google.com (74.125.113.103): icmp_req=39 ttl=53 time=7181 ms
    64 bytes from google.com (74.125.113.103): icmp_req=40 ttl=53 time=7110 ms
    64 bytes from google.com (74.125.113.103): icmp_req=42 ttl=53 time=7335 ms
    64 bytes from google.com (74.125.113.103): icmp_req=43 ttl=53 time=7245 ms
    64 bytes from google.com (74.125.113.103): icmp_req=44 ttl=53 time=7233 ms
    64 bytes from google.com (74.125.113.103): icmp_req=45 ttl=53 time=6867 ms
    64 bytes from google.com (74.125.113.103): icmp_req=46 ttl=53 time=6568 ms
    64 bytes from google.com (74.125.113.103): icmp_req=48 ttl=53 time=6853 ms
    64 bytes from google.com (74.125.113.103): icmp_req=49 ttl=53 time=6941 ms
    64 bytes from google.com (74.125.113.103): icmp_req=51 ttl=53 time=6217 ms
    64 bytes from google.com (74.125.113.103): icmp_req=52 ttl=53 time=5076 ms
    64 bytes from google.com (74.125.113.103): icmp_req=53 ttl=53 time=4089 ms
    64 bytes from google.com (74.125.113.103): icmp_req=54 ttl=53 time=3090 ms
    64 bytes from google.com (74.125.113.103): icmp_req=56 ttl=53 time=1116 ms
    64 bytes from google.com (74.125.113.103): icmp_req=57 ttl=53 time=123 ms
    64 bytes from google.com (74.125.113.103): icmp_req=58 ttl=53 time=27.2 ms
    64 bytes from google.com (74.125.113.103): icmp_req=59 ttl=53 time=27.6 ms
    64 bytes from google.com (74.125.113.103): icmp_req=60 ttl=53 time=26.7 ms
    64 bytes from google.com (74.125.113.103): icmp_req=61 ttl=53 time=28.1 ms
    64 bytes from google.com (74.125.113.103): icmp_req=62 ttl=53 time=27.8 ms
    64 bytes from google.com (74.125.113.103): icmp_req=63 ttl=53 time=26.4 ms
    64 bytes from google.com (74.125.113.103): icmp_req=64 ttl=53 time=28.7 ms
    ^C
    --- google.com ping statistics ---
    64 packets transmitted, 48 received, 25% packet loss, time 63422ms
    rtt min/avg/max/mdev = 26.432/5680.762/7770.894/2781.887 ms, pipe 8
    traceroute to google.com (74.125.115.147), 30 hops max, 60 byte packets
     1  * * *
     2  10.7.16.1 (10.7.16.1)  9.245 ms  10.587 ms  12.078 ms
     3  at (130.81.11.225)  13.893 ms  15.135 ms  16.356 ms
     4  so (130.81.20.138)  17.821 ms  19.309 ms  20.454 ms
     5  0.xe (152.63.3.69)  29.078 ms 0.xe (152.63.3.249)  30.880 ms 0.xe-3-0-2.XL4.IAD8.ALTER.NET (152.63.3.57)  31.131 ms
     6  TenGigE0 (152.63.32.198)  59.392 ms  50.667 ms TenGigE0 (152.63.37.98)  49.240 ms
     7  google (152.179.50.62)  82.575 ms  82.762 ms  81.635 ms
     8  72.14.238.214 (72.14.238.214)  26.059 ms 72.14.238.212 (72.14.238.212)  28.260 ms 216.239.46.248 (216.239.46.248)  28.090 ms
     9  209.85.243.114 (209.85.243.114)  60.433 ms  52.703 ms  51.837 ms
    10  216.239.48.103 (216.239.48.103)  31.146 ms  26.518 ms 64.233.174.117 (64.233.174.117)  27.577 ms
    11  209.85.242.177 (209.85.242.177)  36.145 ms * 209.85.242.181 (209.85.242.181)  33.298 ms
    12  google.com (74.125.115.147)  30.762 ms  30.036 ms  28.894 ms

  • Re: audio, video based chat in Java

    Hai,
    I am new to Java. I created text based chatting in Java using Socket. Now I need to add audio, video based chat in Java through Socket. Can you send sample coding for my project.
         Thanks in advance.
    reg
    vino

    Check out JMF

  • Servlet Based Chat program.

    Hi,
    I would like to develop a web based chat application,
    Does anyone of you have any links which are helpful for me to refer?
    Do you know whether are there any sample servlet chat program ?
    Thank you.
    Your help will be appreciated.

    I have forgotten to mention that the chat program will be web based using Java Servlet technology.

  • Java based Chat console works fine, but does not automatically scroll down to last chat item

    Hi,
    I am currently facing a problem with a Chat program using jsp (Java Server Pages) where the chat console works perfect except for one little thing.
    The chat window does not automatically scroll down to the last reply in the chat window.
    the code used to scroll down to the last items (based on Netscape) is the following:
    <pre><nowiki>if (navigator.appName.indexOf("Netscape") != -1) {
    isOther = (navigator.appVersion.substring(0,1) == "3");
    isNS4 = (navigator.appVersion.substring(0,1) == "4");
    isNS6 = (navigator.appVersion.substring(0,1) == "5");
    } else if (navigator.appName.indexOf("Microsoft Internet Explorer") != -1) {
    isIE = true;
    } else if (navigator.appName.indexOf("Opera") != -1) {
    isOpera = true;
    } else {
    isOther = true;
    if (navigator.platform.indexOf("Mac") != -1)
    isMac = true;
    if (isOther)
    alert("Sorry but you will have to upgrade your browser to NS4+ or IE4+ for this to work properly.");
    function setScrollProperties() {
    if (isMac) {
    scrollStart = 0;
    scrollEnd = answerFrame.document.height - scrollStart;
    } else {
    scrollStart = 0;
    scrollEnd = answerFrame.document.height - scrollStart;
    function doScroll() {
    documentYposition += scrollAmount;
    window.scrollTo(0,documentYposition);
    if (documentYposition < scrollEnd) {
    setTimeout('doScroll()',slowScrollInterval);
    }else if (moreScrolling){
    moreScrolling = false;
    scrolling = false;
    startScroll();
    }else{
    scrolling = false;
    }</nowiki></pre>
    I cannot see what goes wrong in here and the manufacturer does not know how to fix this either.
    Irritatingly this scrolling function is working normally in IE, Chrome and some other browsers.
    I sure hope you can help me, as this is a very irritating problem that needs to be solved.
    Best regards,
    Corné Snoek

    Hi,
    sorry for such a late reply. I tried modifying the java bean to resize the JScrollPane object also but even that didn't work. Then I hardcoded the size of my Java Bean in my forms code by trial and error. For example, the size of the bean area was 381x169. The values that I had to pass to the "setSize" bean method were 510x195. This made the bean exactly fit the bean area. Seems crazy to me, but there it is.
    Anyway, thank you.
    Manu

  • ASA 5510 Firewall internet Restriction based on IP address and block rest users excluding Mails

    Hi,
    As i have assignment to create access list based on IP address like we have to allow internet access this IP range 192.168.172.201 to 212.
    And rest users we have to block excluding Mails.
    Please help.
    Thanks,
    Regards,
    Hemant Yadav 

    login as: Rakh
    [email protected]'s
    password:
    Type help or '?' for a list of available commands.
    FAST-HQ-ASA> en
    Password:
    Invalid password
    Password: ***********
    FAST-HQ-ASA# show rum
                        ^
    ERROR: % Invalid input detected at '^' marker.
    FAST-HQ-ASA# show run
    : Saved
    ASA Version 8.3(1)
    hostname FAST-HQ-ASA
    enable password 7tt1ICjiO2a2/Hn2 encrypted
    passwd U8oee3lIrDCUmSK2 encrypted
    names
    interface Ethernet0/0
    description ASA Outside segment
    speed 100
    duplex full
    nameif OUTSIDE
    security-level 0
    ip address 62.173.33.67 255.255.255.240
    interface Ethernet0/1
    description VLAN AGGREGATION point
    no nameif
    no security-level
    no ip address
    interface Ethernet0/1.2
    description INSIDE segment (User)
    vlan 2
    nameif INSIDE
    security-level 100
    ip address 192.168.172.1 255.255.255.0
    interface Ethernet0/1.3
    description LAN
    vlan 3
    nameif LAN
    security-level 100
    ip address 192.168.173.1 255.255.255.0
    interface Ethernet0/2
    shutdown
    no nameif
    no security-level
    no ip address
    interface Ethernet0/3
    shutdown
    no nameif
    no security-level
    no ip address
    interface Management0/0
    nameif management
    security-level 100
    ip address 192.168.1.1 255.255.255.0
    management-only
    ftp mode passive
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object network INSIDE
    subnet 192.168.172.0 255.255.255.0
    object network LAN
    subnet 192.168.173.0 255.255.255.0
    object network MAIL-SERVER
    host 192.168.172.32
    object network DENY-IP-INTERNET
    range 192.168.172.121 192.168.172.200
    object-group service serBLOCK-INTERNET tcp
    port-object eq www
    object-group network BLOCK-IP-INTERNET
    network-object object DENY-IP-INTERNET
    access-list 102 extended permit icmp any any time-exceeded
    access-list 102 extended permit icmp any any echo-reply
    access-list OUTSIDE-IN extended permit tcp any host 192.168.172.32 eq smtp
    access-list OUTSIDE-IN extended permit tcp any host 192.168.172.32 eq https
    access-list BLOCK-WWW extended deny tcp object-group BLOCK-IP-INTERNET any object-group serBLOCK-INTERNET
    access-list BLOCK-WWW extended permit ip any any
    pager lines 24
    logging asdm informational
    mtu OUTSIDE 1500
    mtu INSIDE 1500
    mtu LAN 1500
    mtu management 1500
    icmp unreachable rate-limit 1 burst-size 1
    no asdm history enable
    arp timeout 14400
    object network INSIDE
    nat (INSIDE,OUTSIDE) dynamic interface
    object network LAN
    nat (LAN,OUTSIDE) dynamic interface
    object network MAIL-SERVER
    nat (INSIDE,OUTSIDE) static 62.173.33.70
    access-group OUTSIDE-IN in interface OUTSIDE
    access-group BLOCK-WWW out interface OUTSIDE
    route OUTSIDE 0.0.0.0 0.0.0.0 62.173.33.65 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication ssh console LOCAL
    http server enable
    http 192.168.1.0 255.255.255.0 management
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    vpn-addr-assign local reuse-delay 5
    telnet timeout 5
    ssh 192.168.172.37 255.255.255.255 INSIDE
    ssh 192.168.173.10 255.255.255.255 LAN
    ssh timeout 5
    console timeout 0
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    username Rakh password EV9pEo1UkhHJSbIW encrypted
    class-map inspection_default
    match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
    parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
    class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
    service-policy global_policy global
    prompt hostname context
    call-home
    profile CiscoTAC-1
      no active
      destination address http
    https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email
    [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:1ee78d19f958efc6fd95f5e9d4e97b8d
    : end
    FAST-HQ-ASA#

  • P routers have no knowledge of the customer prefixes, they just Label switch the packets based on their LFIB

    Here is a scenrio,
    (1.1.1.0)CE1-PE1-P-PE2-CE2(2.2.2.0)
    P router has no customer routes in its routing table, since it is not participating in iBGP.. thats perfect....
    but P routers are meant to label switch packets between CE-1 & CE-2 through PE1 & PE2.. but i cannot see any labels for customer routes in P LFIB:
    /* Style Definitions */
    table.MsoNormalTable
    {mso-style-name:"Table Normal";
    mso-tstyle-rowband-size:0;
    mso-tstyle-colband-size:0;
    mso-style-noshow:yes;
    mso-style-priority:99;
    mso-style-qformat:yes;
    mso-style-parent:"";
    mso-padding-alt:0in 5.4pt 0in 5.4pt;
    mso-para-margin-top:0in;
    mso-para-margin-right:0in;
    mso-para-margin-bottom:10.0pt;
    mso-para-margin-left:0in;
    line-height:115%;
    mso-pagination:widow-orphan;
    font-size:11.0pt;
    font-family:"Calibri","sans-serif";
    mso-ascii-font-family:Calibri;
    mso-ascii-theme-font:minor-latin;
    mso-hansi-font-family:Calibri;
    mso-hansi-theme-font:minor-latin;}
    P#sh mpls for
    Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
    tag    tag or VC   or Tunnel Id      switched   interface
    16     Pop tag     10.10.10.11/32    6703       Se0/1      point2point
    17     Pop tag     10.10.10.10/32    2140       Se0/0      point2point

    Hi Mukarramjahraheel 
    You are right . P will not participating in iBGP. He is not aware of any Customer router of BGP VPNv4 route..
    P Router know only internal IGP. Please go through the below points.
    The JOB of Core router is to propogate the route As Fast As Possible without delay.
    Don't Get confuse in MPLS . MPLS is used for only  Fast switching . Whouth MPLS also you can RUN  VRF kown as VRF - Lite , BGP - AF & use CEF for fast switching.
    Before Going Further Please check you Design = Whether You want to Create Full Mesh IBGP  or Go With  BGP Route Reflector.
    Communication from CE to PE
    PE routers translate into VPN-V4 route
    Assigns an RD, SOO (if configured) and RT based on configuration
    Re-writes Next-Hop attribute  (to PE loopback ) -- When PE Re-Write the Next HOP , That next hop will  IBGP VPNv4 Neighbore PE and that is reachable through internal IGP. MPLS work only for Internal IGP to forward the packet AFAP without delay .
    Assigns a label based on VRF and/or interface
    Sends MP-BGP update to all PE neighbors
    Receiving PE routers translate to IPv4Insert the route into the VRF identified by the RT
    attribute (based on PE configuration)The label associated to the VPN-V4 address will be set onpackets forwarded towards the destination

  • Moving Cloud-Based Chats to P2P

    I wondering how I could complete this? I favor p2p because of it's extensive moderating commands for the large group chat I monitor.

    Hi and welcome to the Skype Community,
    Currently 1-on-1 chats and newly created group chats are cloud based. If you have group chats created with older Skype version they might still be P2P chats.
    Group video calls are "cloud based", e.g. a server is used to mix audio and stream video of participants. I'm not sure about audio only group and 1-on-1 Skype calls, but to my understanding the only cloud contribution to calling is the incoming call signalling which is perfomed by the call notification servers. Actuall calls are still P2P. You can refer to the Skype technical call info screen to verify that yourself.
    Follow the latest Skype Community News
    ↓ Did my reply answer your question? Accept it as a solution to help others, Thanks. ↓

  • How can I protect files from being uploaded to the internet/web-based email or being written to a disc/flash drive?

    I work for a company that want to update itself to this century.  I got all our PC upgraded to Windows 7 and networked into a homegroup.  We want to use a web-based appointment scheduler but this means giving our users web access.  The main
    concern is our .mdb files.  We have anti-virus/anti-spyware to protect us from infiltration but we want to safeguard against personnel selling our client list; At least make it more difficult, just a precautionary measure.  Do I need additional software
    or is it something that I can do in Windows setting?  Or do I need a file encryption service that works in conjunction with Windows Access?  Sorry for my ignorance and thanks in advance.

    There is technology known as RMS which you could set series of policies like only members in the company could access certain documents and if someone copy them and attempt to run them in another PC or outside company, it won't work. Take a look at:
    http://blogs.technet.com/b/rms/archive/2013/08/29/the-new-microsoft-rms-is-live-in-preview.aspx
    https://technet.microsoft.com/en-us/library/dd277361.aspx

  • How To Create An SMS Flash Based Chat with Multiple Usersfor Website

    I have a site, that will need messaging service for up to
    four people at a time. All users are part of a database in mysql. I
    want to use my database to extend the usage of the site to live
    chat. Does anyone know how to start and where to go find out how to
    start, so far in flash I have textfield and input field but how to
    connect is beyond me right now. Please help.

    Have a look
    Here

  • Support contact for Internet VPN based provider access

    Dear folks,
    I have an IP-Sec tunnel operational to provide our customers with Internet access to the gateway 194.117.106.129
    T'his has been up for about 10 years now.
    I am trying to update our databases now. Who would be my contact in case of trouble?
    thanks for any hints
    regards Karsten

    Hi David,
    You mentioned "Another thing I noticed is that the option to Status -> statictics  -> Route details, as Secured Routes gives me the Ip 0.0.0.0, and  other VPN connections give me some Ip ...." this means that there is no split tunneling configured on VPN server. 'Route details' section defines the destinations which you will be able to access over VPN and this is pushed by your VPN server.
    So, if you see 0.0.0.0 in above section, all traffic from your computer goes over the VPN tunnel to server including internet traffic. Two possibilities:
    - That is the expected flow, should work if VPN server has required config to route the internet traffic.
    - If not, and you only use VPN to access certain resources and internet should still work locally, in that case VPN server end config has to be modified to configure split tunnel so that it instead of pushing '0.0.0.0' route sends a route like 'x.x.x.x' where 'x.x.x.x' is the resource behind VPN tunnel. In that way, internet will work locally.
    Either way, its a config issue at VPN server end.
    Simple explanation of split tunneling:
    http://en.wikipedia.org/wiki/Split_tunneling
    HTH.
    Sourav

Maybe you are looking for

  • Since update, facebook doesn't load properly; it does in IE and Chrome.

    firefox updated yesterday. since then, facebook does not load properly at all. i thought maybe facebook had changed, again. nope. i tried with IE, Google chrome and on the ipad and all 3 loaded the way facebook always loads. this is really annoying.

  • "Receive Email Notifications" not working correctly?

    Not a Snow Leopard question, but I don't know where else to post this. I seem to be receiving email notifications for * every * topic in this forum.  My email notification preferences are set for only limited notifications -- i.e., threads I want to

  • GPU Transitions in Premiere CS5

    What happened to GPU Transitions in CS5? - Removed in this version? - Removed from downloadable version? Why explaining Card Flip transition usage if it is not available in Pr CS5? http://help.adobe.com/en_US/premierepro/cs/using/WS82164649-8DCE-4cd5

  • Verify date format in module pool

    Hi all, I am working in module pool. My requirement needs to verify the date format in dd.mm.yyyy. If the entered date format is yyyy.mm.dd, then prompt error message. Can this be done? Please advise.

  • Bouncing dock icon

    I've set up the bouncing dock icon. But in Thunderbird, it would bounce and once TB got focus (even without clicking the dock icon), it would stop bouncing. In Mail, this is not the case, I have to click the dock icon to stop the bouncing. Is this fi