IOS Template - Best Practices

Hello,
Does anyone have a standard template that they apply to all ios switches/routers/waps? I'm looking for some best practices for ios configs. For example, which services do you disable on all devices, what snmp settings, etc..
Thanks!

Hi,
See the below link :
http://www.cymru.com/Documents/secure-ios-template.html
Regards,
Mehrdad

Similar Messages

  • Facelets template best practices

    Hi,
    As I gain more experience in JSF, I am doing things a bit differently. When I first started I was binding all components to a backing bean and using the component binding in code for various things such as multi component validation. Later I used only value bindings, and had a lot of configuration in the template:
    <select id="country" jsfc="h:selectOneMenu" value="#{user.countryCode}" validator="#{someBackingBean.country_validate}" required="true" requiredMessage="#{theme_messages['field.country']} #{theme_messages['word.required']}">
        <f:selectItems value="#{someBackingBean.countryItems}"/>
    </select>I modified that example from real code, so it might make more sense to use a converter than a validator for a country code... But anyway, there is a lot of per component configuration in my templates. When I create multiple themes/skins, this stuff has to be duplicated. When I make changes to the application, all themes have to be updated.
    I think Wicket encourages you to bind all components to the "backing bean" and do your configuration in code. Your equivalent template would look something like this:
    <select id="country" jsfc="h:selectOneMenu" binding="#{someBackingBean.countryDropDown}">
        <f:selectItems value="#{someBackingBean.countryItems}"/>
    </select>You might even leave the f:selectItems out of the template. The only challenge I foresee with this is that using JSF APIs to resolve EL to add a validator, converter, action, or whatever else into the component from code is very verbose and difficult. I asked the JSF expert group to enhance the APIs to make it easier to do everything in code, but it did not make the JSF 2.0 spec. They will consider it in a future release: [JSF API Ticket 363|https://javaserverfaces-spec-public.dev.java.net/issues/show_bug.cgi?id=363]
    Can anyone share their experiences with facelets template complexities and best practices they have learned? If you do most of your component configuration in code, how much of it do you allow in the template? Do you allow value bindings? The f:selectItems tag?
    Thanks,
    Ryan

    If you want full understand facelets , Install NetBeans6.1, install facelets plugin for it, here isa link
    http://armarz.ifolder.ru/9150024. if you want more about facelets read this book -
    http://armarz.ifolder.ru/8396066 .
    In net beans the first create web/facelets application, create facelets template, and client pages for it.
    here is a template example, it hase top, left and content, also in each part inserted one xhtml file for defaults views(logo, logout...)
    <html xmlns="http://www.w3.org/1999/xhtml"
          xmlns:ui="http://java.sun.com/jsf/facelets"
          xmlns:h="http://java.sun.com/jsf/html"
          xmlns:f="http://java.sun.com/jsf/core">
      <head>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
        <link href="/css/tableLayout.css" rel="stylesheet" type="text/css" />
        <link href="/css/index.css" rel="stylesheet" type="text/css" />
        <title>My Template</title>
      </head>
      <body>
        <table cellpadding="0"  cellspacing="0" border="0" width="100%">
          <tr>
            <td id="top" valign="top" align="left" colspan="2" >
              <ui:insert name="top"></ui:insert>
              <ui:include src="top.xhtml"></ui:include>         
            </td>
          </tr>
          <tr>
            <h:panelGroup rendered ="#{,,;,;,;,;,;,;l}">                 
              <td id="left" valign="top" align="left" width="150px">
                <ui:insert name="left"></ui:insert>
                <ui:include src="left.xhtml"></ui:include>           
              </td>
            </h:panelGroup>
            <h:panelGroup rendered ="#{kjkjkjkjkjkkk}">                 
              <td>
                <table width="150px" cellpadding="0" cellspacing="0" border="0">
                  <tr>
                    <td>
                      <f:verbatim> </f:verbatim>
                    </td>
                  </tr>
                </table>
              </td>
            </h:panelGroup>
            <td id="content" valign="top" align="left">
              <ui:insert name="content"></ui:insert>
              <ui:include src="content.xhtml"></ui:include>
            </td>
          </tr>
        </table>
      </body>
    </html>And here is a client page.
    <ui:composition xmlns="http://www.w3.org/1999/xhtml"
                    xmlns:ui="http://java.sun.com/jsf/facelets"
                    xmlns:h="http://java.sun.com/jsf/html"
                    xmlns:f="http://java.sun.com/jsf/core"
                    xmlns:c="http://java.sun.com/jsp/jstl/core"
                    template="/layout/main.xhtml">////refer to main.xhtml template
      <ui:define name="content">
        <f:view>
          <h:form id ="login">
            <table width="200" border="0" cellpadding="0" cellspacing="0">
                <tr>
                  <td align="left" colspan="2" class="red" style="padding:0 0 5px 0" >                                               
                  </td>
                </tr>
                <tr>
                  <td class="form_text">
                    <h:outputText styleclass="form_text" value="#{bean.username}" />
                  </td>
                  <td>
                    <h:inputText styleClass="input_text" id="loginname" value="#{Login.username}" required ="true"
                                 requiredMessage="#{log.required}">                  
                    </h:inputText>
                  </td>
                </tr>
                <tr>
                  <td></td>
                  <td><h:message id="error" for="loginname" styleClass="validate" /></td>           
                </tr>
                <tr>
                  <td class="form_text">
                    <h:outputText styleclass="form_text" value="#{bean.pass}" />
                  </td>
                  <td >
                    <h:inputSecret styleClass="input_text" id="password" value="#{Login.password}" required ="true"
                                   requiredMessage="#{log.passlen}">                      
                    </h:inputSecret>
                  </td>
                </tr>
                <tr>
                  <td></td>
                  <td><h:message id="fail" for="password" styleClass="validate" /></td>           
                </tr>
                <tr>
                  <td>
                    <f:verbatim> </f:verbatim>
                  </td>
                </tr>           
                <tr>
                  <td></td>
                  <td align="right">
                    <h:commandButton styleClass="submit" style="float:right;" value="#{bean.login}" action="#{Login.loggedIn}"  >
                    </h:commandButton>
                  </td>
                </tr>
              </h:panelGroup>
            </table>
          </h:form>
        </f:view>
      </ui:define>
    </ui:composition>is this useful?:)

  • IOS Update Best Practices for Business Devices

    We're trying to figure out some best practices for doing iOS software updates to business devices.  Our devices are scattered across 24 hospitals and parts of two states. Going forward there might be hundreds of iOS devices at each facility.  Apple has tools for doing this in a smaller setting with a limited network, but to my knowledge, nothing (yet) for a larger implementation.  I know configurator can be used to do iOS updates.  I found this online:
    https://www.youtube.com/watch?v=6QPbZG3e-Uc
    I'm thinking the approach to take for the time being would be to have a mobile sync station setup with configurator for use at each facility.  The station would be moved throughout the facility to perform updates to the various devices.  Thought I'd see if anyone has tried this approach, or has any other ideas for dealing with device software updates.  Thanks in advance. 

    Hi Bonesaw1962,
    We've had our staff and students run iOS updates OTA via Settings -> Software Update. In the past, we put a DNS block on Apple's update servers to prevent users from updating iOS (like last fall when iOS 7 was first released). By blocking mesu.apple com, the iPads weren't able to check for or install any iOS software updates. We waited until iOS 7.0.3 was released before we removed the block to mesu.apple.com at which point we told users if they wanted to update to iOS 7 they could do so OTA. We used our MDM to run reports periodically to see how many people updated to iOS 7 and how many stayed on iOS 6. As time went on, just about everyone updated on their own.
    If you go this route (depending on the number of devices you have), you may want to take a look at Caching Server 2 to help with the network load https://www.apple.com/osx/server/features/#caching-server . From Apple's website, "When a user on your network downloads new software from Apple, a copy is automatically stored on your server. So the next time other users on your network update or download that same software, they actually access it from inside the network."
    I wish there was a way for MDMs to manage iOS updates, but unfortunately Apple hasn't made this feature available to MDM providers. I've given this feedback to our Apple SE, but haven't heard if it is being considered or not. Keeping fingers crossed.
    Hope this helps. Let us know what you decide on and keep us posted on the progress. Good luck!!
    ~Joe

  • Template(best practice) for Switch ports

    Hi,
    Looking for best practice advice on switchport config for client facing ports.
    We recently had an incident where an access port turned into a trunk(trunk mode desirable), which we obviously do not want to happen again!
    For Access Ports(First two should stop DTP I'm hoping?):
    switchport mode access
    switchport nonegotiate
    storm-control broadcast level 20.00
    storm-control action trap
    no cdp enable
    spanning-tree portfast
    spanning-tree bpdufilter enable
    spanning-tree guard root
    switchport port-security maximum 10
    switchport port-security
    switchport port-security aging time 10
    And for trunk ports to clients:
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk allowed vlan xxx,xxx
    switchport nonegotiate
    storm-control broadcast level 20.00
    storm-control action trap
    no cdp enable
    spanning-tree bpdufilter enable
    spanning-tree guard root
    Thanks in advance.

    Look here: http://www.cisco.com/en/US/docs/solutions/Enterprise/Branch/E_B_SDC1.html#wp68930
    That's Cisco's branch design doc from Design Zone.
    For those that want a fast answer:
    For VoIP phones and PC:
    interface GigabitEthernet1/0/6 - interface GigabitEthernet1/0/23
    description phone with PC connected to phone
    switchport access vlan 102
    switchport mode access
    switchport voice vlan 101
    switchport port-security maximum 2
    switchport port-security
    switchport port-security aging time 2
    switchport port-security violation restrict
    switchport port-security aging type inactivity
    ip arp inspection limit rate 100
    load-interval 30
    srr-queue bandwidth share 1 70 25 5
    srr-queue bandwidth shape 3 0 0 0
    priority-queue out
    mls qos trust device cisco-phone
    spanning-tree portfast
    spanning-tree bpduguard enable
    ip verify source
    ip dhcp snooping limit rate 100
    For data only:
    interface GigabitEthernet1/0/24- interface GigabitEthernet1/0/28
    description DATA only ports
    switchport access vlan 102
    switchport mode access
    switchport port-security maximum 3
    switchport port-security
    switchport port-security aging time 2
    switchport port-security violation restrict
    switchport port-security aging type inactivity
    ip arp inspection limit rate 100
    load-interval 30
    srr-queue bandwidth share 1 70 25 5
    srr-queue bandwidth shape 3 0 0 0
    priority-queue out
    spanning-tree portfast
    spanning-tree bpduguard enable
    ip verify source
    ip dhcp snooping limit rate 100
    That's Cisco's recommendation.
    And just my opinion is that I'd much rather shut a port down that receives a BPDU than just filter it. Reason being that you can't trust users not to do something stupid, like hook two switch ports to the same switch they're using at their desk in an effort to "make the network faster". For two, if someone malicious plugs in a switch into your environment, shut the port down. . .that makes it hard for them to do anything malicious.

  • ASA5545x basic config template Best Practice

    Hello
    I am in the process of making some major WAN/Data Center network changes. As part of that, i am installing
    dual ASA5545x's in each DC (2) for redundancy. Please advise on what is best practice for basic configuration on these devices.

    If you want a good overview guide, there's a Cisco Validated Design (CVD) that covers an ASA setup. See this link.
    At the same time, firewall configuration and what you setup depends a lot on your policy and what you're using the firewall for - Internet edge, DMZ, milti-tenant, inter-department, remote access VPN (client-based and clientless), site to site VPN, etc.
    Each has numerous options and no prescriptive guide covers them all.

  • ETL patterns/strategies/templates/"best practices"

    The OWB Users Guide is good for defining the OWB operators, but I'm having some difficulty deciding how to best combine those operators to formulate a mapping. I'm hoping someone will be able to point me to documentation that will fill the gap. It wouldn't necessarily need to be OWB specific.
    Some example questions that I'm hoping an "ETL patterns" book or document would address:
    1. High level implementation decisions (Is the source data staged locally? How/when are the changed records identified?)
    2. Options for locally staging data.
    3. Options for implementing a Type I/II/III SCD.
    4. Options for implementing a cube.
    I was able to find "Slowly Changing Dimensions with Oracle9i Warehouse Builder" (http://otn.oracle.com/sample_code/products/warehouse/files/SCDWhitePaper.zip) that gave a lot of guidance on the SCD issues. The Type II SCD mapping presented in that document uses 10 operators. I never would have been able to formulate that on my own based on just reading the OWB documentation.
    Thanks,
    Brian

    Hi Torsten
    I assume you want to follow the framework described in the SCD Whitepaper.
    Where do I have to add the unbound table?You will need to insert data into a table, and not a dimension. More than this, since you have a need for using a sequence to feed the items with a surrogate key, there comes a matching problem (this is described in the whitepaper).
    The table must be added as the final destination of the data, after the last union (as shown in the Whitepaper).
    Is it an OWB table in the target module where the target dimension is located? Or do I have to create it in the database using sql*plus?It is neither, read the next question
    Why do you call it "unbound"? Because it is not a dimension or fact-table?The reason I call it unbound is that OWB does not have a "true" match between the object in the mapping and the object in the database. There is probable more to it than this, but let's just say, that it could be compared to some temporary table or something - usually it is not good to use unbound tables, but since we edit the "bound name" to an existing repository table, it's no problem - but be aware, that you will get a warning ever after...
    But is it true that I don't need the target dimension in this mapping now?No, you should use it as in the whitepaper, since you need to check if there is a trigger column that should instantiate a new record, or, if an insert or an update should be required.
    Or how do I connect the unbound table to the target mapping?You change the "bound name" (right-click the table, and choose "properties" and change the bound name to the name of the dimension).
    Torsten, generally you should follow the whitepaper, except for the last table/dimension :)
    Don't sweat if your stuck - I've clicked a gazillion times in OWB, in order to make this work - ask again, if I don't make sence :)
    Yours
    Kim

  • IOS DHCP Best Practices

    Hi Group,
    I have a query regarding DHCP conflicts. One of our customer is using Cisco 4500 switches in Core/Distribution and these switches are running DHCP service as well. There is one DHCP Pool configured for IP Phones (172.21.17.0/24). Yesterday we got compalint from cutomer that IP Phones are not able to get IP address so I checked the primary 4500 switch and found 'DHCP conflict' log messages so I used ' claer ip dhcp conflict *' command and after that all IP Phones started getting ip addresses.
    What could be the possible cause of this problem ? Should we disable logging of DHCP conflicts ?
    Can we avoid such incident by using 'ip dhcp ping' command ? Kindly guide me in this reagrd.
    Thanks in Advance.
    Regards,
    Mujeeb

    Hi Andrew,
    Here is the setup of our client,
    - 2*4500 are working in primary/secondary setup.
    - Voice VLAN is 12 and DHCP pool for IP Phones is 172.21.17.0/24. Same DHCP pool is configured on both primary & seconadry switch.
    - HSRP is running, Primary 4500 is 'Active' Router.
    - Primary 4500 is root switch for VLAN 12.
    - All edge switches are connected with primary and secondary 4500 except 2 switches which are cascaded with each other and one of them is only connected with secondary 4500 so root port is going towards secondary 4500. As per my understanding when IP phones which are connected with this edge switch will require IP Address from DHCP then they will broadcast the request. In the result broadcast traffic will actually flow through secondary 4500 to reach root switch but secondary switch is also running DHCP service with same DHCP pool so it will provide the IP Addresses to specific IP Phones. This setup could result in DHCP IP conflicts ??
    Regards,
    Mujeeb

  • Best Practices For Household IOS's/Apple IDs

    Greetings:
    I've been searching support for best practices for sharing primarily apps, music and video among multple iOS's/Apple IDs.  If there is a specific article please point me to it.
    Here is my situation: 
    We currently have 3 iPads (2-kids, 1-dad) in the household and one iTunes account on a win computer.  I previously had all iPads on single Apple ID/credit card and controlled the kids' downloads thru the Apple ID password that I kept secret.  As the kids have grown older, I found myself constantly entering my password as the kids increased there interest in music/apps/video.  I like this approach because all content was shared...I dislike because I was constantly asked to input password for all downloads.
    So, I recently set up an individual account for them with the allowance feature at iTunes that allows them to download content on their own (I set restrictions on their iPads).  Now I have 3 Apple IDs under one household.
    My questions:
    With the 3 Apple IDs, what is the best way to share apps,music, videos among myself and the kids?  Is it multiple accounts on the computer and some sort of sharing? 
    Thanks in advance...

    Hi Bonesaw1962,
    We've had our staff and students run iOS updates OTA via Settings -> Software Update. In the past, we put a DNS block on Apple's update servers to prevent users from updating iOS (like last fall when iOS 7 was first released). By blocking mesu.apple com, the iPads weren't able to check for or install any iOS software updates. We waited until iOS 7.0.3 was released before we removed the block to mesu.apple.com at which point we told users if they wanted to update to iOS 7 they could do so OTA. We used our MDM to run reports periodically to see how many people updated to iOS 7 and how many stayed on iOS 6. As time went on, just about everyone updated on their own.
    If you go this route (depending on the number of devices you have), you may want to take a look at Caching Server 2 to help with the network load https://www.apple.com/osx/server/features/#caching-server . From Apple's website, "When a user on your network downloads new software from Apple, a copy is automatically stored on your server. So the next time other users on your network update or download that same software, they actually access it from inside the network."
    I wish there was a way for MDMs to manage iOS updates, but unfortunately Apple hasn't made this feature available to MDM providers. I've given this feedback to our Apple SE, but haven't heard if it is being considered or not. Keeping fingers crossed.
    Hope this helps. Let us know what you decide on and keep us posted on the progress. Good luck!!
    ~Joe

  • Best practice for Active Directory User Templates regarding Distribution Lists

    Hello All
    I am looking to implement Active Directory User templates for each department in the company to make the process of creating user accounts for new employees easier. Currently when a user is created a current user's Active directory account is copied, but
    this has led to problems with new employees being added to groups which they should not be a part of.
    I have attempted to implement this in the past but ran into an issue regarding Distribution Lists. I would like to set up template users with all group memberships that are needed for the department, including distribution lists. Previously I set this up
    but received complaints from users who would send e-mail to distribution lists the template accounts were members of.
    When sending an e-mail to the distribution list with a member template user, users received an error because the template account does not have an e-mail address.
    What is the best practice regarding template user accounts as it pertains to distribution lists? It seems like I will have to create a mailbox for each template user but I can't help but feel there is a better way to avoid this problem. If a mailbox is created
    for each template user, it will prevent the error messages users were receiving, but messages will simply build up in these mailboxes. I could set a rule for each one that deletes messages, but again I feel like there is a better way which I haven't thought
    of.
    Has anyone come up with a better method of doing this?
    Thank you

    You can just add arbitrary email (not a mailbox) to all your templates and it should solve the problem with errors when sending emails to distribution lists.
    If you want to further simplify your user creation process you can have a look at Adaxes (consider it's a third-party app). If you want to use templates, it gives you a slightly better way to do that (http://www.adaxes.com/tutorials_WebInterfaceCustomization_AllowUsingTemplatesForUserCreation.htm)
    and it also can automatically perform tasks such as mailbox creation for newly created users (http://www.adaxes.com/tutorials_AutomatingDailyTasks_AutomateExchangeMailboxesCreationForNewUsers.htm).
    Alternatively you can abandon templates at all and use customizable condition-based rules to automatically perform all the needed tasks on user creation such as OU allocation, group membership assignment, mailbox creation, home folder creation, etc. based on
    the factors you predefine for them.

  • Captivate 4.0 - Need best practice tips on panning, templates, resolution, etc.

    Hi all,
    Been searching all over in case someone has already published Best Practices for Captivate 4.0 (particularly the new/enhanced features), but coming up empty. My client's in house graphics person has been tasked with creating a template for us to use for a number of software simulations. He's running in to these challenges:
    - Our SWF needs to be 800 x 600 and he created the template for this size, but the app won't fit.
    - He's found the panning feature to produce very choppy, disappointing results. Tips?
    - His suggestion is we capture at 1024 x 768, then resize to 800 x 600, then copy/paste the slides into his 800 x 600 template. Would we be better off recreating the template at 1024 x 768 and not resizing until the final output is generated for each tutorial? His concern is that our template will then become larger, making it harder for us to send back and forth as changes are made, etc.
    Any other suggestions for how to deal with the resolution issue, how best to take advantage of templates, etc.?
    Thanks,
    Katie Carver
    Senior Technical Writer
    Docs-to-You, LLC

    Hi there
    In my own opinion, Panning is a nice attempt, but just doesn't cut the mustard. It's nowhere near as good as the panning one sees with Camtasia Studio.
    I might suggest combining Camtasia with Captivate for the ultimate development set. There are aspects Captivate shines in when compared with Camtasia, and there are aspects Camtasia shines in when compared with Captivate. So I say if you can afford it, go for it!
    Now I know that both packages are sort of pricey and not everyone can afford both. In that case you might want to try Jing, which is free to use. I've not looked very deeply at it, but it may offer some of what Camtasia does. You could then use that for your panning and enhance Captivate that way.
    Cheers... Rick
    Helpful and Handy Links
    Captivate Wish Form/Bug Reporting Form
    Adobe Certified Captivate Training
    SorcerStone Blog
    Captivate eBooks

  • Best practice - creating functions in data model vs. rtf template

    Just a general question. Is there a best practice of creating functions in the data model vs. creating the functions in the data template?
    For example, is it more efficient to sum two fields in my SQL query or to create a function in the template that sums the two fields? Just curious if there is any performance benefit of one over the other.
    Thanks!

    anything you push it to DB(SQL), will be the faster than processing outside.

  • Single Template support multiple formats of data - Best practice

    I have a requirement to create Invoices in a single PDF file.
    The invoices would belong to different categories - DebitNotes, CreditNotes, Invoices with single product,
    invoices with multiple product etc.. each will have a different format.
    I initially thought the right way to create a single pdf is to use a
    single Template, with different formats of invoice seperated by conditional formatting.
    The see from reading the blogs that the other way is to create sub-template
    (one each for credit, invoice, Debits etc) and plug it into the
    main template.
    I would like to know what is the best practice that is followed in the above case.
    If I were to use sub-templates how would I make it possible to view the invoice stub only on the first page.
    Since the data from the sub-template would go to multiple pages.
    Is adding the stub data to the footer the only option. Please can someone share with me an example
    template.
    Thanks
    Shandrila

    Shandrila
    If the various document types are of a single XML format ie the same structure with just document type differences and the layout format is the same just the data different or very minimal changes that can be handled with conditional formatting then I think it would be OK to have a single report for all document types.
    If the data structures are very different and the layout requirements are different then I would create separate reports for each document type. If the data structure is teh same but the document type layouts are different then go for separate layout formats.
    Going down the sub template path can be a little difficult, you might end up with a very complex set of templates that are almost as much of a pain to manage as the original report you are trying to replace.
    Here's the best scenario IMHO ...
    1 data extract, parameterized to pull invoice, CM, etc data based on the user request
    Multiple layout templates, 1 for each document type. If you have common layout sections across the layouts e.g address blocks then break them out as sub template components that all of the layouts can access and share.
    Multiple report definitions, sharing the data extract with a single layout template associated with them
    cheers
    Tim

  • Flash Alternative Content ~ Best Practice ~ Safari on iOS Devices ~ iPad iPhone iPod Touch

    Hi Folks,
    Is there a documented best practice for providing alternate content for Flash in Safari on iOS devices?
    I am getting white space where my Flash animation would normally appear, and management is displeased. I need to display alternative content in this space. I'm hopeful that Adobe has published a best practice for how to accomplish this.
    tyvm
    Keith

    Not sure about Adobe official stance but they have started using swfobject Flash detection to place Flash <objects> on the Web page. The problem I see with the Adobe implementation is that about the only alternate content they recommend is "Click here to download the latest version of Flash player".
    That is about the lamest alternate content you could possibly imagine! Just because you recommend that your viewers download the new version.... doesn't mean they will... so they still go without REAL alternate content.
    A MUCH BETTER use of swfobject is to actually provide alternate content! For your review::
    If you think that Flash is somehow bad for SEO, it's time to dispell that MYTH!
    If fact, in some circumstances I'll use Flash INSTEAD of just HTML because then I'll have better SEO than with just HTML alone.
    http://www.worldbarefootcenter.com/
    The link to World Barefoot Center in the above post is just one example. View the source code and you see a couple paragraphs of text along with regular HTML links.... but what displays is the Flash version of the image and Flash links.
    The client provided the artwork for the page... and that's what they wanted to use a .jpg image. Well yes, that could be done in HTML but it would be virtually invisible to Google. So Instead I converted the image into a Flash .swf and used swfobject to display the Flash. swfobject allows you to create alternate content inside the <div> which also holds the Flash .swf, then when the page is loaded it detects if the browser has the Flash pluggin. If it does, it displays just the Flash content, if not, it displays the alternate content. Since almost everyone has the Flash pluggin, for most people the Flash version of the <div> will display.
    The alternate content for that <div> can be any regular HTML text, images, media player, links, etc., anything that you would use if you were not using the Flash. Now the best part is that the alternate content can be "over the top" as far as optimizing for SEO, since it will not be seen by most viewers.
    Here's another example of SEO with Flash.. again, the page is just a single image provided by the client:
    http://www.ksowetsuits.com/
    View the source code. The alt content is paragraph after paragraph of information about the site, including lists and links. If it was just the HTML, it might be kind of a boring Home page. But for SEO I can go "over the top" in promoting the site, since most viewers will never see that part... but it's all indexed by search engines. The end result is BETTER SEO using Flash than just HTML.
    On another Web site, a Flash video is displayed, the alt content is the complete text narration of the video. Now how many people would take the time to read that if they could just watch the video instead?? again, better SEO with Flash than without. In fact in one case we had first page search result from that video narration within 4 hours of posting the page.
    On still another site with a Flash video, the alt content is another video, but a .mov version, which will, in effect play Flash video on the iPhone (not possible you say??). Well since the iPhone does not have Flash pluggin, it simply displays the .mov version of the video, while everyione else sees the Flash version.
    So anyway, if Flash is a part of your Web development, you should look into using swfobject and alternate content.
    http://code.google.com/p/swfobject/
    Best wishes,
    Eye for Video
    www.cidigitalmedia.com
    So it is and has been for a number of years now, very easy to provide alternate content for non Flash devices... and that includes text, images, and video.
    Best wishes,
    Adninjastrator

  • Is it a best practice to have a template with one master page?

    I am a newbie FM 11 writer and am cleaning up some unorganized books. Should I copy one set of Master Pages to all files in the book. Currently my TOC and certain other files have unique master pages. I would like to set up our books using best practices and would like input from the community. Thanks.

    There are two schools of thought on this. The specific sub-template approach or the "kitchen sink" approach.
    In the "kitchen sink" (i.e. everything, including the...) approach, the FM template is loaded with everything required for the project in a single file. It's simple to deploy, import it to all files and you're good to go. However, the author may have to deal with all sorts of superfluous tags and page layouts in some specific file types, like the cover pages, TOC, Index and other generated files. The onus is on the author to select the correct items to use from the multitude of choices.
    The sub-template approach is modular approach where one creates the various components in separate template files, e.g. paragraph and character tags, tables, page layouts, etc. and combines to create specific templates for the various book components. These component-combined templates only have the minimum that is required for each type of document component. This is a lego-like approach and it provides more flexibility (IMHO) with modifying, updating and creating new templates. This is easier (perhaps less intimidating would be a better term) for the author to use as their choices are much more limited in any given context. However, they do have to apply the correct templates to the specific book components.
    In all cases, you need to document the usage of all components in the template(s), so authors will know the intent of each and every tag, table, sttyle, page layout, etc.

  • Templates & Library items - best practice

    I've been having a bit of a heated discussion about how
    templates and library items should be used on medium to large
    websites.
    I'm of the opinion that you should have 1 template (or as few
    as possible) and any differences be managed with Library items.
    My colleague's argument is you should have a different
    template for each section, so for example 1 for the news, 1 for the
    features section (for magazine sites) so that if you have a banner
    section wide you change that template, as opposed to the way I'm
    used to which would be 1 template with multiple library items in
    the editable regions of the template, my reasoning for this is the
    large amount of html used for each template (like rollovers) can
    become inconsistent when there's more than one template. Like if
    you change something site wide you have to remember to change all
    of the templates, if you do this with a simple copy past DW can
    still make corrupt code if you use multiple templates.
    So basically I was wondering if there was a standard or best
    practice way of doing this.
    Thanks

    Your colleague is mistaken IN MY OPINION. I think you are on
    the right
    track *unless* your section pages are *SO* different in
    layout that you
    cannot conveniently include all of the
    alterations/permutations in a single
    template page. Further, my current workflow is to rely
    heavily on
    server-side includes within template pages, as described here
    Templates do make your life much easier. I use the following
    scheme....
    First, I mentally separate the page layout into three
    sections:
    1. Stuff that will not change for the life of the site (i.e.,
    the basic
    structural elements)
    2. Stuff that *could* change from time to time (e.g.,
    navigation elements,
    burst advertisements, section-specific navigation, etc.)
    3. Stuff that *will* change from one page to the next
    Then I create a template containing all class1 elements. Next
    I create
    server-side include files containing all class 2 elements and
    place them on
    the template as needed. Note - some of the class 2 elements
    may be
    "section-specific elements", and their placement on the
    template will be
    subject to the next item. Finally, I insert editable regions
    to cover the
    class 3 items, INCLUDING the section-specific navigation.
    This allows me to just cookie-cut the rest of the site. I
    estimate that
    even for fairly large sites, about 80% of my work goes into
    planning and
    creating this template file.
    For what it's worth, I never use Library items....
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.dreamweavermx-templates.com
    - Template Triage!
    http://www.projectseven.com/go
    - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs,
    Tutorials & Resources
    http://www.macromedia.com/support/search/
    - Macromedia (MM) Technotes
    ==================
    "tefnut" <[email protected]> wrote in
    message
    news:[email protected]...
    > I've been having a bit of a heated discussion about how
    templates and
    > library
    > items should be used on medium to large websites.
    > I'm of the opinion that you should have 1 template (or
    as few as possible)
    > and
    > any differences be managed with Library items.
    > My colleague's argument is you should have a different
    template for each
    > section, so for example 1 for the news, 1 for the
    features section (for
    > magazine sites) so that if you have a banner section
    wide you change that
    > template, as opposed to the way I'm used to which would
    be 1 template with
    > multiple library items in the editable regions of the
    template, my
    > reasoning
    > for this is the large amount of html used for each
    template (like
    > rollovers)
    > can become inconsistent when there's more than one
    template. Like if you
    > change
    > something site wide you have to remember to change all
    of the templates,
    > if you
    > do this with a simple copy past DW can still make
    corrupt code if you use
    > multiple templates.
    >
    > So basically I was wondering if there was a standard or
    best practice way
    > of
    > doing this.
    >
    > Thanks
    >

Maybe you are looking for

  • 3D Picture Control Orthographic View zoom - Camera Set up?

    I am trying to display two 3D picture controls.  One displays some objects in 3D (Auto Projection: Perspective, Camera Controller: Spherical).  This 3D image works great and I am having no problems with it.  The other Picture Contol is meant to simul

  • Iphoto book

    The opacity slider does not appear when I choose the page when making a book in iphoto; only the zoom slider appears.  How do I get the opacity slider to appear?

  • Not playing back .mov

    I have 10.8.5 osX and QT 10.2 - I have exported .mov from iPhoto into a folder, and when I open in QT I get this.. QuickTime Player can't open "IMG_0917-2.MOV" because the movie's file format isn't recognized. I clicked on the "tell me more" button t

  • MBP 17" just shipped

    My 17" MBP shipped today and is due to be delivered to me in the UK on or before 12 May. Nice! Anyone else's shipped yet? Awaiting MBP 17", 2.16 Ghz, 7200 Rpm, 100G HD, 1G RAM   Mac OS X (10.4.6)  

  • Cat-4506 with Sup II+ won't load new IOS

    I'm trying to upgrade the IOS on my 4506 SUP II+ (WS-X4013+) to 12.2(31)SG from 12.2(25)EWA5. Here are the boot commands and what is in bootflash: and the error during boot: boot system flash slot0:cat4500-ipbasek9-mz.122-31.SG.bin boot system flash