Is chaining pageflow actions allowed?

Hi,
I have 2 different actions which chain to a third action (which seperates
the common logic):
@jpf:forward name="success" path="showBookList.do"
addBookToList(BookDetailsForm form) {
// add a book
return new Forward("success");
@jpf:forward name="success" path="showBookList.do"
removeBookFromList(BookIDForm form) {
//remove a book
return new Forward("success");
@jpf:forward name="success" path="bookList.jsp"
showBookList() {
//fetch book list
return new Forward("success");
This actually works fine, but I am getting netui errors which clutter my
log:
NETUI ERROR: Unable to update expression "{actionForm.isbnPK}" with the
value [0
-13-100287-2]. The typical cause is that the object represented by the
expressi
on is not available or is the wrong type for updating.
This is apperently because for the showBookList action it tries to set the
form parameters.
return new Forward("success", null); doesnt help
Is there a way to make this false netui error dissappear?
I 've read that struts allows action chaining, so why not pageflows?
Thank you for any and all help,
Geoffrey

Hi kevin,
I am not clear with your reqirment. But if you just want to call an action in page flow A from another page flow B, then you can forward to the required action as shown below.
public class A extends PageFlowController{
* @jpf:action
* @jpf:forward name="success" path="/folder/actionB.do"
protected Forward begin()
//logic here
With Regards,
:-) prasad

Similar Messages

  • What is the best way to call a pageflow action from JavaScript?

    What is the best way to call a pageflow action from JavaScript?
    Thanks,
    John

    John,
    How would I do this from a grid??? Unfortunately there are no JavaScript attributes
    on any of the grid tags that I can see.
    Thanks,
    John
    "John H" <[email protected]> wrote:
    >
    Thanks John!
    "John Rohrlich" <[email protected]> wrote:
    John,
    If you want to put up a confirm dialog before calling an action from
    an
    anchor it is done as follows.
    Here is an example from code of mine that deletes a customer order,if
    the
    user confirms the delete. I pass the order id as a parameter.
    - john
    Here is the JavaScript -
    function confirmDelete() {
    if(confirm('Continue with order delete?'))
    return true;
    else
    return false;
    Here is a sample anchor tag -
    <netui:anchor action="requestToDeleteOrder" onClick="return
    confirmDelete(); return false;">
    Delete
    <netui:parameter name="orderId" value="{container.item.orderId}"/>
    </netui:anchor>
    "John H" <[email protected]> wrote in message
    news:402138f5$[email protected]..
    Thanks for the replies. I figured it was going to require buildingmy own
    url
    to call the action. I had hoped there was an easier way to do it.Rich,
    the
    reason I want to do this is because I want to call the JavaScript
    function
    confirm()
    when a user clicks on a link (in a repeater/grid) to drop a record,I only
    want
    to call the drop action if the user confirms the drop. Maybe thereis a
    better
    way to do what I am trying to do??? I really appreciate any help
    you
    guys
    can
    give me on this, I am pretty new to this sort of stuff.
    Thanks,
    John
    "Rich Kucera" <[email protected]> wrote:
    "John H" <[email protected]> wrote:
    What is the best way to call a pageflow action from JavaScript?
    Thanks,
    JohnTry figuring out the URL to the pageflow action, create a hidden
    form
    in the
    page, then use JS to submit the form. Why would you want to though,
    isn't
    the server going to want to send you to the next page?

  • SET CHAINED command not allowed within multi-statement transaction

    Hi,
    i need to do one transaction and i am setting autocommit(false) and
    once i am don ewith my 2 inserts i am settins it to true.
    i have like 20 thousand rows and when it is working fine for some inserts but after that it is throwing
    "SET CHAINED command not allowed within multi-statement transaction".
    can anyone please help me.

    You can find some information here:
    http://publib.boulder.ibm.com/infocenter/wsphelp/index.jsp?topic=/com.ibm.websphere.nd.doc/info/ae/ae/rtrb_dsaccess.html
    it's first problem for sybase DB

  • Calling other pageflow action from header

    hi
    I want to call an action from header bt it throws global app exception and if i give .jsp path in href then the headers nad footers are not coing
    plz help me out

    you can use <netui:anchor> tag in your header jsp to call an action that is defined in Main Controler.jpf
    Since header is not part of any portlet, any actions that you want to call from header should be defined in Controler.jpf file which is under your WebApp.
    But when you do this, you might loose portal context. so you can only use this solution to implement 'logout' or similar functionality where you dont care about portal context after the call.
    Another solution is to mimic the url that portal generates when we call a pageflow action. this is not a clean solution but it works and you won't loose portal context.
    -Subba

  • Ajax call to pageflow action: how to read action output objects?

    I have a pageflow action like:
    doSomething()
    Customer[] customers = null;
    // build the customer array
    Forward f = new Forward("success");
    f.addActionOutput("customers", customers);
    return f;
    I am calling this action from my javascript function using AJAX. How do I read the Customer array in my javascript? I am using the DOJO library.
    dojo.xhrPost({
         url: "/pageflow.doSomething", // I have URL rewrite rules set up whic forwards to the necessary pageflow function
         content: {
              "key":"value",
              "param":"test",
         handleAs: "JSON",
         handle: function(data,args){
              // WHAT GOES HERE?
    });

    This isn't so much pageflow-specific, as AJAX specific. For the xhr call to work, the url (whatever it is) needs to output a valid json object structure so the dojo method can interpret it into a javascript object. So, you would need to make the jsp/servlet which is the forward of the pageflow action output that json structure (instead of HTML). There are many utility libraries out there for creating json from java objects -- just search around the internet; or you could create your own. [http://json.org] is handy starting point.
    So, as an example, I could imagine your customer json looking like:
    "customers" : [
    { "id": 1, "fname": "John", "lname": "Doe", "addr": "1234 5th St. Anytown, CA" },
    { "id": 2, "fname": "Joe", "lname": "Blow", "addr": "6789 10th St. Anytown, CA" }
    Then, in the "// WHAT GOES HERE?" section, you would access that array as any javascript array, e.g:
    function (data, args) {
    var customers = data.customers;
    for (var i = 0; i &lt; customers.length; i++) {
    alert('Customer ' + customers.id + ' is ' + customers.fname + ' ' + customers.lname + ' at ' + customers.addr);
    (Sorry the formatting is messed up, but this forum doesn't seem to maintain whitespace correctly.)
    Maybe in this case, you could populate a dojo list or a table grid, or you could just create an HTML structure in the DOM via javascript. It all depends on what you want your user interface to look like.
    Greg
    Edited by: gsmith on Feb 11, 2009 9:25 AM

  • Sybase:  SET CHAINED command not allowed within multi-statement transaction

    Hello,
    I'm getting the error message "SET CHAINED command not allowed within
    multi-statement transaction" for CMP Entity beans against Sybase.
    The errors appear in my jdbc.log in this order:
    010SM: This database does not support the initial proposed set of
    capabilities, retrying.) SQLState(010SM)
    JZ0EM: End of data.
    JZ0SJ: Metadata accessor information was not found on this database.
    Please install the required tables
    as mentioned in the jConnect documentation.
    010SL: Out-of-date metadata accessor information was found on this
    database. Ask your database administrat
    or to load the latest scripts.) SQLState(010SL)
    SQLState(ZZZZZ) vendor code(226)
    com.sybase.jdbc2.jdbc.SybSQLException: SET CHAINED command not allowed
    within multi-statement transaction.
    I'm using JConnect 5.5, WebLogic 6.1 sp3, Solaris 8, and Sybase 11.
    The weird thing is, the app works on a box running 6.1 sp2 and Win2k
    Prof.
    Any ideas?
    Thanks!
    Dan

    Hi Dan,
    There is a patch for this sybase problem, please contact [email protected] to
    get a temp patch.
    sree
    "Dan Blaner" <[email protected]> wrote in message
    news:[email protected]..
    Hello,
    I'm getting the error message "SET CHAINED command not allowed within
    multi-statement transaction" for CMP Entity beans against Sybase.
    The errors appear in my jdbc.log in this order:
    010SM: This database does not support the initial proposed set of
    capabilities, retrying.) SQLState(010SM)
    JZ0EM: End of data.
    JZ0SJ: Metadata accessor information was not found on this database.
    Please install the required tables
    as mentioned in the jConnect documentation.
    010SL: Out-of-date metadata accessor information was found on this
    database. Ask your database administrat
    or to load the latest scripts.) SQLState(010SL)
    SQLState(ZZZZZ) vendor code(226)
    com.sybase.jdbc2.jdbc.SybSQLException: SET CHAINED command not allowed
    within multi-statement transaction.
    I'm using JConnect 5.5, WebLogic 6.1 sp3, Solaris 8, and Sybase 11.
    The weird thing is, the app works on a box running 6.1 sp2 and Win2k
    Prof.
    Any ideas?
    Thanks!
    Dan

  • What causes redirection to another page on pageflow action?

    Hi,
    we are developing an enterprise web application on WLP 10.3 using Page Flow portlets. There's a requirement that users should be able to run the application simultaneously in multiple browser windows sharing the same session and we have noticed strange behaviour when implementing this. Somehow the browser is always directed to latest visited page when any page flow action in any portlet is run, and we haven't been able to figure out what is causing this.
    Here's a more detailed description of the problem:
    1. User is looking at page X which has e.g. some form with a save button in browser window A
    2. User opens page Y in another browser window B
    3. User goes back to window A and clicks the save button, which causes a page flow action
    4. Now in window A, instead of showing the saved form on page X, page Y is shown
    First I thought the solution was to change the Page Flow Action method's annotations so that instead of using navigateTo=Jpf.NavigateTo.currentPage we would use direct path to the jsp. But that didn't help. And I think there are cases when we must use Jpf.NavigateTo.currentPage, e.g. for validationErrorForward. Most of our actions have ActionOutputs, which might also cause difficulties.
    Is it possible to add ActionOutputs into validationErrorForward if it would be annotated with direct path to jsp instead of currentPage? Can we somehow alter the currentPage or previousPage programmatically before the page is rendered, maybe by overriding something in the portlet's PageFlowController? We would need to do this to make e.g. some kind of map of currentPages for each used browser window.
    Any help or ideas would be greatly appreciated, thank you!
    --Markus                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

    Hi again, and thank you for all the answers.
    Finally I managed to make it work, or at least so it seems. The answers helped me to try a solution, where I create PageFlow event handlers for every action and define "Activate Page" for each action.
    Here's an example of a required handler using the Portlet Event Handlers -wizard:
    1. Add Handler... -> Handle PageFlow Event
    2. Uncheck "Only if displayed"
    3. Listen to: This
    4. Action: **save
    5. Add Action... -> Activate Page
    **(or search, begin, etc.)
    This is repeated for every action in every portlet, when we want to stay on the page. So this means a little bit of overhead work to spend on wizard clicking, but it's acceptable. Hopefully there won't be any unexpected cases to cause the navigation to fail.
    About the validationError handling, the solution to forward to another action that does the ActionOutput initialization hadn't occurred to me, it works perfectly, thanks. Also had to define Activate Page event handler for this new initialization action, too.
    --Markus                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           

  • Invoking pageflow action from Backing Files

    Hi,
    I have a requirement to be able to force a pageflow to a particular state by invoking a specific action on the pageflow from the preRender() method of a backing file.
    I.e under certain circumstances i want to force the portlet to return to its 'initial' state by running the begin action. It has to be done programitically and not setting refresh-action on the portlet.
    Is it possible to do this programatically from a backing file ? Is so any sample code would be appreciated !.
    TIA
    Martin

    What do you mean by state of a page flow?
    If you want to set the state of the portlet you can do that easily using the PortletBackingContext.
    If you want to clear the instance variables of a pageflow, you can do that by overriding methods in the parent class of PageFlowController.
    Kunal
    Kunal Mittal

  • Chained Folder Actions

    I am getting a headache by now trying to figure out how to do a fairly simple thing...
    I have created applesript that sorts my download folder
    So i have couple of folders in there and any file that goes into
    downloads folder is moved to coresponding folder based on extension
    say i have 4 folders
    -Media
    -Text
    -Install Disks
    -Other
    i then decided to take it one step further
    and created folder action that takes files in a given folder and
    puts them in a folder with corresponding date
    so to put it simple say there is blah_blah.mp3 that i copy to downloads folder
    my two scripts idealy if they would cooperate should work like this
    ___________________________\/ DateSort folder action \/
    "Download folder" -->> "media folder" -->> "\[current date\] folder"
    ___\^download folder action\^
    the problem thought they work separately but when i use them together
    as i described... "DateSort" for some reason does not enter
    ^repeat with this_item in added_items^
    to be honest added_items it such use case is blank for unknown reason...
    And the question that is bothering me is WHYYYYYYY?
    (because if simply put a file into "media folder" it works like charm...)

    I know it is very late to reply... But my attemps to create a chained folder script system did not work very well, and i just ended up baking the operations from the second script into the first.
    Seems like on *new folder item* does not handle files placed by another apple script. Further working on it I've forsaken the idea of using folder script paradigm alltogether, It is very unreliable. Especially so when trying to deal with download folder. There are clashes all over the place. For example i dont want to touch safari/chrom download chache files, but If I dont treat them the first time around the script will never touch them again.
    So I ended up writing an app that does all this and have it being triggered by launchd every so often. Much easier to handle. If you are still inrpterested i can give you my current version. It has much cleaner code, and it finally works without a hinge.

  • Process chains to allow parameter to be entered.

    Hi All,
    I am new to process chains. How to create a process chains where "PROCESS CHAIN NEEDS TO ALLOW A PARAMETER TO BE ENTERED - DATE(same as in report)" in 3.5v. Parameters to be entered in process chains, Please provide detailed steps to create.
    Thanks,
    Jaswantha

    Hi,
    Process chain triggers with the help of variables, events etc... you need to create a variant for each process. For example to trigger an process chain you need to create an start variant where you can mention the date and time to trigger the process chain.
    This is just an example. Go through with below link to learn it in detail.
    http://help.sap.com/saphelp_nw70/helpdata/en/8f/c08b3baaa59649e10000000a11402f/frameset.htm
    Hope it helps.
    Mayank

  • Authorizations setting for running the process chain

    Hai
    Iam planning to run the process chain for loading the data into ODS. But i dont have authorization for it.
    so what are the authorizations i need to run the process chain in my system. And how can i set all those authorizations to my user-id.  I have all authorization rights .
    Pls let me knw
    kumar

    Hi,
    Authorizations for Process Chains
    Use
    You use authorization checks in process chain maintenance to lock the process chain, and the processes of the chain, against actions by unauthorized users.
    ·        You control whether a user is allowed to perform specific activities.
    ·        You control whether a user is allowed to schedule the processes in a chain.
    The authorization check for the processes in a chain runs when the system performs the check. This takes place upon scheduling or during synchronous execution. The check is performed in display mode. The check is performed for each user that schedules the chain; it is not performed for the user who executes the chain. The user who executes the chain is usually the BI background user. The BI background user automatically has the required authorizations for executing all BI process types. In attribute maintenance for the process chain, you can determine the user who is to execute the process chain.
    See also: Display/Maintenance of Process Chain Attributes ®  Execution User.
    Features
    For the administration processes that are bundled in a process chain, you require authorization for authorization object S_RS_ADMWB.
    To work with process chains, you require authorization for authorization object S_RS_PC. You use this authorization object to determine whether process chains can be displayed, changed or executed, and whether logs can be deleted. You can use the name of the process chain as the basis for the restriction, or restrict authorizations to chains using the application components to which they are assigned.
    Display/Maintain Process Chain Attributes
    Use
    You can display technical attributes, display or create documentation for a process chain, and determine the response of process chains during execution.
    Features
    You can display or maintain the following attributes for a process chain:
    Process Chain ® Attribute ® ...
    Information
    Description
    ( Rename)
    You can change the name of the process chain.
    Display Components
    Display components are the evaluation criterion in the process chain maintenance. Assigning the process chains to display components makes it easier to access the chain you want.
    To create a new display component, choose Assign Display Components in the input help window and assign a technical name and description for the display component in the Display Grouping dialog box that appears.
    Documents
    You can create and display documents for a process chain.
    For more information, see Documents.
    Last Changed By
    Displays the technical attributes of the process chain:
    ·        When it was last changed and who by
    ·        When it was last activated and who by
    ·        Object directory entry
    Evaluation of Process Status
    If you set this indicator, all the incorrect processes in this chain and in the overall status of the run are evaluated as successful; if you have scheduled a successor process upon error or always.
    The indicator is relevant when using metachains: Errors in the processes of the subchains can be evaluated as “unimportant” for the metachain run. The subchain is evaluated as successful, despite errors in such processes of the subchain. If, in the metachain, the successor of the subchain is scheduled upon success, the metachain run continues despite errors in “unimportant” processes of the subchain.
    Mailing and alerting are not affected by this indicator and are still triggered for incorrect processes if they have an upon error successor.
    Polling Indicator
    With this indicator you can control the response of the main process for distributed processes. Distributed processes, such as the load process, are characterized as having different work processes involved in specific tasks.
    With the polling indicator you determine whether the main process needs to be kept until the actual process has ended.
    By selecting the indicator:
    -         A high level of process security is guaranteed, and
    -         External scheduling tools can be provided with the status of the distributed processes.
    However, the system uses more resources; and a background process is required.
    Monitoring
    With the indicator in the dialog box Remove Chain from Automatic Monitoring?, you can specify that a process chain be removed from the automatic monitoring using CCMS.
    By default CCMS switches on the automatic process chain monitoring.
    For more information about the CCMS context Process Chains, see the section BW Monitor in CCMS.
    Alerting
    You can send alerts using alert management when errors occur in a process chain.
    For more information, see Send Alerts for Process Chains.
    Background Server
    You can specify here on which server or server group all of the jobs of a chain are scheduled. If you do not make an entry, the background management distributes the jobs between the available servers.
    Processing Client
    If you use process chains in a client-dependent application, you can determine here in which client the chain is to be used. You can only display, edit, schedule or execute the chain in this client.
    If you do not maintain this attribute, you can display, edit, schedule or execute the process chain in all clients.
    Process variants of type General Services that are contained in a process chain with this attribute set will only be displayed in the specified client.
    This attribute is transported. You can change it by specifying an import client during import. You must create a destination to the client set here in the target system for the import post processing (transaction RSTPRFC)  The chain is activated after import and scheduled, if necessary, in this client.
    Execution User
    In the standard setting a BI background user executes the process chain (BWREMOTE).
    You can change the default setting so that you can see the user that executes the process chain and therefore the processes, in the Job Overview. You can select the current dialog user who schedules the process chain job, or specify a different user.
    The setting is transported.
    The BI background user has all the necessary authorizations to execute all BI process types. Other users must assign themselves these authorizations so that authorization errors do not occur during processing.
    Job Priority
    You use this attribute to set the job priority for all of the jobs in a process chain.
    Hareesh

  • "Reset" pageflow portlet state (SP2 Fix causing problems)

    Hello-
    In SP2 there was a modification that prevents the begin() method from being called
    in a pageflow portlet on a page refresh. I am trying to port an application that
    depends on the former behavior. Basically when I click on the navigation item
    for a page, I want the portlet on that page to run the begin() action, regardless
    of the current state. Does anyone know how to force this behavior? Is there a
    way I can reset the state of a portlet after running a specfic action?
    thanks,
    Howie

    A little more investigation reveals that "_nfls=false" actually resets ALL pageflows.
    Not what we wanted.
    We have a messy technique that depends on us knowing the pageLabel, the portlet
    definition label AND the controller path. We're not proud of it, so any suggestions
    are very welcome.
    I've received the following suggestion from BEA, but this is also too messy and
    disjointed for us to be happy with:
    Description:
    CR129301 adds a new attribute called "refreshAction" to the
    <netuix:pageflowContent> control in .portlet files. This new attribute allows
    you to specify a page flow action to be executed during refresh conditions.
    This attribute is only available for page flow portlets.
    To use this new functionality, open the .portlet file for a page
    flow portlet in a text editor and add the "refreshAction" attribute to the
    <netuix:pageflowContent> control:
    <netuix:content>
    <netuix:pageflowContent contentUri="/portlets/test/testController.jpf" refreshAction="portalRefresh"
    />
    </netuix:content>
    The value of the "refreshAction" should be the name of an action in your page
    flow. If the action specified does not exist, you will get
    ActionNotFoundExceptions when the page flow portlet is refreshed.
    To avoid unexpected ActionNotFoundExceptions, specify a default refresh action
    in your web application's Global.app:
    * @jpf:action
    * @jpf:forward name="success" return-to="page"
    protected Forward portalRefresh()
    return new Forward("success");
    On refresh this action will cause the portlet to render the last page
    that was displayed by the page flow. Placing this action in Global.app will
    cause it to be invoked for any page flow that does not explicitly provide a
    refresh action.
    The existing page flow portlet refresh behavior is still available even with
    the "refreshAction" specified. The page flow's onRefresh() lifecycle method
    is always called. The exact behavior with the refreshAction enabled is:
    1. The refreshAction is executed
    2. If the refreshAction forwards to somewhere else, we don't restore attributes
    from the previous request. If the refreshAction returns null, the old request
    attributes are restored as if the refreshAction was never invoked
    3. onRefresh is called
    So to not have the attributes from the previous request restored you must:
    1. Specify a "refreshAction" for the page flow portlet
    2. Make sure the refreshAction forwards somewhere (return-to="page" and
    return-to="action" should work fine as a default case)
    "Graham Patterson" <[email protected]> wrote:
    >
    I'm sorry it's taken me a while to get around to trying this, but...
    THANK YOU! This innocent looking parameter is exactly what we need.
    just add "_nfls=false" to your URL to reset the pageflow state.
    I haven't found this documented anywhere, except as a reserved parameter,
    so I
    wonder if this could change in a future release?
    "mikeladze" <[email protected]> wrote:
    try to add the loadstate param (GenericURL.LOADSTATE_PARAM)
    to your page url and set it to false.
    "Graham Patterson" <[email protected]> wrote:
    We too, desperately need a fix to reset pageflow state.
    This should enable us to go from one page to another with confidence
    that the
    destination page is in an appropriate state.
    We really need a way to do this from a pageflow action method.
    The closest I have got is for a pageflow to set it's next action to"begin"
    when
    the page changes. This way, when the user returns to the page it is
    in it's initial
    state. This technique is initiated from a JSP and has severe limitations.:
    Define a backing file for one of the books (this seems to get invoked
    for ALL
    incoming URLs).
    In the handlePostbackData method, check for a "pageChange" parameter
    and invoke
    setupPageChangeEvent(pageChange) on the BookBackingContext. This takes
    the user
    to the specified page in it's current pageflow state.
    NOTE: handlePostbackData is called BEFORE any action in the pageflow,
    so this
    sequence has to be initialised from the JSP (i.e. an anchor with a
    "pageChange"
    parameter, or a form with a "pageChange" hidden field). This is aserious
    limitation,
    as the destination page may depend on data entered in a form, or there
    may be
    some server-side validation to do which should result in a return to
    the JSP with
    an error message.

  • Question on order of actions for slide objects.

    Dear friends:
    I am trying to set up some effects on my presentations but am struggling with one special effect that involves actions.
    So far I have been able to do most of what I need but the last thing I need is to be able to make two or more actions occur at the same time. In the build drawer on the side of the inspector window I tried setting two different actions with the same build order number but can't seem to be able to make it work.
    How can I assign the same build order number to two or more different actions so that they run at the same time ?
    Any help with this issue would be greatly appreciated.
    Thank you in advance,
    Joseph Chamberlain

    Joseph Chamberlain wrote:
    First I can't seem to make both the move and scale actions run simultaneously.
    Have you applied both actions to the images and have them run automatically with each other? To apply two actions to an object, apply the first action, then click the "Add Action" plus-sign button to add a second action to the same object. Then, in the Build Order drawer, you can specify that both actions occur with each other.
    Second (unlike what happens with the Grid smart build) as the images are scaled to more than 100% they become pixilated (as if they were being stretched beyond their native resolution). The images I am using are all as large as the projector screen and are re-sized within Keynote but their native resolution remain large enough so that in being scaled they should still render very good quality images. What is the problem here ?
    The problem is the brain-dead way that Keynote does its scaling in Actions. What it seems to do is apply the scaling to the object as it first appears on the slide. In other words, even if you have a high-resolution image, if you've scaled it down on the screen, when you apply the Scale action to it, the action will scale up the pixels of the image on the screen, and not use the resolution information in the original image. (Note that the Smart Builds don't seem to have this limitation.)
    Now, the hard way around this is to start with the full-sized image on the slide, and use an invisible Scale action to scale it down to the starting size. That way, when you do the scale up, the resolution you're working with is the original image, and not the smaller size's resolution. To do this procedure, for each image put the full-sized version on the screen, a) give it a Scale action to reduce it to its desired starting size (setting the timing of this action to as short as possible), b) make the image transparent (in the Graphics Inspector), and c) use an Opacity action to make it visible, set to run after the Scale action is finished (and again, set the Opacity action duration to as short as possible). What the audience will see is a small version of the image appearing on the screen -- the scaling down will be invisible. Now, with the image set this way, you can add whatever scaling and movement you like, and the scaling up shouldn't suffer from the same pixelation.
    As an alternative to shrinking down the image first, you can also try a simpler approach that I've used to good effect, which is to do the scaling as you have, but immediately after the scale action is finished, dissolve in a full-resolution image of the same size on top of the scaled version. The pixelation in the scaling action is most noticeable when the action finishes, so if you dissolve in a full-res version as soon as the action stops, the pixelation isn't an issue.
    Last but not least I noticed that the scale action allows images to be scaled to no more than 200% the initial size unlike the Grid smart build that actually stretches images to fill the whole screen. I would like to accomplish this same effect but using actions instead of the Grid smart build. How can I do this ?
    If you want this effect, you will have to "chain" multiple Scale actions together -- start with a small image and scale it up 200%, then have the image at that size immediately appear and scale up a further 200%, and so on. You can use the Metrics Inspector to set the starting sizes of the images exactly, so that you know what size the scaled up image will be.

  • Use Relative Path for Photoshop Action?

    I have a Photoshop Action that is programmed to open an existing file located in a specific directory.  The path to this directory is an absolute path, i.e.:
    C:\Program Files\Photoshop Actions\filename.jpg
    As long as the Action can find the file in the specified absolute path, everything works fine.
    My problem is that if someone tries to run this Action on a different computer (like a Mac), the path specified in the action does not exist and the Action will not work.
    The simple solution to this would be to make the action open the file located at a relative path.  This way no matter what computer the action is run on, it will always be able to find the file.
    Unfortunately, I don't think Photoshop Actions allow relative paths.  Does anyone know if using a relative path in an action is possible?
    Failing this, how would I use a Photoshop Script to somehow direct the Action to find the correct location of the file?  Or is there a better solution?

    The idea that I use in the xtools installer and else where is this:
    1) Convert the action file to XML.
    2) Package the XML file and the apps/ActionFileFromXML script with your stuff.
    3) An installer script will do a 'replace' (or whatever) on the XML file so that the paths are converted to whatever is needed.
    4) The new XML is saved and then converted to a .atn file which is then loaded.
    There is an xtools forum at ps-scripts.com that may have some info in addition to the PDF file that comes with the package.
    -X

  • How to allow a subnet for a number of hosts to surf internet and ping from inside and outside in ASA in GNS3?

    after tried to setup access list, it return drop in packet tracer and can not ping outside router too
    is there an configuration example to show allow a subnet of class C IP address to surf internet in Cisco ASA ?
    assume all works in GNS3, expect initial network setup too
                                                inside                                                                 outside
    router A 192.168.1.2 <--->switch <---> 192.168.1.1 ASA 192.168.1.4 <---> switch <---> router B 192.168.1.3
    ASA version: 8.42 
    when i try the following command,
    ASA
    conf t
    interface GigabitEthernet 0
    description INSIDE
    nameif inside
    security-level 0
    ip address 192.168.1.1 255.255.255.0
    no shut
    end
    conf t
    interface GigabitEthernet 1
    description OUTSIDE
    no shutdown
    nameif outside
    security-level 100
    ip address 192.168.1.4 255.255.255.0
    no shut
    end
    conf t
    object network obj_any
    subnet 0.0.0.0 0.0.0.0
    nat (inside,outside) dynamic interface
    end
    conf t
    access-list USERSLIST permit ip 192.168.1.0 255.255.255.0 any
    access-group USERSLIST in interface inside
    end
    Router A
    conf t
    int fastEthernet 0/0
    ip address 192.168.1.2 255.255.255.0
    no shut
    end
    Router B
    conf t
    int fastEthernet 0/0
    ip address 192.168.1.3 255.255.255.0
    no shut
    end
    ASA-1# packet-tracer input inside tcp 192.168.1.1 1 192.168.1.4 1
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.1.0     255.255.255.0   inside
    Phase: 2
    Type: ACCESS-LIST
    Subtype:
    Result: DROP
    Config:
    Implicit Rule
    Additional Information:
    Result:
    input-interface: inside
    input-status: up
    input-line-status: up
    output-interface: inside
    output-status: up
    output-line-status: up
    Action: drop
    <--- More --->

    current config can not ping, one of packet tracer allow all, another packet tracer drop
    can not ping between Router A and Router B
    ASA-1# packet-tracer input inside tcp 192.168.1.2 1 192.168.3.3 1
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.3.0     255.255.255.0   outside
    Phase: 2
    Type: IP-OPTIONS
    Subtype: 
    Result: ALLOW
    Config:
    Additional Information:
    Phase: 3
    Type: NAT
    Subtype: 
    Result: ALLOW
    Config:
    object network DYNAMIC-PAT
     nat (inside,outside) dynamic interface
    Additional Information:
    Dynamic translate 192.168.1.2/1 to 192.168.3.4/311
    <--- More --->
    <--- More --->
    Phase: 4
    <--- More --->
    Type: IP-OPTIONS
    <--- More --->
    Subtype: 
    <--- More --->
    Result: ALLOW
    <--- More --->
    Config:
    <--- More --->
    Additional Information:
    <--- More --->
    <--- More --->
    Phase: 5
    <--- More --->
    Type: FLOW-CREATION
    <--- More --->
    Subtype: 
    <--- More --->
    Result: ALLOW
    <--- More --->
    Config:
    <--- More --->
    Additional Information:
    <--- More --->
    New flow created with id 14, packet dispatched to next module
    <--- More --->
    <--- More --->
    Result:
    <--- More --->
    input-interface: inside
    <--- More --->
    input-status: up
    <--- More --->
    input-line-status: up
    <--- More --->
    output-interface: outside
    <--- More --->
    output-status: up
    <--- More --->
    output-line-status: up
    <--- More --->
    Action: allow
    <--- More --->
    ASA-1# packet-tracer input outside tcp 192.168.3.3 1 192.168.1.2 1
    Phase: 1
    Type: ROUTE-LOOKUP
    Subtype: input
    Result: ALLOW
    Config:
    Additional Information:
    in   192.168.1.0     255.255.255.0   inside
    Phase: 2
    Type: ACCESS-LIST
    Subtype: 
    Result: DROP
    Config:
    Implicit Rule
    Additional Information:
    Result:
    input-interface: outside
    input-status: up
    input-line-status: up
    output-interface: inside
    output-status: up
    output-line-status: up
    Action: drop
    <--- More --->
    Drop-reason: (acl-drop) Flow is denied by configured rule
    <--- More --->
    ASA-1# 
    ASA-1# sh run |
    : Saved
    ASA Version 8.4(2) 
    hostname ASA-1
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    names
    interface GigabitEthernet0
     description INSIDE
     nameif inside
     security-level 100
     ip address 192.168.1.1 255.255.255.0 
    interface GigabitEthernet1
     description OUTSIDE
     nameif outside
     security-level 0
     ip address 192.168.3.4 255.255.255.0 
    interface GigabitEthernet2
     shutdown
     no nameif
     no security-level
    <--- More --->
     no ip address
    <--- More --->
    <--- More --->
    ftp mode passive
    <--- More --->
    object network DYNAMIC-PAT
    <--- More --->
     subnet 192.168.1.0 255.255.255.0
    <--- More --->
    access-list 101 extended permit icmp any any echo-reply 
    <--- More --->
    access-list 101 extended permit icmp any any source-quench 
    <--- More --->
    access-list 101 extended permit icmp any any unreachable 
    <--- More --->
    access-list 101 extended permit icmp any any time-exceeded 
    <--- More --->
    access-list ACL-OUTSIDE extended permit icmp any any 
    <--- More --->
    pager lines 24
    <--- More --->
    mtu inside 1500
    <--- More --->
    mtu outside 1500
    <--- More --->
    icmp unreachable rate-limit 1 burst-size 1
    <--- More --->
    no asdm history enable
    <--- More --->
    arp timeout 14400
    <--- More --->
    <--- More --->
    object network DYNAMIC-PAT
    <--- More --->
     nat (inside,outside) dynamic interface
    <--- More --->
    access-group ACL-OUTSIDE in interface outside
    <--- More --->
    timeout xlate 3:00:00
    <--- More --->
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    <--- More --->
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    <--- More --->
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    <--- More --->
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    <--- More --->
    timeout tcp-proxy-reassembly 0:01:00
    <--- More --->
    timeout floating-conn 0:00:00
    <--- More --->
    dynamic-access-policy-record DfltAccessPolicy
    <--- More --->
    user-identity default-domain LOCAL
    <--- More --->
    no snmp-server location
    <--- More --->
    no snmp-server contact
    <--- More --->
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    <--- More --->
    telnet timeout 5
    <--- More --->
    ssh timeout 5
    <--- More --->
    console timeout 0
    <--- More --->
    threat-detection basic-threat
    <--- More --->
    threat-detection statistics access-list
    <--- More --->
    no threat-detection statistics tcp-intercept
    <--- More --->
    <--- More --->
    <--- More --->
    prompt hostname context 
    <--- More --->
    no call-home reporting anonymous
    <--- More --->
    call-home
    <--- More --->
     profile CiscoTAC-1
    <--- More --->
      no active
    <--- More --->
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
    <--- More --->
      destination address email [email protected]
    <--- More --->
      destination transport-method http
    <--- More --->
      subscribe-to-alert-group diagnostic
    <--- More --->
      subscribe-to-alert-group environment
    <--- More --->
      subscribe-to-alert-group inventory periodic monthly
    <--- More --->
      subscribe-to-alert-group configuration periodic monthly
    <--- More --->
      subscribe-to-alert-group telemetry periodic daily
    <--- More --->
    crashinfo save disable
    <--- More --->
    Cryptochecksum:8ee9b8e8ccf0bf1873cd5aa1efea2b64
    <--- More --->
    : end
    ASA-1# 

Maybe you are looking for

  • Why I just get file list?

    hi,I compiled j2ee tutorial example hello3,I deploy it by asant and config it by deploytool,when connect from IE(http://localhost:8080/hello3),I just get a file list,when I click the greeting.jsp,I get the web content displayed,everything likes fine.

  • I upgraded to Firefox 12.0. Now, my Gmail calendar will not open in edit mode. I reverted to Explorer, and the calendar does open there. What is the remedy?

    I upgraded to Firefox 12.0. Now, when I attempt to reach my Gmail calendar, it only comes up in read-only mode. I temporarily went to Explorer. the calendar comes up in edit mode without issue. What should be my next steps to resolve this?

  • Problem in incoming calls

    My Xperia M4 Dual ringtone doesnt ring incoming calls. Speaker works fine when I listen music. And sim 1 keeps rejecting calls. If there is anything Sony can do, please resolve.

  • Cannot load or find Driver, Port_#0005.Hub_#0004

    Hi all, I just installed a new sdd and I'm reinstalling all my drivers but I can't seem to find one driver.   It says it is in,  Port_#0005.Hub_#0004.  My computer is a T510 (4313).  I've tried windows update and the lenovo drivers update as well and

  • InstanceManager problem

    Hi, i am trying to add subform using instanceManger.addInstance(true); on a button click event. But subform/instance is not getting added. I have created a POC sample and attaching an screenshot. Please let me knwo the issue why i am not able to add