JComboBox is half international

combo = new JComboBox();
combo.setComponentOrientation(ComponentOrientation.RIGHT_TO_LEFT);
this only sets the scrollbars on the left side.The elements in the
combo are still on the left side which should have been on the
right side.
I guess , as JComboBox consists of JButton,JScrollPane,JList(which
uses JTextField),the above code has only effect till JScrollPane
and JButton and does not reach JTextField.
does any one know how to solve this problem.
i will be very thankful to him.....

I was looking at the same thing and found I had to set the orientation for the renderer by doing the following:
((BasicComboBoxRenderer)combo.getRenderer()).applyComponentOrientation(ComponentOrientation.RIGHT_TO_LEFT);

Similar Messages

  • Half internal hard drive half external

    i buy alot of movies but do not have enough room on my internal to hold them all so i hold it in a tb external harddrive. is there anyway to have one itunes lib list and combine what i have on my external with my internal and not have the movies there when i do not have my harddrive plugged in? or do i need to continue using two different lib list for my itunes? one lib list for external one for internal.

    By default Time Machine will not back up all files, i.e. temp file, cache, and system files. Also you can set Time Machine to exclude some folders/files, take a look at this link for more information.  http://pondini.org/TM/11.html

  • Modal Internal Frames and JCombos

    Hi,
    I'm trying to create a modal internal frame as suggested in Sun's TechTip:
    http://developer.java.sun.com/developer/JDCTechTips/2001/tt1220.html
    All I need is to block the input for the rest of the GUI, I don't care about real modality (the setVisible() call returns immediately).
    I need to have a JComboBox in my internal frame. It turns out that under JDK1.4.0/1.4.1 the list for the combo is visible only with the Windows Look And Feel, while in every other JDK version it's not visible, except for the portion falling out of the internal frame.
    The code to verify this follows. Does anybody know how to fix this? I've opened a bug for it, but I was wondering if someone can help in the forum...
    Run the application passing "Windows" or "CDE/Motif", click on "open" and play with the combo to observe the result.
    import java.awt.*;
    import java.awt.event.*;
    import javax.swing.*;
    import javax.swing.event.*;
    public class Modal {
    static class ModalAdapter
    extends InternalFrameAdapter {
    Component glass;
    public ModalAdapter(Component glass) {
    this.glass = glass;
    // Associate dummy mouse listeners
    // Otherwise mouse events pass through
    MouseInputAdapter adapter =
    new MouseInputAdapter(){};
    glass.addMouseListener(adapter);
    glass.addMouseMotionListener(adapter);
    public void internalFrameClosed(
    InternalFrameEvent e) {
    glass.setVisible(false);
    public static void main(String args[]) {
    System.out.println("Installed lookAndFeels:");
    UIManager.LookAndFeelInfo[] lafInfo = UIManager.getInstalledLookAndFeels();
    for(int i=0; i<lafInfo.length; i++) {
    System.out.println(lafInfo.getName());
    String lookAndFeel = null;
    if (args.length>0)
    lookAndFeel = args[0];
    initLookAndFeel(lookAndFeel);
    final JFrame frame = new JFrame(
    "Modal Internal Frame");
    frame.setDefaultCloseOperation(
    JFrame.EXIT_ON_CLOSE);
    final JDesktopPane desktop = new JDesktopPane();
    ActionListener showModal =
    new ActionListener() {
    public void actionPerformed(ActionEvent e) {
    // Manually construct a message frame popup
    JOptionPane optionPane = new JOptionPane();
    optionPane.setMessage("Hello, World");
    optionPane.setMessageType(
    JOptionPane.INFORMATION_MESSAGE);
    // JInternalFrame modal = optionPane.
    // createInternalFrame(desktop, "Modal");
                        JInternalFrame modal = new JInternalFrame("test", true, true, true);
    JPanel jp = (JPanel )modal.getContentPane();
              JComboBox jcb = new JComboBox(new String[]{"choice a", "choice b"});
    jp.setLayout(new BorderLayout());
              jp.add(jcb,BorderLayout.NORTH);
              jp.add(new JTextArea(),BorderLayout.CENTER);
    // create opaque glass pane
    JPanel glass = new JPanel();
    glass.setOpaque(false);
    // Attach modal behavior to frame
    modal.addInternalFrameListener(
    new ModalAdapter(glass));
    // Add modal internal frame to glass pane
    glass.add(modal);
    // Change glass pane to our panel
    frame.setGlassPane(glass);
    // Show glass pane, then modal dialog
    modal.setVisible(true);
    glass.setVisible(true);
    System.out.println("Returns immediately");
    JInternalFrame internal =
    new JInternalFrame("Opener");
    desktop.add(internal);
    JButton button = new JButton("Open");
    button.addActionListener(showModal);
    Container iContent = internal.getContentPane();
    iContent.add(button, BorderLayout.CENTER);
    internal.setBounds(25, 25, 200, 100);
    internal.setVisible(true);
    Container content = frame.getContentPane();
    content.add(desktop, BorderLayout.CENTER);
    frame.setSize(500, 300);
    frame.setVisible(true);
    private static void initLookAndFeel(String lookAndFeel) {
    String lookAndFeelClassName = null;
    UIManager.LookAndFeelInfo[] lafInfo = UIManager.getInstalledLookAndFeels();
    for(int i=0; i<lafInfo.length; i++) {
    if (lafInfo[i].getName().equals(lookAndFeel)) {
    lookAndFeelClassName = lafInfo[i].getClassName();
    if (lookAndFeelClassName == null)
    System.err.println("No class found for lookAndFeel: "+ lookAndFeel);
    try {
    UIManager.setLookAndFeel(lookAndFeelClassName);
    } catch (ClassNotFoundException e) {
    System.err.println("Couldn't find class for specified look and feel:"
    + lookAndFeel);
    System.err.println("Did you include the L&F library in the class path?");
    System.err.println("Using the default look and feel.");
    } catch (UnsupportedLookAndFeelException e) {
    System.err.println("Can't use the specified look and feel ("
    + lookAndFeel
    + ") on this platform.");
    System.err.println("Using the default look and feel.");
    } catch (Exception e) {
    System.err.println("Couldn't get specified look and feel ("
    + lookAndFeel
    + "), for some reason.");
    System.err.println("Using the default look and feel.");
    e.printStackTrace();

    Hi,
    Had exactly the same problem. Seems there are plenty of similar problems all related to the glass pane, so have solved the problem here by putting the event-blocking panel onto the MODAL_LAYER of the layered pane, rather than replacing the glass pane. Otherwise pretty much the same technique - you may need a property change listener to track changes in the size of the layered pane
    something like ...
    layer = frame.getLayeredPane();
    glass.setSize (layer.getSize()); // will need to track size
    glass.add (modal);
    layer.add(glass, JLayeredPane.MODAL_LAYER, 0);
    I've modified the original examples so the frames can be re-used so you may have to play around with the example a bit
    Hope it helps
    cheers.

  • Accessibility of JComboBox problem

    Hi everyone!
    I've got two applications. One of them make changes in the components of the other one through the Accessibility API. (Both are running on the same VM)
    I make changes without problem in JButton, JTextComponent...
    But I've got a JComboBox with 4 options, and the "reader/writer" application has to select the third option, and I can't get a way to do this with Accessibility.
    I can see the JComboBox and its internal structure (a Viewport, a BasicPopUp, a JPanel, ScrollButtons, a ComboList, and the four options).
    The only available action is in the JComboBox and is the togglePopUp that toggles it without problem.
    But I can't get a way to select one of the options of the toggled up pop up.
    Does anybody has an example code for doing this?
    Thank you a lot!
    AC

    Works fine for me.
    If you need further help then you will need to provide [url http://www.physci.org/codes/sscce.jsp]Simple Demo Code that demonstrates the problem.

  • JOptionPane doesn't close

    Hi,
    I've a problem with a JOptionPane.
    This is my code:
    public class myFrame extends JInternalFrame {
       private JInternalFrame parent = null;
       public myFrame(){
          parent = this;
       jComboBox().addItemListener(new java.awt.event.ItemListener() {
                   public void itemStateChanged(java.awt.event.ItemEvent e) {
                               Object[] obj = {"MyQuestion?"};
                                int result = JOptionPane.showInternalConfirmDialog(parent, obj,
                                                      "Question",0,3);
                               if(result == 0){
    }The problem is When I change the state of the jComboBox component, the internal confirm dialog appears;
    but when I click on the "Yes" option (or on the "No" one), nothing happen;
    the confirm dialog hangs and I cannot do anything more, only stop the process.
    I've used, in the same program, in the same way, an internal confirm Dialog on an Action Event, and it works fine.
    Any ideas?
    Thank you in advance
    MargNat

    HI,
    now I'm partially solved the problem;
    That is:
    I've noticed if I cancel, in my prog, the listener jInternalFrame_Activated, the internal confirm dialog works, but not fine.
    Infact, when the event happen, it appears;
    then if I click yes, it disappear and all works fine;
    if I click No, it doesn't close; but if I click again on No, it close.
    I think it run twice the itemStateChanged relative code, but I don't know why.
    It seems the jComboBox is focused twice when I click twice on "No" option.
    Ideas?
    Thank you in advance
    MargNat

  • Problem installating Snow Leopard on old Macbook Pro with Intel Core 2 Duo. After creating partition on internal hard disk (Extended Journaled), installation starts but stops at half of the progress bar. Screen asking Restart appears.

    Hello:
    I have tried installing Snow Leopard via the installation disc on a Macbook Pro (2007) with an Intel Core 2 Duo, but I the installation has failed more than 5 times.
    I have first formatted and partitioned the internal hard disk with Mac Os Extended Journal format.
    Once the installation starts, it starts without a problem unti lthe progress bar gest until half completed then a screen asking for a Computer Restart shows up.
    It asks to press the power button for some time until it the computer shuts down and then, press again to turn it on.
    Once turned on, the installation disc gets readed, the installation screen appears again and asks again to start the whole installation process form the beginning.

    Then you have a Hardware Problem.
    Your system is Crashing part way through the install and Re-Booting because of the crash.
    Could be the drive itself or it could be some other hardware part in your system. Like the RAM.
    To check if it is the internal drive connect an External drive to the system by USB and do the install on that external. If the install completes then it more then likely the drive is bad. If it crashes again then it is more then likely some other piece of hardware in your system.

  • TS1967 My computer failed and the main drive had to be formatted but all my music was on a separate internal hard drive. So I downloaded the latest iTunes , problem is it has found all my songs but seems to not recognize half of the album data, half of th

    My computer failed and the main drive had to be formatted but all my music was on a separate internal hard drive. So I downloaded the latest iTunes , problem is it has found all my songs but seems to not recognize half of the album data, half of the artists, all of the dates and all ratings data.
    I had a large part of it backed up on DVD's but it does not want to recognise them either?
    Any tips?

    Hey briannagrace96,
    Welcome to Apple Support Communities! I'd check out the following article, it looks like it applies to your situation:
    iPod: Appears in Windows but not in iTunes
    http://support.apple.com/kb/ts1363
    You'll want to go through the following troubleshooting steps, and for more detail on each step follow the link to the article above:
    Try the iPod troubleshooting assistant:
    If you have not already done so, try the steps in the iPod Troubleshooting Assistant (choose your iPod model from the list).
    If the issue remains after following your iPod's troubleshooting assistant, follow the steps below to continue troubleshooting your issue.
    Restart the iPod Service
    Restart the Apple Mobile Device Service
    Empty your Temp directory and restart
    Verify that the Apple Mobile Device USB Driver is installed
    Change your iPod's drive letter
    Remove and reinstall iTunes
    Disable conflicting System Services and Startup Items
    Update, Reconfigure, Disable, or Remove Security Software
    Deleting damaged or incorrect registry keys
    Take care,
    David

  • JComboBox: how to capture the internal list  events?

    Hi
    Does anybody know how to capture JComboBox internal list events, what I mean
    is when I click the box arrow button a list of the items pops up and as you move the mouse inside that list up and down, an items gets highlighted.
    So I am interested in capturing those events - basically when the next item from the list is highlighted.
    Thanks

    You can add an item listener to the combo box for that. IIRC, your listener will get
    notified twice: once for the deselection of the previous item, and once for the new
    item's selection.
    : jay

  • SSRS Maps - Display data that crosses international dateline without spanning half the world

    G'day,
    I'm hoping someone here can help me out - I've tried a bunch of thing and can't seem to crack this one.
    Basically I have a collection of position data (w.r.t. WGS84) provided by an aircraft local to my area (Auckland, New Zealand). Occasionally when the aircraft flies off to the east this position data crosses the international date line -
    so Point 1 at say -36° Latitude, -179.9° Longitude,
    and Point 2 at say -36° Latitude, +179.9° Longitude.
    The issue I'm having is when I attempt to display this data superimposed on a map in SSRS the viewport zooms right out to show the entire southern hemisphere.
    On the extreme left I have 180° Longitude, in the center of the viewport is 0° Longitude, continuing through to -180° Longitude on the extreme right. From left to right my map layer displays South America, Southern Africa, Australia and New Zealand. 
    Needless to say the data I was attempting to display is invisible at this scale - however I'm assuming there are some points on the extreme left and some on the extreme right (with a lot of nothing in the middle).
    What I need is some trick I can apply to center the map layer projection over New Zealand so that my report doesn't freak out every time the data spans over the date line.
    Any suggestions around how to achieve this with SQL Server/SSRS? Many thanks for your help :)

    Hi Moshifish,
    According to your description, you want to show position data which acrossing international dataline without switching each half world. Right?
    In Reporting Services, since maps is based on the Bing map background, it's not a tellurian model. So the only thing we can do is split the data into two parts along the international data line. This is the default render behavior of SSRS map. 
    For this kind of issue, we suggest you submit it to the Microsoft Connect at this link
    https://connect.microsoft.com/SQLServer/Feedback.
    This connect site will serve as a connecting point between you and Microsoft, and ultimately the large community for you and Microsoft to interact with. Your feedback enables Microsoft to offer the best software and deliver superior services, meanwhile you
    can learn more about and contribute to the exciting projects on Microsoft Connect.
    Reference:
    Maps (Report Builder and SSRS)
    "Best Practices" when spanning International dateline?
    If you have any question, please feel free to ask.
    Best Regards,
    Simon Hou

  • I have 21,000  photos stored in iphoto. I have a WD 1.5TB backup external hard drive.  What is the best way to erase about half of my photos on my internal hard drive?

    I have 21,000  photos stored in iphoto. I have a WD 1.5TB backup external hard drive.  What is the best way to erase about half of my photos on my internal hard drive?

    Here's one way to do what you want:
    Make sure the drive is formatted Mac OS Extended (Journaled)
    1. Quit iPhoto
    2. Copy the iPhoto Library from your Pictures Folder to the External Disk.
    Now you have two full versions of the Library.
    3. On the Internal library, trash the Events you don't want there
    Now you have a full copy of the Library on the External and a smaller subset on the Internal
    Some Notes:
    As a general rule: when deleting photos do them in batches of about 100 at a time. iPhoto can baulk at trashing large numbers at one go.
    You can choose which Library to open: Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Choose Library'
    You can keep the Library on the external updated with new imports using iPhoto Library Manager

  • I just backed up my 1TB (mostly full) internal hard drive to an external 1TB Time Machine drive, and it says I'm fully backed up. Why is the Time Machine drive only half full?

    I have a 1TB internal drive in my MacBook Pro (15", mid-2009, running Snow Leopard). A couple days ago I decided to format my unused 1TB external drive and use it for Time Machine, so I could wipe/format my internal drive for the Mavericks upgrade I've been putting off. Time Machine backed up the entire drive, and it appears to have successfully worked! Except that Finder shows 157 gigs free on my internal drive and 463 gigs free on the external... I'm hesitant to erase everything in case some stuff didn't get backed up and might disappear. A Google search tells me that Time Machine doesn't compress files at all... so where the heck did those 300 gigs go? Is there really 300 gigs of stuff on my internal drive that Time Machine just decided didn't need to be backed up?

    By default Time Machine will not back up all files, i.e. temp file, cache, and system files. Also you can set Time Machine to exclude some folders/files, take a look at this link for more information.  http://pondini.org/TM/11.html

  • JCombobox and internal component sizes

    Hello,
    I am using a JCombobox in a table header. I would like to change the event handling in that way, that the combobox will be opened only if the arrow button has been selected or the arrow key has been pressed.
    The problem I have is that I do not know the size or lokation of the button inside the JCombobox.
    I created a new HeaderUI where I check the mousePressed event.
    With the function getDeepestComponentAt I get a MetalComboboxButton, but the width seems to be the width of the column size.
    Doese anybody knows how to get the size of the arrow button?
    Claudia

    The API documentation for that method says:
    "Invoked when an item has been selected or deselected. The code written for this method performs the operations that need to occur when an item is selected (or deselected)."
    So, when you change the selection from 4-5-6 to 1-2-3, you deselect 4-5-6 and then select 1-2-3. Two calls result. Fortunately, the ItemEvent parameter has a method getStateChange() that returns either ItemEvent.SELECTED or ItemEvent.DESELECTED, so you can program accordingly.

  • JSF selectOneChoice  VS.  Swing JComboBox

    I have been so impressed with how clean it is using a JSF selectOneChoice with a selectItem and selectItems.
    Using selectItem.itemValue and selectItem.itemLabel is intuitive, and fills a very common need.
    I'm wondering if there is a similar type of component I can use with a JComboBox. It seems that a LOV binding needs a target data collection (and iterator); but I simply want a JComboBox to display labels and manage values, independent from an iterator.
    Any suggestions are very much appreciated!!!
    Jeffrey

    Well I would just like to update this thread as more than a year has passed since I began working on ADF BC & Faces. Coming from a SWING background, I've learned quite a lot about web development. For starters, it’s not as easy as "Drag and Drop" and RAD like some demo videos or evangelical pitches makes it out to be. There is a steep learning curve (about half year with daily interaction with JDeveloper) to get comfortable with this technology. Personally speaking, a firm understanding of page definition bindings was the hardest to grasp, but then again maybe I’m just a bit slow. Compared to SWING or desktop UI development, the richness of ADF Faces UI is limited to boundaries of the web browser.
    <br>
    However, within the last month, our team has made great strides in taking the first step in launching a ported module our internal system (legacy Oracle Forms used by hundreds of hospital employees). Our Dynamic JDBC authentication piece was the keystone for our first module (a modified version from Steve’s infamous “not yet documented samples”). Trying to take full advantage of this technology, we also have created reusable pages and BC components for CRUD operations.
    <br>
    There is still plenty of work to be done as we are now struggling with team development (difficult due to multiple file modifications within JDev’s). We are also eagerly awaiting several rich UI in the next release of ADF Faces. Overall, the light at the end of the tunnel is starting to appear and I hope the Oracle ADF team and everyone on this forum continues to actively contribute to the growth of this community.
    <br>
    Here are a couple of screen shots of our app if you are interested.
    http://i108.photobucket.com/albums/n23/zeoneozero/login.jpg
    http://i108.photobucket.com/albums/n23/zeoneozero/menu.jpg
    http://i108.photobucket.com/albums/n23/zeoneozero/spcreg.jpg
    Cheers,
    -Z

  • My macbook is two and half year old, going to sleep mode randomly

    Having used this Macbook for almost two and half years, my machine has suddenly generated the problem of going to random sleep. It started as an infrequent thing, then it started happening on a regular basis, to the point that it became almost impossible to work with it. When the computer goes to sleep mode, it doesn't wake up with any key, it has to be woken up by pressing the power button lightly.
    Here are the steps I took:
    1. The normal thing I did was search Apple Forum and then reset SMC, PRam, then changed energy saving options, everything. Nothing worked.
    2. Ran the hardware test and no problems found.
    3. Ran the Macbook with all options: with just the battery, without the Magsafe connected, with Battery and Magsafe connected together, with battery removed and the computer running on Magsafe only. Random Sleep continues
    4. Thought must be a connection issue and ran to Apple Store in Kolkata, India, thinking that it could be a connection issue with the sleep-mode cable. Apple Store kept the Macbook for seven days, saying that they needed to check the machine, returned it on the seventh day saying that the machine was fine and charged me Indian Rupee 1,500/- (about $ 34). I came back home and the problem persists.
    (Here I would like to add that Apple Service in Kolkata *****, probably ***** all over India, simply because Apple is not a major player in this country. The service engineer at Apple Store was at a loss with my problem and after seven days could only say, "We have done our internal tests and found no problem with your Macbook." When I asked about the Sleep Mode sensor connection, he said, "That is working fine, we have checked that.")
    5. After coming back home, I faced the same problem, this time with lesser time gap. It would go off to sleep every one minute or so. I decided to set my computer on "never to sleep mode" in the enery saving option. Alas, that didn't help either.
    6. I redid the hardware check, only to find that my computer hasn't detected any hardware problem.
    7. Now, as a previous Windows user, I thought that the problem must have been with the OS. So, at the risk of losing all my files, I decided to reload the OS. (My original OS DVD was Leopard, but it was later upgraded to Snow Leopard by the vendor free of cost). I took backup in Time Machine, and backed up the documents in another Disk and reloaded the OS. All seemed fine so far, for about 10 minutes. I was now confident that finally I could solve the problem and was then planning to migrate my previous files to my newly loaded OS-X. Alas, I was wrong. Before I could connect the external HDD to my computer, my Macbook went back to its previous trick of falling asleep.
    I'll definitely take back my Macbook to Apple Care tomorrow, but with my experience here in Kolkata, don't know whether they would be able to solve anything. Last time I had to show them the posts in Apple Forum to prove that Random Sleep is a problem that happens to Macbook.
    PS: My Macbook is with aluminium body bought in January 2009. Out of warranty. My optical drive conked off long ago (after about 15 months or so after I bought the Macbook) and I live with an external drive.  

    Please read this whole message before doing anything.
    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, by a peripheral device, or by corruption of certain system caches. 
    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled on some models, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output and  Wi-Fi on certain models. The next normal boot may also be somewhat slow.
    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin. Test while in safe mode. Same problem? After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • Need HELPS! ASA 5505 8.4 Cisco VPN Client cannot ping any internal host

    Hi:
    Need your great help for my new ASA 5505 (8.4)
    I just set a new ASA 5505 with 8.4. However, I cannot ping any host after VPN in with Cisco VPN client. Please see below posted configuration file, thanks for any suggestion.
    ASA Version 8.4(3)
    names
    interface Ethernet0/0
    switchport access vlan 2
    interface Ethernet0/1
    switchport access vlan 2
    interface Ethernet0/2
    interface Ethernet0/3
    interface Ethernet0/4
    interface Ethernet0/5
    interface Ethernet0/6
    interface Ethernet0/7
    interface Vlan1
    nameif inside
    security-level 100
    ip address 172.29.8.254 255.255.255.0
    interface Vlan2
    nameif outside
    security-level 0
    ip address 177.164.222.140 255.255.255.248
    ftp mode passive
    clock timezone GMT 0
    dns server-group DefaultDNS
    domain-name ABCtech.com
    same-security-traffic permit inter-interface
    object network obj_any
    subnet 172.29.8.0 255.255.255.0
    object service RDP
    service tcp source eq 3389
    object network orange
    host 172.29.8.151
    object network WAN_173_164_222_138
    host 177.164.222.138
    object service SMTP
    service tcp source eq smtp
    object service PPTP
    service tcp source eq pptp
    object service JT_WWW
    service tcp source eq www
    object service JT_HTTPS
    service tcp source eq https
    object network obj_lex
    subnet 172.29.88.0 255.255.255.0
    description Lexington office network
    object network obj_HQ
    subnet 172.29.8.0 255.255.255.0
    object network guava
    host 172.29.8.3
    object service L2TP
    service udp source eq 1701
    access-list VPN_Tunnel_User standard permit 172.29.8.0 255.255.255.0
    access-list VPN_Tunnel_User standard permit 172.29.88.0 255.255.255.0
    access-list inside_access_in extended permit icmp any any
    access-list inside_access_in extended deny tcp any any eq 135
    access-list inside_access_in extended deny tcp any eq 135 any
    access-list inside_access_in extended deny udp any eq 135 any
    access-list inside_access_in extended deny udp any any eq 135
    access-list inside_access_in extended deny tcp any any eq 1591
    access-list inside_access_in extended deny tcp any eq 1591 any
    access-list inside_access_in extended deny udp any eq 1591 any
    access-list inside_access_in extended deny udp any any eq 1591
    access-list inside_access_in extended deny tcp any any eq 1214
    access-list inside_access_in extended deny tcp any eq 1214 any
    access-list inside_access_in extended deny udp any any eq 1214
    access-list inside_access_in extended deny udp any eq 1214 any
    access-list inside_access_in extended permit ip any any
    access-list inside_access_in extended permit tcp any any eq www
    access-list inside_access_in extended permit tcp any eq www any
    access-list outside_access_in extended permit icmp any any
    access-list outside_access_in extended permit tcp any host 177.164.222.138 eq 33
    89
    access-list outside_access_in extended permit tcp any host 177.164.222.138 eq sm
    tp
    access-list outside_access_in extended permit tcp any host 177.164.222.138 eq pp
    tp
    access-list outside_access_in extended permit tcp any host 177.164.222.138 eq ww
    w
    access-list outside_access_in extended permit tcp any host 177.164.222.138 eq ht
    tps
    access-list outside_access_in extended permit gre any host 177.164.222.138
    access-list outside_access_in extended permit udp any host 177.164.222.138 eq 17
    01
    access-list outside_access_in extended permit ip any any
    access-list inside_access_out extended permit icmp any any
    access-list inside_access_out extended permit ip any any
    access-list outside_cryptomap extended permit ip 172.29.8.0 255.255.255.0 172.29
    .88.0 255.255.255.0
    access-list inside_in extended permit icmp any any
    access-list inside_in extended permit ip any any
    access-list inside_in extended permit udp any any eq isakmp
    access-list inside_in extended permit udp any eq isakmp any
    access-list inside_in extended permit udp any any
    access-list inside_in extended permit tcp any any
    pager lines 24
    logging enable
    logging asdm informational
    mtu inside 1500
    mtu outside 1500
    ip local pool ABC_HQVPN_DHCP 172.29.8.210-172.29.8.230 mask 255.255.255.0
    icmp unreachable rate-limit 1 burst-size 1
    asdm history enable
    arp timeout 14400
    nat (inside,outside) source static orange interface service RDP RDP
    nat (inside,outside) source static obj_HQ obj_HQ destination static obj_lex obj_
    lex route-lookup
    nat (inside,outside) source static guava WAN_173_164_222_138 service JT_WWW JT_W
    WW
    nat (inside,outside) source static guava WAN_173_164_222_138 service JT_HTTPS JT
    _HTTPS
    nat (inside,outside) source static guava WAN_173_164_222_138 service RDP RDP
    nat (inside,outside) source static guava WAN_173_164_222_138 service SMTP SMTP
    nat (inside,outside) source static guava WAN_173_164_222_138 service PPTP PPTP
    nat (inside,outside) source static guava WAN_173_164_222_138 service L2TP L2TP
    object network obj_any
    nat (inside,outside) dynamic interface
    access-group inside_in in interface inside
    access-group outside_access_in in interface outside
    route outside 0.0.0.0 0.0.0.0 177.164.222.142 1
    route inside 172.29.168.0 255.255.255.0 172.29.8.253 1
    timeout xlate 3:00:00
    timeout pat-xlate 0:00:30
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa-server Guava protocol nt
    aaa-server Guava (inside) host 172.29.8.3
    timeout 15
    nt-auth-domain-controller guava
    user-identity default-domain LOCAL
    http server enable
    http 172.29.8.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
    crypto ipsec ikev1 transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set ESP-DES-SHA esp-des esp-sha-hmac
    crypto ipsec ikev1 transform-set ESP-DES-MD5 esp-des esp-md5-hmac
    crypto ipsec ikev1 transform-set Remote_VPN_Set esp-3des esp-md5-hmac
    crypto ipsec ikev1 transform-set Remote_vpn_set esp-3des esp-md5-hmac
    crypto ipsec ikev2 ipsec-proposal AES256
    protocol esp encryption aes-256
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES192
    protocol esp encryption aes-192
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal AES
    protocol esp encryption aes
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal 3DES
    protocol esp encryption 3des
    protocol esp integrity sha-1 md5
    crypto ipsec ikev2 ipsec-proposal DES
    protocol esp encryption des
    protocol esp integrity sha-1 md5
    crypto dynamic-map outside_dyn_map 20 set ikev1 transform-set Remote_VPN_Set
    crypto dynamic-map outside_dyn_map 20 set reverse-route
    crypto map outside_map 1 match address outside_cryptomap
    crypto map outside_map 1 set peer 173.190.123.138
    crypto map outside_map 1 set ikev1 transform-set ESP-AES-128-SHA ESP-AES-128-MD5
    ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ES
    P-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
    crypto map outside_map 1 set ikev2 ipsec-proposal AES256 AES192 AES 3DES DES
    crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
    crypto map outside_map interface outside
    crypto ikev2 policy 1
    encryption aes-256
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 10
    encryption aes-192
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 20
    encryption aes
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 30
    encryption 3des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 policy 40
    encryption des
    integrity sha
    group 5 2
    prf sha
    lifetime seconds 86400
    crypto ikev2 enable outside
    crypto ikev1 enable outside
    crypto ikev1 policy 1
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 43200
    crypto ikev1 policy 10
    authentication crack
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 20
    authentication rsa-sig
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 30
    authentication pre-share
    encryption aes-256
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 40
    authentication crack
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 50
    authentication rsa-sig
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 60
    authentication pre-share
    encryption aes-192
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 70
    authentication crack
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 80
    authentication rsa-sig
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 90
    authentication pre-share
    encryption aes
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 100
    authentication crack
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 110
    authentication rsa-sig
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 120
    authentication pre-share
    encryption 3des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 130
    authentication crack
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 140
    authentication rsa-sig
    encryption des
    hash sha
    group 2
    lifetime 86400
    crypto ikev1 policy 150
    authentication pre-share
    encryption des
    hash sha
    group 2
    lifetime 86400
    telnet 192.168.1.0 255.255.255.0 inside
    telnet 172.29.8.0 255.255.255.0 inside
    telnet timeout 5
    ssh timeout 5
    console timeout 0
    dhcpd auto_config outside vpnclient-wins-override
    dhcprelay server 172.29.8.3 inside
    threat-detection basic-threat
    threat-detection statistics access-list
    no threat-detection statistics tcp-intercept
    webvpn
    enable outside
    group-policy ABCtech_VPN internal
    group-policy ABCtech_VPN attributes
    dns-server value 172.29.8.3
    vpn-tunnel-protocol ikev1
    split-tunnel-policy tunnelspecified
    split-tunnel-network-list value VPN_Tunnel_User
    default-domain value ABCtech.local
    group-policy GroupPolicy_10.8.8.1 internal
    group-policy GroupPolicy_10.8.8.1 attributes
    vpn-tunnel-protocol ikev1 ikev2
    username who password eicyrfJBrqOaxQvS encrypted
    tunnel-group 10.8.8.1 type ipsec-l2l
    tunnel-group 10.8.8.1 general-attributes
    default-group-policy GroupPolicy_10.8.8.1
    tunnel-group 10.8.8.1 ipsec-attributes
    ikev1 pre-shared-key *****
    ikev2 remote-authentication pre-shared-key *****
    ikev2 remote-authentication certificate
    ikev2 local-authentication pre-shared-key *****
    tunnel-group ABCtech type remote-access
    tunnel-group ABCtech general-attributes
    address-pool ABC_HQVPN_DHCP
    authentication-server-group Guava
    default-group-policy ABCtech_VPN
    tunnel-group ABCtech ipsec-attributes
    ikev1 pre-shared-key *****
    tunnel-group 173.190.123.138 type ipsec-l2l
    tunnel-group 173.190.123.138 general-attributes
    default-group-policy GroupPolicy_10.8.8.1
    tunnel-group 173.190.123.138 ipsec-attributes
    ikev1 pre-shared-key *****
    ikev2 remote-authentication pre-shared-key *****
    ikev2 remote-authentication certificate
    ikev2 local-authentication pre-shared-key *****
    class-map inspection_default
    match default-inspection-traffic
    policy-map global_policy
    class inspection_default
      inspect pptp
      inspect ftp
      inspect netbios
    smtp-server 172.29.8.3
    prompt hostname context
    no call-home reporting anonymous
    Cryptochecksum:6a26676668b742900360f924b4bc80de
    : end

    Hello Wayne,
    Can you use a different subnet range than the internal interface, this could cause you a LOT of issues and hours on troubleshooting, so use a dedicated different Ip address range...
    I can see that the local Pool range is included into the inside interface Ip address subnet range, change that and the related config ( NAT,etc, ) and let us know what happens,
    Regards,
    Julio
    Security Trainer

Maybe you are looking for

  • How to I point to my itunes library with my new computer?

    I have recently got a new computer and so I've reinstalled itunes.  I backed up all my music from my old machine and have copied it to my new machine.  How do I tell my new machine where that folder is?  All the music is in folders under C:\iTunes Mu

  • Confused about creation of inner class object of a generic class

    Trying to compile to code below I get three different diagnostic messages using various compilers: javac 1.5, javac 1.6 and Eclipse compiler. (On Mac OS X). class A<T> {     class Nested {} public class UsesA <P extends A<?>> {     P pRef;     A<?>.N

  • How do I chat with a representative from Verizon?

    How do I chat with a representative from Verizon?

  • Seek to a particular location for MONO sounds not working in AS3

    Hi Guys, I am facing an issue seeking to a particular location for MONO sounds with sample rate 22KHz. Another thing I observed was that there is a problem seeking to positions greater than half the total length of the actual sound, otherwise it is w

  • Update geometry of a cylinder

    Hi, There is a way to update the geometry of a cylinder (radius, length) ? There is nothing about on javadoc. It's only possible to get the shape... Thanks. Edit : i will looking on http://aviatrix3d.j3d.org/javadoc/org/j3d/renderer/aviatrix3d/geom/C