JRE ignores proxy setting for connections to non-standard web ports

Hi,
I've noticed that JRE would not use the proxy settings if the application tries to connect to a web address on a non standard http port. If port 80, 443, 8080 etc is used, the proxy is used but if it's something like 32938 it's not. Is there anyway to disable this behaviour and just have the proxy used for all HTTP traffic, regardless of destination port. Below a trace snippet that shows the behaviour.
guistyle/1049  (signed jarfile)
Browser Java version 1.7.0_67
in Explorer 5 +
on NT-based Windows
network: Connecting https://www.123.com/guistyle/*JEMSEC11424340585918 with proxy=HTTP @ /10.10.12.11:3128
Using port: 43856
network: Connecting http://www.123.com:43856/ with proxy=DIRECT
Socket connection failed: java.net.ConnectException: Connection timed out: connect
Attempting tunneled connection
network: Connecting http://www.123.com:80/*TGD=CS/*EVENT=*JEMTUNNEL/1353036962/response.txt with proxy=HTTP @ /10.10.12.11:3128
TNLRCV unknown block start=null
network: Connecting http://www.123.com:80/*TGD=CS/*EVENT=*JEMTUNNEL/1353036962/response.txt with proxy=HTTP @ /10.10.12.11:3128
network: Connecting http://www.123.com:80/*TGD=CS/*EVENT=*JEMTUNNEL/1353036962/response.txt with proxy=HTTP @ /10.10.12.11:3128
TNLRCV unknown block start=null
Receive failed
Unable to make TCP/IP connection
End guistyle (startup failed)
basic: Applet initialized
basic: Starting applet
basic: completed perf rollup
basic: Applet made visible
basic: Applet started
basic: Told clients applet is started

Hi,
I still get the same error:
[12/Nov/2007:14:34:50] failure (16473) rsdts.mycomp.com: for host i78473.mycomp.com trying to GET http:/lidip/, service-http reports: HTTP7765: error reading response header (Server closed connection)
And:
Bad Gateway
Processing of this request was delegated to a server that is not functioning properly.
I don't get any logs on the other side...

Similar Messages

  • Connect to non standard ftp port

    Hi ,
    Is it possible for PI to connec to non standard ftp port to pick files using ftp adapter??
    how abt non standard ftp servers?

    Hi Teja,
    > Is it possible for PI to connec to non standard ftp port to pick files using ftp adapter??
    According to my knowledge it is possible, you have to mention that port in the communication channel. 
    > how abt non standard ftp servers?
    Reffer the below links
    http://www.nsoftware.com/kb/tutorials/biztalkftpadapter.aspx
    http://wikis.sun.com/display/JavaCAPS/SunAdapterfor+Batch-FTP
    Regards
    Ramesh

  • Error in OFR : "No database connection string set for connection group"

    Hi all..
    In OFR, Batches Fail To Export When Line Pairing is Enabled and Batch Remains in State 750 With Error "No database connection string set for connection group".
    I have followed all steps associated to line pairing with database still my batch is not exported..
    Any help is appreciated..
    Thanks in advance

    Hi,
    in case you haven't done this already: for this problem we'd really need you to open a CSS message.
    From your problem description it sounds likely that LCA routines and liveCache user don't fit together. Please check the solution of note 811207 to see if that assumption is correct.
    Furthermore: liveCache 7.5 and SCM 4.0 are not released together (yet). When using SCM 4.0 only liveCache versions 7.4.03 Build XX are released. This it seems you're current combination is not supported!
    Please take a look at PAM (Produkt Availability Matrix) on the SAP Service Marketplace to see which combinations have been released.
    Kind regards,
    Roland
    Message was edited by: Roland Mallmann

  • Safari ignores proxy settings for AJAX requests?

    I'm using Safari 4 on Mac OS X 10.5.7.
    When I configure Safari's proxy settings (which redirect to System Preferences -> Network -> Advanced -> Proxies), all my page requests go through the proxy I configured, except for AJAX requests.
    I configured an intercepting proxy (burp suite) to verify this, and indeed, AJAX requests are not being sent to the proxy. I double checked the exact same page on Firefox 3.5 on the same Mac with the same proxy being configured, and in this case the AJAX requests do go via the proxy.
    For Safari, I configured the "Web Proxy (HTTP)" and "Secure Web Proxy (HTTPS). Is there anything else I need to do? Is this a bug in Safari?
    Thanks in advance for all help.

    I'm seeing the same problem. I use privoxy, a local security/privacy/ad-blocking proxy that lives on my computer. Firefox always sends its requests through the proxy, but Safari sometimes ignores the proxy settings. Vienna, my RSS reader, stops going through the proxy when Safari stops doing it. A restart fixes the problem for a while, but eventually the ads start showing up in Safari and Vienna.
    I didn't start seeing this problem until Safari 4. I'm currently using the most up-to-date version of Safari, 4.0.3, with Mac OS X 10.5.8 and all other updates as of 12 Sep 2009. Privoxy is version 3.0.10, not the very latest, but it's working.

  • Doing proper NAT to FTP connections on non-standard port

    Router 1712, IOS 12.3
    There is an article from Cisco, "Using Non-Standard FTP Port Numbers with NAT".
    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094e76.shtml
    It explains how to enable NATting router to perform proper translation of NAT-sensitive protocols, in this case FTP.
    The article assumes that the FTP server in question is on the inside interface of the router.
    The configuration proposed by the article is as follows:
    interface Ethernet0
    ip address 10.1.1.2 255.255.255.0
    ip nat inside
    interface Serial0
    ip address 192.168.10.1 255.255.255.252
    ip nat outside
    ip nat service list 10 ftp tcp port 2021
    ip nat inside source static 10.1.1.1 20.20.20.1
    access-list 10 permit 10.1.1.1
    In my case, the FTP server in question is on the outside interface. The router is performing source NAT for outbound connections. An example of my config is below:
    interface Ethernet0
    ip address 12.34.56.1 255.255.255.0
    ip nat outside
    interface Vlan324
    ip address 10.1.1.2 255.255.255.0
    ip nat inside
    ip nat service list 10 ftp tcp port 2021
    ip nat inside source static 10.1.1.100 12.34.56.100
    access-list 10 permit 12.34.56.200
    With this configuration, Layer 3 NAT is working. I'm able to establish an FTP control channel and issue FTP commands. However, I think that the IP addresses inside FTP control channel are not translated properly (to 12.34.56.100). Therefore, the FTP data channel is not working.
    I tried to enable the following debug, however didn't see any entries related to FTP control channel translation:
    debug ip nat
    debug ip nat detailed
    debug ip snat
    debug ip snat detailed
    debug ip ftp
    debug ftpserver
    My question is:
    Is the "ip nat service list <acl> ftp tcp <port>" command supposed to work when the FTP server in question is on the outside interface of the translating router ?

    Hi,
    I see that this question was asked quite some time ago but I have come across the same issue, i.e when the server is on the outside interface the ip in the "PORT" command from the client is not translated.
    Did you ever get a fix for it?
    Thanks

  • Terminal: Stored Remote Connection with non-standard Port?

    Hi,
    I am new to MacOS and I am amazed by the integrated terminal. However, I sometimes need to connect to servers which use a non-standard SSH port, for example, 2020. I know that I can manually connect, but for convinience, I'd like to have a saved remote connection including the non-standard port. Is this possible somehow?
    Thanks,
    Felicitus

    I did some experimentation, using Terminal.
    Terminal -> New Remote Connection -> Service -> [+]
    now enter your own new service which includes
    /usr/bin/ssh -p 50022
    I found I had to enter a bonjour entry to get it to accept my new service, but once I did, I was able to use that new service with the custom -p 50022 port value.
    Your mileage may vary. I still prefer iTerm.
    Oh yea. In the future, Terminal and Unix oriented questions are better asked in the Mac OS X Technologies > Unix Forum
    <http://discussions.apple.com/forum.jspa?forumID=735>

  • How To Configure non-standard SMTP port

    My ISP has blocked port 25. I have a service that will deliver mail to the port of my choosing. How do I configure Leopard Server to listen on a non-standard SMTP port? 2525 for example.
    Also, I assume all I have to do on my Airport Express is set up NAT to rake external port 2525 and point it to the private address of my email server on port 2525. Is this correct?
    Thanks,
    -ernie

    Assuming such is offered, look to acquire a business-class ISP service level, and move on to the next issue? The business-class services typically provide static IP address(es), opens up server ports, and sets up DNS and ISP-side server connections for your hosts. And you can call your ISP or other assistance when your network craters; non-standard connections are (as you've found) harder to support.
    One subtlety here: in a number of cases, simply having a business-class service means you're supported by a different group within (larger) ISPs. This can be a significant advantage at times, given that the scripts and tools and such that are available for the business group will be rather more targeted than the scripts that are available for the residential services group at the ISP.
    There are a number of folks that have sought and have tried this (try a few Google searches for SMTP and non-standard port), and it mostly works. But it is fragile, and tends to be derailed when something goes weird, or when the ISP spots and shapes or blocks the server traffic.
    Also check your ISP's terms of service here, lest your network pipe be subject to summary disconnection.
    The other option is to VPN or tunnel into to a co-lo or dedicated server or a virtual hosting service; to run your servers or virtual servers somewhere without firewalls blocking the standard ports.

  • Add Non-Standard Web Link in Mac Mail

    Does anyone know how to add a non-standard web link? The add link dialog box does not like my url.
    I need to add a link like this: http://someserver100/index.html.
    It disables the "OK" button as soon as I add the "100" after "someserver".
    Prior to the Leopard upgrade I never had a problem doing this. Now it seems that Mail is trying to be too clever. Please help, this is an important business need for me to be able to send links like this.

    I didn't originally go deep into detail as not to bore, but maybe the details will make the difference.
    I am a web developer. I have a client that I vpn into to make web updates. The server that I work on is a testing / development server, not the outside world facing production server. The server is not viewable via a domain name. So I can not get to it by typing www.domainname.com. Instead, the client's IT guys have a host name set up for the server that I need to use due to some of the back end technology that serves the pages.
    The server name is "development100".
    In order for me to view pages on this server, I had to make an entry in my host file so my browser would know what ip address "development100" is associated with. That way whenever I type "http://develoment100" into my browser's url bar to proof my web work it would resolve me to the testing / development server.
    Now, once my changes are done and posted, I need to send a notification email to the IT staff that servers two purposes. First, it gives them an exact url laundry list of what files have have updated. Second, it gives them a link to click for each item that will allow them to proof that html, jpeg, etc.
    A typical item in this list would like like this: http://development100/index.html
    That link should send them directly to the index page on the server for example. I have be using this system of building the notification emails with these links for over five years and prior to upgrading to Leopard, it always worked.
    Now, if I try to "Add Link" and type "http://development100/index.html" in the dialog box. The "OK" button will become disabled as soon as I key in the first number in that link.
    If I don't "Add Link" and just key "http://development100/index.html" into the body of the email the link will cut off at the first number as well. So the link will look like this: "http://development"
    Sorry for the long explanation, but I think that it is necessary. The answer may just be that Apple is trying to verify / qualify links automatically and wont let numbers go in the link name without a .com / suffix. Thanks for the help.

  • Http probe on non-standard tcp port 8021

    I've configured http probe on standard port 80 with no issue. I'm now trying http probe on non-standard tcp port 8021, confirmed with packet capture to confirm that the CSM is indeed probing, status code 403 is returned but the reals are showing "probe failed". Am I missing something? Thank you in advance.
    CSM v2.3(3)2
    probe 8021 http
    request method head
    interval 2
    retries 2
    failed 4
    port 8021
    serverfarm TEST
    nat server
    no nat client
    real 10.1.2.101
    inservice
    real 10.1.2.102
    inservice
    probe 8021
    vserver TEST
    virtual 10.1.2.100 tcp 8021
    serverfarm TEST
    replicate csrp connection
    persistent rebalance
    inservice
    VIP and real status:
    vserver type prot virtual vlan state conns
    Q_MAS_8021 SLB TCP 10.1.2.100/32:8021 ALL OUTOFSERVICE 0
    real server farm weight state conns/hits
    10.1.2.101 TEST 8 PROBE_FAILED 0
    10.1.2.102 TEST 8 PROBE_FAILED 0

    you need to specify what HTTP response code you expect.
    The command is :
    gdufour-cat6k-2(config-slb-probe-http)#expect status ?
    <0-999> expected status - minimum value in a range
    The default is to expect only 200.
    This is why your 403 is not accepted.
    Gilles.

  • Enhanced security via non-standard ssh port?

    I am using my Snow basestation as a NAT router, and I have a pass-through to my machine for ssh. This is working fine now. However, I got to thinking that there is value in changing the ssh public port to a non-standard port, like 14038 and routing that to my mac's private port of 22. Doing so, however, merely breaks my ability to log in (note that I have updated my ssh client to point to the new ssh port of 14038)
    Does ssh burp on any port other than 22? Do others have a positive experience running this? Might my ISP (earthlink) be blocking non-standard IP ports?
    With much gratitude,
    Kyle

    I sold the Snow basestation -- so the question is moot now.

  • Proxy setting for Internet Explorer

    Recently purchased new CPU with Windows 8.1. I am not able to access Explorer.  I get an error message about proxy settings. How do I change this?

    Hi,
    To change proxy server settings.
    Click the Tools button, and then click Internet Options.
    Click the Connections tab, and then click LAN settings.
    uncheck  the Use a proxy server for your LAN check box..
    Sudheer MCP,MCSA(Server 2012)

  • Ignore PROXY settings for a given IP

    Hi,
    I use a socks proxy to reach email outside the corporate lan. One account on my Mail though is local Lan (Exchange Server). I put the IP of the Exchange Server to the ignore proxy configuration text box but I still cant connect to the local server.
    Please Help

    Hi,
    My problem sounds really similar. I connect to an exchange server at one university but when I am physically located in another university that I also work at I cannot access the server using the Mail program.
    I don't really understand the details but I was able to use a program called PROXIFIER to force mail to use a SOCKS proxy (or something like that).
    Result... Mail now works from behind the university firewall.
    Good luck!

  • Connecting to non-secure listener port over TCPS

    Hi,
    I am trying to connect to non-SSL port over TCPS.
    When I use tnsping, it hangs.
    When I do an OCIServerAttach, it hangs.
    Client is 10.2
    And Database server is 9.2 and higher..
    Any way I can find out why this is happening??
    -Harsha

    Maybe I'm not getting the point, but when you do not use SSL on this port, why do you want to use TCPS. Wouldn't TPC be a better choice?
    cu
    Andreas

  • Mailserver using non-standard smtp port

    how do i set SMTP to accept connections on a non-standard port (i.e. 2525 or something)?
    i'm running a mail server and my residential isp (comcast) after ten years of peaceful coexistence decided that they need to block port 25. so i am setting up a commercial store/forward mail relay service. all i need to do is set up my snow leopard server to accept incoming connections on a port other than 25. sounds easy. it is mentioned in the docs thusly:
    "By default SMTP is enabled on port 25. If port 25 is blocked in your environment,
    you need to change the port SMTP uses."
    ... but that's all i can find. specifically, it doesn't say exactly how to change the port.
    any help appreciated.

    following up to my own post. hoping this info may be useful for others who face the same issue who are running a server and then having email ports blocked by their ISP's.
    i worked around this by signing up for a mail relay service (i use the one provided by dnydns.com). they forward incoming mail for my domain over a nonstandard port.
    since i never received an answer to my question about how to make SnowLeopardServer email server accept SMTP connections on other ports, i simply used port mapping in my router (Airport Extreme) to redirect this port (i used 2525) on my WAN address to port 25 on my server - an acceptable workaround.
    i also did the same port redirection for the other "standard alternative" smtp ports, 465 and 587.
    since my ISP blocks port 25 in both directions, i also needed to find a work-around for outgoing mail as well. previously, my mail server simply forwarded to my ISP's smtp server (using the default port 25). here the Server Admin interface worked but with one "trick": under Mail>Settings>General, i left the box for "Relay outgoing mail through host:" checked, and in the field there i put "[smtp.myispdomain.net]:587" (that is with square brackets, and a colon, but no double-quotes - and of course, use your own smtp server's domain name). afaik this is not documented anywhere in the apple-provided docs, but i found the corresponding docs for postfix, and reverse-engineered it.
    so now i can read (via IMAP) and send (via SMTP) mail from my home server, both when i am on my LAN and when i am accessing remotely, and effectively work around the bi-directional block of port 25 imposed by my ISP.
    i'd still like to know if there is a method of configuring smtp to accept connections on ports other than 25. i can see how to do it by editing /etc/postfix/master.cf, but afaik that file gets overwritten by Server Admin...

  • Using non-standard sshd port after 10.8 upgrade

    After spending hours tracking down this solution as a result of losing my ssh settings after the upgrade to Mountain Lion, I thought it might be useful to post the steps taken to restore the configuration I used with Snow Leopard.
    Changing the sshd default listening port
    Disclaimer: This tutorial is specific to Mountain Lion (OS X 10.8). I was able to accomplish this using Snow Leopard (OS X 10.6) in fewer steps, but upgrading required this more involved solution. 
    Steps:
    1.) You must first enable the root user account in order to change the relevant files. This can be done from the terminal, or by going to System Preferences --> Users & Groups. Once there, click on 'Login Options' at the bottom of the Current User list, and 'Join' where it says 'Network Account Server'.
    This will bring up a smaller window. Click on 'Open Directory Utility' at the bottom. You will be prompted for your admin password. Now go to the 'Edit' tab at the top of the screen and toggle down to 'Enable Root User'.  You will be prompted to enter your admin password twice.
    2.) Log out of your regular user account. At the log in screen you will now see an additional entry for 'other'. Click on that and log in with the username 'root' and your admin password. If are inexperienced as a root-level user, be careful as you can cause problems to your system can be difficult to undo.
    Once in your root account, the first step is to create a new 'service definition' in the etc/services file. Open the file with text editor of choice and scroll to the current entry for sshd listening port, which will look like this:
    ssh    22/udp    # SSH Remote Login Protocol
    ssh    22/tcp     # SSH Remote Login Protocol
    Overwrite the '22' with the port number you would like sshd to listen on:
    ssh    12345/udp   # SSH Remote Login Protocol
    ssh    12345/tcp    # SSH Remote Login Protocol
    *12345 being our hypothetical, non-standard port.
    It is important to note that the new port number will not take by simply adding a new uncommented line to the file (I tried), unless of course you comment the original ssh entries. Easiest way is just to overwrite what is there already. Save changes.
    3.) You now need to edit the ssh.plist file, which is located at /System/Library/LaunchDaemons/ssh.plist. A word to those familiar with Linux/BSD environments: changing the default port in the sshd_config file, which exists in OS X, does NOT change the listening port. Simply changing the default port, saving the config file, and restarting the server (the sensible way) won't work. The OS X sshd server (openssh) is configured to get launch instructions from the ssh.plist file, as opposed to sshd_config. If you are more interested in this aspect of OS X, read up on LaunchDaemons (e.g. launchd).
    Before altering the ssh.plist file, you should save a backup copy in case of mistakes, or if you need to revert back to it in the future. Name your backup file something like original.ssh.plist, etc.
    In the ssh.plist file, locate the SocksServiceName entry and change it from the default:
    <key>SockServiceName</key>
    <string>ssh</string>
    To the following:
    <key>SockServiceName</key>
    <string>$alternate port number</string>
    In our example from above this value would be 12345.
    4.) Save your changes, and exit ssh.plist. You now need to move the backup file you created (original.ssh.plist) out of the System/Library/LaunchDaemons path.
    The updated sshd port will not take until you have only one ssh.plist file in the LaunchDaemons directory - this has to do with how launchd is configured to load files which is outside the scope of the current discussion.  (*If you've found a way around this, please share.) 
    5.) Restart the sshd server. Easiest way to accomplish this is going to System Preferences --> Sharing and clicking off 'Remote Login', then clicking back on it. 
    6.) Test the configuration by logging into the machine running the sshd server from another host using:
    ssh username@ipaddress -p 12345
    There are a few good tutorials out there that capture some of these steps, but many are dated and/or incomplete. If you are running a standard setup of OS X 10.8, this should work for you.
    Of course, don't be fooled into thinking that changing the default listening port from the ubiquitously-probed 22 equates to actual security. At best, it will cut down on the number of dubious connection attempts and probing.

    Hi all, above helped me change the sshd port number, thank you very much.
    Just upgraded to OS X 10.9.3 on my macbook pro.
    My findings were:
    Step 1(become a root user or sudo)
    Step 2 (/etc/services)
    This may not be required unless you want ssh to work without the "-p XXXX" option to connect to other ssh hosts.  I favor such as "ssh -p 2222 user@hostname" just to be sure I know what I am doing and also to leave ssh known port as its default "22".
    Step 3 (/System/Library/LaunchDaemons/ssh.plist)
    This is required if you want to change the sshd port number, I changed both "ssh" to "2222" in this file.
    Step 4 (launchctl)
    Below is a must as I understood:
    launchctl unload /System/Library/LaunchDaemons/ssh.plist
    launchctl load /System/Library/LaunchDaemons/ssh.plist
    it should be already working with the new port number.
    You can "ssh -p 2222 user@localhost" in the console terminal and see if its working.
    Since I am no expert on MacOS X, and it is a macbook pro that I am using, I also rebooted the system and changes were reflected permanantly.
    Thank you guys!

Maybe you are looking for

  • My ipad says charging but not

    hi can anyone help i have plugged in my ipad mini with the apple usb plug and lead it has the plug in the battery which says its charging but still after an hour it says 10% charged which it started on. the plug is the one that came with my Ipad mini

  • Extension: Distribution error.

    Hello, I finished my Extension and now I want to make it ready for distribution. I did what I got told to do here: http://www.oracle.com/technetwork/developer-tools/jdev/extension-094911.html When I want to import that ZIP-File via "Check for Updates

  • Smartforms in QM module

    Hi all, is it possible to configure smartforms in QM module? Currently we know that the CQ85 transaction only lets us configure SAPScripts here. Is there any workaround to this? Or is it only possible to have SAPScript here? Thanks for answers Regard

  • Will my plan work?

    Hello Apple community. My name is Kevin, and I just recently became a Mac user, after 12 years of Windows I finally decide to buy a MacBook Pro...and I LOVE it!!! Anyway, I have an idea on how I want to build / upgrade my Macbook, and was wondering i

  • Install and run lepoard on a usb-harddrive

    Hi! I wonder if it is possible to install and run leopard on an external harddrive with my macbook. The reason is that my harddrive has failed and I wont be able to get to mac service provider in a near future. Thanks!