CSS10500 Load Balancing Multiple Hosts

Hello,
I have a CSS10500 switch and i would like to load balance the connections to a couple of hosts. My setup (roughly) is as follows
int e1-RTR1-------->int e2-Host1
                 -------->int e3-Host2
and
int e5-RTR2------>int e6-Host1
                 ------>int e7-Host2
How can i assing different interfaces to the two sets of hosts??? I want all ports (0-65535 and tcp/udp)  to go to both sets. I made a circuit vlan 1 and assigned it an ip address but i cannot make a circuit vlan 2 and when i assign multiple addresses to vlan1 i cannot somehow assign interfaces to each ip.
Is there anything i can do??
Sorry for all the fuss i am new to the CSS concept.

Let's start with the basic
http://www.cisco.com/en/US/products/hw/contnetw/ps792/products_configuration_example09186a008009438d.shtml
If you can't make it work, get back to us with whatever you have configured.
Verify that you can ping the CSS from the router and the server.
Gilles.

Similar Messages

  • Load balance multiple URLs on single VIP

    Hello,
    I have a fairly typical load balance configuration on a pair of ACE appliances running (A3)2.5 and now I need to load balance multiple URIs to these same servers on port 80 to the one VIP. Can someone direct me to a doc that shows a good example of this, or explain it below?
    Thanks,
    Dave
    serverfarm host application
    rserver webserver1 80
    probe server-80-PROBE
    inservice
    rserver webserver2 80
    probe server-80-PROBE
    inservice
    sticky ip-netmask 255.255.255.255 address source application-80-STICKY
    replicate sticky
    serverfarm application
    class-map match-all application-80-CLASS
    2 match virtual-address 1.1.1.1.1 tcp eq www
    policy-map type loadbalance first-match application-80-POLICY
    class class-default
    sticky-serverfarm application-80-STICKY
    insert-http X-Forwarded-For header-value "%is"
    class application-80-CLASS
    loadbalance vip inservice
    loadbalance policy application-80-POLICY
    loadbalance vip icmp-reply
    nat dynamic 22 vlan 424
    appl-parameter http advanced-options CASE_PARAM

    Sean,
    Maybe a little confused.
    I have built the new serverfarm, policy-map and class-map in bold, I am just not sure how it gets referenced. Do I add it to the multi-match class statement?  My complete config for this particular app is below.
    Thanks,
    Dave
    serverfarm host application-80
      rserver server1 80
        probe server-80-PROBE
        inservice
      rserver server2 80
        probe server-80-PROBE
        inservice
    serverfarm host application-L7
      rserve rserver1 80
        probe server-80-PROBE
        inservice
      rserver server2 80
        probe server-80-PROBE
        inservice
    class-map match-all application-80-CLASS
      2 match virtual-address 1.1.1.1 tcp eq www
    class-map type http loadbalance match-any application-L7-CLASS
      3 match http url /uri1/
      4 match http url /uri2/uri2
      5 match http url /uri2/uri3.htm
    policy-map type loadbalance first-match application-80-POLICY
      class class-default
        sticky-serverfarm application-80-STICKY
        insert-http X-Forwarded-For header-value "%is"
    policy-map type loadbalance first-match application-L7-POLICY
      class application-L7-CLASS
        serverfarm application-L7
    policy-map multi-match POLICY-424
    class application-80-CLASS
        loadbalance vip inservice
        loadbalance policy application-80-POLICY
        loadbalance vip icmp-reply
        nat dynamic 22 vlan 424
        appl-parameter http advanced-options CASE_PARAM

  • Load balancing multiple J2ee servers - each running it's own CI

    Is it possible to load balance multiple J2ee servers(running Portal), both running it's own Central Instance?
    We do not have the resources (SAN storage) to implement MSCS for Portal...so instead we want to use two complete Portal servers HW load balanced with the ability to keep running in case one fails.
    thanks for any info !
    Linwood

    Hi Linwood,
    in a nutshell, the difference between an ordinary J2EE server instance and the central instance are the central services. The central services (enqueue server, message server) are only needed once. Basically, they are required for the communication between the server instances (and to the load balancer). What you should go for is a cluster installation with one central instance and another ordinary server instance (both running the SAP NetWeaver Portal). But be aware that you have to use the same database for both server instances (otherwise you cannot guarantee consistent data).
    For load balancing the two server you can use the SAP Web Dispatcher  or any other load balancer tool you like. 
    You will find more and detailed information on load balancing in the SAP Library. Have a look into section <a href="http://help.sap.com/saphelp_nw2004s/helpdata/en/2e/611724f410254ca12a3f396ec5ae85/frameset.htm">Java Cluster Architecture</a>.
    Hope I could help!
    Best regards,
    Martin

  • Recommended configuration for load balanced Portal with load balancer, multiple gateways and multiple servers.

    Does anyone have a recommended network, hardware and software configuration guide for a Portal installation running with multiple gateways load balanced (ie one URL) that talk to multiple servers?

    David,
    We've used Resonate (software) to load balance the gateways. It allows
    you to group all the gateways under 1 virtual URL and load balance the
    incoming connections over each gateway depending on the rules that you
    define in Resonate. Look in the SUN portal whitepapers there is one that
    talks about it specifically.
    As far as load balancing the calls to the portals, the gateways will
    automatically load balance across all the portals that they know about
    using a simple round-robin rotation. You may be able to use Resonate in
    front of the portals but you may need to activate persistance within
    Resonate to ensure that the user always ends up on the portal that he
    established his initial connection on (if you want that), check with Sun
    on this one.
    David Broeren wrote:
    Recommended configuration for load balanced Portal with load balancer,
    multiple gateways and multiple servers.
    Does anyone have a recommended network, hardware and software
    configuration guide for a Portal installation running with multiple
    gateways load balanced (ie one URL) that talk to multiple servers?
    Try our New Web Based Forum at http://softwareforum.sun.com
    Includes Access to our Product Knowledge Base!

  • What's the best way to load balance multiple protocols on one vserver?

    Hi,
    We have a CSM blade on a 6513, in bridge mode. I'm just wondering what is the best way to serve HTTP and HTTPS (or any two or more ports) from the same group of servers. As I see it, we have two options:
    1. Don't set a port on the vserver, so it is load balancing "any" or "tcp". This is easy but I want to be sure there isn't a downside to this, other than the obvious security issue.
    2. Create multiple vservers and point them at the same serverfarm. I tried this and I got some odd results with the health checks.
    Any ideas? Thanks a lot.

    you listed the only 2 options available.
    The advantage of solution #2 is that you can apply specific config for each protocol ie: for HTTP you can turn 'persistent rebalance' if needed.
    If you want to use specific probes [not icmp], it is also a good practice to create a different serverfarm for each protocol.
    Like this, if the HTTP service goes down but not the server, you can still have other protocols loadbalanced.
    Regards,
    Gilles.
    Thanks for rating this answer.

  • Load balancing multiple SSO mid-tier with single SSO database

    I want to load balance SSO middle tier servers and have them access a single SSO database. When you install infrastructure and select SSO only it creates a new infrastructure database. How can I install multiple SSO servers and point them to a single database. I am doing Load Balancing with F5 and read an Oracle WP where they mentioned an Oracle supported configuration where they load balanced SSO servers with F5.
    KB

    Two possible solutions:
    1.) Oracle 10gAS Enterprise Deployment Guide (B13998-03) follow the configuration for SSO configuration in Chapter 5.
    2.) I have not tried this but it should be logically possible with the SSO. 10gAS Administrators guide (B13995-05) Part III Advanced Administration. The success of this method assumes you have OID and SSO each installed in separate homes. You would be cloning the SSO home to another box as if it were a middle tier (it is still part of the infrastructure) then re-configuring it on the new box.
    Personally solution 1 is the best method. We are using F5 Big-IP with this configuration and it is working great.
    Hope this helps!

  • Etherchannel Load-Balancing To Host (Confused)

    I'm a bit confused as to how an etherchannel load-balances traffic across all the links, in the port-channel.  If I have a 4 port etherchannel, to an AIX host, does the traffic load balance across all 4 ports?   In reading the load-balancing documentation, it states that a global configuration of src-mac forwards traffic from the same host, over the same port, all the time, whereas it forwards traffic over different ports for other hosts.  What if it's the same host tied into the port-channel?  So if my AIX box has 4 ethernet cards in a port channel, each ethernet card goes over only one link?  If the ethernet cards are bundled, into a port channel config, is there no way to load balance all the traffic?  Maybe I'm misunderstanding the etherchannel configuration and how it works.  Thanks for any and all help!!
    Dan

      Port channel is link aggregation for all traffic which will get distributed across all links.  A given ip conversation will only travel down one of those links at any given time. The single ip conversation is not carried say for instance across all 4 links if it's a 4 port etherchannel.

  • Using a single CSS to load balance multiple services

    Is it possible to use a single CSS to load balance 3 different services (server farm) ? That mean the CSS need to advertise 3 VIP
    I'm thinking of two scenarios:
    1 - configure the CSS to use 4 interfaces: 1 to public, 3 to private (each interface will plug-in to a different vlan/server farm)
    2 - configure the CSS to use 2 interfaces: 1 to public, 1 to private (all 3 server farms are in the same vlan)
    Will both scenarios work ?
    Thanks
    --Phillip.

    Hi Phillip,
    both scenarios will work. One CSS can certainly manage more than 3 services! You can even use just one VIP for all traffic, then just create the proper rules to send specific traffic to the corresponding service(s). No need for 3 VIPs.
    Regards
    -juerg

  • Load Balancing multiple web servers

    Hi All:
    I need to load balance 2 different web servers using sticky connections on a LocalDirector 416.
    I need to use cookie-passive mode, which of course relies on a cookie set by the web server.
    Problem: The name of the session cookie is different on each web server (IIS) and I'm not sure that I can change it.
    Question: What do I pass to the sticky command as the name of the cookie?
    Any ideas?
    craig

    fortunately the cookie are different on the 2 servers otherwise this feature would not work.
    The value you enter after the keyword cookie-passive is a 'name' and can be whatever you want (you can also leave it blank/empty).
    The LD will learn the cookie directly from the server.
    See the documentation at :
    http://www.cisco.com/univercd/cc/td/doc/product/iaabu/localdir/ldv42/421guide/42ch05.htm#xtocid8565101
    I hope this answer your question.
    Gilles.

  • Load balancing multiple AP1242

    Hi,
    I just deployed a few AP1242 in my office environment.
    I've set them to use the same SSID and encryption (WPA2).
    I would like to know can I set load balancing on the APs? E.g. there are 30 users at the office and I installed 2 APs in the area, is there anyway the AP will auto loan balance between themselves, taking 15 users each?
    Thanks.

    Hi Patrick
    There really is no load balancing feature with Autonomous AP's. But you can use this;
    To allow only so many users to associate to an AP at one time you can use the max-Associations command.
    This example shows how to:
    Name an SSID
    Configure the SSID for RADIUS accounting
    Set the maximum number of client devices that can associate using this SSID to 15
    Assign the SSID to a VLAN
    AP# configure terminal
    AP(config)# interface dot11radio 0
    AP(config-if)# ssid batman
    AP(config-ssid)# accounting accounting-method-list
    AP(config-ssid)# max-associations 15
    AP(config-ssid)# vlan 3762
    AP(config-ssid)# end
    From this doc;
    http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_guide_chapter09186a00802085c4.html
    To find out how many users are associated to an AP, this example shows how to display all client devices associated with the access point:
    AP# show dot11 associations client
    http://www.cisco.com/en/US/docs/wireless/access_point/12.3_4_JA/command/reference/cr34main.html#wpxref81339
    Hope this helps!
    Rob

  • Load balancing multiple serverfarms

    access-list PERMIT_ACL line 1 extended permit ip any any
    probe http port-7777
    port 7777
    interval 5
    faildetect 15
    passdetect interval 15
    receive 2
    expect status 200 200
    open 2
    probe http port-8005
    Listener Port
    port 8005
    interval 5
    faildetect 15
    passdetect interval 15
    receive 2
    expect status 200 200
    open 2
    parameter-map type http http-par
    persistence-rebalance
    set header-maxparse-length 4096
    length-exceed continue
    rserver host zcgnoraapp04-Perf
    ip address 10.1.40.12
    inservice
    rserver host zcgnoraapp05
    ip address 10.1.40.13
    inservice
    rserver host zcgnoradb04-Perf
    ip address 10.1.40.112
    inservice
    rserver host zcgnoradb05-Perf
    ip address 10.1.40.113
    inservice
    serverfarm host SFarm1-Perf
    probe port-7777
    rserver zcgnoradb04-Perf 7777
    inservice
    rserver zcgnoradb05-Perf 7777
    inservice
    serverfarm host SFarm3-Perf
    description SFARM3-Perf
    probe port-7777
    probe port-8005
    rserver zcgnoraapp04-Perf 8005
    inservice
    rserver zcgnoraapp05-Perf 8005
    inservice
    serverfarm host SFarm6-Perf
    description SFARM6-Perf
    probe port-7777
    probe port-8005
    rserver zcgnoraapp04-Perf 7777
    inservice
    rserver zcgnoraapp05-Perf 7777
    inservice
    sticky http-cookie acecookiePerf sticky-cookie-insert-7777-Perf_SOA
    cookie insert
    replicate sticky
    serverfarm SFarm1-Perf
    sticky http-cookie acecookiePerf sticky-cookie-insert-8005-perf
    cookie insert
    replicate sticky
    serverfarm SFarm3
    sticky http-cookie acecookiePerf sticky-cookie-insert-7777-Perf
    cookie insert
    replicate sticky
    serverfarm SFarm6
    class-map match-all port_8005_perf
    description Match Apache port
    2 match virtual-address 10.1.90.140 tcp eq 8005
    class-map match-all port_7777_perf
    description Match ESB and SOA port
    2 match virtual-address 10.1.90.140 tcp eq 7777
    class-map match-all port_7777_perf_SOA
    2 match virtual-address 10.1.90.141 tcp eq 7777
    policy-map type loadbalance first-match port_7777_policy_perf_SOA
    class class-default
    sticky-serverfarm sticky-cookie-insert-7777-Perf_SOA
    insert-http x-forward header-value "%is"
    policy-map type loadbalance first-match port_7777_policy_perf_SSO
    class class-default
    sticky-serverfarm sticky-cookie-insert-7777-Perf
    insert-http x-forward header-value "%is"
    policy-map type loadbalance first-match port_8005_policy_perf
    class class-default
    sticky-serverfarm sticky-cookie-insert-8005-Perf
    insert-http x-forward header-value "%is"
    policy-map multi-match VIP
    class port_7777_perf
    loadbalance vip inservice
    loadbalance policy port_7777_policy_perf_SSO
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 5
    appl-parameter http advanced-options http-par
    class port_7777_perf_S0A
    loadbalance vip inservice
    loadbalance policy port_7777_policy_perf_SOA
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 5
    appl-parameter http advanced-options http-par
    class port_8005_perf
    loadbalance vip inservice
    loadbalance policy port_8005_policy_perf
    loadbalance vip icmp-reply active
    nat dynamic 1 vlan 5
    appl-parameter http advanced-options http-par
    interface vlan 5
    ip address 10.1.90.162 255.255.255.240
    access-group input PERMIT_ACL
    nat-pool 1 10.1.90.165 10.1.90.174 netmask 255.255.255.240 pat
    service-policy input VIP
    no shutdown
    ip route 0.0.0.0 0.0.0.0 10.1.90.161
    whn initiate a request for 10.1.90.140 on port 8005, the connection gets estab with the server from serverfarm1 and that too on port 7777
    the connection should go to serverfarm6
    whn initiate a request for 10.1.90.141 on port 8005, the connection gets estab with the server from serverfarm1 and that too on port 7777-although there is no match statment in class for this port on that vip. the connection shouldnt establish
    not sure whats wrong?

    You are using the same cookie-name for all sticky groups.
    When sticky is in place. Sticky DB is checked first and the decision is made.
    Something in the following lines should do
    sticky http-cookie acecookie1 sticky-cookie-insert-7777-Perf_SOA
    cookie insert
    replicate sticky
    serverfarm SFarm1-Perf
    sticky http-cookie acecookie2 sticky-cookie-insert-8005-perf
    cookie insert
    replicate sticky
    serverfarm SFarm3
    sticky http-cookie acecookie3 sticky-cookie-insert-7777-Perf
    cookie insert
    replicate sticky
    serverfarm SFarm6
    Syed Iftekhar Ahmed

  • Load balancing host named site collection

    I am jumping into the realm of host named site collection. While the learning experience has been good, still there are some questions unanswered. Please bare patience since my questions are long.
    - I have a non host header site on port 80 that has https certificate added to IIS for supporting app store in https mode.
    - I tried to created the host name site collection using https in this default port 80 non host header web application and was greeted with error. Then i extended the web app to different  zone with port 443 . Then created the host header site collection
    with https with web application name for extended 443 one. Creation went in fine.
    - I tired to use IPs on now extended IIS site and bind certificates on that one. The site does not load. I do the same again in the default zone iss site, bind ips on that one and site loads. Now question is even though host header site collection was created
    using extended web application url , why binding had to be done on default zone IIS site?
    - Second test, i changed the authentication mode for extended, no effect on host named site collection but as soon as i changed it in default zone it reflected in host named site collection. I am confused why it needs extended zone url to create the https
    site but every change done in default zone is getting reflected on this host named site collection.
    Now for load balancing , it works fine with IP? But how to load balance these host named site collection using url. I talked with f5 team and they said i need to send some reply query string from each site. Where do i do that? Or is it even needed? 
    Accoring to this link : https://devcentral.f5.com/articles/name-based-virtual-hosting-with-ltm
    . If the site hosts an application, though, the monitor should request a dynamic page on each webserver which forces a transaction with the application to verify its health and returns a specific phrase upon success.
    For application monitoring, the recommended best practice is to create such a script specific to your application, configure the monitor Send string to call that script, and set the Receive string to match that phrase. 
    Has any one done this before? I tired to search for resource regarding this for iis or sharepoint but was not able to get anything.
    Thank you for your patience for reading such a long question. 
    Adit

    first part of question:
    Default Web Appliction in port 80: Creating https host named site collection fails.
    Extend default web application on port 443 : Https hostnamed site collection created when web application name is passed for extended web application on port 443. This means this site collection is associated with this extended web application correct? But
    all the changes made in IIS only reflect if it is made to port 80 web application. Also changing authentication scheme from Central Admin, only changes on default zone reflects on site collection not the one in extended web application? Why  if the site
    was only created on extended web application paremeter, changes on default are reflecting on it but not from extended.
    Second part of question:
    Each Hostnamed site collection when load balanced thorough f5 using IP for 3 WFE uses 3 IPs for each. This way we will run out of IPs pretty soon. I want to know if there is way to load balance these sites using Hostname or anyother paramenter through f5
    and if any body has done it? 
    https://devcentral.f5.com/articles/name-based-virtual-hosting-with-ltm link talks about sending reply string
    from application but i do not know where to set it up or how to do it? No resources in the net. Just asking if any one else has done it. 
    Adit

  • Link Load balancing - Data center query

    Dear all,
    I have a query on link load balancing. My scenario goes like this. The customer has taken web hosting services from two data centers. When an user who is accessing the servcies available in primary data center gets disconnected due to say link failure. Then the services should be available continuosly from the secondary data center. All the services provided by the primary data center should be available now from the secondary data center without any down time. What device i should go for, for doing this link load balancing. After searching a lot in the web, i found this Cisco Global site selector which does the link load balancing between data centers. I want to know whether i have ended up with the right choice? Plz give your valuable suggestions for the correct device i should use for load balancing multiple data center.

    That product can be quite good, I believe another company called F5 also makes good stuff in that arena... However, you have to remember that alot of this depends on what application you are doing on these servers. If you're running a service that only hosts static web pages, that's no problem. But, if you're going to be doing ecommerce where it needs to save the users "state" between page loads and such, that gets much more complex and you need to choose the right server software, such as Coldfusion or PHP or whatever to accomodate this too...

  • Setting up Load Balancing / Clustering in BIP installation

    Hi,
    We're upgrading Siebel 7.8 to 8.1.1.5. As part of this process, we'll be replacing the two clustered Actuate Servers with two BI Publisher installations.
    We need BIP to behave like for like compared to Actuate (clustered / load balanced) but I cannot any detailed instructions on implementing Load Balancing / Clustering of BIP anywhere.
    We use a Loadbalancer.org appliance to balance the Siebel URL - my plan is to use this to support load balancing of the Web Services across the two BIP instances. However, I also need the two BIP installations to share the same repository.
    I've come across an Oracle White Paper (http://www.oracle.com/technetwork/middleware/bi-publisher/bip-cluster-deployment-366859.pdf) that states:
    The repository is shared among different servers in the cluster
    However, looking at the installation guide for Oracle BIP 10.1.x.x.x, there are no details on how to achieve this.
    Anyone know where to find documentation explaining, in detail, how to load balance multiple BIP servers to achieve the same level of high availability as we had with Actuate?
    Thanks in advance!
    mroshaw

    http://e-docs.bea.com/wls/docs60/////adminguide/apache.html
              "Kit Chan" <[email protected]> wrote in message news:[email protected]..
              > After I have gone through the documentation of Administering the server and
              > Clustering, I still do not know where should I start with and what settings
              > I need to add. Is there any detailed document concerning setting up a
              > cluster with Apache plug-in and two WL6.0 servers?
              >
              > Can anyone please help?
              >
              > Thanks a lot.
              >
              > Kit Chan
              > [email protected]
              >
              >
              >
              

  • One-Armed Load Balancing

    Can CSS 11000 load balance multiple server farms, using different load balancing algorithms on the same ip subnet and having multiple VIPs in the one-armed configuration.
    I know this is not an ideal configuration but have to do it for a relocation project.
    Thank yoi

    yes you can.
    No need for a trunk.
    But you have to keep in mind that the CSS must see both sides of a connection.
    So, obviously the traffic from the client will hit the CSS vip, but for the server response, you have to make sure it goes back to the CSS.
    This can be done with source nating or policy routing.
    Gilles.

Maybe you are looking for

  • Events in smart forms

    Hi abapers please guide me about events in tables in smart forms Madhu

  • Two out of 16 channel of the AT-MIO-16-​E1 are not working

    Hello! I'm here again with a question. I greatly appreciate the help i previously got from you guys. I was trying to acquire analog signals from the AMUX-64T using AT-MIO-16E-1 DAQ and the labview. Everything was going perfectly, but few days ago, th

  • How to register the Solution at SAP?

    Dear experts, We get statuts VAR. Settings of Solution Manager Service Desk are made. Required to answer the question: Is this solution registered at SAP (solution must be sent to SAP): < > What steps should be run? Thanks!

  • Website/software that prevens you from logging onto the Internet

    Recently I read about a website or software that allows you to disengage from the Internet for a period of time. Do you know the URL for this site or product? Thank you.

  • Basic setting for bringing MM into SAP

    Hi I am SAP FICO consultant. I want to trying product costing in CO. So i am creating new company code in IDES client But for this some settings is needed like OBYC, plant creation, etc. I am not aware what basic things needs to be configured in MM i