Load balancing Http/https requests of SRM

Hi all,
we are on SRM 5.0 with CI and one DI , we don't have any web dispatcher for routing http/https requests.
Currently CI is flooded with all requests and DI is sitting idle no routing  is  going on.... and users are experiencing Time out expceptions ...
we  have configured SMLG  and services in SICF have group assigned...
we have BI portal where users log in and  access all SRM web applications like shopping cart, invoice....
Please suggest how to handle the load balancing of http/https requests with message server...
Thanks,
Subhash.G

Thanks

Similar Messages

  • Load balancing HTTP requests for an OC4J instance w/multiple JVMs

    Hello everyone,
    I am using OAS 10.1.3.1 and wish to load balance HTTP requests across an OC4J group of one or more OC4J instances, where each like named OC4J instance may have multiple JVMs or it may just have one JVM.
    My mod_oc4j.conf file would contain the following directives :
    Oc4jSelectMethod roundrobin:local
    Oc4jRoutingMode Static
    Oc4JMount /xyz/* xyz
    In the degenerate case, I would like to have an OC4J group with a cluster size of one, and have that one OC4J instance have two or more JVMs. I would like to be able to receive a request within my web application, determine that the JVM that has been sent the request is the wrong JVM to process the request, and then call HttpServletResponse.sendRedirect("/xyz"). Then, when the browser receives the HTTP 302 response and issues the subsequent HTTP request, have that request sent to a different JVM than the previous JVM that issued the sendRedirect().
    What I have seen is that the subsequent request is sent back to the same JVM that issued the sendRedirect(). I also call invalidate() against the HttpSession prior to calling sendRedirect(), but that does not seem to affect the behavior that I see.
    In the full blown case, I would have an OC4J group with a cluster size > 1, and each of those OC4J instances would have at least one JVM. In that case, I wish the sendRedirect() call to allow the subsequent request to be sent to any one of the OC4J instances in the group, and any one of those JVMs within all of those OC4J instances.
    Can anyone verify that my mod_oc4j mount directive is appropriate given the select method and routing mode? What else might I need to do to have a chance to have a different JVM respond to the request that results from a sendRedirect()?
    Thank you,
    Doug

    I should clarify that in the full blown environment, the OC4J instances that form a group will each be housed within a separate OAS instance that resides on its own machine.
    So ideally, a request could be inbound to say OAS instance 1 on machine A, OC4J instance AA, JVM 2, and I need to force a redirect so that the request can actually be serviced by OAS instance 3 on machine C, OC4J instance AA, JVM 1, and I need to be able to call sendRedirect() against an HttpServletResponse from within a JVM until the subsequent request from the browser, Internet Explorer in my case, is serviced by that JVM.
    Thanks,
    Doug

  • Load Balancing HTTP requests to ABAP App Servers options?

    Looking at SAP Documentations, SAP recommends to use the Web Dispatcher to load balance HTTP requests to multiply ABAP App servers. 
    My question is that the only solution? or can we use hardware such as the F5 BigIP to perform the same job?
    Any thoughts?

    In collaboration with SAP and SAP customers, F5 Networks has created a solution that delivers security, high availability, and improved performance for SAP web and portal technologies.
    By deploying F5 Networks solutions with SAP NetWeaver, enterprises extend their control over their Network and Application traffic, and ensure the fast and secure delivery of their applications.
    Benefits of F5 for SAP NetWeaver and Enterprise SOA
    u2022 Cuts SAP Enterprise Portal login time by more than half for WAN users
    u2022 Speeds document downloads
    u2022 Reduces SAP server CPU utilization by 44%
    u2022 Provides a 20x reduction in the number of SAP server-side connections
    Further details, case studies and deployment guides on;
    http://www.f5.com/solutions/applications/sap/netweaver/
    F5 certification information on SAP Website
    http://www.sap.com/partners/directories/SoftwareISVSolutions.epx?context=21B87D61C0F646A22B2A6DB254A010CA8C9C141B7529F029910FE6FF9EEEC5A701BF20EED61AC07159D98BAA068EBE1B8C5C7665EA2226374E942CF1D2A49D20AB1BFDFA1E0B68EC41E3058F04A85F105D5002CF1A11383C905D9FE5DDB951251A4B574B0BBE58309F67667A3B95877FEF85F1EF8B2C1A9F6FBA3BF5066D9534%7c01518B8BD6BF02F55A5A72E5947F2C45
    Hope this helps. Thanks

  • Weblogic 10.3.6 - Load balancing- sending duplicate requests 5 min

    Hello,
             We have configured clustering and load balancing to our integration solution as mentioned at http: //abhinavgupta3.blogspot.in/2012/02/osb-clustering-load-balancer.html
    But when ever a requests goes through load balancer and if that requests goes beyond 5 min (300Sec), then load balancer generating new request and that request is being redirected to another node.
    As per my blogging  I found there is some setting need t
    Because of this we are going to ambiguous situation.o configured at load balancer for not falling in to this situation.Its about a property called 'Idempotent'
    Please help me on this.
    Thanks,
    Satyendra

    "The datasource is created successfully from the console so there's no problem with the jar file."
    Did you also test the data source when you created it?
    - when yes then WebLogic can indeed find the derbyclient.jar as the driver org.apache.derby.jdbc.ClientDriver is part of it.
    "I specified in the weblogic.xml that the antlr.* classes should be taken from the application. Also tried this option for org.apache.derby.* classes."
    Have you only defined a
    <prefer-application-packages>
        <package-name>antlr.*</package-name>
        <package-name>org.apache.derby.*</package-name>
    </prefer-application-packages>in weblogic.xml or did you also turn on prefer-web-inf-classes?
    It is smart to start from scratch and delete all the jar files in all the directories. To make the derbyclient.jar part of the WebLogic classpath you can do the following:
    - edit setDomainEnv: When you open setDomainEnv there is an entry like "SET THE CLASSPATH". Just before - if [ "${JAVA_VENDOR}" != "BEA" ] ; then
    you can put something like: CLASSPATH=${CLASSPATH}${CLASSPATHSEP}location/derbyclient.jar
    If the class must be available on every server in a cluster, you can edit the commEnv file (located in the ${WL_HOME}/common/bin directory)
    Search for the entry "set up WebLogic Server's class path". And below the WEBLOGIC_CLASSPATH you can add something like:
    WEBLOGIC_CLASSPATH=${WEBLOGIC_CLASSPATH}${CLASSPATHSEP}location/derbyclient.jar
    Hope this helps you a little

  • How to see the Source IP Address of a client using ACE One-armed-mode to load balance HTTP proxy request

    I'm using an Ace 4710 Appliance deployed in One-Armed mode, using Source NAT to loadbalance HTTP request to a couple of Proxy servers.
    Everything is working fine, but the thing is that I can't see the Clients IP addresses on Proxy's logs, so I can't keep track of them.
    The Interfaces and Nat configs are:
    interface vlan 200
      description Server-Side-VLAN
      bridge-group 5
      nat-pool 5 10.1.1.5 10.1.1.5 netmask 255.255.255.0 pat
      service-policy input VIPS
    interface vlan 300
      description Client-Side-VLAN
      bridge-group 5
    interface bvi 5
      ip address 10.1.1.3 255.255.248.0
      description Client-Server-Virtual-Interface
    ip route 0.0.0.0 0.0.0.0 10.1.1.1
    and the policy map looks like this
    policy-map multi-match VIPS
      class Port80
        loadbalance vip inservice
        loadbalance policy Port80
        nat dynamic 5 vlan 200
    Resource assignment:
    sticky ip-netmask 255.255.255.255 address both RESOURCE-CLASS
      timeout 5
      serverfarm Service80
    Any suggestions will be appreciated,
    Thanks

    Hi Kanwal,
    Thanks for your quick reply,
    I've already tried this but it didn't work. The problem is that I don't manage the proxy servers so I rely on their skills to see the logs.
    The Proxies are Squid. Do you know if they need to do something else on the servers to see that field of the HTTP header?
    But I'll try again tomorrow and let you know how it goes.
    Thank you again.

  • Load Balance HTTPS servers with redirection

    Hello,
    I have been tasked with ACE configuration at work as the prior go-to guy for load balancing is no longer available. Trouble is, I have little idea what I’m doing when it comes to the ACE. So, forgive me if the question I have is super basic. After doing some research I put together a LB config, but its not working.
    I was trying to load balance 10 servers, split into groups of 2 using 5 VIPS (1 VIP for each group of 2 servers). The servers serve an ssl web app.
    Below is my configuration. What am I doing wrong? Does the config have any glaring errors? I've been staring at this thing on and off for a week  and searching these forums trying to figure it out.
    Any help provided will greatly appreciated.
    probe tcp probe_443
      port 443
      interval 30
      passdetect interval 5
    probe https probe_https_test
      interval 30
      passdetect interval 5
      ssl version all
      request method get url /test.html
      expect status 200 200
    rserver host QA-1.1
    ip address 10.200.162.126
    inservice
    rserver host QA-1.2
    ip address 10.200.162.127
    inservice
    rserver redirect QA-group_1_redirect_rserver
    webhost-redirection https://10.37.5.73/ 302
      inservice
    rserver host QA-2.1
    ip address 10.200.162.22
    inservice
    rserver host QA-2.2
    ip address 10.200.162.240
    inservice
    rserver redirect QA-group_2_redirect_rserver
    webhost-redirection https://10.37.5.74/ 302
      inservice
    rserver host QA-3.1
    ip address 10.200.162.181
    inservice
    rserver host QA-3.2
    ip address 10.200.162.50
    inservice
    rserver redirect QA-group_3_redirect_rserver
    webhost-redirection https://10.37.5.75/ 302
      inservice
    rserver host QA-4.1
    ip address 10.200.162.23
    inservice
    rserver host QA-4.2
    ip address 10.200.162.241
    inservice
    rserver redirect QA-group_4_redirect_rserver
    webhost-redirection https://10.37.5.76/ 302
      inservice
    rserver host QA-5.1
    ip address 10.200.162.182
    inservice
    rserver host QA-5.2
    ip address 10.200.162.51
    inservice
    rserver redirect QA-group_5_redirect_rserver
    webhost-redirection https://10.37.5.77/ 302
      inservice
    serverfarm host SF_QA-group_1_HTTPS
    failaction reassign
    predictor leastconns
    probe probe_443
    probe probe_https_test
    rserver QA-1.1 443
    inservice
    rserver QA-1. 2 443
    inservice
    serverfarm host SF_QA-group_2_HTTPS
    failaction reassign
    predictor leastconns
    probe probe_443
    probe probe_https_test
    rserver QA-2.1 443
    inservice
    rserver QA-2. 2 443
    inservice
    serverfarm host SF_QA-group_3_HTTPS
    failaction reassign
    predictor leastconns
    probe probe_443
    probe probe_https_test
    rserver QA-3.1 443
    inservice
    rserver QA-3. 2 443
    inservice
    serverfarm host SF_QA-group_4_HTTPS
    failaction reassign
    predictor leastconns
    probe probe_443
    probe probe_https_test
    rserver QA-4.1 443
    inservice
    rserver QA-4. 2 443
    inservice
    serverfarm host SF_QA-group_5_HTTPS
    failaction reassign
    predictor leastconns
    probe probe_443
    probe probe_https_test
    rserver QA-5.1 443
    inservice
    rserver QA-5. 2 443
    inservice
    serverfarm redirect SF_ QA-group_1_REDIRECT
    rserver QA-group_1_redirect_rserver
    inservice
    serverfarm redirect SF_ QA-group_2_REDIRECT
    rserver QA-group_2_redirect_rserver
    inservice
    serverfarm redirect SF_ QA-group_3_REDIRECT
    rserver QA-group_3_redirect_rserver
    inservice
    serverfarm redirect SF_ QA-group_4_REDIRECT
    rserver QA-group_4_redirect_rserver
    inservice
    serverfarm redirect SF_ QA-group_5_REDIRECT
    rserver QA-group_5_redirect_rserver
    inservice
    sticky ip-netmask 255.255.255.255 address source SRC_ QA-group_1_STICKY
    serverfarm SF_ QA-group_1_HTTPS
    timeout 30
    replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_ QA-group_2_STICKY
    serverfarm SF_ QA-group_2_HTTPS
    timeout 30
    replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_ QA-group_3_STICKY
    serverfarm SF_ QA-group_3_HTTPS
    timeout 30
    replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_ QA-group_4_STICKY
    serverfarm SF_ QA-group_4_HTTPS
    timeout 30
    replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_ QA-group_5_STICKY
    serverfarm SF_ QA-group_5_HTTPS
    timeout 30
    replicate sticky
    class-map match-all QA-group_1_HTTP
    3 match virtual-address 10.37.5.73 tcp eq www
    class-map match-all QA-group_1_HTTPS
    3 match virtual-address 10.37.5.73 tcp eq https
    class-map match-all QA-group_2_HTTP
    3 match virtual-address 10.37.5.74 tcp eq www
    class-map match-all QA-group_2_HTTPS
    3 match virtual-address 10.37.5.74 tcp eq https
    class-map match-all QA-group_3_HTTP
    3 match virtual-address 10.37.5.75 tcp eq www
    class-map match-all QA-group_3_HTTPS
    3 match virtual-address 10.37.5.75 tcp eq https
    class-map match-all QA-group_4_HTTP
    3 match virtual-address 10.37.5.76 tcp eq www
    class-map match-all QA-group_4_HTTPS
    3 match virtual-address 10.37.5.76 tcp eq https
    class-map match-all QA-group_5_HTTPS
    3 match virtual-address 10.37.5.77 tcp eq www
    class-map match-all QA-group_5_HTTPS
    3 match virtual-address 10.37.5.77 tcp eq https
    class-map type management match-any remote-management
    2 match protocol http any
    3 match protocol https any
    4 match protocol icmp any
    5 match protocol snmp any
    6 match protocol ssh any
    policy-map type management first-match remote-access
    class remote-management
    permit
    policy-map type loadbalance first-match QA-group_1_REDIRECT
    class class-default
    serverfarm SF_ QA-group_1_REDIRECT
    policy-map type loadbalance first-match QA-group_2_REDIRECT
    class class-default
    serverfarm SF_ QA-group_2_REDIRECT
    policy-map type loadbalance first-match QA-group_3_REDIRECT
    class class-default
    serverfarm SF_ QA-group_3_REDIRECT
    policy-map type loadbalance first-match QA-group_4_REDIRECT
    class class-default
    serverfarm SF_ QA-group_4_REDIRECT
    policy-map type loadbalance first-match QA-group_5_REDIRECT
    class class-default
    serverfarm SF_ QA-group_5_REDIRECT
    policy-map multi-match SERVICE_VIPS
    class QA-group_1_HTTPS
        loadbalance vip inservice
        loadbalance policy HTTPS_ QA-group_1_HTTPS _L7_BALANCED
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 25
      class QA-group_1_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_1_REDIRECT
    class QA-group_2_HTTPS
        loadbalance vip inservice
        loadbalance policy HTTPS_ QA-group_2_HTTPS _L7_BALANCED
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 25
      class QA-group_2_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_2_REDIRECT
    class QA-group_3_HTTPS
        loadbalance vip inservice
        loadbalance policy HTTPS_ QA-group_3_HTTPS _L7_BALANCED
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 25
      class QA-group_3_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_3_REDIRECT
    class QA-group_4_HTTPS
        loadbalance vip inservice
        loadbalance policy HTTPS_ QA-group_4_HTTPS _L7_BALANCED
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 25
      class QA-group_4_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_4_REDIRECT
    class QA-group_5_HTTPS
        loadbalance vip inservice
        loadbalance policy HTTPS_ QA-group_4_HTTPS _L7_BALANCED
        loadbalance vip icmp-reply
        nat dynamic 1 vlan 25
      class QA-group_5_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_4_REDIRECT
    interface vlan 25
      ip address 10.37.5.72 255.255.255.0
        access-group input everyone
      service-policy input remote-access
      service-policy input SERVICE_VIPS
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.37.5.1

    Fnu,
    Thank you so much for your reply.
    At this point I can get to the real server IP's via ping and https in a browser from my PC. I can also ping the gateway and all the real server IP's from the ACE context i'm working on. However, the VIPS are not working. When I attempt to use one of the VIPS in the browser, the request times out. When I issue the command ":show service-policy"  I see a hit count (which increments every time I try and reach the VIP via the browser) but the dropped counter is equal to the hit counter. I will paste the running config from the context I’m working in along with the output from the show service-policy command.
    Any suggestions on how I can get this working would be greatly appreciated.
    csc#  show run
    Generating configuration....
    access-list Servers line 3 extended permit tcp any any eq https
    access-list Servers line 5 extended permit tcp any any eq www
    access-list everyone line 1 extended permit ip any any
    access-list everyone line 2 extended permit icmp any any
    probe tcp probe_443
      port 443
      interval 30
      passdetect interval 5
    rserver host QA-1.1
      ip address 10.37.5.111
      inservice
    rserver host QA-1.2
      ip address 10.37.5.88
      inservice
    rserver host QA-2.1
      ip address 10.37.5.84
      inservice
    rserver host QA-2.2
      ip address 10.37.5.89
      inservice
    rserver host QA-3.1
      ip address 10.37.5.85
      inservice
    rserver host QA-3.2
      ip address 10.37.5.90
      inservice
    rserver host QA-4.1
      ip address 10.37.5.86
      inservice
    rserver host QA-4.2
      ip address 10.37.5.81
      inservice
    rserver host QA-5.1
      ip address 10.37.5.87
      inservice
    rserver host QA-5.2
      ip address 10.37.5.92
      inservice
    rserver redirect QA-group_1_redirect_rserver
      webhost-redirection https://10.37.5.93/ 302
      inservice
    rserver redirect QA-group_2_redirect_rserver
      webhost-redirection https://10.37.5.94/ 302
      inservice
    rserver redirect QA-group_3_redirect_rserver
      webhost-redirection https://10.37.5.95/ 302
      inservice
    rserver redirect QA-group_4_redirect_rserver
      webhost-redirection https://10.37.5.96/ 302
      inservice
    rserver redirect QA-group_5_redirect_rserver
      webhost-redirection https://10.37.5.97/ 302
      inservice
    serverfarm host SF_QA-group_1_HTTPS
      failaction reassign
      predictor leastconns
      probe probe_443
      rserver QA-1.1 443
        inservice
      rserver QA-1.2 443
        inservice
    serverfarm redirect SF_QA-group_1_REDIRECT
      rserver QA-group_1_redirect_rserver
        inservice
    serverfarm host SF_QA-group_2_HTTPS
      failaction reassign
      predictor leastconns
      probe probe_443
      rserver QA-2.1 443
        inservice
      rserver QA-2.2 443
        inservice
    serverfarm redirect SF_QA-group_2_REDIRECT
      rserver QA-group_2_redirect_rserver
        inservice
    serverfarm host SF_QA-group_3_HTTPS
      failaction reassign
      predictor leastconns
      probe probe_443
      rserver QA-3.1 443
        inservice
      rserver QA-3.2 443
        inservice
    serverfarm redirect SF_QA-group_3_REDIRECT
      rserver QA-group_3_redirect_rserver
        inservice
    serverfarm host SF_QA-group_4_HTTPS
      failaction reassign
      predictor leastconns
      probe probe_443
      rserver QA-4.1 443
        inservice
      rserver QA-4.2 443
        inservice
    serverfarm redirect SF_QA-group_4_REDIRECT
      rserver QA-group_4_redirect_rserver
        inservice
    serverfarm host SF_QA-group_5_HTTPS
      failaction reassign
      predictor leastconns
      probe probe_443
      rserver QA-5.1 443
        inservice
      rserver QA-5.2 443
        inservice
    serverfarm redirect SF_QA-group_5_REDIRECT
      rserver QA-group_5_redirect_rserver
        inservice
    serverfarm host SF_QA-group_HTTPS
    serverfarm host SF_QA-group__HTTPS
    sticky ip-netmask 255.255.255.255 address source SRC_QA-group_1_STICKY
      serverfarm SF_QA-group_1_HTTPS
      timeout 30
      replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_QA-group_2_STICKY
      serverfarm SF_QA-group_2_HTTPS
      timeout 30
      replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_QA-group_3_STICKY
      serverfarm SF_QA-group_3_HTTPS
      timeout 30
      replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_QA-group_4_STICKY
      serverfarm SF_QA-group_4_HTTPS
      timeout 30
      replicate sticky
    sticky ip-netmask 255.255.255.255 address source SRC_QA-group_5_STICKY
      serverfarm SF_QA-group_5_HTTPS
      timeout 30
      replicate sticky
    class-map match-all QA-group_1_HTTP
      3 match virtual-address 10.37.5.93 tcp eq www
    class-map match-all QA-group_1_HTTPS
      3 match virtual-address 10.37.5.93 tcp eq https
    class-map match-all QA-group_2_HTTP
      3 match virtual-address 10.37.5.94 tcp eq www
    class-map match-all QA-group_2_HTTPS
      3 match virtual-address 10.37.5.94 tcp eq https
    class-map match-all QA-group_3_HTTP
      3 match virtual-address 10.37.5.95 tcp eq www
    class-map match-all QA-group_3_HTTPS
      3 match virtual-address 10.37.5.95 tcp eq https
    class-map match-all QA-group_4_HTTP
      3 match virtual-address 10.37.5.96 tcp eq www
    class-map match-all QA-group_4_HTTPS
      3 match virtual-address 10.37.5.76 tcp eq https
    class-map match-all QA-group_5_HTTP
      3 match virtual-address 10.37.5.97 tcp eq www
    class-map match-all QA-group_5_HTTPS
      3 match virtual-address 10.37.5.97 tcp eq https
    class-map type management match-any remote-management
      2 match protocol http any
      3 match protocol https any
      4 match protocol icmp any
      5 match protocol snmp any
      6 match protocol ssh any
    policy-map type management first-match remote-access
      class remote-management
        permit
    policy-map type loadbalance first-match QA-group_1_REDIRECT
      class class-default
    policy-map type loadbalance first-match QA-group_2_REDIRECT
      class class-default
        serverfarm SF_QA-group_2_REDIRECT
    policy-map type loadbalance first-match QA-group_3_REDIRECT
      class class-default
        serverfarm SF_QA-group_3_REDIRECT
    policy-map type loadbalance first-match QA-group_4_REDIRECT
      class class-default
        serverfarm SF_QA-group_4_REDIRECT
    policy-map type loadbalance first-match QA-group_5_REDIRECT
      class class-default
        serverfarm SF_QA-group_5_REDIRECT
    policy-map multi-match SERVICE_VIPS
      class QA-group_1_HTTPS
        loadbalance vip inservice
        loadbalance policy QA-group_1_REDIRECT
        loadbalance vip icmp-reply
      class QA-group_1_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_1_REDIRECT
      class QA-group_2_HTTPS
        loadbalance vip inservice
        loadbalance policy QA-group_2_REDIRECT
        loadbalance vip icmp-reply
      class QA-group_2_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_2_REDIRECT
      class QA-group_3_HTTPS
        loadbalance vip inservice
        loadbalance policy QA-group_3_REDIRECT
        loadbalance vip icmp-reply
      class QA-group_3_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_3_REDIRECT
      class QA-group_4_HTTPS
        loadbalance vip inservice
        loadbalance policy QA-group_4_REDIRECT
        loadbalance vip icmp-reply
      class QA-group_4_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_4_REDIRECT
      class QA-group_5_HTTPS
        loadbalance vip inservice
        loadbalance policy QA-group_5_REDIRECT
        loadbalance vip icmp-reply
      class QA-group_5_HTTP
        loadbalance vip inservice
        loadbalance policy QA-group_5_REDIRECT
    interface vlan 25
      ip address 10.37.5.98 255.255.255.0
      access-group input everyone
      service-policy input remote-access
      service-policy input SERVICE_VIPS
      no shutdown
    ip route 0.0.0.0 0.0.0.0 10.37.5.1
    csc# show service-policy SERVICE_VIPS
    Status     : ACTIVE
    Interface: vlan 25
      service-policy: SERVICE_VIPS
        class: QA-group_1_HTTPS
          loadbalance:
            L7 loadbalance policy: QA-group_1_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : ENABLED
            VIP state: OUTOFSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: DISABLED
            curr conns       : 0         , hit count        : 122      
            dropped conns    : 122      
            conns per second    : 0        
            client pkt count : 122       , client byte count: 6164               
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_1_HTTP
          loadbalance:
            L7 loadbalance policy: QA-group_1_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : DISABLED
            VIP state: OUTOFSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: DISABLED
            curr conns       : 0         , hit count        : 58       
            dropped conns    : 58       
            conns per second    : 0        
            client pkt count : 58        , client byte count: 3628               
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_2_HTTPS
          loadbalance:
            L7 loadbalance policy: QA-group_2_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : ENABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 13       
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 74        , client byte count: 7648               
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_2_HTTP
          loadbalance:
            L7 loadbalance policy: QA-group_2_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : DISABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 3        
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 12        , client byte count: 1398               
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_3_HTTPS
          loadbalance:
            L7 loadbalance policy: QA-group_3_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : ENABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 34       
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 201       , client byte count: 23495              
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_3_HTTP
          loadbalance:
            L7 loadbalance policy: QA-group_3_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : DISABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 5        
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 20        , client byte count: 1907               
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_4_HTTPS
          loadbalance:
            L7 loadbalance policy: QA-group_4_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : ENABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 0        
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 0         , client byte count: 0                  
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_4_HTTP
          loadbalance:
            L7 loadbalance policy: QA-group_4_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : DISABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 2        
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 8         , client byte count: 697                
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_5_HTTPS
          loadbalance:
            L7 loadbalance policy: QA-group_5_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : ENABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 0        
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 0         , client byte count: 0                  
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        
        class: QA-group_5_HTTP
          loadbalance:
            L7 loadbalance policy: QA-group_5_REDIRECT
            VIP Route Metric     : 77
            VIP Route Advertise  : DISABLED
            VIP ICMP Reply       : DISABLED
            VIP State: INSERVICE
            VIP DWS state: DWS_DISABLED
            Persistence Rebalance: ENABLED
            curr conns       : 0         , hit count        : 0        
            dropped conns    : 0        
            conns per second    : 0        
            client pkt count : 0         , client byte count: 0                  
            server pkt count : 0         , server byte count: 0                  
            conn-rate-limit      : 0         , drop-count : 0        
            bandwidth-rate-limit : 0         , drop-count : 0        
          compression:
            bytes_in  : 0                          bytes_out : 0                  
            Compression ratio : 0.00%
                    Gzip: 0               Deflate: 0        
          compression errors:
            User-Agent  : 0               Accept-Encoding    : 0        
            Content size: 0               Content type       : 0        
            Not HTTP 1.1: 0               HTTP response error: 0        
            Others      : 0        

  • Load balancing http server

    Hi There,
    I want to implement a load balancer (linux virtual server) into our htmldb configuration. We currently run the http server on the same machine running oracle/htmldb. I want to split this out and use 2 seperate machines running http server behind the load balancer, both these http servers will be pointing to the same oracle database.
    The load balancer will not be using persistent sessions, therefore client requests will be sent evenly to each http server. My main question is, will I have problems with user sessions, or (as I imagine) is all the session information written to the database ?
    Thanks in advance.
    Tom

    Bill,
    There are a few things you need to consider
    1: Availability of http server. ie how many are you going to have. How are you going to access them. Load balancer, DNS round robin. These should be on different servers to the database.
    2: How are the http servers going to connect. For RAC you'll need to specify TNS connections. I'd also recommend that you look at using application partitioning using services in the RAC cluster. That way you can have Apex using a subset of nodes in the cluster .
    3: If you are going down the RAC path then I'd assume availability is a priority. You''ll need to think of standby configuration. Again this is possible with TNS configuration.
    You can do it all with Apex. RAC and Standby but it will take planning and testing.

  • Using ACE to load balance HTTP/S traffic between client & proxy server using tcp 8080

    Folks,
    I have a scenario where ACE is in load balancing connections to a bunch of Websense servers in a one-armed topology.  ACE presents a single VIP to web browser clients and each client's browser proxy configuration is populated with the VIP DNS name.  Traffic then gets load balanced between the Websense servers.  The problem arises due to Websense requiring the 'X-Forwarded-For' HTTP header in order to obtain the source IP of the client.  
    ACE inserts this header into the standard HTTP 'proxied' traffic but doing this for HTTPS traffic has required the configuration of the ACE SSL proxy client server.
    So the problem I have is this:
    How to configure ACE to load balance both HTTP & HTTPS applications using a single VIP and tcp port number ie tcp 8080
    The ACE hardware being used is ACE20-MOD-K9  -  MODULE
    I have attempted to use a L7 class map to match all ciphers and attach this to a L7 Policy-Map but the documentation highlights the fact the 'match cipher' configuration is only available on the ACE appliance.  
    I believe I am on the correct track.  The HTTPS traffic must be identified and used to match against PolicyA and HTTP traffic matched against PolicyB
    I'm looking for ideas!  I'm hopeful someone must have solved this problem previously!!
    Regards,
    Simon

    Hi Simon,
    The classification has to work on different ports. Whether client types http or https doesn't matter to client. His request will reach VIP which will classify the traffic based on port, protocol first and then it can look into further detail to send the traffic to appropriate serverfarm.
    You can class-map match-any xxxxx
    2 match virtual-address x.x.x.x tcp any
    and then you configure further classification on the basis of L7 like  url, header etc. 
    But again, you will still need SSL termination on ACE.
    Regards,
    Kanwal
    Note: Please mark answers if they are helpful.

  • Load Balance https based on url

    I am trying to configure ACE 4710 to load balance base on the URL, If it matches the specific URL ( /456/ ), the traffic will be sent to server farm 456 else the traffic will be sent to server farm 123.
    I attached an image of the topology.
    Ace Config:
    rserver host SRV01_123
      ip address 192.168.1.101
      inservice
    rserver host SRV02_123
      ip address 192.168.1.102
      inservice
    rserver host SRV01_456
      ip address 192.168.1.111
      inservice
    serverfarm host farm_123
      rserver SRV01_123
        inservice
      rserver SRV02_123
        inservice
    serverfarm host farm_456
      rserver SRV01_456
        inservice
    class-map match-all VIP_Application
      2 match virtual-address 192.168.1.10 tcp eq https
    class-map type http loadbalance match-all L7_server_456
      2 match http url /456/
    policy-map type loadbalance http first-match LB_Application
      class L7_server_456
        serverfarm farm_456
      class class-default
        serverfarm farm_123
    policy-map multi-match ServerGroup1_PM
      class VIP_Application
        loadbalance vip inservice
        loadbalance policy LB_Application
        loadbalance vip icmp-reply
    interface vlan 70
      bridge-group 1
      no shutdown
    interface vlan 700
      bridge-group 1
      service-policy input ServerGroup1_PM
      no shutdown
    Thanks

    Hi John,
    If you want to do the offload in the ACE also called SSL termination, it is a two step process:
    1- You need to upload your certificate and key to the ACE using FTP or one of the available methods.
    2- Create the the SSL proxy service where you add these two files and finally add this service under the policy-multimatch for the VIP in question.
    You also need to decide whether you want to keep your server listening in the encrypted port (that would be a two way encryption process called End-to-End SSL) or you can change the port to 80 and leave all the decyption process to the ACE (this would be transparent to the client, the site will show up as HTTPS all the time).
    Here you can take a look at the SSL termination process (using clear text port in the backend servers).
    Oficial Configuration Example
    http://www.cisco.com/en/US/partner/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA4_1_0/configuration/ssl/guide/terminat.html
    Cisco Wiki Example
    http://docwiki.cisco.com/wiki/SSL_Termination_on_the_Cisco_Application_Control_Engine_Without_an_Existing_Chained_Certificate_and_Key_in_Routed_Mode_Configuration_Example
    HTH
    Pablo

  • Load balancer vs. Request Management

    I am wondering what are the functionalities RM provides however load balancer. I was thinking that health based routing RM can provide however load balancer can't. But it seems that load balancer
    can also provide this functionality , refer below link.<o:p></o:p>
    http://social.msdn.microsoft.com/Forums/en-US/6be22098-bce8-4709-9403-4599b9599973/health-based-load-balancing?forum=sharepointadmin<o:p></o:p>
    Could anyone please tell me what is a additional functionalities RM can provide compare to load balancer?
    Regards Restless Spirit

    As far i know RM will serve the same purpose of load balance with much more flexible rule for routing, e.g request throttling based routing, you can build more flexible routing logic based on various param available in RM.
    You can take a look at this:-
    http://social.technet.microsoft.com/wiki/contents/articles/16177.request-management-in-sharepoint-2013.aspx
    Mark ANSWER if this reply resolves your query, If helpful then VOTE HELPFUL
    INSQLSERVER.COM
    Mohammad Nizamuddin

  • Load balancing over rmi requests

    On a cluster of ias10g (9041), Is it possible that all requests over RMI use a "virtual" hostname and port which directs them to a load balancing mechanism which then determines which of the operational OC4J instances should process this request?

    Does anyone know anything on this question?

  • CSS - load balance https on different port no

    Hi,
    Need to create a rule for access :
    https://1.1.1.1:7000 (Front End), but the server only open port 7000, how can i create a rule for that?
    FYI, my CSS do not have any SSL license..is that workable??
    Thanks..

    you have both 7000 frontend and backend.
    service web-7000
    ip address x.x.x.x
    port 7000
    active
    owner MyCompany
    content https-7000
    vip address x.x.x.x
    port 7000
    add service web-7000
    active
    Use the 'port' command to select the frontend and backend port.
    You can change it to whatever you want and it does not need to match.
    Gilles.

  • Two load balanced server sending requests to external system on different protocol

    Hi,
    I have two loadbalanced OEG servers (server A and server B) with same endpoint configurations in envsetting.props. But when requesting the service, it is creting different URI in both servers. In one of server (server A)it sets URI with following details :
    DEBUG   30/Mar/2015:07:29:34.356 [92b0e940]     Set host='abc.tdc.dk'
    DEBUG   30/Mar/2015:07:29:34.356 [92b0e940]     Set port='80'
    DEBUG   30/Mar/2015:07:29:34.356 [92b0e940]     Set scheme='https'
    and fails with following error : ERROR   30/Mar/2015:07:29:34.370 [92b0e940]         [SSL_connect, 0x1220]: error - SSLv2/v3 read server hello A.
    However another server (server B),sets URI as :
    DEBUG   30/Mar/2015:07:29:34.356 [92b0e940]     Set host='abc.tdc.dk'
    DEBUG   30/Mar/2015:07:29:34.356 [92b0e940]     Set port='80'
    DEBUG   30/Mar/2015:07:29:34.356 [92b0e940]     Set scheme='http'
    and successfully processes the request.
    So can you please help here to know even if we are using same endpoints configuration (abc.tdc.dk ) and port (80) on both the servers , then why the URL is set as http on one of server and https on another.
    Thanks !!!
    Akshay

    Hi
    Thanks for immediate respose. I tried the ping/acknowledgement example in the biginning itself. It doesn't work. I also tried by changing the agents ( to respective values suitable for my systems) of that example. Then also it failed. The error in that case also same. The message will not propogate from the out going agent.

  • Best way for HTTP load balancing in OSB

    Hi everybody,
    We have setup an OSB cluster and we need to load balance HTTP requests across managed servers. Looking for info about load balancing in OSB I found that there are mainly two options: using a hardware load balancer or a software solution like Weblogic HttpClusterServlet. At the moment we have no hardware balancer available so we will have to take the software option. I found some articles about configuring HttpClusterServlet like http://redstack.wordpress.com/2010/12/20/using-weblogic-as-a-load-balancer.
    But I have a question about this configuration. If we use a managed server as an HTTP proxy that balances requests between OSB managed servers, what would happen if this server goes down? I think one of the main goals of a clustered deployment is avoiding a single point of failure but with that setup all requests would depend on the availability of the proxy managed server.
    Could you recommend us a setup for implementing load balancing in OSB?
    Thank you in advance,
    Daniel.

    Load balancing in a cluster for http requests can be achieved using atleast 4 different ways:
    (1)- use a hardware load balancer like F5 BigIP LTM
    (2)- use a web server with weblogic plugin to frontend the cluster
    (3)- use weblogic with HTTPClusterServlet
    (4)- use DNS round robin - this works if you have managed servers running on 2 machines (say mach1, mach2) but on the same port. HTTP clients use hostname 'mach' to access the URL's and the dns does a round robin name resolution of mach to mach 1 and mach2 IP addresses..
    All the options except (1) achieve only load balancing and not auto failover on all instances.. Hardware load balancers has the extra feature of probing [ sending periodic pings to the targets] , by which it can detect whether the target resource is alive and if not send the traffic to other nodes which are alive.. this is why hardware load balancers are worth their investment..
    other options may work if client is coded to do retrying on failure.. so on 2nd or subsequent attempt, the routing is done to the machine which is alive..
    For options (1),(2) and (3), you also need some redundancy of load balancing device ( web server, weblogic or hardware load balancer) to prevent single point of failure.. Hardware load balancers are usually deployed in redundant pairs to achieve this..
    Edited by: atheek1 on 22/11/2011 15:31

  • ACE HTTP requests

    Hello,
    I currently have a Serverfarm consisting of 6 Servers Load Balancing HTTP requests (Port 80) from the VIP to the Real Servers.
    I now have a requirement to load balance another application on the same Real Servers  using the same VIP however the URL to be used is using Port 1880 within HTTP.
    http://10.10.90.1:1880/Service.asmx
    Any advice on how to configure this on the ACE would be appreciated.
    thanks
    Ian.

    Ian,
    Maybe something like this:
    policy-map multi-match int56
      class VIP_Plumtree_1880
        loadbalance vip inservice
        loadbalance policy VIP_WEB-l7slb_1880
        loadbalance vip icmp-reply
    class-map match-all VIP_WEB_1880
      2 match virtual-address 10.10.90.1 tcp eq 1880
    class-map type http loadbalance match-all MATCH-URL-1880
      2 match http url /Service.asmx.*
    sticky ip-netmask 255.255.255.255 address source Sticky_Group_WEB_1880
      serverfarm SF_WEB_1880
      replicate sticky
    policy-map type loadbalance first-match VIP_WEB-l7slb_1880
      class MATCH-URL-1880
        sticky-serverfarm Sticky_Group_WEB_1880
      class class-default
        sticky-serverfarm Sticky_Group_WEB_1880
    serverfarm host SF_WEB_1880
      description WEB1&2
      rserver RS_WEB1 1880
        conn-limit max 4000000 min 4000000
        inservice
      rserver RS_WEB2 1880
        conn-limit max 4000000 min 4000000
        inservice
    Jorge

Maybe you are looking for

  • How to get max date in variable using  dynamic query

    Hi, the following code gets all dates from sourcetable i want only max date , so i thought max function can be added and it will work but still i have to create a table for one value(scalar) can get it in any other effeciant way. declare TYPE date_st

  • Non-Understandable characters in InDesign CS4

    The title text occurred in InDesign has been converted as understandable characters when we do PS to PDF. On a particular page the title text alone has been converted as non-understandable characters. The next time when we do PS to PDF, the actual ch

  • Start and Stop ASM in a Standalone Environment

    Hi, I have just installed 11gR2 Grid Infrastructure and have ASM up and running. Q1. How do I shut ASM down cleanly ? So far I have shutdown the +ASM instance shutdown the listener however I still appear to have a number of processes running grid1   

  • Random Chapter

    Does anyone know how to create a menu item that when selected will make the DVD play chapters in a random order? I've seem a DVD that does this but I don't know how they did it and I'd like to put something like that into my own productions. Thanks

  • Apple care and Lion upgrade

    Hello everyone I've been using my iMac 27" i5 for 3-4 months now, it doesn't run so smooth like it used to when I switched it on for the first time. I don't know what causes the lag but I heard that temporary files/old unused Safari files cause this