MaskFormatter stops allowing input

i need a MaskFormatter which allows the user ot input time in the format hh:mm. features:
user should be able to conveniently type four digites without having to press the ":" key
the value of the JFormattedTextfield should always be of type date, never string
the problem: once i set a value, the textfield doesn't allow input anymore. here's an example:
import java.awt.Dimension;
import java.awt.FlowLayout;
import java.awt.event.ActionEvent;
import java.awt.event.ActionListener;
import java.text.ParseException;
import java.text.SimpleDateFormat;
import java.util.Date;
import javax.swing.JButton;
import javax.swing.JFormattedTextField;
import javax.swing.JFrame;
import javax.swing.text.MaskFormatter;
public class TimeFormatter extends MaskFormatter {
     // set mask and placeholder
     public TimeFormatter() {
          try {
               setMask("##:##");
               setPlaceholderCharacter('0');
               setAllowsInvalid(false);
               setOverwriteMode(true);
          } catch (ParseException e) {
               e.printStackTrace();
     @Override
     public Object stringToValue(String string) throws ParseException {
          SimpleDateFormat df = new SimpleDateFormat("HH:mm");
          if( string == null)
               string = "00:00";
          return df.parse(string);
     @Override
     public String valueToString(Object value) throws ParseException {
          SimpleDateFormat df = new SimpleDateFormat("HH:mm");
          if( value == null)
               value = new Date( 0);
          return df.format( (Date) value);
     public static void main(String[] args) throws Exception {
          // textfield 1: create formatter and textfield
          final MaskFormatter formatter = new TimeFormatter();
//          formatter.setValueClass(java.util.Date.class);
          final JFormattedTextField tf1 = new JFormattedTextField( formatter);
          tf1.setPreferredSize( new Dimension( 50, 22));
          // set initial value
          tf1.setValue( new Date());
          // textfield 2: create formatter and textfield
          final JFormattedTextField tf2 = new JFormattedTextField( formatter);
          tf1.setPreferredSize( new Dimension( 50, 22));
          // no initial value
          // tf1.setValue( new Date());
          // button to show current value
          JButton bt = new JButton("Show Value");
          bt.addActionListener(new ActionListener() {
               public void actionPerformed(ActionEvent e) {
                    System.out.println("value 1 = " + tf1.getValue() + ", value 2 = " + tf2.getValue());
                    System.out.println("value 1 = " + tf1.getText() + ", value 2 = " + tf2.getText());
                    // System.out.println("value class: " + formatter.getValueClass());
          // main frame
          JFrame f = new JFrame();
          f.getContentPane().setLayout(new FlowLayout());
          f.getContentPane().add(tf1);
          f.getContentPane().add(tf2);
          f.getContentPane().add(bt);
          f.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
          f.pack();
          f.setSize(300, 100);
          f.setVisible(true);
}you see, that you can't edit the first textfield. it has a value set (current date). however, you can edit the 2nd textfield, but once that field loses the focus, you can't edit that anymore either.
does anyone know what's happening and have a solution?

you can lock this, i've solved it.
however, since probably more people will run into this issue, here's a quick solution:
import java.awt.Dimension;
import java.awt.FlowLayout;
import java.awt.event.ActionEvent;
import java.awt.event.ActionListener;
import java.text.ParseException;
import java.text.SimpleDateFormat;
import java.util.Date;
import javax.swing.JButton;
import javax.swing.JFormattedTextField;
import javax.swing.JFrame;
import javax.swing.text.MaskFormatter;
public class TimeFormatter extends MaskFormatter {
     // set mask and placeholder
     public TimeFormatter() {
          try {
               setMask("##:##");
               setPlaceholderCharacter('0');
               setAllowsInvalid(false);
               setOverwriteMode(true);
          } catch (ParseException e) {
               e.printStackTrace();
     @Override
     public Object stringToValue(String string) throws ParseException {
          return new MyDate( string);
     @Override
     public String valueToString(Object value) throws ParseException {
          if( value == null)
               return new MyDate().toString();
          return ((MyDate) value).toString();
     public static void main(String[] args) throws Exception {
          // textfield 1: create formatter and textfield
          final MaskFormatter formatter = new TimeFormatter();
          final JFormattedTextField tf1 = new JFormattedTextField( formatter);
          tf1.setPreferredSize( new Dimension( 50, 22));
          // set initial value
          tf1.setValue( new MyDate());
          // textfield 2: create formatter and textfield
          final JFormattedTextField tf2 = new JFormattedTextField( formatter);
          tf1.setPreferredSize( new Dimension( 50, 22));
          // no initial value
          // tf1.setValue( new Date());
          // button to show current value
          JButton bt = new JButton("Show Value");
          bt.addActionListener(new ActionListener() {
               public void actionPerformed(ActionEvent e) {
                    System.out.println("value 1 = " + tf1.getValue() + ", value 2 = " + tf2.getValue());
                    System.out.println("value 1 = " + tf1.getText() + ", value 2 = " + tf2.getText());
                    // System.out.println("value class: " + formatter.getValueClass());
          // main frame
          JFrame f = new JFrame();
          f.getContentPane().setLayout(new FlowLayout());
          f.getContentPane().add(tf1);
          f.getContentPane().add(tf2);
          f.getContentPane().add(bt);
          f.setDefaultCloseOperation(JFrame.EXIT_ON_CLOSE);
          f.pack();
          f.setSize(300, 100);
          f.setVisible(true);
     public static class MyDate extends Date {
          public MyDate() {
               super();
          public MyDate( String time) {
               super();
               try {
                    setTime( new SimpleDateFormat("HH:mm").parse(time).getTime());
               } catch (ParseException e) {
                    e.printStackTrace();
                    setTime( 0);
          @Override
          public String toString() {
               SimpleDateFormat df = new SimpleDateFormat("HH:mm");
               return df.format( getTime());
}the problem: you mustn't use Date as an object of the formatter.
the reason: Date doesn't have a constructor that allows a string specified in "HH:mm" format. new Date("00:00") throws an
IllegalArgumentException()
in Date's
public static long parse(String s)
During text input the parser is called from Date's String parameterized constructor:
MaskFormatter's stringToValue(String value, boolean completeMatch)
calls
DefaultFormatter's stringToValue(String string)
which contains:
cons = vc.getConstructor(new Class[] { String.class });
return cons.newInstance(new Object[] { string });
and the instantiation of Date( "00:00") fails because the above mentioned IllegalArgumentException()
In short: a given MUST for the MaskFormatter is, that the used object must have a valid constructor which allows a String parameter.

Similar Messages

  • Cisco 1811W stopped allowing wireless connection of domain laptops

    I have a Cisco 1811W that after several years in service suddenly stopped allowing any wireless connection to laptops on the domain. It allows hard wired connections and devices that are just using the wireless hot spot like iPads and Iphones but not devices on the domain. These same laptops connect wirelessly without issue at our other facilities which use the same hardware.
    Here is the config file...
    Here is the config file of the router in question...
    router#show run
    Building configuration...
    Current configuration : 11776 bytes
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec localtime show-timezone year
    service password-encryption
    hostname xxx
    boot-start-marker
    boot-end-marker
    logging message-counter syslog
    logging buffered 4096
    no logging console
    enable secret 5 xxxx
    aaa new-model
    aaa authentication login default local
    aaa authorization exec default local
    aaa session-id common
    crypto pki trustpoint TP-self-signed-1083484987
    enrollment selfsigned
    subject-name cn=IOS-Self-Signed-Certificate-1083484987
    revocation-check none
    rsakeypair TP-self-signed-xxxx
    dot11 syslog
    dot11 ssid xxxx
    vlan 44
    authentication open
    authentication key-management wpa
    wpa-psk ascii 7
    dot11 ssid xxxx
    vlan 144
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7
    ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address xxx.xxx.xxx.xxx
    ip dhcp excluded-address xxx.xxx.xxx.xxx
    ip dhcp excluded-address xxx.xxx.xxx.xxx
    ip dhcp pool xxx-LAN
    networkxxx.xxx.xxx.xxx 255.255.255.0
    domain-name xxxx
    dns-server xxx.xxx.xxx.xxx
    default-router xxx.xxx.xxx.xxx
    lease 0 2
    ip dhcp pool VLAN44
    network xxx.xxx.xxx.xxx 255.255.255.0
    default-router xxx.xxx.xxx.xxx
    domain-name xxxx
    dns-server xxx.xxx.xxx.xxx
    lease 4
    ip dhcp pool VLAN144
    network xxx.xxx.xxx.xxx 255.255.255.0
    default-router xxx.xxx.xxx.xxx
    domain-name xxxx
    dns-server 12.127.16.67 12.127.16.68
    lease 4
    ip cef
    ip domain name xxxx
    ip name-server xxx.xxx.xxx.xxx
    ip name-server xxx.xxx.xxx.xxx
    ip inspect tcp reassembly queue length 24
    ip inspect name IPFW tcp timeout 3600
    ip inspect name IPFW udp timeout 15
    ip inspect name IPFW ftp
    ip inspect name IPFW realaudio
    ip inspect name IPFW smtp
    ip inspect name IPFW h323
    ip inspect name IPFW ftps
    ip inspect name IPFW http
    ip inspect name IPFW https
    ip inspect name IPFW icmp
    ip inspect name IPFW imap
    ip inspect name IPFW imaps
    ip inspect name IPFW irc
    ip inspect name IPFW ircs
    ip inspect name IPFW ntp
    ip inspect name IPFW pop3
    ip inspect name IPFW pop3s
    ip inspect name IPFW radius
    ip inspect name IPFW sip
    ip inspect name IPFW sip-tls
    ip inspect name IPFW ssh
    ip inspect name IPFW telnet
    ip inspect name IPFW telnets
    ip inspect name IPFW vdolive
    ip inspect name IPFW webster
    ip inspect name IPFW dns
    no ipv6 cef
    multilink bundle-name authenticated
    password encryption aes
    file prompt quiet
    username admin password n
    username laneadmin password n
    crypto isakmp policy 1
    encr aes
    authentication pre-share
    group 2
    crypto isakmp policy 2
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp key 5122662533fedcbabcdef address 12.97.225.232
    crypto isakmp key 5122662533fedcbabcdef address 12.97.224.120
    crypto isakmp key 5122662533fedcbabcdef address 12.97.225.152
    crypto isakmp key 5122662533fedcbabcdef address 12.97.230.154
    crypto isakmp key 5122662533fedcbabcdef address 12.97.225.226
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec transform-set ESP-AES256-SHA esp-aes 256 esp-sha-hmac
    crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
    crypto ipsec transform-set ESP-AES256-SHA-LZO esp-aes 256 esp-sha-hmac comp-lzs
    crypto ipsec df-bit clear
    crypto ipsec profile SITE-to-SITE-DMVPN-Profile
    set transform-set ESP-AES256-SHA
    crypto ipsec client ezvpn ezvpn-client
    connect auto
    mode client
    xauth userid mode interactive
    archive
    log config
    logging enable
    notify syslog contenttype plaintext
    hidekeys
    path scp://cisco:wrs-.o#d8Au8M@fs00/$h-$t
    write-memory
    ip ssh version 2
    bridge irb
    interface Loopback0
    ip address 1.1.1.5 255.255.255.252
    interface Tunnel0
    ip address xxx.xxx.xxx.xxx 255.255.255.0
    no ip redirects
    ip nhrp map xxx.xxx.xxx.xxx 12.97.230.154
    ip nhrp map multicast 12.97.230.154
    ip nhrp map xxx.xxx.xxx.xxx 12.97.225.226
    ip nhrp map multicast 12.97.225.226
    ip nhrp network-id 1
    ip nhrp nhs xxx.xxx.xxx.xxx
    ip nhrp nhs xxx.xxx.xxx.xxx
    tunnel source 12.97.225.234
    tunnel mode gre multipoint
    tunnel protection ipsec profile SITE-to-SITE-DMVPN-Profile
    interface Dot11Radio0
    no ip address
    no dot11 extension aironet
    encryption vlan 44 mode ciphers tkip
    encryption vlan 144 mode ciphers tkip
    ssid XXXX
    ssid XXX-guest
    speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
    channel 2437
    station-role root
    no cdp enable
    interface Dot11Radio0.44
    encapsulation dot1Q 44
    bridge-group 44
    bridge-group 44 subscriber-loop-control
    bridge-group 44 spanning-disabled
    bridge-group 44 block-unknown-source
    no bridge-group 44 source-learning
    no bridge-group 44 unicast-flooding
    interface Dot11Radio0.144
    encapsulation dot1Q 144
    bridge-group 144
    bridge-group 144 subscriber-loop-control
    bridge-group 144 spanning-disabled
    bridge-group 144 block-unknown-source
    no bridge-group 144 source-learning
    no bridge-group 144 unicast-flooding
    interface Dot11Radio1
    no ip address
    speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
    station-role root
    interface FastEthernet0
    description 604 AT&T static IP
    ip address 12.97.225.234 255.255.255.248
    ip access-group IPFW-ACL-outside-A in
    no ip redirects
    no ip proxy-arp
    ip nat outside
    ip inspect IPFW out
    ip virtual-reassembly
    duplex auto
    speed auto
    interface FastEthernet1
    no ip address
    shutdown
    duplex auto
    speed auto
    interface FastEthernet2
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet3
    description phone system
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet4
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet5
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet6
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet7
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet8
    switchport access vlan 4
    spanning-tree portfast
    interface FastEthernet9
    description switchport uplink
    switchport access vlan 4
    interface Vlan1
    no ip address
    interface Vlan4
    ip address xxx.xxx.xxx.xxx 255.255.255.0
    no ip redirects
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip tcp adjust-mss 1200
    ip policy route-map NONAT-LAN
    interface Vlan5
    no ip address
    interface Vlan10
    no ip address
    interface Vlan44
    description nnn private WLAN
    no ip address
    ip nat inside
    ip virtual-reassembly
    ip policy route-map NONAT-LAN
    bridge-group 44
    bridge-group 44 spanning-disabled
    interface Vlan144
    description nnn Guest WLAN
    no ip address
    ip nat inside
    ip virtual-reassembly
    ip policy route-map NONAT-LAN
    bridge-group 144
    bridge-group 144 spanning-disabled
    interface Async1
    no ip address
    encapsulation slip
    interface BVI44
    description Bridge to nnn private WLAN
    ip address xxx.xxx.xxx.xxx 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    interface BVI144
    description Bridge to nnn Guest WLAN
    ip address xxx.xxx.xxx.xxx 255.255.255.0
    ip nat inside
    ip virtual-reassembly
    router eigrp 1
    network xxx.xxx.xxx.xxx
    network xxx.xxx.xxx.xxx
    no auto-summary
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 12.97.225.233
    no ip http server
    no ip http secure-server
    ip nat inside source list NAT-ACL interface FastEthernet0 overload
    ip nat inside source static tcp xxx.xxx.xxx.xxx 22 interface FastEthernet0 22222
    ip nat inside source route-map NO-NAT interface FastEthernet0 overload
    ip access-list standard VTY-ACL
    permit 192.168.0.0 0.0.63.255
    ip access-list extended IPFW-ACL-outside
    permit udp any any eq isakmp
    permit udp any eq isakmp any
    permit esp any any
    permit tcp any host 12.97.225.234 eq 23232
    permit icmp any any administratively-prohibited
    permit icmp any any echo-reply
    permit icmp any any packet-too-big
    permit icmp any any time-exceeded
    permit icmp any any traceroute
    deny ip any any
    ip access-list extended IPFW-ACL-outside-A
    permit tcp any host 12.97.225.234 eq 22222
    permit udp any any eq isakmp
    permit udp any eq isakmp any
    permit esp any any
    permit tcp any host 12.97.225.234 eq 23232
    permit icmp any any administratively-prohibited
    permit icmp any any echo-reply
    permit icmp any any packet-too-big
    permit icmp any any time-exceeded
    permit icmp any any traceroute
    deny ip any any
    ip access-list extended NAT-ACL
    deny ip 192.168.4.0 0.0.0.255 192.168.3.0 0.0.0.255
    deny ip 192.168.4.0 0.0.0.255 192.168.5.0 0.0.0.255
    deny ip 192.168.4.0 0.0.0.255 192.168.2.0 0.0.0.255
    deny ip 192.168.4.0 0.0.0.255 192.168.0.0 0.0.0.255
    permit ip 192.168.4.0 0.0.0.255 any
    deny ip 192.168.44.0 0.0.0.255 192.168.1.0 0.0.0.255
    deny ip 192.168.44.0 0.0.0.255 192.168.2.0 0.0.0.255
    deny ip 192.168.44.0 0.0.0.255 192.168.3.0 0.0.0.255
    deny ip 192.168.44.0 0.0.0.255 192.168.0.0 0.0.0.255
    deny ip 192.168.44.0 0.0.0.255 192.168.5.0 0.0.0.255
    permit ip 192.168.44.0 0.0.0.255 any
    deny ip 192.168.144.0 0.0.0.255 192.168.1.0 0.0.0.255
    deny ip 192.168.144.0 0.0.0.255 192.168.2.0 0.0.0.255
    deny ip 192.168.144.0 0.0.0.255 192.168.3.0 0.0.0.255
    deny ip 192.168.144.0 0.0.0.255 192.168.0.0 0.0.0.255
    deny ip 192.168.144.0 0.0.0.255 192.168.5.0 0.0.0.255
    permit ip 192.168.144.0 0.0.0.255 any
    ip access-list extended NONAT-LAN-RETURNING-ACL
    permit ip 192.168.4.0 0.0.0.255 192.168.3.0 0.0.0.255
    permit ip 192.168.4.0 0.0.0.255 192.168.5.0 0.0.0.255
    permit ip 192.168.4.0 0.0.0.255 192.168.2.0 0.0.0.255
    permit ip 192.168.4.0 0.0.0.255 192.168.0.0 0.0.0.255
    permit ip 192.168.44.0 0.0.0.255 192.168.3.0 0.0.0.255
    permit ip 192.168.44.0 0.0.0.255 192.168.5.0 0.0.0.255
    permit ip 192.168.44.0 0.0.0.255 192.168.2.0 0.0.0.255
    permit ip 192.168.44.0 0.0.0.255 192.168.0.0 0.0.0.255
    permit ip 192.168.144.0 0.0.0.255 192.168.3.0 0.0.0.255
    permit ip 192.168.144.0 0.0.0.255 192.168.5.0 0.0.0.255
    permit ip 192.168.144.0 0.0.0.255 192.168.2.0 0.0.0.255
    permit ip 192.168.144.0 0.0.0.255 192.168.0.0 0.0.0.255
    ip access-list extended VTY-ACL-A
    deny ip 192.168.160.0 0.0.0.255 any
    permit ip 192.168.44.0 0.0.0.255 any
    permit ip 192.168.144.0 0.0.0.255 any
    permit ip 192.168.0.0 0.0.0.255 any
    permit ip 192.168.1.0 0.0.0.255 any
    permit ip 192.168.2.0 0.0.0.255 any
    permit ip 192.168.3.0 0.0.0.255 any
    permit ip 192.168.4.0 0.0.0.255 any
    permit ip 192.168.5.0 0.0.0.255 any
    permit tcp any any eq 22
    deny ip any any
    logging trap notifications
    logging source-interface Vlan5
    logging 192.168.0.225
    route-map NONAT-LAN permit 10
    match ip address NONAT-LAN-RETURNING-ACL
    set interface Loopback0
    route-map NO-NAT permit 10
    match ip address NAT-ACL
    snmp-server community XXXsnmppub RO
    control-plane
    bridge 44 route ip
    bridge 144 route ip
    banner login ^C
    Unauthorized access is prohibited and will be monitored and prosecuted.
    If you are not explicitly authorized to access this device, you must
    disconnect now.
    ^C
    banner motd ^C
    Unauthorized access is prohibited and will be monitored and prosecuted.
    If you are not explicitly authorized to access this device, you must
    disconnect now.
    ^C
    line con 0
    line 1
    modem InOut
    stopbits 1
    speed 115200
    flowcontrol hardware
    line aux 0
    line vty 0 4
    access-class VTY-ACL-A in
    password 7 nnn
    transport input ssh
    line vty 5 15
    webvpn gateway webgateway
    ssl trustpoint TP-self-signed-1083484987
    no inservice
    webvpn gateway sslvpn.xxx
    hostname www.nnn
    ssl trustpoint TP-self-signed-1083484987
    inservice
    end
    router#

    It was a two fold problem.  There is another stronger Wi-Fi signal that exists at the facility from another entity on a different domain that the two laptops were trying to associate to in lieu of the network signal from our 1811.  This could only be seen while watching the Intel wireless Proset app NOT the Windows wireless management app.  Then by deleting all other old Wi-Fi networks listed in the Intel Proset app except ours it connected.  Also set devices to never connect to the other signal.  This was not an issue when I brought the laptop to another faciIity without a competing Wi-Fi signal becuase they would connect using the strongest and ONLY Wi-Fi network signal which was ours.

  • My Adobe has stopped allowing me to move library books from my PC to my KOBO (both show authorized on the ADE. the message reads : CE_COPY_NOT_ALLOWED - No permission to copy book.  It used to work. Any easy fixed for me?(I already tried uninstall and re-

    My Adobe has stopped allowing me to move library books from my PC to my KOBO (both show authorized on the ADE. the message reads : CE_COPY_NOT_ALLOWED - No permission to copy book.  It used to work. Any easy fixed for me?(I already tried uninstall and re-install)

    Welcome to the Club! Got the same Problem and had a really hard time reaching the Customer Support because they were down due to maitenance! Just wrote to their experts chat and hope to get an answer in this life!
    I tried to authorize my Computer and eBookreader with a new Adobe-ID, but it says I've done used this ID too often, even though it was brandnew! Can't copy my just-purchased eBook because "Copying is not allowed".
    I hold my thumbs for you that Adobe solves this Problem fast enough. Other ways I'll sell my eBookreader and buy the Kindle-Reader from Amazon and say GOOD BYE to Adobe!

  • How can I access the iTunes store.  I have had it on my computer for 2 years and 10 days ago it stopped allowing me access?  I have credit and cannot use it.

    How can I gain access to the itunes store?  I have had an account for 2 years and 10 days ago it stopped allowing me access.  I have credit and can't use it.

    You have encounter Activation Lock, the antitheft feature of the iPhone. The previous owner did not remove the phone from their account. The phone cannot be used until they do. Return to the store and let them sort this out. It is very unusual for someone to "forget" to disable activation lock, as it is necessary to do so to erase personal information on the phone. So it is quite likely you bought a stolen phone.

  • The finder window for an external USB hard disk suddenly started separating files by time (today, yesterday, etc.) and stopped allowing me to change column width, order, etc. Also the header bar shifted to flat white from gray.

    The finder window for an external USB hard disk suddenly started separating files by time (today, yesterday, etc.) and stopped allowing me to change column width, order, etc. Also the header bar shifted to flat white from gray.
    All was normal until the icon for the disk stopped showing up on the desktop when I would plug it in. I rebooted the computer, and the disk icon now shows up but this new look to the finder window started as a result. The hard disk does not have this problem when I use it on another Mac running Snow leopard. Also, two other external hard disks that I use on this computer running lion 7.4 still have the normal header bars with columns that can be reordered, etc.
    I have tried looking in preferences and other places but have not seen this discussed. 

    Well duh - I finally figured out that somehow in the View options for the hard drive, the "arrange by" option had been changed to "by date" from "none". Not sure how that happened, I had never used the "view options" menu tem before. Changing "arrange by" back to "none" gets the gray column headers and the collapsible folder icons back. 

  • My Acrobat 9 Standard has stopped allowing me to move thumbnails with the mouse.

    For some unknown reason my Acrobat 9 Standard has stopped allowing me to move the thumbnails with the mouse to change the order of a PDF document.  I've tried reinstalling.  I'm at my wits end on this one...

    Try updating to version 9.5.2.  I seem to remember that one of the earlier updates did this and a later update rectified the issue.  I don't have that issue with 9.5.2

  • Hi, my facebook app on my Ipad3 has stopped allowing me to put comments on. Does anyone have any ideas how to correct this? Don't know if it is a problem with the Ipad or just the facebook app. Thanks.

    Hi, my facebook app on my Ipad3 has stopped allowing me to put comments on. Does anyone have any ideas how to correct this? Don't know if it is a problem with the Ipad or just the facebook app. Thanks.

    Using FaceTime http://support.apple.com/kb/ht4319
    Troubleshooting FaceTime http://support.apple.com/kb/TS3367
    The Complete Guide to FaceTime: Set-up, Use, and Troubleshooting Problems
    http://tinyurl.com/32drz3d
    I saw one post where a user said dust got inside the small microphone hole. Using a vacuum cleaner removed the dust and restored the audio.
     Cheers, Tom

  • Adobe reader has just stopped allowing me to convert a pdf into a word doc.

    I have been converting PDF documents today and just randomly, it stopped allowing me to do that. When I click the convert button, it pops up with a message saying, "An error has occurred while trying to access the service." I really need this function ASAP. What can I do to fix this??

    Hi rolandl,
    This error has been popping up in Reader, and Adobe engineers are investigating the root cause. Please try signing out, and then signing back in. And if that does't do the trick, you should be able to sign in without issue directly to the ExportPDF website.
    Please let us know how it goes.
    Best,
    Sara

  • Audigy 2 ZS maximum allowed input level signa

    What is the maximum allowed input level signal (voltage or mv) without actually damaging the card.
    Because I want to use some input sources and I am affraid not to damage the Audigy 2 ZS card.
    Please answer as tehnically as possible concerning peak levels and RMS signal levels.

    Finally found what I was looking for, thanks to Customer Support! Here are the technical specs for SoundBlaster cards. Input is listed as 2 VRMS (for PCI cards), which is line-level for this class of audio equipment, with a recommended normal input limit of volt. They are saying this applies to all SoundBlaster cards, and the specs speak for themselves, but it's up to you whether still to worry about that .2 to .5 volt transient surge. HTH.
    ABA wrote:
    My problem is that I have a sattelite DVB receiver connected to my TV-tuner via S-VIDEO and RCA outputs.
    The problem is when I first started my receiver it bumps a peak signal of 5-7 volts recorded on osciloscope, this signal is somehow short sec but it still there.
    The good thing is that this signal is reduced in TV-tuner from 5-7 V to just about .2-.5 V output and then hits the Audigy card input.
    So I don't know exactly if I have to worry about this problem anymore ?
    Message Edited by Katman on 02-5-200606:06 PM

  • Does anyone know why the mixed signal graph stops allowing traces to be drag'ed and dropped between different plot areas?

    I have a mixed signal graph that allows me to drag and drop my traces between the plot areas,  then it stops allowing it.
    If I start with a new graph it allows it but eventually stops allowing it.
    I have 4 XY charts feeding the one mixed singal graph through a bundle function, then I run it once and drag my traces to the correct plot area
    and hope that it keeps working.
    Best Regards
    Tim C.
    1:30 Seconds ARRRGHHH!!!! I want my popcorn NOW! Isn't there anything faster than a microwave!

    Hi Tim,
    That sounds like some interesting behavior.  Can you reproduce what you were seeing, or have you continued to be able to drag the signals to other plots since you saved and reopened your program? 
    Jennifer R.
    National Instruments
    Applications Engineer

  • Browse URL in FM11 won't allow input of any kind.  I need to connect either to a CMS, or WebDav, or checkout from Sharepoint, but nothing works.

    Any one in FrameMaker 11 having ANY luck of any kind with a check out rev controlled doc management system for a team?  So far, CMS won't work with FM11.  SharePoint 12 doesn't work with FM11.  And the Browse URL won't allow input of any kind no matter what direction I approach at.  I have been to preferences, allowing checkout of HTTP files on open, and upload HTTP files on save, but nothing works yet.
    I can check out and return from SP13 from the web, but all links are lost, and only embedded information carries over.
    Any suggestions and input would be valued.
    I didn't want to go Ditta simply because the company has SharePoint and it was supposed to be compatible. It isn't, so I need a back door.
    I would rather not run two systems for Doc Control if I don't have to.  There is much to do, and dividing resources is a waste that I would prefer to avoid.
    Thanks
    A

    I didn't want to go Ditta simply because the company has SharePoint and it was supposed to be compatible. It isn't, so I need a back door.
    If you mean DITA and structured documentation, take a look at DITA Exchange – sad disclaimer, I'm no wise affiliated and I haven't yet managed to persuade the powers that be to try this level of integration.

  • Setting an Edit pattern does not allow inputting values

    I'm using a custom field (Phone Number North America) in a designer form. My users want to be able to edit and display value in (999) 999-9999 format. So I set the Display and Edit formats to text{'('999')' 999-9999}. Setting this pattern only displays the value in this format, but when I go to edit the field for the first time (when the field is blank), it allows inputting without any format. And when I want to edit an inputted value in the field, it does not even allow to change anything. It seems to be readonly/locked.
    What I want to be able to do is that the field must allow the user to input values in the format that I set in the Edit pattern box. This must work even if the field has a phone number value already in it.
    Any help will be highly appreciated.
    FYI...My Adobe LiveCycle Designer ES2 version is:  9.0.0.2.20101008.1.734229 Cipher: 128-bit.
    Thanks in advance...

    Hi Mahabub,
    Keep the below script on exit event of the Phone Number dnt select any pattern for the field.
    // Regular Expression for the phone number (999) 999-9999
    var vPattern = /^(\(\d{3}\) \d{3}-\d{4})$/;
    if (vPattern.test(this.rawValue))
    app.alert("Matched");
    else
    app.alert("not matched")
    This gives you Error message if the entered value is not matched with the pattern.
    Please let me know if you need any more info.
    Vjay

  • HT1689 How do I stop allowing my kids to charge purchases to my account?

    When I originally set up my Apple ID, on my iPad, I set it to allow my kids to purchase apps (for their iPhones) by using my password. I now want to stop allowing them to do this. How do I change my settings?

    Change your password and don't tell them the new one.

  • How to no allow input japanese in JCombobox but still handle keypress event

    How to no allow input japanese in JCombobox but still handle keypress event?
    I used DocumentFilter to no allow input japanese but when i execute ENTER keypress event no action.
    Please help me. thanks very much

    I don't know about Raspberry but on desktop it would be primaryStage.close() - does that work?

  • My iPhone has suddenly stopped allowing me to send and receive Hotmail messages. Any help would be brilliant!

    As of yesterday, my iPhone 5 stopped allowing me to send and receive messages from my Hotmail accounts. Is this a problem on Apple's end, or Hotmail's? I've seen one post that claims Hotmail is having difficulties with mobile devices at the moment, but could do with some clarification (if there actually is any out there).
    Thanks in advance!

    It is a problem on Hotmail's end and they are working on a fix. Here is a link to keep up-to-date with their progress if anyone else is in my position: https://status.live.com/detail/hotmail

Maybe you are looking for

  • Opening files in Ps CS5

    In Photoshop CS5, why can't I open files?

  • Bootcamp partition problem

    Okay, so I did something really stupid. I admit that up front. So I wanted to expand my Win 7 partition, so I went to the Bootcamp assistant and deleted the old partition, then opened it again and started to create a new larger partition. However the

  • Cleared Invoice should not allow to cancel.

    Dear All I have posted one invoice with reference to sales order. My finance team also cleared that invoice. Now System is allowing me to cancel the invoice document.But i dont want to allow people to cancel cleared invoice. How to achieve this. Kind

  • In Planning Book fo DP how do I change desing view of Selcted objects part?

    Hi All, Can anyone advice how I change view of Slected objects which is on left side top of planning book. When we open planning book and use selction to select display divisiona and select all Divisions , in selected object box all divisions are dis

  • ISE wifi profile editable?

    Hello, We have implemented BYOD with certificates with ISE 1.1.2. After registering the device and installing the certificates for the devices, a network profile is applied that makes the susequent connections to the same ssid use EAP-TLS. All works