N7K Port Channel Layer 3 VLAN Question

I have 2 N7K switches and would like to connect them via port channel and put the channel in VLAN 101. I have the following config, does it make sense? Thanks in advance!
interface eth 3/1
switchport
channel-group 101 mode active
interface eth 3/2
switchport
channel-group 101 mode active
interface port-channel 101
switchport
switchport mode access
switchport access vlan 10
spanning-tree network type edge
interface vlan 10
ip address 10.1.1.1/24

Could be something like this in the both sides (if the port numbers match):
conf t
feature lacp
feature interface-vlan
interface eth 3/1
switchport
channel-group 101 mode active
interface eth 3/2
switchport
channel-group 101 mode active
interface port-channel 101
switchport
switchport mode access
switchport access vlan 101
spanning-tree port type network
interface vlan 101
ip address 10.1.1.1/24
no shut
end
vlan 101
end
*(This ip address will be available in only one box, you can use a FHRP as well, to increase the level of reachability)

Similar Messages

  • How to configure a port channel with VLAN trunking (and make it work..)

    We're trying to configure a port channel group with trunked ports to connect a NetApp HA pair. We want to create two data LIFs and connect them to the switch stack.  We are trying to create 2 data lifs, one for cifs and one for nfs that are on different vlans.
    We want the same ports to be able to allow multiple vlans to communicate. (trunked)
    These data lifs should be able to fail over to different nodes in the HA pair and still be able to communicate on the network.
    What this means is that we have to connect 4 ports each for each node in the NetApp HA Pair to the switches and create a port channel of some type that allows for trunked vlans. When we configure the ports, the configuration is as follows (below):
    We are only able to configure an IP on one of the vlans.
    When we configure an IP from another vlan for the data lif, it does not respond to a ping.
    Does anyone have any idea what I'm doing wrong on the Cisco switch?
    interface GigabitEthernet4/0/12
    description Netapp2-e0a
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet4/0/13
    description Netapp2-e0c
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet6/0/12
    description Netapp2-e0b
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface GigabitEthernet6/0/13
    description Netapp2-e0d
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    channel-protocol lacp
    channel-group 20 mode active
    end
    interface Port-channel20
    description Netapp2-NFS
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    spanning-tree portfast
    spanning-tree bpduguard enable
    end

    Our problem was fixed by the storage people.  They changed the server end to trunk, and the encapsulation / etherchannel.
    I like all the suggestions, and they probably helped out with the configuration getting this to work.
    Thanks!
    interface Port-channel20
    description Netapp2-NFS
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    interface GigabitEthernet4/0/12
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet4/0/13
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet6/0/12
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active
    interface GigabitEthernet6/0/13
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 10,20,511,519
    switchport mode trunk
    channel-protocol lacp
    channel-group 20 mode active

  • Port Channel and VLAN trunking

    When configuring trunking of VLANS accross a Port Channel, do we need to configure vlan pruning on both the port-Channel port and the physical ports ???
    E.g. do I need to apply the "switchport trunk allowed vlan add " command under each physical port and the port channel port ? Or only under the port channel port ?
    Thanks

    In short, yes. Configure the port channel interface exactly as you do the physical interfaces and both ends should be an exact match. otherwise you will have problems getting the channel to come up or stay up.
    -Mark

  • Nexus 1000v port-channels questions

    Hi,
    I’m running vCenter 4.1 and Nexus 1000v and about 30 ESX Hosts.
    I’m using one system uplink port profile for all 30 ESX Host; On each of the ESX host I have 2 NICs going to a Catalyst 3750 switch stack (Switch A), and another 2 NICs going to another Catalyst 3750 switch stack (Switch B).
    The Nexus is configured with the “sub-group CDP” command on the system uplink port profile like the following:
    port-profile type ethernet uplink
    vmware port-group
    switchport mode trunk
    switchport trunk allowed vlan 1,800,802,900,988-991,996-997,999
    switchport trunk native vlan 500
    mtu 1500
    channel-group auto mode on sub-group cdp
    no shutdown
    system vlan 988-989
    description System-Uplink
    state enabled
    And the port channel on the Catalyst 3750 are configured like the following:
    interface Port-channel11
    description ESX-10(Virtual Machine)
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 500
    switchport trunk allowed vlan 800,802,900,988-991
    switchport mode trunk
    switchport nonegotiate
    spanning-tree portfast trunk
    end
    interface GigabitEthernet1/0/18
    description ESX-10(Virtual Machine)
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 500
    switchport trunk allowed vlan 800,802,900,988-991
    switchport mode trunk
    switchport nonegotiate
    channel-group 11 mode on
    spanning-tree portfast trunk
    spanning-tree guard root
    end
    interface GigabitEthernet1/0/1
    description ESX-10(Virtual Machine)
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 500
    switchport trunk allowed vlan 800,802,900,988-991
    switchport mode trunk
    switchport nonegotiate
    channel-group 11 mode on
    spanning-tree portfast trunk
    spanning-tree guard root
    end
    Now Cisco is telling me that I should be using MAC pinning when doing a trunk to two different stacks , and that each interface on 3750 should not be configured in a port-channel like above,  but should be configured as individual trunks.
    First question: Is the above statement correct, are my uplinks configured wrong?  Should they be configured individually in trunks instead of a port-channel?
    Second questions: If I need to add the MAC pinning configuration on my system uplink port-profile can I create a new system uplink port profile with the MAC pinning configuration and then move one ESX host (with no VM on them) one at a time to that new system uplink port profile? This way, I could migrate one ESX host at a time without outages to my VMs. Or is there an easier way to move 30 ESX hosts to a new system uplink profile with the MAC Pinning configuration.
    Thanks.

    Hello,
    From what I understood, you have the following setup:
         - Each ESX host has 4 NICS
         - 2 of them go to a 3750 stack and the other 2 go to a different 3750 stack
         - all 4 vmnics on the ESX host use the same Ethernet port-profile
              - this has 'channel-group auto mode on sub-group cdp'
         - The 2 interfaces on each 3750 stack are in a port-channel (just 'mode on')
    If yes, then this sort of a setup is correct. The only problem with this is the dependance on CDP. With CDP loss, the port-channels would go down.
    'mac-pinning' is the recommended option for this sort of a setup. You don't have to bundle the interfaces on the 3750 for this and these can be just regular trunk ports. If all your ports are on the same stack, then you can look at LACP. The CDP option would not be supported in the future releases. In fact, it is supposed to be removed from 4.2(1)SV1(2.1) but I still see the command available (ignore 4.2(1)SV1(4) next to it) - I'll follow up on this internally:
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus1000/sw/4_2_1_s_v_2_1_1/interface/configuration/guide/b_Cisco_Nexus_1000V_Interface_Configuration_Guide_Release_4_2_1_SV_2_1_1_chapter_01.html
    For migrating, the best option would be as you suggested. Create a new port-profile with mac-pinning and move one host at a time. You can migrate VMs off the host before you change the port-profile and can remove the upstream port-channel config as well.
    Thanks,
    Shankar

  • SG300 Port-Channel Configuration

    We have an SG300 52P and a SG300 28P that we need to LAG/Trunk together, but have had a hell of a time doing it.  Both switches are updated to 1.3.0.62.  The 52 port switch is configured in layer 3, the 28 port switch in layer 2.  All connectivity that is directly connected to the 52 port works as intended, but no traffic on the 28 port over the port channel to VLANs outside the native VLAN are working.  Strangely too, it is possible to ping the 28 port from a serial connection on the 52 port on the native vlan address, but cannot access the management interface over ethernet.  The last 4 ports of each switch are part of the port channel.
    Here are the two configurations:
    52 Port:
    vlan database
    vlan 2,4,6,8,10,100
    ip dhcp relay address 10.0.4.10
    ip dhcp relay address 10.0.4.14
    ip dhcp relay enable
    ip name-server  10.0.4.10 10.0.4.14
    hostname CORE-SW1
    ip ssh server
    ip ssh pubkey-auth
    snmp-server server
    snmp-server community public ro 10.0.4.5 view Default
    interface vlan 1
    Name ReserverdDefault
    ip address 192.168.0.1 255.255.255.0
    no ip address dhcp
    interface vlan 2
    ip address 10.0.2.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 4
    ip address 10.0.4.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 6
    ip address 10.0.6.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 8
    ip address 10.0.8.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 10
    ip address 10.0.10.1 255.255.255.0
    ip dhcp relay enable
    interface vlan 100
    name Network
    ip address 10.0.0.1 255.255.255.0
    ip dhcp relay enable
    interface gigabitethernet1
    switchport mode access
    switchport access vlan 100
    interface gigabitethernet2
    switchport mode access
    switchport access vlan 100
    (all ports between are configured like ports 1 & 2)
    interface gigabitethernet49
    channel-group 1 mode on
    interface gigabitethernet50
    channel-group 1 mode on
    interface gigabitethernet51
    channel-group 1 mode on
    interface gigabitethernet52
    channel-group 1 mode on
    interface Port-channel1
    description CORELINK
    speed 1000
    no negotiation
    switchport trunk allowed vlan add 2,4,6,8,10
    switchport trunk native vlan 100
    ip default-gateway 10.0.0.254
    28 Port:
    vlan database
    vlan 2,4,6,8,10,100
    ip dhcp relay address 10.0.4.10
    ip dhcp relay address 10.0.4.14
    ip dhcp relay enable
    ip name-server  10.0.4.10 10.0.4.14
    hostname ACC-SW1
    ip ssh server
    ip ssh pubkey-auth
    snmp-server server
    snmp-server community public ro 10.0.4.5 view Default
    interface vlan 1
    Name ReserverdDefault
    no ip address dhcp
    interface vlan 2
    ip dhcp relay enable
    interface vlan 4
    ip dhcp relay enable
    interface vlan 6
    ip dhcp relay enable
    interface vlan 8
    ip dhcp relay enable
    interface vlan 10
    ip dhcp relay enable
    interface vlan 100
    name Network
    ip address 10.0.0.2 255.255.255.0
    ip dhcp relay enable
    interface gigabitethernet1
    switchport mode access
    switchport access vlan 100
    interface gigabitethernet2
    switchport mode access
    switchport access vlan 100
    (all ports between are configured like ports 1 & 2)
    interface gigabitethernet25
    channel-group 1 mode on
    interface gigabitethernet26
    channel-group 1 mode on
    interface gigabitethernet27
    channel-group 1 mode on
    interface gigabitethernet28
    channel-group 1 mode on
    interface Port-channel1
    description CORELINK
    speed 1000
    no negotiation
    switchport trunk allowed vlan add 2,4,6,8,10
    switchport trunk native vlan 100
    Thank you in advance for any assistance that you can provide, I have been tearing my hair out on this
    -Drew       

    The LAG is back up and working on native VLAN 100, but I am still not able to pass other vlan traffic from the L2 to L3 switch.  The switch also took out my switchport trunk native vlan 100 configs on both switches when they were connected.  After I manually put the configuration back the switches were able to communicate.  Here is the current port channel and LAG configurations:
    52:
    interface gigabitethernet51
    description "LAG 3"
    channel-group 1 mode on
    no macro auto smartport
    interface gigabitethernet52
    description "LAG 4"
    channel-group 1 mode on
    no macro auto smartport
    interface Port-channel1
    negotiation 1000f
    description CORELINK
    spanning-tree link-type point-to-point
    switchport trunk allowed vlan add 2,4,10,14
    switchport trunk native vlan 100
    macro description switch
    !next command is internal.
    macro auto smartport dynamic_type switch
    28:
    interface gigabitethernet27
    description "LAG 3"
    channel-group 1 mode on
    interface gigabitethernet28
    description "LAG 4"
    channel-group 1 mode on
    interface Port-channel1
    negotiation 1000f
    description CORELINK
    spanning-tree link-type point-to-point
    switchport trunk allowed vlan add 2,4,10,14
    switchport trunk native vlan 100
    macro description switch
    !next command is internal.
    macro auto smartport dynamic_type switch
    When I try to ping 10.0.4.1 from the 28 port, here is the output:
    Pinging 10.0.4.1 with 18 bytes of data:
    PING: net-unreachable
    PING: net-unreachable
    PING: net-unreachable
    PING: net-unreachable
    ----10.0.4.1 PING Statistics----
    4 packets transmitted, 0 packets received, 100% packet loss
    Thank you again for any assistance you can provide.
    -Drew

  • Nexus 6K: Port-Channel Load-Balance

    Hi all,
    I configured "port-channel load-balance ethernet source-dest-mac" on Nexus 6001. But when I use "show run all | in load-balance", it displays module 1 and module 2 are still using source-dest-ip for port-channel load-balance. And for command "show port-channel load-balance" and "show port-channel load-balance forwarding-path interface", it still shows switch using MAC for hash algorithm. The NXOS is 6.0(2)N1(2a).
    Does anybody know:
    -  What is the function of "port-channel load-balance ethernet source-dest-ip module" and in which situation this command will be effective?
    -  It shows "port-channel load-balance ethernet source-dest-ip module" command for both module 1 and 2. Module 1 is N6K Supervisor and module 2 is 4xQSFP Ethernet Module. Is it possible to set different load-balance algorithm  to these 2 modules?   
    # show run all | in load-balance
    port-channel load-balance ethernet source-dest-mac
    port-channel load-balance ethernet source-dest-ip module 1
    port-channel load-balance ethernet source-dest-ip module 2
    # show port-channel load-balance
    Port Channel Load-Balancing Configuration:
    System: source-dest-mac
    Port Channel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: source-dest-mac
    IP: source-dest-mac
    # show port-channel load-balance forwarding-path interface port-channel 30 vlan 150 src-ip 172.25.228.6 dst-ip 172.25.226.97
    Missing params will be substituted by 0's.
    Load-balance Algorithm on switch: source-dest-mac
    crc_hash: 977 Polynomial: CRC10b        Outgoing port id  Ethernet1/2
    Param(s) used to calculate load-balance:
            seed: 0x701
            dst-mac:  0000.0000.0000
            src-mac:  0000.0000.0000
    # show module
    Mod Ports Module-Type                         Model                  Status
    1   48    Norcal 64 Supervisor                N6K-C6001-64P-SUP      active *
    2   10    Nexus 4xQSFP Ethernet Module        N6K-C6001-M4Q          ok
    Mod  Sw              Hw      World-Wide-Name(s) (WWN)
    1    6.0(2)N2(3)     1.0     --
    2    6.0(2)N2(3)     1.0     --

    Hi all,
    I configured "port-channel load-balance ethernet source-dest-mac" on Nexus 6001. But when I use "show run all | in load-balance", it displays module 1 and module 2 are still using source-dest-ip for port-channel load-balance. And for command "show port-channel load-balance" and "show port-channel load-balance forwarding-path interface", it still shows switch using MAC for hash algorithm. The NXOS is 6.0(2)N1(2a).
    Does anybody know:
    -  What is the function of "port-channel load-balance ethernet source-dest-ip module" and in which situation this command will be effective?
    -  It shows "port-channel load-balance ethernet source-dest-ip module" command for both module 1 and 2. Module 1 is N6K Supervisor and module 2 is 4xQSFP Ethernet Module. Is it possible to set different load-balance algorithm  to these 2 modules?   
    # show run all | in load-balance
    port-channel load-balance ethernet source-dest-mac
    port-channel load-balance ethernet source-dest-ip module 1
    port-channel load-balance ethernet source-dest-ip module 2
    # show port-channel load-balance
    Port Channel Load-Balancing Configuration:
    System: source-dest-mac
    Port Channel Load-Balancing Addresses Used Per-Protocol:
    Non-IP: source-dest-mac
    IP: source-dest-mac
    # show port-channel load-balance forwarding-path interface port-channel 30 vlan 150 src-ip 172.25.228.6 dst-ip 172.25.226.97
    Missing params will be substituted by 0's.
    Load-balance Algorithm on switch: source-dest-mac
    crc_hash: 977 Polynomial: CRC10b        Outgoing port id  Ethernet1/2
    Param(s) used to calculate load-balance:
            seed: 0x701
            dst-mac:  0000.0000.0000
            src-mac:  0000.0000.0000
    # show module
    Mod Ports Module-Type                         Model                  Status
    1   48    Norcal 64 Supervisor                N6K-C6001-64P-SUP      active *
    2   10    Nexus 4xQSFP Ethernet Module        N6K-C6001-M4Q          ok
    Mod  Sw              Hw      World-Wide-Name(s) (WWN)
    1    6.0(2)N2(3)     1.0     --
    2    6.0(2)N2(3)     1.0     --

  • How to troubleshooting port channel in N7K

     i find N5K
    http://www.cisco.com/c/en/us/support/docs/switches/nexus-5000-series-switches/116199-technote-stp-00.html
    i notice distribution switch has root  guard block log
    does it mean that looping has occured yesterday?
    i use command below do not have yesterday record
    show spanning-tree internal event-history tree 1 brief | in "2015:03:15 10"
    first core is root switch
    now port channel shutdown in first core and use port channel in second core. How can i see which problem has occurred in port channel ?
    how to know which port has problem ?
    how to know which vlan caused the problem ?
    we notice one of access switch has lost config, will it affect the distribution layer switch?
    i remember that yesterday i just get log with filezilla after configure notebook same vlan and same network with the testing access switch

    Not sure if youre after the portchannel bandwidth or port-channel speed... If you really want to get an insight on the bandwidth usage, get SNMP on both sides, actively monitor the port channel and interfaces (real time by frequent polling)
    And you could get two endpoints @ 10 gb nics that are bundled, then 'thrash' the link, end to end. I use iperf, you could use big ftp transfers to test and see what performance is. You'll get the rate / speed in which the links are operating 'end to end'
    It may mean that the ports are @10gb full duplex, but the overall bandwidth is 20gb
    Sent from Cisco Technical Support iPhone App

  • FabricPath vPC port-channel err-disabled CE Vlan?

    I have a pair of Nexus 56128 configured with fabric path and vpc+. The Nexus pair has UCS connected downstream using vpc port-channels. When a Vlan is in mode fabricpath, it's ok for the vpc+ peer-link and the vpc port-channel to UCS. However when I changed the vlan to classic Ethernet, it's err-diabled in the vpc port-channels.
    Is this the normal behavior of fabric path domain? In other words, CE Vlans and fabric path Vlans cannot use the same Layer 2 path, correct?
    If I need to transport CE Vlans and fabric path Vlans from Nexus (fabric path vpc+) to UCS, I have to use a separate non-vpc port-channel for the CE Vlans between each Nexus and UCS?
    Thanks

    I have a pair of Nexus 56128 configured with fabric path and vpc+. The Nexus pair has UCS connected downstream using vpc port-channels. When a Vlan is in mode fabricpath, it's ok for the vpc+ peer-link and the vpc port-channel to UCS. However when I changed the vlan to classic Ethernet, it's err-diabled in the vpc port-channels.
    Is this the normal behavior of fabric path domain? In other words, CE Vlans and fabric path Vlans cannot use the same Layer 2 path, correct?
    If I need to transport CE Vlans and fabric path Vlans from Nexus (fabric path vpc+) to UCS, I have to use a separate non-vpc port-channel for the CE Vlans between each Nexus and UCS?
    Thanks

  • Layer 2 port-channel flood

    Hi all,
    I was wondering if you may be able to help me, hopefully I will provide enough information.
    The background to my problem is this. Every Tuesday morning around 10AM we were experiencing network slowdowns, after many weeks fault finding I have narrowed it down to two backup jobs and two vlans. These are quite substantial backup jobs each 100GB in size.
    The servers that are being backed-up are behind an ISA server which is controlling the routing for the subnets that these servers use. The ISA servers are load balanced using Microsoft NLB. It is thought by our security expert that this is the best way to secure these servers.
    On our core switch (6513) we have a static route pointing to these subnets and the vlans are defined. Here is the basic config of one of the vlans:-
    interface Vlan121
     description DB vlan
     no ip address
     ip flow ingress
     ip flow egress
    end
    ip route 192.168.221.0 255.255.255.0 192.168.219.10
    I have managed to stop the flooding going to the user switches by denying the 121 vlan on the port-channels. The issue is still apparent however on our top of rack switches (server switches). The reason for this is, there are servers that require vlan 121 on nearly every top of rack switch.
    If anyone can recommend a solution to this problem other than limiting vlans, I would greatly appreciate it.
    If you require any further information, please let me know.
    Kind regards,
    Jamie.

    Hi Jon, let me see if I can answer your questions.
    There are four VLANs that reside behind the ISA VLAN -121, 122, 123 and 124. Any traffic that requires access to these VLANs have to pass through the ISA because the ISA dcontrols all the routing for the subnets associated with these VLANs.
    The server that we are backing up lives on a VLAN 124 and the actual backup server lives on a VLAN outside of the protected VLANs. For the sake of argument lets say that the backup server is shown as the PC on VLAN 156. 
    When the 90GB backup is initiated, the traffic propagates to all trunk ports throughout the network. I see traffic running at 500Mbps and it can last for up to 20 hours.
    I have managed to stop the flood to all the user switches by denying the VLANs stated above. The problem is, I can't deny those VLANs to other top of rack switches because there is at lease one server in each switch that requires one of the VLANs.
    In a nutshell, when large amounts of traffic pass through VLAN 666 (ISA) we see it flood to all trunk ports. We think this could be due to the nature of MLB forming a virtual MAC address. The core doesn't know about the MAC address so it sends a unicast flood to find out where it is.
    If you have any ideas please let me know.
    J.

  • Nexus 6004: Question about port-profile type port-channel

    I'm setting up a new deployment of Nexus 6004 switches and want to utilize port-profiles as much as possible to simplify management down the road.
    All uplinks to other switches, routers and firewalls will be connected using VPC:s. On the port-channels (vpc) the only thing that will change over time is the allowed vlans.
    It seems that port-profiles of the type port-channel does not behave in the same way as those with type ethernet, at least not when adding vlans.
    If I modify the port-profile using "switchport trunk allowed vlan add XXX" it will delete the previous config and only retain "switchport trunk allowed vlan add XXX", and not merge it with the previous config as is expected. 
    Question: Is this a bug or is it working as intended?
    RH_N6K4_01(config-sync)# switch-profile rh
    Switch-Profile started, Profile ID is 1
    RH_N6K4_01(config-sync-sp)# port-profile type port-channel FIREWALL-UPLINK
    RH_N6K4_01(config-sync-port-prof)# switchport trunk allowed vlan 3
    RH_N6K4_01(config-sync-port-prof)# verify 
    Verification Successful
    RH_N6K4_01(config-sync-sp)# commit
    Verification successful...
    Proceeding to apply configuration. This might take a while depending on amount of configuration in buffer.
    Please avoid other configuration changes during this time.
    Commit Successful
    RH_N6K4_01(config-sync)# show port-profile 
    SHOW PORT_PROFILE
    port-profile FIREWALL-UPLINK
     type: Port-channel
     description: 
     status: enabled
     max-ports: 512
     inherit: 
     config attributes:
      switchport mode trunk
      switchport trunk allowed vlan 3
     evaluated config attributes:
      switchport mode trunk
      switchport trunk allowed vlan 3
     assigned interfaces:
    ===================================
    RH_N6K4_01(config-sync-sp)# port-profile type port-channel FIREWALL-UPLINK
    RH_N6K4_01(config-sync-port-prof)# switchport trunk allowed vlan add 84
    RH_N6K4_01(config-sync-port-prof)# verify 
    Verification Successful
    RH_N6K4_01(config-sync-sp)# commit 
    Verification successful...
    Proceeding to apply configuration. This might take a while depending on amount of configuration in buffer.
    Please avoid other configuration changes during this time.
    Commit Successful
    RH_N6K4_01(config-sync)# show port-profile 
    SHOW PORT_PROFILE
    port-profile FIREWALL-UPLINK
     type: Port-channel
     description: 
     status: enabled
     max-ports: 512
     inherit: 
     config attributes:
      switchport mode trunk
      switchport trunk allowed vlan add 84
     evaluated config attributes:
      switchport mode trunk
      switchport trunk allowed vlan add 84
     assigned interfaces:
    Expected behavior here would be "switchport trunk allowed vlan 3,84". This only occurs when using "port-profile type port-channel" not when using "port-profile type ethernet"

    <> is template syntax and is generally the type of object a container holds..   So it is defining that the MSGQUEUE type is a deque holding struct_buffer*'s.

  • Port-channel question on 9148

    hey I have a question about  port-channel.
    we have a port-channel 10 which contains 4 interfaces as below.
    my question is how the port-channel associated with the servers?  I mean the output "sh flogi database" as below........
    do we need to add port-channel as a zone member ? I think the answer is no since I don;t see the port-channel as a zone member....
    =================================================================
    tormds01# sh interface port-channel  10
    port-channel 10 is up
        Hardware is Fibre Channel
        Port WWN is 24:0a:54:7f:ee:a0:d5:48
        Admin port mode is auto, trunk mode is on
        snmp link state traps are enabled
        Port mode is F
        Port vsan is 510
        Speed is 32 Gbps
        5 minutes input rate 124316072 bits/sec, 15539509 bytes/sec, 9919 frames/sec
        5 minutes output rate 2205921104 bits/sec, 275740138 bytes/sec, 141424 frames/sec
          43540499847 frames input, 70772376296224 bytes
            0 discards, 0 errors
            0 CRC,  0 unknown class
            0 too long, 0 too short
          237450525827 frames output, 442040501099476 bytes
            0 discards, 0 errors
          0 input OLS, 0 LRR, 0 NOS, 0 loop inits
          0 output OLS, 0 LRR, 0 NOS, 0 loop inits
        Member[1] : fc1/1
        Member[2] : fc1/5
        Member[3] : fc1/9
        Member[4] : fc1/13
        Interface last changed at Tue Apr  8 22:16:49 2014
    tormds01# sh flogi database
    INTERFACE        VSAN    FCID           PORT NAME               NODE NAME      
    fc1/3            510   0x860000  50:06:01:64:3d:e0:24:d0 50:06:01:60:bd:e0:24:d0
                               [torvnx01_spa0]
    fc1/7            510   0x860100  50:06:01:6c:3d:e0:24:d0 50:06:01:60:bd:e0:24:d0
                               [torvnx01_spb0]
    fc1/11           510   0x860200  50:06:01:60:3d:e0:24:d0 50:06:01:60:bd:e0:24:d0
                               [torvnx01_spa2]
    fc1/15           510   0x860300  50:06:01:68:3d:e0:24:d0 50:06:01:60:bd:e0:24:d0
                               [torvnx01_spb2]
    port-channel 10  510   0x860400  24:0a:54:7f:ee:92:3e:80 21:fe:54:7f:ee:92:3e:81
    port-channel 10  510   0x860401  20:01:04:25:b5:3a:00:8f 20:01:00:25:b5:30:00:8f
                               [mcvhes0101hba0]
    port-channel 10  510   0x860402  20:01:04:25:b5:3a:00:9f 20:01:00:25:b5:30:00:9f
                               [mcvhes0102hba0]
    port-channel 10  510   0x860404  20:01:04:25:b5:3a:00:6f 20:01:00:25:b5:30:00:6f
                               [mcvhes0103hba0]
    port-channel 10  510   0x860408  20:01:04:25:b5:3a:00:7f 20:01:00:25:b5:30:00:7f
                               [mcvhes0104hba0]
    port-channel 10  510   0x86040f  20:01:04:25:b5:3a:00:4f 20:01:00:25:b5:30:00:4f
                               [mcvhes0105hba0]
    port-channel 10  510   0x860410  20:01:04:25:b5:3a:00:5f 20:01:00:25:b5:30:00:5f
                               [mcvhes0106hba0]
    port-channel 10  510   0x860417  20:01:04:25:b5:3a:00:2f 20:01:00:25:b5:30:00:2f
                               [mcvhes0107hba0]
    port-channel 10  510   0x860418  20:01:04:25:b5:3a:00:0f 20:01:00:25:b5:30:00:0f
                               [mcvhes0109hba0]
    port-channel 10  510   0x86041b  20:01:04:25:b5:3a:00:bf 20:01:00:25:b5:30:01:bf
                               [mcvhes0110hba0]
    port-channel 10  510   0x86041d  20:01:04:25:b5:3a:00:1f 20:01:00:25:b5:30:00:1f
                               [mcvhes0111hba0]
    port-channel 10  510   0x86041e  20:01:04:25:b5:3a:00:3f 20:01:00:25:b5:30:00:3f
                               [mcvhes0108hba0]
    port-channel 10  510   0x86041f  20:01:04:25:b5:3a:00:ff 20:01:00:25:b5:30:01:ff
                               [mcvhes0112hba0]
    port-channel 10  510   0x860423  20:01:04:25:b5:3a:00:df 20:01:00:25:b5:30:01:df
                               [mcvhes0113hba0]
    port-channel 10  510   0x860425  20:01:04:25:b5:3a:00:ef 20:01:00:25:b5:30:01:ef
                               [mcvhes0114hba0]
    port-channel 10  510   0x860426  20:01:04:25:b5:3a:00:cf 20:01:00:25:b5:30:01:cf
                               [mcvhes0115hba0]
    port-channel 10  510   0x860427  20:01:04:25:b5:3a:00:8e 20:01:00:25:b5:30:01:8f
                               [MCDBWS0200hba0]
    port-channel 10  510   0x860429  20:01:04:25:b5:3a:00:9e 20:01:00:25:b5:30:01:9f
                               [MCDBWS0201hba0]
    port-channel 10  510   0x86042a  20:01:04:25:b5:3a:00:7e 20:01:00:25:b5:30:01:7f
                               [mcvhes0118hba0]
    port-channel 10  510   0x86042b  20:01:04:25:b5:3a:00:af 20:01:00:25:b5:30:01:af
                               [mcvhes0116hba0]
    port-channel 10  510   0x86042c  20:01:04:25:b5:3a:00:6e 20:01:00:25:b5:30:01:6f
                               [mcvhes0117hba0]
    port-channel 10  510   0x86042d  20:01:04:25:b5:3a:00:4e 20:01:00:25:b5:30:01:4f
                               [mcvhes0119hba0]
    port-channel 10  510   0x86042e  20:01:04:25:b5:3a:00:5e 20:01:00:25:b5:30:01:5f
                               [mcvhes0120hba0]
    port-channel 10  510   0x860431  20:01:04:25:b5:3a:00:2e 20:01:00:25:b5:30:01:2f
                               [awotorprodsql01hba0]
    port-channel 10  510   0x860432  20:01:04:25:b5:3a:00:3e 20:01:00:25:b5:30:01:3f
                               [awotorprodsql02hba0]
    port-channel 10  510   0x860435  20:01:04:25:b5:3a:00:fe 20:01:00:25:b5:30:00:ef
                               [dbcactv01n3hba0]
    port-channel 10  510   0x860436  20:01:04:25:b5:3a:00:de 20:01:00:25:b5:30:00:bf
                               [dbcactv01n4hba0]
    port-channel 10  510   0x860439  20:01:04:25:b5:3a:00:ce 20:01:00:25:b5:30:00:8e
                               [mcvhes0123hba0]
    port-channel 10  510   0x86043a  20:01:04:25:b5:3a:00:be 20:01:00:25:b5:30:00:af
                               [mcvhes0122hba0]
    port-channel 10  510   0x86043c  20:01:04:25:b5:3a:00:ae 20:01:00:25:b5:30:00:9e
                               [mcvhes0124hba0]
    port-channel 10  510   0x860443  20:01:04:25:b5:3a:00:8d 20:01:00:25:b5:30:00:6e
                               [mcvhes0125hba0]
    port-channel 10  510   0x860445  20:01:04:25:b5:3a:00:ee 20:01:00:25:b5:30:00:cf
                               [mcvhes0121hba0]
    port-channel 10  510   0x860446  20:01:04:25:b5:3a:00:9d 20:01:00:25:b5:30:00:7e
                               [mcvhes0126hba0]
    port-channel 10  510   0x860447  20:01:04:25:b5:3a:00:6d 20:01:00:25:b5:30:00:4e
                               [mcvhes0127hba0]
    port-channel 10  510   0x860449  20:01:04:25:b5:3a:00:7d 20:01:00:25:b5:30:00:5e
                               [mcvhes0128hba0]

    I think what you do is F-Port trunking channeling !
    port-channel as a zone member ? I assume you will do pwwn based zoning; in which case the answer is NO !

  • Port-channel Problem between Fabric Interconnect and N7K vPC

    Dear all,
    I have a problem with Port-channel Uplink between Fabric Interconnect with N7K using vPC
    This is my network topology for UCS Deployment
    In N7K I has configured vPC for red link and green link, at Fabric Interconnect A I has configured Port-Channel with member is Port 1 and Port 2, uplink is red link. At Fabric Interconnect B, I has configured Port-Channel with member is Port 1 and Port 2, uplink is green link.
    The show interface port-channel on N7K is good, every port-channel is up and have all member. But At Fabric Interconnnect, when I see on UCS Manager, the status of Port-Channel on Fabic A and Fabric B is fault with Additional Info: No operational member. Although all link is link up and I has status of Port-Channel is enable on UCS Manager. When I see the Properties of Port 1, Port 2 on Port-channel, I see the membership status is : individual. This mean port-channel is not up and no membership in this configuration. I want to using port-channel for load balance and plus more bandwidth for uplink to 20Gig. I don't understand why ?
    Please help me resolve this problem, I has send the capture screen of UCS Manager when I show status of Port-channel and Port-member in port-channel in attach items.
    Anyone can help me to resolve this, thanks you very much. Please reference attach items for more detail about fault.
    Thanks,
    Trung.

    Thanks Matthew very much,
    I has resolved this problem. The reason of problem is miss match protocol of port-channel between N7K and Fabric Interconnect. The Fabric Interconnect always use LACP protocol, but N7K using Port-channel mode on, that why the port-channel failed. I has configured LACP for port-channel in N7K, it has resolved the problems.
    Thanks,
    Trung.

  • Configuring port-channel on N7K

    Hi there,
    I am trying to build a port-channel from N7K-01 to N7K-02 using a breakout cables (40G interface from N7K-01 to 4x10G interfaces on N7K-02). it didn't work
    is this require a special configuration??? because I have done port-channel configuration between two 40G interfaces and it works.
    appreciate your valuable support if possible to share the needed configuration to accomplish this.
    thanks,
    regards,
    Haitham.

    Hi,
    when I do it directly between cisco ASR9k, the 10g interfaces are up with lights but 40G side is red not up.
    between cisco N7Ks, no lights from both sides. between N7Ks cable is going to patch-panel and then to other nexus.
    thanks,

  • SG-300 52p POE and the case of Native vlan forgotten on a Port-channel

    Hi
    We have recently changed our access switched to Cisco Small Business SG-300 52p on which is working firmware
    SW version    1.3.5.58
    We found out a very annoying problem on Port-channel and default vlan topic.
    Our switch have a default vlan diffrent to the vlan 1 that depends on the floor they are, and this native vlan is at first defined on the portchannel of our central switch, a Cisco 3750
    Example of a central switch port-channel with a define native vlan:
    interface Port-channel2
    description TO 1F
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 6
    switchport trunk allowed vlan 4-6,11,13
    switchport mode trunk
    on the SG300 side the configuration is this:
    interface Port-channel2
    description 1F
    switchport trunk allowed vlan add 4-5,11,13
    !next command is internal.
    macro auto smartport dynamic_type switch
    As you can see there is no "switchport trunk native vlan 6" simply because the SG300 once i write it on the command line, it accepts the command but the command sentence is not written on the conf (why?!)
    the result is that everytime the SG300 is restarted on the port-channel i got two AUTO CREATED commands on the configuration "
    switchport trunk native vlan 1
    switchport default-vlan tagged
    that let not work the network on that floor until i manually write on the SG300
    no switchport default-vlan tagged
    switchport trunk native vlan 6
    These command, as said, works once i write them but are not viewed on a "sh run" and so saved on the conf so every time SG 300 is restarted i need to re-write them.
    Is this a bug?
    have i made some mistake?
    Please let me know
    regards
    Pietro

    Figure out!
    the problem was on macro i have to write this:
    macro auto processing type switch disabled
    and then everything starts going as it should be
    Regards
    Pietro

  • 3750-2960 Vlans Issue via Port Channel

    Im trying to get all my vlans to pass thru to my 2960 user level switches, from my 3750 stack.
    Each one of my 2960 stack is connected to my 3750 via port channel. Here is my port setup.
    I have Vlans 1,210,214,216,220,306,406 on my 3750 stack. I cannot see those vlans on my 2960 stack. Why is that? What am I missing from the config?
    Thanks...
    3750 ports:
    interface GigabitEthernet1/0/41
    description Uplink to ETHSW03
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 7 mode active
    interface GigabitEthernet1/0/42
    description Uplink to ETHSW03
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 7 mode active
    interface Port-channel7
    description Uplink to ETHSW03
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    Here are my 2960 ports setup:
    interface GigabitEthernet1/0/47
    description Uplink to CORE01
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 1 mode active
    interface GigabitEthernet1/0/48
    description Uplink to CORE01
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop
    channel-protocol lacp
    channel-group 1 mode active
    interface Port-channel1
    description Uplink to CORE01
    switchport trunk allowed vlan 1,210,214,216,220,306,406
    switchport mode trunk
    snmp trap mac-notification change added
    snmp trap mac-notification change removed
    spanning-tree guard loop

    I have 1 stack of 3750, connected with flex technology.
    I have 3 stacks of 4-2960s, connected with flex technology.
    Then, each 2960 stack is connected to my 3750 stack via port channels (gig ports x2).
    Now, this is a second office site. We are connected to our datacenter via private ethernet line, and thats where most of our vlans and servers reside.
    Output from 3750
    P-DB-CORE01#sh vtp status
    VTP Version capable             : 1 to 3
    VTP version running             : 1
    VTP Domain Name                 : NULL
    VTP Pruning Mode                : Disabled
    VTP Traps Generation            : Disabled
    Device ID                       : 6c41.6a9c.a280
    Configuration last modified by 10.2.20.1 at 3-3-93 23:43:55
    Feature VLAN:
    VTP Operating Mode                : Transparent
    Maximum VLANs supported locally   : 1005
    Number of existing VLANs          : 19
    Configuration Revision            : 0
    MD5 digest                        : 0x3D 0x05 0x4D 0x8C 0x31 0x07 0x34 0xDA
                                        0x2F 0x60 0xE8 0x24 0xA6 0x27 0x59 0x24
    Output from 2960
    P-ETHSW03-20.4#sh vtp status
    VTP Version capable             : 1 to 3
    VTP version running             : 1
    VTP Domain Name                 : NULL
    VTP Pruning Mode                : Disabled
    VTP Traps Generation            : Disabled
    Device ID                       : c07b.bcb2.9a80
    Configuration last modified by 10.2.20.2 at 1-3-14 13:02:15
    Local updater ID is 10.2.20.4 on interface Vl1 (lowest numbered VLAN interface found)
    Feature VLAN:
    VTP Operating Mode                : Server
    Maximum VLANs supported locally   : 255
    Number of existing VLANs          : 7
    Configuration Revision            : 5
    MD5 digest                        : 0x89 0x91 0xBA 0xE3 0x12 0x1B 0xDB 0x1D
                                        0x75 0x43 0x7F 0x8D 0x62 0x5A 0x09 0x70

Maybe you are looking for

  • Intricate generics problem

    I have a problem with this code: interface Test<T extends Number> {     public <U> void test(Test<? super U> t, U value); }Sun javac 1.6.0_13 accepts it, Eclipse 3.5.1 says: "Bound mismatch: The type ? super U is not a valid substitute for the bounde

  • 42 '' Panasonic pro Plasma display or FSI 17'' monitor ??

    i want to buy a second monitor for my grading suite. I already have a Sony CRT ( SD-HD ) that's still in great condition ( bought it new 3 years ago ) and i want to add a nice LCD/Plasma. Is the Panasonic 42'' professional series plasma good enough f

  • Thor digital copy not working?

    Hi I bought the movie Thor today. I loaded the digital copy disk into my PC and redeemed the code as I have done many time before. The only thing is this time the movie downloaded ok and when I click on the movie tab i see it there but it will not pl

  • Should I care about HD versus SD when buying a new camcorder?

    Should I care about HD versus SD when buying a new camcorder? I coach track, and need a good optical zoom and want to keep my budget around $300-400. Should I care about HD? Suggested camcorders?

  • How to stop the Company Code popup window in MIRO!

    Hi, When User logs in the system and enters into the MIRO transaction, he is asked to enter the Company Code first in order to proceed further. I know that once you enter the company code then the system does not ask it to enter again during that log