Nexus 5548UP FCoE to C series UCS

Ok here is the scenario
nexus 5548 switch ---- fex 2232 --- UCS C series (C220)
snippets of the configuration:
vlan 1100
fcoe vsan 1100
vlan database
vsan 1100
fex 100
description 2232-A
fcoe
int ethernet100/1/1
switchport
switchport mode trunk
switchport trunk allowed vlan 10,1100           
interface vfc100
bind interface ethernet100/1/1
switchport trunk allowed vsan 1100
no shut
so it is configured above, the vfc interface won't trunk unless I do the following:
vsan database
vsan 1100 interface vfc100
I found this document that describes mapping VSANs to VLANs example configuration (page 8)

Each fc and/or vfc interface must be member of a VSAN; by default, they belong all initially to VSAN 1.

Similar Messages

  • Single Nexus 5548UP- FCoE configuration with multiple server ports

    Hello Everyone,
    I am new to Networking so please bear with me.
    Here is some background information. We have a SINGLE Nexus 5548 UP switch to which we are connecting both the storage and the UCS C240 M3 servers (with CNA). Both the storage and server has 2 ports each going to this nexus switch.
    We want to implement FCoE with this solution.
    Below are the steps (for server ports) that I have followed to configure the nexus. But the port not logging into the SAN (no flogi) with the config.
    Enable Features
    config t
    feature lacp
    feature dot1x
    feature interface-vlan
    feature sshServer
    feature npiv
    end
    Confgure Ethernet Ports - Server 
    configure
    interface ethernet 1/17
    description To_UCS_rack_server_1_FCoE_port_1
    switchport mode trunk
    switchport trunk native vlan 6
    switchport trunk allowed vlan 1,6
    spanning-tree port type edge trunk
    priority-flow-control mode on
    no shutdown
    end
    configure
    interface ethernet 1/18
    description To_UCS_rack_server_1_FCoE_port_2
    switchport mode trunk
    switchport trunk native vlan 6
    switchport trunk allowed vlan 1,6
    spanning-tree port type edge trunk
    priority-flow-control mode on
    no shutdown
    end
    Create VLAN
    configure
    vlan 6
    name FCOE_VLAN
    fcoe vsan 6
    end
    Setup FCoE QOS
    configure terminal
    system qos
    service-policy type qos input fcoe-default-in-policy 
    service-policy type queuing input fcoe-default-in-policy 
    service-policy type queuing output fcoe-default-out-policy 
    service-policy type network-qos fcoe-default-nq-policy 
    end
    Create vfc for Initiators (UCS Servers)
    configure
    interface vfc 17
    bind interface ethernet 1/17
    switchport description virtual_fiber_channel_Server1_Port1
    end
    configure
    interface vfc 18
    bind interface ethernet 1/18
    switchport description virtual_fiber_channel_Server1_Port2
    end
    Adding vFC’s to VSAN
    configure
    vsan database
    vsan 6 interface vfc 17
    vsan 6 interface vfc 18
    Create Zonesets and Zones
    configure
    show flogi database vsan 6      ----> Do not see any pwwn here???
    show fcns database vsan 6
    Any help in the regard would be highly appreciated.
    Cheers,
    KS

    Fixed the issue. "switchport trunk native vlan 6" was causing the issue. Maybe the storage and Servers were not configured with proper VLAN's. I removed the native vlan and everything logged in fine.
    Any how I have configured a single zone with all 3 servers pWWN's. I know single initiator zoning is the way to go.
    Can you please guide me if I can move these servers in their separate zones without any outages?  If it helps, all severs have 2 pWWN's. The current zoneset is active with that single zone.
    Please let me know if you need any additional details.
    Cheers,
    KS

  • Nexus 5548UP FCoE

    Hi,
    I'm trying to setup an connection from Netapp to n5k using CNA card on Netapp.
    I've configured n5k as it should, but it seems that it always fails with:
    2011 Jun 27 11:45:19 site1-n5k-sw1 %PORT-5-IF_TRUNK_DOWN: %$VSAN 50%$ Interface vfc31, vsan 50 is down (waiting for flogi)
    Any ideas if it's configured wrongly on nexus side ... (?) Thanks.
    feature fcoe
    interface Ethernet1/23
      switchport mode trunk
      spanning-tree port type edge trunk
    vlan 50
      fcoe vsan 50
    vsan database
      vsan 50 interface vfc31
    interface vfc31
      bind interface Ethernet1/23
      switchport trunk allowed vsan 50
      no shutdown
    # sh vsan membership
    vsan 50 interfaces:
        fc1/29            vfc31
    n5k-sw1(config-if)# sh int vfc31
    vfc31 is trunking
        Bound interface is Ethernet1/23
        Hardware is Virtual Fibre Channel
        Port WWN is 20:1e:00:05:73:f2:b0:bf
        Admin port mode is F, trunk mode is on
        snmp link state traps are enabled
        Port mode is TF
        Port vsan is 50
        Trunk vsans (admin allowed and active) (50)
        Trunk vsans (up)                       ()
        Trunk vsans (isolated)                 ()
        Trunk vsans (initializing)             (50)
        1 minute input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
        1 minute output rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
          0 frames input, 0 bytes
            0 discards, 0 errors
          0 frames output, 0 bytes
            0 discards, 0 errors
        last clearing of "show interface" counters never
        Interface last changed at Mon Jun 27 11:43:17 2011
    -n5k-sw1(config-if)# sh flogi database
    INTERFACE        VSAN    FCID           PORT NAME               NODE NAME
    fc1/29           50    0xb80000  20:41:00:05:73:e3:59:80 20:32:00:05:73:e3:59:81
    Total number of flogi = 1.

    Documentation says so
    The Ethernet interface that you bind the virtual Fibre Channel interface to must be configured as follows:
    •It must be a trunk port (use the switchport mode trunk command).
    •The FCoE VLAN that corresponds to virtual Fibre Channel's VSAN must be in the allowed VLAN list.

  • Nexus 5548UP/2232PP/FCoE

    Hi,
    In my enviroment I have a datacenter with 2 Nexus 5548UP with FCoE Licence. As I am new to storage networking I need some information about the configuration of FCoE.
    The enviroment is :
    2 x 5548UP Switch
    2 x 2232PP FEX
    1 x Host with Emulex OneConnect OCe10102-F interface
    1 x storage with FCoE interface.
    How many virtual SANs we can create with a single stoarge device.
    I have to configure this 2 5548UP Vs the 2 FEX 2232PP with FCoE.
    1) I have to map each vsan with a Layer 2 FCoE Vlan?
    2) How I can distribute the VSans (and the FcoE Vlans) and the Ethernet Vlans from the 2 FEX 2232PP Vs the 2 5548UP? How many Links? Is better to do a Port-Channel or different Port-Channels? Best Practices?
    3) In which way we need to configure the Teaming? Active Standby or Active Active?
    4) I studied that, it is possibile to do an ISL Trunk between the two Nexus 5548UP switches...right? Can I Create a port-channel and allow all the vsans?
    Kindly guide me with proper connection diagram and configuration steps.
    Thanks in advance!
    Gaurav

    Assuming FEXes are already connected and operational. Nexus 5548 cannot run in NPV mode. You have to configure zoning in addition to following configuration.
    @Nexus 5548 switch1
    feature fcoe
    vlan 100
    name DATA_VLAN
    vlan 101
    name Fabric_A_SAN101
    fcoe vsan 101
    vlan 102
    name Fabric_B_SAN102
    fcoe vsan 102
    vsan database
    vsan 101
    vsan 101 interface vfc 101
    vsan 101 interface vfc 13
    vsan 102
    vsan 102 interface vfc 102
    vsan 102 interface vfc 23
    int eth 102/1/1
    description server CNA port 1
    switchport mode trunk
    spanning-tree port type edge trunk
    int vfc 101
    bind interface eth 102/1/1
    switchport mode F
    int eth1/3
    description Interswitchlink
    switch mode trunk
    switchport trunk allowed vlan exclude 101
    int vfc 102
    bind interface eth1/3
    switchport mode E
    int eth1/2
    descrition Storage port 1
    switchport mode trunk
    spanning-tree port type edge trunk
    interface vfc 13
    bind interface eth1/2
    switchport mode F
    int eth1/6
    descrition storage port2
    switchport mode trunk
    spanning-tree port type edge trunk
    interface vfc 23
    bind interface eth1/6
    switchport mode F
    system qos
    service-policy type qos input fcoe-default-in-policy
    service-policy type queuing input fcoe-default-in-policy
    service-policy type queuing output fcoe-default-out-policy
    service-policy type network-qosfcoe-default-nq-policy
    @Nexus 5548 switch2
    feature fcoe
    vlan 102
    name Fabric_B_SAN102
    fcoe vsan 102
    vsan database
    vsan 102
    vsan 102 interface vfc 102
    vsan 102 interface vfc 12
    int eth1/3
    description interswitch link
    switch mode trunk
    switchport trunk allowed vlan 102
    int vfc 102
    bind interface eth1/3
    switchport mode E
    int eth101/1/1
    switchport mode trunk
    spanning-tree port type edge trunk
    interface vfc 12
    bind interface eth101/1/1
    switchport mode F
    system qos
    service-policy type qos input fcoe-default-in-policy
    service-policy type queuing input fcoe-default-in-policy
    service-policy type queuing output fcoe-default-out-policy
    service-policy type network-qosfcoe-default-nq-policy

  • Ask the Expert: Cisco Nexus 2000, 5000, and 6000 Series Switches

    with Cisco Expert Vinayak Sudame
    Welcome to the Cisco Support Community Ask the Expert conversation. This is an opportunity to learn and ask questions how to configure and troubleshoot the Cisco Nexus 2000, 5000 and 6000 Series Switches with Cisco subject matter expert Vinayak Sudame. You can ask any question on configuration, troubleshooting, features, design and Fiber Channel over Ethernet (FCoE).
    Vinayak Sudame is a Technical Lead in Data Center Switching Support Team within Cisco's Technical Services in RTP, North Carolina. His current responsibilities include but are not limited to Troubleshooting Technical support problems and Escalations in the areas of Nexus 5000, Nexus 2000, FCoE. Vinayak is also involved in developing technical content for Cisco Internal as well as external. eg, Nexus 5000 Troubleshooting Guide (CCO), Nexus 5000 portal (partners), etc. This involves cross team collaboration and working with multiple different teams within Cisco. Vinayak has also contributed to training account teams and partners in CAE (Customer Assurance Engineering) bootcamp dealing with Nexus 5000 technologies. In the past, Vinayak's responsibilities included supporting MDS platform (Fiber Channel Technologies) and work with EMC support on Escalated MDS cases. Vinayak was the Subject Matter Expert for Santap Technologies before moving to Nexus 5000 support. Vinayak holds a Masters in Electrical Engineering with Specialization in Networking from Wichita State University, Kansas. He also holds Cisco Certification CCIE (#20672) in Routing and Switching.
    Remember to use the rating system to let Vinayak know if you have received an adequate response.
    Vinayak might not be able to answer each question due to the volume expected during this event. Remember that you can continue the conversation on the  Data Center sub-community, Other Data Center Topics discussion forum shortly after the event.
    This event last through Friday July 12, 2013. Visit the community often to view responses to youe questions of other community members.

    Hi Vinayak,
    Output of "show cfs internal ethernet-peer database"
    Switch 1
    ETH Fabric
    Switch WWN              logical-if_index
    20:00:54:7f:ee:b7:c2:80 [Local]
    20:00:54:7f:ee:b6:3f:80 16000005
    Total number of entries = 2
    Switch 2
    ETH Fabric
    Switch WWN              logical-if_index
    20:00:54:7f:ee:b6:3f:80 [Local]
    20:00:54:7f:ee:b7:c2:80 16000005
    Total number of entries = 2
    Output of "show system internal csm info trace"
    Switch 1 in which "show cfs peers" show proper output
    Mon Jul  1 05:46:19.145339  (CSM_T) csm_sp_buf_cmd_tbl_expand_range(8604): No range command in buf_cmd_tbl.
    Mon Jul  1 05:46:19.145280  (CSM_T) csm_set_sync_status(6257): Peer RT status PSSed
    Mon Jul  1 05:46:19.145188  (CSM_T) csm_sp_handle_local_verify_commit(4291):
    Mon Jul  1 05:46:19.145131  csm_continue_verify_ac[597]: peer is not reachable over CFS so continuing with local verify/commit
    Mon Jul  1 05:46:19.145071  csm_tl_lock(766): Peer information not found for IP address: '172.16.1.54'
    Mon Jul  1 05:46:19.145011  csm_tl_lock(737):
    Mon Jul  1 05:46:19.144955  (CSM_EV) csm_sp_build_tl_lock_req_n_send(941): sending lock-request for CONF_SYNC_TL_SESSION_TYPE_VERIFY subtype 0 to Peer ip = (172.16.1.54)
    Mon Jul  1 05:46:19.143819  (CSM_T) csm_copy_image_and_internal_versions(788): sw_img_ver: 5.2(1)N1(2a), int_rev: 1
    Mon Jul  1 05:46:19.143761  (CSM_T) csm_sp_get_peer_sync_rev(329): found the peer with address=172.16.1.54 and sync_rev=78
    Mon Jul  1 05:46:19.143699  (CSM_T) csm_sp_get_peer_sync_rev(315):
    Mon Jul  1 05:46:19.143641  (CSM_EV) csm_sp_build_tl_lock_req_n_send(838): Entered fn
    Mon Jul  1 05:46:19.143582  (CSM_T) csm_set_sync_status(6257): Peer RT status PSSed
    Switch 2 in which "show cfs peers" does not show proper output
    Mon Jul  1 06:13:11.885354  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport mode trunk, cmd pseq 77 seq 482
    Mon Jul  1 06:13:11.884992  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd channel-group 51 mode active, cmd pseq 357 seq 369
    Mon Jul  1 06:13:11.884932  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport trunk allowed vlan 2, 11, cmd pseq 357 seq 368
    Mon Jul  1 06:13:11.884872  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport mode trunk, cmd pseq 357 seq 367
    Mon Jul  1 06:13:11.884811  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd description process_vpc, cmd pseq 357 seq 366
    Mon Jul  1 06:13:11.884750  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd channel-group 51 mode active, cmd pseq 352 seq 365
    Mon Jul  1 06:13:11.884690  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport trunk allowed vlan 2, 11, cmd pseq 352 seq 364
    Mon Jul  1 06:13:11.884630  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd switchport mode trunk, cmd pseq 352 seq 363
    Mon Jul  1 06:13:11.884568  (CSM_ERR) csm_pss_cmd_tree_walk_cb(2057): Parent command not found for cmd description process_vpc, cmd pseq 352 seq 362
    Mon Jul  1 06:13:11.884207  (CSM_EV) csm_sp_acfg_gen_handler(3011):  Preparing config into /tmp/csm_sp_acfg_1733916569.txt
    Mon Jul  1 06:13:11.878695  csm_get_locked_ssn_ctxt[539]: Lock not yet taken.
    Mon Jul  1 06:13:11.878638  (CSM_EV) csm_sp_acfg_gen_handler(2937): Recieved sp acfg merge request for type: running cfg
    Mon Jul  1 06:12:29.527840  (CSM_T) csm_pss_del_seq_tbl(1989): Freeing seq tbl data
    Mon Jul  1 06:12:29.513255  (CSM_T) csm_sp_acfg_gen_handler(3106): Done acfg file write
    Mon Jul  1 06:12:29.513179  (CSM_EV) csm_sp_acfg_gen_handler(3011):  Preparing config into /tmp/csm_sp_acfg_1733911262.txt
    Mon Jul  1 06:12:29.508859  csm_get_locked_ssn_ctxt[539]: Lock not yet taken.
    Mon Jul  1 06:12:29.508803  (CSM_EV) csm_sp_acfg_gen_handler(2937): Recieved sp acfg merge request for type: running cfg
    Mon Jul  1 05:53:17.651236  Collecting peer info
    Mon Jul  1 05:53:17.651181  Failed to get the argumentvalue for 'ip-address'
    Mon Jul  1 05:40:59.262736  DB Unlocked Successfully
    Mon Jul  1 05:40:59.262654  Unlocking DB, Lock Owner Details:Client:1 ID:1
    Mon Jul  1 05:40:59.262570  (CSM_T) csm_sp_del_buf_cmd(1713): Deleting comand with Id = 1
    Mon Jul  1 05:40:59.262513  DB Lock Successful by Client:1 ID:1
    Mon Jul  1 05:40:59.262435  Recieved lock request by Client:1 ID:1
    Mon Jul  1 05:40:41.741224  ssnmgr_ssn_handle_create_get: Session FSM already present, ID:1
    Mon Jul  1 05:40:41.741167  ssnmgr_handle_mgmt_request: Create/Get request received for session[process_n5kprof]
    show cfs lock gives no output.
    Just to further clarify, we have 4 5548UP switches in the same management vlan. 2 switches are in one location lets say location A and they are CFS peers and are working fine.
    These two switches which are having problem are in location B. All the switches are in the same vlan. Essentially the all CFS multicast messages will be seen by all 5548 switches as they are in the same vlan. I am assuming that this might not create any problems as we specify the peers in the respective configurations. Or do we have to change the CFSoIPv4 multicast addresses in location B or may be configure a different region.
    Regards.

  • C-200 M2 with P81E to Nexus 5548UP

    Hi all,
    I'm working on a project which is about to set up a Cisco UCS Lab.
    Actually the topology looks simple and easy but there must be some missconfiguration on my side because i can't see any of IDs (P81E's wwpn and mac address info) from the Nexus 5548UP.
    I connected my 5548UP to MDS 9124 for providing the FCoE traffic to the C-200 Farm.
    Then i configured the MDS with NPIV and converted couple of ethernet ports to the FC ports on 5548UP (which i'm using to connect to the MDS)
    Finally i connected my C-200M2's VIC to the 5548UP but i couldn't see any information about server. The ports actually are up. But can't see nothing.
    Some help and advises will be appreciated.

    Padma,
    Right now i connected the N5548 directly to the storage for that reason you can not see the fc uplink connections on running-configuration.
    On Nexus 5548 ;
         Ethernet 1/1 and Ethernet 1/2 are the server ports (P81E)
         Ethernet 1/15 is the Uplink Ethernet port
         Fc 1/31 1/32 is the Storage Ports
         Storage has been configured for the wwpns and LUNs.
    And here is the configuration :
    N5548(config-if)# show running-config
    !Command: show running-config
    !Time: Tue Jan 24 13:32:53 2012
    version 5.0(3)N2(1)
    feature fcoe
    feature telnet
    feature lldp
    username admin password 5 $1$XCMHODt3$yEItwOs0Vl.LLYyXBPjZu0  role network-admin
    no password strength-check
    ip domain-lookup
    hostname N5548
    class-map type qos class-fcoe
    class-map type queuing class-fcoe
      match qos-group 1
    class-map type queuing class-all-flood
      match qos-group 2
    class-map type queuing class-ip-multicast
      match qos-group 2
    class-map type network-qos class-fcoe
      match qos-group 1
    class-map type network-qos class-all-flood
      match qos-group 2
    class-map type network-qos class-ip-multicast
      match qos-group 2
    slot 1
      port 1-24 type ethernet
      port 25-32 type fc
    snmp-server user admin network-admin auth md5 0x29cde3d41c6724dcbec14cf28387824d
    priv 0x29cde3d41c6724dcbec14cf28387824d localizedkey
    snmp-server enable traps entity fru
    vrf context management
    vlan 1
      fcoe vsan 1
    fcdomain fcid database
      vsan 1 wwn 50:06:0e:80:10:4d:03:60 fcid 0xa10000 dynamic
      vsan 1 wwn 50:06:0e:80:10:4d:03:62 fcid 0xa10001 dynamic
    interface vfc1
      bind interface Ethernet1/1
      no shutdown
    interface vfc2
      bind interface Ethernet1/2
      no shutdown
    interface fc1/25
    interface fc1/26
    interface fc1/27
    interface fc1/28
    interface fc1/29
    interface fc1/30
    interface fc1/31
      no shutdown
    interface fc1/32
      no shutdown
    interface Ethernet1/1
    interface Ethernet1/2
    interface Ethernet1/3
    interface Ethernet1/4
    interface Ethernet1/5
    interface Ethernet1/6
    interface Ethernet1/7
    interface Ethernet1/8
    interface Ethernet1/9
    interface Ethernet1/10
    interface Ethernet1/11
    interface Ethernet1/12
    interface Ethernet1/13
    interface Ethernet1/14
    interface Ethernet1/15
      switchport mode trunk
      speed 1000
    interface Ethernet1/16
    interface Ethernet1/17
    interface Ethernet1/18
    interface Ethernet1/19
    interface Ethernet1/20
    interface Ethernet1/21
    interface Ethernet1/22
    interface Ethernet1/23
    interface Ethernet1/24
    interface mgmt0
      ip address 192.168.10.210/24
    line console
    line vty
    boot kickstart bootflash:/n5000-uk9-kickstart.5.0.3.N2.1.bin
    boot system bootflash:/n5000-uk9.5.0.3.N2.1.bin
    interface fc1/25
    interface fc1/26
    interface fc1/27
    interface fc1/28
    interface fc1/29
    interface fc1/30
    interface fc1/31
    interface fc1/32
    N5548(config-if)#

  • Nexus 5548UP

    Hi,
    Just want to know, how many ports in Nexus 5548UP can be used for 10G connectivity? 
    Thanks,
    Sridhar

    Hi Sridhar,
    At least 32 10G ports SFP+  up to 48:
    "Cisco Nexus 5548P Switch
    The Cisco Nexus 5548P Switch (Figure 1) is the first of the Cisco Nexus 5500 platform switches. It is a one-rack-unit (1RU) 10 Gigabit Ethernet and FCoE switch offering up to 960-Gbps throughput and up to 48 ports. The switch has 32 1/10-Gbps fixed SFP+ Ethernet and FCoE ports and one expansion slot."
    http://www.cisco.com/c/en/us/products/collateral/switches/nexus-5000-series-switches/data_sheet_c78-618603.html
    Regards,
    Gus Magno

  • Cisco Nexus 5548UP to Brocade SAN Connectivity

    Hi,
    I have a Server-SAN-Storage setup as shown in the attachment/below. There are new Cisco UCS rack mount servers with VIC 1225 and Virtual servers on VMware Esxi hypevisor connected to a new Cisco Nexus 5548UP switch in IP+FCoE mode. The new 5548 switch then connects to an existing production SAN of Brocade 48000 Director SAN switch which connects to storage in production environment.
    I need to know the best way to connect the 5548 switch to the Brocade SAN switch without disrupting the existing Production SAN environment i.e. Brocade SAN switch configurations & setup e.g. Fabric Principal switch. priority etc.
    Would configuring the 5548 switch in NPV mode be best practice?

    See Figure 6-2 Converged Multi-hop FCoE Network Design Using FCoE NPV
    http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/operations/fcoe/513_n1_1/ops_fcoe/ops_fcoe_npv.html
    You have to use NPV on N5k, there is no FC interop support on N5k, to connect to Brocade.

  • NEXUS 5548UP LAYOUT - Shared flogi between nexus

    Hello,
    I have 4 Nexus 5548UP, and I need to do they share information of FLOGI among the switches N5K1 and N5K3.
    Today i can do this, the way shown above.
    But I would like to have another link redundancy between switches N5K1 and N5K3.
    I already tried adding this link redundancy on a port-channel, but when I do that I can not share the FLOGI informations between switches.
    I would like your help to know what I can do in this case?.

    In your picture I see, that you plan to use classical Fibrechannel for storage and FCoE for servers.
    Fibrechannel and multihop FCoE has strict design rules of separate fabrics, which is very different to Ethernet (and IP) networking.
    Specially vPC violates this separation; see eg. Fibre Channel over Ethernet Operations
    http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/operations/n5k_fcoe_ops.html#wp1079705
    and
    http://www.cisco.com/en/US/docs/switches/datacenter/nexus5000/sw/mkt_ops_guides/513_n1_1/n5k_enhanced_vpc.html#wp1162674
    SAN A and SAN B Traffic Isolation
    You can deploy FCoE in an Enhanced vPC topology. Traditionally, the SAN network maintains two fabrics, the SAN A and SAN B. The traffic from side A is isolated from side B. Hosts and storage arrays are attached to host SAN networks for high availability. The FCoE traffic in an Enhanced vPC topology maintain the traffic isolation for two SAN networks. The FCoE command ensures the FCoE traffic from the FEX is only sent to one Cisco Nexus 5000 Series device is as follows:

  • LMS User Tracking for NEXUS 5548UP

    Dear,
    A while ago I received a ticket from one of our customers because User Tracking was not working for NEXUS 5548UP on LMS 3.2. I opened a TAC case for this but this was normal since it is a Datacenter switch. Now the customer came back on this because they really want to see which server is connected to which switch port. I understood from the TAC engineer this is not on the roadmap to integrate in LMS 4.x. They want to know if there exists another product (they thought about DCNM) and wanted to know how this integrates or works together with LMS...
    Kind regards,
    Sven Laureyssens                    

    My latest understanding of User Tracking and Nexus 5K series is that it is not supported due to a limitation of the MIB support in the NX-OS.
    The current DCNM (release 5.2) is distinct from the LMS and Cisco Prime umbrella but that wil be changing a bit moving forwad as DCNM is enhanced and rolled into the Cisco Prime family. Last I heard there should be some information coming out of Cisco Live this week and a new release will have some additional functionality and better integration. Still, I doubt we'll see UT for the 5K due to the NX-OS limitation.
    One way to do what you're asking apart from use of any of the Cisco products is to enable LLDP on your Nexus and servers. That will at least give you the ability to pull the information from the NX-OS command line ("show lldp neighbor")

  • Fc ports on nexus 5548up.

    Hi Guyz,
    I have a pair of nexus 5548UP with expansion module N55-M16UP. both switches have below licensing.
    Feature                      Ins  Lic   Status Expiry Date Comments
                                     Count
    FCOE_NPV_PKG                  No    -   Unused             -
    FM_SERVER_PKG                 No    -   Unused             -
    ENTERPRISE_PKG                Yes   -   Unused Never       -
    FC_FEATURES_PKG               Yes   -   In use Never       -
    VMFEX_FEATURE_PKG             Yes   -   Unused Never       -
    ENHANCED_LAYER2_PKG           No    -   Unused             -
    LAN_BASE_SERVICES_PKG         Yes   -   In use Never       -
    LAN_ENTERPRISE_SERVICES_PKG   Yes   -   Unused Never       -
    on first switch i made slot 2 as fc ports & after reload  i can see fc ports.
    slot 2
      port 1-16 type fc
    However with same procedure on switch 2 , i cant see any FC ports nor module 2 ports.
    if i turn module 2 ports to ethernet i can see E2/1 - E2/16 , but no ports when they are configures as FC.
    any idea ???
    Confused as both switches have same lic installed.
    Thanks in Advance.

    After the port type has been changed from Ethernet to FC, the FC port will not be enabled on the switch until FCOE feature is enabled:
    N5K(config)#feature FCOE
    C license checked out successfully
    fc_plugin extracted successfully
    FC plugin loaded successfully
    FCoE manager enabled successfully
    FC enabled on all modules successfully
    Enabled FCoE QoS policies successfully
    After that, we verify that the port type is changed successfully and the FC ports appear on the switch:
    N5K# show interface brief

  • Nexus 5548UP with 1Gb ether to 10Gb ether on same switch

    I have a Nexus 5548UP switch with a couple of systems some of which have been configured with 1Gb nic's running various OS's and other that have 10Gb nic's.  When I try to SSH from 1Gb box to a 1Gb box everything is fine, when I SSH from 1Gb to 10Gb box it does not work but 10Gb to 10Gb boxes will work.  The switch is a fresh install and has one VLAN 51 the first 2 ports are setup with LACP and the only differences is speed of 1000 and 10000 for the boxes attached.  Is there some trick or additional configuration that is needed to make 1Gb to 10Gb work for SSH and other applications?  I trying to setup some test boxes now to have a repeatable environment and will update when completed.
    !Command: show running-config
    !Time: Fri Jan  9 18:30:44 2009
    version 5.2(1)N1(4)
    hostname ISC5548B
    no feature telnet
    feature lacp
    feature lldp
    ...... account info removed
    ssh key rsa 2048
    ip domain-lookup
    class-map type qos class-fcoe
    class-map type queuing class-fcoe
      match qos-group 1
    class-map type queuing class-all-flood
      match qos-group 2
    class-map type queuing class-ip-multicast
      match qos-group 2
    class-map type network-qos class-fcoe
      match qos-group 1
    class-map type network-qos class-all-flood
      match qos-group 2
    class-map type network-qos class-ip-multicast
      match qos-group 2
    vrf context management
      ip route 0.0.0.0/0 192.168.52.1
    vlan 1
    vlan 51
      name InfoSec
    port-profile default max-ports 512
    interface port-channel1
      switchport access vlan 51
      speed 1000
    interface Ethernet1/1
      lacp port-priority 500
      switchport access vlan 51
      speed 1000
      channel-group 1 mode active
    interface Ethernet1/2
      switchport access vlan 51
      speed 1000
      channel-group 1 mode active
    interface Ethernet1/3
      switchport access vlan 51
      speed 1000
    interface Ethernet1/4
      switchport access vlan 51
      speed 1000
    interface Ethernet1/5
      switchport access vlan 51
      speed 1000
    interface Ethernet1/6
      switchport access vlan 51
      speed 1000
    interface Ethernet1/7
      switchport access vlan 51
      speed 1000
    interface Ethernet1/8
      switchport access vlan 51
      speed 1000
    interface Ethernet1/9
      switchport access vlan 51
      speed 1000
    interface Ethernet1/32
      switchport access vlan 51
      speed 1000
    interface Ethernet2/1
      switchport access vlan 51
    interface Ethernet2/2
      switchport access vlan 51
    interface Ethernet2/3
      switchport access vlan 51
    interface Ethernet2/4
      switchport access vlan 51
    interface Ethernet2/5
      switchport access vlan 51
    interface Ethernet2/6
      switchport access vlan 51
    interface Ethernet2/7
      switchport access vlan 51
    interface Ethernet2/8
      switchport access vlan 51
    interface Ethernet2/14
      switchport access vlan 51
    interface Ethernet2/15
      switchport access vlan 51
    interface Ethernet2/16
      switchport access vlan 51
    interface mgmt0
      ip address 192.168.52.4/24
    line console
    line vty
    boot kickstart bootflash:/n5000-uk9-kickstart.5.2.1.N1.4.bin
    boot system bootflash:/n5000-uk9.5.2.1.N1.4.bin
    ISC5548B# show int brief
    Ethernet      VLAN    Type Mode   Status  Reason                   Speed     Port
    Interface                                                                    Ch #
    Eth1/1        51      eth  access up      none                       1000(D) 1
    Eth1/2        51      eth  access up      none                       1000(D) 1
    Eth1/3        51      eth  access up      none                       1000(D) --
    Eth1/4        51      eth  access up      none                       1000(D) --
    Eth1/5        51      eth  access up      none                       1000(D) --
    Eth1/6        51      eth  access up      none                       1000(D) --
    Eth1/7        51      eth  access up      none                       1000(D) --
    Eth1/8        51      eth  access up      none                       1000(D) --
    Eth1/9        51      eth  access up      none                       1000(D) --
    Eth1/10       51      eth  access up      none                       1000(D) --
    Eth1/11       51      eth  access up      none                       1000(D) --
    Eth1/12       51      eth  access up      none                       1000(D) --
    Eth1/13       51      eth  access down    Link not connected         1000(D) --
    Eth1/14       51      eth  access down    Link not connected         1000(D) --
    Eth1/15       51      eth  access up      none                       1000(D) --
    Eth1/16       51      eth  access down    Link not connected         1000(D) --
    Eth1/17       51      eth  access down    SFP not inserted           1000(D) --
    Eth1/18       51      eth  access down    SFP not inserted           1000(D) --
    Eth1/28       51      eth  access down    SFP not inserted           1000(D) --
    Eth1/29       51      eth  access down    SFP not inserted           1000(D) --
    Eth1/30       51      eth  access down    SFP not inserted           1000(D) --
    Eth1/31       51      eth  access down    SFP not inserted           1000(D) --
    Eth1/32       51      eth  access down    SFP not inserted           1000(D) --
    Eth2/1        51      eth  access up      none                        10G(D) --
    Eth2/2        51      eth  access up      none                        10G(D) --
    Eth2/3        51      eth  access up      none                        10G(D) --
    Eth2/4        51      eth  access up      none                        10G(D) --
    Eth2/5        51      eth  access up      none                        10G(D) --
    Eth2/6        51      eth  access up      none                        10G(D) --
    Eth2/7        51      eth  access down    SFP not inserted            10G(D) --
    Eth2/8        51      eth  access down    SFP not inserted            10G(D) --
    Eth2/9        51      eth  access down    SFP not inserted            10G(D) --
    Eth2/10       51      eth  access down    SFP not inserted            10G(D) --
    Eth2/11       51      eth  access down    SFP not inserted            10G(D) --
    Eth2/12       51      eth  access down    SFP not inserted            10G(D) --
    Eth2/13       51      eth  access down    Link not connected          10G(D) --
    Eth2/14       51      eth  access down    SFP not inserted            10G(D) --
    Eth2/15       51      eth  access down    Link not connected          10G(D) --
    Eth2/16       51      eth  access down    Link not connected          10G(D) --
    Port-channel VLAN    Type Mode   Status  Reason                    Speed   Protocol
    Interface
    Po1          51      eth  access up      none                      a-1000(D)  lacp
    Port   VRF          Status IP Address                              Speed    MTU
    mgmt0  --           up     192.168.52.4                            100      1500
    ISC5548B# show interface ethernet 1/3
    Ethernet1/3 is up
     Dedicated Interface
      Hardware: 1000/10000 Ethernet, address: 8c60.4f49.818a (bia 8c60.4f49.818a)
      MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA
      Port mode is access
      full-duplex, 1000 Mb/s, media type is 10G
      Beacon is turned off
      Input flow-control is off, output flow-control is off
      Rate mode is dedicated
      Switchport monitor is off
      EtherType is 0x8100
      Last link flapped 1d02h
      Last clearing of "show interface" counters 1d20h
      30 seconds input rate 0 bits/sec, 0 packets/sec
      30 seconds output rate 304 bits/sec, 0 packets/sec
      Load-Interval #2: 5 minute (300 seconds)
        input rate 0 bps, 0 pps; output rate 200 bps, 0 pps
      RX
        0 unicast packets  0 multicast packets  0 broadcast packets
        0 input packets  0 bytes
        0 jumbo packets  0 storm suppression bytes
        0 runts  0 giants  0 CRC  0 no buffer
        0 input error  0 short frame  0 overrun   0 underrun  0 ignored
        0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
        0 input with dribble  0 input discard
        0 Rx pause
      TX
        202 unicast packets  87027 multicast packets  1077 broadcast packets
        88306 output packets  7601016 bytes
        0 jumbo packets
        0 output errors  0 collision  0 deferred  0 late collision
        0 lost carrier  0 no carrier  0 babble 0 output discard
        0 Tx pause
      4 interface resets
    ISC5548B# show interface ethernet 2/1
    Ethernet2/1 is up
     Dedicated Interface
      Hardware: 1000/10000 Ethernet, address: 8c60.4f23.5de0 (bia 8c60.4f23.5de0)
      MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA
      Port mode is access
      full-duplex, 10 Gb/s, media type is 10G
      Beacon is turned off
      Input flow-control is off, output flow-control is off
      Rate mode is dedicated
      Switchport monitor is off
      EtherType is 0x8100
      Last link flapped 1d20h
      Last clearing of "show interface" counters never
      30 seconds input rate 0 bits/sec, 0 packets/sec
      30 seconds output rate 312 bits/sec, 0 packets/sec
      Load-Interval #2: 5 minute (300 seconds)
        input rate 0 bps, 0 pps; output rate 200 bps, 0 pps
      RX
        285 unicast packets  0 multicast packets  218 broadcast packets
        503 input packets  32724 bytes
        0 jumbo packets  0 storm suppression bytes
        0 runts  0 giants  0 CRC  0 no buffer
        0 input error  0 short frame  0 overrun   0 underrun  0 ignored
        0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
        0 input with dribble  0 input discard
        0 Rx pause
      TX
        406 unicast packets  89109 multicast packets  1077 broadcast packets
        90592 output packets  7827146 bytes
        0 jumbo packets
        0 output errors  0 collision  0 deferred  0 late collision
        0 lost carrier  0 no carrier  0 babble 0 output discard
        0 Tx pause
      1 interface resets

    I have a laptop connected to a port on the switch and I am currently adding a SUSE 11 SP2 to another port that has a 10G card for a NIC.  Once I finished the install I will post more specific tests using ping and SSH to illustrate. 
    Here is the output you requested.
    ISC5548B# show port-channel summary
    Flags:  D - Down        P - Up in port-channel (members)
            I - Individual  H - Hot-standby (LACP only)
            s - Suspended   r - Module-removed
            S - Switched    R - Routed
            U - Up (port-channel)
            M - Not in use. Min-links not met
    Group Port-       Type     Protocol  Member Ports
          Channel
    1     Po1(SU)     Eth      LACP      Eth1/1(P)    Eth1/2(P)
    ISC5548B# sh int po1
    port-channel1 is up
      Hardware: Port-Channel, address: 8c60.4f49.8188 (bia 8c60.4f49.8188)
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec
      reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA
      Port mode is access
      full-duplex, 1000 Mb/s
      Input flow-control is off, output flow-control is off
      Switchport monitor is off
      EtherType is 0x8100
      Members in this channel: Eth1/1, Eth1/2
      Last clearing of "show interface" counters never
      30 seconds input rate 560 bits/sec, 0 packets/sec
      30 seconds output rate 3064 bits/sec, 2 packets/sec
      Load-Interval #2: 5 minute (300 seconds)
        input rate 128 bps, 0 pps; output rate 2.74 Kbps, 2 pps
      RX
        578695 unicast packets  11167 multicast packets  1056 broadcast packets
        590918 input packets  760063851 bytes
        0 jumbo packets  0 storm suppression bytes
        0 runts  0 giants  0 CRC  0 no buffer
        0 input error  0 short frame  0 overrun   0 underrun  0 ignored
        0 watchdog  0 bad etype drop  0 bad proto drop  0 if down drop
        0 input with dribble  0 input discard
        0 Rx pause
      TX
        392417 unicast packets  434693 multicast packets  2984 broadcast packets
        830094 output packets  320257324 bytes
        0 jumbo packets
        0 output errors  0 collision  0 deferred  0 late collision
        0 lost carrier  0 no carrier  0 babble 0 output discard
        0 Tx pause
      1 interface resets

  • Cisco Nexus 5548UP connecting to HP P4330 StoreVirtual over iScsi

    Hi,
    I need some advice when it comes to how to setup a port-channel between Nexus 5548UP and a HP StoreVirtual 4330 device. The idea is to use 2 10 GB ports in a port-channel group and this far I've this on the port-channel group;
    interface port-channel1002
      priority-flow-control mode off
      switchport access vlan 400
      load-interval counter 2 30
      load-interval counter 3 300
    What about priority-flow-control, any needs to change anything here? Any other things that needs to be considered when using iScsi?
    Much appreciated!
    Tony Lewis

    Hi Tony,
    You do not have to worry about PFC. Priority-Flow-Control is something which is related to FCOE or DCBX protocol. With iSCSI as this is a TCP traffic, you have to make sure that you have a proper QOS for the IP Subnet or VLAN that has your iSCSI hosts transmitting the data. As iSCSI rides over TCP this is the major issue that I have seen related to the valid QOS config for the traffic. There is not best practice for it but you have make sure that you added it to a class other than BE or Scavanger class.
    Hope this helps.
    Cheers,
    -amit singh

  • Cisco Nexus 5548UP

    Hi
    I need a switch that supports FC, FCoE and iSCSI traffic. The switch that has been suggested to us is Cisco Nexus 5548UP.
    I have the following queries regarding this switch:
    1)       At our end, I have AMS 2100 Hitachi Storage which has iSCSI & FC Ports. I also have Qlogic CNA card at the server end which supports both ISCSI & FCOE. For FCoE protocol based traffic, the storage to switch connection will have to be FC and the switch to server connection will be FCoE. Can you please confirm whether, if this will be possible through the proposed Cisco Nexus 5548UP switch?
    2)       The specification for the Nexus 5548UP switch claims that it supports 10 Gigabit Ethernet. Can you please confirm if this relates to iSCSI support that the switch provides?
    3)       We are going to use  -SFP-FC4G-SW & SFP-10G-SR SFP for fiber connectivity. Can you please let us know the what these SFP are used for and whether they assist in FC and FCoE traffic forwarding?
    4)       We are also going to use Nexus 5500 Storage License, 8 Ports. Does this indicate that only 8 ports of the switch can be connected to the storage? Among these ports, can we configure 4 ports for FC and 4 ports for iSCSI (keeping in mind that our storage has both FC and iSCSI ports)?
    5)       Is there any License required for enable FC, FCoE and iSCSI protocols?
    An early resolution of these queries will enable us to make a decision regarding the switch.
    Thanks
    Bhanudas Mali

    The specification for the Nexus 5548UP switch claims that it supports 10 Gigabit Ethernet. Can you please confirm if this relates to iSCSI support that the switch provides?
    The "UP" in the Nexus 5548 stands for Universal Port.  This means that each port can support FC, FCoE and Ethernet.  So, a 5548 has 32 ports of SFP/SFP+.  Each port can support and push 10 Gbps at a 1:1 oversubscription rate.
    There is an optional 16-port SFP/SFP+ module, N55-M16UP, which will add an additional 16 Universal Ports.
    Because they are "universal" they can support 1/10 Gbps FCoE and Ethernet as well as 1, 2, 4 and 8 Gbps FC.

  • Cisco Nexus 5548UP and FI6248UP compatibility with FC SFP

    Cisco Nexus 5548UP and FI 6248UP comes with Unified Ports. What are the SFP types this port can take? 1Gig, 10Gig and 2/4/8FC. Could you please clarify?  
    Thanks,
    Cheriyan

    Hi Cheriyan,
    Here is te URL to the 6200 series FI data sheet:
    http://www.cisco.com/en/US/prod/collateral/ps10265/ps11544/data_sheet_c78-675245.pdf
    Check for the table to supported SFPs.
    Same for the 5500 switches
    http://www.cisco.com/en/US/prod/collateral/switches/ps9441/ps9670/data_sheet_c78-618603.html.
    Hope this helps!
    ./Abhinav

Maybe you are looking for