ObjectListItem with additional input controls like Switch

Hi there
I have a sap.m.List and use ObjectListItem to display the information for every single item. However, I have the requirement to add input controls like sap.m.Input and sap.m.Switch. As the layout of ObjectListItem works great for me, I don't want to switch to another ListItem type.
Is there a way to do this?
If not, how can this be solved? Is it needed to extend the ObjectListItem? If so, in which way do I have to extend it?
Any ideas would be great!
Best regards
Tobias

Hi Tobias,
As I understand, you want to create a list, which will have Label at Left and the desired UI Control(Input, or Button, etc) on Right side, like below ->
Inside a List view -->
Label1    Input
Label2    Button
Label3    Switch
corect?
This can be done. Please check following code.
                  new sap.m.List({
                    items : [
                        new sap.m.InputListItem({
                            label : “Quantity”,
                            content : new sap.m.Input( { value : “10” } )
                        new sap.m.InputListItem({
                            label : “Product Name”,
                            content : new sap.m.Input( { value : “Cake”, type : sap.m.InputType.Password } )
                            new sap.m.InputListItem
                              label : "Discount",
                              selected : true,
                              content :
                            this.CheckBoxRememberMEOption,
                              select : function()
Hope you are looking for something like this. Do let me know.
Regards,
Suraj Kumar

Similar Messages

  • In-Ear with the full control like the original ear-phones?

    Hi I been looking for a set of in-ears that got the same control as the original ear-phones that comes with the iPhone, with volume, skip song & talk. I don't want the apple in-ear's. I appreciate answers

    Not sure what you're talking about...  It works just the way I expect it to work on my PC.
    What you say makes a lot of sense though.  Integration with system features is a Good Thing.
    I do wish Windows would provide a text vocalization tool; I have had to install a very old one.  Say hi to (the voice of) Siri for me.
    You can request new features here:
    http://feedback.photoshop.com/photoshop_family
    -Noel

  • E72 or E7 with additional input languages and spel...

    Hi.
    I have a E72 with swedish keyboard and a language package with english, swedish and finnish.
    i am occasionally writing messages in other languages as well (norwegian and polish).
    norwegian input is not a problem, i just use the Symbol key. Polish symbols are not possible though.
    And spellcheckers (prediction) is not possible for norwegian nor polish.
    i have seen it is possible on android phones.
    i really do not need a proper polish keypad as long as i can create the characters, but i would very much appreciate predictive input for norwegian and polish.
    Is there a way to add polish as an input language and add the two spellchecker languages without changing the language package from swedish on the E72?
    how about the E7?

    Hi
    These phones only have standard language packs, so you can't add what you want. There is a complete list of all the language packs somewhere, but I have no idea, which of them contain Polish. Mine has Danish, English, Icelandic and Norwegian...
    I would love Brazilian Portuguese, which I write quite a lot, but then with Portuguese you _can_ get away with no accents at all, although it doesn't look very nice...
    hughm_nyksj_dk

  • Invalid readings with additional inputs

    I am using a PCI-MIO-16E-4 daq. I have three 0-100 mV input channels and three 0-10V inputs. If the 0-10V channels are read simultaneously with 0-100mV channels, the 0-100mV inputs are incorrect. Is this a common problem? How do I fix it?

    It seems that the gain setting is not set right.
    For the channels that are 0-100 mv, set the gain to min=0, max=100mV
    and
    for the 0 to 10 v, set it to min=0, max=10 volts
    There could be issues (with settling time)at high scan rates when the gains are set differently, but for most part, it should work.

  • Wrong LOV in input controls

    Hi all,
    we have an Infoview document containing two reports with an input control on months (01,02,03, etc.). When we open this report for the first time, in the LOV there are other values (i.e. the list of customers)!. We change tab and go to other report, we return to the first one and LOV is correct. We use IE8 and this happens in compatibility mode too.
    Thanks for help.

    Hi,
    That was a very useful answer!
    I have a quick question - I am in BO 4.0 (not 4.1) and I would like to default the "All values" selection to a specific value.
    I have defined the input control using Var_Currency_Type (dimension) and have assigned two values i.e. 'USD' & 'Local Currency'.   The default value is 'USD'.
    The input control works fine. When I select either USD or Local Currency.
    but, I do not see any table when I select 'all values'.  I would like it to display 'USD' when user selects 'All Values'.
    =======================================================================
    In the format table (two tables - one for USD and one for Local currency), I have put in the formula:
    x - Hide when following formula is true
    =ReportFilter([Var_Curency_Type])<>"USD" -- for USD table
    and = ReortFilter([Var_Currency_Type])<>"Local Currency" for Local Currency table.
    ======================================================================
    Does anyone have encoutered this situation.  Could you please share the solution?
    Thanks for your time.

  • No Input controls in Web Intelligence Ritch Client ?

    Hi,
    I have got Web Intelligence Rich Client 12.1.0.882 ( the one from the Trial BO Edge)
    I wan't to set Input Controls like Buttons, etc.
    According to the Documentation "Building Reports with the Web Intelligence Java Report Panel" 
    ( xi31_sp2_webi_java_en.pdf ) this is possible:
    Chapter 19 "Filtering data using input controls"
    Input controls defined
    Input controls provide a convenient, easily-accessible method for filtering
    and analyzing report data. You define input controls using standard windows
    controls such as text boxes and radio buttons. You associate these controls
    with report elements such as tables or section headers, and use the controls
    to filter the data in the report elements. When you select values in the input
    control, Web Intelligence filters the values in the associated report elements.
    Anybody found the Input Control Tab ?
    Where ?
    Wrong version ?
    Thanks
    Martin

    Hello Martin,
    Thank you for your interest in that feature.
    Input controls were delivered from Service Pack 2 of XI 3.1, and are available from all WebI clients, with that release level.
    Version number you provide corresponds to XI 3.1, not XI 3.1 SP2, for which About... should display version number 12.2.0.290, reason why you haven't been able to find the feature.
    Input control tab is available as an extra tab on the left hand side of Rich Client (by default), tab is simply called 'Input Controls', there are also a specific entry on some Report Element contextual menus (to facilitate input control definition from current selection).
    Hope that helps,
    David.

  • Reload page with additional parameter?

    Hi!
    I'm writing a site with the following simple structure: JSP using taglibs is for page structure, and taglibs are for applying XSLT to XML. Model uses XPath to extract needed XML , and there is no controller. Typical JSP is like that news.jsp:
    <my:page>
    <my:header title="News" />
    <my:news show="10">
    <my:rangeSelector />
    </my:news>
    </my:page>This displays a page with 10 news list and a range selector string like that:
    1..10 | 11..20 | 21..25
    Tag my:rangeSelector asks its parent tag my:news (which implements IHasRange, so as my:photos for photogallery thumbnails grid, etc.) about the total number of news to form that range selection string. The idea is the following: after the user clicks for example on 11..20, there goes a request, the same as the previous one, but with additional parameter, something like rangeStart=11. The question is HOW TO ACHIEVE THIS keeping in mind that my:rangeSelector knows nothing about its parent, but that it should implement IHasRange. In other words, how to reload the current page with the same set of parameters, and one more additional parameter, without explicit specifying the page, i. e. without that:
    <my:rangeSelector target="news.jsp" />Maybe Struts as a controller can help? I have no idea about it...
    Thanks a lot! :)
    Constantine Kulak
    FAMI BSU, IBA BY

    I have the same problem: I had used F5 to make text smaller (zoom out). F6 to Zoom In still works, but F5 doesn't. It worked under Safari 4 BETA, but not the release version. I've tried this on several machines.

  • Dependencies between Input Controls

    Hello, Experts.
    I have a trouble with my input controls in webi report XI 3.1.
    Problem statement: There are documents that have authors and executors. Report has two input controls (combo box) "Authors" and "Executors" that are filtering crosstable. When I change value of Author's control - crosstable has changed and executors that is one of axis of crosstable has changed too. But the list of values in Executor's control isn't changing. It shows the list of all values and don't restrict it regardless value from Author's control.
    Is this a feature of input control ? or I place a mistake ?

    Hi Marianne,
    I read your post and I thougt I've got the answer to my question but it doesn't seem to work.
    I've got two dimensions "region" and "country". I want do filter the relevant countries according to the regions so that the drop down filter "country" (report filter bar) shows only the countres within the specific region. According to your advice I placed "region" as a first filter, but still all countries are shown. And it seems that input controls have a limitation in this matter. Any ideas?
    I'm using an excel file as my source (no universe) and webi 4.

  • Challenge: Spanning Tree Control Between 2 links from Switch DELL M6220 to 2 links towards 2 switches CISCO 3750 connected with an stack (behavior like one switch for redundancy)

    Hello,
    I have an Spanning tree problem when i conect  2 links from Switch DELL M6220 (there are blades to virtual machines too) to 2 links towards 2 switches CISCO 3750 connected with an stack (behavior  like one switch  for redundancy, with one IP of management)
    In dell virtual machine is Spanning tree rapid stp, and in 3750 is Spanning tree mode pvst, cisco says that this is not important, only is longer time to create the tree.
     I dont know but do you like this solutions i want to try on sunday?:
     Could Spanning tree needs to work to send one native vlan to negociate the bdpus? switchport trunk native vlan 250
    Is it better to put spanning-tree guard root in both 3750 in the ports to mitigate DELL to be root in Spanning Tree?
    Is it better to put spanning- tree port-priority in the ports of Swicht Dell?
    ¿could you help me to control the root? ¿Do you think its better another solution? thanks!
     CONFIG WITH PROBLEM
    ======================
    3750: (the 2 ports are of 2 switches 3750s conected with a stack cable, in a show run you can see this)
    interface GigabitEthernet2/0/28
     description VIRTUAL SNMP2
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 4,13,88,250
     switchport mode trunk
     switchport nonegotiate
     logging event trunk-status
     shutdown
    interface GigabitEthernet1/0/43
     description VIRTUAL SNMP1
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 4,13,88,250
     switchport mode trunk
     switchport nonegotiate
     shutdown
    DELL M6220: (its only one swith)
    interface Gi3/0/19
    switchport mode trunk
    switchport trunk allowed vlan 4,13,88,250
    exit
    interface Gi4/0/19
    switchport mode trunk
    switchport trunk allowed vlan 4,13,88,250
    exit

    F.Y.I for catylyst heroes - here is the equivalent config for SG-300 - Vlan1 is required on the allowed list on the catylyst side (3xxx/4xxx/6xxx)
    In this example:
    VLANS - Voice on 188, data on 57, management on 56.
    conf t
    hostname XXX-VOICE-SWXX
    no passwords complexity enable
    username xxxx priv 15 password XXXXX
    enable password xxxxxx
    ip ssh server
    ip telnet server
    crypto key generate rsa
    macro auto disabled
    voice vlan state auto-enabled !(otherwise one switch controls your voice vlan….)
    vlan 56,57,188
    voice vlan id 188
    int vlan 56
    ip address 10.230.56.12 255.255.255.0
    int vlan1
    no ip add dhcp
    ip default-gateway 10.230.56.1
    interface range GE1 - 2
    switchport mode trunk
    channel-group 1 mode auto
    int range fa1 - 24
    switchport mode trunk
    switchport trunk allowed vlan add 188
    switchport trunk native vlan 57
    qos advanced
    qos advanced ports-trusted
    exit
    int Po1
    switchport trunk allowed vlan add 56,57,188
    switchport trunk native vlan 1
    do sh interfaces switchport po1
    !CATYLYST SIDE
    !Must Explicitly allow VLan1, this is not normal for catalysts - or spanning tree will not work ! Even though it’s the native vlan on both sides.
    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,56,57,189
    switchport mode trunk

  • How can i control graph with two inputs?

    Hi,
        i would like to ask you about the graph with two inputs
    Normally, if i just give one input, they generate the graph with this input(y) vs time(x).
    But now i would like to get the graph with my two inputs in x axis and y axis .
    i want to control both of two axis. How could i do for it ?
    i attached the file that i try to use "Build XY graph" to control both x and y axis with random number .
    It can run but i don't know how come the graph show nothing. .
    Actually , it have to show something like wavefrom continuously. am i right?
    Could you tell me a way to solve it ? 
    >>>
    what i want to get is ..
    in Graph,
    for x axis , ditance (always increases)
    for y axis , vibration (vary)
    >>>
    Thank you so much for your time . I am looking forward your kindly reply.
    With Respect,
                            Su
    Attachments:
    using Build XY graph.vi ‏59 KB

    Hi NI9233,
    Mind me to interrupt, I am just helping Mike to explain what he meant to you, refer to the graph:
    Picture 1:
    Double click on Build XY Graph, uncheck the clear data on each call
    Picture 2 and 3:
    Change your formula node into +1 Basic Function in Functions Pallette.
    Hope that helps!
    PS: I am sorry for the size of the image, seems I made a mistakes when I saved the picture.
    Sincerely,
    Krisna Wisnu
    Message Edited by Krisna Wisnu on 11-19-2008 08:19 PM
    Sincerely,
    Krisna Wisnu
    Attachments:
    Clear Graph on Each Call.PNG ‏46 KB
    +1.PNG ‏30 KB
    +1_2.PNG ‏21 KB

  • How to modify input range (DAQ assistant) with a numeric control ?

    hello every one
    I am currently working with the NI USB-6218 acquisition card.
    I would like, in order to acquire a signal, to be able to choose the input range of the DAQ assistant with a numeric control ( and not by opening the DAQ assistant window ) (like the "number of sample" and the "rate" entry...)
    Is it possible and if yes, how ?
    Thanks so much in advance for your answers !
    Solved!
    Go to Solution.

    hello
    sorry I forgot it. but after spending a few hours on the problem this morning, i solved it Apparently, I corrupted the general DAQmx assistant last friday. By restarting my computer this morning, this issue was solved and I was able to transform the constant into command for the input range.
    Thanks a lot for your help !!!
    Guyua

  • Yesterday, when I brought my laptop back from sleep, I tried to check my e-mail with the Mail app like I always do. But there was the lightning bolt sign next to the inbox, and the pop-up asked me to input my password, which didn't work. It says mail.mac.

    Yesterday, when I brought my laptop back from sleep, I tried to check my e-mail with the Mail app like I always do. But there was the lightning bolt sign next to the inbox, and the pop-up asked me to input my password, which didn't work. It says mail.mac.com has rejected my password. The password is correct (I'm able to check my e-mail through my browser at me.com), but for some reason Mail keeps on rejecting it. I usually don't have to input my password at all in Mail. Any clue how to fix this? I haven't changed anything at all on my laptop.

    I did change my apple ID password though...

  • Web service data control with complex input parameter problem

    Hi!
    I'm making ADF web app, using JDev 11.1.1.2.0. I have to call a web service (using a data control), which has complex input parameter (array of complex objects).
    I followed steps from Susan Duncan blog: http://susanduncan.blogspot.com/2006/09/dealing-with-complex-input-params-in.html , but I ran into a problem.
    As Susan wrote, I changed submit's button action binding to an operation in a managed bean, which returns array of objects and everything works fine. I can call a WS and my table shows the result.
    The problem is, that after I change button's action binding to my manage bean, row selection in result table doesn't work anymore (I allways get NullPointerException).
    What can be done here?
    Can somebody please help?

    Hi,
    I also have similar type of problem where I need to invoke a Web service with Complex input parameters.
    I followed Susan's blog but I stuck at a point where methos getItem is created.
    Can anyone tell me how to get that method for my requirement.
    If possible can you guys share your solutions here.
    Thanks in advance.

  • Numbers spreadsheet with a guage (speedometer-like) control

    I'm new to the Apple world and need to create a Numbers spreadsheet with a guage (speedometer-like) control that reacts to a value changed by a slider in real-time.  Are there any Numbers featrures or add-ons that provide this type of functionality?  Eventually, I'd like to move this to an iOS app.  Any suggestions on nice charting and guage controls for iOS apps?
    Thanks,
    Lisa

    Here is an old thread dealing with something similar to this.  There is no way in Numbers to make a needle unless you are will to use and X-Y graph and perform the rotation math on many points.  Said another way you cannot insert an image of a needle, then rotat it based on the value of a cell.
    You CAN enter points for the outline of a needle, then perform the math to rotate the points:
    The formulas are:
    columns D and E are the unrotate coordinates for the arrow
    F2=SQRT(D2^2+E2^2)
    G2=ATAN(D2/E2)
    select F2 and G2, then fill down
    B2=F2*SIN($A$1+G2)
    C2=F2*COS($A$1+G2)
    select B2 and C2, then fill down
    make A1 a slider and set the range from 0 to 8 (that'l a little more than twice around, or 2*pi)
    The graph is set so the limits (min and max for X and Y) are -1 to +1
    I hope this is another option

  • I have transefer function like (1/(s^2+s+​5)) and i have a square wave input , i want to use this transfer function with this input to see the output , how can i do that , with example please.

    i need to know also how to represent this transfer function in labview, try to send me example. answer me at my mail

    "st" wrote:
    > answer me at my mail
    give a valid e-mail first, and your name, we don't like to help anonymous
    people
    > try to send me example.
    how much do you pay ?
    > i have transefer function like (1/(s^2+s+5)) and i have a square wave
    > input , i want to use this transfer function with this input to see
    > the output , how can i do that
    First you have to know what you are doing, like an engineer : you have a
    Laplace, continuous time transfer function but LabView handles discrete
    signals only. Use matlab/simulink if you want to simulate continuous time
    systems easily...
    If you definitely want to use LabView, the first step is to discretize your
    continuous-time transfer function, i.e. decide a sampling rate and convert
    it to a "z transfor
    m". Then you can directly use the "IIR Filter.vi" as I
    said earlier.
    Philippe Guglielmetti - www.dynabits.com me at my mail

Maybe you are looking for

  • PDF file as code in email message

    Hi, I received an email with a PDF file attached. This file I can open on a Windows pc or via webmail perfectly, but in Mail the attachment is part of the message (in code): <---start message---> "Dear ..., Hereby you receive the pdf file... %PDF-1.4

  • Possible to create a link in PDF?

    I am new the Acrobat SDK.  I have been asked to develop a tool that searches for a specific string in a PDF document and then creates a UNC link from it to a shared document on the network. This is currently done manually using the Adobe Acrobat prod

  • What's missing in 10g Standard?

    What options features are missing in 10g Standard or Standard ONE as compared to Enterprise Edition?

  • Error: 0x800f0922 when trying to install NFS Server Feature on Windows 2012R2

    I'm trying to install the "Server for NFS" option under the File and Storage Services role on a Windows 2012R2 server, but I keep receiving an 0x800f0922 error. I've tried the install via the GUI and Powershell. I've also tried using the DISM utility

  • Re: Name Service

    Hi, Do you know how to do it in Tool without redirecting stdout ? Daniel Nguyen Freelance Forte Consultant KALLAMBELLA Ajith wrote: > Yes. You can list the named objects using NameService agent commands using EConsole or Escript. Look into the System