ODI PErformance on Specific Interface

Hi
I have migrated an Interface from Dev to QA, Which is worked fine initially until before i killed that particular interface session. After that interface has been taking too much time to load data.
I have executed the same interface in DEv by changing repository connections pointing to QA. It ran fast, time difference is about 30 mins. And this is happenning to only one interace. Rest of the interfaces in QA are running fine.
I looked at the pending sessions, for that particular interface and could n't find any in the work repository.
Any clues to troubleshoot this issue..

Daniel,
I happened to have this code, which I posted in the past. simplified
You could ignore the creation of package and you could include the functionality of procedure A into procedure B in the following example,-- create a SQL type
SQL> create or replace type numTyp as table of number
  2  /
Type created.
SQL> create or replace package test_pkg as
  2    procedure B;
  3  end;
  4  /
Package created.
SQL> create or replace package body test_pkg as
  2 
  2       numArray numTyp := numTyp(); -- initialize
  3 
  3       procedure A Is -- Fills the array
  4       Begin
  5           numArray.extend(2);
  6           numArray(1) := 10;
  7           numArray(2) := 20;
  8       End;
  9   
10       procedure B Is
11       Begin
12          A; -- call to procedure A
13          For rec in (select empno from my_emp where deptno IN
14                       (Select a.column_value  val
15                          From THE ( select cast(numArray as numTyp) from dual ) a))
16          loop
17             dbms_output.put_line(rec.empno);
18          end loop;
19       end;
20  end;
21  /
Package body created.
SQL> exec test_pkg.B;
7782
7839
7934
7369
7876
7902
7788
7566
PL/SQL procedure successfully completed.Not a great example, but it shows how to use SQL type nested tables to use in SQL join operations. Hope it helps.
Thx,
Sri

Similar Messages

  • ODI Performance Tunning

    Hi All,
    our Interface is running very slow.
    The sourc file is flat file and the target is Oracle.
    The source file is having 10 records but its taking more than 15 mins to complete.
    Please let me know all the place where i can look for tuning.
    Cheers,
    Andy

    Hi Andy,
    I am good, how about you?
    ODI performance strategy tells,
    1. Its recommended to run the AGENT in the target host rather than source. In case if your target is a remote host.
    2.Selecting appropriate KMs to load data, for example, if its a simple file to oracle transfer, its recommended to use native DB utilities like SQLLDR, External Table and so on.
    3. In case, if your staging and target are on the same server then make sure in Physical architecture your selected the correct schema (Data Schema and Work Schema)
    4. Right area of execution of joins and filters. If your source has more records then use the filter condition to be executed on SOURCE rather staging.
    5. Increase the Array Fetch Size and Batch Fectch Size of your Data server ( so that agent can accordingly fetch/insert the data)
    And more....
    Thanks,
    G

  • Advice on constructing a test engine and formatting a spreadsheet test file to perform command line interface testing on a product through telnet or serial interface

    Advice on constructing a test engine and formatting a spreadsheet test file to perform command line interface testing on a range of products through telnet or serial interface and output pass/fail results.

    If I understand correctly, you want to do the following:
    1. Create one or more tab-delimited files that specify a series of query strings (that LabVIEW will send to your products) and expected reply strings (that LabVIEW will look for in response to each query)
    2. Run your LabVIEW program (the test engine) and have it execute one or more test scripts from file using either TCP/IP or serial communication to your units under test
    3. Track how many of the queries are met with the expected response, and output an indication of whether each step passed or failed
    If this is close to correct, then I've attached a sample test file and LabVIEW VI as an example; I chose the TCP/telnet method because it allowed me to use the ni.com Web site to simulate my tes
    t hardware. If you happen to own the LabVIEW Internet Toolkit, there's a VI called "Telnet Play Script" in the Telnet palette that does something fairly similar using TCP. The same general model would also work for Serial communications.
    Hope it helps,
    John Lum
    Attachments:
    test_engine.zip ‏24 KB

  • Advice on constructi​ng a test engine and formatting a spreadshee​t test file to perform command line interface testing on a product through telnet or serial interface

    Advice on constructing a test engine and formatting a spreadsheet test file to perform command line interface testing on a range of products through telnet or serial interface and output pass/fail results.

    Hello j. smith,
    TestStand gives you the ability to create "sequence files" which are lists of tests to be run sequentially or in parallel. These tests can be written in any language: LabVIEW VIs, C/C++ DLLs, EXEs, ActiveX objects, .NET Assemblies, etc.
    You can run your TestStand sequence files from a command-line prompt using the following syntax:
    \bin\SeqEdit.exe" /quit -run
    This will launch the TestStand Sequence Editor (and optionally prompt you for TestStand login information if you have this configured), run your sequence file, then exit.
    If you're using the TestStand process model, it can output your results to a report file or database if you configure this. To use a TestStand process mo
    del to execute your sequence file, use the following syntax:
    \bin\SeqEdit.exe" /quit -runEntryPoint
    Here's an example:
    C:\>"C:\Program Files\National Instruments\TestStand 3.0\bin\SeqEdit.exe" /quit -runEntryPoint "Single Pass" "C:\Program Files\National Instruments\TestStand 3.0\Examples\Demo\C\computer.seq"
    Note that multiple sequences and sequence files can be specified on the command line.
    TestStand supports remote sequence execution using DCOM (Distributed COM), which is an east way to remotely execute tests. But as for running tests or commands through a telnet or serial interface, you would have need to check Windows documentation on how to execute command-line remotely like this.
    David Mc.
    NI Applications Engineer

  • How to add a route for a specific interface

    HI,
    i want to make a direct link beetween 2 computers (ubuntu and solaris) with a cross over cable.
    solaris : e1000g0 (192.168.0.212= normal network)
    e1000g1 (172.18.0.2 = network for interconnection beetween ubuntu and solaris
    routing table:
    Destination Gateway Flags Ref Use Interface
    default 192.168.0.245 UG 1 7040 e1000g0
    192.168.0.0 192.168.0.212 U 1 5167 e1000g0
    224.0.0.0 192.168.0.212 U 1 0 e1000g0
    127.0.0.1 127.0.0.1 UH 4 30343 lo0
    ubuntu : eth0 (192.168.0.144 = normal network)
    eth1 (172.18.0.3 = network for interconnection beetween ubuntu and solaris)
    routing table :
    Destination Gateway Genmask Flags MSS Window irtt Iface
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    0.0.0.0 192.168.0.245 0.0.0.0 UG 0 0 0 eth0
    at the beginning, i was thinking that no route was necessary, but the ping didn't work beetween the two servers.
    so, my question is : how can i add a route for a specific interface on my solaris (i want that the traffic for the network 172.18.0.0 go throught e1000g1)
    thank for your help

    SOLARIS :
    -bash-3.00# ifconfig -a
    lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
    inet 127.0.0.1 netmask ff000000
    e1000g0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
    inet 192.168.0.212 netmask ffffff00 broadcast 192.168.0.255
    ether 0:1b:24:f0:7a:fc
    e1000g1: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 3
    inet 172.18.0.2 netmask ffffff00 broadcast 172.18.0.255
    ether 0:1b:24:f0:7a:fd
    -bash-3.00# netstat -rn
    Routing Table: IPv4
    Destination Gateway Flags Ref Use Interface
    default 192.168.0.245 UG 1 7040 e1000g0
    192.168.0.0 192.168.0.212 U 1 5323 e1000g0
    224.0.0.0 192.168.0.212 U 1 0 e1000g0
    127.0.0.1 127.0.0.1 UH 8 31593 lo0
    -bash-3.00#
    UBUNTU :
    ifconfig
    eth0 Link encap:Ethernet HWaddr 00:1e:c9:d1:22:ea
    inet addr:192.168.0.144 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::21e:c9ff:fed1:22ea/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:19992226 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9886296 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:10075930406 (10.0 GB) TX bytes:2847567457 (2.8 GB)
    Interrupt:16 Memory:f8000000-f8012700
    eth1 Link encap:Ethernet HWaddr 00:1e:c9:d1:22:ec
    inet addr:172.18.0.3 Bcast:172.18.0.255 Mask:255.255.255.0
    inet6 addr: fe80::21e:c9ff:fed1:22ec/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:919 errors:0 dropped:0 overruns:0 frame:0
    TX packets:905 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:58816 (58.8 KB) TX bytes:91286 (91.2 KB)
    Interrupt:16 Memory:f4000000-f4012700
    # netstat -rn
    Kernel IP routing table
    Destination Gateway Genmask Flags MSS Window irtt Iface
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
    0.0.0.0 192.168.0.245 0.0.0.0 UG 0 0 0 eth0

  • Archiving and different Retention period by  specific interface

    We want to specify different Retention period for different interfaces (audit reasons)... and based on search in SDN, it does not seem like this is  supported by SAP...
    Do any of you know if SAP intends to support this in future? Any ideas for overcoming this gap? or is this limitation deliberate (and has been kept in place for a reason)?

    Hi Krish,
    Actually I don't think we have this option of setting the retention period for specific interfaces,
    but for the global interfaces in the system.
    If you want to increase the time for Audit Log messages you need to change parameter 'messaging.auditLog.memoryCache' to false in order to persist the audit logs in PI 7.1 system. Take a look at note #1314974 for more details.
    And notice that after changing the parameter to false, audit logs are persisted till the corresponding messages are deleted. The default retention period of messages on AE is 30 days, keep in mind that it could have a little impact on the data volume.
    To increase the retention time in AFW, go to:
    Services -> XPI Adapter: XI:
    "xiadapter.outbound.persistDuration.default"
    "xiadapter.inbound.persistDuration.default"
    For the Integration Engine, it's under SXMB_ADM -> Integration Engine Configuration and Configuration.
    Regards,
    Caio Cagnani

  • Customizing performance threshold for interface utilization in LMS 4.0

    Am running LMS 4.0, i want to customize performance threshold for interface utilization from the default 40% to x%, please help.

    Based on your other post, I think you're talking about Device Fault management.  You can go to Monitor > Fault Settings > Setup > Threshold Settings, and select the DFM > System Defined Groups > Interface and the interface type you want, then edit the thresholds for this group.  Change the default utilization threshold from 40% to your desired value.  Save your changes, then go to Monitor > Fault Settings > Setup > Apple Changes to apply them.

  • Force http traffic to specific interface

    Just setup a 2801 router. We have a Serial interface card on it connected to a T1 and eth1 connected to DSL. We want to force web traffic (http, https, ftp) to use the DSL connection. I tried a simple access-list to allow http to the DSL and deny to the T1, however it didn't seem to work. Then I noticed that in the SDM it has "default" rultes that always enable http. Do I need to disable the http server to get this access list to work or is there an easier way to force web traffic to a specific interface?
    Thanks in advance.

    I setup the route-map and access-list and applied it to FE 0/1 (DSL connection), however it still appears nothing is going through that interface. When I monitor it in the SDM, it shows 0% bandwidth usage.
    Just to double check I unplugged the DSL to see if web traffic stopped, but it was still going, I assume through the T1 at S 0/2/0.
    FE 0/0 goes to our fw, then to lan
    FE 0/1 goes to DSL
    S 0/2/0 goes to T1
    Here is my config:
    router#show run
    Building configuration...
    Current configuration : 4506 bytes
    ! Last configuration change at 10:29:45 MDT Fri Aug 4 2006 by admin
    ! NVRAM config last updated at 15:17:31 MDT Thu Aug 3 2006 by admin
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service sequence-numbers
    boot-start-marker
    boot system flash c2801-ipbasek9-mz.124-8.bin
    boot-end-marker
    security authentication failure rate 3 log
    security passwords min-length 6
    logging buffered 51200 debugging
    logging console critical
    enable secret 5 $1$EWDt$pvWzeNhilneb/EUJosxlv0
    no aaa new-model
    resource policy
    clock timezone MDT -7
    clock summer-time MDT date Apr 6 2003 2:00 Oct 26 2003 2:00
    no ip source-route
    ip cef
    ip tcp synwait-time 10
    no ip bootp server
    ip name-server 198.60.22.2
    ip name-server 198.60.22.22
    username admin privilege 15 secret 5 $1$TF47$aa8RLf18isZxIwjOKfdmZ.
    interface FastEthernet0/0
    description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$
    ip address 199.104.124.210 255.255.255.240
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    duplex auto
    speed auto
    no mop enabled
    interface FastEthernet0/1
    description $FW_OUTSIDE$$ETH-LAN$
    ip address 192.168.2.2 255.255.255.0
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    ip policy route-map toDSL
    duplex auto
    speed auto
    no mop enabled
    interface FastEthernet0/1/0
    interface FastEthernet0/1/1
    interface FastEthernet0/1/2
    interface FastEthernet0/1/3
    interface Serial0/2/0
    ip address 204.228.133.46 255.255.255.252
    interface Vlan1
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip flow ingress
    ip flow egress
    ip route-cache flow
    ip route 0.0.0.0 0.0.0.0 204.228.133.45
    ip route 192.168.2.0 255.255.255.0 192.168.2.1
    no ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 60 life 86400 requests 10000
    logging trap debugging
    access-list 111 permit tcp any any eq www
    no cdp run
    route-map toDSL permit 1
    match ip address 111
    set ip next-hop 192.168.2.1
    control-plane
    banner login ^CAuthorized access only!
    Disconnect IMMEDIATELY if you are not an authorized user!^C
    line con 0
    login local
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    exec-timeout 30 0
    privilege level 15
    login local
    transport input ssh
    transport output ssh
    line vty 5 15
    access-class 102 in
    privilege level 15
    login local
    transport input ssh
    scheduler allocate 20000 1000
    ntp clock-period 17178101
    ntp update-calendar
    ntp server 198.60.22.240 source Serial0/2/0
    end

  • How do i query the module object for the interface of the module-specific interface I require

    Hi there.
    Currently using LabVIEW 2012/TestStand 2012.
    I am attempting to edit the LabVIEW Text Sequence Translator, and in the CreateStep.vi I am trying to create a step that is of type WIS_Sequence_Call (a custom version of NI_Types.ini-->SequenceCall).
    I need to set the file pathname, sequence name and parameter values in the step.  I believe I need to get access to the SequenceCallModule class to do this.
    This help file SequenceCallModule states in the description: "To access the properties and methods of a specific module class, query the Module object for the interface of the module-specific interface you want to acquire.".
    What exactly is meant by "query" here?  It looks like "Specify" might be what I am after, but I want this done programmatically, ie no dialog boxes.
    See my snippet below.
    Thanks.

    Thanks for the reply Charles.
    I have been using the 2012 version of the poster.
    I can get access to the Module class from the Step Class as shown in the snippet above, but I can't see how to get to SequenceCallModule? The "To more specific class" VI doesn't seem to work for TS refs. Is there no way to derive the SequenceCallModule from this?
    Also I can use the TSAdp.SequenceCallModule reference, but I need to link this to the relevant step that I've just created.  Can NI please provide me with a link to any examples on this?
    Thanks

  • ODI Error: While running interface to perform Essbase ouline extraction

    Hi All,
    I have requiremnet to extract all dimensions from Essbase outline and put them into Flat Files.
    I created Essbase and Flatfile model and reversed successfully.
    I created interfaces for each dimension for extracting its metadata to flat file.
    All the interfaces ran successfully except for Entity dimension and Cube_Data.
    When i ran interface to extract Entity dimension i got the following error in "4 - Loading - SS_0 - Extract Metadata" step
    com.hyperion.odi.essbase.ODIEssbaseException: Extract operation failed : Cannot perform cube view operation. Essbase Error(1012703): Unknown calculation type [0] during the dynamic calculation. Only default agg/formula/time balance operations are handled.
    Please help me resolve this.
    Thanks,
    Srinivas
    Edited by: SRINIVAS_N on Apr 28, 2010 12:15 AM

    Hi,
    This is a problem on the essbase side of things and not an ODI issue, it usually means you have a problem with a formula in the outline of your database.
    Cheers
    John
    http://john-goodwin.blogspot.com/

  • ODI Performance Techniques

    Hi,
    How to improve performance in ODI interfaces.
    Is there any settings to to check/Un-check kind of things to improve performance.
    And what is the difference between joins and look-ups in ODI.
    Regards,
    Srini

    1. Tuning in ODI means you have to go for sql tuning. There is nothing specific to odi studio except some jdk issues ( java memory error etc).
    2. Try to find out the step from operator which is taking much time to complete.
    3. See if proper hint can applied to them
    4. Go for tracing to see the exact problem.
    YOu can refer my post for lookup and joins. Again it depends on the requirement.
    http://dwteam.in/lookup-in-odi-11g/

  • Performance of ITS interface to SRM

    We have a Windows OS server with two instances of WAS: one for SRM and the other for XI. SRM web interface via ITS works fine when XI Java stack is down. Once the XI Java stack is started, the SRM web interface suffers
    significant performance deterioration. We can still access SRM via SAP client GUI but the SRM web interface experiences major delays. It appears that when XI Java stack is started, it hogs the resources commonly used by ITS (interfacing to SRM) and the Java stack.

    Hello Amjad.
    What are the hardware specifications for the server?
    Best regards,
    Jacob

  • ODI....Interface Error

    Hi All,
    I am trying to create an XML file from staging tables
    I created several interfaces for loading target datastores for the XML which were reverse engineered from a DTD.
    The source tables are the staging tables.
    All of my interfaces are working except one.
    It shows an error while creating a work table....which I think is a temporary table which ODI creates while executing the interface.
    the one interface shows an error message
    0 : null : java.sql.SQLException: Table already exists: MMMORDERFILE_C$_REQUEST in statement [create table MMMORDERFILE_C$_REQUEST]
    java.sql.SQLException: Table already exists: MMMORDERFILE_C$_REQUEST in statement [create table MMMORDERFILE_C$_REQUEST]
         at com.sunopsis.jdbc.driver.xml.bq.executeUpdate(bq.java)
         at com.sunopsis.jdbc.driver.xml.br.executeUpdate(br.java)
         at com.sunopsis.sql.SnpsQuery.executeUpdate(SnpsQuery.java)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.execStdOrders(SnpSessTaskSql.java)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.treatTaskTrt(SnpSessTaskSql.java)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSqlC.treatTaskTrt(SnpSessTaskSqlC.java)
         at com.sunopsis.dwg.dbobj.SnpSessTaskSql.treatTask(SnpSessTaskSql.java)
         at com.sunopsis.dwg.dbobj.SnpSessStep.treatSessStep(SnpSessStep.java)
         at com.sunopsis.dwg.dbobj.SnpSession.treatSession(SnpSession.java)
         at com.sunopsis.dwg.cmd.DwgCommandSession.treatCommand(DwgCommandSession.java)
         at com.sunopsis.dwg.cmd.DwgCommandBase.execute(DwgCommandBase.java)
         at com.sunopsis.dwg.cmd.e.i(e.java)
         at com.sunopsis.dwg.cmd.g.y(g.java)
         at com.sunopsis.dwg.cmd.e.run(e.java)
         at java.lang.Thread.run(Unknown Source)
    Thank you!

    It seems the table(MMMORDERFILE_C$_REQUEST ) already exist in the work schema,so cant able to create and throw an error. can you tell me which KM you are using?

  • ODI Performance

    Hi Frnds,
    I Created package and executed it in dev. area - total exec. time was 2 minutes.
    With Array size, Batch size = 30 , ODI Init heap = 32m and ODI Max heap = 256 m [ default settings ]
    My system configuration: windows7, 2 GB Ram.
    I thought, i can reduce the execution time i.e. increase the performance by working around array size, batch size, odi init heap , odi max heap.
    I changed array size, batch size = 100 , ODI Init heap = 32m , ODI Max heap = 1024m ---- Execution time = 2 Minutes
    I changed array size, batch size = 100 , ODI Init heap = 256m, ODI Max heap = 1 GB - - - Execution time = 2 Minutes
    Does, Execution time varies by changing array size, batch size, ODI Init Heap, ODI Max heap ? ( Atlst on Prod area )
    If Changes, then can you please guide me how to work around this ?
    Thank you Frnds.
    Edited by: 831909 on Jun 16, 2011 7:33 AM
    Edited by: 831909 on Jun 16, 2011 7:35 AM

    Hi
    There is a nice write up below of how array fetch size impacts performance;
    http://www.business-intelligence-quotient.com/?p=1205
    and below for JDBC batch update size
    http://blog.lishman.com/2008/06/jdbc-batch-updates.html
    You should be able to change these parameters and tune like Uli did in his blog.
    Cheers
    David

  • LMS 4.2 specific interface utilization report

          Hi,
    is there a way to create a interface utilization report only for a specific port? Like switch1->interface fa0/10
    Right now i can only choose all ports from a device?
    Thank you.
    Chris

    So, the new weekly report does not show the high Utilizations anymore, but there is a new problem:
    In the "Report Details", there are 7 devices and 126 interfaces, but in the "Interface Utilization Summary", there are only 49 Interfaces.
    I have added a screenshot, so that you can see, what I mean.

Maybe you are looking for

  • Oim 9.1.0.2 migration to 11.1.1.5

    hi friends, I am looking to migrate oim 9.1.0.2 to 11.1.1.5 can any post me the links regarding this migration task. Thanks & Regards srikanth

  • Messages are not moving to Error Queue in OSB if Error is Raised

    Hi All, My OSB process is as below. Queue1-->OSB-->Queue2. OSB Proxy is listening to the Queue1.When messages comes to Queue1 Proxy will pick the message and after applying the business logic it will put the message to Queue2. If OSB is not able to d

  • Creative video converter problem

    when i first got my creative zen (just the creative zen) i could easy use yt downloader and put the videos on my player not when i use the creative video converter it would keep saying its unscessful at 36%. i tried a video at .9mb and it work but wh

  • Can someone help! Zen Sl

    im trying to contact customer service but the wait time is too much, and i tried email but the link is not working so im stuck talking to no one! if there is anyone out there that li'ves in Califonia, Los Angeles and has a different number to custome

  • Different betwwen Enterprise and Standard

    what is the different between Oracle8 Enterprise Edition and Oracle8 Standard Edition?which one can i download? null