Passing session information to multiple JVM's

Is it possible to pass session information to another JVM running on another server?
Example:
Server A calls a servlet on Server B. Will the session object (and values stored in it) created on Server A be accessible to Server B.

DrClap wrote:
No.This is not exactly true. If you're talking about a clustered app server implementation (for example, Weblogic supports clustering), where 'machine A' and 'machine B' are both part of the same cluster, then, generally speaking, yes, you're HttpSessions are distributed across those machines.
God bless,
-Toby Reyelts

Similar Messages

  • Boyum External Launcher Passing Database Information w/Multiple Parametes

    I have a Boyum button which calls a .NET application passing multiple parameters.  However, I need to add an additional parameter that passes the database name.  Can someone show me the correct syntax to do so?
    Thanks in advance.

    FYI:  Here's the syntax for calling a .NET application and pass multiple arguments (In the "Arguments" field of the "Buttons - Configuration"):
    "C:\ExecutableLocation\Program.exe" | "Value1" "Value2"
    If you'd like to pass values from the form in which the button resides you can do the following:
    "C:\ExecutableLocation\Program.exe" | "$[$8.0.1\]" "$[$16.0.1\]"
    Edited by: David Miller on Oct 7, 2011 4:03 PM

  • Passing Session info between servlets

    We are running WebLogic 5.1, sp 4 and Apache 1.3 on Solaris 2.6 and we are
              successfully proxying requests to the server. But we are unable to pass
              session information between servlets. We are NOT using URL encoding. We are
              instead using cookies. We believe our configuration is correct because the
              BEA example session servlet works. Does anyone have any recommendations or
              suggestions?
              Thank you,
              Jorge
              Jorge A. Martin
              Systems Analyst
              The Kinetic Group
              1950 Stemmons Freeway, Suite 3040
              Dallas, Texas 75207
              

    This is a basic misunderstanding of how Java Works:
    String name +r = request.getParameter(name +r);1) You can't use a + on the left part of an assignment operation - it must be a plain variable reference. This isn't like JavaScript where you have an eval(...) capability.
    2) Your Strings are being defined inside the For Loop, which means they will leave scope once the loop ends and you won't be able to refer to them anymore.
    3) Is there already a String value named 'name' which you are using in getParameters(name+r)? You should probably use getParameter("name"+r) instead.
    What you want to do is either put the values in an array so they are easy to access:
    String name[] = new String[value1];Then loop through the parameters to assign values:
    for(int r = 0; r< value1; r++) { //Start at 0 to value1-1 because arrays are 0 based.
      String nameParam = "name"+ (r+1);
      name[r] = request.getParameter(nameParam);Now I can access the names in order:
    name1 via name[0]
    name2 via name[1]
    name3 via name[2]
    etc...Before going any further I would stop working on Servlets and go back to some good Basic Java Tutorials and books until you get a better grasp of how the language works.

  • Server, Multiple JVMs sources

    Hi,
    i've to create a (web serivce) server application. This application should be ready for clustering or something, if one server isn't fast enough.
    I know already some things abou concurrency in Java. I'm no Java newbie. But i don't know how clustering works.
    Does it depend on the used JVM?
    Or is this for every server (i.e. Tomcat, JBOSS, ...) different?
    What are the requirements in the webservice-layer and in the persistance layer?
    Any good internet pages/PDFs which discusses this?
    Any good books?
    I really hope some can help me here, because it's very important for me.
    Cheers,
    Ingo

    I just re-read the guidelines for a clustered web app over the weekend, so I think I've got things straight. Your application will have to be sensitive to two important issues:
    1) A class which was previously a singleton may now be instantiated in multiple JVMs. The most obvious side effect of this is that the init() method of any servlet will have a different ServletConfig object passed to it for each JVM it is initialized in. As a result, the application context is no longer a valid place to store information, since the change to the application context is not necessarily propagated to the other JVMs. However, context-params will still be available from all JVMs. Another noticable side-effect is that static variables no longer work as expected (since there may be multiple instances of the same class).
    2) The HttpSession object for a given session can only be in existence on one JVM at a time. If the HttpSession needs to migrate to another JVM, then it will be serialized and sent to the other JVM. As a result, adding an object to a session that is not Serializable may result in IllegalArgumentException being thrown. I'm guessing that in the case of a fail-over (node dies unexepectedly) that the HttpSession object is lost.
    Brian

  • Passing Public IPs through multiple ASA's (Part 2) - Continued

    This is the continuation of an issue posted on : https://supportforums.cisco.com/discussion/12463791/passing-public-ips-through-multiple-asas-part-1

    Here is a Show Run from the 5510 (heavily filtered)
    names
    name 10.40.0.0 MCST-FW-Net
    name 70.x.x.179 Masked_FW_Outside
    name 70.x.x.185 Dummy description Placeholder for 182
    name 10.40.128.25 EMAIL
    name 10.40.0.4 OpenVPN
    name 68.x.x.176 NEW_WAN
    name 10.39.0.2 CORE-ASA 
    name 70.x.x.224 PublicIPs
    dns-guard
    interface Ethernet0/0
     nameif outside
     security-level 0
     ip address 68.x.x.178 255.255.255.240
    interface Ethernet0/1
     nameif inside
     security-level 100
     ip address 10.40.0.1 255.255.255.0
    interface Ethernet0/2
     shutdown
     no nameif
     no security-level
     no ip address
    interface Ethernet0/3
     shutdown
     no nameif
     no security-level
     no ip address
    interface Management0/0
     shutdown
     no nameif
     no security-level
     no ip address
     management-only
    boot system disk0:/asa825-13-k8.bin
    ftp mode passive
    dns domain-lookup outside
    dns server-group DefaultDNS
     domain-name MASKED
    same-security-traffic permit inter-interface
    same-security-traffic permit intra-interface
    object-group service TCP-Services tcp
     port-object eq 10101
     port-object eq 123
     port-object range 15000 19999
     port-object eq 2000
     port-object eq 2195
     port-object eq 2196
     port-object eq 5038
     port-object eq 5061
     port-object eq 5228
     port-object eq 5229
     port-object eq 5230
     port-object eq 5432
     port-object eq h323
     port-object eq www
     port-object eq https
     port-object eq kerberos
     port-object eq ldap
     port-object eq ldaps
     port-object eq sip
     port-object eq smtp
     port-object eq ssh
     port-object eq citrix-ica
     port-object eq 943
     port-object eq pptp
     port-object eq imap4
    object-group service UDP-Services udp
     port-object eq 1718
     port-object eq 1719
     port-object eq 2727
     port-object eq 3478
     port-object eq 4500
     port-object eq 4520
     port-object eq 4569
     port-object eq 5000
     port-object range 50000 54999
     port-object range 60000 61799
     port-object eq 88
     port-object eq domain
     port-object eq sip
     port-object eq syslog
     port-object eq ntp
     port-object eq 1194
     port-object eq 8888
    object-group protocol VPN-Traffic
     protocol-object esp
     protocol-object ah
    object-group service TCP-Services-Inbound
     service-object esp
     service-object tcp eq 5228
     service-object tcp eq 5229
     service-object tcp eq 5230
     service-object tcp eq 5432
     service-object tcp eq ssh
    object-group service UDP-Services-Inbound udp
     port-object eq 4500
     port-object eq domain
     port-object eq isakmp
    object-group network test
     network-object 10.40.0.2 255.255.255.255
    object-group service DM_INLINE_UDP_2 udp
     port-object eq 4500
     port-object eq isakmp
    object-group icmp-type DM_INLINE_ICMP_1
     icmp-object echo
     icmp-object echo-reply
    object-group icmp-type DM_INLINE_ICMP_2
     icmp-object echo
     icmp-object echo-reply
    object-group service DM_INLINE_TCP_2 tcp
     group-object Samsung_TCP_Ports
     port-object eq www
     port-object eq https
    object-group network DM_INLINE_NETWORK_1
     network-object MCST-FW-Net 255.255.0.0
     network-object 70.x.x.160 255.255.255.224
    object-group service DM_INLINE_SERVICE_1
     service-object tcp eq 1701
     service-object udp eq 4500
     service-object udp eq isakmp
     service-object udp eq ntp
     service-object tcp eq www
    object-group service DM_INLINE_SERVICE_2
     service-object tcp eq https
     service-object udp eq 1194
     service-object udp eq 8080
    object-group service DM_INLINE_SERVICE_3
     service-object icmp
     service-object tcp eq https
    object-group protocol DM_INLINE_PROTOCOL_1
     protocol-object udp
     protocol-object tcp
    object-group protocol TCPUDP
     protocol-object udp
     protocol-object tcp
    object-group protocol DM_INLINE_PROTOCOL_2
     protocol-object udp
     protocol-object tcp
    object-group network publicips
    access-list inside_access_in extended permit ip PublicIPs 255.255.255.240 any
    access-list inside_access_in extended permit ip host 70.x.x.225 any
    access-list inside_access_in extended permit ip host 70.x.x.236 any
    access-list inside_access_in extended permit udp MCST-FW-Net 255.255.0.0 any object-group UDP-Services log
    access-list inside_access_in extended permit tcp MCST-FW-Net 255.255.0.0 any object-group TCP-Services log
    access-list inside_access_in extended permit esp MCST-FW-Net 255.255.0.0 any log
    access-list inside_access_in extended permit udp MCST-FW-Net 255.255.0.0 any object-group DM_INLINE_UDP_2 log
    access-list inside_access_in extended permit tcp MCST-FW-Net 255.255.0.0 any object-group DM_INLINE_TCP_2 log
    access-list inside_access_in extended permit icmp MCST-FW-Net 255.255.0.0 any log
    access-list inside_access_in extended permit tcp 10.10.10.0 255.255.255.0 any eq 873 inactive
    access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_2 host OpenVPN any
    access-list inside_access_in extended permit udp host 70.x.x.182 any eq 1194
    access-list inside_access_in extended permit tcp host 70.x.x.182 any eq ssh
    access-list inside_access_in extended permit ip host 70.x.x.231 any log
    access-list inside_access_in extended permit ip host 70.x.x.232 any
    access-list inside_access_in extended permit ip host 70.x.x.233 any log
    access-list inside_access_in extended permit ip NEW_WAN 255.255.255.248 interface inside inactive
    access-list inside_access_in extended deny ip any any log
    access-list inside extended permit tcp 70.x.x.240 255.255.255.240 72.x.x.64 255.255.255.224 object-group TCP-Services
    access-list inside extended permit udp 70.x.x.240 255.255.255.240 72.x.x.64 255.255.255.224 object-group UDP-Services
    access-list outside extended permit udp 72.x.x.64 255.255.255.224 70.x.x.240 255.255.255.240 object-group UDP-Services
    access-list outside extended permit tcp 72.x.x.64 255.255.255.224 70.x.x.240 255.255.255.240 object-group TCP-Services
    access-list outside_access_in remark STEALTH RULE
    access-list outside_access_in extended deny ip any host Masked_FW_Outside log
    access-list outside_access_in extended permit ip any PublicIPs 255.255.255.240
    access-list outside_access_in extended permit ip any host 70.x.x.225
    access-list outside_access_in extended permit ip any host 70.x.x.231 log
    access-list outside_access_in extended permit ip any host 70.x.x.232
    access-list outside_access_in extended permit ip any host 70.x.x.233 log
    access-list outside_access_in extended permit ip any host 70.x.x.236 log
    access-list outside_access_in extended permit esp any 70.x.x.160 255.255.255.224 log
    access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_1 any 70.x.x.160 255.255.255.224 log
    access-list outside_access_in extended permit object-group DM_INLINE_SERVICE_3 any 70.x.x.160 255.255.255.224
    access-list outside_access_in extended permit udp any host 70.x.x.182 eq 1194
    access-list outside_access_in extended permit tcp any host 70.x.x.182 eq ssh
    access-list outside_access_in remark Ping
    access-list outside_access_in extended permit icmp any host 10.40.0.33 inactive
    access-list outside_access_in extended permit tcp any 70.x.x.160 255.255.255.224 object-group TCP-Services inactive
    access-list outside_access_in extended permit udp any 70.x.x.160 255.255.255.224 object-group UDP-Services inactive
    access-list outside_access_in extended permit ip PublicIPs 255.255.255.240 NEW_WAN 255.255.255.248 inactive
    access-list outside_access_in extended deny ip any any log
    access-list Mobility_Infrastructure_access_in remark Ping Test
    access-list inside_access_out extended permit ip any any log
    access-list inside_access_out extended permit esp any object-group DM_INLINE_NETWORK_1 log
    access-list inside_access_out extended permit icmp any any
    access-list Inside2_access_in extended permit ip 10.39.0.0 255.255.255.0 any
    access-list Inside2_access_in extended permit ip any 10.39.0.0 255.255.255.0
    pager lines 24
    logging enable
    logging timestamp
    logging console debugging
    logging monitor informational
    logging buffered debugging
    logging trap informational
    logging history critical
    logging asdm warnings
    logging device-id hostname
    mtu outside 1500
    mtu inside 1500
    ip verify reverse-path interface outside
    ip verify reverse-path interface inside
    icmp unreachable rate-limit 1 burst-size 1
    asdm image disk0:/asdm-647.bin
    no asdm history enable
    arp timeout 14400
    global (outside) 1 interface
    nat (inside) 1 0.0.0.0 0.0.0.0
    static (inside,outside) 70.x.x.182 10.40.0.7 netmask 255.255.255.255
    static (inside,outside) 70.x.x.180 10.40.0.2 netmask 255.255.255.255
    static (inside,outside) 70.x.x.181 10.40.0.17 netmask 255.255.255.255
    static (outside,inside) 10.40.0.7 70.x.x.182 netmask 255.255.255.255
    static (outside,inside) 10.40.0.2 70.x.x.180 netmask 255.255.255.255
    static (outside,inside) 10.40.0.17 70.x.x.181 netmask 255.255.255.255
    static (inside,outside) PublicIPs PublicIPs netmask 255.255.255.240
    access-group outside_access_in in interface outside
    access-group inside_access_in in interface inside
    access-group inside_access_out out interface inside
    route outside 0.0.0.0 0.0.0.0 68.101.41.177 1
    route inside 10.40.64.0 255.255.192.0 10.40.0.17 1
    route inside 10.40.128.0 255.255.192.0 10.40.0.17 1
    route inside 10.50.0.0 255.255.255.0 10.40.0.21 1
    route inside 10.50.0.11 255.255.255.255 10.40.0.21 1
    route inside 10.50.112.0 255.255.255.0 10.40.0.21 1
    route inside 10.60.0.233 255.255.255.255 10.40.0.21 1
    route inside PublicIPs 255.255.255.224 10.40.0.21 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
    timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
    timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
    timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
    timeout tcp-proxy-reassembly 0:01:00
    timeout floating-conn 0:00:00
    dynamic-access-policy-record DfltAccessPolicy
    aaa authentication enable console LOCAL
    aaa authentication ssh console LOCAL
    http server enable
    http server session-timeout 10
    http 0.0.0.0 0.0.0.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server enable traps snmp authentication linkup linkdown coldstart
    no sysopt connection permit-vpn
    sysopt noproxyarp inside
    crypto ipsec security-association lifetime seconds 28800
    crypto ipsec security-association lifetime kilobytes 4608000
    telnet timeout 5
    ssh 0.0.0.0 0.0.0.0 inside
    ssh timeout 5
    console timeout 30
    threat-detection basic-threat
    threat-detection statistics
    threat-detection statistics tcp-intercept rate-interval 30 burst-rate 400 average-rate 200
    webvpn
     service-type nas-prompt
    class-map inspection_default
     match default-inspection-traffic
    policy-map type inspect dns preset_dns_map
     parameters
      message-length maximum client auto
      message-length maximum 512
    policy-map global_policy
     class inspection_default
      inspect dns preset_dns_map
      inspect ftp
      inspect h323 h225
      inspect h323 ras
      inspect rsh
      inspect rtsp
      inspect esmtp
      inspect sqlnet
      inspect skinny
      inspect sunrpc
      inspect xdmcp
      inspect sip
      inspect netbios
      inspect tftp
      inspect ip-options
      inspect icmp
    service-policy global_policy global
    privilege cmd level 3 mode exec command perfmon
    privilege cmd level 3 mode exec command ping
    privilege cmd level 3 mode exec command who
    privilege cmd level 3 mode exec command logging
    privilege cmd level 3 mode exec command failover
    privilege cmd level 3 mode exec command vpn-sessiondb
    privilege cmd level 3 mode exec command packet-tracer
    privilege show level 5 mode exec command import
    privilege show level 5 mode exec command running-config
    privilege show level 3 mode exec command reload
    privilege show level 3 mode exec command mode
    privilege show level 3 mode exec command firewall
    privilege show level 3 mode exec command asp
    privilege show level 3 mode exec command cpu
    privilege show level 3 mode exec command interface
    privilege show level 3 mode exec command clock
    privilege show level 3 mode exec command dns-hosts
    privilege show level 3 mode exec command access-list
    privilege show level 3 mode exec command logging
    privilege show level 3 mode exec command vlan
    privilege show level 3 mode exec command ip
    privilege show level 3 mode exec command ipv6
    privilege show level 3 mode exec command failover
    privilege show level 3 mode exec command asdm
    privilege show level 3 mode exec command arp
    privilege show level 3 mode exec command route
    privilege show level 3 mode exec command ospf
    privilege show level 3 mode exec command aaa-server
    privilege show level 3 mode exec command aaa
    privilege show level 3 mode exec command eigrp
    privilege show level 3 mode exec command crypto
    privilege show level 3 mode exec command vpn-sessiondb
    privilege show level 3 mode exec command ssh
    privilege show level 3 mode exec command dhcpd
    privilege show level 3 mode exec command vpn
    privilege show level 3 mode exec command blocks
    privilege show level 3 mode exec command wccp
    privilege show level 3 mode exec command dynamic-filter
    privilege show level 3 mode exec command webvpn
    privilege show level 3 mode exec command module
    privilege show level 3 mode exec command uauth
    privilege show level 3 mode exec command compression
    privilege show level 3 mode configure command interface
    privilege show level 3 mode configure command clock
    privilege show level 3 mode configure command access-list
    privilege show level 3 mode configure command logging
    privilege show level 3 mode configure command ip
    privilege show level 3 mode configure command failover
    privilege show level 5 mode configure command asdm
    privilege show level 3 mode configure command arp
    privilege show level 3 mode configure command route
    privilege show level 3 mode configure command aaa-server
    privilege show level 3 mode configure command aaa
    privilege show level 3 mode configure command crypto
    privilege show level 3 mode configure command ssh
    privilege show level 3 mode configure command dhcpd
    privilege show level 5 mode configure command privilege
    privilege clear level 3 mode exec command dns-hosts
    privilege clear level 3 mode exec command logging
    privilege clear level 3 mode exec command arp
    privilege clear level 3 mode exec command aaa-server
    privilege clear level 3 mode exec command crypto
    privilege clear level 3 mode exec command dynamic-filter
    privilege cmd level 3 mode configure command failover
    privilege clear level 3 mode configure command logging
    privilege clear level 3 mode configure command arp
    privilege clear level 3 mode configure command crypto
    privilege clear level 3 mode configure command aaa-server
    prompt hostname context
    no call-home reporting anonymous
    call-home
     profile CiscoTAC-1
      no active
      destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
      destination address email [email protected]
      destination transport-method http
      subscribe-to-alert-group diagnostic
      subscribe-to-alert-group environment
      subscribe-to-alert-group inventory periodic monthly
      subscribe-to-alert-group configuration periodic monthly
      subscribe-to-alert-group telemetry periodic daily
    Cryptochecksum:bd962a8c0dd6b27b5b024778602f8b60
    : end

  • SSP5: Using multiple JVM for load balance performance?

    Sun 12 MAY 2002
    Apps 11.0.3
    SSP5 patchset I
    HP UX 11.0
    db 8.1.7.2 (64-bit)
    Load 60 concurrent sessions, each spawning 2.5 - 3 http connections.
    CPU 3:750Mhz
    RAM 8G
    Is anybody using multiple JVM for load balance?
    What is your ratio of JVM to concurrent iP sessions?
    Are you running Apache/Jserv on a server with any other applications, or is Apache by itself?
    If you are not using JVM, how many httpd processes do you get before Apache implodes? We stopped in the water at 90 httpd processes, but performance degraded starting at 70 sessions.
    Thx - Don

    Using Web Cache to load balance servlet-based Forms (6i and 9i) is unofficially supported. I say "unofficially" because we have actual customers doing it and getting support, but the 2 development teams (Forms and Web Cache) haven't actually done any integration testing of this sort of configuration yet. For your case, please contact your Support rep and ask what was done to use Web Cache as a load balancer for Forms6i at METRO in Germany. The Forms product managemment team is writing up a white paper to describe how to do it, but until then, you'll need to go through Support. Please contact me if you want more information.

  • Hyperion Smart Cut Session Issue streaming multiple reports at a time using

    This is a lengthly post with details, Please review with Patience:
    We are trying to integrate Workspace based web Analysis reports within our intranet portal, thru portlets (made from individual workspace smartcut link), so that users can customize their page as needed, Once they login thru intranet, Cookie is set and passed to succeeding smart cut links via secured http headers. This part is fine, but mainly running into issue with streaming several multiple web-analysis reports at a time,+ we are using Iframe to display and stream multiple individual reports on to one page, but unfortunately all Iframes are sharing one session rather than creating individual session, mostly because of limitation of current web analysis system architecture and IE browser behavior with sessions .
    Which Hyperion reporting tool does allow to stream multiple reports  at a time? ideally we want to create Iframe of each workspace report so that users can customize and pick portlets as needed. To stream multiple reports at a time.
    Problem Description: Hypeiron Web Analsysis, Smart cut reports incorrectly rendering images and intermixing dash boards on POV changes upon multiple reports being diplayed at one time thru Iframe's, issue seem to mostly relate to Hyperion using single session rather to multiple session when displaying several web reports at a time.
    Steps Needed To Reproduce:
    User logs into workspace.
    user click on expolore and able to view the report without any issues.
    When right on any of the report and select properties.
    Select the SmartCut url and paste it in the Internet explorer.
    The webanalysis report opens without any issues.
    Similarly user copies the smartcut url for a different report and paste the link on a different tab or new window of same browser.
    The report on the first tab gets over written of the report of the second tab of the browser.
    The issue happens when two different reports and opened on a browser with multiple tabs. The reports get over written.
    Oracle development answer:
    In the described scenario opening new browser window does not spawn a separate independent browser session. A new browser window is supplied with URL pointing to the same domain, so all browser cookies including the "ORA_WA_SID" (WA session cookie) are shared between the windows. But multiple application instances cannot run in the same browser session simultaneously because of session sharing. This is not actually a defect, but rather a limitation of current system architecture and browser behavior. And there is no way to fix it programmatically on the product side.

    Hi MeHyper,
    Your current arrangement puts most of the session handling and persistence on the client. This forces you to accept whatever the client decides to persist and propogate between browser elements (in this case iframes).
    My approach would be to:
    Consider coding your portlets to manage the sessions. Manage using a somewhat stateless strategy so that each request to the server requires a login and connect, retrieve, and disconnect. Each Iframe should access a different portlet url (or provide a different query) based on its content.
    This way, in theory, you can invalidate the sessions and related cookies and update the various report elements independently.
    Is smartview out of the question here?
    Regards,
    Robb Salzmann

  • How to pass session variable value with GO URL to override session value

    Hi Gurus,
    We have below requirement.Please help us at the earliest.
    How to pass session variable value with GO URL to override session value. ( It is not working after making changes to authentication xml file session init block creation as explained by oracle (Bug No14372679 : which they claim it is fixed in 1.7 version  Ref No :Bug 14372679 : REQUEST VARIABLE NOT OVERRIDING SESSION VARIABLE RUNNING THRU A GO URL )
    Please provide step by step solution.No vague answers.
    I followed below steps mentioned.
    RPD:
    ****-> Created a session variable called STATUS
    -> Create Session Init block called Init_Status with SQL
        select 'ACTIVE' from dual;
    -> Assigned the session variable STATUS to Init block Init_Status
    authenticationschemas.xml:
    Added
    <RequestVariable source="url" type="informational"
    nameInSource="RE_CODE" biVariableName="NQ_SESSION.STATUS"/>
    Report
    Edit column "Contract Status" and added session variable as
    VALUEOF(NQ_SESSION.STATUS)
    URL:
    http://localhost:9704/analytics/saw.dll?PortalGo&Action=prompt&path=%2Fshared%2FQAV%2FTest_Report_By%20Contract%20Status&RE_CODE='EXPIRED'
    Issue:
    When  I run the URL above with parameter EXPIRED, the report still shows for  ACTIVE only. The URL is not making any difference with report.
    Report is picking the default value from RPD session variable init query.
    could you please let me know if I am missing something.

    Hi,
    Check those links might help you.
    Integrating Oracle OBIEE Content using GO URL
    How to set session variables using url variables | OBIEE Blog
    OBIEE 10G - How to set a request/session variable using the Saw Url (Go/Dashboard) | GerardNico.com (BI, OBIEE, O…
    Thanks,
    Satya

  • Passing Session variable of DATE data type to opaque view filter

    Hi Everyone,
    Can you guys please help me in passing session variable of DATE data type in RPD's physical layer 'opaque view' filter for Oracle database
    I tried following syntax, syntax wise I didn't got getting any error, but at the same time this opaque view is not fetching any records as well. my session variable is "END_DATE" and its value is 1998/12/31:00:00:00(as shown in RPD session windows, datatype is DATETIME)
    SELECT AMOUNT_SOLD, CHANNEL_ID, CUST_ID, PROD_ID, PROMO_ID, QUANTITY_SOLD, TIME_ID FROM SH.SALES
    WHERE TIME_ID =TO_DATE( 'VALUEOF(NQ_SESSION.END_DATE)','MM/DD/YYYY')
    SELECT AMOUNT_SOLD, CHANNEL_ID, CUST_ID, PROD_ID, PROMO_ID, QUANTITY_SOLD, TIME_ID FROM SH.SALES
    WHERE TIME_ID = TO_DATE( 'VALUEOF(NQ_SESSION."END_DATE")','MM/DD/YYYY')
    SELECT AMOUNT_SOLD, CHANNEL_ID, CUST_ID, PROD_ID, PROMO_ID, QUANTITY_SOLD, TIME_ID FROM SH.SALES
    WHERE TRUNC(TIME_ID) = TO_DATE( 'VALUEOF(NQ_SESSION."END_DATE")','MM/DD/YYYY')
    In past, I was able to pass a session variable into a opaque view filter using DATEOF function, but that was in DB2.
    I appreciate your time and help

    Finally, I got right format. here it is
    to_date(substr('valueof(NQ_SESSION.END_DATE)',1,10), 'yyyy-mm-dd')
    and here is the source from where I got this information
    Using OBIEE Session Variables in Select Tables in the Physical Layer

  • Getting session information in servlet?

    In Apache SOAP, org.apache.soap.rpc.SOAPContext can be used as a parameter to get at session data in your servlet. The JDeveloper web services publishing wizard won't expose a method with this parameter, saying that the XML Schema mapping and/or serializer is not specified. Is there an OC4J equivalent to get at session information?

    Hi.
    Most definitely possible. A few months ago I coded something very similar - jsp
    form, submit to a servlet. I needed to get and set session info in both the
    servlet and jsp. The code was very basic (ie no tricks involved) and worked
    well. FWIW both my servlet and jsp were in the same webapp.
    Good luck,
    Michael
    PeterH wrote:
    Howdy.
    re meant something else
    That's what I'm trying to figure out. :>
    re what do I mean by...
    I have one jsp page, that has a an html form on it with elements that get
    passed to a servlet through a submit button on the form. I would like to be
    able to get information about the session from within the servlet. Is that
    possible?
    Let me know if I'm not explaining myself properly and you need more info.
    I'm relatively new to this stuff. But I'm learning! :>>>>
    Thanks for your reply.
    <[email protected]> wrote in message news:[email protected]..
    Hrm. Whoever told you this probably meant something else. What do you mean
    by a 'servlet being called from a jsp' ?
    PeterH <!REMOVEBeforeSending![email protected]> wrote:
    I was told today when using a servlet within a web app (being called
    from a
    jsp), you do not have access to the session object. Is that true?Short of
    passing session attributes via the servlet call, how can you access the
    session information?
    Thanks for any ideas.--
    Dimitri
    Michael Young
    Developer Relations Engineer
    BEA Support

  • Accessing client session information in ejb

    Hi!
    My prblem is the following. We want to access ejb from a servlet. We need some client session information in ejb (e.g. client username, client terminal name, client ip address) for several reason. Could anybody suggest a solution other than passing all the data through the parameter list of every method?
    Thanks for any help.
    Zoltan

    If you use stateful session bean, you can pass this information, when you create it.

  • Passing Session to Other Java Application

    Dear All,
    We need to pass session of SAP BO to other java application.in short we need to make single sign on between these two without using third party authentication type.
    by research , i could find out extension point API which supports to environment, through which it might be possible.
    I need your help on this.
    Environment:
    SAP BO 4.1 Sp2
    Any Help on this would be appreciated.
    Best Regards,
    Atulm

    Hi all, i have one problem. I need to pass some
    session to a java bean for processing.. Can i know are
    there any possible ways of passing? thanks.if i understand you correctly, and you mean passing a session object
    to a bean from a jsp page, do this:
    have in your bean:
    import javax.servlet.http.HttpSession;
    private HttpSession session = null;
    public void setSession (HttpSession sessionFromJsp) {
    session = sessionFromJsp;
    in your jsp:
    beanname.setSession(session);
    the variable named session is available is jsp pages,
    it is an instance of the javax.servlet.http.HttpSession class,
    and provides access to the client session information.
    dave

  • Singletons across multiple JVMs

    I have an EJB application container which is spread across multiple JVMs(something like a clustered EJB container). I am using a Singleton class to hand out 'running serial numbers'. Therefore there is a Singleton class per JVM(which is not very clean but i chose this path in the absence of anything better). Each singleton comes up when it is first invoked within a JVM and reads a starting running number and a pool of numbers from the database. This way multiple Singletons will not step on each other when doling out the serial numbers and there is no need to go back to the database for every request to the 'running serial number'.
    Is there some way to do some of the initialization within these Singleton's just ONCE across the multiple instances of the JVM ie. a real Singleton across multiple JVMs?
    Thanks
    Ramdas

    Pranav,
    thanks for your suggestions.
    the idea of using a Session bean to access a serialized object was one of my design options when i first implemented this, but then i decided against it because of the overhead of having to make an RMI call for every request to the 'running serial number'. The application being written is for a performance benchmark, and the request to the number being done at least once for every transaction, I chose to use Singletons.
    It is a clustered EJB container(not like most conatiners), in the sense that a single container is spread across multiple JVMs.
    Now if your application is getting clustured
    then you have a problem, in that what you can do is
    what object you have made put it in JNDI context and
    everytime you want to edit it pull it out edit and set
    it back. This will act a your singleton object in
    clustured environment accross JVM'sI did not fully understand the second part of your solution????
    Ramdas

  • Accessing the same stateful session bean from multiple clients in a clustered environment

    I am trying to access the same stateful session bean from multiple
              clients. I also want this bean to have failover support so we want to
              deploy it in a cluster. The following description is how we have tried
              to solve this problem, but it does not seem to be working. Any
              insight would be greatly appreciated!
              I have set up a cluster of three servers. I deployed a stateful
              session bean with in memory replication across the cluster. A client
              obtains a reference to an instance of one of these beans to handle a
              request. Subsequent requests will have to use the same bean and could
              come from various clients. So after using the bean the first client
              stores the handle to the bean (actually the replica aware stub) to be
              used by other clients to be able to obtain the bean. When another
              client retrieves the handle gets the replica aware stub and makes a
              call to the bean the request seems to unpredictably go to any of the
              three servers rather than the primary server hosting that bean. If the
              call goes to the primary server everything seems to work fine the
              session data is available and it gets backed up on the secondary
              server. If it happens to go to the secondary server a bean that has
              the correct session data services the request but gives the error
              <Failed to update the secondary copy of a stateful session bean from
              home:ejb20-statefulSession-TraderHome>. Then any subsequent requests
              to the primary server will not reflect changes made on the secondary
              and vice versa. If the request happens to go to the third server that
              is not hosting an instance of that bean then the client receives an
              error that the bean was not available. From my understanding I thought
              the replica aware stub would know which server is the primary host for
              that bean and send the request there.
              Thanks in advance,
              Justin
              

              If 'allow-concurrent-call' does exactly what you need, then you don't have a problem,
              do you?
              Except of course if you switch ejb containers. Oh well.
              Mike
              "FBenvadi" <[email protected]> wrote:
              >I've got the same problem.
              >I understand from you that concurrent access to a stateful session bean
              >is
              >not allowed but there is a
              >token is weblogic-ejb-jar.xml that is called 'allow-concurrent-call'
              >that
              >does exactly what I need.
              >What you mean 'you'll get a surprise when you go to production' ?
              >I need to understand becouse I can still change the design.
              >Thanks Francesco
              >[email protected]
              >
              >"Mike Reiche" <[email protected]> wrote in message
              >news:[email protected]...
              >>
              >> Get the fix immediately from BEA and test it. It would be a shame to
              >wait
              >until
              >> December only to get a fix - that doesn't work.
              >>
              >> As for stateful session bean use - just remember that concurrent access
              >to
              >a stateful
              >> session bean is not allowed. Things will work fine until you go to
              >production
              >> and encounter some real load - then you will get a surprise.
              >>
              >> Mike
              >>
              >> [email protected] (Justin Meyer) wrote:
              >> >I just heard back from WebLogic Tech Support and they have confirmed
              >> >that this is a bug. Here is their reply:
              >> >
              >> >There is some problem in failover of stateful session beans when its
              >> >run from a java client.However, it is fixed now.
              >> >
              >> >The fix will be in SP2 which will be out by december.
              >> >
              >> >
              >> >Mike,
              >> >Thanks for your reply. I do infact believe we are correctly using
              >a
              >> >stateful session bean however it may have been misleading from my
              >> >description of the problem. We are not accessing the bean
              >> >concurrently from 2 different clients. The second client will only
              >> >come into play if the first client fails. In this case we want to
              >be
              >> >able to reacquire the handle to our stateful session bean and call
              >it
              >> >from the secondary client.
              >> >
              >> >
              >> >Justin
              >> >
              >> >"Mike Reiche" <[email protected]> wrote in message
              >news:<[email protected]>...
              >> >> You should be using an entity bean, not a stateful session bean
              >for
              >> >this application.
              >> >>
              >> >> A stateful session bean is intended to be keep state (stateful)
              >for
              >> >the duration
              >> >> of a client's session (session).
              >> >>
              >> >> It is not meant to be shared by different clients - in fact, if
              >you
              >> >attempt to
              >> >> access the same stateful session bean concurrently - it will throw
              >> >an exception.
              >> >>
              >> >> We did your little trick (storing/retrieving handle) with a stateful
              >> >session bean
              >> >> on WLS 5.1 - and it did work properly - not as you describe. Our
              >sfsb's
              >> >were not
              >> >> replicated as yours are.
              >> >>
              >> >> Mike
              >> >>
              >> >> [email protected] (Justin Meyer) wrote:
              >> >> >I am trying to access the same stateful session bean from multiple
              >> >> >clients. I also want this bean to have failover support so we want
              >> >to
              >> >> >deploy it in a cluster. The following description is how we have
              >tried
              >> >> >to solve this problem, but it does not seem to be working. Any
              >> >> >insight would be greatly appreciated!
              >> >> >
              >> >> >I have set up a cluster of three servers. I deployed a stateful
              >> >> >session bean with in memory replication across the cluster. A client
              >> >> >obtains a reference to an instance of one of these beans to handle
              >> >a
              >> >> >request. Subsequent requests will have to use the same bean and
              >could
              >> >> >come from various clients. So after using the bean the first client
              >> >> >stores the handle to the bean (actually the replica aware stub)
              >to
              >> >be
              >> >> >used by other clients to be able to obtain the bean. When another
              >> >> >client retrieves the handle gets the replica aware stub and makes
              >> >a
              >> >> >call to the bean the request seems to unpredictably go to any of
              >the
              >> >> >three servers rather than the primary server hosting that bean.
              >If
              >> >the
              >> >> >call goes to the primary server everything seems to work fine the
              >> >> >session data is available and it gets backed up on the secondary
              >> >> >server. If it happens to go to the secondary server a bean that
              >has
              >> >> >the correct session data services the request but gives the error
              >> >> ><Failed to update the secondary copy of a stateful session bean
              >from
              >> >> >home:ejb20-statefulSession-TraderHome>. Then any subsequent requests
              >> >> >to the primary server will not reflect changes made on the secondary
              >> >> >and vice versa. If the request happens to go to the third server
              >that
              >> >> >is not hosting an instance of that bean then the client receives
              >an
              >> >> >error that the bean was not available. From my understanding I
              >thought
              >> >> >the replica aware stub would know which server is the primary host
              >> >for
              >> >> >that bean and send the request there.
              >> >> >
              >> >> >Thanks in advance,
              >> >> >Justin
              >>
              >
              >
              

  • Single Sign-On and session information

    I have an Oracle Portal application with many Java Web Applications. I wish to
    provide Single Sign-On to this applications. I know how to configure Single
    Sign-On and how to get the user login in Java. I want to store session
    information such as: User First and Last Name, User Social Security Number. I
    want to get this information from the database after authentication, store it
    in session and then access this information from all my applications.

    Are you familiarized with sys_context function?
    Hope this is useful help.
    BR,
    Marcos

Maybe you are looking for