Pbr based ports , not working

Hi,
I need that incoming connection to port 3389 come to ISP1, and incoming connection to port 5800 come to ISP2. I configured the follow config, but not working, could you help me?
And i need another config, the IP SLA to configure outbound traffic from inside to any destination ( except ports 3389 and 5800), the ISP1 is the primary link , when this link is down, the ISP2 stay actived to outbound traffic.
interface GigabitEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip policy route-map internet
 duplex auto
 speed auto
interface GigabitEthernet0/1
 ip address 2.2.2.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
interface GigabitEthernet0/2
 ip address 3.3.3.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
ip nat inside source list nat-isp1 interface GigabitEthernet0/1 overload
ip nat inside source list nat-isp2 interface GigabitEthernet0/2 overload
ip access-list extended nat-isp1
 permit ip any any
ip access-list extended nat-isp2
 permit ip any any
ip nat inside source static tcp 1.1.1.3 5800 3.3.3.2 5800 extendable
ip nat inside source static tcp 1.1.1.3 3389 2.2.2.2 3389 extendable
ip route 0.0.0.0 0.0.0.0 2.2.2.1
ip route 0.0.0.0 0.0.0.0 3.3.3.1
ip access-list extended pbr-isp1
 permit tcp any any eq 3389
ip access-list extended pbr-isp2
 permit tcp any any eq 5800
route-map internet permit 20
 match ip address pbr-isp1
 set ip next-hop 2.2.2.1
 set interface GigabitEthernet0/1
route-map internet permit 30
 match ip address pbr-isp2
 set ip next-hop 3.3.3.1
 set interface GigabitEthernet0/2

Hi LukaszTJB ,
Sorry for the late, I need help again, i´ve configured this way,the IPsla is working, but when the ISP2 come up, the nat table dont clear automatic, i tried EEM but no success.
I need another thing, supose the active link is ISP1, i need the incommig from ISP2 connections by port 5800 working.
=====================================================================
Interfaces:
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
interface GigabitEthernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip policy route-map internet
 duplex auto
 speed auto
interface GigabitEthernet0/1
 ip address 2.2.2.2  255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
interface GigabitEthernet0/2
 ip address 3.3.3.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
=============================================================
NATs:
ip nat inside source route-map ISP2 interface GigabitEthernet0/1 overload
ip nat inside source route-map ISP1 interface GigabitEthernet0/2 overload
==================================================================
Routes and IP SLA:
ip route 0.0.0.0 0.0.0.0.0 2.2.2.1 track 10
ip route 0.0.0.0 0.0.0.0.0  3.3.3.1 254
track 10 ip sla 1 reachability
ip sla 1
 icmp-echo 8.8.8.8 source-interface GigabitEthernet0/2
 threshold 5
 frequency 5
ip sla schedule 1 life forever start-time now
ip sla responder
=======================================================
Configs to ISP1:
ip access-list extended acl-ISP1
 deny   tcp any eq 5800 any
 permit ip any any
 permit icmp any any
ip access-list extended nat-ISP1
 permit ip 1.1.1.0 0.0.0.255 any
route-map internet permit 10
 match ip address acl-ISP1
 match interface GigabitEthernet0/2
 set ip next-hop 2.2.2.1
route-map ISP1 permit 10
 match ip address nat-ISP1
 match interface GigabitEthernet0/2
==============================================================
Configs to ISP2:
ip nat inside source static tcp 1.1.1.3 5800 3.3.3.2 5800 extendable
ip access-list extended nat-ISP2
 permit ip 1.1.1.0 0.0.0.255 any
ip access-list extended acl-ISP2
 permit   tcp any eq 5800 any
 deny  ip any any
route-map internet permit 20
 match ip address acl-ISP2
 match interface GigabitEthernet0/1
 set ip next-hop 3.3.3.1
route-map ISP2 permit 10
 match ip address nat-ISP2
 match interface GigabitEthernet0/1
=============================================================
EEM :
event manager applet Clear_NAT
event track 10 state any
action 0.0 cli command "enable"
action 1.0 cli command "clear ip nat translation forced *"
action 3.0 syslog msg "WAN failover, cleared NAT"

Similar Messages

  • MSI GAMING 5 - ALL USB ports not working

    hello
    how are you every one 
    i have problem with rear usb port i can use it in safe mod and bios only but it does't work when the operition system start i try to slove the problem i updated bios i have other pc and same specification and it's work without any problem but with this mother borad rear USB ports not work also the USB ports on the case ALL USB PORTS NOT WORKING
    Mouse and keyborad work in bios but if the system run don't work ! and trun off
    and all usb devices
    in safe mod work 
    rellay i don't know where is the problem !
    CPU : Intel Core i5-4690K
    M.B : MSI Z97 GAMING 5
    RAM : G.Skill Ripjaws X 8GB DDR3 Kit
    GPU : Gigabyte GeForce GTX 970 G1 GAMING
    SSD:Corsair force LX 256 GB
    HARD: Seagate Barracuda 1 T.B 7200 RPM
    CPU COOLER : Cooler Master Hyper 212 Evo
    PSU : Cooler Master GM-Series 750 watt
    CASE : NZXT Phantom 410
     Thank you

    Quote from: Nichrome on 28-January-15, 00:18:47
    Hi,
    What about if you try to install drivers from your product's page?
    http://uk.msi.com/support/mb/Z97-GAMING-5.html#down-driver
    And when exactly it starts to fail to work? Did you try to have OS just installed, restart it and see if it works then? Are you able to determine which driver installation causes USBs to stop working?
    thank you
    i just remove USB3 controller driver and work 
    thank you all :D

  • Touchsmart TX-2 fingerprint scanner and USB ports not working

    Hi everyone,
    Please forgive me if this is in the wrong spot.
    Just sent my laptop (Touchsmart TX-2 1015au) off for a warranty fix - told them the USB ports weren't working on Windows 7, 64 bit. It came back wiped, running on Vista 32 bit and.....with the USB ports not working.
    I figured I'd try to get it working because I need my laptop for uni and can't send it back right now. So I clean installed Windows 7, 64 bit again and its still not working. Did the standard open device manager and uninstall everything under the usb tab. All that has resulted in is causing the fingerprint scanner to stop working (being told that it is not connected) and still no working USB ports.
    All advice really welcome and very much appreciated!
    Thanks in advance

    Hi:
    Should be no problem to get W7 32 bit to work on that model.
    Just use all of the drivers and software from the HP Probook 450 G0 on your model except the Audio, BIOS and firmware files.
    Your model uses the Intel HD graphics driver only.
    The first driver you have to install is the Intel chipset installation utility and then reboot.
    http://h20565.www2.hp.com/portal/site/hpsc/public/psi/swdHome/?cc=us&lang=en&sp4ts.oid=5359407&ac.ad...
    Audio:  Accept the agreement.  Download and install the first driver on the list.
    http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownT...
    If for some reason, the Intel HD graphics driver from that model does not work, then use this one...
    https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23713

  • My usb port not work and hot usb port aria please help me

    my usb port not work and hot usb port aria please help me

    Hi
    Please find the link givenbelow might help you to fix your issue.
    USB Device Troubleshooting
    Fix Windows 7 “USB Device Not Recognized” Error
    Let us know how it goes!
    "I work for HP."
    ****Click the (purple thumbs up icon in the lower right corner of a post) to say thanks****
    ****Please mark Accept As Solution if it solves your problem****
    Regards
    Manjunath

  • Hp 15-D018TU USB SS PORT NOT WORKS

    Hi, In my HP 15-d018tu Notebook PC the USB SS port not works.Can anyone look into this problem and guide me.
    Thanks in Advance

    Hi:
    Did you install the applicable usb3 driver?
    http://h20564.www2.hp.com/hpsc/swd/public/detail?swItemId=ob_135422_1

  • E1200 - Ports not working and mac filtering problem

    If there was a way to give negative stars to this router, I would. As it is, the minimum rating I can give this product is one star, and that's one star too many.
    I was upgrading from the WRT54G, which is an ugly thing to look at, but a reliable workhorse nonetheless. I turned that in to a downstream switch in my comms hub.
    On the E1200, I flashed the latest firmware, used different Cat5 cables, and different laptops before committing to hating this product.
    The first time I reached out to Amazon, the Amazon rep gave me a Cisco number to call. Turns out, that's some shady mortgage refinance hotline. Try it for yourself! 1-800-666-1771.
    Now, the rant -
    1. Two out of four wired LAN ports don't work: What can be the fix for this?! The activity lights on ports 3 and 4 blink and suggest data transfer is taking place, but the wired laptop simply can't acquire an IP address and access the internet. Same result when I connect my Panasonic Blu-Ray player to ports 3 and 4. None of the Viera Cast features load.
    2. MAC filtering unreliable: The wireless routing works somewhat reliably, if and only if, one settles for the most basic security. If I only choose a password and WPA2 protocol, things work fine. If I add another layer of security (in my case, enabling MAC filtering and only PERMITTING gateway to listed MAC IDs), things break down. As soon as I disable MAC filtering, wireless access to authenticated clients is restored.
    3. Cisco customer service: The censored world we live in, compels me to criticize politely. TERRIBLE. Cisco website is unintuitive, and frustrating. There's no easy way to register your purchased product. The Cisco "registration" is intentionally misleading and deceptive. For all intents and purposes, it's just an information gathering tool for Cisco. Don't bother registering there, unless you love the idea of storing your personal information on their servers. Their phone-based customer service is apathetic and uninterested. My rep was so distrusting of my intelligence and motor control, that he simply wouldn't believe that I had selected "PERMIT" and not "PREVENT" as the option under MAC filtering. After he asked me the same question for the fourth time, I raised my voice, and he gave up the idea of checking for the fifth time.
    However, this review is a tale of two companies. I reached out to Amazon again. This time, I got a rockstar in the shape of Leanne C! She was incredibly helpful, and understanding. What's more, she set up my return without any hassle and this Cisco dud is on its way back. I'm a big fan of Leanne's and my confidence in Amazon is restored.
    I'm sure that i received a lemon. I've never had problems with Linksys products. Maybe others' experience is different from mine.

    In your case as port numbers 1 and 2 does not work, what you could have done a loop back test. To perform a loop back test you need to take an ethernet cable, connect one end of that cable to internet port and the other end to the non-working port on the router. If you get the led to glow on both internet and the respective ethernet port that indicates that the port is working fine.
    It could also be a sychronization issue between the above mentioned lan ports and the lan card of your computer. As a part of trouble shooting you can try to reduce the card speed of your lan card. Following are the steps to reduce the speed of your lan card.
    START--> right-click My Network Places and click Properties
    right-click on the device manager and click properties
    Click on the CONFIGURE button
    Select the ADVANCED tab and in the box under the header property select "speed and duplex" and change the value on the right to 10 mbps half duplex. A restart would be recommended after performing these steps.
    In the second half you said that after enabling the mac filter option the internet breaks down. Here, do you mean to say that the computer
    gets disconnected from the wireless network or it stays connected with a valid IP address but without an internet connection.
    Well, it is an unusual issue however you could have reset and reconfigure the router as you got the latest firmware upgraded on it.
    Steps to reset the router:
    Push the reset button on router for 30 seconds, turn off the router wait for 30 seconds and then power it on. Power light should blink when you perform the reset process.

  • G72-a40SA usb port not working

    Hi
    can anyone help me please?
    I have a HP G72-a40SA laptop running windows 7.
    The bios has been updated to the latest version.
    BUT, i cannot get one (out of three) usb ports to work. Its NOT being recognised by the PC.
    I have tried everything possible...... can anyone help me on this please...???
    Thanks

    It is only a piece a equipment; any part can break at any time. You may want to contact HP technical support and identify your options. These options will be based on your warranty status, and you can locate that information here: http://h20566.www2.hp.com/portal/site/hpsc/public/wc/home?ac.admitted=1383763792097.876444892.199480...
    Please call the number, closest to your region, which you can locate here: http://www8.hp.com/us/en/contact-hp/ww-contact-us.html
    Let me know if you have any further questions or concerns.
    Mario
    I worked on behalf of HP.

  • After 10.8.4 update macmini usb ports not working

    After 10.8.4 update some of macmini usb ports are not working and i receive "usb drawing to much power....." message , also when i plug off all devices from usb ports still i get same message

    Hi ErayK,
    If you are having unusual USB power error messages after an OS update, you may want to try resetting the SMC/NVRAM and see if the issue persists. You may find the following articles helpful:
    Intel-based Macs: Resetting the System Management Controller (SMC)
    http://support.apple.com/kb/ht3964
    Apple Support: About NVRAM and PRAM
    http://support.apple.com/kb/HT1379
    Regards,
    - Brenden

  • HPDV6 6c04sa - HP truevision HD camea and usb ports not working

    My camera is not working - there appear to be no drivers for it through the website for re-installing, and none in HP recovery and the copies of the original drivers loaded on the computer.  Cyerlink you cam does not install a driver.
    How am I expected to be able to re-instal a driver when there is not driver for it?
    Secondly, there is no information on the camera provided in the laptop.
    USB ports on the left hand side are not working.
    Finally - there is a mysterious Q drive which also appears not to function.
    Running Windows 7 64 bit.

    bump
    Is the HP TrueVision HD internal webcam usb based?

  • Usb ports not working after mavericks install

    After installing Mavericks on my mac pro the usb ports are not working for my printer or other usb drives. the only item i can get to be seen via usb is an apple optical mouse. any suggestions would be great.

    Hi there grnded189,
    You may find the troubleshooting steps in the article below helpful.
    OS X Mavericks: If a USB device isn’t working
    http://support.apple.com/kb/PH13876
    You may also want to reset the PRAM and SMC as well.
    OS X Mavericks: Reset your computer’s PRAM
    http://support.apple.com/kb/ph14222
    Intel-based Macs: Resetting the System Management Controller (SMC)
    http://support.apple.com/kb/ht3964
    -Griff W. 

  • Hdmi port not working on HP Pavilion g7-2240us Notebook PC

    I can't get my HDMI port on my on HP Pavilion g7-2240us Notebook PC to work... Can someone please help me? (it's windows 8)

    This is ridiculous - the number of hits that come up for "Pavilion g7 HDMI not working" is astounding; yet finding a useful answer, or anything resembling a useful answer other than a document that instructs 4-yr olds on how to locate an HDMI port, is impossible.
    HAS ANYONE FOUND A SOLUTION TO THIS?  Or is this a rampant model-wide issue that HP would rather not acknowledge?

  • HDMI Port not working on Lenovo G460 Win7-64bit

    I've been trying to solve this for some months now.
    I bought my lenovo G460 with nvidia M310 (with hdmi) this year and have not been able to get the hdmi port to work.
    I have two lcd displays one in our lab and another one at home (LG 2361V-PF) which have hdmi connections in the back.
    In the beginning I was able to get my notebook to work on the display in our office. However, now both displays (work+home) are not working.
    I have tried to reinstall latest nvidia drivers as of 2010-11-02 (ver. 8.16.11.8990) from lenovo, completely restore Operating system and tried different hdmi cables.
    I have even tried to use original drivers and also downgrade that to a lower version all with no luck.
    I have even taken my LG LCD display to the LG After Service Warranty office and have found no issues wrong with the Monitor itself.
    I am sure I have taken all the trouble-shooting methods into consideration so a simple question is...
    Is the hdmi port defective?
    I will take my laptop into the Lenovo After Care service center this week, but before then is there anyone who has had this issue and solved it?  -->or is it just a hardware problem easily fixed with warranty replacement parts.
    Thank you
    Solved!
    Go to Solution.

    ::Update:: ----------> Partially SOLVED
    Lenovo After Service Center Report:
       1. hdmi connection is fine
    They said that it could be a software problem and that they would try to update the driver.
    Partial Solution:
    Use Lenovo Original Drivers, for some reason NVIDIA newest drivers conflict with hdmi port on Lenovo G460 .
    I restored my laptop to factory condition and tested the hdmi connection and it worked for a few seconds ...
    my lcd screen started to flicker and my laptop flickers now when hdmi is connected....(A sign that hdmi is not really broken)
    Will update solution when i get it to work 100%

  • 20" Cinema display with USB and firewire ports not working

    I have a new 20" display and was wondering why my USB and fire wire ports at the back are not working. I have an external drive that is powered hooked up to the fire wire port and a no powered piano keyboard to a usb port.
    Any help please

    Verify that the display’s USB and FireWire cables are firmly plugged in to the
    computer. Do they show in your profiler?
    Try different ports in the computer.
    Verify that your computer ports are working with other known problem free device.

  • DVI port not working anymore after latest BIOS update on T410s

    Hi all,
    after installing the most recent BIOS update via ThinkVantage System Update, the DVI port in my T410s does not work anymore. Nvidia and Intel display drivers are in place, and I also checked the BIOS settings, but to no avail. It appears that the DVI port is no longer recognised by the system at all.
    Thanks and cheers!

    Do you mean the DVI port on the docking station?
    W520: i7-2720QM, Q2000M at 1080/688/1376, 21GB RAM, 500GB + 750GB HDD, FHD screen
    X61T: L7500, 3GB RAM, 500GB HDD, XGA screen, Ultrabase
    Y3P: 5Y70, 8GB RAM, 256GB SSD, QHD+ screen

  • Mountain Lion Mac Mini Server Ethernet Port Not Working

    I have a Mac Mini Server and once I upgraded to Mountain Lion Server the Ethernet port is unresponsive. It worked before upgrading. Is there something with Mountain Lion Server that is causing the Ethernet port not to work properly?

    Make a "Genius" appointment at an Apple Store.
    Back up all data on the internal drive(s) before you hand over your computer to anyone. If privacy is a concern, erase the data partition(s) with the option to write zeros* (do this only if you have at least two complete, independent backups, and you know how to restore to an empty drive from any of them.) Don’t erase the recovery partition, if present.
    Keeping your confidential data secure during hardware repair
    *An SSD doesn't need to be zeroed.

Maybe you are looking for

  • Installation problems with Windows

    Hi, I have the windows 7 beta and have been trying to reinstall it on my boot camp partition, however the installation continually reports a corrupt CD. I know that the CD is not corrupt because i have successfully installed Win7 beta on a boot camp

  • Change display size of plot area

    I have a VI that is reading signals from 16 different channels. The signals recorded from each of the 16 channels are displayed on 16 different graphs. I want to be able to see all 16 channels at the same time, in case anything interesting happens on

  • Anyone got a GOOD calibration with the Dell 2408WFP?

    From everything I've read, this monitor is tough to set up correctly, and perhaps best done w/ a Spyder 3 Elite, or other professional calibration tools... But I've just got these buttons, my pointer finger, and Apple's & SuperCal calibration program

  • Apple TV 3.0 not showing what it's able to play

    Now that I have moved to Apple TV 3.0 (And upgraded iTunes) I am no longer able to see what I used to be able to see. Before I was able to see on my Apple TV all the stuff that was ABLE to play on the Apple TV. So if I have something that wasn't enco

  • Why can't I delete music off of my iphone 5?

    I cannot for the life of me figure out how to delete music off of my phone. It has all the new updates. Normally what I do is plug my phone into my macbook and then right click and click delete under the music option. But when I right click there is